Тест на логическое мышление

Опубликовал Ирина Пятакова (Alraune) в раздел Программирование - Работа с интерфейсом

Несложный, не очень серьезный, тест из 30 вопросов. Автор теста – М. Войнаровский.

Единственный вариант логического теста на ИС (хотя он, скорее, психологический), который удалось найти, - Тест Белбина.

Предлагаемый тест не требует никаких специальных знаний, не отнимает много времени. Не стоит относиться к нему слишком серьезно.

Благодаря помощи newsky_34 добавлен второй вариант теста, где есть возможность включить подсказку правильного варианта ответа.

 

Скачать файлы

Наименование Файл Версия Размер
Тест_ЛогическоеМышление_.epf
.epf 17,76Kb
25.02.13
635
.epf 17,76Kb 635 Скачать
Тест_ЛогическоеМышление_СПодсказкой.epf
.epf 17,76Kb
25.02.13
38
.epf 17,76Kb 38 Скачать

См. также

Комментарии
1. Александр Шишкин (Шёпот теней) 1687 31.05.10 10:39 Сейчас в теме
.. уффф ... 30 вопросов ... вот ...
2. Ирина Пятакова (Alraune) 1382 31.05.10 10:42 Сейчас в теме
(1) Главное - количество правильных ответов ))
3. Юрий Тимофеев (Tatitutu) 3584 31.05.10 10:50 Сейчас в теме
:D кнопка "Получить результат" - отравь смс на номер ХХХХ чтобы получить правильный ответ. Добавь эту функцию и обработка будет золотой.
Представте себе - в любом отчете , сформировать - отправь СМС и получишь печатную форму.
ЗЫ: автор извини за флуд, так что то напомнило из сети. Спасибо.
4. Малулий (malulig) 31.05.10 16:16 Сейчас в теме
полгода назад на рамблере крутилась эта штука :D
5. Ирина Пятакова (Alraune) 1382 31.05.10 16:20 Сейчас в теме
(4) Автор самого теста указан, если кто уже переносил его в 1С, извините, я не нашла.
6. Малулий (malulig) 31.05.10 18:20 Сейчас в теме
(5) Точно, тогда плюс!
7. Андрей Григорьев (Borisych) 502 01.06.10 13:03 Сейчас в теме
8. Александр Цегельников (markers) 186 02.06.10 07:16 Сейчас в теме
22/30 Боялся что и того не наберу! :)
9. Татьяна Перемитина (yanat) 02.06.10 07:21 Сейчас в теме
25/30 еще бы знать где логика подвела.
10. Игорь (24821) 02.06.10 09:34 Сейчас в теме
Получил 28 из 30, но не понял - для чего на практике можно использовать этот тест? ;)

Если, например, я ищу программиста 1С, и заставляю возможного кандидата этот тест пройти, а он получил 20 балов из 30 - что это значит? Можно его брать на работу или нет?
Можно ли считать, что если у другого результат будет равен 25, то он однозначно лучше подходит, чем первый?
11. Ирина Пятакова (Alraune) 1382 02.06.10 09:38 Сейчас в теме
(10) Отличный результат!
На практике ценность использования подобных тестов при приеме на работу - разумеется, очень и очень условна ))
12. Николай Клементьев (Rusmus) 37 02.06.10 09:55 Сейчас в теме
30/30
ушел радовать бушек
13. Владимир Скворцов (Vovanches) 02.06.10 10:51 Сейчас в теме
Прикольно! 27/30. :) Вот вам в тему:

Не все вопросы в тесте очевидные.
1. Бывают и очевидные вопросы;
2. Очевидность вопросов в тесте непостоянна;
3. Не бывает всегда очевидных вопросов;
4. Все вопросы в тесте неочевидные.
Roman24; Alraune; +2 Ответить
14. Marine (ТвояСовесть) 8 02.06.10 10:54 Сейчас в теме
Ржака )))) Всем офисом развлекаемся ))))
Сама прошла, 28/30. Где-то малек подкачала. :D
Roman24; Alraune; +2 Ответить
15. Olga (Джиневра) 02.06.10 11:12 Сейчас в теме
По внешнему виду формы обработки делаю логический вывод, что у автора широкоформатный монитор :D
У меня 28/30. Повеселилась, спасибо.
16. Максим Симонович (mctsimco) 02.06.10 12:45 Сейчас в теме
17. Александр Иванов (newsky_34) 18 02.06.10 23:40 Сейчас в теме
а ведь и правда, "все пуфелки радуют или умом или красотой" ;)
18. Ирина Пятакова (Alraune) 1382 02.06.10 23:44 Сейчас в теме
(17) Вы не дочитали условие: "а иногда даже и тем, и другим" )))))
19. Елена (bell-ka) 03.06.10 08:42 Сейчас в теме
20. Андрей Янакаев (YAN) 1356 03.06.10 10:52 Сейчас в теме
За тест спасибо и "+"
а вот за способ реализации "-"
:)
21. Ирина Пятакова (Alraune) 1382 03.06.10 11:08 Сейчас в теме
(20) Спасибо за обе оценки ))
22. Максим Я (maxchaos) 22 03.06.10 11:33 Сейчас в теме
Словечки напомнили ассортимент в Икеа :)
28-й вопрос - самый неестественный для этого теста: вопрос про рядового Васю :)
Появилась идея создать галерею образов персонажей этого теста среди отвечающих :)
23. Алекс Климанов (fuxic) 283 04.06.10 12:20 Сейчас в теме
30/30
мило, но вот чтобы на каждый вопрос свою закладку - реализация хромает. Признаюсь иногда думал что тест вообще не даст результата а лишь шутка
24. Алекс Климанов (fuxic) 283 04.06.10 12:22 Сейчас в теме
порадовал результат

ИначеЕсли А >= 1 И А <= 2 Тогда
Roman24; Alraune; +2 Ответить
25. Ирина Пятакова (Alraune) 1382 04.06.10 12:22 Сейчас в теме
(23)(24) Спасибо. Выставлять то, что не работает, было бы уж слишком. Реализация хромает, причем на обе ноги, согласна. Это одна из первых попыток что-то сделать самостоятельно ))
26. Александр Иванов (newsky_34) 18 04.06.10 16:11 Сейчас в теме
предлагаю расширить тест процедурой, для ленивых...

Процедура ТестПриСменеСтраницы(Элемент, ТекущаяСтраница)
Если НЕ Подсказывать Тогда
Возврат;
КонецЕсли;
СтрКоличПк = 3;
НомерПервого = ТекущаяСтраница*СтрКоличПк-2;
НомерПоследнего = НомерПервого+СтрКоличПк;
Для i = НомерПервого По НомерПоследнего Цикл
ТекЭлем = ЭлементыФормы.Найти("Переключатель"+Строка(i));
Если ТекЭлем = Неопределено Тогда
Иначе
Если ТекЭлем.ВыбираемоеЗначение = 1 Тогда
Сообщить("Вопрос №"+Строка(ТекущаяСтраница)+", "+ТекЭлем.Заголовок);
Прервать;
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецПроцедуры
27. Ирина Пятакова (Alraune) 1382 04.06.10 17:21 Сейчас в теме
(26) У меня получается по-другому:
Процедура ТестПриСменеСтраницы(Элемент, ТекущаяСтраница)

Если НЕ Подсказывать Тогда
Возврат;
КонецЕсли;

ТекСтр=ЭлементыФормы.Тест.Страницы.Индекс(ТекущаяСтраница);
НомВопр=ТекСтр-1;
Для А = 3 по 5 цикл
КК = ТекСтр*3-А;
Тек = "Переключатель"+Строка(КК);
ТекЭлем = ЭлементыФормы.Найти(Тек);
Если ТекЭлем.ВыбираемоеЗначение = 1 тогда
Сообщить ("Вопрос№" + НомВопр + ": Правильный ответ: " + ТекЭлем.Заголовок);
КонецЕсли;
КонецЦикла;

КонецПроцедуры

P.S. Прикрепила второй файл с новым вариантом теста
28. Марс Айзатуллов (profimars) 04.06.10 17:49 Сейчас в теме
29. Ирина Пятакова (Alraune) 1382 04.06.10 18:21 Сейчас в теме
30. Андрей Куканов (KukA.5) 478 11.06.10 11:40 Сейчас в теме
Прошел тест - это "поднималка настроения" :), не более....
Автору плюсик за креатив и юмор.

(...и "девочек нельзя обижать")
31. Ирина Пятакова (Alraune) 1382 11.06.10 12:01 Сейчас в теме
32. Андрей Куканов (KukA.5) 478 11.06.10 21:22 Сейчас в теме
(25) Критиковать легко, выражать снобизм тоже... а помочь чем-то человеку, который ищет и поэтому обязательно найдет - это поступок. Тем более, что человек изучает и творит.

Коллеги, давайте этой замечательной девушке поможем. У каждого есть что то, что можно дать или подсказать.

Могу поделиться материалами (картинка), которые есть у меня.
И, само собой, рекомендациями, советами.
Прикрепленные файлы:
bulpi; Alraune; +2 Ответить 1
33. Ирина Пятакова (Alraune) 1382 13.06.10 23:11 Сейчас в теме
34. Елена Царёва (citicat) 112 24.01.11 21:30 Сейчас в теме
Прикольно! Надо ж отдыхать после "Объекта Плана видов Характеристик" не только за чтением Чехова или Тэффи :)
35. Ирина Пятакова (Alraune) 1382 24.01.11 21:42 Сейчас в теме
(34) Спасибо! Это точно)))
А вот сообщения на почту о комментариях к материалам перестали приходить уже давно почему-то.
36. Ийон Тихий (cool.vlad4) 41 24.01.11 22:12 Сейчас в теме
(36) Тесты, это, конечно - хорошо! За любовь к 1С тоже спасибо! Все мы любим 1С - и теперь не отрываясь от него можем делать все, что захотим и тесты щелкать. У меня тоже тесты есть - целый набор. Я не стал мучится как внедрить его в 1С - через полеhtmlдокумента/activex можно, что угодно туда зафигачить, но вот проблема тесты весят около 60 метров, что делать? а пока прикреплю демоверсию...в принципе любой желающий может туда свои тесты поместить - если они на swf или на html, в общем всем том, что поддерживает браузер
ЗЫ в демо версии только содержание тестов.
Прикрепленные файлы:
Test.epf
37. Ирина Пятакова (Alraune) 1382 24.01.11 22:24 Сейчас в теме
(36) Спасибо, завтра посмотрю, что это. А почему Вам не выставить это в собственную публикацию? Комментарии здесь, поверьте, мало кто читает, не удивлюсь, если, кроме меня, никто и не заметит.
38. Ийон Тихий (cool.vlad4) 41 24.01.11 22:32 Сейчас в теме
(37) ну потому, что там ничего особенного :D две строчки кода, а тесты не мои, где-то скачал
39. Canabis 220 (Canabis220) 65 07.09.11 22:36 Сейчас в теме
(27) "Если ТекЭлем = Неопределено Тогда" Зря от этой строки отказались. Ошибка выскакивает: {Форма.Форма.Форма(15)}: Значение не является значением объектного типа (ВыбираемоеЗначение)
Если ТекЭлем.ВыбираемоеЗначение = 1 тогда
40. Ирина Пятакова (Alraune) 1382 07.09.11 22:44 Сейчас в теме
(39) Спасибо. Возможно, в новых релизах выпадает ошибка? Раньше работало как-то. Завтра посмотрю. Единственная отмазка, что я не программист))) надо было просто этот тест сделать, чтобы хоть как-то, но работал :)
41. Владимир Полухин (pv94384) 6 24.10.11 20:20 Сейчас в теме
42. solarlion (solarlion) 08.11.11 16:06 Сейчас в теме
43. start2000 start2000 (start2000) 22 12.12.12 17:55 Сейчас в теме
На одном крупном градообразующем предприятии, одного не крупного города, менеджеры крупного звена после крупного обучения, проходили крупный тест, по результатам которого решалась их судьба в дальнейшем по крупному управлять подразделениями того крупного предприятия. Я помогал прорешивать варианты того крупного теста. Там были разные задачи и на логику тоже. Пуфелки там тоже были =) . Вам-то что, решили и посмеялись, а крупные менеджеры если не решили, то понижение на ступень или две со всеми вытекающими последствиями.
44. John Smith (PiccaHut001) 25.02.13 17:11 Сейчас в теме
куздра бежит, страшнооо...
45. bulpi bulpi (bulpi) 110 27.02.13 17:43 Сейчас в теме
2 Alraune
Если фото на аватаре реальное, то дополнительный плюс :)
46. Ирина Пятакова (Alraune) 1382 27.02.13 18:24 Сейчас в теме
Оставьте свое сообщение