gifts2017

Легкий TCP сервер

Опубликовал H A D G E H O G s (Hadgehogs) в раздел Программирование - Внешние компоненты

Легкий TCP сервер.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Архив с файлом
.zip 239,28Kb
09.03.11
142
.zip 239,28Kb 142 Скачать

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение

Комментарии

1. Ийон Тихий (cool.vlad4) 09.03.11 15:43
:D Настолько легкий, что его нет...
2. Владимир Казначеев (Mogidin) 09.03.11 15:49
3. H A D G E H O G s (Hadgehogs) 09.03.11 16:04
4. Антон (anton.fly7) 09.03.11 16:09
к 1с77 его прикрутить можно?
5. Антон (anton.fly7) 09.03.11 16:11
мне надо из 1с77 в 1с8 передать файло например
6. Serg Eli (elizarovs) 10.03.11 11:46
А написать пару слов? Я сам должен выкачать и смотреть, что Вы имели ввиду под ТСР?
7. Дмитрий Шерстобитов (DitriX) 16.03.11 13:10
elizarovs пишет:

А написать пару слов? Я сам должен выкачать и смотреть, что Вы имели ввиду под ТСР?


Присоединяюсь... Че это и зачем надо?
8. АНДРЕЙ Фамилия (MegaMouse) 17.03.11 18:07
Ау автор!!!
Обьястите в двух словах - что Вы создали и зачем???
Мне например надо чтоб в 1С можно было HTTP сервер запустить (и чтоб PHP работал) - Ваша программка это позволяет?
9. Вадим Никонов (V.Nikonov) 25.03.11 13:04
Наверное это кот в мешке. Сначали приносите домой, а потом думаете, нафига вам это надо?
И надо ли вообще?
10. uri-fl (dedkov) 27.07.11 11:16
Друзья, это не кот в мешке. В архиве есть описание dll на которой построен сервер.
Для себя нахожу эту публикацию полезной.
11. Александр Яшкин (VoDo) 04.12.12 12:08
Публикация крайне полезна. ДЛЛ рабочая, описание есть. Только возник вопрос по перекодировке в CP1251. Автор,как можно с Вами связаться ?
12. Дмитрий Воробьев (vde69) 05.07.13 08:32
полное отсутсвие описание сделано специально для увеличения скачек?
13. игорь Бельский (igori3333) 08.05.16 18:42
Всем привет.

Вопрос автору:

Пытаюсь перевести в УФ вашу обработку, с установкой и подключением разобрался. Когда дело доходит до выполнение команд dll типа ".Иденитификатор", то тонкий клиент зависает и ничего не происходит.

Вот код под 8.3.7.1776


&НаКлиенте
Перем АдресАрхиваКомпонента;
&НаКлиенте
Перем Компонент;

&НаКлиенте
Процедура ПриОткрытии(Отказ)
   // адрес, содержит строку (навигационную ссылку на двоичные данные zip архива во 
   // временном хранилище)
   АдресАрхиваКомпонента = ПолучитьАдресАрхиваВоВременномХранилище();
   УстановитьКомпонент();

КонецПроцедуры // ПриОткрытии()

&НаСервере
// методы ПодключитьВнешнююКомпоненту,УстановитьВнешнююКомпоненту, могут принимать в 
// качестве первого параметра строку в формате "навигационная ссылка" 
// (URL к внешней компоненте, упакованной в ZIP-архив, в формате, аналогичном 
// ПолучитьНавигационнуюСсылку).
Функция ПолучитьАдресАрхиваВоВременномХранилище()
   //ОбъектОбработки = РеквизитФормыВЗначение("ОбработкаОбъект");
   СсылкаНаАрхив    = ПоместитьВоВременноеХранилище(ПолучитьОбщийМакет("Макет"),
                                                   Новый УникальныйИдентификатор);
   Возврат СсылкаНаАрхив;
КонецФункции // ПолучитьАдресАрхиваВоВременномХранилище()

&НаКлиенте
// Процедура должна вызываться лишь один раз, в случае, если компонент еще не установлен 
// или нуждается в обновлении
Процедура УстановитьКомпонент()
   УстановитьВнешнююКомпоненту(АдресАрхиваКомпонента);
КонецПроцедуры // УстановитьКомпонент()


&НаКлиенте
// основная процедура инициализации комопнента
Процедура Инициализаровать()
      Сообщить( АдресАрхиваКомпонента);
      НачатьПодключениеВнешнейКомпоненты(Новый ОписаниеОповещения("ИнициализароватьЗавершение", ЭтотОбъект), "D:\1сBases\1c8\ClientDesk\DLL\TTCPServer.dll", "TTCPServer", ТипВнешнейКомпоненты.COM);	
КонецПроцедуры

&НаКлиенте
Процедура ИнициализароватьЗавершение(Подключено, ДополнительныеПараметры) Экспорт
	
Сообщить(Подключено);

КонецПроцедуры


&НаКлиенте
Процедура Декорация1Нажатие(Элемент)
      Инициализаровать();
КонецПроцедуры

&НаКлиенте
Процедура Декорация2Нажатие(Элемент)
	Попытка
	  Компонент = Новый ("AddIn.TTCPServer.TTCPServer");
	  
	  Сообщить(Компонент);
  Исключение
	  Сообщить("Нет");
	  Сообщить(ОписаниеОшибки());
  КонецПопытки;

КонецПроцедуры

&НаКлиенте
Процедура Декорация3Нажатие(Элемент)
	Попытка
		Если Не Компонент.Включено Тогда
		Компонент.Порт=36666;
		КонецЕсли;
		Если НЕ Компонент.Открыть() Тогда
			Сообщить(Компонент.ОписаниеОшибки);
		КонецЕсли;
	Исключение
	//Иначе
	//	Сообщить("Соединение открыто. Закройте и попробуйте еще раз");
	//КонецЕсли;
	Сообщить(ОписаниеОшибки());
	КонецПопытки;
КонецПроцедуры
...Показать Скрыть
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа