Прием файлов с FTP-сервера и создание их резервных копии на сервере. 1С8

15.02.20

Интеграция - Файловый обмен (TXT, XML, DBF), FTP

Как осуществить загрузку файлов с FTP-сервера на платформе 1С8.

Возникла необходимость в оперативном режиме получать сведения о платежах через ЕРИП (Единое расчетное информационное пространство). Т.к. являюсь программистом старой закалки (DOS и FoxPro), то изначально решил реализовать эту проблему с помощью BAT-ника, но XXI век и 64-разрядные Windows-ы вынуждая предостеречь «старичков» и обогатить знаниями «новичков» решил поделиться свои опытом и опубликовать простое и лаконичное решение по приему файлов с FTP-сервера.

Из кода программы будет понятно предназначение функции  FTPСоединение() и логика обмена информацией.

Все банально просто – файлы с FTP-сервера копируются во временную папку C:\TMP, а дальше по своему усмотрению можно делать с ними все что угодно. Но для подстраховки создаются резервные копии принимаемых файлов out/bak/.

Процедура ОсновныеДействияФормыЗагрузки(Кнопка)
Попытка
        
    FTPКаталогИсточник="out/";        
    КаталогПриемник = "C:\TMP\";
    
    IPCервера="10.10.10.10";
    Порт=21;
    Пользователь="user";
    Пароль="pass";
        
    Соединение = Новый FTPСоединение(IPCервера,Порт,Пользователь,Пароль, ,Ложь);
    Массив = Соединение.НайтиФайлы(FTPКаталогИсточник, "*.*");
    Если Не Массив.Количество() = 0 Тогда
        Для Каждого Стр Из Массив Цикл
            ФайлНаДиске = Новый Файл(КаталогПриемник+Стр.Имя);
            ИмяФайла = КаталогПриемник+Стр.Имя;
            Соединение.Получить(Стр.ПолноеИмя, ИмяФайла);
            Если ФайлНаДиске.Существует() Тогда // Файл принят
                Сообщить("Принят файл "+ФайлНаДиске.ПолноеИмя);
                // Перемещаем полученный файл в каталог резервных копий на FTP-сервере
                FTPФайлРезернойКопии=FTPКаталогИсточник+"bak/"+Стр.Имя;        
                Соединение.Переместить(FTPКаталогИсточник+Стр.Имя,FTPФайлРезернойКопии);
                КопияФайла = Соединение.НайтиФайлы(FTPФайлРезернойКопии);
                Если КопияФайла.Количество()=0 Тогда
                    Сообщить("Резервная копия "+FTPФайлРезернойКопии+ " не создана!!!");
                КонецЕсли;
            КонецЕсли;
        КонецЦикла;
    Иначе    
        Сообщить("Нет файлов!");
    КонецЕсли;             
Исключение
    Сообщить("Ошибка подключения FTP!!!");
КонецПопытки;        
Сообщить("--------------------------------------------------------");
КонецПроцедуры

 

загрузка FTP

См. также

SALE! 10%

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен и синхронизацию в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    138040    760    292    

404

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

45650 руб.

15.04.2019    70331    173    146    

116

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.228.x) и БП 3.0 (3.0.154.x). Правила подходят для версии ПРОФ и КОРП.

28000 руб.

15.12.2021    21752    144    40    

104

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 Бухгалтерский учет Управленческий учет Платные (руб)

Переход и перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:ERP Управление предприятием 2.5 и 1С:Комплексную автоматизацию 2.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x), ERP 2.5 (2.5.16.x), КА 2.5 (2.5.16.x) .

28000 руб.

24.06.2020    62319    51    27    

80

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Платформа 1C v8.2 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием Россия Платные (руб)

Регулярный обмен, выгрузка, перенос из КА 1.1, УПП 1.3, УТ 10.3 для обмена с любыми конфигурациями, поддерживающими обмен в формате EnterpriseData (КД3) - БП 3.0, ERP, КА 2, УТ 11, Розница 2, УНФ 1.6 и другими. Правила для старых и доработанных конфигураций не требуют синхронного обновления и совместимы с новыми и будущими конфигурациями. Обмен по расписанию, через папку, FTP, почту.

14580 руб.

18.02.2016    184477    573    509    

516

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3.87.x и УТ 11.5.16.x

28000 руб.

23.07.2020    48380    208    64    

170

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление нашей фирмой 3.0 Россия Платные (руб)

В продаже с 2018г. | Воспользовались более 41 предприятия! | Правила конвертации (КД 2) для переноса данных из БП 3 в УНФ | Переносятся все виды документов, начальные остатки и вся возможная справочная информация | Есть фильтр по организациям | Оперативно обновляем на новые релизы | Учет в БП 3 должен быть корректным, некорректные данные не переносятся | Можно бесплатно проверить на вашем сервере до покупки!

45650 руб.

10.07.2018    69123    46    126    

49

SALE! %

Перенос данных 1C Взаиморасчеты Оптовая торговля Логистика, склад и ТМЦ Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление торговлей 10 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Управленческий учет Платные (руб)

Можно проверить до покупки, оставьте заявку! Воспользовались более 268 компаний! Перенос в продаже с 2015г., и мы постоянно работаем над его развитием. Перенос данных из УТ 10.3 в УТ 11 | из УТ 10.3 в КА 2 | из УТ 10.3 в ERP. Предлагаем качественное и проверенное временем решение для перехода с УТ 10.3. Можно перенести начальные остатки, нормативно-справочную информацию и все возможные документы. При выгрузке можно установить отбор по периоду, организациям и складам. При выходе новых релизов конфигураций 1C оперативно выпускаем обновление переноса данных.

45650 27000 руб.

24.04.2015    192389    141    241    

272
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. ltfriend 968 15.02.20 17:36 Сейчас в теме
Статья для тех, кто не осилил синтаксис-помощник?
gigapevt; WellMaster; wolfsoft; t278; +4 Ответить
3. Star_SU 12 15.02.20 18:51 Сейчас в теме
(1) предостеречь «старичков» и обогатить знаниями «новичков»
2. пользователь 15.02.20 18:49
Сообщение было скрыто модератором.
...
4. Megaiff 20.02.20 23:57 Сейчас в теме
Выглядит как заплатка.
Оставьте свое сообщение