Обмен между 1С 7.7 и 1С 8 через "ЗначениеВСтрокуВнутр"

20.03.12

Интеграция - Обмен между базами 1C

Функция разбора строки, содержащей таблицу значений, полученной из 1С 7.7 методом "ЗначениеВСтрокуВнутр"

Часто приходилось встречать обмен м/у конфигурациями написанными в 1С 7.7 посредством методов "ЗначениеВСтрокуВнутр" и "ЗначениеВСтрокуВнутр". В настоящее время возникла необходимость написать обмен м/у 7.7 и 8.2. Из 7.7 выгружается таблица значений в которой находятся различного рода данные (за исключением ссылочных). Дабы не переписывать обмен полностью а только на стороне 1С 8.2 предлагаю вашему вниманию заготовку функции по разбору таблицы. Почему заготовку - потому что данная функция работает упрощенно с типами данных, без преобразования, и имеет еще некоторые недостатки которые для моей задачи не существенны. Все же надеюсь что кому то это наработка поможет.

&НаСервере
Функция ПолучитьТаблицуЗначенийИз1С77(Адрес)

   
Таблица        = Новый ТаблицаЗначений;
   
ЧтениеТХТ      = Новый ЧтениеТекста(Адрес);
   
МассивТипов    = Новый Массив;
   
ИндексСтроки   = 0;

   
//Сформируем массив начальных строк типов данных
   
МассивТипов.Добавить("{" + """"+ "S"+""""+",");
   
МассивТипов.Добавить("{" + """"+ "D"+""""+",");
   
МассивТипов.Добавить("{" + """"+ "N"+""""+",");
   
МассивТипов.Добавить("{" + """"+ "U"+""""+",");
   
МассивТипов.Добавить("{" + """"+ "B"+""""+",");

   
Строка = ЧтениеТХТ.ПрочитатьСтроку();

   
ПерваяСтрока = Истина;
    Пока
Строка <> Неопределено Цикл

       
//Первую строку отбросим
       
Если ПерваяСтрока Тогда

           
Строка       = ЧтениеТХТ.ПрочитатьСтроку();
           
ПерваяСтрока = Ложь;
            Продолжить;
        КонецЕсли;

       
//Проверим является ли данная строка типом
        //Если строка является типом то это есть строка колонки
        //Если строка Типом не является то это есть новая колонка

       
Если СтрДлина(Строка) = 1 Тогда  Строка = ЧтениеТХТ.ПрочитатьСтроку(); Продолжить; КонецЕсли;
        Если
Строка      = "}}}}" Тогда Строка = ЧтениеТХТ.ПрочитатьСтроку(); Продолжить; КонецЕсли;
        Если
Строка      = "},"   Тогда Строка = ЧтениеТХТ.ПрочитатьСтроку(); Продолжить; КонецЕсли;

       
//Это строка с названием новой колонки
       
Если МассивТипов.Найти(Лев(Строка,5)) = Неопределено Тогда
           
Колонка = СтрЗаменить(Строка, ",", Символы.ПС);
           
Колонка = СтрПолучитьСтроку(Колонка, 1);

           
//Уберем дополнительные символы
           
Колонка = Лев (Колонка, СтрДлина(Колонка) - 1);
           
Колонка = Прав(Колонка, СтрДлина(Колонка) - 2);

           
Таблица.Колонки.Добавить(Колонка);
           
ИндексСтроки = 0;
        Иначе
//Это строка со значением

           
Значение = Лев(Строка, СтрДлина(Строка)-3);
           
Значение =Прав(Значение, СтрДлина(Строка)-29);


            //Уберем доп символы кавычек из строки значения
           
Пока Лев(Значение, 1) = """" Цикл
               
Значение = Прав(Значение, СтрДлина(Значение)-1);
            КонецЦикла;

            Пока
Прав(Значение, 1) = """" Цикл
               
Значение = Лев(Значение, СтрДлина(Значение)-1);
            КонецЦикла;

           
//Добавим колонки которых нет
           
Если Таблица.Количество()< ИндексСтроки+1 Тогда
               
Таблица.Добавить();
            КонецЕсли;

           
//УстановимЗначениеСтроки
           
ИскомаяСтрока = Таблица.Получить(ИндексСтроки);
           
ИскомаяСтрока[Колонка]  =  Значение;

           
ИндексСтроки = ИндексСтроки+ 1;
        Конецесли;
       
Строка = ЧтениеТХТ.ПрочитатьСтроку();
    КонецЦикла;

    Возврат
Таблица;
КонецФункции

Использование функции:

1. На выходе из 1С 7.7 мы имеем таблицу с заранее известными колонками. Допустим есть две колонки "Расчетный счет" и "Организация". Значение строк табличной части - номер Р/С и ИНН организации

2. С помощью метода "ЗначениеВСтроку" записываем нашу таблицу в txt файл.

3.В 1С 8.2 в обработке прописываем вызов вышеописаной функции. В качестве параметра - передадим адрес текстового файла полученного в пункте 2.

4. Результатом вызова функции будет таблица аналогичная таблице записанной в текстовый файл в пункте 2.

5. Поскольку структура таблицы в 1С 7.7 нам известна - мы можем привести типы для таблицы полученной в 4. Например даты будут идти строкой типа 20120312, с помощью функции Дата() можно преобразовать ее к нужному типу.

Данная функция используется на практике при переносе платежных поручений из 1С 7.7 в 1С 8.2

См. также

SALE! 10%

Перенос данных из УПП 1.3 в ERP 2 / УТ 11 / КА 2

Обмен между базами 1C Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Обработка позволяет перенести из УПП в ERP / 1С:УТ 11 / КА 2 всю возможную информацию. Переносятся документы, а также начальные остатки и справочная информация. Типовая обработка от фирмы 1С не позволяет сохранить документы за период работы. Кроме того, наши алгоритмы выгрузки начальных остатков тоже имеют больше функционала и тщательно проверялись на реальных проектах перехода с УПП на ERP. При приобретении обработки вы будете 1 месяц получать ее обновления, далее можно приобрести подписку на обновления. Конфигурации 1С постоянно меняются, выходят новые релизы. Имея подписку на обновления, вы всегда можете быть уверены, что правила конвертации данных будут работать на ваших базах 1С.

50722 45650 руб.

04.08.2015    158149    300    266    

343

SALE! 10%

Перенос данных из ERP 2 / КА 2 / УТ 11 в БП 3.0

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос позволяет настроить собственный обмен данными между указанными программами, альтернативный предлагаемому фирмой 1С. Перенос данных осуществляется из 1С:ERP 2 / 1С:КА 2 / 1С:УТ 11 в 1С:БП 3.0. Правила обмена оперативно обновляются при выходе новых релизов программы 1С, так что вы всегда будете иметь самую актуальную версию обработки.

38500 34650 руб.

15.04.2019    67801    175    136    

107

SALE! 15%

[ED3] Обмен для ERP 2.5, КА 2.5, УТ 11.5 БП 3.0, Розница, УНФ и других с EnterpriseData (универсальный формат обмена), правила обмена

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    133614    714    291    

383

Перенос данных из УПП 1.3 в БП 3.0. Переносятся документы (обороты за период), справочная информация и остатки

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила тестировались на конфигурациях УПП 1.3 (1.3.220.x) и БП 3.0 (3.0.147.x). Правила подходят для версии ПРОФ и КОРП.

28000 руб.

15.12.2021    19605    129    38    

87

SALE! 10%

Перенос данных из ERP 2 / КА 2 в ЗУП 3

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Управленческий учет Платные (руб)

Обработка позволяет не только перенести все документы, справочную информацию и начальные остатки из ERP 2 или КА 2 в ЗУП 3, но и организовать регулярный перенос данных между программами 1С:ERP 2 / КА 2 и 1С:ЗУП 3. Вы можете выбрать период отбора данных и установить фильтр по организациям, чтобы выгружать только необходимую информацию. Более того, перенос оперативно обновляется при выходе новых релизов программы 1С, так что вы всегда будете иметь самую актуальную версию обработки.

48278 43450 руб.

03.12.2020    33789    79    57    

77

SALE! 10%

Перенос данных из УПП 1.3 / КА 1.1 в БП 3.0

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Перенос данных из УПП 1.3 в БП 3.0 (или из КА 1.1 в БП 3.0). Переносятся документы, начальные остатки и вся справочная информация. Есть фильтр по организации и множество других параметров выгрузки. Поддерживается несколько сценариев работы: как первичный полный перенос, так и перенос только новых документов. Перенос данных возможен в 1С: Бухгалтерию 3.0 версии ПРОФ, КОРП или базовую. Переход с "1С: Управление производственным предприятием 1.3" / "1С:Комплексная автоматизация 1.1" на "1С:Бухгалтерия предприятия 3.0" с помощью наших правил конвертации будет максимально комфортным!

43889 39500 руб.

25.02.2015    168007    286    240    

370

Перенос данных из УТ 10.3 в УТ 11.5. Переносятся документы (обороты за период), справочная информация и остатки

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. За основу были взяты стандартные правила переноса остатков и справочной информации. Правила тестировались на конфигурациях УТ 10.3 (10.3.87.x) и УТ 11.5 (11.5.15.x).

28000 руб.

23.07.2020    45410    193    63    

151

SALE! 10%

Перенос данных из БП 3.0 в УТ 11 / КА 2 / ERP 2

Обмен между базами 1C Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Переносятся документы за выбранный период, нормативно-справочная информация и остатки по счетам бухгалтерского учета из программы "1С:БП 3.0" в "1С:УТ 11" или "1С:КА. 2" или "1С:ERP Управление предприятием, ред. 2". Остатки переносятся по денежным средствам, взаиморасчетам, товарам (собственным и переданным на комиссию), материалам на складах и вложениям во внеоборотные активы. Есть отбор по периоду переноса документов и фильтр по организации, доступен выбор даты ввода остатков.

50722 45650 руб.

31.10.2014    230382    121    326    

294
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. NPMar 22.03.12 16:30 Сейчас в теме
Спасибо большое! Особенно за то, что не нужно копить балл для скачиания. Думаю, что мне это пригодится при переходе на восмерку, которую только буду изучать.
2. AvalonE2008 100 23.03.12 00:55 Сейчас в теме
Пожалуйста, надеюсь поможет. ОБРАТИТЕ ВНИМАНИЕ, в публикации есть опечатки. Функция для работы со строкой полученной посредство ЗначениеВСтрокуВнутр а не ЗначениеВСтроку.
3. avcherkasov 102 16.10.13 11:47 Сейчас в теме
Большое спасибо, очень пригодилось.
4. AvalonE2008 100 16.10.13 12:10 Сейчас в теме
(3)Рад что пригодилось :)
5. bes-kkm 06.02.14 18:13 Сейчас в теме
Спасибо большое!!!!!!!!!!!!!
6. user636219_dmitriy.gomzin 13.12.16 16:27 Сейчас в теме
Спасибо большое. пригодилось.
7. v.l. 434 16.07.19 20:09 Сейчас в теме
Автор, спасибо.
Прикрутил семерочные ДБФ базы как внешний источник данных, и в некоторых местах таблица значений с формы сохранялась как строка неограниченной длины (привет таблице 1SBLOB).

И надо было распарсить... Восьмерочная процеду ЗначениеИзСтрокиВнутр не понимала семерочный формат, пытался парсить, разбивать на строки, заменять литералы "0", на пустые строки, высчитывать фигурные скобки... Много мороки.

Немного преобразовал, чтобы не писать временный файл, обошелся
ЧтениеТХТ    = Новый ТекстовыйДокумент;
ЧтениеТХТ.ДобавитьСтроку(Адрес);

Соответственно чтение строки в цикле Для:
КолвоСтрок = ЧтениеТХТ.КоличествоСтрок();
Для Сч = 2 По КолвоСтрок Цикл
	Строка = ЧтениеТХТ.ПолучитьСтроку(Сч);

Еще раз спасибо!
8. alexander-bu 1 21.11.20 09:46 Сейчас в теме
Автор, спасибо.
Нашел ошибку:
В файле, полученном из 7.7, нет запятой после последнего значения в колонке:

{"Код","Код","1","0","0",{"S","0","0","0","0","0"},"","0",
{
{"S","0","0","0","0","0","8200000000"},
{"S","0","0","0","0","0","8000000000"}
}

Поэтому должно быть условие:

			//После последнего значения нет запятой, поэтому надо срезать справа 2 символа, а не 3
			Если Прав(Строка, 1) = "," Тогда
				Значение = Лев(Строка, СтрДлина(Строка)-3);
				Значение =Прав(Значение, СтрДлина(Строка)-29);
			Иначе
				Значение = Лев(Строка, СтрДлина(Строка)-2);
				Значение =Прав(Значение, СтрДлина(Строка)-28);
			КонецЕсли;	
Показать
9. babybu 28 04.02.21 12:27 Сейчас в теме
Спасибо, пригодилось!
Оставьте свое сообщение