Управление сложностью при доработке типовых конфигураций

Публикация № 1225391

Разработка - Адаптация типовых решений

Описан пример доработки типовой конфигурации 1С:ERP Управление предприятием с помощью подсистемы Модель объекта.

Со сложностью при разработке новых объектов метаданных с большим количеством зависимостей между реквизитами отлично справляется подсистема Модель объекта. Но может ли она помочь при доработке типовых объектов метаданных? На мой взгляд может. Для примера рассмотрим доработку документа "Заказ клиента" в типовой конфигурации 1С:ERP Управление предприятием версии 2.4.11.93

В этой конфигурации для зависимостью между реквизитами используется набор общих модулей, начинающихся с ОбработкаТабличнойЧасти

Для определения зависимостей между реквизитами используется понятие действия, которые описаны в общем модуле в виде процедур, а при изменении реквизита от которого зависят другие необходимо передать в общий модуль упорядоченный список действий. Например при изменении количества упаковок в строке табличной части "Товары":

	СтруктураДействий.Вставить("ПересчитатьКоличествоЕдиниц");
	СтруктураДействий.Вставить("ПересчитатьСуммуНДС", СтруктураПересчетаСуммы);
	СтруктураДействий.Вставить("ПересчитатьСуммуСНДС", СтруктураПересчетаСуммы);
	СтруктураДействий.Вставить("ПересчитатьСумму");
	СтруктураДействий.Вставить("ПересчитатьСуммуСУчетомРучнойСкидки", Новый Структура("Очищать", Ложь));
	СтруктураДействий.Вставить("ПересчитатьСуммуСУчетомАвтоматическойСкидки", Новый Структура("Очищать", Истина));
	СтруктураДействий.Вставить("ЗаполнитьДубликатыЗависимыхРеквизитов", ЗависимыеРеквизиты());

Недостатки такого подхода очевидны:

1. Список действий и порядок необходимо объявлять в каждом месте, где изменяется данный реквизит. При этом если меняется реквизит, от которого зависит количество упаковок к нему нужно добавить все действия, относящиеся к количеству упаковок. Для некоторых реквизитов это превращается в огромные списки действий, в которых кроме всего прочего нужно учитывать порядок

2. Если мы хотим добавить в табличную часть новый реквизит который зависит от количества упаковок нам нужно добавить новое действие в набор общих модулей и добавить это действие во все списки где явно или не явно меняется реквизит "Количество упаковок". И так для каждого реквизита

В качестве примера рассмотрим следующую задачу. Необходимо в заказ клиента выводить цену и стоимость закупки каждого товара. Соответственно мы добавляем в табличную часть 3 реквизита "Цена закупки", "Валюта закупки", "Стоимость закупки". Кроме того необходима возможность изменять количество в заказе клиента из новой обработки и не хочется при добавлении новых действий поставщиком типовой конфигурации вносить какие либо изменени в новую обработку

Для решения данной задачи необходимо сделать следующее:

1. Описать все зависимости реквизита "КоличествоУпаковок" в модуле модели, одновременно удаляя их из списка действий:

// Документ.ЗаказКлиента.Форма.ФормаДокумента
&НаСервере
Процедура ПриЧтенииСозданииНаСервере()
	// +МОД. Модель объекта
	глМодель_ПриЧтенииСозданииНаСервере(ЭтаФорма);
	// -МОД
	// ...
КонецПроцедуры

// +МОД. Модель объекта
&НаКлиенте
Функция Модель_ОбработатьДействия(КонтекстИзменений) Экспорт
	Возврат Модель_ОбработатьДействияСервер(КонтекстИзменений);
КонецФункции // -МОД

// +МОД. Модель объекта
&НаСервере
Функция Модель_ОбработатьДействияСервер(КонтекстИзменений)
	Возврат глМодель_ОбработатьДействия(КонтекстИзменений, ЭтаФорма);
КонецФункции // -МОД

&НаКлиенте
Процедура ТоварыКоличествоУпаковокПриИзменении(Элемент)
	// ...
	// +МОД. Модель объекта
	МОД_ОбщегоНазначенияКлиентСервер.УдалитьТиповыеОбработчикиСтроки(СтруктураДействий);
	глМодель_ПриИзмененииРеквизитовСтроки(ЭтаФорма, глМодель_ТекущиеДанные(Элемент), глМодель_ИмяРеквизита(Элемент), КэшированныеЗначения);
	// -МОД
	ОбработкаТабличнойЧастиКлиент.ОбработатьСтрокуТЧ(ТекущаяСтрока, СтруктураДействий, КэшированныеЗначения);
КонецПроцедуры

// ОбщийМодуль.ОбработкаТабличнойЧастиКлиентСервер
// +МОД. Модель объекта
Процедура МОД_ОбработатьСтрокуТЧ(ТекущаяСтрока, СтруктураДействий, КэшированныеЗначения) Экспорт
	#Если Клиент Тогда
	ОбработкаТабличнойЧастиКлиент.ОбработатьСтрокуТЧ(ТекущаяСтрока, СтруктураДействий, КэшированныеЗначения);
	#Иначе
	ОбработкаТабличнойЧастиСервер.ОбработатьСтрокуТЧ(ТекущаяСтрока, СтруктураДействий, КэшированныеЗначения);
	#КонецЕсли
КонецПроцедуры // -МОД

// ОбщийМодуль.Модель_Документ_ЗаказКлиента
Процедура ПриВыполненииОбработчиковСтроки(КонтекстИзменений, ДанныеСтроки) Экспорт
	МОД_ОбщегоНазначенияКлиентСервер.ПриВыполненииТиповыхОбработчиковСтроки(КонтекстИзменений, ДанныеСтроки);
КонецПроцедуры

// ОбщийМодуль.МОД_ОбщегоНазначенияКлиентСервер
Процедура УдалитьТиповыеОбработчикиСтроки(СтруктураДействий) Экспорт
	СтруктураДействий.Удалить("ПересчитатьКоличествоЕдиниц");
	СтруктураДействий.Удалить("ПересчитатьСуммуНДС");
	СтруктураДействий.Удалить("ПересчитатьСуммуСНДС");
	СтруктураДействий.Удалить("ПересчитатьСумму");
	СтруктураДействий.Удалить("ПересчитатьСуммуСУчетомРучнойСкидки");
	СтруктураДействий.Удалить("ПересчитатьСуммуСУчетомАвтоматическойСкидки");
КонецПроцедуры

Процедура ПриВыполненииТиповыхОбработчиковСтроки(КонтекстИзменений, ДанныеСтроки) Экспорт
	КэшированныеЗначения = глМодель_ПолучитьСвойствоКонтекста(КонтекстИзменений, "Кэш");
	Если КэшированныеЗначения = Неопределено Тогда
		КэшированныеЗначения = ОбработкаТабличнойЧастиКлиентСервер.ПолучитьСтруктуруКэшируемыеЗначения();
		глМодель_УстановитьСвойствоКонтекста(КонтекстИзменений, "Кэш", КэшированныеЗначения);
	КонецЕсли;
	
	Объект = глМодель_Данные(КонтекстИзменений);
	
	// ПересчитатьКоличествоЕдиниц
	Если глМодель_ВыполнятьОбработчикСтроки(КонтекстИзменений, ДанныеСтроки, "Количество", "КоличествоУпаковок,Упаковка", Истина) Тогда
		Если глМодель_НачатьУстановкуПараметровОбработчика(КонтекстИзменений) Тогда
			КлючКоэффициента = ОбработкаТабличнойЧастиКлиентСервер.КлючКэшаУпаковки(ДанныеСтроки.Номенклатура, ДанныеСтроки.Упаковка);
			
			Если ЗначениеЗаполнено(ДанныеСтроки.Упаковка)
				И ЗначениеЗаполнено(ДанныеСтроки.Номенклатура)
				И КэшированныеЗначения.КоэффициентыУпаковок[КлючКоэффициента] = Неопределено Тогда
				
				глМодель_УстановитьПараметрОбработчика(КонтекстИзменений, "_Сервер_", Истина);
			КонецЕсли;
		Иначе
			СтруктураДействий = Новый Структура;
			СтруктураДействий.Вставить("ПересчитатьКоличествоЕдиниц");
			
			ОбработкаТабличнойЧастиКлиентСервер.МОД_ОбработатьСтрокуТЧ(ДанныеСтроки, СтруктураДействий, КэшированныеЗначения);
		КонецЕсли;
	КонецЕсли;
	
	// ПересчитатьСуммуНДС
	Если глМодель_ВыполнятьОбработчикСтроки(КонтекстИзменений, ДанныеСтроки, "СуммаНДС", "Сумма,СтавкаНДС") Тогда
		ПараметрыДействия = ОбработкаТабличнойЧастиКлиентСервер.ПараметрыПересчетаСуммыНДСВСтрокеТЧ(глМодель_Данные(КонтекстИзменений));
		#Если Клиент Тогда
		УчетНДСУПКлиент.ПересчитатьСуммуНДСВСтрокеТЧ(ДанныеСтроки, ПараметрыДействия, КэшированныеЗначения);
		#Иначе
		УчетНДСУП.ПересчитатьСуммуНДСВСтрокеТЧ(ДанныеСтроки, ПараметрыДействия, КэшированныеЗначения);
		#КонецЕсли
	КонецЕсли;
	
	// ПересчитатьСуммуСНДС
	Если глМодель_ВыполнятьОбработчикСтроки(КонтекстИзменений, ДанныеСтроки, "СуммаСНДС", "Сумма,СуммаНДС") Тогда
		ПараметрыДействия = ОбработкаТабличнойЧастиКлиентСервер.ПараметрыПересчетаСуммыНДСВСтрокеТЧ(глМодель_Данные(КонтекстИзменений));
		
		СтруктураДействий = Новый Структура;
		СтруктураДействий.Вставить("ПересчитатьСуммуСНДС", ПараметрыДействия);
		
		ОбработкаТабличнойЧастиКлиентСервер.МОД_ОбработатьСтрокуТЧ(ДанныеСтроки, СтруктураДействий, КэшированныеЗначения);
	КонецЕсли;
	
	// ПересчитатьСумму
	// ПересчитатьСуммуСУчетомРучнойСкидки
	// ПересчитатьСуммуСУчетомАвтоматическойСкидки
	ТекстРеквизиты = "Цена,КоличествоУпаковок,СуммаАвтоматическойСкидки,ПроцентАвтоматическойСкидки,СуммаРучнойСкидки,ПроцентРучнойСкидки";
	Если глМодель_ВыполнятьОбработчикСтроки(КонтекстИзменений, ДанныеСтроки, "Сумма", ТекстРеквизиты) Тогда
		Если глМодель_РеквизитыСтрокиИзменены(КонтекстИзменений, ДанныеСтроки, ТекстРеквизиты, Истина) Тогда
			ОчищатьСуммуАвтоматическойСкидки = глМодель_РеквизитыСтрокиИзменены(КонтекстИзменений, ДанныеСтроки, "Цена,КоличествоУпаковок");
			
			СтруктураДействий = Новый Структура;
			СтруктураДействий.Вставить("ПересчитатьСумму");
			СтруктураДействий.Вставить("ПересчитатьСуммуСУчетомРучнойСкидки", Новый Структура("Очищать", Ложь));
			СтруктураДействий.Вставить("ПересчитатьСуммуСУчетомАвтоматическойСкидки", Новый Структура("Очищать", ОчищатьСуммуАвтоматическойСкидки));
			
			ОбработкаТабличнойЧастиКлиентСервер.МОД_ОбработатьСтрокуТЧ(ДанныеСтроки, СтруктураДействий, КэшированныеЗначения);
		КонецЕсли;
	КонецЕсли;
КонецПроцедуры

2. Далее мы можем, наконец, добавить обработчики для новых реквизитов и описать их зависимость в модуле модели

// Документ.ЗаказКлиента.Форма.ФормаДокумента
// +МОД. Добавление стоимости закупки
&НаКлиенте
Процедура ТоварыМОД_ЦенаЗакупкиПриИзменении(Элемент)
	глМодель_ПриИзмененииРеквизитовСтроки(ЭтаФорма, глМодель_ТекущиеДанные(Элемент), глМодель_ИмяРеквизита(Элемент), КэшированныеЗначения);
КонецПроцедуры // -МОД

// +МОД. Добавление стоимости закупки
&НаКлиенте
Процедура ТоварыМОД_ВалютаЗакупкиПриИзменении(Элемент)
	глМодель_ПриИзмененииРеквизитовСтроки(ЭтаФорма, глМодель_ТекущиеДанные(Элемент), глМодель_ИмяРеквизита(Элемент), КэшированныеЗначения);
КонецПроцедуры // -МОД

// ОбщийМодуль.Модель_Документ_ЗаказКлиента
Процедура ПриВыполненииОбработчиковСтроки(КонтекстИзменений, ДанныеСтроки) Экспорт
	Объект = глМодель_Данные(КонтекстИзменений);
	
	Если глМодель_ВыполнятьОбработчикСтроки(КонтекстИзменений, ДанныеСтроки, "МОД_СтоимостьЗакупки", "КоличествоУпаковок,МОД_ЦенаЗакупки,МОД_ВалютаЗакупки", "_Сервер_") Тогда
		#Если НЕ Клиент ИЛИ ТолстыйКлиентОбычноеПриложение Тогда
		Если ЗначениеЗаполнено(ДанныеСтроки.МОД_ВалютаЗакупки) Тогда
			СтруктураКурса = РаботаСКурсамиВалют.ПолучитьКурсВалюты(ДанныеСтроки.МОД_ВалютаЗакупки, Объект.Дата);
			СтруктураКурсаДокумента = РаботаСКурсамиВалют.ПолучитьКурсВалюты(Объект.Валюта, Объект.Дата);
			
			ДанныеСтроки.МОД_СтоимостьЗакупки = ДанныеСтроки.КоличествоУпаковок * РаботаСКурсамиВалютКлиентСервер.ПересчитатьПоКурсу(ДанныеСтроки.МОД_ЦенаЗакупки, СтруктураКурса, СтруктураКурсаДокумента);
		Иначе
			ДанныеСтроки.МОД_СтоимостьЗакупки = 0;
		КонецЕсли;
		#КонецЕсли
	КонецЕсли;
	// ...
КонецПроцедуры

Вот собственно и все.

 

Помимо того, что новая зависимость будет работать в форме, количество в документе Заказ клиента можно менять извне без перечисления всех обработчиков. Например:

ДокументОбъект = глМодель_НачатьИзменения(Ссылка)

Для Каждого СтрокаТЧ Из ДокументОбъект.Товары Цикл
	глМодель_ИзменитьРеквизитСтроки(ДокументОбъект, СтрокаТЧ, "КоличествоУпаковок", НовоеКоличество[СтрокаТЧ.НомерСтроки]);
КонецЦикла;

глМодель_ЗавершитьИзменения(ДокументОбъект)

Если поставщик добавить новые зависимости для реквизита Количество упаковок, их будет достаточно описать в процедурах МОД_ОбщегоНазначенияКлиентСервер.УдалитьТиповыеОбработчикиСтроки и МОД_ОбщегоНазначенияКлиентСервер.ПриВыполненииТиповыхОбработчиковСтроки. Остальной код останется без изменений

Специальные предложения

Оставьте свое сообщение

См. также

Модель объекта Промо

Инструментарий разработчика v8 Абонемент ($m)

Подсистема позволяет описать модель данных объекта, где описана зависимость между реквизитами, и затем использовать эту модель в разных сценариях работы с объектом. Версия платформы: 8.3.6 и выше. С небольшими доработками будет работать на 8.2.

1 стартмани

30.06.2019    11526    0    vadim1980    5    

Нюансы создания конфигураций на нескольких языках

Локализация решений v8 1cv8.cf Бесплатно (free)

Рассмотрим на примере ERP WE различные нюансы при реализации решений на нескольких языках.

25.07.2020    1096    Flashill    4    

Если ККМ Атол + 1С Розница тормозит при печати чеков по сети, или экономим на покупке ККТ и ФР

Розничная торговля Адаптация типовых решений ККМ v8 Розница УТ11 Россия Бесплатно (free)

Очень медленная работа с ККТ по Tcp/ip или Как заставить две клиентских Розницы 1С печатать чеки на одной кассе ККТ онлайн Предыстория и чем все закончилось.

01.07.2020    2020    lepihin    5    

Локализация интерфейсов конфигураций. Практика и инструментарий 1Ci

Работа с интерфейсом Локализация решений v8 Бесплатно (free)

В последнее время компания 1С International все увереннее заявляет о себе на международном рынке. Но для успешного продвижения в этом направлении необходима локализация интерфейсов конфигураций 1С. О том, как выглядит процесс перевода, какие инструменты для этого есть, где брать переводчиков и как проверять их работу, на конференции Infostart Event 2018 Education рассказал руководитель группы локализации компании 1Ci Сергей Поликарпов.

05.11.2019    4899    user1069006    1    

Исправление ошибок в типовых релизах 1С: УТ 10.3 и Розница 1.0 при отражении продаж в ЕГАИС Промо

Адаптация типовых решений v8 УТ10 Бесплатно (free)

При продаже алкогольной продукции в программах Управление торговлей и Розница возникают ошибки. В статье разберем причины ошибок и способ их решения.

05.06.2016    38341    @lexandr    21    

"Прелести" БСП. Часть 1 - Дополнительные реквизиты / сведения

Адаптация типовых решений v8 1cv8.cf Бесплатно (free)

История небольшого расследования - сломались дополнительные реквизиты, или как НЕ НАДО использовать УИД в программном коде.

04.07.2019    11443    Enigma    15    

Итеративная ошибка почтового сервиса в 1С "Комплексная автоматизация" 2.4.8

Адаптация типовых решений v8 КА2 Россия Бесплатно (free)

После обновления на релиз 2.4.8.79 возникла конфликтная ситуация на уровне генерального директора, а именно: клиенты, которым отправлялись письма из 1С, начали регулярно получать одни и те же письма, то есть что-то вроде вирусной атаки (многократная отправка одного и того же письма).

02.07.2019    3911    pas    4    

Исправление КОСГУ в проводках по денежным обязательствам (в части сумм по счету 210.Р2). БГУ 1, релиз 1.0.56.10

Практика программирования Адаптация типовых решений Разработка v8 БГУ Государственные, бюджетные структуры Россия Госбюджет Бесплатно (free)

БГУ 1 релиз 1.0.56.10: исправление КОСГУ в проводках по денежным обязательствам (в части сумм по счету 210.Р2). Запрос для модуля документа "МЗ_Покупка".

11.04.2019    3791    pavel_vrn    0    

Не открывается оборотно-сальдовая ведомость или "variable not found in subplan target lists"

Адаптация типовых решений Оборотно-сальдовая ведомость, Анализ счета Оборотно-сальдовая ведомость, Анализ счета v8 v8::БУ УПП1 БУ Бесплатно (free)

При попытке открыть Оборотно-сальдовую ведомость программа выдает ошибку "Ошибка СУБД: ERROR: variable not found in subplan target lists" и либо закрывается, либо ее нужно перезапускать. Описан частный случай решения проблемы.

02.04.2019    6225    Max777    9    

Подключение дополнительных обработок - Розница для Украины

Адаптация типовых решений v8 1cv8.cf Украина Бесплатно (free)

Внешние подключаемые обработки - замечательный механизм! Но почему же он не работает для простых пользователей?

22.03.2019    4101    kaliuzhnyi    9    

Неверный расчет СЗВ-СТАЖ. ЗУП 3.1

Адаптация типовых решений Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП3.x БУ ФОМС, ПФ, ФСС Бесплатно (free)

При заполнении отчета СЗВ-СТАЖ на последних релизах ЗУП (ошибка не исправлена и в релизе 3.1.9.107) выявлены ошибки при расчете периодов, а также неверное выделение стажа ДЛОТПУСК.

01.03.2019    7483    dbachinsky    2    

Устранение некоторых ошибок, обнаруженных в модуле Обмена с ВЕТИС (ФГИС Меркурий)

WEB Адаптация типовых решений v8 БП3.0 Сельское хозяйство и рыболовство Оптовая торговля, дистрибуция, логистика Пищевая промышленность Россия Бесплатно (free)

Устранение ошибок, обнаруженных в модуле Обмена с ВЕТИС (ФГИС Меркурий) в конфигурации Бухгалтерия предприятия, редакция 3.0 (3.0.67.67).

08.02.2019    8077    aks    3    

Исправление отрицательных остатков по организациям в УТ 11.4, КА 2.4, ЕРП 2.4. Интеркампани, механизм формирования резервов

Практика программирования Адаптация типовых решений Учет ТМЦ Учет ТМЦ v8 v8::УФ ERP2 УТ11 КА2 УУ Бесплатно (free)

Подробно рассмотрены два способа исправления отрицательных остатков по организациям без использования подсистемы Интеркампани и с использованием. Описан механизм формирования резервов на уровне процедур общего модуля. Доработки механизма и исправление ошибок.

29.01.2019    28380    ids79    35    

Пропал фокус (активность) элемента формы, ошибка при переходе на платформу 1С:Предприятие 8.3 (8.3.12.1790)

Адаптация типовых решений v8 1cv8.cf Бесплатно (free)

После перехода на платформу 8.3.12.1790 обнаружилась проблема. При подборе товара в форме подбора номенклатуры на поле ввода количество пропал фокус (активность).

09.01.2019    8105    rhtr    21    

Некорректно заполняются значения по умолчанию при создании документа. 1С: УТ

Адаптация типовых решений v8 v8::ОУ УТ11 Россия Бесплатно (free)

Столкнулся у клиента с такой проблемой: при смене банковского счета организации, 1С настойчиво подставляет в документы, при их создании, старый счет.

21.11.2018    6826    yupi71    11    

Разные хм... неожиданности при работе с УТ 11 и платформой

Практика программирования Адаптация типовых решений v8 v8::ОУ УТ11 УУ Бесплатно (free)

По мере обнаружения буду писать сюда тонкости работы с УТ 11 и платформой, больше для себя, но, может, кому-то еще пригодится... Для нескольких вопросов предложены варианты обхода.

09.08.2018    17503    Kutuzov    30    

ЗУП 3.1: долгое открытие ряда документов (больничный, отпуск, командировка), начиная с релиза 3.1.6.6 - исправление ошибки с кодом 30161250

Адаптация типовых решений Зарплата Зарплата v8 v8::СПР ЗУП3.x Россия БУ УУ Бесплатно (free)

В релизе 3.1.6.6 разработчиками была допущена ошибка, заключающаяся в написании крайне неоптимального запроса к базе данных. Конкретно на моей базе, где учет ведется всего пару месяцев, запрос выполнялся около 10 секунд, что уже напрягало. В данной публикации я укажу на расположение данного запроса и выложу текст нового запроса, опубликованного разработчиками в версии для тестирования 3.1.7.67.

21.06.2018    8947    Bene_Valete    12    

Ошибка печати чека на ККМ Атол FPrint22. ПоследующаяОплата (Кредит) вместо Электронными. Розница 2

Адаптация типовых решений ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 Розница Россия Бесплатно (free)

При печати чека на FPrint22 неожиданно выяснилось, что вместо Электронными (пробивали по платежной карте) в чеке вставало на вид оплат ПоследущаяОплата (Кредит).

22.01.2018    28167    ah7777777    15    

Ошибка "Запись не верна! Набор записей, принадлежащий менеджеру, должен содержать ровно 1 запись" в Альфа-Авто 5 и методы ее устранения

Адаптация типовых решений v8 1cv8.cf Автомобили, автосервисы Россия Бесплатно (free)

Сегодня посреди рабочего дня база отказалась впускать пользователей. При попытке запуска вываливалась ошибка "Запись не верна! Набор записей, принадлежащий менеджеру, должен содержать ровно 1 запись". При этом активные сеансы работали без проблем. Саму ошибку можно было увидеть не всегда, чаще всего она пряталась за баннером с машинками.

28.12.2017    12423    MrsMastersan    7    

Исправление ошибки типового релиза ЗУП 2.5.118.1 в регламентированном отчёте "Расчет по страховым взносам"

Зарплата Практика программирования Адаптация типовых решений Зарплата v8::СПР ЗУП2.5 Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

В ЗУП 2.5.118.1 ошибка в регламентированном отчёте "Расчет по страховым взносам" за 1 квартал 2017. Коротко об ошибке: В отчёт не попадают сотрудники, уволенные до 2017 года, а попадать они обязаны,т.к. начисления по ним очень часто встречаются, например "Сохраняемый заработок на время трудоустройства" - это как раз выплата уже после увольнения сотрудника.

21.04.2017    19256    human_new    12    

Ошибка при заполнении строки 070 раздела 1 формы 6-НДФЛ

Зарплата Практика программирования Адаптация типовых решений Зарплата v8::БУ КА1 Россия НУ НДФЛ Бесплатно (free)

Комплексная автоматизация, редакция 1.1 (1.1.82.1). Возможно, в ЗУП 2.5.114.1 присутствует также. После очередного обновления КА, бухгалтер по заработной плате пожаловался на неправильное заполнение 070 строки раздела 1 отчета 6-НДФЛ.

08.02.2017    15723    dima_home    3    

Ошибка 2-НДФЛ ЗУП (3.0.25.150) {ОбщийМодуль.ЗарплатаКадры.Модуль(5279)}: Индекс находится за границами массива

Практика программирования Адаптация типовых решений Зарплата Зарплата v8 ЗУП3.x Россия БУ НДФЛ Бесплатно (free)

Ошибка при выполнении обработчика - 'ПриЗаписи' по причине: {ОбщийМодуль.ЗарплатаКадры.Модуль(5279)}: Индекс находится за границами массива ИмяПоля = УзелФормата.ДочерниеУзлы[3].ТекстовоеСодержимое;

01.02.2017    19912    sergey512    3    

Ошибка при загрузке курсов валют. Комплексная автоматизация 2.2 (ошибка в типовой)

Практика программирования Адаптация типовых решений v8::ОУ КА2 Россия Бесплатно (free)

При вызове обработки "Загрузить курсы валют" в конфигурации "Комплексная автоматизация 2.2" рел. 2.2.2.157 программа выдавала ошибку

17.01.2017    16343    serg1c    7    

Проблемы web-клиента 1С: Предприятие. Исправляем ошибку в 1С: Договорчики 8

Практика программирования Адаптация типовых решений v8 1cv8.cf Бесплатно (free)

Описывается способ обхода ошибки, возникающей в web-клиенте при программном изменении видимости элементов формы в процессе записи и закрытия. Ошибка была выявлена в типовой конфигурации 1С: Договорчики 8, но, вполне вероятно, может встречаться и в иных ситуациях. Предложен способ обхода с использованием механизма расширений 1С: Предприятие 8.3, что позволяет не вносить изменения в типовую конфигурацию.

06.07.2016    17720    Sergey1CSpb    3    

Розница 8. Аптека, поиск номенклатуры по штрихкоду

Практика программирования Адаптация типовых решений v8 Розница Фармацевтика, аптеки Бесплатно (free)

В конфигурации Розница 8. Аптека, редакция 2.1 (2.1.9.12) возникает ситуация, когда при чтении штрихкода выводится вся номенклатура, у которой совпадает прочтенный штрихкод независимо от остатков на текущем складе рабочего места, что при недостаточном контроле со стороны кассира приводит к списанию номенклатуры с другого склада. Для избежания данной ситуации предлагается в запрос типовой конфигурации добавлять условия по складу и положительным остаткам с изменением типовой конфигурации.

30.06.2016    14164    its_33    3    

Ошибка в выгрузке из УТ 11 в БП 3.0, правила УТ-БП (11.1.10.131, 3.0.42.1, v.1-4)

Перенос данных из 1C8 в 1C8 Адаптация типовых решений v8 КД БП3.0 УТ11 Бесплатно (free)

Переливка Заказа клиента из УТ (правила УТ-БП (11.1.10.131, 3.0.42.1, v.1-4)) происходит вместе со свойствами ГлавныйБухгалтер, Руководитель.

05.11.2015    24637    oleg21592    6    

Признание отложенного налогового обязательства по налогу на прибыль

Бухгалтерский учет Адаптация типовых решений v8 УПП1 Россия БУ НУ Налог на прибыль Бесплатно (free)

В статье рассмотрена ошибка, возникающая при исчислении отложенного налогового обязательства документом «Расчеты по налогу на прибыль»

21.04.2015    21548    el-le    4    

Отказ от модальности. Баг в типовых конфигурациях

Адаптация типовых решений v8 1cv8.cf Бесплатно (free)

Не буду расписывать про сам отказ от модальности. Думаю если Вы это читаете, то уже знаете о чем речь. Дело в том, что при рефакторинге некоторых обработок я столкнулся с багом, который, как мне кажется есть почти во всех типовых конфигурациях.

25.09.2014    16058    alm_ilya    19    

После обновления Бухгалтерии предприятия 3.0 возникает ошибка "Ошибка преобразования данных XDTO:"

Адаптация типовых решений v8 БП2.0 Бесплатно (free)

После обновления Бухгалтерия предприятия 3.0 возникает ошибка: {ОбщийМодуль.СтандартныеПодсистемыКлиентПовтИсп.Модуль(56)}: Ошибка при вызове метода контекста (ПараметрыРаботыКлиентаПриЗапуске) ПараметрыКлиента = СтандартныеПодсистемыВызовСервера.ПараметрыРаботыКлиентаПриЗапуске(Параметры); по причине: Ошибка при вызове серверного метода. по причине: Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа. по причине: Ошибка преобразования данных XDTO: НачалоСвойства: {http://v8.1c.ru/8.2/managed-application/modules}cli Форма: Элемент Тип: {http://v8.1c.ru/8.1/data/core}FixedStructure Способы решения проблемы.

16.07.2014    60126    bird21    9    

Контроль уникальности счетов фактур выданных в УТ 11.0.9.8

Адаптация типовых решений Розничная торговля Розничная торговля v8 УТ10 БУ Бесплатно (free)

Работая с управленческим учетом часто приходится заниматься обменом данными с регламентированным учетом. Данная ошибка возникла по воле производителя типовой конфигурации УТ 11.0.9.8. А именно отсутствует контроль уникальности номеров документа "Счет-фактура выданный".

20.06.2014    16808    zekrus    4    

Ошибка в документе "Отражение зарплаты в управленческом учете"

Адаптация типовых решений Зарплата Бухгалтерский учет Зарплата v8 УПП1 Россия Бесплатно (free)

Имеем: типовая Управление производственным предприятием, редакция 1.3 (1.3.31.1). При заполнении неверно заполнились данные по страховым взносам.

05.04.2013    9679    pss1985    0    

Очень долгое обновление типовой БП с релиза 2.0.41.х. Простой способ лечения.

Администрирование данных 1С Адаптация типовых решений v8 БП2.0 Аудит и бухгалтерские услуги, юриспруденция Россия БУ Бесплатно (free)

При обновлении типовой бухгалтерии с релиза 2.0.41.x до предпоследнего на сей день релиза 2.0.42.6 запускается обработка «ОбновлениеИнформационнойБазы» и происходит обработка документов...и в зависимости от разного рода причин, длиться она может достаточно долго (от минут - до часов)

19.12.2012    28629    Новиков    51