Как в 1С 7.7 сделать обмен на базе FTP

12.05.20

Интеграция - Файловый обмен (TXT, XML, DBF), FTP

Выгрузка данных на FTP на примере в конфигурации Штрих-М Кассир 1.10.

Как сделать на базе 1с.77 обмен по ftp

Рассмотрим пример на базе конфигурации Штрих-М кассир 1.хх:

 

  1. Настройка FTP

Во первых для того чтобы сделать обмен по FTP, необходима компонента которая способна работать по данному протоколу, мы используем “DialMail.dll”.

В процедуре “ПриНачалеРаботыСистемы” определим следующее, каталог в который будут сохраняться файлы и отправляться на FTP сервер:

             

КаталогFTP= КаталогИБ()+"FTP";

Время когда была произведена последняя отправка  на FTP сервер:            

Константа.УдачноеВремяОтправки            = ТекущееВремя();

                Константа.РаботаПоИнтервалу_2 = 0;

Инициализация компоненты DialMail:

                Если ЗагрузитьВнешнююКомпоненту(КаталогИБ() + "DialMail.dll")=0 Тогда

                               Сообщить("Не удалось обнаружить компоненту DialMail.dll!");

                КонецЕсли;

                Попытка

                               FTP = СоздатьОбъект("AddIn.FTP");

                               FTP.ИмяЛогФайла = КаталогИБ() + "dialmail_ftp.log";

                               FTP.ВестиЛогФайл = 1;

                               FTP.ВестиТехническийЛогФайл = 1;

                               FTP.NewRFC = 0;

                               Сообщить(FTP.ВерсияОбъектаСтр);

                Исключение

                               Сообщить("Не удалось создать объект из компоненты DialMail.dll!");

                КонецПопытки;

               

 

  1. Настройка FTP

Во первых для того чтобы сделать обмен по FTP, нужно сделать настройки

Для обработки «Настройка» создадим вкладку «РаботаСFTP»

Добавим реквизиты:

- ОбменПоFTP(флаг использовать обмен по FTP или нет),

- ИмяСервераФТП(Имя сервера FTP для связи),

- ИмяПользователяФТП(Имя пользователя FTP для связи),

- ПарольПользователяФТП (Пароль пользователя FTP для связи),

- ПортФТП (Порт FTP для связи),

- ПассивныйРежимФТП (Пассивный или нет режим FTP для связи, через перечисление),

- Интервал1ФТП(Период через который будут отправляться файлы)

- Интервал2ФТП(Период через который система будет проверять связь в случае ее отстутствия).

В модуле обработки создадим процедуру “ВыборFTP”, заполнение полей вкладки из констант

Процедура ВыборFTP() 
	//Обмен данными по ФТП
	ИмяСервераФТП         = Константа.ИмяСервераФТП;
	ИмяПользователяФТП    = Константа.ИмяПользователяФТП;
	ПарольПользователяФТП = Константа.ПарольПользователяФТП; 
	ПортФТП               = Константа.ПортФТП;
	ПассивныйРежимФТП     = Константа.ПассивныйРежимФТП;
	Интервал1ФТП		  = Константа.Интервал1ФТП;
	Интервал2ФТП 		  = Константа.Интервал2ФТП; 
	ОбменПоFTP			  = Константа.ОбменПоFTP;
	Если ПортФТП < 1 Тогда
		ПортФТП = 21;
	КонецЕсли;	
КонецПроцедуры

В процедуре “ПриВыбореЗакладки” дополним следующим кодом, для отображения вкладки и заполнения параметров вкладки:

ИначеЕсли ЗначениеЗакладки=11 Тогда     
		Форма.ИспользоватьСлой("РаботаСFTP",1);
		ВыборFTP();

В конце модуля добавим код чтобы вкладка была в списке вкладок:

Форма.Закладки.ДобавитьЗначение(11,"Настройка FTP"); 

И конечно же для запоминания изменений по параметрам FTP в процедуру “Выполнить” добавим код:

Константа.ИмяСервераФТП         = СокрЛП(ИмяСервераФТП);
	Константа.ИмяПользователяФТП    = СокрЛП(ИмяПользователяФТП);
	Константа.ПарольПользователяФТП = ПарольПользователяФТП; 
	Константа.ПортФТП               = ПортФТП;
	Константа.ПассивныйРежимФТП     = ПассивныйРежимФТП;   
	Константа.Интервал1ФТП			= Интервал1ФТП;
	Константа.Интервал2ФТП			= Интервал2ФТП;  
	Константа.ОбменПоFTP			= ОбменПоFTP;

        

  1. Режим обмена FTP

Определим периодический обмен в процедуре “Таймер”, добавив код

Если (Константа.ОбменПоFTP>0) И (Константа.РаботаПоИнтервалу_2 >0) Тогда 
		Если ПрошелИнтервал1()=1 Тогда 
			Для й=1 по 3 Цикл
				FTPThreads[й] = "";
				ИДПотока[й] = 0;
				СостояниеПотока[й] = "";
			КонецЦикла;
			//Поиск не отправленных Файлов 
			ФС.УстТекКаталог(КаталогFTP);
			ИмяФайла = ФС.НайтиПервыйФайл("*.*");    
			Пока 1=1 Цикл                            
				ИмяФайла = ФС.НайтиСледующийФайл(); 
				Если ПустаяСтрока(ИмяФайла)=1 Тогда
					Прервать;
				КонецЕсли;
				Если (ИмяФайла=".") или (ИмяФайла="..") Тогда
					Продолжить;
				КонецЕсли;
				//-2-  Отправить по FTP  
				Если (ПодключитьсяКFTP()>0) Тогда
					Если ВыгрузитьНаFTP(КаталогFTP+"\"+ИмяФайла,ИмяФайла)=0 Тогда
						//включение интервала 2 
						Константа.РаботаПоИнтервалу_2 = 1;
						Прервать;
					Иначе
						Константа.УдачноеВремяОтправки	= ТекущееВремя();
						Константа.РаботаПоИнтервалу_2 = 0;	
						//Переименовать!
						ИмяКуда = СтрЗаменить(КаталогFTP+"\"+ИмяФайла,"PROD","OTPR");
						ФС.ПереименоватьФайл(КаталогFTP+"\"+ИмяФайла,ИмяКуда,1);
					КонецЕсли;
				КонецЕсли;
			КонецЦикла; 
			ОтключитьсяОтFTP(); 
			Константа.УдачноеВремяОтправки	= ТекущееВремя();
		КонецЕсли;
	КонецЕсли;

        

Первая строчка определяет, подключена ли работа с компонентой обмена по FTP и включена ли работа по интервалу 2(период проверки связи при его отсутствии), следующая функция «ПрошелИнтервал1()» возвращает 1 в случае если прошел период со времени последней удачной отправки данных на FTP, 0 в случае неудачи, код функции ниже:

Функция ПрошелИнтервал1()
	ТекВрем = ТекущееВремя();
	//проверка времени!
	Если Константа.РаботаПоИнтервалу_2>0 Тогда
		Дельта = Константа.Интервал2ФТП; 
	Иначе
		Дельта = Константа.Интервал1ФТП; 
	КонецЕсли;                           	
	ПрошВремя = Константа.УдачноеВремяОтправки;
	СекТекущие = РасчетСекундПоВремени(ТекВрем);
	СекПоследние = РасчетСекундПоВремени(ПрошВремя);

	РазницаСекунд = СекТекущие-СекПоследние;
	Если (РазницаСекунд<0) Тогда
		РазницаСекунд=-РазницаСекунд;
	КонецЕсли;
	
	Если (РазницаСекунд>=Дельта) Тогда //*60
		Возврат 1;
	КонецЕсли;
	Возврат 0;
КонецФункции	 

Далее устанавливаем каталог FTP, и смотрим есть ли не отправленные файлы, если есть, то подключаемся при помощи функции «ПодключитьсяКFTP»

Функция ПодключитьсяКFTP()
	ОтключитьсяОтFTP();
	Подключено = 0;
	FTP.ИспользоватьПрокси		= 0; 
	FTP.ВремяДоРазрыва 			= 10000; 	
	FTPПассивныйРежим=0;
	Если FTP.Подключиться( СокрЛП(Константа.ИмяСервераФТП),
						Константа.ПортФТП,
						СокрЛП(Константа.ИмяПользователяФТП),
						СокрЛП(Константа.ПарольПользователяФТП),FTPПассивныйРежим)=0 тогда
		Сообщить("Не смогли подключиться к FTP-серверу");
	Иначе
		Подключено = 1;
	КонецЕсли;
	Возврат Подключено;
КонецФункции

После удачно подключения, выгрузим файл на FTP с помощью функции «ВыгрузитьнаFTP»:

Функция ВыгрузитьНаFTP(ОтправляемыйФайл,ВыбрФайл)
		Если FTP.ОтправитьФайл(ОтправляемыйФайл,ВыбрФайл)=0 тогда
			Предупреждение("Ошибка!!! Файл не отправлен!");
			Возврат 0;
		КонецЕсли;
		Возврат 1;
		
		НомерНезанятого = СоздатьСоединениеДляПотока(); 
		ТекКаталог="/";
		Если НомерНезанятого = 0 Тогда
			Возврат 0;
		КонецЕсли;
		
		
		Если FTPThreads[НомерНезанятого].ОтправитьФайлы(ОтправляемыйФайл,               // Файл(ы), расположенный на ftp
		                                               ?(СокрЛП(ТекКаталог)="/","",СокрЛП(ТекКаталог)), // Каталог на диске, куда будет записываться файл
													   0,                       // 1 - докачка разрешена, 0 - переписываем, даже если найдем с таким же именем
													   0,                       // 1 - удаляем после удачного принятия, 0 - не удаляем
													   1,                       // 1 - посылаем команду Отключиться() после получения, 0 - оставляем сединение с FTP
													   1                        // 1 - выполняем в потоке, 0 - без потока
													   )<> -100 Тогда
			Предупреждение("Произошла непредвиденная ошибка!");
			FTPThreads[НомерНезанятого] = "";
			Возврат 0;
		КонецЕсли;
		ИДПотока[НомерНезанятого] = FTPThreads[НомерНезанятого].ИДПотока();
		СостояниеПотока[НомерНезанятого] = "ОТПРАВКА";
		Сообщить("Номер потока = "+ИДПотока[НомерНезанятого]);
		
	Возврат 1;
КонецФункции

Описание функции «СоздатьСоединениеДляПотока»:

Функция СоздатьСоединениеДляПотока()
	НомерНезанятого = 0;
	Для й = 1 по 3 Цикл		
		Если ТипЗначенияСтр(FTPThreads[й])="Строка" Тогда
			НомерНезанятого = й;
			Прервать;
		Иначе
			Если FTPThreads[й].ВПотоке()=0 Тогда
				FTPThreads[й] = "";
				НомерНезанятого = й;
				Прервать;
			КонецЕсли;
		КонецЕсли;		
	КонецЦикла;	
	Если НомерНезанятого = 0 Тогда
		Предупреждение("Все потоки заняты");
		Возврат 0;
	КонецЕсли;
	FTPThreads[НомерНезанятого] = СоздатьОбъект("AddIn.FTP");
	FTPThreads[НомерНезанятого].ИмяЛогФайла = КаталогИБ()+"dialmail_ftp"+СокрЛП(НомерНезанятого)+".log";
	FTPThreads[НомерНезанятого].ВестиЛогФайл = 1;
	FTPThreads[НомерНезанятого].ВестиТехническийЛогФайл = 1;
	
	FTPThreads[НомерНезанятого].ВремяДоРазрыва	= 100000; // Timeout
	FTPThreads[НомерНезанятого].ВремяМеждуСобытиями=1000;		FTPThreads[НомерНезанятого].ИспользоватьПрокси=0; 
	FTPПассивныйРежим = 0;
	Если FTPThreads[НомерНезанятого].Подключиться(СокрЛП(Константа.ИмяСервераФТП),
						Константа.ПортФТП,
						СокрЛП(Константа.ИмяПользователяФТП),
						СокрЛП(Константа.ПарольПользователяФТП),FTPПассивныйРежим)=0 тогда
	
		Сообщить("Не; смогли подключиться к FTP-серверу");
		Возврат 0;
	КонецЕсли;
	Возврат НомерНезанятого;
КонецФункции

Затем отключимся от FTP:

Процедура ОтключитьсяОтFTP()

                FTP.Отключиться();

КонецПроцедуры

Теперь опишем обмен файлов в рабочем режиме. Создадим процедуру, которая будет выгружать чек после каждого закрытия чека «ВыгрузитьОтчетПоЧеку»:

	Процедура ВыгрузитьОтчетПоЧеку(ТекЧек) Экспорт 
		Для й=1 по 3 Цикл
			FTPThreads[й] = "";
			ИДПотока[й] = 0;
			СостояниеПотока[й] = "";
		КонецЦикла;
		//ИмяПК.PROD.№ЧЕКА.ДАТА
		ИмяЧека = ИмяКомпьютера()+"_"+"PROD_"+"№"+НомерЧека+"_"+СтрЗаменить(Строка(ТекущаяДата()),".","_");
		ИмяТекстовогоФайла = КаталогFTP+"\"+ИмяЧека;
		////Пошел процесс формирования 
		//Информация в файле: время чека, общая сумма чека, код товара, количество товара по коду, цена
		//-1-Создали файл
		Анализатор=СоздатьОбъект("AddIn.XMLParser");
		ФайлXML=Анализатор.СоздатьДокумент();
		
		ВыгрузкаXML	= Анализатор.СоздатьДокумент();
		Шапка		= ВыгрузкаXML.СоздатьПодчиненныйЭлемент("Chek");
		
		//Дата
		ствол = Шапка.СоздатьПодчиненныйЭлемент("Data"); 
		ствол.Значение = Строка(ТекущаяДата());
		//Общая сумма                          
		ствол = Шапка.СоздатьПодчиненныйЭлемент("Summ"); 
		ствол.Значение = ТекЧек.Итог("Сумма");	
		//Перебор!                                                  
		Тело		= Шапка.СоздатьПодчиненныйЭлемент("ChekStr");
		инд=0; 
		ТекЧек.ВыбратьСтроки();
		Пока ТекЧек.ПолучитьСтроку() = 1 Цикл
			инд = инд +1;
			Состояние ("Обработано "+инд+" элементов.");
			ЗаполнитьДанныеПо__(Тело,ТекЧек);	
		КонецЦикла;
		ВыгрузкаXML.Записать(ИмяТекстовогоФайла);
		//-1-2
		Если ПрошелИнтервал1()=1 Тогда 
			//Поиск не отправленных Файлов 
			ФС.УстТекКаталог(КаталогFTP);
			ИмяФайла = ФС.НайтиПервыйФайл("*.*");    
			Пока 1=1 Цикл                            
				ИмяФайла = ФС.НайтиСледующийФайл(); 
				Если ПустаяСтрока(ИмяФайла)=1 Тогда
					Прервать;
				КонецЕсли;
				Если (ИмяФайла=".") или (ИмяФайла="..") Тогда
					Продолжить;
				КонецЕсли;
				//-2-  Отправить по FTP  
				Если ПодключитьсяКFTP()=0 Тогда
					//включение интервала 2 
					Константа.РаботаПоИнтервалу_2 = 1;
					Прервать;
				Иначе 
					Если ВыгрузитьНаFTP(КаталогFTP+"\"+ИмяФайла,ИмяФайла)=0 Тогда
						//включение интервала 2 
						Константа.РаботаПоИнтервалу_2 = 1;
						Прервать;
					Иначе
						Константа.УдачноеВремяОтправки	= ТекущееВремя();
						Константа.РаботаПоИнтервалу_2 = 0;	
						//Переименовать!
						ИмяКуда = СтрЗаменить(КаталогFTP+"\"+ИмяФайла,"PROD","OTPR");
						ФС.ПереименоватьФайл(КаталогFTP+"\"+ИмяФайла,ИмяКуда,1);
					КонецЕсли;
				КонецЕсли;
			КонецЦикла; 
			ОтключитьсяОтFTP();
		КонецЕсли;
	КонецПроцедуры

           

Процедуру «ВыгрузитьОтчетПоЧеку» можно вызвать во функции «Выгрузка отчета» при следующих параметрах:

Если Константа.СпособОбменаДанными=2 Тогда

Смещение=0,

Синхронизация=1

Данные по чеку можно получить через

Если ФормаРегистрации<>0 Тогда

_Чек = ФормаРегистрации.Чек

Функция, которая создает xml-тело файл по данным чека «ЗаполнитьДанныеПо__»:

Функция ЗаполнитьДанныеПо__(Элемент,Эл) 
	ствол = Элемент.СоздатьПодчиненныйЭлемент("stroka"); 
	//Код товара
	Code = ствол.СоздатьПодчиненныйЭлемент("Code"); 
	Code.Значение = Эл.Товар.Код;
	//Кол
	Quantity = ствол.СоздатьПодчиненныйЭлемент("Quantity"); 
	Quantity.Значение =Эл.Количество;
	//цена
	Price = ствол.СоздатьПодчиненныйЭлемент("Price"); 
	Price.Значение = Эл.Цена;
	
	Возврат Элемент;
КонецФункции

В глобальном модуле сделаем следующие переменные

Перем КаталогFTP Экспорт;

Перем FTP Экспорт;

Перем FTPThreads[3];

Перем СостояниеПотока[3];

Перем ИДПотока[3];

Система готова. 

7.7 FTP обмен данными

См. также

SALE! 10%

Перенос данных из 1С:Бухгалтерия 7.7 в БП 3.0

Файловый обмен (TXT, XML, DBF), FTP Обмен между базами 1C Платформа 1С v7.7 Платформа 1С v8.3 1С:Бухгалтерия 7.7 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Переход с 1С:Бухгалтерии 7.7 на 1С:Бухгалтерию предприятия 8, редакция 3.0, через стандартную обработку является сложным процессом, требующим определенной подготовки. Во время выполнения этого перехода возникает множество проблем и ошибок (примеры ошибок ниже), которые могут затруднить его успешное выполнение. В разработке учтены и исправлены все ошибки.

50722 45650 руб.

26.05.2020    33615    10    66    

16

Выгрузка данных из 1С 7.7. в формате EnterpriseData 1.6 (универсальный формат обмена) в конфигурации 8.3

Обмен между базами 1C Платформа 1С v7.7 Платформа 1С v8.3 1С:Торговля и склад 7.7 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Обработка позволяет выгружать данные из ТиС 7.7 в конфигурации 8.3 для сдачи отчетности, для переноса данных при переходе на 8.3, для организации обмена внутри компании при использовании разных версий 1С в структурных подразделениях или формирования отгрузочных накладных для клиентов.

6000 руб.

18.05.2020    22513    59    39    

35

Конфигурация "Информационный киоск". Обработки выгрузки товаров для ТиС 9.2, УТ 10.3, УТ 11 (обмен данными с любой конфигурацией 1С 7.7, 8.х)

Оптовая торговля Розничная торговля Обмен между базами 1C Сканер штрих-кода Платформа 1С v7.7 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv7 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Управленческий учет Платные (руб)

Конфигурация предназначена для организации offline доступа клиента (покупателя) к информации о товарах, услугах или дисконтных картах посредством сканирования штрих-кода. Основная цель – мгновенно предоставить наиболее актуальную информацию о цене, остатках, наименовании товара (услуги) или накоплениях, держателе, состоянии дисконтной карты.

1800 руб.

21.12.2014    59141    8    21    

20

Робот-загрузчик и архив документов. Распознавание/загрузка сканов документов в 1С8(7.7), архив сканированных документов.

Файловый обмен (TXT, XML, DBF), FTP Учет документов Распознавание документов и образов Платформа 1С v7.7 Платформа 1С v8.3 Платформа 1C v8.2 Конфигурации 1cv8 Конфигурации 1cv7 Россия Платные (руб)

Программный комплекс способный распознавать сотни листов за раз любых сканированных(фото) документов (УПД, ТОРГ12, СФ, паспорт и пр.) и загружать их в любую 1С (БП3.0, УТ, КА, УНФ, УПП, 1С7.7 ТиС, ЗУП3 и пр.), а также формировать архив сканированных документов.<br> Робот применяет до 5 способов распознавания. Максимальное качество загрузки документов из бесплатных OCR. Работает без Интернета.

10800 руб.

13.10.2022    7726    1    12    

8

Выгрузка УПД И УКД в формате ЭДО для Бухгалтерии 7.7 (ПУБ 7.7, УСН 7.7, ТиС 7.7, Комплексной 7.7)

Документооборот и делопроизводство (СЭД) Файловый обмен (TXT, XML, DBF), FTP ЭДО и ОФД Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 1С:Торговля и склад 7.7 1С:Упрощенное налогообложение 7.7 Россия Бухгалтерский учет Абонемент ($m)

Обмениваемся УПД (УКД) с различными контрагентами через СБИС. А чтобы загрузить УПД (УКД) из 7.7 в Сбис, используем данную обработку, которая создает файл в формате XML, который можно импортировать в систему электронного документооборота. Для конфигурации "Бухгалтерский учет" (тестировалась на релизе 7.70.663) Для конфигурации "Упрощенная система налогообложения" ( тестировалась на релизе 7.70.305) Для конфигурации "Торговля и Склад 7.7" (тестировалась на релизе 7.70.1007)

1 стартмани

31.07.2021    14562    195    AndKovalchuk    30    

15

Переход с 1С:Комплексной 7.7 на 1С:УТ 10.3

Обмен между базами 1C Платформа 1С v7.7 Платформа 1С v8.3 Платформа 1C v8.2 1С:Управление торговлей 10 1С:Комплексная 7.7 Россия Управленческий учет Платные (руб)

Начните вести учет в УТ 10.3! Перенесите все свои данные в УТ 10.3 в любом месяце года и продолжите вести учет! Программа перенесёт любое количество баз с документами и остатками в больших количествах. Обработка выгрузки выполнит проверку исходных данных и сформирует отчет о найденных ошибках в справочниках и документах. Партии переносятся с себестоимостью. Штрихкоды номенклатуры загружаются. Цена переносится. Автор консультирует.

8400 руб.

17.03.2021    15493    5    13    

6

Обмен данными ЗУП 3.1 - Бухгалтерия 7.7

Зарплата Обмен между базами 1C Бухгалтерский учет 7.7 Сложные периодические расчеты 1С:Бухгалтерия 7.7 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Платные (руб)

Как известно, Бухгалтерия 7.7 не имеет штатной возможности для обмена с ЗУП 3.1. Данная разработка пригодится тем, кто перешел с ЗиК 2.3 на ЗУП 3.1, но вынужден по каким-то своим причинам оставаться на Бухгалтерии 7.7.

18000 руб.

29.09.2020    13551    2    0    

5

Конвертация данных из 1С 8.3 в 7.7 (версия КД 2.1). Перенос данных из 8.3 в 7.7. Создание в современной 1С 8.3 XML в формате КД2. Инструкции и примеры переноса данных из любой современной 1С 8.3 в устаревшую конфигурацию 1С 7.7, через Конвертацию данных 2

Обмен между базами 1C Платформа 1С v7.7 Платформа 1С v8.3 1С:Конвертация данных Бесплатно (free)

При переходе на новую версию 1С в период параллельной эксплуатации может возникнуть необходимость обратной конвертации данных (по правилам КД версии 2.1) из 1С:Предприятие 8.3 в 1С:Предприятие 7.7 для переноса данных из 1С:Предприятие 8.3 в 7.7. Сделать это поможет следующая инструкция по КД2 о том, как создать новую конвертацию из 8.3 в 7.7, сохранить модуль и правила загрузки данных, сделать загрузку данных. КД2.

17.10.2019    13847    ksnik    0    

15
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Vortigaunt 96 12.05.20 13:14 Сейчас в теме
Компонента dialmail удачный выбор. Нужно только упомянуть, что она не умеет в русские буквы в имени каталогов на ФТП. Ну или я не умею ее готовить. У меня почему-то при попытке создания каталога с русскими буквами создается каталог с какой-то кракозяброй. До этого пользовался компонентой из поставки АгентПлюс, но она очень тормозная. Медленно передает файлы на ФТП.
3. Ignatov_mu 40 13.05.20 10:19 Сейчас в теме
(1) Я использовал только латиницу, чтобы избежать проблем с кириллицей.
2. CheBurator 3118 12.05.20 22:55 Сейчас в теме
я гонял туда-сюда используя ncftp
Ignatov_mu; +1 Ответить
4. lame 69 14.05.20 07:58 Сейчас в теме
эта компонента у меня не захотела работать на винсервер2010
5. Ignatov_mu 40 15.05.20 09:37 Сейчас в теме
(4)А как компоненту зарегистрировали?
6. lame 69 15.05.20 09:50 Сейчас в теме
стандартно -Regsvr32 под правами администратора.

там через раз идет срабатывание
обращался к разработчкиам - они сказали - что на вин2010 она стабильно не работает и предложили поменять ОС
они об этой проблеме типа знают - но решения нет
7. Ignatov_mu 40 18.05.20 18:16 Сейчас в теме
(6)Если разработчики советуют, то без вариантов.
11. Antoska 17 07.12.21 10:11 Сейчас в теме
(6) А система 32 битная или 64?
12. Ignatov_mu 40 07.12.21 20:28 Сейчас в теме
8. lvictor58 135 11.03.21 00:33 Сейчас в теме
Народ, а у кого есть описание методов работы с компонентой dialmail
интересует передача и получение файлов с FTP-ресурса не по одному, а по маске. Вроде там есть методы
ОтправитьФайлЫ() и ПолучитьФайлы() а вот как и какие параметры передавать?
9. Ignatov_mu 40 15.03.21 16:50 Сейчас в теме
(8) Описания вообще не встречал, делал согласно того что находил на просторах инета и проверял соответственно в коде.(
10. lvictor58 135 16.03.21 00:36 Сейчас в теме
Ну значит мне повезло больше. Я таки нашел на просторах инфостарта файл описания в виде синтакс-помощника. Прилагаю здесь, может кому-то пригодится.
Прикрепленные файлы:
DialMail_als.zip
Antoska; Ignatov_mu; +2 Ответить
13. pavelvaskan 19.05.22 14:43 Сейчас в теме
Скажите, пожалуйста, какова структура-содержимое файла dialmail_ftp.log ?? чтоб я мог его руками создать или кодом сгенерировать?

https://forum-1c.ru/index.php?topic=79012
14. Ignatov_mu 40 20.05.22 18:14 Сейчас в теме
15. Ignatov_mu 40 20.05.22 18:14 Сейчас в теме
Скрытый текст
16. pavelvaskan 23.05.22 10:13 Сейчас в теме
(14) Это что угодно, но не bat-файл - это набор сообщений пользователю - в лучшем случае!
17. Ignatov_mu 40 23.05.22 11:05 Сейчас в теме
(16) Это лог с клиента у которого и работает вышеописанная длл
19. pavelvaskan 23.05.22 11:36 Сейчас в теме
(17) Не понимаю! Мне лог-файл надо создавать и чем-то заполнять или система его сама сгенерирует???

ОК. Буду пробовать вариант использования dll и FTP-соединения без лог-файла пока...
20. Ignatov_mu 40 23.05.22 15:14 Сейчас в теме
(19) Я просто показал как заполняется, самого описания нет, Но по данному логу предварительно можно посмотреть как оно есть.
18. pavelvaskan 23.05.22 11:36 Сейчас в теме
21. pavelvaskan 23.05.22 15:50 Сейчас в теме
(20) Спасибо!

Пока воспользовался другой DLL...

Больше интересует ответ на вопрос сейчас:

https://forum-1c.ru/index.php?topic=79012.msg229545#msg229545
Оставьте свое сообщение