Использование ПоказатьВопрос() в событии НачалоВыбора()

20.07.20

Разработка - Механизмы типовых конфигураций

На ИТС описано, как избегать использования модальности в событиях ПередЗаписью() и ПередЗакрытием() (можно ознакомиться по ссылке http://its.1c.ru/docs/v8nonmodal/). А что делать, если нужно задать вопрос пользователю в событии НачалоВыбора(). В данной статье приведу пример реализации с использованием асинхронного вызова ПоказатьВопрос(). Статья предназначена в основном для начинающих программистов, недавно столкнувшихся с управляемыми формами.

В качестве предисловия стоит написать, что в современных типовых конфигурациях настройка "Режим использования модальности" установлена в значение "Не использовать". 

В обычных формах было допустимо использование конструкции "Ответ = Вопрос()"... При вызове этой функции окно программы блокируется (т.е. работает в модальном режиме). Следовательно в пользовательском режиме будет выдана ошибка "Использование модальных окон в данном режиме запрещено".

Какую задачу решал я: 

Перед тем, как изменить одно из ключевых полей на форме, проверялась заполненность вспомогательных таблиц. И если вспомогательная таблица не пустая, необходимо от пользователя получить согласие на её автоматическую модификацию. Это необходимо, т.к. пользователь ранее потратил время на настройку. Возможно он случайно нажал на кнопку выбора из списка у реквизита.

Для этого мне необходимо такую проверку написать в событии "НачалоВыбора". 

Почему именно здесь? Потому как в этом событии есть параметр "СтандартнаяОбработка". 

&НаКлиенте
Процедура СпособОпределенияСпискаСотрудниковНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)

Если данный параметр установить в значение Ложь, и написать Возврат, то выбор даже не начнётся. Но, к сожалению здесь использовать конструкцию ПоказатьВопрос не получится по следующим причинам:

1. Если установить параметр СтандартнаяОбработка = Ложь сразу в процедуре, то не сработает стандартный механизм выбора, который нам нужен при положительном ответе пользователя. 

2. Передать это как параметр в Оповещение тоже нельзя, т.к. назад значение не вернётся. Связано это с тем, что ПоказатьВопрос должно быть последним выполняемым действием в процедуре/функции. 

3. Возможно пользователь ничего не поменял! Тогда и смысла нет ему лишний раз показывать вопрос. Понять произошли изменения или нет можно в событиях "ПриИзменении" либо "ОбработкаВыбора".

По этим причинам пришлось выдумать более сложную схему, состоящую из следующих шагов:

1. Создаем реквизит формы с постфиксом "Исходный".

2. Запоминаем его значение до изменения в событии "НачалоВыбора":

&НаКлиенте
Процедура СпособОпределенияСпискаСотрудниковНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
	
	Если Не ТаблицаПоказателей.Количество() = 0 Тогда
		СпособОпределенияСпискаСотрудниковИсходный = Объект.СпособОпределенияСпискаСотрудников;
	КонецЕсли;
	
КонецПроцедуры

3. Обрабатываем выбор в событии "ОбработкаВыбора". Здесь мы проверяем, изменилось ли вообще значение. Может и смысла нет задавать пользователю лишний вопрос, ведь он ничего не поменял!

4. Если вспомогательная таблица пустая, то вызываем процедуру, которая является оповещением, как будто пользователь нажал на кнопку "Да". Таким образом ещё уменьшаем количество сценариев, где необходимо вмешательство пользователя.

5. Если вспомогательная таблица не пуста, и значение изменилось - задаем вопрос. 

6. В случае с обычными формами, мы бы обработали выбор в обработчике "При изменении". В данной ситуации код этого обработчика ушел в оповещение. Также в оповещение через параметр передаем СтандартнаяОбработка. Ниже по коду видно, что в одном из случаев, мы устанавливаем её в значение "Ложь". Делаем это ДО ВХОДА в оповещение.

&НаКлиенте
Процедура СпособОпределенияСпискаСотрудниковОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
	
	Если Не ТаблицаПоказателей.Количество() = 0 И Не СпособОпределенияСпискаСотрудниковИсходный = Объект.СпособОпределенияСпискаСотрудников Тогда
		СтандартнаяОбработка = Ложь;
		СтруктураПараметров = Новый Структура("ВыбранноеЗначение, СтандартнаяОбработка", ВыбранноеЗначение, СтандартнаяОбработка);
		
		Оповещение = Новый ОписаниеОповещения("СпособОпределенияСпискаСотрудниковЗавершениеВыбора", ЭтотОбъект, СтруктураПараметров);
		ПоказатьВопрос(Оповещение, "Уже выбраны показатели. Некоторые могут пропасть при изменении способа определения списка сотрудников! Продолжить?", РежимДиалогаВопрос.ДаНет);
	Иначе
		СтруктураПараметров = Новый Структура("ВыбранноеЗначение, СтандартнаяОбработка", ВыбранноеЗначение, СтандартнаяОбработка);
		
		СпособОпределенияСпискаСотрудниковЗавершениеВыбора(КодВозвратаДиалога.Да, СтруктураПараметров);
	КонецЕсли;
	
КонецПроцедуры

7. Последняя задача - обработать выбор пользователя в оповещении. Если пользователь ответил "Нет", то возвращаем исходное значение реквизита из реквизита формы. 

8. Выполняем необходимые действия при изменении:

&НаКлиенте
Процедура СпособОпределенияСпискаСотрудниковЗавершениеВыбора(Результат, ПараметрыКоманды) Экспорт
	
	Если Результат = КодВозвратаДиалога.Нет Тогда
	    Объект.СпособОпределенияСпискаСотрудников = СпособОпределенияСпискаСотрудниковИсходный;
		
		Возврат;
	ИначеЕсли Результат = КодВозвратаДиалога.Да Тогда
		Если Не ПараметрыКоманды.СтандартнаяОбработка Тогда
		    Объект.СпособОпределенияСпискаСотрудников = ПараметрыКоманды.ВыбранноеЗначение;
		КонецЕсли; 
	КонецЕсли; 

 	ЗаполнитьДостуныеИИспользуемыеДанные(Объект.ТипВыгрузки, Объект.СпособОпределенияСпискаСотрудников);
	
	УстановитьВидимость();

КонецПроцедуры // СпособОпределенияСпискаСотрудниковЗавершениеВыбора()

Обратите внимание на то, что процедура СпособОпределенияСпискаСотрудниковЗавершениеВыбора экспортная. Не забывайте для оповещений ставить Экспорт.

Таким вот замысловатым способом удалось обойти ограничения по модальности окон, и решить мою задачу. Также данный подход снизил количество сценариев, при которых пользователь видит вопрос! Это немаловажно при разработке дружественных интерфейсов. Пользователя необходимо как можно реже отрывать от заполнения формы вопросами и сообщениями.

Собственно статью данную решил написать, т.к. ни на сайте 1С, ни на Инфостарте ничего подобного не нашел по событию "НачалоВыбора". Должна быть полезна... Возможно есть другие варианты решения данной задачи. Не претендую на то, что этот единственный. Предлагаемый мною способ - один из вариантов. 

НачалоВыбора асинхронный вызов ПоказатьВопрос модальность вопрос

См. также

Механизмы типовых конфигураций Программист Платформа 1С v8.3 1С:Комплексная автоматизация 2.х Россия Бесплатно (free)

Эта ошибка была обнаружена мной в типовой конфигурации 1С:Комплексная автоматизация 2 (2.5.16.115), БСП версия 3.1.9.302. Возникает она после того, как вы добавляете в расширение бизнес-процесс или задачу, выполняете обновление идентификаторов метаданных расширений, но ошибка при записи любого элемента справочника "Профили групп доступа" всё равно остаётся.

01.07.2024    866    Vidz    0    

6

Механизмы типовых конфигураций Программист Платформа 1С v8.3 Конфигурации 1cv8 Россия Бесплатно (free)

Очень часто в написании кода требуется обращаться к предопределённым значениям. Если идёт обращение к типовым предопределённым значениям, то проблем не возникает.

24.06.2024    678    olja-ljaaa    0    

2

Механизмы типовых конфигураций Программист Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Статистическая выборка сценариев и точек изменения отчетов на общей форме ФормаОтчета в типовых конфигурациях. Примеры кода.

03.06.2024    3004    Serg2000mr    29    

100

Механизмы типовых конфигураций Ценообразование, анализ цен Программист Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 Россия Абонемент ($m)

Продолжение темы вынесения кусков повторно-используемого кода в запрос. В прошлый раз мы сделали это с вычислением пользовательских формул. Здесь замахнулись на формулы, задаваемые пользователем запросами.

1 стартмани

11.04.2024    785    tango    5    

3

Механизмы типовых конфигураций Программист Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Какому-либо элементу списка сопоставляется числовое значение, зависящее от других значений, причем эта зависимость изменяется от элемента к элементу. Так, в справочнике "Валюты" курс какой-либо валюты может быть задан формулой (или даже запросом) от значения другой валюты. А в справочнике "Виды цен" формула определяет расчет цены для товарной позиции, т.е. элементов справочника "Номенклатура", у которых в карточке указан этот вид цены. А в 1С:ERP, например, этот механизм используется в ресурсной спецификации.

10 стартмани

11.04.2024    659    tango    5    

4

Механизмы типовых конфигураций Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 Россия Бесплатно (free)

В первом сезоне мы рассмотрели (с точки зрения программиста) внутренний механизм, помещающий цены в регистр "Цены". Из этого регистра цена попадает в исходящие УПД (в продажи). Но эта цена (в прайс-листе) дифференцирована (ценообразована) в разрезах свойств самой номенклатуры. Но стратегия ценообразования, ценовая власть - это в первую очередь о работе с ценами для клиента. И тут вступает в дело второй акт марлезонского, Скидки (наценки) и кешбек.

08.04.2024    971    tango    0    

2

Ценообразование, анализ цен Механизмы типовых конфигураций Программист Бизнес-аналитик Пользователь Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 11 Россия Управленческий учет Абонемент ($m)

Ценовая власть - это способность (возможность) компании изменять в некоторых пределах отпускную цену своего товара (услуг, продукции). Чем в более широких пределах вы можете играть в цену продажи, тем больше этой власти у вас. Если вы не можете управлять отпускной ценой, то это или не ваш бизнес, или не бизнес вовсе. Здесь в рубрике "База знаний аналитика и руководителя проекта" слово проект не ограничено "проектом в 1С". Посмотрим, что для этого есть в УТ 11.5.

1 стартмани

05.04.2024    965    tango    12    

2
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Cirdan 07.08.20 13:09 Сейчас в теме
Посмотрите у поля формы свойство ПредупреждениеПриРедактировании и ОтображениеПредупрежденияПриРедактировании. С помощью них можно решить вашу задачу если правильно ее понял.
перед началом редактирования будет выведено диалоговое окно с текстом из свойтва ПредупреждениеПриРедактировании и вопросом "Продолжить редактирование?"
vlastek; Oxygraphis; Pyryrym; +3 Ответить
2. biimmap 1986 07.08.20 15:31 Сейчас в теме
(1) Это подходит если при любом выборе требуется предупреждение. В моей задаче оно нужно только в одном сценарии. Этот сценарий описан в статье. При остальных сценариях ничего быть не должно. Ну и собственно обработчика предложенный механизм не имеет.
Оставьте свое сообщение