Загрузка или обновление файла на яндекс диске через rest-api

19.09.20

Интеграция - Файловый обмен (TXT, XML, DBF), FTP

Коллеги, в данной публикации я хочу поделиться кодом, с помощью которого можно загрузить файл на яндекс диск или обновить существующий.

Для начала работы с rest-api яндекс диска из 1С необходимо зарегистрировать приложение в яндексе. Создание приложения подробно описано в статье //infostart.ru/public/853451/.

Официальная документация по загрузке файла на яндекс диск через rest-api.

 
 Программный код

 

// Процедура - Загрузить обновить файл на яндекс диске
//
// Параметры:
//  token		 - 	 Строка, токен для авторизации
//  path		 - 	 Путь, по которому следует загрузить файл. Например, /Fbar (Имя папки)/photo.png. Максимальная длина имени загружаемого файла — 255 символов; максимальная длина пути — 32760 символов. 
//	Если файл необходимо загрузить в корень диска, то следует передать только имя файла в формате /photo.png
//  overwrite	 - 	 булево, признак перезаписи файла. Учитывается, если файл загружается в папку, в которой уже есть файл с таким именем. 
//  ПутьКФайлуДляЗагрузки	 - 	 путь к файлу, который необходимо загрузить на диск 
//
Процедура ЗагрузитьОбновитьФайлНаЯндексДиске(token, path, overwrite, ПутьКФайлуДляЗагрузки)
	
	//Параметры Get запроса для получения URL {{
	path = "disk:" + СтрЗаменить(path,"/","%2F");
	overwrite = ?(overwrite, "true", "false");
	//Параметры Get запроса для получения URL }}
	
	Заголовки = Новый Соответствие;
	Заголовки.Вставить("Content-Type", "application/x-www-form-urlencoded");
	Заголовки.Вставить("Authorization","OAuth " + token);
	ЗащищенноеСоединение = Новый ЗащищенноеСоединениеOpenSSL(Неопределено, Неопределено);
	
	//Получение URL для загрузки {{
	HTTPЗапрос = Новый HTTPЗапрос("/v1/disk/resources/upload?path=" + path + "&overwrite=" + overwrite, Заголовки);
	
	Соединение = Новый HTTPСоединение("cloud-api.yandex.net",,,,,, ЗащищенноеСоединение);
	
	Результат = Соединение.Получить(HTTPЗапрос);// GET запрос для получения URL
	//Получение URL для загрузки }} 
	
	Если Результат.КодСостояния <> 200 Тогда
		
		ВызватьИсключение "Ошибка при получении URL для загрузки." + Символы.ПС + Результат.ПолучитьТелоКакСтроку();
		
	Иначе
		
		Сообщить("URL для загрузки файла получен успешно." + Символы.ПС + Результат.ПолучитьТелоКакСтроку());
		
		ЧтениеJSON = Новый ЧтениеJSON;
		ЧтениеJSON.УстановитьСтроку(Результат.ПолучитьТелоКакСтроку());
		
		СоответствиеРезультат = ПрочитатьJSON(ЧтениеJSON, Истина);
		
		СсылкаДляЗагрузки = СоответствиеРезультат.Получить("href");
		
		СсылкаДляЗагрузки = СтрЗаменить(СсылкаДляЗагрузки, "https://", "");
		
		ИмяСервера = Лев(СсылкаДляЗагрузки, СтрНайти(СсылкаДляЗагрузки, "/") -1);
		
		СсылкаДляЗагрузки = СтрЗаменить(СсылкаДляЗагрузки, ИмяСервера, "");
		
		//Загрузка файла на полученный URL {{
		HTTPЗапрос = Новый HTTPЗапрос(СсылкаДляЗагрузки, Заголовки);
		HTTPЗапрос.УстановитьТелоИзДвоичныхДанных(Новый ДвоичныеДанные(ПутьКФайлуДляЗагрузки));
		
		Соединение = Новый HTTPСоединение(ИмяСервера,,,,,, ЗащищенноеСоединение);
		
		Результат = Соединение.Записать(HTTPЗапрос);// PUT запрос		
		//Загрузка файла на полученный URL }}
		
		Если Результат.КодСостояния <> 201 Тогда
			
			ВызватьИсключение Результат.ПолучитьТелоКакСтроку();
			
		Иначе
			
			Сообщить("файл успешно загружен.");	
			
		КонецЕсли;
							
	КонецЕсли;
	
КонецПроцедуры

 

Данный программный код тестировался на версии платформы 8.3.17.1549.

См. также

SALE! 10%

[ED3] Обмен для ERP 2.5, КА 2.5, УТ 11.5 БП 3.0, Розница, УНФ и других с EnterpriseData (универсальный формат обмена), правила обмена

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    135597    729    291    

391

SALE! 10%

Перенос данных из ERP 2 / КА 2 / УТ 11 в БП 3.0. Переносятся документы, начальные остатки и справочники

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

38500 34650 руб.

15.04.2019    68884    181    139    

111

Перенос данных из УПП 1.3 в БП 3.0. Переносятся документы (обороты за период), справочная информация и остатки

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.226.x) и БП 3.0 (3.0.151.x). Правила подходят для версии ПРОФ и КОРП.

28000 руб.

15.12.2021    20638    136    38    

94

Перенос данных из УТ 10.3 в УТ 11.5. Переносятся документы (обороты за период), справочная информация и остатки

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3 (10.3.87.x) и УТ 11.5 (11.5.16.x).

28000 руб.

23.07.2020    46804    199    64    

162

SALE! 10%

Перенос данных из ERP 2 / КА 2 в ЗУП 3. Переносятся остатки, документы и справочники

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из ERP в ЗУП 3 | из КА 2 в ЗУП | Воспользовались более 79 предприятий! | Предлагаем приобрести готовые правила конвертации данных (КД 2) для переноса остатков, документов с движениями и справочной информации 3 | В продаже с 2020г. | Оперативно обновляем правила до актуальных релизов 1С | Есть перенос начальной задолженности по зарплате и начальной штатной расстановки на выбранную дату | Обороты за прошлые годы (данные для расчета среднего) переносятся свернуто в документ "Перенос данных" | Есть фильтр по организациям | Документы за текущий период переносятся сразу с движениями, поэтому не потребуется делать перерасчеты | Перенос можно проверить перед покупкой, обращайтесь!

48278 43450 руб.

03.12.2020    34464    83    58    

78

SALE! 10%

Перенос данных из БП 3.0 в УНФ 3.0 / УНФ 1.6. Переносятся остатки, документы и справочная информация

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление нашей фирмой 3.0 Россия Платные (руб)

В продаже с 2018г. | Воспользовались более 41 предприятия! | Правила конвертации (КД 2) для переноса данных из БП 3 в УНФ | Переносятся все виды документов, начальные остатки и вся возможная справочная информация | Есть фильтр по организациям | Оперативно обновляем на новые релизы | Оказываем техподдержку | В комплект файлов входит инструкция, авторская версия обработки "Универсальный обмен...", актуальные правила переноса данных и архив старых версий переноса | Учет в БП 3 должен быть корректным, некорректные данные не переносятся | Можно бесплатно проверить на вашем сервере до покупки!

50722 руб.

10.07.2018    67792    41    123    

46

Интеграция Альфа Авто 5 / Альфа Авто 6 и AUTOCRM / Инфотек

Сайты и интернет-магазины WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 1С:Управление торговлей 11 Автомобили, автосервисы Россия Управленческий учет Платные (руб)

Интеграционный модуль обмена между конфигурацией Альфа Авто 5 и Альфа Авто 6 и порталом AUTOCRM. Данный модуль универсален. Позволяет работать с несколькими обменами AUTOCRM разных брендов в одной информационной базе в ручном и автоматическом режиме.

36000 руб.

03.08.2020    15941    13    18    

13

Загрузка номенклатуры c картинками (несколько потоков одновременно) и сопутствующими данными в базу и любые документы из yml, xls, xlsx, xlsm, ods, ots, csv для УТ 10.3, УТ 11 (все), БП 3, КА 2, ERP 2, УНФ 1.6/3.0, Розница 2

Загрузка и выгрузка в Excel Логистика, склад и ТМЦ Ценообразование, анализ цен Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Платные (руб)

Эволюция не стоит на месте - новая удобная версия функциональной обработки для Вашего бизнеса! Что же Вы получаете? Удобный и интуитивно понятный интерфейс с 3-мя этапами работы. 2 режима - автоматический и ручной. Чтение XLSX, XLSM, CSV, XML/YML форматов без офиса, на любом сервере! Визуальное связывание колонок файла и реквизитов простым перетаскиванием колонок. Создание или обновление номенклатуры с иерархией, характеристик, доп. реквизитов, упаковок, загрузка практически неограниченного количества картинок на одну номенклатуру (с возможностью загрузки в несколько потоков одновременно), с хранением в томах или в базе. Загрузка номенклатуры поставщиков или поиск по их данным номенклатуры. Загрузка доп. реквизитов в характеристики. Загрузка штрихкодов с генерацией новых. Создание элементов справочников и ПВХ "на лету" для выбранных реквизитов. (Обновление от 09.04.2024, версия 9.9 - 9.10)

14400 руб.

20.11.2015    151493    367    376    

503
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. aleksxx 71 14.08.20 02:01 Сейчас в теме
Спасибо, работает отлично.
Но вот бы еще получить ссылку на скачку файла.
pavelpribytkin96; +1 Ответить
2. aleksxx 71 14.08.20 02:26 Сейчас в теме
Процедура ПолучитьСсылкуНаФайлНаЯндексДиске(token, path)
	
	//Параметры Get запроса для получения URL {{
	path = "disk:" + СтрЗаменить(path,"/","%2F");
	//Параметры Get запроса для получения URL }}
	
	Заголовки = Новый Соответствие;
	Заголовки.Вставить("Content-Type", "application/x-www-form-urlencoded");
	Заголовки.Вставить("Authorization","OAuth " + token);
	ЗащищенноеСоединение = Новый ЗащищенноеСоединениеOpenSSL(Неопределено, Неопределено);
	
	//Получение URL для загрузки {{
	HTTPЗапрос = Новый HTTPЗапрос("/v1/disk/resources/download?path=" + path + "&", Заголовки);
	
	Соединение = Новый HTTPСоединение("cloud-api.yandex.net",,,,,, ЗащищенноеСоединение);
	
	Результат = Соединение.Получить(HTTPЗапрос);// GET запрос для получения URL
	//Получение URL для загрузки }} 
	
	Если Результат.КодСостояния <> 200 Тогда
		
		ВызватьИсключение "Ошибка при получении URL для загрузки." + Символы.ПС + Результат.ПолучитьТелоКакСтроку();
		
	Иначе
		
		Сообщить("URL для загрузки файла получен успешно." + Символы.ПС + Результат.ПолучитьТелоКакСтроку());
							
	КонецЕсли;
	
КонецПроцедуры
Показать
pavelpribytkin96; jONES1979; +2 Ответить
5. pavelpribytkin96 585 14.08.20 13:51 Сейчас в теме
(3)Можно опубликовать файл (предоставить доступ по ссылке), тогда ссылка будет "нормальной".
https://yandex.ru/dev/disk/api/reference/publish-docpage/
6. pavelpribytkin96 585 14.08.20 14:46 Сейчас в теме
(3)
	
        path = "disk:" + СтрЗаменить(path,"/","%2F");
	
	Заголовки = Новый Соответствие;
	Заголовки.Вставить("Content-Type", "application/x-www-form-urlencoded");
	Заголовки.Вставить("Authorization","OAuth " + token);
	ЗащищенноеСоединение = Новый ЗащищенноеСоединениеOpenSSL(Неопределено, Неопределено);
	
	//Публикация файла {{
	HTTPЗапрос = Новый HTTPЗапрос("/v1/disk/resources/publish?path=" + path, Заголовки);
	
	Соединение = Новый HTTPСоединение("cloud-api.yandex.net",,,,,, ЗащищенноеСоединение);
	
	Результат = Соединение.Записать(HTTPЗапрос);// PUT запрос
	
	ЧтениеJSON = Новый ЧтениеJSON;
	ЧтениеJSON.УстановитьСтроку(Результат.ПолучитьТелоКакСтроку());
	
	СоответствиеРезультат = ПрочитатьJSON(ЧтениеJSON, Истина);
	
	СсылкаДляЗагрузки = СоответствиеРезультат.Получить("href");
	
	path = Прав(СсылкаДляЗагрузки, СтрДлина(СсылкаДляЗагрузки) - СтрНайти(СсылкаДляЗагрузки, "path=") - 4); //путь к опубликованному файлу
	//Публикация файла }}
	
	//Получение информации о файле {{
	HTTPЗапрос = Новый HTTPЗапрос("v1/disk/resources?path=" + path + "&fields=" + "public_url", Заголовки);
	
	Результат = Соединение.Получить(HTTPЗапрос);// GET запрос
	
	ЧтениеJSON.УстановитьСтроку(Результат.ПолучитьТелоКакСтроку());
	
	СоответствиеРезультат = ПрочитатьJSON(ЧтениеJSON, Истина);
	
	ПубличнаяСсылка = СоответствиеРезультат.Получить("public_url");
	//Получение информации о файле }}
Показать
GIZmo; jig; Tarlich; aleksxx; +4 Ответить
7. aleksxx 71 15.08.20 01:18 Сейчас в теме
(6) спасибо огромное
pavelpribytkin96; +1 Ответить
4. RustIG 1595 14.08.20 09:04 Сейчас в теме
+
пригодится, спасибо за разбор!
pavelpribytkin96; +1 Ответить
8. Angel_19 6 24.08.20 08:31 Сейчас в теме
Может кому пригодится, пример того как скачать файл с яндекс диска:

//  token		 - 	 Строка, токен для авторизации
//  path		 - 	 путь к файлу на яндекс диске
//  ПутьДляСохранения		 - 	 путь куда сохранить файл (указываем не только каталог, но и имя файла, пример: "d:\test_YD_333.txt")
Процедура СкачатьФайлСЯндексДиска(token, path, ПутьДляСохранения) Экспорт
	
	path = "disk:" + СтрЗаменить(path,"/","%2F");
	
	Заголовки = Новый Соответствие;
	Заголовки.Вставить("Content-Type", "application/x-www-form-urlencoded");
	Заголовки.Вставить("Authorization","OAuth " + token);
	ЗащищенноеСоединение = Новый ЗащищенноеСоединениеOpenSSL(Неопределено, Неопределено);
	
	//Получение URL для загрузки {{
	HTTPЗапрос = Новый HTTPЗапрос("/v1/disk/resources/download?path=" + path, Заголовки);
	
	Соединение = Новый HTTPСоединение("cloud-api.yandex.net",,,,,, ЗащищенноеСоединение);
	
	Результат = Соединение.Получить(HTTPЗапрос);// GET запрос для получения URL
	
	Если Результат.КодСостояния <> 200 Тогда
		
		ВызватьИсключение "Ошибка при получении URL для скачивания файла." + Символы.ПС + Результат.ПолучитьТелоКакСтроку();
		
	Иначе
		
		Сообщить("URL для скачивания файла получен успешно." + Символы.ПС + Результат.ПолучитьТелоКакСтроку());
		
		ЧтениеJSON = Новый ЧтениеJSON;
		ЧтениеJSON.УстановитьСтроку(Результат.ПолучитьТелоКакСтроку());
		
		СоответствиеРезультат = ПрочитатьJSON(ЧтениеJSON, Истина);
		
		СсылкаДляЗагрузки = СоответствиеРезультат.Получить("href");
		
		Сообщить("Ссылка для загрузки:"+СсылкаДляЗагрузки);
		
		ЗагрузитьФайлССервера(Заголовки, СсылкаДляЗагрузки, ПутьДляСохранения);
		
	КонецЕсли;	
	
КонецПроцедуры	

Процедура ЗагрузитьФайлССервера(Заголовки, знач СсылкаДляЗагрузки, ПутьДляСохранения)
	
	ЗащищенноеСоединение = Новый ЗащищенноеСоединениеOpenSSL(Неопределено, Неопределено);
	
	СсылкаДляЗагрузки = СтрЗаменить(СсылкаДляЗагрузки, "https://", "");
	ИмяСервера = Лев(СсылкаДляЗагрузки, Найти(СсылкаДляЗагрузки, "/") -1);
	СсылкаДляЗагрузки = СтрЗаменить(СсылкаДляЗагрузки, ИмяСервера, "");
	
	HTTPЗапрос = Новый HTTPЗапрос(СсылкаДляЗагрузки, Заголовки);
	Соединение = Новый HTTPСоединение(ИмяСервера,,,,,, ЗащищенноеСоединение);
	Результат = Соединение.Получить(HTTPЗапрос, ПутьДляСохранения);// GET запрос для получения URL
	
	Если Результат.КодСостояния = 200 Тогда 
		
		Сообщить("Файл успешно загружен с сервера.");
		
	ИначеЕсли Результат.КодСостояния >= 300 И Результат.КодСостояния <= 308 Тогда
		
		// редирект
		Сообщить("Перенаправление при загрузке файла ...");
		СсылкаДляЗагрузки = Результат.Заголовки.Получить("Location");
		ЗагрузитьФайлССервера(Заголовки, СсылкаДляЗагрузки, ПутьДляСохранения);
		
	Иначе
		
		ВызватьИсключение "Ошибка при загрузке файла." + Символы.ПС + Результат.ПолучитьТелоКакСтроку();
		
	КонецЕсли;	
	
КонецПроцедуры	
Показать
GIZmo; user1445914; nikidevel; Matveev_VS; pavelpribytkin96; RustIG; +6 Ответить
11. nikidevel 20.08.21 16:11 Сейчас в теме
Спасибо, работает , долго мучился .
9. execombat 41 18.09.20 13:38 Сейчас в теме
Спасибо. Пригодилось.

При создании HTTP запроса забыли указать переменную overwrite. В случае, если файл загружается повторно с одинаковым наименованием, то вылетает ошибка.

Исправил эту строку и всё ОК).

HTTPЗапрос = Новый HTTPЗапрос("/v1/disk/resources/upload?path=" + path + "&overwrite=" + overwrite, Заголовки);
pavelpribytkin96; +1 Ответить
10. pavelpribytkin96 585 19.09.20 20:58 Сейчас в теме
(9)Спасибо.
Поправил в публикации.
12. ZIGRAS 25.09.23 23:59 Сейчас в теме
Павел приветствую. У вас на сегодняшний день работает выгрузка файлов? Что только не делал вылетает ошибка "413 Request Entity Too Large" - "слишком большой размер файла", тестовый файл 50кб. Вашей обработкой пробовал включительно. Все работает кроме выгрузки.
13. sin_ner 16.12.23 21:53 Сейчас в теме
А как получить token ?? на Яндексе.
Оставьте свое сообщение