Расчет дней компенсации по всем видам ежегодных отпусков в документе «Увольнение из организаций» 1С:УПП

13.06.12

Задачи пользователя - Адаптация типовых решений

Как известно, в типовых решениях 1С «Зарплата и управление персоналом» и «Управление производственным предприятием» в документе «Увольнение из организаций» не предусмотрен расчет дней компенсации отпуска по всем видам ежегодных отпусков. Этот документ позволяет рассчитать остаток дней отпуска только по основному ежегодному отпуску. Поскольку некоторые сотрудники помимо ежегодного отпуска могут иметь дополнительные виды отпусков такие как «Дополнительный ежегодный отпуск», «Отпуск за ненормированный рабочий день» и т.д. то возникает необходимость при увольнении сотрудника компенсировать ему остатки всех видов отпусков.

Ниже приведен код процедуры которая позволяет рассчитывать общий остаток отпуска по всем видам ежегодных отпусков, которые имеет сотрудник.

Код процедуры приведен полностью со всеми изменениями, которые необходимо внести в типовой код. Комментарии вида: // *** ИТР … показывают изменения типового кода

// Процедура рассчитывает количество дней отпуска, которые необходимо компенсировать или удержать //
Процедура РассчитатьКоличествоДнейОтпуска(СтрокаТЧ, СведенияОСотрудниках = Неопределено) Экспорт
	
	Если Не ЗначениеЗаполнено(СтрокаТЧ.Сотрудник) ИЛИ Не ЗначениеЗаполнено(СтрокаТЧ.ДатаУвольнения) ИЛИ СтрокаТЧ.ПорядокРасчетаОтпуска.Пустая() Тогда
		Возврат;
	КонецЕсли;
	
	Запрос = Новый Запрос;
	
	Если СтрокаТЧ.ПорядокРасчетаОтпуска = Перечисления.ПорядокРасчетаОтпуска.ПоКалендарнымДням Тогда
		ВидНачисления = ПланыВидовРасчета.ДополнительныеНачисленияОрганизаций.КомпенсацияОтпускаКалендарныеДни;
	Иначе
		ВидНачисления = ПланыВидовРасчета.ДополнительныеНачисленияОрганизаций.КомпенсацияОтпускаШестидневка;
	КонецЕсли;
	
	Запрос.УстановитьПараметр("ВидНачисления",	ВидНачисления);
	
	Запрос.Текст =
	"ВЫБРАТЬ
	|	ДополнительныеНачисленияОрганизаций.ВидЕжегодногоОтпуска
	|ИЗ
	|	ПланВидовРасчета.ДополнительныеНачисленияОрганизаций КАК ДополнительныеНачисленияОрганизаций
	|ГДЕ
	|	ДополнительныеНачисленияОрганизаций.Ссылка = &ВидНачисления
	|	И ДополнительныеНачисленияОрганизаций.ВидЕжегодногоОтпуска <> ЗНАЧЕНИЕ(Справочник.ВидыЕжегодныхОтпусков.ПустаяСсылка)";
	Выборка = Запрос.Выполнить().Выбрать();
	
	Если Выборка.Следующий() Тогда
		ВидЕжегодногоОтпуска = Выборка.ВидЕжегодногоОтпуска;
	Иначе
		Возврат;
	КонецЕсли;
	
	ТаблицаПериодов = Новый ТаблицаЗначений;
	ТаблицаПериодов.Колонки.Добавить("НомерСтроки",				Новый ОписаниеТипов("Число"));
	ТаблицаПериодов.Колонки.Добавить("Сотрудник",				Новый ОписаниеТипов("СправочникСсылка.СотрудникиОрганизаций"));
	ТаблицаПериодов.Колонки.Добавить("ВидЕжегодногоОтпуска",		Новый ОписаниеТипов("СправочникСсылка.ВидыЕжегодныхОтпусков"));
	ТаблицаПериодов.Колонки.Добавить("ДатаНачала",				Новый ОписаниеТипов("Дата"));
	ТаблицаПериодов.Колонки.Добавить("ДатаОкончания",				Новый ОписаниеТипов("Дата"));
	ТаблицаПериодов.Колонки.Добавить("ДатаРасчетаПриУвольнении",	Новый ОписаниеТипов("Дата"));
	
	ДлинаСуток = 86400;
 Строка = ТаблицаПериодов.Добавить();
	Строка.НомерСтроки = 1;
	Строка.Сотрудник = СтрокаТЧ.Сотрудник;
	Строка.ВидЕжегодногоОтпуска = ВидЕжегодногоОтпуска;
	Строка.ДатаНачала = СтрокаТЧ.ДатаУвольнения + ДлинаСуток;
	Строка.ДатаОкончания = СтрокаТЧ.ДатаУвольнения + ДлинаСуток;
	Строка.ДатаРасчетаПриУвольнении = СтрокаТЧ.ДатаУвольнения;
	
	// *** ИТР Добавляем для компенсации все оставщиеся отпуска из справочника виды ежегодных отпусков
	ТекНомерСтроки = 1;
	ВыборкаВидыЕжегодныхОтпусков = Справочники.ВидыЕжегодныхОтпусков.Выбрать();
	Пока ВыборкаВидыЕжегодныхОтпусков.Следующий() Цикл
		//Пропускам ранее добавленный отпуск
		Если ВыборкаВидыЕжегодныхОтпусков.Ссылка = ВидЕжегодногоОтпуска Тогда Продолжить КонецЕсли;
		
		ТекНомерСтроки = ТекНомерСтроки + 1;
		
		Строка = ТаблицаПериодов.Добавить();
		Строка.НомерСтроки = ТекНомерСтроки;
		Строка.Сотрудник = СтрокаТЧ.Сотрудник;
		Строка.ВидЕжегодногоОтпуска = ВыборкаВидыЕжегодныхОтпусков.Ссылка;
		Строка.ДатаНачала = СтрокаТЧ.ДатаУвольнения + ДлинаСуток;
		Строка.ДатаОкончания = СтрокаТЧ.ДатаУвольнения + ДлинаСуток;
		Строка.ДатаРасчетаПриУвольнении = СтрокаТЧ.ДатаУвольнения;
	КонецЦикла;
	// *** ИТР Добавляем дополнительный ежегодный отпуск для компенсации
	
	ВыборкаПоОтпускам = ПроцедурыУправленияПерсоналом.ПодготовитьДанныеПоРегламентированнымОтпускам(ТаблицаПериодов, Ссылка);
	
	// *** ИТР Суммируем полученные остатки отпусков
	ОстатокРасчитан = Ложь;
	СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска = 0;
	Пока ВыборкаПоОтпускам.Следующий() Цикл
		Если ВыборкаПоОтпускам.ВидЕжегодногоОтпуска = ВидЕжегодногоОтпуска Тогда
			СтрокаТЧ.РабочийГодС = ВыборкаПоОтпускам.ДатаНачалаРабочегоГода;
			СтрокаТЧ.РабочийГодПо = СтрокаТЧ.ДатаУвольнения;
			СтрокаТЧ.ПризнакКомпенсацииОтпуска = ВыборкаПоОтпускам.Количество >= 0;
		КонецЕсли;
		
		СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска = СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска + ВыборкаПоОтпускам.Количество;  // * ?(ВыборкаПоОтпускам.Количество >= 0, 1, -1)
		
		ОстатокРасчитан = Истина;
	КонецЦикла;
	СтрокаТЧ.ПризнакКомпенсацииОтпуска = ?(СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска >= 0, Истина, Ложь);
	СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска = СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска * ?(СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска >= 0, 1, -1); 
	
	//Если нету что компенсировать
	Если Не ОстатокРасчитан Тогда
		СтрокаТЧ.РабочийГодС = Дата(1,1,1);
		СтрокаТЧ.РабочийГодПо = Дата(1,1,1);
		СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска = 0;
		СтрокаТЧ.ПризнакКомпенсацииОтпуска = Ложь;
	КонецЕсли;
	// *** ИТР Суммируем полученные остатки отпусков
	
	// *** ИТР Не используем типовой расчет остатка отпуска 
 //Если ВыборкаПоОтпускам.Следующий() Тогда 
 // СтрокаТЧ.РабочийГодС = ВыборкаПоОтпускам.ДатаНачалаРабочегоГода; 
 // СтрокаТЧ.РабочийГодПо = СтрокаТЧ.ДатаУвольнения; 
 // СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска = ВыборкаПоОтпускам.Количество * ?(ВыборкаПоОтпускам.Количество >= 0, 1, -1); 
 // СтрокаТЧ.ПризнакКомпенсацииОтпуска = ВыборкаПоОтпускам.Количество >= 0; 
 // УвольнениеИзОрганизацийПереопределяемый.ДополнительноУточнитьДниКомпенсации(СтрокаТЧ, ПолучитьСведенияОСотрудниках(СведенияОСотрудниках, СтрокаТЧ.Сотрудник)); 
 //Иначе 
 // СтрокаТЧ.РабочийГодС = Дата(1,1,1); 
 // СтрокаТЧ.РабочийГодПо = Дата(1,1,1); 
 // СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска = 0; 
 // СтрокаТЧ.ПризнакКомпенсацииОтпуска = Ложь; //КонецЕсли; 
 // *** ИТР Не используем типовой расчет остатка отпуска
	
	Если мОкруглятьДниОтпускаПриКомпенсации = Неопределено Тогда
		мОкруглятьДниОтпускаПриКомпенсации = Константы.ОкруглятьДниОтпускаПриКомпенсации.Получить();
	КонецЕсли;
	Если мОкруглятьДниОтпускаПриКомпенсации Тогда
		СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска = Цел(СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска) +
			?(Цел(СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска) = СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска, 0, 1);
	КонецЕсли;
	
КонецПроцедуры

См. также

Табличная часть в доп. реквизитах и формирование таблиц в шаблоне docx для 1С:ДО 3.0

Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Россия Платные (руб)

Расширение конфигурации для «1С:Документооборот КОРП», редакция 3.0. позволяет: 1.использовать произвольные табличные части в качестве дополнительных реквизитов к документу; 2 использовать произвольные табличные части в шаблонах в формате docx для автоматического заполнения таблиц.

29400 руб.

29.06.2023    4900    10    5    

19

Расширение для 1С:УНФ. Автоматическое снятие резервов в Заказах покупателей

Логистика, склад и ТМЦ Адаптация типовых решений Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Чтобы не допустить путаницы с обещаниями клиентам и для четкого контроля исполнения заказов мы используем резервирование товаров. Мы доработали УНФ, чтобы она автоматически отменяла старые резервы и не мешала эффективно продавать.

7200 руб.

02.08.2023    3268    6    0    

23

Каждому менеджеру нужен свой Excel

Адаптация типовых решений Программист Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Абонемент ($m)

Каждый из нас сталкивается с ситуацией, когда какой-нибудь менеджер показывает свой Excel и рассказывает, как он что-то из 1С копирует в него, снабжает пояснениями, выделяет цветом и т.д. и т.п. Заканчивается все просьбой сделать вот чтобы также было в 1С. И оказывается такой человек (почти с гарантией) либо лучшим продажником, либо каким-то важным, за все отвечающим, - на ком все держится.

2 стартмани

22.04.2024    4425    dimanich70    15    

18

Создать на основании - своя кнопка (БСП). Проблема двух подменю Создать на основании

БСП (Библиотека стандартных подсистем) Адаптация типовых решений Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 Бесплатно (free)

Понадобилось в подменю "Создать на основании" добавить свою команду, которая открывает обработку. В процессе доработок появилась проблема двух подменю "Создать на основании". В статье о том, как решились проблемы.

01.03.2024    2554    dimanich70    8    

15

Доработка отчета "Связанные документы" (структура подчиненности) для вывода объектов из любого расширения

Адаптация типовых решений Программист Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Доработка типового отчета "Связанные документы" позволяет просто и быстро расширять состав объектов для построения структуры подчиненности документов, используя объекты основной конфигурации и любых расширений.

1 стартмани

27.10.2023    2320    19    avmartynov    14    

44

Печать непроведенных документов для УТ, КА, ERP. Настройка печати по пользователям, документам и печатным формам

Пакетная печать Печатные формы Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Расширение для программ 1С:Управление торговлей, 1С:Комплексная автоматизация, 1С:ERP, которое позволяет распечатывать печатные формы для непроведенных документов. Можно настроить, каким пользователям, какие конкретные формы документов разрешено печатать без проведения документа.

2 стартмани

22.08.2023    2525    35    progmaster    8    

4
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Zero_nv 128 14.06.12 04:41 Сейчас в теме
Самое обидное, что данный функционал должен быть типовым
2. Zero_nv 128 21.06.12 08:28 Сейчас в теме
Теперь, начиная с 2.5.52.2 этот фукционал стал типовым
3. dimetra2008 65 21.06.12 09:42 Сейчас в теме
Интересно как этот функционал станет типовым в УПП...
4. IamNataly 25.06.12 06:41 Сейчас в теме
5. snik-2 18.07.12 04:31 Сейчас в теме
В действительности в релизе 2.5.52.3 процедура была полность изменена, но доп. отпуск по прежнему при увольнении не учитывается.
6. snik-2 18.07.12 07:57 Сейчас в теме
Хорошо есть еще добрые люди, подсказали как устранить проблему.
Прилагаю текст процедуры, может кому пригодится.


Процедура РассчитатьКоличествоДнейОтпуска(СтрокаТЧ, СведенияОСотрудниках = Неопределено) Экспорт

Если Не ЗначениеЗаполнено(СтрокаТЧ.Сотрудник) ИЛИ Не ЗначениеЗаполнено(СтрокаТЧ.ДатаУвольнения) ИЛИ СтрокаТЧ.ПорядокРасчетаОтпуска.Пустая() Тогда
Возврат;
КонецЕсли;
//убираем эти параметры из отбора: ,Истина, СтрокаТЧ.ПорядокРасчетаОтпуска
Результат = ОстаткиОтпусков.ОстатокОтпускаСотрудникаНаДату(СтрокаТЧ.Сотрудник, СтрокаТЧ.ДатаУвольнения); // ,Истина, СтрокаТЧ.ПорядокРасчетаОтпуска);

СтрокаТЧ.РабочийГодС = Результат.РабочийГодС;
СтрокаТЧ.РабочийГодПо = Результат.РабочийГодПо;
СтрокаТЧ.ДнейЧасовКомпенсацииУдержанияОтпуска = Результат.ОстатокНаДату * ?(Результат.ОстатокНаДату >= 0, 1, -1);
СтрокаТЧ.ПризнакКомпенсацииОтпуска = Результат.ОстатокНаДату >= 0;

УвольнениеИзОрганизацийПереопределяемый.ДополнительноУточнитьДниКомпенсации(СтрокаТЧ, ПолучитьСведенияОСотрудниках(СведенияОСотрудниках, СтрокаТЧ.Сотрудник));

КонецПроцедуры
spas163; b-dm; +2 Ответить
7. Эсти 8 16.03.15 08:00 Сейчас в теме
Оставьте свое сообщение