Опрос пользователя в цикле с оповещением (управляемые формы)

01.06.22

Задачи пользователя - Адаптация типовых решений

Пример вопроса пользователю по каждой строке при обходе таблицы значений в цикле с помощью оповещения.

В новых и последних конфигурациях нежелательно использовать модальные окна, но требуется в цикле опрашивать пользователя. Как решить такую задачу и не использовать модальные окна?  Решил поделиться примером обхода таблицы значения и опроса пользователя по оповещению (управляемые формы).

Задача:

1. Проверить в заказе покупателя доступность необходимого количества.

2. По каждой строке товара, у которого недостаточно на остатке, предложить пользователю оприходовать или разукомплектовать комплект.

Решение: Сделать опрос пользователя в процедуре оповещения.

// Кнопка проверки остатков
&НаКлиенте
Процедура РасшАВ_ПроверитьОстаткиПосле(Команда)	
	
	ТаблицаСОстатками.Очистить();
	РасшАВ_ПроверитьОстаткиПослеНаСервере(); // Заполнение таблицы с остатками
	Если не ТаблицаСОстатками.Количество() = 0 Тогда 
		ПараметрыОбхода = Новый Структура;
		ПараметрыОбхода.Вставить("НомерСтроки", -1);
		ПараметрыОбхода.Вставить("Комплектация",Ложь);
		ПараметрыОбхода.Вставить("Оприходование",Ложь);
		РаботаСОтрицательнымиОстатками(КодВозвратаДиалога.Нет,ПараметрыОбхода);	// Запуск обхода таблицы	
	КонецЕсли;
	
КонецПроцедуры

// Циклическая процедура с вопросами
&НаКлиенте
Процедура РаботаСОтрицательнымиОстатками(Результат, ПараметрыОбхода) Экспорт  
	
	// Пришел ответ "да" - комплектуем или оприходуем
	Если Результат = КодВозвратаДиалога.Да Тогда 
		ст = ТаблицаСОстатками[ПараметрыОбхода.НомерСтроки];
		Если ПараметрыОбхода.Комплектация Тогда // Комплектуем 
			АртикулРулона = Лев(СокрЛП(ст.НоменклатураАртикул),Найти(ст.НоменклатураАртикул,"m")-1);
			Если СоздатьКомплектацию(АртикулРулона) Тогда
				Сообщение = Новый СообщениеПользователю;
				Сообщение.Текст = "Разукомплектовали для товара: ("+ст.НоменклатураАртикул+") "+ст.НоменклатураНаименование;
				Сообщение.Сообщить();
			КонецЕсли;			
		ИначеЕсли ПараметрыОбхода.Оприходование Тогда // Оприходуем
			КоличествоНужно = ст.Количество - (ст.КоличествоОстаток * ст.Коэффициент);
			Если СоздатьОприходование(ст.НоменклатураАртикул, КоличествоНужно) Тогда
				Сообщение = Новый СообщениеПользователю;
				Сообщение.Текст = "Оприходовали товар: ("+ст.НоменклатураАртикул+") "+ст.НоменклатураНаименование+" в количестве: "+Строка(КоличествоНужно); 
				Сообщение.Сообщить();
			КонецЕсли;
		КонецЕсли;
	ИначеЕсли Результат = КодВозвратаДиалога.Отмена Тогда 
		Возврат;
	КонецЕсли;
	
	// Это была последняя строка, прерываем выполнение
	Если ПараметрыОбхода.НомерСтроки+1 = ТаблицаСОстатками.Количество() Тогда
		Возврат;
	КонецЕсли;
	
	ст = ТаблицаСОстатками[ПараметрыОбхода.НомерСтроки+1];
	КоличествоНужно = ст.Количество - (ст.КоличествоОстаток * ст.Коэффициент);
	ПараметрыОбходаНовый = Новый Структура;
	Если не СтрНайти(ст.НоменклатураАртикул,"m") = 0 Тогда 
		ОстатокРулона = 0;
		АртикулРулона = Лев(СокрЛП(ст.НоменклатураАртикул),Найти(ст.НоменклатураАртикул,"m")-1);
		ОстатокРулона = ПолучитьОстатокРулоны(АртикулРулона);
		Если не ОстатокРулона = 0 Тогда
			// Спросим разкомплектовать?			
			ПараметрыОбходаНовый.Вставить("НомерСтроки",ТаблицаСОстатками.Индекс(ст));
			ПараметрыОбходаНовый.Вставить("Комплектация",Истина);
			ПараметрыОбходаНовый.Вставить("Оприходование",Ложь);
			Режим = РежимДиалогаВопрос.ДаНетОтмена;
			СтрокаВопроса = "Разукомплектовать для товара: ("+ст.НоменклатураАртикул+") "+ст.НоменклатураНаименование;
			Оповещение = Новый ОписаниеОповещения("РаботаСОтрицательнымиОстатками", ЭтаФорма, ПараметрыОбходаНовый);
			ПоказатьВопрос(Оповещение, СтрокаВопроса, Режим, 0); // Вызываем эту же процедуру и передаем в неё параметры
		Иначе 
			// Спросим оприходовать? 
			ПараметрыОбходаНовый.Вставить("НомерСтроки",ТаблицаСОстатками.Индекс(ст));
			ПараметрыОбходаНовый.Вставить("Комплектация",Ложь);
			ПараметрыОбходаНовый.Вставить("Оприходование",Истина);
			Режим = РежимДиалогаВопрос.ДаНетОтмена; 
			СтрокаВопроса = "Оприходовать товар: ("+ст.НоменклатураАртикул+") "+ст.НоменклатураНаименование+" в количестве: "+Строка(КоличествоНужно); 
			Оповещение = Новый ОписаниеОповещения("РаботаСОтрицательнымиОстатками", ЭтаФорма, ПараметрыОбходаНовый);
			ПоказатьВопрос(Оповещение, СтрокаВопроса, Режим, 0); // Вызываем эту же процедуру и передаем в неё параметры
		КонецЕсли;
	Иначе // Если это не метры
		// Спросим оприходовать? 
		ПараметрыОбходаНовый.Вставить("НомерСтроки",ТаблицаСОстатками.Индекс(ст));
		ПараметрыОбходаНовый.Вставить("Комплектация",Ложь);
		ПараметрыОбходаНовый.Вставить("Оприходование",Истина);
		Режим = РежимДиалогаВопрос.ДаНетОтмена; 
		СтрокаВопроса = "Оприходовать товар: ("+ст.НоменклатураАртикул+") "+ст.НоменклатураНаименование+" в количестве: "+Строка(КоличествоНужно); 
		Оповещение = Новый ОписаниеОповещения("РаботаСОтрицательнымиОстатками", ЭтаФорма, ПараметрыОбходаНовый);
		ПоказатьВопрос(Оповещение, СтрокаВопроса, Режим, 0); // Вызываем эту же процедуру и передаем в неё параметры
	КонецЕсли;		
	
КонецПроцедуры 

Думаю, такой простой пример кому-то пригодится. Если есть какие-то замечания или предложения по улучшению такого кода - комментируйте.

цикл вопрос в цикле оповещение

См. также

Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Россия Платные (руб)

Расширение конфигурации для «1С:Документооборот КОРП», редакция 3.0. позволяет: 1.использовать произвольные табличные части в качестве дополнительных реквизитов к документу; 2 использовать произвольные табличные части в шаблонах в формате docx для автоматического заполнения таблиц.

29400 руб.

29.06.2023    5148    11    5    

20

Логистика, склад и ТМЦ Адаптация типовых решений Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Чтобы не допустить путаницы с обещаниями клиентам и для четкого контроля исполнения заказов мы используем резервирование товаров. Мы доработали УНФ, чтобы она автоматически отменяла старые резервы и не мешала эффективно продавать.

7200 руб.

02.08.2023    3529    8    0    

27

Адаптация типовых решений Программист Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Абонемент ($m)

Каждый из нас сталкивается с ситуацией, когда какой-нибудь менеджер показывает свой Excel и рассказывает, как он что-то из 1С копирует в него, снабжает пояснениями, выделяет цветом и т.д. и т.п. Заканчивается все просьбой сделать вот чтобы также было в 1С. И оказывается такой человек (почти с гарантией) либо лучшим продажником, либо каким-то важным, за все отвечающим, - на ком все держится.

2 стартмани

22.04.2024    4727    dimanich70    15    

20

БСП (Библиотека стандартных подсистем) Адаптация типовых решений Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 Бесплатно (free)

Понадобилось в подменю "Создать на основании" добавить свою команду, которая открывает обработку. В процессе доработок появилась проблема двух подменю "Создать на основании". В статье о том, как решились проблемы.

01.03.2024    3607    dimanich70    8    

16

Адаптация типовых решений Программист Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Доработка типового отчета "Связанные документы" позволяет просто и быстро расширять состав объектов для построения структуры подчиненности документов, используя объекты основной конфигурации и любых расширений.

1 стартмани

27.10.2023    2787    21    avmartynov    14    

53

Пакетная печать Печатные формы Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Расширение для программ 1С:Управление торговлей, 1С:Комплексная автоматизация, 1С:ERP, которое позволяет распечатывать печатные формы для непроведенных документов. Можно настроить, каким пользователям, какие конкретные формы документов разрешено печатать без проведения документа.

2 стартмани

22.08.2023    2860    43    progmaster    8    

4
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. booksfill 01.06.22 18:06 Сейчас в теме
Я правильно понял, что рекомендуется просто организовать рекурсию в методе "ПоказатьВопрос", а фишка в том, что все это запихали именно в один метод?

Если, да, то мне кажется более структурированным решение, приводимое в
https://forum.infostart.ru/forum9/topic213234/. Там, правда, не один метод, а два, но так , по-моему, правильнее, все-таки убираем анализ запросов в свой метод..

P.S.
А метод ПоказатьВопросАсинх не рассматривается, или я неверно понимаю как он работает?
3. nikolasx 59 02.06.22 18:15 Сейчас в теме
(1) Да, цель была запихнуть именно в один метод и вызывать эту же процедуру в процедуре для компактности. Вариант с двумя методами аналогичный. Этот пример как вариант использования в разных ситуациях и на свой вкус.
triviumfan; +1 Ответить
6. nikolasx 59 02.06.22 19:15 Сейчас в теме
(1)
А метод ПоказатьВопросАсинх не рассматривается, или я неверно понимаю как он работает?
Что касается этого метода - это хорошо, но не у всех платформа выше 8.3.18.1128. Я даже не сталкивался с асинхронными методами. Но вы мне дали подсказку разобраться с асинхронными методами и попробовать их в деле. Спасибо.
2. malikov_pro 1314 01.06.22 20:09 Сейчас в теме
Не мучайте пользователей, выведите форму блокирующую текущую с таблицей строк товаров и ошибками, + кнопками для решения по выделенным.
marku; ixijixi; ltfriend; +3 Ответить
4. nikolasx 59 02.06.22 18:23 Сейчас в теме
(2) Что вы имеете ввиду "Не мучайте пользователей"? Цель была именно отдать решение пользователю по вопросу возникновение отрицательных остатков по каждому такому товару, оприходовать или разукомплектовать, а так же пропустить (ответив Нет) или прервать цикл (ответив Отменить) и разобраться с остатками.
5. ltfriend 969 02.06.22 19:09 Сейчас в теме
(4) Имеется в виду, что вместо того, чтобы заставлять пользователя нажимать кнопки по каждой строке (а если таких строк 10, 20 и т.д.?), лучше собрать проблемные товары все вместе, вывести отдельную форму с этими товарами с возможностью выделения строк и кнопками, что нужно сделать сразу со всеми выделенными строками. А ваша реализация - это реальное мучение для пользователей. По несколько раз нажимать "Да/Нет/Отмена".
7. booksfill 03.06.22 09:34 Сейчас в теме
(5) Это, конечно, все правильно, но вопросы не обязаны быть взаимонезависимыми.
Иногда от ответа пользователя на один вопрос меняется текст следующего и сама необходимость в нем.

- Вам больше 18 лет?
- Да.
- Сколько бутылок водки хотите взять?

- Вам больше 18 лет?
- Нет.
- Иди, девочка, отсюда!

Или, в примере близком к авторскому:
- Разукомплектовать товар N?
- Да
- Образовались зап. части, доукомплектовать товар N1?
8. ltfriend 969 03.06.22 10:12 Сейчас в теме
(7) К самой реализации показа нескольких вопросов подряд претензий, по сути, нет. Действительно, бывают ситуации, когда это необходимо. Вопросы вызвало то, для чего такая возможность была использована автором. Как правильно написал malikov_pro - это мучение пользователей ))
9. nikolasx 59 03.06.22 11:47 Сейчас в теме
(5) Я согласен с тем когда 10, 20 и т.д. - это не лучший вариант реализации обходом, но в данной ситуации таких строк 1-5 и то редкость, больше сделано для проверки и быстрого решения, не пересматривать и сопоставлять колонки количество и остаток (в голове вычислять, сколько не хватает), а потом еще и самому делать и заполнять документы оприходования и комплектации.
10. DrAku1a 1733 04.06.22 07:32 Сейчас в теме
(4) Сразу представил некую Марь Ивановну, которая так подтверждает список из 100 позиций и где-то на второй половине её отвлекают каким-то вопросом... В этом плане, ИМХО, лучше сделать список с пометками.
Оставьте свое сообщение