Автоматическое оповещение пользователей при проведении документа Поступление товаров, с возможностью дублировать сообщения другому сотруднику

26.02.18

Задачи пользователя - Адаптация типовых решений

Данная разработка автоматически оповещает пользователя о поступлении товара по заказу клиента. Схема работы : Заказ клиента > Заказ поставщику > Поступление товаров. Оповещается пользователь, который создавал заказ клиента (менеджер). Оповещение выводится на экран и ждет подтверждения о прочтении. После подтверждения - фиксируется время прочтения оповещения. Есть возможность просматривать все сообщения по пользователю за любой период. Есть возможность дублировать сообщение другим пользователям. Например, если менеджер в отпуске, и его заменяет другой менеджер, и оповещения будут отправляться второму (третьему и т.д.).

Скачать исходный код

Наименование Файл Версия Размер
Автоматическое оповещение пользователей при проведении документа поступление товаров, с возможностью дублировать сообщения другому сотруднику.:
.cf 373,55Kb
43
.cf 373,55Kb 43 Скачать

Принцип работы: При проведении документа Поступление товаров по заказу поставщику, который создан на основании заказа клиента - делается запись в регистр. Записывается сообщение о поступлении товара для пользователя, который ответственный за заказ клиента. Каждые 10 минут срабатывает обработчик ожидания, проверяет, есть ли неотправленные сообщения, и отправляет их пользователю. Весь механизм можно отключить, это делается перед групповым перепроведением или при закрытии месяца, чтобы на пользователя не сыпались сообщения. Время проверки сообщений можно уменьшить (например, каждую минуту) или увеличить (например, один раз в день).

Описание:

1. Создан справочник: ОП_ДублированиеОповещенийПользователям

Пользователь = Спр Пользователи 

ДублироватьОповещения = Булево

2. Создан Регистр Сведений :

Документ Событие - Любой документ , при проведении которого делается запись в регистр (У меня поступление товаров)

Дополнительный Документ - Любой документ, при необходимости (У меня Заказ клиента)

Справочник Событие - Любой справочник (на всякий случай, можно этот механизм реализовать например при записи элемента справочника, только код доработать) 

Пользователь - Тут  все понятно

Оповещение выполнено - булево

Дата Доставки Оповещения - ДатаиВремя

Текст - то что будете выводить пользователю

 

3. Создана константа, которая включает механизм оповещения. Если константа - ложь, запись в регистр не делается.

4. Созданы две подписки на событие: При проведении документа поступление делается запись в регистр, а при удалении проведения - запись удаляется

5. Созданы 3 общих модуля. См скрины и код

5.1

Процедура ОП_ОповещениеПользователей() Экспорт    
    ОП_ОповещениеПользователейКлиент.ОП_ОповещениеПользователейКлиент()
КонецПроцедуры

 

5.2 

Процедура ОП_ОповещениеПользователейКлиент() Экспорт
        Пользователь = "";    
        ТекстСообщения = ""; //Если документов будет несколько текст будет общий для всех документов
        ДокументСобытие = Новый Массив;   //Если документов будет несколько создадим массив, для корректоного формирования записи в регистр
   ОП_ОповещениеПользователейСервер.СформироватьСообщение(ТекстСообщения,ДокументСобытие,Пользователь);     
        Параметры = Новый Структура;
        Параметры.Вставить("Пользователь",Пользователь);
        Параметры.Вставить("ДокументСобытие",ДокументСобытие);        
        Если  ТекстСообщения<>"" Тогда
            Оповещение = Новый ОписаниеОповещения("СделатьЗаписьВРегистр",ОП_ОповещениеПользователейКлиент,Параметры);
            ПоказатьВопрос(Оповещение,ТекстСообщения,РежимДиалогаВопрос.ОК);
        КонецЕсли;
КонецПроцедуры



Процедура  СделатьЗаписьВРегистр(Результат, ДополнительныеПараметры) Экспорт       
 ОП_ОповещениеПользователейСервер.СделатьЗаписьВРегистрОТомЧтоОповещениеПолучено(ДополнительныеПараметры);             
КонецПроцедуры

 

5.3

Процедура ОП_ОповещениеПользователейОбработкаПроведения(Источник, Отказ, РежимПроведения) Экспорт
  ИспользоватьОповещение = Константы.ОП_ОповещениеПользователей.Получить();    
    Если ИспользоватьОповещение Тогда    
        ЗаказКлиента = Источник.Ссылка.ЗаказПоставщику.ДокументОснование;
        //сообщения в регистр должны записываться только если поступление формируется на основании заказа поставщику, 
        //а заказ поставщику  формируется по заказу клиента.
        Если ЗначениеЗаполнено(ЗаказКлиента) Тогда
            Пользователь = Источник.Ссылка.ЗаказПоставщику.ДокументОснование.Менеджер;    
            Запрос = Новый Запрос;
            Запрос.УстановитьПараметр("Пользователь",Пользователь);
            Запрос.Текст =      "ВЫБРАТЬ
            |    ОП_ДублированиеОповещенийПользователям.Ссылка КАК Ссылка
            |ИЗ
            |    Справочник.ОП_ДублированиеОповещенийПользователям КАК ОП_ДублированиеОповещенийПользователям
            |ГДЕ
            |    ОП_ДублированиеОповещенийПользователям.Пользователь = &Пользователь
            |    И ОП_ДублированиеОповещенийПользователям.Ссылка.ПометкаУдаления = ЛОЖЬ";
            
            Результат = Запрос.Выполнить().Выбрать();
            
            
            Пока Результат.Следующий() Цикл
                //Если записи есть в регистре тогда их нужно удалить и записать новые, т.к. документ мог быть изменен 
                //и пользователь должен снова получить сообщение для перепроверки документа (своего рода подстраховка от изменений документа)
                НаборЗаписей = РегистрыСведений.ОП_ОповещениеПользователей.СоздатьНаборЗаписей(); 
                
                НаборЗаписей.Отбор.ДокументСобытие.Установить(Источник.Ссылка); 
                НаборЗаписей.Прочитать();
                НаборЗаписей.Очистить(); 
                
                Если Результат.Ссылка.ДублироватьОповещения = Ложь Тогда  //Сделаем только одну запись для данного пользователя
                    
                    НоваяЗапись = НаборЗаписей.Добавить(); 
                    НоваяЗапись. ДокументСобытие = Источник.Ссылка;     
                    НоваяЗапись.ДополнительныйДокумент = ЗаказКлиента; 
                    НоваяЗапись.Период = Источник.Ссылка.Дата;
                    НоваяЗапись.Пользователь = Пользователь;
                    НоваяЗапись.ТекстСообщения = "Поступил товар по заказу клиента № " + ЗаказКлиента.Номер + " , от "+ ЗаказКлиента.Дата +    " . "+ Источник.Ссылка;
                    НаборЗаписей.Записать(); 
                    
                Иначе //Если нужно дублировать записи, тогда делаем записи только для тех пользователей, которым нужно дублировать
                    
                    //Здесь записи для дублирования
                    Для Каждого Строка Из Результат.Ссылка.ТабличнаяЧасть Цикл
                        
                        НоваяЗапись = НаборЗаписей.Добавить(); 
                        НоваяЗапись. ДокументСобытие = Источник.Ссылка;     
                        НоваяЗапись.ДополнительныйДокумент = ЗаказКлиента; 
                        НоваяЗапись.Период = Источник.Ссылка.Дата;
                        НоваяЗапись.Пользователь = Строка.ПользовательДляДублирования;
                        НоваяЗапись.ТекстСообщения = "Поступил товар по заказу клиента № " + ЗаказКлиента.Номер + " , от "+ ЗаказКлиента.Дата +    " . "+ Источник.Ссылка;
                        
                        НаборЗаписей.Записать();       
                        
                    КонецЦикла;
                КонецЕсли;    
            КонецЦикла;
        КонецЕсли; //Если ЗначениеЗаполнено(ЗаказКлиента)
    КонецЕсли; //Константа "Включить оповещение пользователей" = истина
КонецПроцедуры

Процедура ОП_ОповещениеПользователейОбработкаУдаленияПроведения(Источник, Отказ) Экспорт
    ИспользоватьОповещение = Константы.ОП_ОповещениеПользователей.Получить();    
    Если ИспользоватьОповещение Тогда
        ЗаказКлиента = Источник.Ссылка.ЗаказПоставщику.ДокументОснование;
        Если ЗначениеЗаполнено(ЗаказКлиента) Тогда
            //При отменен проведения документа удаляем записи из регистра
            НаборЗаписей = РегистрыСведений.ОП_ОповещениеПользователей.СоздатьНаборЗаписей();     
            НаборЗаписей.Отбор.ДокументСобытие.Установить(Источник.Ссылка); 
            НаборЗаписей.Прочитать();
            НаборЗаписей.Очистить();
            НаборЗаписей.Записать();
        КонецЕсли;
    КонецЕсли; //Константа "Включить оповещение пользователей" = истина

КонецПроцедуры

Процедура СформироватьСообщение(ТекстСообщения,ДокументСобытие,Пользователь) Экспорт
    
    ТекстСообщения = "";
    Пользователь = Пользователи.ТекущийПользователь();
    
    //Период берем за 3 месяца, при желании можно увеличить
    НачалоПериода = ДобавитьМесяц(ТекущаяДата(),-3);
    КонецПериода =  ТекущаяДата();
    
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("НачалоПериода",НачалоПериода);
    Запрос.УстановитьПараметр("КонецПериода",КонецПериода);
    Запрос.УстановитьПараметр("Пользователь",Пользователь);
    Запрос.Текст = "ВЫБРАТЬ
    |    ОП_ОповещениеПользователей.ДокументСобытие КАК ДокументСобытие,
    |    ОП_ОповещениеПользователей.ДополнительныйДокумент КАК ДополнительныйДокумент,
    |    ОП_ОповещениеПользователей.Пользователь КАК Пользователь,
    |    ОП_ОповещениеПользователей.ТекстСообщения КАК ТекстСообщения
    |ИЗ
    |    РегистрСведений.ОП_ОповещениеПользователей КАК ОП_ОповещениеПользователей
    |ГДЕ
    |    ОП_ОповещениеПользователей.Период МЕЖДУ &НачалоПериода И &КонецПериода
    |    И ОП_ОповещениеПользователей.ОповещениеВыполнено = ЛОЖЬ
    |    И ОП_ОповещениеПользователей.Пользователь = &Пользователь" ;
    
    Результат =  Запрос.Выполнить().Выбрать();    
    
    Пока Результат.Следующий() Цикл
        Попытка            
            ТекстСообщения = Результат.ТекстСообщения + Символы.ПС+ ТекстСообщения;      
            ДокументСобытие.Добавить(Результат.ДокументСобытие);
        Исключение
        КонецПопытки;
    КонецЦикла;
                
КонецПроцедуры

Процедура СделатьЗаписьВРегистрОТомЧтоОповещениеПолучено(ДополнительныеПараметры) Экспорт
    
    Для Каждого Документ Из ДополнительныеПараметры.ДокументСобытие Цикл
        НаборЗаписей = РегистрыСведений.ОП_ОповещениеПользователей.СоздатьНаборЗаписей();             
        НаборЗаписей.Отбор.ДокументСобытие.Установить(Документ); 
        НаборЗаписей.Отбор.Пользователь.Установить(ДополнительныеПараметры.Пользователь);
        НаборЗаписей.Прочитать();
        СтрокаЗаписи = НаборЗаписей[0];
        СтрокаЗаписи.ОповещениеВыполнено = Истина;
        СтрокаЗаписи.ДатаДоставкиОповещения = ТекущаяДата();
        НаборЗаписей.Записать();
    КонецЦикла;
    
КонецПроцедуры    

 

6. В модуле управляемого приложения Процедура ПриНачалеРаботыСистемы()  нужно добавить   обработчик ожидания

  
  

 //\\ Рассылка оповещения менеджерам о поступлении по заказу клиента
    ПодключитьОбработчикОжидания("ОП_ОповещениеПользователей",600,Ложь);
    //\\

7. Создана подсистема, которая соединила все новые объекты конфигурации

 

Ну вот и всё!!!!  Может, кому пригодится.  Сильно за код не ругаться )))) . Не спорю, что можно и улучшить, можно доработать систему, чтобы оповещала пользователей при нескольких событиях. Всё в ваших руках.

Разрабатывалась для Управление торговлей, редакция 11 (11.4.2.123). На других конфигурациях не тестировалась, но думаю, что при небольших доработках будет работать везде. Кому неохота возиться - есть cf-ник, только при объединении не нужно объединять справочник пользователи и документ Приобретение товаров. Они созданы фиктивно для целостности ссылок.


 

См. также

Табличная часть в доп. реквизитах и формирование таблиц в шаблоне docx для 1С:ДО 3.0

Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Россия Платные (руб)

Расширение конфигурации для «1С:Документооборот КОРП», редакция 3.0. позволяет: 1.использовать произвольные табличные части в качестве дополнительных реквизитов к документу; 2 использовать произвольные табличные части в шаблонах в формате docx для автоматического заполнения таблиц.

29400 руб.

29.06.2023    4841    10    5    

19

Расширение для 1С:УНФ. Автоматическое снятие резервов в Заказах покупателей

Логистика, склад и ТМЦ Адаптация типовых решений Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Чтобы не допустить путаницы с обещаниями клиентам и для четкого контроля исполнения заказов мы используем резервирование товаров. Мы доработали УНФ, чтобы она автоматически отменяла старые резервы и не мешала эффективно продавать.

7200 руб.

02.08.2023    3224    5    0    

22

Каждому менеджеру нужен свой Excel

Адаптация типовых решений Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Абонемент ($m)

Каждый из нас сталкивается с ситуацией, когда какой-нибудь менеджер показывает свой Excel и рассказывает, как он что-то из 1С копирует в него, снабжает пояснениями, выделяет цветом и т.д. и т.п. Заканчивается все просьбой сделать вот чтобы также было в 1С. И оказывается такой человек (почти с гарантией) либо лучшим продажником, либо каким-то важным, за все отвечающим, - на ком все держится.

2 стартмани

22.04.2024    4276    dimanich70    15    

18

Создать на основании - своя кнопка (БСП). Проблема двух подменю Создать на основании

БСП (Библиотека стандартных подсистем) Адаптация типовых решений Платформа 1С v8.3 1С:ERP Управление предприятием 2 Бесплатно (free)

Понадобилось в подменю "Создать на основании" добавить свою команду, которая открывает обработку. В процессе доработок появилась проблема двух подменю "Создать на основании". В статье о том, как решились проблемы.

01.03.2024    2305    dimanich70    8    

14

Доработка отчета "Связанные документы" (структура подчиненности) для вывода объектов из любого расширения

Адаптация типовых решений Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Доработка типового отчета "Связанные документы" позволяет просто и быстро расширять состав объектов для построения структуры подчиненности документов, используя объекты основной конфигурации и любых расширений.

1 стартмани

27.10.2023    2249    19    avmartynov    14    

44

Печать непроведенных документов для УТ, КА, ERP. Настройка печати по пользователям, документам и печатным формам

Пакетная печать Печатные формы Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Расширение для программ 1С:Управление торговлей, 1С:Комплексная автоматизация, 1С:ERP, которое позволяет распечатывать печатные формы для непроведенных документов. Можно настроить, каким пользователям, какие конкретные формы документов разрешено печатать без проведения документа.

2 стартмани

22.08.2023    2465    32    progmaster    8    

4
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Romarius 15 26.02.18 17:21 Сейчас в теме
Делал подобное, но сообщения выводились только тем менеджерам, по заказам которых есть приход с уведомлением в разрезе заказов и номенклатуры. Также учитывались перемещения. Менеджера остались доработкой довольны.
10. user1647665 26.08.21 10:33 Сейчас в теме
(1) Мне как раз и нужно сделать такое же. Чтобы оповещения (email) приходили тем менеджерам, по заказам которых есть приход.

Можно увидеть образец такого письма, оповещения?
2. Natali307192013 25 26.02.18 18:41 Сейчас в теме
Было задание разработать основу для оповещения пользователей, которую при необходимости можно дорабатывать. У клиента штучный дорогой товар, поэтому необходимости в разрезе номенклатуры нет. Хотя идея хорошая со временем можно доработать. Также хочу добавить возможность отложить сообщение на заданное время. Спасибо за идею.)))
11. user1647665 26.08.21 10:34 Сейчас в теме
(2) Наталья, а можно посмотреть вариант получаемого письма (оповещения) ?
3. пользователь 27.02.18 00:13
Сообщение было скрыто модератором.
...
4. BigB 192 27.02.18 11:44 Сейчас в теме
А не лучше ли было сделать на основе системы взаимодействия? Мне кажется она как раз для этого подойдет. https://wonderland.v8.1c.ru/blog/peredacha-informatsii-s-servera/
EvgeniusRusius; +1 Ответить
5. Natali307192013 25 28.02.18 16:53 Сейчас в теме
Не знаю , может и лучше, но с этим нужно разбираться. Я не претендую на крутость обработки , но мой вариант прост и понятен.
6. MarryJane 31 03.03.18 12:10 Сейчас в теме
А может посмотрите УНФ. Там как раз модуль "Обсуждения" хорошо сделан, что легко его дорабатывать.
7. 1Cappldev 30.10.19 22:30 Сейчас в теме
Наталья, спасибо за публикацию! Действительно, Ваш вариант довольно прост и понятен! Подскажите, почему дополнительный документ для оповещения выведен в отдельный реквизит, почему не стали использовать составной тип данных для реквизита "ДокументСобытия"?
8. Natali307192013 25 12.11.19 16:51 Сейчас в теме
(7) На тот момент, казалось что так удобнее в дальнейшем работать со списком оповещений )). Можно и одним реквизитом обойтись. ))
9. 1Cappldev 13.11.19 12:41 Сейчас в теме
(8)Так и подумал) Спасибо за ответ.
Оставьте свое сообщение