Сохранение реквизитов и табличных частей объектов в XML

23.12.11

Интеграция - Файловый обмен (TXT, XML, DBF), FTP

Пример того, как можно сохранять и загружать объекты 1С методами встроенных объектов ЗаписьXML и ЧтениеXML.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
пример использования
.epf 8,19Kb
111
111
1 SM
Скачать Купить за 1 850 руб.

Представленные в публикации процедуры были рождены потребностью сохранять настройки внешних обработок с возможностью последующего их использования на других компьютерах и в других информационных базах. Работают они, однако, не только для обработок, но и для любых других объектов 1С, имеющих реквизиты и табличные части. Сам я пользуюсь ими достаточно часто, при решении самых различных задач, потому решил поделиться, глядишь кому-нибудь пригодится. Так же, думаю, этот материал может быть полезен начинающим программистам как пример рекурсивного чтения структуры XML-файла, к тому же процедуры малы, просты и легко "допиливаются" под специфические задачи.

Сохранение производится процедурой СохранитьРеквизитыИТабличныеЧасти. В качестве параметров она принимает сохраняемый объект и имя файла. Ссылочные реквизиты сохраняются в виде GUID.

Процедура СохранитьРеквизитыИТабличныеЧасти (Объект, ИмяФайлаXML=Неопределено) Экспорт
   
ФайлXML = Новый ЗаписьXML;
   
ФайлXML.ОткрытьФайл(ИмяФайлаXML);
   
ФайлXML.ЗаписатьОбъявлениеXML();
   
ФайлXML.ЗаписатьНачалоЭлемента("Root");
   
ФайлXML.ЗаписатьАтрибут("Объект",Объект.Метаданные().Имя);
//Сохраняем реквизиты
   
Для Каждого Реквизит Из Объект.Метаданные().Реквизиты Цикл
       
ФайлXML.ЗаписатьНачалоЭлемента("Реквизит");
       
ФайлXML.ЗаписатьАтрибут("Имя", Реквизит.Имя);
       
ТипЗначения = ТипЗнч(Объект[Реквизит.Имя]);
        Если Не
ТипЗначения = Тип("Неопределено") Тогда
           
ФайлXML.ЗаписатьАтрибут("ИмяТипа", XMLТип(ТипЗначения).ИмяТипа);
           
ФайлXML.ЗаписатьАтрибут("URI", XMLТип(ТипЗначения).URIПространстваИмен);
        КонецЕсли;
       
ФайлXML.ЗаписатьТекст(XMLСтрока(Объект[Реквизит.Имя]));
       
ФайлXML.ЗаписатьКонецЭлемента();
    КонецЦикла;
//Сохраняем табличные части
   
Для Каждого ТЧ из Объект.Метаданные().ТабличныеЧасти Цикл
       
ФайлXML.ЗаписатьНачалоЭлемента("ТабличнаяЧасть");
       
ФайлXML.ЗаписатьАтрибут("Имя", ТЧ.Имя);
        Для Каждого
СтрокаТЧ из Объект[ТЧ.Имя] Цикл
           
ФайлXML.ЗаписатьНачалоЭлемента("ЭлементКоллекции");
            Для Каждого
РеквизитТЧ Из ТЧ.Реквизиты Цикл
               
ФайлXML.ЗаписатьНачалоЭлемента("Реквизит");
               
ФайлXML.ЗаписатьАтрибут("Имя", РеквизитТЧ.Имя);
               
ТипЗначения = ТипЗнч(СтрокаТЧ[РеквизитТЧ.Имя]);
                Если Не
ТипЗначения = Тип("Неопределено") Тогда
                   
ФайлXML.ЗаписатьАтрибут("ИмяТипа", XMLТип(ТипЗначения).ИмяТипа);
                   
ФайлXML.ЗаписатьАтрибут("URI", XMLТип(ТипЗначения).URIПространстваИмен);
                КонецЕсли;
               
ФайлXML.ЗаписатьТекст(XMLСтрока(СтрокаТЧ[РеквизитТЧ.Имя]));
               
ФайлXML.ЗаписатьКонецЭлемента();
            КонецЦикла;
           
ФайлXML.ЗаписатьКонецЭлемента();
        КонецЦикла;
       
ФайлXML.ЗаписатьКонецЭлемента();
    КонецЦикла;
    Если Не
ФайлXML=Null Тогда
       
ФайлXML.ЗаписатьКонецЭлемента();
       
ФайлXML.Закрыть();
    КонецЕсли;
КонецПроцедуры

За чтение объекта отвечают процедуры ЗагрузитьРеквизитыИТабличныеЧасти и ЗагрузитьОбъектРекурсивно. Чтобы прочитать объект вызывается первая, ей передаются объект, который необходимо заполнить, и имя файла. Вторая является вспомогательной.

Процедура ЗагрузитьРеквизитыИТабличныеЧасти(Объект, ИмяФайлаXML=Неопределено) Экспорт
    Если Не
ИмяФайлаXML = Неопределено Тогда
       
ФайлXML = Новый ЧтениеXML;
       
ФайлXML.ОткрытьФайл(ИмяФайлаXML);
        Пока
ФайлXML.Прочитать() Цикл
            Если
ФайлXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
               
ЗагрузитьОбъектРекурсивно(ФайлXML, Объект, ФайлXML.Имя);
            КонецЕсли
        КонецЦикла;
    КонецЕсли;
КонецПроцедуры

Процедура ЗагрузитьОбъектРекурсивно(ФайлXML, Объект, знач ИмяУзла)
   
ИмяТипа = "";
   
ПространствоИмен = "";
    Пока
ФайлXML.ПрочитатьАтрибут() Цикл
        Если
ФайлXML.Имя = "ИмяТипа" Тогда
           
ИмяТипа = ФайлXML.Значение;
        ИначеЕсли
ФайлXML.Имя = "URI" Тогда
           
ПространствоИмен = ФайлXML.Значение;
        КонецЕсли;
    КонецЦикла;
    Пока
ФайлXML.Прочитать() Цикл
        Если
ФайлXML.ТипУзла = ТипУзлаXML.КонецЭлемента И ФайлXML.Имя = ИмяУзла Тогда
            Возврат;
        ИначеЕсли
ФайлXML.ТипУзла = ТипУзлаXML.Текст Тогда
           
ТипОбъекта = ИзXMLТипа(ИмяТипа, ПространствоИмен);
            Если НЕ
ТипОбъекта = Неопределено тогда
               
Объект = XMLЗначение(ТипОбъекта, ФайлXML.Значение);
            КонецЕсли;
        ИначеЕсли
ФайлXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
           
ИмяТекУзла = ФайлXML.Имя;
            Если
ФайлXML.Имя = "ЭлементКоллекции" Тогда
               
ЗагрузитьОбъектРекурсивно(ФайлXML, Объект.Добавить(), ИмяТекУзла);
            Иначе
                Если
ФайлXML.ПрочитатьАтрибут() Тогда
                   
ЗагрузитьОбъектРекурсивно(ФайлXML, Объект[ФайлXML.Значение], ИмяТекУзла);
                КонецЕсли;
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры

В приложенном файле демонстрационная обработка, позволяющая сохранить ссылочный объект БД в файл и заполнить объект из файла. Заполняемый объект должен быть того же типа, что и сохраненный, а также он должен быть предварительно создан, сохранен в ИБ и выбран в поле "Ссылка".

См. также

SALE! 10%

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен и синхронизацию в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    138145    761    292    

404

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 Бухгалтерский учет Управленческий учет Платные (руб)

Переход и перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:ERP Управление предприятием 2.5 и 1С:Комплексную автоматизацию 2.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x), ERP 2.5 (2.5.16.x), КА 2.5 (2.5.16.x) .

28000 руб.

24.06.2020    62367    51    27    

81

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.228.x) и БП 3.0 (3.0.154.x). Правила подходят для версии ПРОФ и КОРП.

28000 руб.

15.12.2021    21794    144    40    

104

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

45650 руб.

15.04.2019    70376    175    146    

117

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3.87.x и УТ 11.5.16.x

28000 руб.

23.07.2020    48437    208    64    

170

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Платформа 1C v8.2 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием Россия Платные (руб)

Регулярный обмен, выгрузка, перенос из КА 1.1, УПП 1.3, УТ 10.3 для обмена с любыми конфигурациями, поддерживающими обмен в формате EnterpriseData (КД3) - БП 3.0, ERP, КА 2, УТ 11, Розница 2, УНФ 1.6 и другими. Правила для старых и доработанных конфигураций не требуют синхронного обновления и совместимы с новыми и будущими конфигурациями. Обмен по расписанию, через папку, FTP, почту.

14580 руб.

18.02.2016    184532    573    509    

516

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

В продаже с 2015 года | Воспользовались более 287 предприятий! | Перенос данных из УПП 1.3 в БП 3.0 | из КА 1.1 в БП 3.0 | Переносятся документы, начальные остатки и вся справочная информация | Сэкономьте свое время - используйте готовое решение для перехода! | Есть фильтр по организации и множество других параметров выгрузки | Поддерживается несколько сценариев работы: как первичный полный перенос, так и перенос только новых документов | Перенос данных возможен в "1С: Бухгалтерия 3.0" версии ПРОФ, КОРП или базовую | Переход с "1С: УПП1.3" / "1С:КА 1.1" на "1С:БП3.0" с помощью правил конвертации будет максимально комфортным! | Можно бесплатно проверить перенос на вашем сервере!

39500 руб.

25.02.2015    169754    293    253    

374

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление нашей фирмой 3.0 Россия Платные (руб)

В продаже с 2018г. | Воспользовались более 41 предприятия! | Правила конвертации (КД 2) для переноса данных из БП 3 в УНФ | Переносятся все виды документов, начальные остатки и вся возможная справочная информация | Есть фильтр по организациям | Оперативно обновляем на новые релизы | Учет в БП 3 должен быть корректным, некорректные данные не переносятся | Можно бесплатно проверить на вашем сервере до покупки!

45650 руб.

10.07.2018    69179    46    126    

49
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Angeros 25.11.11 11:19 Сейчас в теме
Конечно + но все это есть в выгрузка загрузка хмл. стандартной обработке.
2. saiten 246 25.11.11 11:38 Сейчас в теме
все это есть в выгрузка загрузка хмл. стандартной обработке

Конечно, там это есть, и даже гораздо больше. Я же только лишь предложил минимальный механизм, который без лишних сложностей можно использовать в собственных разработках.
3. Поручик 4683 25.11.11 12:21 Сейчас в теме
Рекомендую как пример работы с XML
4. Seregalink 79 26.11.11 02:21 Сейчас в теме
Спасибо, очень хорошо, как пример вполне устраивает!
5. Gasdrubal 01.12.11 10:54 Сейчас в теме
Отличный универсальный механизм. А нельзя как - то также регистры выгружать или там планы счетов? Выложите может код?
6. saiten 246 01.12.11 11:53 Сейчас в теме
(5) Как-то необходимости не возникало. С регистрами много вопросов: весь регистр выкидывать или по отбору? или по запросу? и как загружать: только дописывать или очищать имеющиеся записи? Если бы мне поставили такую задачу - я бы сделал обработку с табличной частью, колонки которой повторяют структуру данных регистра, запросом выбрал бы нужные записи в ТЧ, а ее уже потом приведенным кодом выкинул в XML. Хотя, можно и непосредственно регистр обрабатывать. Почему, собственно, нет? Будет время - посмотрю.
Добавлено:
А лучше использовать универсальную выгрузку/загрузку XML - это задача самое для нее.
7. пользователь 20.12.11 16:19
Сообщение было скрыто модератором.
...
8. saiten 246 21.12.11 11:17 Сейчас в теме
(7) Пожалуйста. Рад, что кому-то пригодилось.
9. artmicro 28.12.11 11:19 Сейчас в теме
Хм, Автор скорее всего не слышах про встроенный сериализатор, который позволяет сделать все тоже - только используя всего две строчки кода.
11. saiten 246 28.12.11 16:37 Сейчас в теме
(9) Попробуйте сериализовать внешнюю обработку. Собственно, именно для сохранения реквизитов и ТЧ обработок этот код и писался. То, что можно выгружать и другие объекты БД - это побочный эффект.

Кроме того, не всегда можно обойтись сериализацией. Например, если идёт обмен XML-файлами со сторонней системой. В этом случае надо работать методами объектов Чтение-/ЗаписьXML. Можно, в принципе, и через DOM, но, честно говоря, не знаю, насколько реализация этой технологии в 1С справляется с большими файлами.
13. artmicro 28.12.11 21:18 Сейчас в теме
(11) Согласен, внешнюю обработку сериализовать штатными средствами не получится. Но можно использовать механизм хранения настроек в БД. Но я, если честно, не могу себе представить задачу где обходимо было бы сериализовать внешнюю обработку %)

DOM отлично справляется с довольно крупными файлами. Правда, проблема в том, что не так уж и часто найдешь тех, кто сможет граммотно это использовать со стороны сторонней системы.
14. saiten 246 29.12.11 09:24 Сейчас в теме
(13)
Но я, если честно, не могу себе представить задачу где обходимо было бы сериализовать внешнюю обработку %)

Сохранение настроек средствами платформы, к сожалению, не отличается надёжностью. Хранить же настройки в БД не всегда целесообразно.
Данный механизм может использоваться
1. для надёжного хранения настроек вне базы;
2. если обработка содержит большое количество настроек, ну, например, загрузка данных сложной структуры из XLS-файла: сопоставили ячейки документа данным, обкатали на тестовой базе, сохранили настройки в XLS, перенесли в рабочую;
3. если нескольким пользователям необходимо работать с общим набором настроек;
4. транспорт данных в тех случаях, когда нецелесообразно заморачиваться с конвертацией;
5. внешнее хранение небольших объемов данных.
15. artmicro 29.12.11 13:47 Сейчас в теме
(14) Надежность хранение настроек в файлах, тоже довольно сомнительный момент. Но в целом Вы правы. Суть понятна. Спасибо.
16. lsp71 17.02.12 13:21 Сейчас в теме
(14) я сам аналогичным образом использую xml-файлы для сохранения настроек отчетов/обработок, т.к. более надежное хранение, можно передать настройки другому пользователю, на другой комп.
18. DrAku1a 1732 17.03.15 03:11 Сейчас в теме
(14) А так сохранить настройки не проще?
ЗначениеВФайл(<ИмяФайла>, ТабличнаяЧасть.Выгрузить())
19. saiten 246 17.03.15 10:16 Сейчас в теме
(18)Ага, проще конечно. Но не всегда. Реквизиты так не выгрузить; если табличных частей больше одной - потребуется несколько файлов. В общем, каждой задаче - свой инструмент.
10. zog 28.12.11 14:57 Сейчас в теме
artmicro пишет:

Хм, Автор скорее всего не слышах про встроенный сериализатор, который позволяет сделать все тоже - только используя всего две строчки кода.


поумничать решили?) автор все слышал, я уверен, для новичков (таких как я) пример в самый раз.
12. artmicro 28.12.11 21:12 Сейчас в теме
(10) Ну чего же поумничать. Просто в последнее время, на этом ресурсе все больше и больше тем которые описаны в типовых книгах 1С...
17. пользователь 29.02.12 10:01
Сообщение было скрыто модератором.
...
20. v.a.ryag 37 12.02.16 04:28 Сейчас в теме
Плюсую за простоту и доступность представления информации. Взял себе код на заметку)
21. serq82 8 20.08.16 11:23 Сейчас в теме
а как можно сделать с внешней обработкой, в ней реквизиты и табличные части выгружались???не сохраняя данные обработки, а также как документ.ве дь в обработке не получишь Объект.Метаданные()
22. saiten 246 20.08.16 16:28 Сейчас в теме
(21)Ну почему же? У внешних обработок есть метаданные. Собственно, для обработок этот код и писался. Все работает.
Оставьте свое сообщение