Универсальный Реестр 8.2

08.02.12

Реестр документов для конфигураций 8.2 изначально писалось для УТ 11 версии.(управ. форма)
Адаптирован под компоновку данных
Выбор любых полей по документу
Функционал множественного Отбора
расчет итогов "СуммаДокумента",(для ут11 Сумма без НДС)

Скачать исходный код

Наименование Файл Версия Размер
Реестр Документов
.erf 12,72Kb
208
.erf 12,72Kb 208 Скачать
Реестр Документов с возможностью подключения внешнего отчета.
.erf 14,83Kb
35
.erf 14,83Kb 35 Скачать

Реестр документов для конфигураций 8.2 изначально писалось для УТ 11 версии, для чего установлен блок кода дополнительного расчета колонки НДС.
В отчете есть недочеты:
1)Нельзя открыть документ, используя механизм расшифровки.
2)Расчет НДС  происходит не в запросе.
за что прошу прощения у пользователей и коллег.

Код открыт и доступен.

Кто сможет подсказать по поводу расшифровки обязательно доработаю.

См. также

INFOSTART TECH EVENT 2024, 10-12 октября, Санкт-Петербург

Мероприятия Системный администратор Программист Бизнес-аналитик Руководитель проекта Россия Платные (руб)

XIV конференция по управлению и технологиям автоматизации учета на платформе 1С:Предприятие, которая пройдет в Санкт-Петербурге и соберет 1200 участников из разных регионов России и мира.

42000 руб.

06.12.2023    7385    373    0    

81

Оркестратор 1С

Технологические Системный администратор Программист Бизнес-аналитик Конфигурации 1cv8

Оркестратор 1С – мощный инструмент для мониторинга и управления системами 1С. Решение обеспечивает оперативный мониторинг данных в режиме реального времени, предоставляет наглядные графические показатели и позволяет управлять базами и сеансами. Отечественное ПО с регулярными обновлениями и сопровождением гарантирует стабильность и безопасность вашей инфраструктуры. Заказывайте 1С-Оркестратор и получайте центр наблюдения для эффективного управления и контроля, даже за высоконагруженными системами 1С!

92000 руб.

04.12.2023    6511    0    0    

23

Модуль интеграции 1С и Wildberries+Яндекс Маркет+СберМегамаркет по схеме FBO+FBS для УТ 11, КА, ERP, УНФ

Маркетплейсы Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Оптовая торговля, дистрибуция, логистика Ювелирная промышленность и торговля Фармацевтика, аптеки Легкая промышленность, мода и одежда Пищевая промышленность Бухгалтерский учет Налоговый учет Управленческий учет Платные (руб)

Расширение позволяет работать из 1С с площадкой Wildberries, Яндекс Маркет (без публикации базы), СберМегамаркет по Схеме FBS и FBO В FBO реализован механизм сборки коробов по штрих кодам в Wildberries. Отличительная особенность легкая настройка и информативный управленческий учет! Всего через 15 минут вы сможете полностью автоматизировать свои продажи на WB, ЯМ, Мегамаркет и узнать какую итоговую выручку вы получаете за вычетом всех комиссий ВБ, ЯМ, Мегамаркет. Исключите штрафы за продажу товара отсутствующего на складе и не своевременную передачу кодов маркировок, легкий и интуитивно понятный интерфейс позволит перенести всю работу с площадкой в 1С. Есть Демо.

30000 руб.

17.07.2023    8510    38    19    

30

Интеграция ФГИС Зерно и 1С: обмен с системой через API для любых конфигураций (универсальная подсистема ХамелеонЗерно)

Обмен с ГосИС Программист Платформа 1С v8.3 Конфигурации 1cv8 Оптовая торговля, дистрибуция, логистика Россия Управленческий учет Платные (руб)

Универсальная конфигурация ХамелеонЗерно для взаимодействия с системой ФГИС Зерно (тестовый+рабочий контур) может использоваться для интеграции в любую конфигурацию на базе 1С, версии ПРОФ и выше. Работа через API 1.0.7 и на API 1.0.8. Для удобства реализован общий интерфейс в виде обработки, схожей с интерфейсом ФГИС Зерно, но возможностей гораздо больше, т.к. при интеграции в Вашу учетную систему, можно на основании Ваших справочников и документов, создавать соответствующие документы и справочники в системе ФГИС Зерно и наоборот.

124800 руб.

27.06.2023    3307    23    0    

11

1C:Предприятие для программистов: Запросы и отчеты. Онлайн-интенсив с 14 мая по 13 июня 2024 г.

1С-программирование Программист Стажер Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения. Курс является вторым курсом траектории развития 1С-Разработчика, с углубленным изучением тем "Язык запросов" и "Отчеты", которые были рассмотрены в рамках “Базового курса для начинающих 1С-программистов”.

7500 руб.

04.10.2023    4729    20    1    

92

1С-Коннект - платформа для автоматизации техподдержки, услуг и коммуникаций

Поддержка Для ИТ-специалистов Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Корпоративный чат с возможностью обращаться в техподдержку, общаться с коллегами где и когда удобно, передавать файлы и удаленно подключаться к компьютеру

29900 руб.

26.12.2023    2153    11    0    

3

Таймлист (1С:Совещание, Таймлист Лайт)

Документооборот и делопроизводство (СЭД) Конфигурации 1cv8

«Таймлист» – экосистема сервисов («Таймлист Лайт», «1C:Совещание», «Таймлист Recorder»), основанная на искусственном интеллекте Таймлист, который позволяет эффективно работать с легкими поручениями за счет фиксации всех важных идей при расшифровке и последующем формировании автопротокола встречи. Сервисы, в которые интегрирован ИИ, позволяют работать с задачами (поручениями), полученными из автопротокола.

10000 руб.

06.12.2023    1679    0    0    

8

1С:Распознавание первичных документов

Для бухгалтерии и кадров Конфигурации 1cv8 Россия Платные (руб)

Это сервис, который распознает и исключает необходимость ввода первичных документов в 1С.

600 руб.

11.07.2023    13959    102    0    

50
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Marysia 18.01.12 06:43 Сейчас в теме
Универсальный Реестр 8.2 - т.е. получается что на любой конфигурации будет работать, или это только в теории?
3. Legavaz 704 18.01.12 08:49 Сейчас в теме
(1) Универсальный это значит для любой 8.2
(2) Обязательно
4. Marysia 18.01.12 08:52 Сейчас в теме
(3) Спасибо за ответ. Будем пробовать.
21. rozer 309 22.09.14 22:18 Сейчас в теме
(3) подскажу по расшифровке:

1) в форме добавить реквизит "ДанныеРасшифровки" (тип Строка)

2) поменять код на

ДанныеРасшифровкиСКД  = Новый ДанныеРасшифровкиКомпоновкиДанных;
КомпоновщикМакета 	= Новый КомпоновщикМакетаКомпоновкиДанных;
МакетКомпоновки = КомпоновщикМакета.Выполнить(МакетСКД,
Настройки, ДанныеРасшифровкиСКД);
ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;
ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки, ВнешниеНаборыДанных,ДанныеРасшифровкиСКД, Истина);
ДанныеРасшифровки = ПоместитьВоВременноеХранилище(ДанныеРасшифровкиСКД, ЭтаФорма.УникальныйИдентификатор);
Показать


3) добавить обработку расшифровки для поля табл. документа "Результат"

&НаКлиенте
Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
	СтандартнаяОбработка = Ложь;     
	ИсточникНастроек = Новый ИсточникДоступныхНастроекКомпоновкиДанных(Отчет);     
	ОбработкаРасшифровкиКД = Новый ОбработкаРасшифровкиКомпоновкиДанных(ДанныеРасшифровки, ИсточникНастроек);           
	ВыполненноеДействие = Неопределено;     
	ПараметрДействия = Неопределено;     
	ОбработкаРасшифровкиКД.ВыбратьДействие(Расшифровка, ВыполненноеДействие, ПараметрДействия);           
	Если ВыполненноеДействие <> ДействиеОбработкиРасшифровкиКомпоновкиДанных.Нет Тогда                       
		Если ВыполненноеДействие = ДействиеОбработкиРасшифровкиКомпоновкиДанных.ОткрытьЗначение Тогда                                   
			ОткрытьЗначение(ПараметрДействия);                             
		КонецЕсли;                  
	КонецЕсли;    
КонецПроцедуры
Показать


Бинго!
2. vain79 18.01.12 07:44 Сейчас в теме
Вопрос автору, итоги есть?
5. rasswet 82 25.01.12 13:33 Сейчас в теме
я знаю что если в отчетах управляемая форма а конфа обычная скажем ЗУП, формы не открываются эти. как тут? откроется?
6. Legavaz 704 25.01.12 15:38 Сейчас в теме
если обычное приложение то вы ничего не увидите, упр. приложение обязательно.
7. ulovka 10 26.01.12 02:15 Сейчас в теме
В УТ 11.0.7.13 в администрирование - дополнительные отчеты и обработки прописываю вашу обработку. Указываю раздел командного интерфейса, скажем для раздела администрирование. Далее пытаюсь вызвать через администрирование - дополнительные отчеты. Пишет "Дополнительные отчеты не предусмотрены для раздела: Раздел "Аминистрирование". В итоге получается запустить отчет только через файл-открыть. Что я делаю не так?
8. Legavaz 704 26.01.12 09:24 Сейчас в теме
в настоящее время обработка не может использоваться в спр. внешних обработок, в ближайшее время этот недочет будет устранен. Спасибо за комментарий.
9. ulovka 10 27.01.12 23:49 Сейчас в теме
(8)
Плюсую авансом, ждем доработанную версию.
10. пользователь 21.02.12 09:33
Сообщение было скрыто модератором.
...
11. Lizi60 08.03.12 12:42 Сейчас в теме
Конечно плюсую. Спасибо за красивый отчет.
12. Fanil 11.03.12 14:17 Сейчас в теме
Очень хорошая обработка Все работает ставим +
13. dex3 22.03.12 15:00 Сейчас в теме
При задании периода на сегодня ( например 20.03.12-20.03.12) дает не все документы ( например реализации), а если захватывать следующий день (20.03.12-21.03.12), до дает инфу всю за 20.0.3.12 и часть по 21.03.12.
14. Legavaz 704 22.03.12 22:39 Сейчас в теме
(13)ок, проверю и исправлю.
спасибо.
18. Naton 3 21.03.13 12:29 Сейчас в теме
(14)
Не создает реестр документов по перемещениям в Рознице 2.0
С чем это связано?
15. protlt 22.03.12 23:07 Сейчас в теме
Плюс. Намного лучше типового реестра.
16. ut2k5 15 21.04.12 20:09 Сейчас в теме
Автор, однозначно тебе респект. На текущий момент лучший реестр!
17. ut2k5 15 21.04.12 21:31 Сейчас в теме
Вставь нижеследующий код в модуль объекта твоего отчета
И получишь полноценно подключаемый внешний отчет (ут 11.0.7.19)
... (код писал на скоряк, больше копи-пастом, сильно не ругайте, не было времени)

//
// СЛУЖЕБНЫЕ ПРОЦЕДУРЫ И ФУНКЦИИ РЕГИСТРАЦИИ ОБРАБОТКИ
//

// Сервисная экспортная функция. Вызывается в основной программе при регистрации обработки в информационной базе
// Возвращает структуру с параметрами регистрации
//
// Возвращаемое значение:
//		Структура с полями:
//			Вид - строка, вид обработки, один из возможных: "ДополнительнаяОбработка", "ДополнительныйОтчет", 
//					"ЗаполнениеОбъекта", "Отчет", "ПечатнаяФорма", "СозданиеСвязанныхОбъектов"
//			Назначение - Массив строк имен объектов метаданных в формате: 
//					<ИмяКлассаОбъектаМетаданного>.[ * | <ИмяОбъектаМетаданных>]. 
//					Например, "Документ.СчетЗаказ" или "Справочник.*". Параметр имеет смысл только для назначаемых обработок, для глобальных может не задаваться.
//			Наименование - строка - Наименование обработки, которым будет заполнено наименование элемента справочника по умолчанию.
//			Информация  - строка - Краткая информация или описание по обработке.
//			Версия - строка - Версия обработки в формате “<старший номер>.<младший номер>” используется при загрузке обработок в информационную базу.
//			БезопасныйРежим - булево - Принимает значение Истина или Ложь, в зависимости от того, требуется ли устанавливать или отключать безопасный режим 
//							исполнения обработок. Если истина, обработка будет запущена в безопасном режиме. 
//
//
Функция СведенияОВнешнейОбработке() Экспорт
	
	//Инициализируем структуру с параметрами регистрации
	ТекстОписания	= "Реестр документов с возможностью СКД";
	
		
	ПараметрыРегистрации = ПолучитьПараметрыРегистрации(, "Реестр документов", ТекстОписания);
	ПараметрыРегистрации.Версия = "1.1";

	ТаблицаКоманд = ПолучитьТаблицуКоманд();

	ДобавитьКоманду(ТаблицаКоманд,
		"Реестр документов (универс.)",			// Представление команды в пользовательском интерфейсе
		"РеестрДокументов_СКД",					// Уникальный идентификатор команды
		"ОткрытиеФормы"
	);

	ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);

	Возврат ПараметрыРегистрации;

КонецФункции

//
// ВСПОМОГАТЕЛЬНЫЕ ПРОЦЕДУРЫ И ФУНКЦИИ РЕГИСТРАЦИИ ОБРАБОТКИ
//

// Формирует структуру с параметрами регистрации регистрации обработки в информационной базе
//
// Параметры:
//	ОбъектыНазначенияФормы - Массив - Массив строк имен объектов метаданных в формате: 
//					<ИмяКлассаОбъектаМетаданного>.[ * | <ИмяОбъектаМетаданных>]. 
//					или строка с именем объекта метаданных 
//	НаименованиеОбработки - строка - Наименование обработки, которым будет заполнено наименование элемента справочника по умолчанию.
//							Необязательно, по умолчанию синоним или представление объекта
//	Информация  - строка - Краткая информация или описание обработки.
//							Необязательно, по умолчанию комментарий объекта
//	Версия - строка - Версия обработки в формате “<старший номер>.<младший номер>” используется при загрузке обработок в информационную базу.
//
//
// Возвращаемое значение:
//		Структура
//
Функция ПолучитьПараметрыРегистрации(ОбъектыНазначенияФормы = Неопределено, НаименованиеОбработки = "", Информация = "", Версия = "1.0")

	Если ТипЗнч(ОбъектыНазначенияФормы) = Тип("Строка") Тогда
		ОбъектНазначенияФормы = ОбъектыНазначенияФормы;
		ОбъектыНазначенияФормы = Новый Массив;
		ОбъектыНазначенияФормы.Добавить(ОбъектНазначенияФормы);
	КонецЕсли; 
	
	ПараметрыРегистрации = Новый Структура;
	ПараметрыРегистрации.Вставить("Вид", "ДополнительныйОтчет");

	ПараметрыРегистрации.Вставить("БезопасныйРежим", Истина);
	ПараметрыРегистрации.Вставить("Назначение", ОбъектыНазначенияФормы);
	
	Если Не ЗначениеЗаполнено(НаименованиеОбработки) Тогда
		НаименованиеОбработки = ЭтотОбъект.Метаданные().Представление();
	КонецЕсли; 
	ПараметрыРегистрации.Вставить("Наименование", НаименованиеОбработки);
	
	Если Не ЗначениеЗаполнено(Информация) Тогда
		Информация = ЭтотОбъект.Метаданные().Комментарий;
	КонецЕсли; 
	ПараметрыРегистрации.Вставить("Информация", Информация);
	
	ПараметрыРегистрации.Вставить("Версия", Версия);

	Возврат ПараметрыРегистрации;

КонецФункции


// Формирует таблицу значений с командами печати
//	
// Возвращаемое значение:
//		ТаблицаЗначений
//
Функция ПолучитьТаблицуКоманд()

	Команды = Новый ТаблицаЗначений;
	
	//Представление команды в пользовательском интерфейсе
	Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
	
	//Уникальный идентификатор команды или имя макета печати
	Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
	
	//Способ вызова команды: "ОткрытиеФормы", "ВызовКлиентскогоМетода", "ВызовСерверногоМетода"
	// "ОткрытиеФормы" - применяется только для отчетов и дополнительных отчетов
	// "ВызовКлиентскогоМетода" - вызов процедуры Печать(), определённой в модуле формы обработки
	// "ВызовСерверногоМетода" - вызов процедуры Печать(), определённой в модуле объекта обработки
	Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
	
	//Показывать оповещение.
	//Если Истина, требуется показать оповещение при начале и при завершении работы обработки. 
	//Имеет смысл только при запуске обработки без открытия формы
	Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
	
	//Дополнительный модификатор команды. 
	//Используется для дополнительных обработок печатных форм на основе табличных макетов.
	//Для таких команд должен содержать строку ПечатьMXL
	Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));

	Возврат Команды;

КонецФункции

// Вспомогательная процедура.
//
Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование = "ОткрытиеФормы", ПоказыватьОповещение = Ложь, Модификатор = "ФормаОтчета")

	НоваяКоманда = ТаблицаКоманд.Добавить();
	НоваяКоманда.Представление = Представление;
	НоваяКоманда.Идентификатор = Идентификатор;
	НоваяКоманда.Использование = Использование;
	НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
	НоваяКоманда.Модификатор = Модификатор;

КонецПроцедуры
Показать
19. Naton 3 21.03.13 12:38 Сейчас в теме
Вопрос снят - при формировании отбора выбрала не тот реквизит
20. logarifm 1121 10.02.14 12:35 Сейчас в теме
Ошибка при выполнении файловой операции 'E:\data\1C_ERP-prof\Хомяк\FastReports\Other\РеестрДокументовУФ.erf'
по причине:
Неверный формат хранилища данных.

Платформа: 1С:Предприятие 8.3 (8.3.4.389)

Не открывается ни в конфигураторе ни в предприятии соответственно.
Оставьте свое сообщение