Запрос QueryBarcode в ЕГАИС 1.5 для Розницы 2.2.6

18.11.17

Интеграция - Обмен с ГосИС

Обработка решает проблему с нечитаемой маркой на крепком алкоголе.

Скачать исходный код

Наименование Файл Версия Размер
ЗапросМарки1.4 под Розница 2.2.5
.epf 7,63Mb
111
.epf 1.4 7,63Mb 111 Скачать
Запрос QueryBarcode в ЕГАИС 1.5 под Розница 2.2.6
.epf 7,63Mb
13
.epf 7,63Mb 13 Скачать

Версия 1.5 от 18.11.2017:

  • Добавлена версия под 2.2.6

Версия 1.4.1 от 03.01.2016:

  • Не правильная датамарка, вернулся тикет с отказом - Марки не прошли проверку

Версия 1.4 от 09.11.2016:

  • Исправлена ошибка " Ошибка работы с Интернет: ресурс не найден (404)"

Версия 1.3 от 08.11.2016:

  • Исправлена ошибка при получении марки (не правильный формат ip адреса)
  • Корректно обрабатывается ответ сервера 500 (ошибка в типе марки)
  • Добавлена возможность заполнять с помощью сканера в ТЗ и кнопка которая выбирает нужные данные
  • Мелкие изменения

Версия 1.2:

  • Добавлена возможность подключения через Дополнительные отчеты и Обработки (БСП)
  • Поле номер штрихкода заполняется случайным значением от 1 до 30
  • Убраны лишние кнопки
  • Добавлены проверки на заполнение ТЗ с датамарками

Версия 1.1:

  • Исправлена ошибка при разложении строки из текстового файла, теперь не нужно удалять - (тире)

Известные проблемы:

  1.   Вывод на печать для каждой марки на отдельную страницу
  2.   Если все же 404 ошибка, то заходите на страницу вашего утм, открывайте файл ответ который соответствует полю ID запроса шк например d019c231-1bf7-4eca-8519-a5e50726537b, внутри будет хмл файл с данными нам нужен длинный код, его копируем и вставляем в поле ШК в табличной части обработки (тз) нажимаем печать 

Инструкция:

Предназначена для 1С:Розница 2.2, хотя будет работать в любой конфигурации при ручном заполнении настроек.

  1. Заполнить настройки
  2. Сканируем datamatrix коды в текстовый файл (либо вводим руками)
  3. Загружаем коды в ТЗ
  4. Запрашиваем штрихкоды. (Ждем 5 минут)
  5. Нажимаем получить ответ, заполняется поле ШК
  6. Нажимаем печатать, клеим на бутылки, продаем.

Розница datamatrix

См. также

Раздельный учет по ГОЗ (Гособоронзаказу) в 1С: Бухгалтерия 3.0

Бюджетный учет Обмен с ГосИС Бухгалтерский учет 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 1С:Управление холдингом Государственные, бюджетные структуры Россия Бухгалтерский учет Бюджетный учет Платные (руб)

Управляйте учетной политикой раздельного учета ГОЗ в 1С:Бухгалтерия 3.0 ПРОФ/КОРП и УХ 3.2. Отчеты по исполнению госконтрактов, расчетно-калькуляционные материалы и контроль операций для исполнения в срок. Готовое расширение подходит для всех бухгалтеров и руководителей производства, помогая вести правильный учет по гособоронзаказу в соответствии 275-ФЗ. Профессиональный консалтинг и регулярные обновления продукта.

28.08.2020    207427    1679    vvmanannikov    132    

849

Гособоронзаказ: учет и отчетность 1С БП3.0 КОРП + ПРОФ + БИТ.ФИНАНС

Бюджетный учет Обмен с ГосИС Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Государственные, бюджетные структуры Россия Бухгалтерский учет Платные (руб)

Доработка конфигурации 1С: Бухгалтерия предприятия, редакция 3.0. Предназначена для ведения раздельного учета и автоматизации заполнения отчетности исполнения контрактов ГОЗ в конфигурациях 1С БП КОРП, ПРОФ, БИТ.ФИНАНС.

30000 руб.

16.08.2019    88882    209    85    

129

ЕГАИС++. Опт, производство, импорт

Оптовая торговля Розничная торговля Обмен с ГосИС Платформа 1С v8.3 1С:Управление торговлей 10 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Россия Бухгалтерский учет Управленческий учет Акцизы Платные (руб)

Полнофункциональное расширение (ранее известное как Модуль 1С-ЕГАИС) для взаимодействия типовых конфигураций 1С и ЕГАИС, предоставляющее максимум возможностей по работе с УТМ. Получение и отправка ТТН, отправка акта о постановке на баланс и акта о списании. Получение остатков. Загрузка и сопоставление номенклатуры и контрагентов. Оправка в ЕГАИС отчетов о производстве и импорте.

8970 руб.

15.12.2015    167315    724    362    

391

Обмен 1С с Честным Знаком для УТ11, УНФ, КА2, ERP, Розница: Расширение для работы с СУЗ, ГИС МТ, ЦРПТ

Обмен с ГосИС Платформа 1С v8.3 1С:Розница 2 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Платные (руб)

Полноценное интеграционное решение которое манипулирует сотнями задач по ведению учета в системе мониторинга честный знак, особенности: такие как полная поддержка учета карточек в национальном каталоге (модерация, редактирование, подписание, получение информации), получение кодов маркировок в станции управления заказами "СУЗ Облако", удобная отправка и получение "УПД" через систему "ЭДОЛайт" из документов реализации или корректировки, так же существует механизм приема через ЭДОЛайт, отправка и получения таких документов как перемаркировка , списание, отгрузка и еще более 40 типов документов в ГИСМТ которые описаны ниже, моментальное сопоставление и внедрение в типовую конфигурацию которое обеспечивает ракетную мега скорость ...

18000 руб.

28.03.2023    10973    38    9    

44

Интеграция ФГИС Зерно и 1С: обмен с системой через API для любых конфигураций (универсальная подсистема ХамелеонЗерно)

Обмен с ГосИС Платформа 1С v8.3 Конфигурации 1cv8 Оптовая торговля, дистрибуция, логистика Россия Управленческий учет Платные (руб)

Универсальная конфигурация ХамелеонЗерно для взаимодействия с системой ФГИС Зерно (тестовый+рабочий контур) может использоваться для интеграции в любую конфигурацию на базе 1С, версии ПРОФ и выше. Работа через API 1.0.5 и на API 1.0.7. Для удобства реализован общий интерфейс в виде обработки, схожей с интерфейсом ФГИС Зерно, но возможностей гораздо больше, т.к. при интеграции в Вашу учетную систему, можно на основании Ваших справочников и документов, создавать соответствующие документы и справочники в системе ФГИС Зерно и наоборот.

124800 руб.

27.06.2023    3282    23    0    

11

Обмен с системой ЦРПТ (Универсальная конфигурация ХамелеонЦРПТ + маркировка табака, обуви, одежды, лекарств, фото, молока, духов(парфюма), питьевой воды, велосипедов и шин)

Оптовая торговля Розничная торговля Обмен с ГосИС Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Бухгалтерский учет Управленческий учет Платные (руб)

Данная публикация создана для помощи разработчикам, интеграторам и другим заинтересованным лицам по настройке системы маркировки обуви, одежды, лекарств, табака, фото, молока, духов(парфюма), питьевой воды, велосипедов и шин. Смело задавайте нам вопросы по работе с ЦРПТ, GS1, ЭДО, Национальным каталогом, мы накопили достаточно большую базу знаний по данным темам и готовы ответить на все Ваши вопросы.

104000 руб.

18.03.2019    111100    36    114    

179

Обмен с системами Казначейства: Электронный бюджет

Обмен с ГосИС Платформа 1С v8.3 Бухгалтерский учет 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Обработка для обмена платежными документами в формате xml для системы Федерального казначейства "Электронный бюджет" из конфигураций 1С. Поставляется в двух вариантах для БП 3.0 и КА 2.х/ERP 2.х. Работа только с контрагентами.

15000 руб.

14.10.2020    59782    358    101    

282
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. ValeriTim 20 20.09.16 09:31 Сейчас в теме
"ФсайрАйди" .... :))))))

Спасибо. Хорошее начало дня :)
xx_34_xx; picoloz; coolseo; +3 Ответить
2. coolseo 79 20.09.16 12:23 Сейчас в теме
(1) ValeriTim, da, ya otlichno govory po angliski.
Vsegda pochalysita
3. xeephon 9 08.11.16 19:01 Сейчас в теме
Ошибка работы с Интернет: ресурс не найден (404)
4. coolseo 79 09.11.16 02:13 Сейчас в теме
(3) xeephon, хорошо, баг найден в неправильном разложении строки адреса для утм.
Исправлю, вышлю вам рабочию версию.
5. chinaski 18 09.11.16 16:45 Сейчас в теме
Кто нибудь пробовал распечатывать QR код и сканировать? Скачал обработку потому что самому не получалось правильно сделать, что бы подсмотреть формат штрихкода, формат не задается (высота, ширина), при таких настройках сканироваться не будут марки.
6. coolseo 79 10.11.16 02:19 Сейчас в теме
(5) chinaski, Здравствуйте, QR код отлично сканируется на разных сканерах, даже на дешевых китайцах.
Отличная идея вынести настройки ширины и высоты кода на форму.
7. chinaski 18 10.11.16 10:08 Сейчас в теме
(6) к сожалению нет возможности проверить вашу обработку, я всего лишь написал что при таком же коде формирования QR кода, сканер Datalogic 2430 не сканировал QR код. Только после внесения правок в ширину, высоты и ECL штрихкод нормально отсканировался.
8. intsolru 22.12.16 09:29 Сейчас в теме
Ошибка 404 в версии 1.4, получить марку не получилось
9. sokandr76 09.01.17 16:21 Сейчас в теме
В УТ 10.3 будет работать (обычные формы)?
10. coolseo 79 11.01.17 07:49 Сейчас в теме
11. tattoo_master 15 27.01.17 07:15 Сейчас в теме
Немного подправив и добавив Запрос QueryBarcode в саму конфигурацию УТ 10.3.39.1, обработка работает отлично из обычного приложения. Не плохо было бы добавить еще наименование алкогольной продукции и печать штрих кодов акцизных марок не каждый на своем листе а сколько влезет на лист.
12. coolseo 79 12.02.17 08:50 Сейчас в теме
(11) Скиньте мне на мыло, я ее выложу тут
biznesdv@yandex.ru
13. Herznaet 1 27.02.17 07:43 Сейчас в теме
В команде "pl" надо исправить:
Иначе
		//Получаем файл ответа 
	Соединение = Новый HTTPСоединение(УТМ1,Порт);     
	Соединение.Получить("/opt/out/ReplyBarcode/" + МассивПутьКХмлЗапрос[6] , РабочаяПапка + "otvet.xml");      
КонецЕсли;


А у автора /opt/out/Ticket/
14. user679005_denis_sds 27.02.17 11:50 Сейчас в теме
Ошибка работы с Интернет: ресурс не найден (404). Как обновиться?
15. user679005_denis_sds 27.02.17 11:52 Сейчас в теме
Есть ли ограничение на количество этих запросов?
16. coolseo 79 01.03.17 03:08 Сейчас в теме
(15) 100 шт в месяц или 1000. Не помню
17. tocv 19.06.17 13:03 Сейчас в теме
Процедуру у себя подправил.

Процедура ВывестиPDFКод(ТабДок, PDFСтрока, ДатаМарка ,ОбластьМакета)
	
	Если Не ПустаяСтрока(PDFСтрока) Тогда
		
		PDFКод = ДанныеPDF417(PDFСтрока);
		
		Если ТипЗнч(PDFКод) = Тип("ДвоичныеДанные") Тогда
			КартинкаPDFКода = Новый Картинка(PDFКод);
			ОбластьМакета.Рисунки.PDF417.Картинка = КартинкаPDFКода;
			Обл = ОбластьМакета.Область("ДатаМарка");
			Обл.Текст = ДатаМарка;
			ТабДок.Вывести(ОбластьМакета);
		Иначе
			ТекстСообщения ="Не удалось сформировать PDF-код.
				|Технические подробности см. в журнале регистрации.";
			Сообщить(ТекстСообщения);
		КонецЕсли;
		
	КонецЕсли;
	
Конецпроцедуры
Показать
18. tocv 19.06.17 13:04 Сейчас в теме
Вывод нескольких штрих кодов на листе

&НаКлиенте
Процедура ПечатьПДФ(Команда)
	Если СокрЛП(ЭлемТаб.Шк)<>"" Тогда	
       ТабДок = Новый ТабличныйДокумент;					   
	   Область = ПолучитьОбластьНаСервере();
	   Для каждого ЭлемТаб Из ШКмарки Цикл
	   	   		ВывестиPDFКод(ТабДок, ЭлемТаб.Шк, ЭлемТаб.ДатаМатрикс, Область);
		   КонецЦикла; 	   
	   ТабДок.Показать();
	   КонецЕсли;	   
КонецПроцедуры


Показать
19. tocv 19.06.17 13:09 Сейчас в теме
В модуле формы. Лишние процедуры убрать.
Оставить только
СведенияОВнешнейОбработке()
В форме у процедур и функций убрать Экспорт.
********************************************************
Чтобы исключить косяка при работе кассы.
20. tocv 19.06.17 13:12 Сейчас в теме
Добавить внешнее событие. Для сканера штрих кода.

&НаКлиенте
Процедура ВнешнееСобытие(Источник, Событие, Данные)
	
	Если ВводДоступен() Тогда
		
		IDЗапросШК="";
		
		ПодключаемоеОборудованиеРТКлиент.ВнешнееСобытиеОборудования(ЭтотОбъект, Источник, Событие, Данные);
	    //Сообщить("Источник="+СокрЛП(Источник)+"  Событие"+СокрЛП(Событие)+"  Данные="+СокрЛП(Данные));
					
		ДатаМарка = СокрЛП(Данные);
		
		Стр = ШКмарки.Добавить();
		Стр.ДатаМатрикс = ДатаМарка; 
		МассивДатаМарки	= РазборСтроки(ДатаМарка);
		Стр.Тип = МассивДатаМарки[0];
		Стр.Серия = МассивДатаМарки[1];
		Стр.Номер = МассивДатаМарки[2];
				
	КонецЕсли;
	
КонецПроцедуры

Показать
21. tocv 19.06.17 13:14 Сейчас в теме
Подключение компоненты взял из Розницы.

Функция КомпонентаФормированияШтрихкода(Отказ) 
	
	Отказ = ложь;
	
	ВнешняяКомпонента = МенеджерОборудованияСерверПовтИсп.ПодключитьВнешнююКомпонентуПечатиШтрихкода();
	
	Если ВнешняяКомпонента = Неопределено Тогда
		ВызватьИсключение НСтр("ru = 'Ошибка подключения внешней компоненты печати штрихкода!'");
	КонецЕсли;
	
	Возврат ВнешняяКомпонента;
	
КонецФункции

Показать
22. coolseo 79 19.06.17 14:44 Сейчас в теме
(21) Скиньте в личку вашу версию обработки, я выложу.
23. tocv 19.06.17 15:34 Сейчас в теме
Ок.
И еще в модуле в процедуре
СведенияОВнешнейОбработке()

Поправьте текст.
РегистрационныеДанные.Вставить("Наименование", "Запрос QueryBarcode в ЕГАИС 1.2");
РегистрационныеДанные.Вставить("БезопасныйРежим", Ложь);
РегистрационныеДанные.Вставить("Версия", "v 1.2");

У вас вроде в Заголовке форума написано v 1.4

Запрос QueryBarcode в ЕГАИС 1.4 от 03.01.2017

РабочуюПапку я под себя в двух местах указал.

*******************************************************************
Если скажете как в личке Файл, прикрепить. Сброшу.
*******************************************************************
24. user592309_wi.nikolaev 11.09.17 01:20 Сейчас в теме
подскажите в УТ 10.3 как запустить?
25. coolseo 79 11.09.17 01:26 Сейчас в теме
26. user592309_wi.nikolaev 11.09.17 03:24 Сейчас в теме
нажимаю открыть и ничего не происходит.
"Управление торговлей", редакция 10.3 (10.3.38.1)
27. Eco-hlado 05.10.17 12:28 Сейчас в теме
Добрый день. А нет ли возможности выводить при печати не только QR код, но и цифровой код датаматрикса? Т.к. не совсем понятно как потом безошибочно распределить распечатанные коды по бутылкам. И еще момент: сканер подключенный к 1с через эмуляцию компорта не выводит датаматрикс в данную обработку?
28. user841454 10.10.17 14:03 Сейчас в теме
Здравствуйте! Не заполняется параметры организации при нажатии кнопки Заполнить параметры УТМ, кнопка добавить тоже не активна. В настройках обмена с ЕГАИС магазин идет как торговый обьект, подумали может дело в этом. Розница 2.2.6.30. Прикрепил скриншоты. В чем может быть проблема
Прикрепленные файлы:
29. coolseo 79 10.10.17 14:54 Сейчас в теме
На этой неделе исправлю ошибку.
Оставьте почту скину новую версию, если сами не исправите.
30. user841454 13.10.17 11:10 Сейчас в теме
Здравствуйте.
Почта: d9197666453@yandex.ru
31. user841454 23.10.17 12:55 Сейчас в теме
Здравствуйте!
Обработка открылась, данные заполнились. Но при запросе выходит такая вот ошибка. Также очень долго ждем ответа. Как поступить?
Прикрепленные файлы:
32. coolseo 79 24.10.17 01:32 Сейчас в теме
(31) Проверьте, есть ли ответы в утм. Зайдите в ответ, посмотрите что там написано. Возможно что-то типо марка не прошла проверку, и обработка не корректно это обрабатывает.
33. user841454 30.10.17 14:00 Сейчас в теме
Здравствуйте!
Сегодня сделали пробный запрос на 2 бутылки. И вот такой ответ нам пришел. Что это может значить?
Прикрепленные файлы:
34. coolseo 79 31.10.17 09:38 Сейчас в теме
(33)Здравствуйте, чтобы получить развернутый ответ, нужно обратиться на форум фсрара.
Приложить фото марок и полный файлы ответов егаиса.

По вашей проблеме с этим сталкивался - просто списывал бутылки.
35. user841454 24.11.17 13:08 Сейчас в теме
Здравствуйте! Сегодня смогли сделать запрос. Два раза. Но на третий раз вот такая ошибка выходит. Вроде все правильно сканируем.
Прикрепленные файлы:
36. coolseo 79 24.11.17 13:20 Сейчас в теме
(35) Здравствуйте, удалите пустые строки в табличной части.
37. sokandr76 20.02.18 13:14 Сейчас в теме
Здравствуйте! Как скачать обновленную версию? Что-то у меня старая не работает, а только понадобилась. Покупал в январе, электронка computernets@mail.ru. Запрос, судя по всему, не уходит, хотя документы приходят, настройки одинаковые
Прикрепленные файлы:
38. sokandr76 20.02.18 16:51 Сейчас в теме
Нажимаю "Запросить ШК", тишина. В протоколе обмена запросов нет, ID запроса каждый раз новое. Что делаю не так?
39. coolseo 79 02.03.18 02:23 Сейчас в теме
(38) Отправил новую версию. Попробуйте пройтись отладчиком, скорее всего не создается хмл файл для отправки в утм.
40. sokandr76 02.03.18 08:55 Сейчас в теме
41. sokandr76 13.03.18 20:31 Сейчас в теме
Не получается
Прикрепленные файлы:
42. sokandr76 14.03.18 02:23 Сейчас в теме
Если правильно понял, используется "spisok.xml" как промежуточный файл. Почему он может не формироваться?
43. coolseo 79 14.03.18 07:19 Сейчас в теме
(42) Возможно вы работаете не под администратором этого windows.
Измените путь на другой.
Оставьте свое сообщение