IE 2017

Запрос QueryBarcode в ЕГАИС 1.4 от 03.01.2017

Печать - Ценники

Обработка решает проблему с нечитаемой маркой на крепком алкоголе.

Версия 1.4.1 от 03.01.2016:

  • Не правильная датамарка, вернулся тикет с отказом - Марки не прошли проверку

Версия 1.4 от 09.11.2016:

  • Исправлена ошибка " Ошибка работы с Интернет: ресурс не найден (404)"

Версия 1.3 от 08.11.2016:

  • Исправлена ошибка при получении марки (не правильный формат ip адреса)
  • Корректно обрабатывается ответ сервера 500 (ошибка в типе марки)
  • Добавлена возможность заполнять с помощью сканера в ТЗ и кнопка которая выбирает нужные данные
  • Мелкие изменения

Версия 1.2:

  • Добавлена возможность подключения через Дополнительные отчеты и Обработки (БСП)
  • Поле номер штрихкода заполняется случайным значением от 1 до 30
  • Убраны лишние кнопки
  • Добавлены проверки на заполнение ТЗ с датамарками

Версия 1.1:

  • Исправлена ошибка при разложении строки из текстового файла, теперь не нужно удалять - (тире)

Известные проблемы:

  1.   Вывод на печать для каждой марки на отдельную страницу
  2.   Если все же 404 ошибка, то заходите на страницу вашего утм, открывайте файл ответ который соответствует полю ID запроса шк например d019c231-1bf7-4eca-8519-a5e50726537b, внутри будет хмл файл с данными нам нужен длинный код, его копируем и вставляем в поле ШК в табличной части обработки (тз) нажимаем печать 

Инструкция:

Предназначена для 1С:Розница 2.2.4, хотя будет работать в любой конфигурации при ручном заполнении настроек.

  1. Заполнить настройки
  2. Сканируем datamatrix коды в текстовый файл (либо вводим руками)
  3. Загружаем коды в ТЗ
  4. Запрашиваем штрихкоды. (Ждем 5 минут)
  5. Нажимаем получить ответ, заполняется поле ШК
  6. Нажимаем печатать, клеим на бутылки, продаем.

Скачать файлы

Наименование Файл Версия Размер
ЗапросМарки1.4
.epf 7,63Mb
09.11.16
106
.epf 1.4 7,63Mb 106 Скачать

См. также

Комментарии
1. ValeriTim (ValeriTim) 20 20.09.16 09:31 Сейчас в теме
"ФсайрАйди" .... :))))))

Спасибо. Хорошее начало дня :)
picoloz; coolseo; +2 Ответить 1
2. Максим Радченко (coolseo) 31 20.09.16 12:23 Сейчас в теме
(1) ValeriTim, da, ya otlichno govory po angliski.
Vsegda pochalysita
3. Денис Бондаренко (xeephon) 5 08.11.16 19:01 Сейчас в теме
Ошибка работы с Интернет: ресурс не найден (404)
4. Максим Радченко (coolseo) 31 09.11.16 02:13 Сейчас в теме
(3) xeephon, хорошо, баг найден в неправильном разложении строки адреса для утм.
Исправлю, вышлю вам рабочию версию.
5. Артем Семенков (chinaski) 13 09.11.16 16:45 Сейчас в теме
Кто нибудь пробовал распечатывать QR код и сканировать? Скачал обработку потому что самому не получалось правильно сделать, что бы подсмотреть формат штрихкода, формат не задается (высота, ширина), при таких настройках сканироваться не будут марки.
6. Максим Радченко (coolseo) 31 10.11.16 02:19 Сейчас в теме
(5) chinaski, Здравствуйте, QR код отлично сканируется на разных сканерах, даже на дешевых китайцах.
Отличная идея вынести настройки ширины и высоты кода на форму.
7. Артем Семенков (chinaski) 13 10.11.16 10:08 Сейчас в теме
(6) coolseo, к сожалению нет возможности проверить вашу обработку, я всего лишь написал что при таком же коде формирования QR кода, сканер Datalogic 2430 не сканировал QR код. Только после внесения правок в ширину, высоты и ECL штрихкод нормально отсканировался.
8. Леонтий Самыгин (intsolru) 22.12.16 09:29 Сейчас в теме
Ошибка 404 в версии 1.4, получить марку не получилось
9. Андрей Соколенко (sokandr76) 09.01.17 16:21 Сейчас в теме
В УТ 10.3 будет работать (обычные формы)?
10. Максим Радченко (coolseo) 31 11.01.17 07:49 Сейчас в теме
11. Александр Самко (tattoo_master) 11 27.01.17 07:15 Сейчас в теме
Немного подправив и добавив Запрос QueryBarcode в саму конфигурацию УТ 10.3.39.1, обработка работает отлично из обычного приложения. Не плохо было бы добавить еще наименование алкогольной продукции и печать штрих кодов акцизных марок не каждый на своем листе а сколько влезет на лист.
12. Максим Радченко (coolseo) 31 12.02.17 08:50 Сейчас в теме
(11) Скиньте мне на мыло, я ее выложу тут
biznesdv@yandex.ru
13. Игорь Докучаев (Herznaet) 27.02.17 07:43 Сейчас в теме
В команде "pl" надо исправить:
Иначе
		//Получаем файл ответа 
	Соединение = Новый HTTPСоединение(УТМ1,Порт);     
	Соединение.Получить("/opt/out/ReplyBarcode/" + МассивПутьКХмлЗапрос[6] , РабочаяПапка + "otvet.xml");      
КонецЕсли;
...Показать Скрыть


А у автора /opt/out/Ticket/
14. Денис Дмитриев (user679005_denis_sds) 27.02.17 11:50 Сейчас в теме
Ошибка работы с Интернет: ресурс не найден (404). Как обновиться?
15. Денис Дмитриев (user679005_denis_sds) 27.02.17 11:52 Сейчас в теме
Есть ли ограничение на количество этих запросов?
16. Максим Радченко (coolseo) 31 01.03.17 03:08 Сейчас в теме
(15) 100 шт в месяц или 1000. Не помню
17. Юра Таенков (tocv) 19.06.17 13:03 Сейчас в теме
Процедуру у себя подправил.

Процедура ВывестиPDFКод(ТабДок, PDFСтрока, ДатаМарка ,ОбластьМакета)
	
	Если Не ПустаяСтрока(PDFСтрока) Тогда
		
		PDFКод = ДанныеPDF417(PDFСтрока);
		
		Если ТипЗнч(PDFКод) = Тип("ДвоичныеДанные") Тогда
			КартинкаPDFКода = Новый Картинка(PDFКод);
			ОбластьМакета.Рисунки.PDF417.Картинка = КартинкаPDFКода;
			Обл = ОбластьМакета.Область("ДатаМарка");
			Обл.Текст = ДатаМарка;
			ТабДок.Вывести(ОбластьМакета);
		Иначе
			ТекстСообщения ="Не удалось сформировать PDF-код.
				|Технические подробности см. в журнале регистрации.";
			Сообщить(ТекстСообщения);
		КонецЕсли;
		
	КонецЕсли;
	
Конецпроцедуры
...Показать Скрыть
18. Юра Таенков (tocv) 19.06.17 13:04 Сейчас в теме
Вывод нескольких штрих кодов на листе

&НаКлиенте
Процедура ПечатьПДФ(Команда)
	Если СокрЛП(ЭлемТаб.Шк)<>"" Тогда	
       ТабДок = Новый ТабличныйДокумент;					   
	   Область = ПолучитьОбластьНаСервере();
	   Для каждого ЭлемТаб Из ШКмарки Цикл
	   	   		ВывестиPDFКод(ТабДок, ЭлемТаб.Шк, ЭлемТаб.ДатаМатрикс, Область);
		   КонецЦикла; 	   
	   ТабДок.Показать();
	   КонецЕсли;	   
КонецПроцедуры


...Показать Скрыть
19. Юра Таенков (tocv) 19.06.17 13:09 Сейчас в теме
В модуле формы. Лишние процедуры убрать.
Оставить только
СведенияОВнешнейОбработке()
В форме у процедур и функций убрать Экспорт.
********************************************************
Чтобы исключить косяка при работе кассы.
20. Юра Таенков (tocv) 19.06.17 13:12 Сейчас в теме
Добавить внешнее событие. Для сканера штрих кода.

&НаКлиенте
Процедура ВнешнееСобытие(Источник, Событие, Данные)
	
	Если ВводДоступен() Тогда
		
		IDЗапросШК="";
		
		ПодключаемоеОборудованиеРТКлиент.ВнешнееСобытиеОборудования(ЭтотОбъект, Источник, Событие, Данные);
	    //Сообщить("Источник="+СокрЛП(Источник)+"  Событие"+СокрЛП(Событие)+"  Данные="+СокрЛП(Данные));
					
		ДатаМарка = СокрЛП(Данные);
		
		Стр = ШКмарки.Добавить();
		Стр.ДатаМатрикс = ДатаМарка; 
		МассивДатаМарки	= РазборСтроки(ДатаМарка);
		Стр.Тип = МассивДатаМарки[0];
		Стр.Серия = МассивДатаМарки[1];
		Стр.Номер = МассивДатаМарки[2];
				
	КонецЕсли;
	
КонецПроцедуры

...Показать Скрыть
21. Юра Таенков (tocv) 19.06.17 13:14 Сейчас в теме
Подключение компоненты взял из Розницы.

Функция КомпонентаФормированияШтрихкода(Отказ) 
	
	Отказ = ложь;
	
	ВнешняяКомпонента = МенеджерОборудованияСерверПовтИсп.ПодключитьВнешнююКомпонентуПечатиШтрихкода();
	
	Если ВнешняяКомпонента = Неопределено Тогда
		ВызватьИсключение НСтр("ru = 'Ошибка подключения внешней компоненты печати штрихкода!'");
	КонецЕсли;
	
	Возврат ВнешняяКомпонента;
	
КонецФункции

...Показать Скрыть
22. Максим Радченко (coolseo) 31 19.06.17 14:44 Сейчас в теме
(21) Скиньте в личку вашу версию обработки, я выложу.
23. Юра Таенков (tocv) 19.06.17 15:34 Сейчас в теме
Ок.
И еще в модуле в процедуре
СведенияОВнешнейОбработке()

Поправьте текст.
РегистрационныеДанные.Вставить("Наименование", "Запрос QueryBarcode в ЕГАИС 1.2");
РегистрационныеДанные.Вставить("БезопасныйРежим", Ложь);
РегистрационныеДанные.Вставить("Версия", "v 1.2");

У вас вроде в Заголовке форума написано v 1.4

Запрос QueryBarcode в ЕГАИС 1.4 от 03.01.2017

РабочуюПапку я под себя в двух местах указал.

*******************************************************************
Если скажете как в личке Файл, прикрепить. Сброшу.
*******************************************************************
24. wi.nikolaev (user592309_wi.nikolaev) 11.09.17 01:20 Сейчас в теме
подскажите в УТ 10.3 как запустить?
25. Максим Радченко (coolseo) 31 11.09.17 01:26 Сейчас в теме
26. wi.nikolaev (user592309_wi.nikolaev) 11.09.17 03:24 Сейчас в теме
нажимаю открыть и ничего не происходит.
"Управление торговлей", редакция 10.3 (10.3.38.1)
Оставьте свое сообщение