Набор внешних печатных форм и отчетов для "Розница 1" и "Розница 2.1/2.2"

06.03.17

Учетные задачи - Печатные формы

Накопилось большое количество доработок по конфигурациям "Розница", выкладываю для облегчения труда коллег.

Скачать исходный код

Наименование Файл Версия Размер
Печать ТТН (внешния)
.epf 27,23Kb
2
.epf 27,23Kb 2 Скачать
УПД - Реализация (внешняя)
.epf 31,77Kb
6
.epf 31,77Kb 6 Скачать
Поиск ссылок на объект - обычные формы
.erf 11,00Kb
1
.erf 11,00Kb 1 Скачать
Поиск ссылок на объект - управляемые формы
.erf 17,27Kb
1
.erf 17,27Kb 1 Скачать
Отчет по Выгрузке прайса (по складам)
.epf 8,98Kb
1
.epf 8,98Kb 1 Скачать
Отключение пользователей - обычные формы
.epf 16,63Kb
1
.epf 16,63Kb 1 Скачать
АктВыполненныхРабот - Розница 2 - док. Возврат из ремонта
.epf 13,65Kb
4
.epf 13,65Kb 4 Скачать
КвитанцияОПриемеВРемонт - Розница 2 (док. прием в ремонт)
.epf 15,02Kb
2
.epf 15,02Kb 2 Скачать
СчетНаОплату - Розница 2 - документ заказ покупателя
.epf 21,74Kb
9
.epf 21,74Kb 9 Скачать
Акт сверки взаиморасчетов - Розница 2
.erf 13,66Kb
6
.erf 13,66Kb 6 Скачать

Набор внешних печатных форм и отчетов для "Розница 1" и "Розница 2.1"

Соответственно, на чем эксплуатирую:

1) Розница 1  (релиз 1.0.14.4) -  "Обычные формы" / "толстый клиент"

Печатные формы:

- ТТН (для документов Реализация, ПеремещениеТоваров, РасходныйОрдерНаТовары)

- УПД  (для документов Реализация)

Отчеты/Обработки:

- Отчет по выгрузке прайса по складам и выгрузкой прайса для сайта в формате ТХТ с разделителями (Код, Наименование, Цена, Остаток, Свойства).

Функционал по выгрузке прайса закоментирован - для запуска выгрузке необходимо строку кода заменить на свою:     \\Текст.Записать(константы.ИмяФайлаОбмена.Получить(),КодировкаТекста.ANSI);) - путь к каталогу  выгрузки (константы.ИмяФайлаОбмена), например: "D:\1c\pr1.txt" 

- Поиск ссылок на объект (СКД - обычные формы) 

- Отключение пользователей (файловый режим - обычные формы, 8.2)

2) Розница 2.1 (2.1.8.16) - "Управляемые формы" / "тонкий клиент"

Печатные формы:

- АктВыполненныхРабот  - документ: Возврат из ремонта

- КвитанцияОПриемеВРемонт - Документ: Прием в ремонт

- СчетНаОплату  - Документ: Заказ покупателя

- Акт сверки взаиморасчетов

Отчеты/Обработки:

- Поиск ссылок на объект (СКД - управляемые формы) 

(как появится время, дополню публикацию - наработок много, в частности, добавлю выгрузку на сайт XML с картинками для обеих версий)

См. также

Автоматический заказ поставщику в 1С: загрузка прайсов и анализ цен поставщиков для УТ 10.3, УТ 11, КА2, УНФ, УПП, ERP, Розница 2

Бюджетирование и планирование Оптовая торговля Розничная торговля Логистика, склад и ТМЦ Анализ продаж Платформа 1С v7.7 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Беларусь Украина Россия Казахстан Управленческий учет Платные (руб)

Система управления запасами для 1С помогает работать с запасами правильно: автоматически рассчитывает потребность и делает заказ поставщику, загружает прайсы, перемещает товары по филиалам, анализирует продажи и позволяет управлять ассортиментом.

28500 руб.

21.04.2017    91870    116    40    

204

ККТ-ОНЛАЙН 54-ФЗ: Обработка для работы онлайн касс АТОЛ, ШТРИХ, VIKI PRINT и т.д. МАРКИРОВКА (Разрешит. режим) + ЭКВАЙРИНГ + БЕСПЛАТНЫЙ ДЕМО

ККМ Кассовые операции Розничная торговля Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия 1.6 1С:Бухгалтерия автономного учреждения 1С:CRM ПРОФ, КОРП Россия Платные (руб)

Универсальная обработка для обслуживания любых фискальных регистраторов (ККТ), в том числе Веб сервер АТОЛ. Работает в соответствии с 54-ФЗ. (ФФД 1.0, ФФД 1.05, ФФД 1.1). Подключайте любую онлайн кассу к практически любой конфигурации. Нет необходимости обновлять 1С. Можно бесплатно скачать и протестировать. Может работать одновременно с несколькими онлайн-кассами, либо одной с разных рабочих мест. (через RDP, TCP\IP или веб-сервер) Позволяет разделить один чек сразу на несколько ККТ или на несколько систем налогообложения. Поддерживает разрешительный режим. Можно настроить собственный шаблонов чека. Можно использовать эквайринг там, где он не поддерживается. Работает на LINUX и Windows ЭМУЛЯТОР + ЭКВАЙРИНГ + МАРКИРОВКА + ПОДДЕРЖКА ФФД 1.2

6000 руб.

27.02.2017    775070    4705    9505    

2800

ЕГАИС++. Опт, производство, импорт

Оптовая торговля Розничная торговля Обмен с ГосИС Платформа 1С v8.3 1С:Управление торговлей 10 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Россия Бухгалтерский учет Управленческий учет Акцизы Платные (руб)

Полнофункциональное расширение (ранее известное как Модуль 1С-ЕГАИС) для взаимодействия типовых конфигураций 1С и ЕГАИС, предоставляющее максимум возможностей по работе с УТМ. Получение и отправка ТТН, отправка акта о постановке на баланс и акта о списании. Получение остатков. Загрузка и сопоставление номенклатуры и контрагентов. Оправка в ЕГАИС отчетов о производстве и импорте.

8970 руб.

15.12.2015    167302    724    362    

391

Обмен с системой ЦРПТ (Универсальная конфигурация ХамелеонЦРПТ + маркировка табака, обуви, одежды, лекарств, фото, молока, духов(парфюма), питьевой воды, велосипедов и шин)

Оптовая торговля Розничная торговля Обмен с ГосИС Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Бухгалтерский учет Управленческий учет Платные (руб)

Данная публикация создана для помощи разработчикам, интеграторам и другим заинтересованным лицам по настройке системы маркировки обуви, одежды, лекарств, табака, фото, молока, духов(парфюма), питьевой воды, велосипедов и шин. Смело задавайте нам вопросы по работе с ЦРПТ, GS1, ЭДО, Национальным каталогом, мы накопили достаточно большую базу знаний по данным темам и готовы ответить на все Ваши вопросы.

104000 руб.

18.03.2019    111078    36    114    

179

Infostart PrintWizard - создание и редактирование печатных форм в 1С 8.3

Пакетная печать Печатные формы Инструментарий разработчика Платформа 1С v8.3 Запросы 1С:Зарплата и кадры бюджетного учреждения 1С:Конвертация данных 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 Платные (руб)

Инструмент, позволяющий абсолютно по-новому взглянуть на процесс разработки печатных форм. Благодаря конструктору можно значительно снизить затраты времени на разработку печатных форм, повысить качество и "прозрачность" разработки, а также навести порядок в многообразии корпоративных печатных форм.

18000 руб.

06.10.2023    9130    26    6    

49

Загрузка номенклатуры в УТ11, КА 2, ERP 2, Розница 2 из Excel. Дополнительные реквизиты и сведения, характеристики, картинки, цены, остатки

Загрузка и выгрузка в Excel Розничная торговля Логистика, склад и ТМЦ Ценообразование, анализ цен Прайсы Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Розница 2 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Платные (руб)

Загрузка номенклатуры из файлов Excel (xls, xlsx, ods, csv, mxl) в УТ11, КА 2, ERP 2, Розница 2. Задействованы все возможности конфигурации - заполнение реквизитов номенклатуры, дополнительных реквизитов и сведений, характеристики, доп.реквизиты и сведения характеристик. Дополнительные обработки для расширения возможностей.

10560 руб.

29.10.2014    212815    632    526    

447

54-ФЗ и Разрешительный режим. Обработки для подключения онлайн-касс к 1С 8 (поддержка Маркировки) + Эмулятор + ФФД 1.2

ККМ Кассовые операции Розничная торговля Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия автономного учреждения Россия Платные (руб)

Обработка осуществляет обслуживание ККТ АТОЛ, Штрих и Меркурий для конфигураций "УТ 10.3", "КА 1.1", "УПП 1.3", "Розница 1.0", "БП 2.0" и других отраслевых решений, построенных на основе указанных выше конфигурациях. Поддерживает возможность параллельно пробития чеков на одной ККМ несколькими пользователями. Поддерживает Веб-сервер Атол. Соответствует требованиям 54-ФЗ. Поддерживает ФФД 1.0, 1.05, 1.1 и 1.2. Разделяет чеки по нескольким СНО. Поддерживает механизмы подключения ККТ по TCP/IP, для работы через RDP или интернет. Поддержка маркировки и разрешительного режима.

5400 руб.

25.05.2015    322934    1857    3023    

1000
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Team leader 12 12.07.17 18:12 Сейчас в теме
Процедура ОЗТЧ заполнения Требования остатками (БП 3.0):

&НаСервере
Процедура ЗаполнитьПоОстаткамНаСервере()
	
	
	ЗаполнитьПоОстаткамНаСкладе_2();

	
КонецПроцедуры


&НаСервере
Процедура ЗаполнитьПоОстаткамНаСкладе_2() 
	
	ДокументОбъект = РеквизитФормыВЗначение("Объект");
	ДокументОбъект.Материалы.Очистить();

	ДокТ = ДокументОбъект; 
	
	ДанныеСклада = ОбщегоНазначения.ЗначенияРеквизитовОбъекта(ДокТ.Склад, "ТипСклада, ТипЦенРозничнойТорговли");
	//Определим настройки аналитического учета
	БУ = ПланыСчетов.Хозрасчетный.Товары.ПолучитьОбъект();
	ВестиСкладскойУчетБУ = БУ.ВидыСубконто.Найти(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Склады, "ВидСубконто") <> Неопределено;
	ВестиСуммовойУчетПоСкладамБУ = ?(ВестиСкладскойУчетБУ, 
	БУ.ВидыСубконто.Найти(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Склады, "ВидСубконто").Суммовой, Ложь);
	
	ТекстУсловияК = ?(ВестиСкладскойУчетБУ, "И Субконто2 В (&Склад)", "");
	ТекстУсловияС = ?(ВестиСуммовойУчетПоСкладамБУ, "И Субконто2 В (&Склад)", "");
	
	ПорядокСубконтоК = Новый Массив();
	ПорядокСубконтоК.Добавить(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Номенклатура);
	Если ВестиСкладскойУчетБУ Тогда
		ПорядокСубконтоК.Добавить(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Склады);
	КонецЕсли;
	
	ПорядокСубконтоС = Новый Массив();
	ПорядокСубконтоС.Добавить(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Номенклатура);
	Если ВестиСуммовойУчетПоСкладамБУ Тогда
		ПорядокСубконтоС.Добавить(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Склады);
	КонецЕсли;
	
	ПорядокСубконтоМОЛ = Новый Массив();
	ПорядокСубконтоМОЛ.Добавить(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Номенклатура);
	ПорядокСубконтоМОЛ.Добавить(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.РаботникиОрганизаций);
	
	МассивИсклСчетов = Новый Массив();
	МассивИсклСчетов.Добавить(ПланыСчетов.Хозрасчетный.МатериальныеЦенностиВЭксплуатации);
	МассивИсклСчетов.Добавить(ПланыСчетов.Хозрасчетный.ТоварыВРозничнойТорговлеВПродажныхЦенахНТТ);
	МассивИсклСчетов.Добавить(ПланыСчетов.Хозрасчетный.ТорговаяНаценкаАТТ);
	МассивИсклСчетов.Добавить(ПланыСчетов.Хозрасчетный.ТорговаяНаценкаНТТ);
	МассивИсклСчетов.Добавить(ПланыСчетов.Хозрасчетный.ГТД);
	
	Запрос = Новый Запрос;
	Запрос.УстановитьПараметр("Склад",		        ДокТ.Склад);
	Запрос.УстановитьПараметр("КонецПериода",	 	ДокТ.Дата);
	Запрос.УстановитьПараметр("Организация",	    ДокТ.Организация);
	Запрос.УстановитьПараметр("ВидСубконто",	    ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Склады);
	Запрос.УстановитьПараметр("ПорядокСубконтоК",	ПорядокСубконтоК);
	Запрос.УстановитьПараметр("ПорядокСубконтоС",	ПорядокСубконтоС);
	Запрос.УстановитьПараметр("ПорядокСубконтоМОЛ",	ПорядокСубконтоМОЛ);
	Запрос.УстановитьПараметр("ИсклСчета",	 		МассивИсклСчетов);
	ТекстЗапросаИнвентаризация = 
	"ВЫБРАТЬ
	|	Хозрасчетный.Ссылка КАК Счет
	|ПОМЕСТИТЬ ВТ_ИсклСчета
	|ИЗ
	|	ПланСчетов.Хозрасчетный КАК Хозрасчетный
	|ГДЕ
	|	Хозрасчетный.Ссылка В ИЕРАРХИИ(&ИсклСчета)
	|
	|ИНДЕКСИРОВАТЬ ПО
	|	Счет
	|;
	|
	|////////////////////////////////////////////////////////////­////////////////////
	|ВЫБРАТЬ
	|	ХозрасчетныйОстаткиК.Счет,
	|	ХозрасчетныйОстаткиК.Субконто1,
	|	ХозрасчетныйОстаткиК.КоличествоОстаток
	|ПОМЕСТИТЬ ХозрасчетныйОстаткиК
	|ИЗ
	|	РегистрБухгалтерии.Хозрасчетный.Остатки(&КонецПериода, , &ПорядокСубконтоК, Организация В (&Организация) " 
	+ ТекстУсловияК + ") КАК ХозрасчетныйОстаткиК
	|;									
	|
	|////////////////////////////////////////////////////////////­////////////////////
	|ВЫБРАТЬ
	|	ХозрасчетныйОстаткиС.Счет,
	|	ХозрасчетныйОстаткиС.Субконто1,
	|	ХозрасчетныйОстаткиС.СуммаОстаток,
	|	ХозрасчетныйОстаткиС.КоличествоОстаток
	|ПОМЕСТИТЬ ХозрасчетныйОстаткиС
	|ИЗ
	|РегистрБухгалтерии.Хозрасчетный.Остатки(&КонецПериода, , &ПорядокСубконтоС, Организация В (&Организация) " 
	+ ТекстУсловияС + ") КАК ХозрасчетныйОстаткиС
	|;
	|
	|////////////////////////////////////////////////////////////­////////////////////
	|ВЫБРАТЬ
	|	ХозрасчетныйОстаткиК.Счет КАК Счет,
	|	ХозрасчетныйОстаткиК.Счет.Порядок КАК Порядок,
	|	ХозрасчетныйОстаткиК.Субконто1 КАК Номенклатура,
	|	ХозрасчетныйОстаткиК.Субконто1.ЕдиницаИзмерения КАК ЕдиницаИзмерения,
	|	ЕСТЬNULL(ХозрасчетныйОстаткиС.СуммаОстаток, 0) КАК СуммаВсего,
	|	ЕСТЬNULL(ХозрасчетныйОстаткиС.КоличествоОстаток, 0) КАК КоличествоВсего,
	|	ЕСТЬNULL(ХозрасчетныйОстаткиК.КоличествоОстаток, 0) КАК Количество
	|ИЗ
	|	ХозрасчетныйОстаткиК КАК ХозрасчетныйОстаткиК
	|		ЛЕВОЕ СОЕДИНЕНИЕ ХозрасчетныйОстаткиС КАК ХозрасчетныйОстаткиС
	|		ПО ХозрасчетныйОстаткиК.Счет = ХозрасчетныйОстаткиС.Счет
	|			И ХозрасчетныйОстаткиК.Субконто1 = ХозрасчетныйОстаткиС.Субконто1
	|ГДЕ
	|	НЕ ХозрасчетныйОстаткиК.Счет В
	|				(ВЫБРАТЬ
	|					ВТ_ИсклСчета.Счет
	|				ИЗ
	|					ВТ_ИсклСчета)";
	
	Если НЕ ЗначениеЗаполнено(ДокТ.Склад)  Тогда
		ТекстЗапросаИнвентаризация = ТекстЗапросаИнвентаризация + "
		|
		|ОБЪЕДИНИТЬ ВСЕ
		|
		|ВЫБРАТЬ
		|	ХозрасчетныйОстатки.Счет,
		|	ХозрасчетныйОстатки.Счет.Порядок,
		|	ХозрасчетныйОстатки.Субконто1,
		|	ХозрасчетныйОстатки.Субконто1.ЕдиницаИзмерения,
		|	ЕСТЬNULL(ХозрасчетныйОстатки.СуммаОстаток, 0),
		|	ЕСТЬNULL(ХозрасчетныйОстатки.КоличествоОстаток, 0),
		|	ЕСТЬNULL(ХозрасчетныйОстатки.КоличествоОстаток, 0)
		|ИЗ
		|	РегистрБухгалтерии.Хозрасчетный.Остатки(&КонецПериода, , &ПорядокСубконтоМОЛ, Организация В (&Организация) И Субконто2 В (&МОЛ)) КАК ХозрасчетныйОстатки
		|
		|ГДЕ
		|  НЕ (ХозрасчетныйОстатки.Счет В (ВЫБРАТЬ
		|					ВТ_ИсклСчета.Счет
		|				ИЗ
		|					ВТ_ИсклСчета))
		|";
	КонецЕсли;
	ТекстЗапросаИнвентаризация = ТекстЗапросаИнвентаризация + "
	|
	|УПОРЯДОЧИТЬ ПО
	|	Порядок";
	
	Запрос.Текст = ТекстЗапросаИнвентаризация;
	
	Выборка = Запрос.Выполнить().Выбрать();
	
	Пока Выборка.Следующий() Цикл
		
		Если Выборка.Количество <= 0 Тогда
			Продолжить;
		КонецЕсли;
		
		СтрокаТабличнойЧасти = ДокТ.Материалы.Добавить();
		
		СтрокаТабличнойЧасти.Номенклатура   = Выборка.Номенклатура;
		СтрокаТабличнойЧасти.Количество     = Выборка.Количество;
		СтрокаТабличнойЧасти.Счет	    = Выборка.Счет;
		СтрокаТабличнойЧасти.Количество = СтрокаТабличнойЧасти.Количество;
		
		//		Цена = ?(Выборка.КоличествоВсего = 0, 0, Выборка.СуммаВсего / Выборка.КоличествоВсего);
		//		
		//		СтрокаТабличнойЧасти.Сумма     = СтрокаТабличнойЧасти.СуммаУчет;
		////		СтрокаТабличнойЧасти.Цена      = Цена;
		
		//		Если ДанныеСклада.ТипСклада = Перечисления.ТипыСкладов.НеавтоматизированнаяТорговаяТочка Тогда
		//			СтрокаТабличнойЧасти.ЦенаВРознице = Ценообразование.ПолучитьЦенуНоменклатуры(СтрокаТабличнойЧасти.Номенклатура,
		//				ДанныеСклада.ТипЦенРозничнойТорговли, Дата, Константы.ВалютаРегламентированногоУчета.Получить(), 1, 1);
		//		КонецЕсли;
		
	КонецЦикла;
	
	ЗначениеВРеквизитФормы(ДокументОбъект, "Объект");
	
	
КонецПроцедуры
Показать
2. silver-747 23.11.17 03:08 Сейчас в теме
Акт сверки взаиморасчетов формируется только по поставщикам или по покупателям тоже?
3. Team leader 12 16.05.19 20:41 Сейчас в теме
4. Team leader 12 16.05.19 20:46 Сейчас в теме
Еще вариант
Прикрепленные файлы:
файлы.rar
Оставьте свое сообщение