Заполнение документа Установка цен номенклатуры по себестоимости предыдущего месяца. БП ред. 3.0

18.04.19

Учетные задачи - Ценообразование, анализ цен

Внешняя обработка заполнения документа "Установка цен номенклатуры" ценами, которые рассчитаны по себестоимости продукции, выпущенной в предыдущем месяце.

Скачать исходный код

Наименование Файл Версия Размер
Заполнение документа Установка цен номенклатуры по себестоимости предыдущего месяца. БП ред. 3.0:
.epf 9,18Kb
10
.epf 9,18Kb 10 Скачать

В начале каждого месяца вводится документ "Установка цен номенклатуры", который актуализирует плановые цены на номенклатурные позиции, выпускавшиеся в предыдущем месяце. Эта внешняя обработка автоматически заполняет документ "Установка цен номенклатуры" ценами, которые рассчитаны по себестоимости продукции, выпущенной в предыдущем месяце.

Ниже приведена процедура расчета цены.


&НаСервере
// Процедура заполнения цен по себестоимости предыдущего месяца
//
Процедура ЗаполнитьЦеныПоСебенстоимости(пОбъект, ИмяТабличнойЧасти)
	
	Если пОбъект.Товары.Количество() > 0 Тогда
		пОбъект.Товары.Очистить();
	КонецЕсли;
		
	лЗапрос = Новый Запрос;
	лЗапрос.Текст = "ВЫБРАТЬ
	                |	Выпуск.НоменклатураВыпуска КАК Номенклатура,
	                |	МАКСИМУМ(ЕСТЬNULL(Выпуск.КоличествоВыпуска, 0)) КАК Количество,
	                |	МАКСИМУМ(ЕСТЬNULL(Выпуск.СуммаВыпуска, 0)) КАК Сумма,
	                |	ВЫБОР
	                |		КОГДА ЕСТЬNULL(Выпуск.КоличествоВыпуска, 0) = 0
	                |			ТОГДА ЕСТЬNULL(Выпуск.СуммаВыпуска, 0)
	                |		ИНАЧЕ ЕСТЬNULL(Выпуск.СуммаВыпуска, 0) / ЕСТЬNULL(Выпуск.КоличествоВыпуска, 0)
	                |	КОНЕЦ КАК Цена,
	                |	&Валюта
	                |ИЗ
	                |	(ВЫБРАТЬ
	                |		ХозрасчетныйОбороты.Подразделение КАК ПодразделениеВыпуска,
	                |		ХозрасчетныйОбороты.Субконто1 КАК НоменклатурнаяГруппаВыпуска,
	                |		ХозрасчетныйОбороты.КорСубконто1 КАК НоменклатураВыпуска,
	                |		ХозрасчетныйОбороты.СуммаОборотКт КАК СуммаВыпуска,
	                |		ХозрасчетныйОбороты.СуммаОборотКт КАК ОбщаяСуммаВыпуска,
	                |		-ХозрасчетныйОбороты.КоличествоКорОборот КАК КоличествоВыпуска
	                |	ИЗ
	                |		РегистрБухгалтерии.Хозрасчетный.Обороты(&НачДата, &КонДата, , Счет В ИЕРАРХИИ (&СчетПрямЗатрат), , Организация = &Организация, (НЕ КорСчет В ИЕРАРХИИ (&Счет90)), ) КАК ХозрасчетныйОбороты
	                |	ГДЕ
	                |		ХозрасчетныйОбороты.СуммаОборотКт <> 0) КАК Выпуск
	                |
	                |СГРУППИРОВАТЬ ПО
	                |	Выпуск.НоменклатураВыпуска,
	                |	ВЫБОР
	                |		КОГДА ЕСТЬNULL(Выпуск.КоличествоВыпуска, 0) = 0
	                |			ТОГДА ЕСТЬNULL(Выпуск.СуммаВыпуска, 0)
	                |		ИНАЧЕ ЕСТЬNULL(Выпуск.СуммаВыпуска, 0) / ЕСТЬNULL(Выпуск.КоличествоВыпуска, 0)
	                |	КОНЕЦ
	                |
	                |УПОРЯДОЧИТЬ ПО
	                |	Номенклатура";				
					
	лЗапрос.УстановитьПараметр("Валюта", Константы.ВалютаРегламентированногоУчета.Получить());
	
	СписокСчетов = Новый Массив;
	СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.ОсновноеПроизводство);
	СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.ВспомогательныеПроизводства);
	
	ДатаНач = НачалоМесяца(ДобавитьМесяц(пОбъект.Дата, -1));
    ДатаКон = КонецМесяца(ДобавитьМесяц(пОбъект.Дата, -1));
	лЗапрос.УстановитьПараметр("НачДата",     Новый Граница(НачалоДня(ДатаНач), ВидГраницы.Включая));
	лЗапрос.УстановитьПараметр("КонДата",     Новый Граница(КонецДня(ДатаКон),  ВидГраницы.Включая));
	лЗапрос.УстановитьПараметр("Организация", БухгалтерскийУчетПереопределяемый.ПолучитьЗначениеПоУмолчанию("ОсновнаяОрганизация"));
    лЗапрос.УстановитьПараметр("СчетПрямЗатрат",  СписокСчетов);
	
	СписокСчетов90 = Новый Массив;
	СписокСчетов90.Добавить(ПланыСчетов.Хозрасчетный.Продажи_РасходыНаПродажу);
	СписокСчетов90.Добавить(ПланыСчетов.Хозрасчетный.Продажи_УправленческиеРасходы);
    лЗапрос.УстановитьПараметр("Счет90",  СписокСчетов90);
	
	Выборка = лЗапрос.Выполнить().Выбрать();
	Пока Выборка.Следующий() Цикл
		СтруктураОтбора = Новый Структура();
		СтруктураОтбора.Вставить("Номенклатура", Выборка.Номенклатура);
		
		СтрокаТабличнойЧасти = ОбработкаТабличныхЧастейКлиентСервер.НайтиСтрокуТабЧасти(пОбъект, "Товары", СтруктураОтбора);
		
		Если СтрокаТабличнойЧасти = Неопределено Тогда
			
			СтрокаТабличнойЧасти = пОбъект.Товары.Добавить();
			СтрокаТабличнойЧасти.Номенклатура = Выборка.Номенклатура;
			
		КонецЕсли;
		
		СтрокаТабличнойЧасти.Цена = Выборка.Цена;;
		СтрокаТабличнойЧасти.Валюта =  Выборка.Валюта;
		
	КонецЦикла;
		
КонецПроцедуры

Тестировалось на релизе БП 3.0 (3.0.69.35). 

обработка заполнение цены бухгалтерия себестоимость продукция

См. также

Загрузка номенклатуры из Excel в УТ11, КА 2, ERP 2, Розница 2. Дополнительные реквизиты и сведения, характеристики, картинки, цены, остатки

Загрузка и выгрузка в Excel Розничная торговля Логистика, склад и ТМЦ Ценообразование, анализ цен Прайсы Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Розница 2 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Платные (руб)

Загрузка из файлов xls, xlsx, ods, csv, mxl в УТ11, КА 2, ERP 2, Розница 2. Задействованы все возможности конфигурации - заполнение реквизитов номенклатуры, дополнительных реквизитов и сведений, характеристики, доп.реквизиты и сведения характеристик. Дополнительные обработки для расширения возможностей.

10560 руб.

29.10.2014    212752    632    526    

447

Загрузка номенклатуры c картинками (несколько потоков одновременно) и сопутствующими данными в базу и любые документы из yml, xls, xlsx, xlsm, ods, ots, csv для УТ 10.3, УТ 11 (все), БП 3, КА 2, ERP 2, УНФ 1.6/3.0, Розница 2

Загрузка и выгрузка в Excel Логистика, склад и ТМЦ Ценообразование, анализ цен Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Платные (руб)

Эволюция не стоит на месте - новая удобная версия функциональной обработки для Вашего бизнеса! Что же Вы получаете? Удобный и интуитивно понятный интерфейс с 3-мя этапами работы. 2 режима - автоматический и ручной. Чтение XLSX, XLSM, CSV, XML/YML форматов без офиса, на любом сервере! Визуальное связывание колонок файла и реквизитов простым перетаскиванием колонок. Создание или обновление номенклатуры с иерархией, характеристик, доп. реквизитов, упаковок, загрузка практически неограниченного количества картинок на одну номенклатуру (с возможностью загрузки в несколько потоков одновременно), с хранением в томах или в базе. Загрузка номенклатуры поставщиков или поиск по их данным номенклатуры. Загрузка доп. реквизитов в характеристики. Загрузка штрихкодов с генерацией новых. Создание элементов справочников и ПВХ "на лету" для выбранных реквизитов. (Обновление от 09.04.2024, версия 9.9 - 9.10)

14400 руб.

20.11.2015    152397    370    376    

505

Универсальная загрузка остатков и цен поставщиков в 1С (УТ 11, КА 2, ERP 2.0) из файлов Excel, CSV, XML (YML и CML)

Прайсы Оптовая торговля Розничная торговля Ценообразование, анализ цен Файловый обмен (TXT, XML, DBF), FTP Загрузка и выгрузка в Excel Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Платные (руб)

Обработка позволяет легко настроить загрузку прайс-листов и остатков поставщиков. Форматы файлов задаются для каждого поставщика отдельно. В настройках предусмотрена возможность гибкой обработки входящих данных (убрать лишние символы, пересчитать цены в другую валюту, сделать произвольную наценку и т.д.).

18000 руб.

23.01.2017    59245    65    48    

69

Простое ценообразование (установка цен номенклатуры) для 1С 8.3 (УТ 11 / ERP 2 / КА 2 / Розница 2) + (УТ 10.3 / УПП / КА 1 / Розница 1)

Оптовая торговля Розничная торговля Ценообразование, анализ цен Платформа 1С v8.3 Управляемые формы 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:CRM ПРОФ, КОРП Управленческий учет Платные (руб)

Есть проблемы с расчетом и установкой цен на товары? Универсальная подсистема для ценообразования в 1С поможет навести порядок с ценами! Механизм позволяет задавать произвольные правила расчета колонок цен для разных групп товаров и легко их изменять. Может автоматически (по расписанию) обновлять цены в 1С и выполнять проверку наличия и корректности цен на все товары.

30000 руб.

13.11.2017    78228    40    11    

46

"Мобильный ТСД" - инвентаризация и сбор штрихкодов для iOS и Android

Сканер штрих-кода Терминал сбора данных Мобильная разработка Монитор заказов Оптовая торговля Розничная торговля Ценообразование, анализ цен Платформа 1С v8.3 Мобильная платформа 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Управленческий учет Платные (руб)

Простой мобильный терминал сбора данных для смартфонов на iOS и Android, не требующий сложных настроек и установки дополнительных программ. Обмен между Вашей 1С и мобильным приложением осуществляется через облачный сервис и расширение конфигурации. Работает с конфигурациями УТ 11, ERP, КА2, Розница 2, Розница 3, УНФ 1.6, УНФ 3.0. Полнофункциональный демо-доступ для своей конфигурации можно запросить в настройках мобильного приложения - все необходимое придет на почту автоматически.

2000 руб.

22.04.2019    92988    532    186    

302

Автоматический подбор и заполнение ГТД для 1С:Бухгалтерия предприятия 8, редакция 3.0 (платформа 8.2 и 8.3)

Операции по ВЭД Оптовая торговля Розничная торговля Логистика, склад и ТМЦ Мастера заполнения Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

СКАЧАЙТЕ И ПОПРОБУЙТЕ БЕСПЛАТНО! Данная обработка расширяет функционал типовой конфигурации «1С:Бухгалтерия предприятия» и позволяет осуществлять автоматическое заполнение ГТД в документах «Реализация товаров и услуг», «Списание товаров», «Отчет о розничных продажах», «Отчет комиссионера (агента) о продажах», «Требование-накладная», «Возврат товаров от покупателя», «Комплектация номенклатуры», «Безвозмездная передача», «Отчет производства за смену». Обработка предназначена для работы в конфигурации «1С:Бухгалтерия предприятия 8, редакция 3.0» Есть версия обработки оптимизированная для работы в 1CFresh

8280 руб.

19.06.2012    137299    253    81    

216
Оставьте свое сообщение