Оптовая торговля. Обработки дистрибьютора для обмена с поставщиками и покупателями через Excel в 1С 7.7

08.09.19

Учетные задачи - Оптовая торговля

В данной публикации приведены примеры обработок обмена дистрибьютора с поставщиками и покупателями через Эксель. Создание товаров-новинок. Автоматическое формирование Заказа поставщику по продажам. Заполнение бланка заказа поставщику. Загрузка приходной накладной от поставщика. Загрузка любых справочников из Эксель, например товарных сертификатов. Выгрузка прайслиста в бланк заказа (создание бланка заказа). Загрузка заявки покупателя из произвольного файла Эксель. Загрузка заявки покупателя из бланка заказа.. Для работы требуется установленный MS Excel.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
1) Создание товаров-новинок из Эксель.
.ert 117,50Kb
1
1
1 SM
Скачать Купить за 1 850 руб.
2) Автоматическое формирование Заказа поставщику по продажам (планирование закупки).
.ert 124,00Kb
0
0
1 SM
Скачать Купить за 1 850 руб.
3) Заполнение бланка Эксель из заказа поставщику.
.ert 116,00Kb
2
2
1 SM
Скачать Купить за 1 850 руб.
4) Загрузка приходной накладной по штрихкоду поставщика.
.ert 118,50Kb
0
0
1 SM
Скачать Купить за 1 850 руб.
5) Загрузка приходной накладной по артикулу поставщика.
.ert 117,50Kb
1
1
1 SM
Скачать Купить за 1 850 руб.
6) Загрузка любых справочников из Эксель (например товарных сертификатов).
.ert 59,50Kb
2
2
1 SM
Скачать Купить за 1 850 руб.
7) Выгрузка прайслиста в бланк заказа покупателя Эксель.
.ert 127,00Kb
0
0
1 SM
Скачать Купить за 1 850 руб.
8) Загрузка заявки покупателя из произвольного файла Эксель.
.ert 117,00Kb
1
1
1 SM
Скачать Купить за 1 850 руб.
9) Загрузка заявки покупателя из бланка заказа покупателя Эксель.
.ert 124,00Kb
0
0
1 SM
Скачать Купить за 1 850 руб.
10) Объединение несколько заявок в одну с подбором по указанным реквизитам.
.ert 118,00Kb
1
1
1 SM
Скачать Купить за 1 850 руб.
11) Деление заявки по указанным признакам.
.ert 114,50Kb
1
1
1 SM
Скачать Купить за 1 850 руб.
12) Сравнение заказа поставщику с файлом поступления.
.ert 114,50Kb
0
0
1 SM
Скачать Купить за 1 850 руб.
13) Печать перечня сертификатов.
.ert 115,00Kb
1
1
1 SM
Скачать Купить за 1 850 руб.

Производитель, прибегая к услугам дистрибьютора, при совместном соглашении определяет цену, рынок, сроки реализации, условия расчета за товары. Заключая договор с производителем на реализацию товара, дистрибьютор становится его полномочным представителем. Дистрибьютор - это торговец, предоставляющий свою территориально-разветвленную сеть распределительных центров сбыта продукции  товаропроизводителю.

Обработки для дистрибьютора написаны в комплексной конфигурации 4.2 (7.70.424). Версия платформы 7.70.027. Для работы требуется установленный MS Excel. Используется COMОбъект("Excel.Application").

1) Создание товаров-новинок из Эксель.
2) Автоматическое формирование Заказа поставщику по продажам (планирование закупки).
3) Заполнение бланка Эксель из заказа поставщику. Количество проставляется в строку соответствующую считанному из Эксель с помощью поиска штрихкоду или артикулу.
4) Загрузка приходной накладной по штрихкоду поставщика.
5) Загрузка приходной накладной по артикулу поставщика.
6) Загрузка любых справочников из Эксель (в том числе товарных сертификатов).
7) Выгрузка прайслиста в бланк заказа Эксель.
8) Загрузка заявки покупателя из произвольного файла Эксель. Количество проставляется в строку соответствующую считанному из Эксель с помощью поиска штрихкоду или артикулу.
9) Загрузка заявки покупателя из бланка заказа Эксель (бланк сохранен ранее, см.п.7). Количество проставляется в строку соответствующую считанному из Эксель с помощью поиска штрихкоду или артикулу.
10) Объединение несколько заявок в одну с подбором по указанным реквизитам.
11) Деление заявки по указанным признакам.
12) Сравнение заказа поставщику с файлом поступления.
13) Печать перечня сертификатов

Обработка автоматического формирования Заказа поставщику по продажам (планирование закупки) - скрин и пример запуска.

 
 Пример вызова обработки автоматического формирования Заказа поставщику по продажам (планирование закупки).

Заполнения бланка Эксель из заказа поставщику - скрин и пример запуска.

 
 Пример запуска заполнения бланка Эксель из заказа поставщику.

Сравнение заказа поставщику с файлом поступления - скрин и пример запуска.

 
 Пример запуска обработки сравнения заказа поставщику с файлом поступления.

При сохранении файла прайс-листа (кнопка старый) выводится печатная форма 1С с иерархией.

При сохранении файла прайс-листа (кнопка новый) выводится заполняется иерархия в шаблоне Эксель, проставляются формулы автоматического расчета суммы при вводе количества. На основании заполненного шаблона с проставленным количеством автоматически создаются заявки покупателя.

Загрузка заявки покупателя из бланка заказа Эксель (сам бланк сохранен ранее, см.п.7 проиллюстрирован на данном скриншоте выше) выполняется во внешней обработке как показано на следующих скриншотах. Сначала открываем обработку (см. п.9, Загрузка заявки покупателя из бланка заказа Эксель), выбираем контрагента.

Затем проверяем товар, выбираем какой товар попадет в заявку а какой не попадет.

Затем нажимаем сформировать, получаем созданную заявку покупателя.

13) Печать перечня сертификатов

обработка Excel покупатель поставщик

См. также

Бюджетирование и планирование Оптовая торговля Розничная торговля Логистика, склад и ТМЦ Анализ продаж Пользователь Платформа 1С v7.7 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Беларусь Украина Россия Казахстан Управленческий учет Платные (руб)

Система управления запасами для 1С помогает работать с запасами правильно: автоматически рассчитывает потребность и делает заказ поставщику, загружает прайсы, перемещает товары по филиалам, анализирует продажи и позволяет управлять ассортиментом.

28500 руб.

21.04.2017    93618    119    40    

210

Оптовая торговля Розничная торговля ККМ ЭДО и ОФД Обмен с ГосИС Системный администратор Программист Оперативный учет 7.7 Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 1С:Комплексная 7.7 1С:Торговля и склад 7.7 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Платные (руб)

Подключение фискального регистратора к 1С 7.7 в режиме онлайн-кассы (в соответствии с 54-ФЗ). Поддержка крайних версий драйверов ККТ: ДТО 10 и ДТО 8 для Атол, 4.15, 5.16 для Штрих-М. Поддержка протоколов ФФД 1.0, 1.05, 1.1 и 1.2, развитые настройки для применения частичных оплат и авансов в оптовой и розничной торговле. Поддержка чеков коррекции всех версий. Поддержка розничной продажи маркированной продукции (ЕГАИС, табак, обувь, лекарства, шины, одежда, белье, парфюмерия, молочная продукция, вода и пр.). Вывод электронного чека (на е-майл, телефон) по требованию покупателя, поддерживаются комбинированные типы оплаты, режим эмуляции печати чека на ФР. Полный цикл работы из 1С 7.7 с маркировкой Честный ЗНАК (ГИСМТ, ЦРПТ) из 1С 7.7. ЭДО (табак, обувь, шины, одежда, молочная продукция, вода и прочие группы товаров) для розницы и опта (приемка и оптовая отгрузка маркированной продукции). Поддерживается как объемно-сортовой учет (ОСУ) так и поштучный (поэкземплярный) учет.

2000 руб.

28.03.2017    472145    4333    3473    

2443

Оптовая торговля Розничная торговля Обмен с ГосИС Бухгалтер Оперативный учет 7.7 Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 1С:Комплексная 7.7 1С:Торговля и склад 7.7 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Бухгалтерский учет Управленческий учет Акцизы Платные (руб)

Полностью автоматизированный обмен данными между конфигурациями 1С 7.7 и универсальным транспортным модулем (УТМ) ЕГАИС для всех видов деятельности (Опт, Розница, Производство, Импорт). Для организации обмена с ЕГАИС требуется минимальная доработка конфигураций (поддерживается 1С: "Торговля и склад ред. 9.2", 1С: "Бухгалтерия 7.7", 1С: "УСН 7.7", другие конфигурации по заказу, включая нетиповые). В данном программном продукте реализованы все технические требования ФСРАР по обмену с УТМ ЕГАИС (включая отправку чеков розничных продаж в ЕГАИС - требование с 01.07.16). Поддержана фиксация чеков ЕГАИС на онлайн-кассах (в соответствии с 54-ФЗ). Поддержана версия 3 документооборота и поштучный (помарочный) учет. Поддержан эксперимент Татарстана по маркировке нефасованного (кегового) пива.

3000 руб.

13.12.2015    136826    169    400    

146

Банковские операции Загрузка и выгрузка в Excel Бухгалтер Пользователь Платформа 1С v7.7 Конфигурации 1cv7 Россия Бухгалтерский учет Платные (руб)

Решение предоставляет комплексную загрузку банковской выписки из CSV, XLS, TXT файла в 1С 7.7 любой конфигурации. Позволяет создавать документы выбранного вида, например "Строка выписки банка (приход/расход)", или многострочный табличный документ, например Выписка, для каждой операции из загружаемого файла банковской выписки. Загружает реквизиты документа, а также создаёт контрагентов и другие необходимые элементы справочников.

3588 руб.

29.07.2021    21409    13    22    

14

Анализ учета Оптовая торговля Бухгалтер Бухгалтерский учет 7.7 1С:Комплексная 7.7 Россия Бухгалтерский учет НДС Абонемент ($m)

Отчет написан для Комплексной конфигурации 4.2. Отчет позволяет выполнить сверку кредитовых оборотов счета 76.АВ (НДС с авансов полученных) с книгой покупок, проверить правильность выписки счетов фактур на зачет аванса по счетам БУ в разрезе разных ставок НДС 18% и 20% в комплексной конфигурации 1С:Предприятия 7.7. Позволяет найти и исправить ошибки в процессе перехода на 20% НДС. Помогает с закрытием квартала 18% и 20% НДС. Отчет обновлен для анализа данных 2 квартала 2019 года и всех следующих кварталов (стал более универсальным).

1 стартмани

27.03.2019    24202    13    ksnik    5    

2

Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Обмен с ГосИС Программист Бухгалтер Оперативный учет 7.7 Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 1С:Комплексная 7.7 1С:Торговля и склад 7.7 1С:Упрощенное налогообложение 7.7 Сельское хозяйство и рыболовство Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Пищевая промышленность Россия Бухгалтерский учет Управленческий учет Платные (руб)

Полностью автоматизированный обмен между конфигурациями 1С 7.7 и ФГИС Меркурий через Ветис.API для всех видов деятельности (Опт, Розница, Производство). Для организации обмена с ФГИС Меркурий требуется минимальная доработка конфигураций (поддерживается "из коробки" 1С: "Торговля и склад ред. 9.2", 1С: "Комплексная ред. 4.5", 1С: "Бухгалтерия 7.7", 1С: "УСН 7.7", 1С Предприниматель, другие конфигурации по заказу, включая нетиповые и самописные). Модуль разработан таким образом, чтобы минимизировать затраты по внедрению в произвольную конфигурацию на базе 1С 7.7. Вы можете БЕСПЛАТНО скачать демо-версию без ограничения по функционалу и опробовать решение в полном объеме перед покупкой. В данном программном продукте реализованы все технические требования Россельхознадзора по обмену в формате 2.0 и 2.1. Решение прошло опытную эксплуатацию и тестирование на крупных объектах всех видов деятельности: Производство, Опт, Розница.

10000 руб.

21.11.2018    53456    155    105    

69

Оптовая торговля Обмен с ГосИС Программист Бухгалтер Платформа 1С v7.7 Конфигурации 1cv7 Сельское хозяйство и рыболовство Оптовая торговля, дистрибуция, логистика Пищевая промышленность Бухгалтерский учет Платные (руб)

В обработке реализован полный цикл работы с ГИС Меркурий из 1С на платфоме 7.70.027 (поддерживается конфигурация "Торговля и Склад") через Ветис.API: реализованы процедуры обмена с подсистемами заявок и справочников Ветис.API в формате 2.0.

5040 руб.

03.07.2018    37228    79    27    

60
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. user1535375 25.04.21 08:17 Сейчас в теме
Коллекция = глДайПапу<<?>>(РодительНоменклатуры);
{G:\G\21\PUBID_1119384-ЗАГРУЗКА ПОСТУПЛЕНИЯ ПО АРТИКУЛУ.ERT(157)}: Функция не обнаружена (глДайПапу)
глПечатьТаблицы<<?>>(ТаблицаЕксель);
{G:\G\21\PUBID_1119384-ЗАГРУЗКА ПОСТУПЛЕНИЯ ПО АРТИКУЛУ.ERT(266)}: Процедура не обнаружена (глПечатьТаблицы) как победить эту ошибку?
2. ksnik 591 26.04.21 05:52 Сейчас в теме
(1)
ДайПапу, ПечатьТаблицы

Функция глДайПапу(элемент) Экспорт
	Если элемент.Родитель.Выбран() = 1 Тогда
	   Возврат глДайПапу(элемент.Родитель);
	КонецЕсли;
	Возврат элемент;
КонецФункции

Процедура глПечатьТаблицы(ТабЗнач, пЗаголовок="", пЛегенда = "", пИмяФайла = "") Экспорт
    Если ТипЗначенияСтр(ТабЗнач)<>"ТаблицаЗначений" тогда
        Возврат;
    КонецЕсли;
    Таблица = СоздатьОбъект("Таблица");

    Таблица.Область(1, 1).Текст = пЗаголовок;
    Таблица.Область(1, 1).Шрифт("Times New Roman,204");
    Таблица.Область(1, 1).РазмерШрифта(14);
    Таблица.Область(1, 1).Полужирный(1);

    Таблица.Область(2, 1).Текст = пЛегенда;
    Таблица.Область(2, 1).Шрифт("Times New Roman,204");
    Таблица.Область(2, 1).РазмерШрифта(12);

    врШапкаТаблицы = 4; // 1 строка под заголовок, одна под легенду, одна пустая - разделитель
    Если ПустаяСтрока(пЛегенда) = 1 Тогда
        врШапкаТаблицы = врШапкаТаблицы - 1;
    КонецЕсли;
    Если ПустаяСтрока(пЗаголовок) = 1 Тогда
        врШапкаТаблицы = врШапкаТаблицы - 1;
    КонецЕсли;

    Для нк=1 по ТабЗнач.КоличествоКолонок() цикл
        врШир = 0;
        врЗаголовок = "";
        Таблица.Область(врШапкаТаблицы,нк).Текст=ТабЗнач.ПолучитьПараметрыКолонки(нк,,,,врЗаголовок,врШир);
        Если СокрЛП(врЗаголовок) <> "" Тогда
            Таблица.Область(врШапкаТаблицы,нк).Текст = врЗаголовок;
        КонецЕсли;
        Таблица.Область(врШапкаТаблицы,нк).ШиринаСтолбца(врШир);

        Таблица.Область(врШапкаТаблицы,нк).Шрифт("Times New Roman,204");
        Таблица.Область(врШапкаТаблицы,нк).РазмерШрифта(10);
        Таблица.Область(врШапкаТаблицы,нк).Полужирный(1);
        Таблица.Область(врШапкаТаблицы,нк).РамкаОбвести(3,3,3,3);
    КонецЦикла;

    кол=ТабЗнач.КоличествоСтрок();
    Для нс=1 по кол Цикл
        Для нк=1 по ТабЗнач.КоличествоКолонок() цикл
            // Устал менять "." на "," в Excel, сделаю автоматом
            врТип = 0;
            врЗнач = СокрЛП(ТабЗнач.ПолучитьЗначение(нс, нк));
            ТабЗнач.ПолучитьПараметрыКолонки(нк, врТип);
            Если врТип = "Число" Тогда
                врЗнач = СтрЗаменить(врЗнач, ".", ",");
            КонецЕсли;

            Таблица.Область(нс+врШапкаТаблицы,нк).Текст=врЗнач;
            Таблица.Область(нс+врШапкаТаблицы,нк).Шрифт("Times New Roman,204");
            Таблица.Область(нс+врШапкаТаблицы,нк).РазмерШрифта(10);
            Таблица.Область(нс+врШапкаТаблицы,нк).РамкаОбвести(3,3,3,3);
        КонецЦикла;
        состояние("В таблицу выведено "+нс+" строк из "+кол);
    КонецЦикла;

    Таблица.Опции(0, 1, врШапкаТаблицы,1);
    Таблица.ТолькоПросмотр(0);


    Если пИмяФайла <> "" Тогда
        Таблица.Записать(пИмяФайла, 1); // сохраним в формате XLS
    Иначе
        Таблица.ПараметрыСтраницы(2,100,1,5,5,25,5, 0, 0);
        Таблица.Показать("Печать таблицы значений","");
    КонецЕсли;
КонецПроцедуры   
Показать
Оставьте свое сообщение