Выгрузка данных из дерева значений 1С в формат JSON иерархический список (Сериализация ДереваЗначений в JSON)

22.10.19

Интеграция - Файловый обмен (TXT, XML, DBF), FTP

Тема: Иерархические списки при обмене данными. В интернете не удалось найти подобного решения. Обнаружена реализация только обратной операции JSON в дерево значений 1С или рассматриваются линейные списки (таблицы).

Скачать файлы

Наименование Файл Версия Размер
Выгрузка данных из ДеревоЗначений 1с в формат JSON иерархический список (Сериализации (ДереваЗначений) в JSON):
.epf 30,03Kb
39
.epf 30,03Kb 39 Скачать

Рассмотрим презентуемую обработку: Тестирование выполнялось на платформе 1С:Предприятие 8.3.12.1790

1) Заполняет ДеревоЗначений, иерархию работ

{
    "project": "Нарва",
    "data": [
        {
            "type": "section",
            "meta": {
                "name": "Организация и содержание строительной площадки",
                "xml_id": "9bb86f0d-e9a9-11e9-80ef-005056a42dd9",
                "code": "B",
                "lvl": 1
            },
            "children": [
                {
                    "type": "section",
                    "meta": {
                        "name": "Общие условия, не зависящие от продолжительности работ: прокладка и подключение временных коммуникаций; прокладка временных дорог; устройство бытового",
                        "xml_id": "a965c933-e9a9-11e9-80ef-005056a42dd9",
                        "code": "B10",
                        "lvl": 2
                    },
                    "children": [
                        {
                            "type": "section",
                            "meta": {
                                "name": "Устройство забора",
                                "xml_id": "bcd8e68b-e9a9-11e9-80ef-005056a42dd9",
                                "code": "B1010",
                                "lvl": 3
                            },
                            "children": [
                                {
                                    "type": "element",
                                    "meta": {
                                        "xml_id": "df8507ba-e03a-11e9-80ee-005056a42dd9",
                                        "name": "Временное ограждение стройплощадки из металлического оцинкованного профнастила, тип 3БН",
                                        "parent": "bcd8e68b-e9a9-11e9-80ef-005056a42dd9",
                                        "code": "B10101001000",
                                        "count": 243.45,
                                        "um": "п.м",
                                        "contracted": 776640.19,
                                        "contracted_vat": 916965.88
                                    }
                                },
                                {
                                    "type": "element",
                                    "meta": {
                                        "xml_id": "df8507bb-e03a-11e9-80ee-005056a42dd9",
                                        "name": "Металлические ворота выезда (шириной 6,0 м)",
                                        "parent": "bcd8e68b-e9a9-11e9-80ef-005056a42dd9",
                                        "code": "B10101001100",
                                        "count": 1,
                                        "um": "шт.",
                                        "contracted": 46756.8,
                                        "contracted_vat": 55173.02
                                    }
                                },
                                {
                                    "type": "element",
                                    "meta": {
                                        "xml_id": "df8507bc-e03a-11e9-80ee-005056a42dd9",
                                        "name": "Калитка",
                                        "parent": "bcd8e68b-e9a9-11e9-80ef-005056a42dd9",
                                        "code": "B10101001150",
                                        "count": 1,
                                        "um": "шт.",
                                        "contracted": 8096.9,
                                        "contracted_vat": 9554.34
                                    }
                                },
                                {
                                    "type": "element",
                                    "meta": {
                                        "xml_id": "df8507bd-e03a-11e9-80ee-005056a42dd9",
                                        "name": "Демонтаж и вывоз",
                                        "parent": "bcd8e68b-e9a9-11e9-80ef-005056a42dd9",
                                        "code": "B10101001200",
                                        "count": 1,
                            }
                        }
                    ]
                }
            ]
        }
    ]
}

2) Преобразует ДеревоЗначений 1С в Дерево JSON

3) Отправляет Дерево JSON методом «HTTP Запроса», тип команды «POST»

Обработку вы сможете адаптировать под любую конфигурацию.

Порядок работы с обработкой.

  1. Команда «Заполнить работы», заполняет линейный список
  2. Команда «Заполнить дерево иерархии», по данным верхней таблицы – формируется древовидная структура (ДеревоЗначений)
  3. Команда формирования структуры JSON (для отладки)
  4. Команда формирования JSON и отправки POST HTTP запроса

Основное требование:

В верхней таблице имеется колонка «Иерархия работ сметы»

Это иерархический справочник. Иерархия элементов.

Приведу листинг алгоритма сериализации ДеревоЗначений -> ДеревоJSON

//
Функция СоздатьЗаписиСмета(ВыводитьСообщения = Ложь) Экспорт
	
	ДеревоJSON = ПолучитьДеревоJSON(ДеревоРаботИерархия);
	
	// Сформировать строку JSON
	ТелоЗапроса = "";

	Запись = Новый ЗаписьJSON;
	Запись.УстановитьСтроку(Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Unix, "    ")); // инициализация записи
	
	НастройкиСериализации = Новый НастройкиСериализацииJSON();
	НастройкиСериализации.ВариантЗаписиДаты = ВариантЗаписиДатыJSON.ЛокальнаяДата;
	НастройкиСериализации.ФорматСериализацииДаты = ФорматДатыJSON.ISO;
	НастройкиСериализации.СериализовыватьМассивыКакОбъекты = Ложь;
	
	ДополнительныеПараметрыСериализации = Новый Структура;
	
	ЗаписатьJSON(Запись, ДеревоJSON, НастройкиСериализации, "СериализацияВJSON", ЭтотОбъект, ДополнительныеПараметрыСериализации);
	
	ТелоЗапроса = Запись.Закрыть();
	
КонецФункции

Функция ПолучитьДеревоJSON(ДеревоЗначенийСКД)
	
	СтруктураJSON = Новый Структура();
	
	ОбходДереваСКД(СтруктураJSON, ДеревоЗначенийСКД);
	
	Возврат СтруктураJSON;
	
КонецФункции

Процедура ОбходДереваСКД(СтруктураJSON, ДеревоЗначенийСКД)
	
	ИмяСвойстваМассиваСтрокиСтруктураJSON = ОпределитьСвойствоМассив(СтруктураJSON);
	
	Для Каждого СтрокаДеревоЗначенийСКД Из ДеревоЗначенийСКД.Строки Цикл
		
		Если ИмяСвойстваМассиваСтрокиСтруктураJSON = "ROOT" Тогда // Инициализация дерева JSON
			СтруктураJSONНоваяСтрока = ВставитьЭлементСтруктурыJSON(СтруктураJSON, СтрокаДеревоЗначенийСКД);
		Иначе	
			СтруктураJSONНоваяСтрока = ВставитьЭлементСтруктурыJSON(СтруктураJSON[ИмяСвойстваМассиваСтрокиСтруктураJSON], СтрокаДеревоЗначенийСКД);
		КонецЕсли;
		
		Если СтрокаДеревоЗначенийСКД.Строки.Количество()>0 Тогда
			ОбходДереваСКД(СтруктураJSONНоваяСтрока, СтрокаДеревоЗначенийСКД);
		КонецЕсли;
		
	КонецЦикла;
	
	
КонецПроцедуры

Функция ВставитьЭлементСтруктурыJSON(МассивСтрокаСтруктураJSON, СтрокаДеревоЗначенийСКД)
	
	СтруктураJSON 	= Новый Структура;
	МассивСтруктуры = Новый Массив;
	
	Если НЕ ЗначениеЗаполнено(СтрокаДеревоЗначенийСКД.Работа) Тогда // Это "Проект"
		
		СтруктураJSON.Вставить("project", 						Строка(СтрокаДеревоЗначенийСКД.Проект));
		СтруктураJSON.Вставить("dev_object_name", 				Строка(ОбъектСтроительства));
		СтруктураJSON.Вставить("owner", 						Строка(Организация));
		СтруктураJSON.Вставить("general_contractor", 			Строка(Контрагент));
		СтруктураJSON.Вставить("general_contractor_contract", 	Строка(ДоговорКонтрагента));
		СтруктураJSON.Вставить("сurrency", 						Строка(ДоговорКонтрагента.ВалютаВзаиморасчетов));
		СтруктураJSON.Вставить("data", 							МассивСтруктуры);
		
		МассивСтрокаСтруктураJSON = СтруктураJSON; // Инициализация структуры JSON

	ИначеЕсли ЗначениеЗаполнено(СтрокаДеревоЗначенийСКД.Работа) // Это элемент иерархии
			И ТипЗнч(СтрокаДеревоЗначенийСКД.Работа) = Тип("СправочникСсылка.смр_ИерархияРаботСметы") Тогда 
			
		СтруктураJSON.Вставить("type", "section");
		СтруктураJSON.Вставить("meta", ЗаписьЭлементИерархии(СтрокаДеревоЗначенийСКД));
		СтруктураJSON.Вставить("children", МассивСтруктуры);
		
		// Это Массив для дочерних элементов
		МассивСтрокаСтруктураJSON.Добавить(СтруктураJSON);
		
	ИначеЕсли ЗначениеЗаполнено(СтрокаДеревоЗначенийСКД.Работа) // Это элемент "Работа"
			И ТипЗнч(СтрокаДеревоЗначенийСКД.Работа) = Тип("СправочникСсылка.снх_РаботыСУП") Тогда 
			
		СтруктураJSON.Вставить("type", "element");
		СтруктураJSON.Вставить("meta", ЗаписьРаботы(СтрокаДеревоЗначенийСКД));
		
		// Это Массив для дочерних элементов
		МассивСтрокаСтруктураJSON.Добавить(СтруктураJSON);
		
	КонецЕсли;	
	
	Возврат СтруктураJSON;
	
КонецФункции

Функция ОпределитьСвойствоМассив(СтрокаСтруктураJSON)
	
	Если СтрокаСтруктураJSON.Свойство("data") Тогда // Это "Проект"
		СвойствоМассив = "data";
		
	ИначеЕсли СтрокаСтруктураJSON.Свойство("children") Тогда 
		СвойствоМассив = "children";
		
	Иначе
		СвойствоМассив = "ROOT";
	КонецЕсли;	

	Возврат СвойствоМассив;
	
КонецФункции

///////// Элементы Дерева JSON

Функция ЗаписьРаботы(СтрокаДеревоЗначенийСКД)
	Перем СтруктураJSON;

	СтруктураJSON = Новый Структура();
	
	СтруктураJSON.Вставить("xml_id", 		XMLСтрока(СтрокаДеревоЗначенийСКД.Работа.Ссылка));
    СтруктураJSON.Вставить("name", 			СтрокаДеревоЗначенийСКД.Работа.Наименование);
    СтруктураJSON.Вставить("parent", 		XMLСтрока(СтрокаДеревоЗначенийСКД.ИерархияРаботСметы.Ссылка)); 
    СтруктураJSON.Вставить("code", 			СтрокаДеревоЗначенийСКД.Работа.Шифр);
    СтруктураJSON.Вставить("count", 		СтрокаДеревоЗначенийСКД.ОбъемРаботы);
    СтруктураJSON.Вставить("um", 			СтрокаДеревоЗначенийСКД.Работа.ЕдиницаИзмерения.Наименование);
    СтруктураJSON.Вставить("contracted", 	СтрокаДеревоЗначенийСКД.СуммаБезНДС);
    СтруктураJSON.Вставить("contracted_vat",СтрокаДеревоЗначенийСКД.Сумма);
	
 	Возврат СтруктураJSON;
	
КонецФункции

Функция ЗаписьЭлементИерархии(СтрокаДеревоЗначенийСКД)
	Перем СтруктураJSON;

	СтруктураJSON = Новый Структура();
	
    СтруктураJSON.Вставить("name", 			СтрокаДеревоЗначенийСКД.Работа.Наименование);
	СтруктураJSON.Вставить("xml_id", 		XMLСтрока(СтрокаДеревоЗначенийСКД.Работа.Ссылка));
    СтруктураJSON.Вставить("code", 			СтрокаДеревоЗначенийСКД.Работа.Шифр);
    СтруктураJSON.Вставить("lvl", 			СтрокаДеревоЗначенийСКД.Работа.Уровень);
 
	Возврат СтруктураJSON;
	
КонецФункции

 

См. также

SALE! 10%

Перенос данных из ERP 2 / КА 2 / УТ 11 в БП 3.0

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос позволяет настроить собственный обмен данными между указанными программами, альтернативный предлагаемому фирмой 1С. Перенос данных осуществляется из 1С:ERP 2 / 1С:КА 2 / 1С:УТ 11 в 1С:БП 3.0. Правила обмена оперативно обновляются при выходе новых релизов программы 1С, так что вы всегда будете иметь самую актуальную версию обработки.

38500 34650 руб.

15.04.2019    67709    176    136    

107

Перенос данных из УПП 1.3 в БП 3.0. Переносятся документы (обороты за период), справочная информация и остатки

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила тестировались на конфигурациях УПП 1.3 (1.3.220.x) и БП 3.0 (3.0.147.x). Правила подходят для версии ПРОФ и КОРП.

28000 руб.

15.12.2021    19537    129    38    

85

SALE! 10%

[ED3] Обмен для ERP 2.5, КА 2.5, УТ 11.5 БП 3.0, Розница, УНФ и других с EnterpriseData (универсальный формат обмена), правила обмена

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    133497    712    291    

383

SALE! 10%

Перенос данных из ERP 2 / КА 2 в ЗУП 3

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Управленческий учет Платные (руб)

Обработка позволяет не только перенести все документы, справочную информацию и начальные остатки из ERP 2 или КА 2 в ЗУП 3, но и организовать регулярный перенос данных между программами 1С:ERP 2 / КА 2 и 1С:ЗУП 3. Вы можете выбрать период отбора данных и установить фильтр по организациям, чтобы выгружать только необходимую информацию. Более того, перенос оперативно обновляется при выходе новых релизов программы 1С, так что вы всегда будете иметь самую актуальную версию обработки.

48278 43450 руб.

03.12.2020    33641    79    57    

76

SALE! 10%

Перенос данных из УПП 1.3 / КА 1.1 в БП 3.0

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Перенос данных из УПП 1.3 в БП 3.0 (или из КА 1.1 в БП 3.0). Переносятся документы, начальные остатки и вся справочная информация. Есть фильтр по организации и множество других параметров выгрузки. Поддерживается несколько сценариев работы: как первичный полный перенос, так и перенос только новых документов. Перенос данных возможен в 1С: Бухгалтерию 3.0 версии ПРОФ, КОРП или базовую. Переход с "1С: Управление производственным предприятием 1.3" / "1С:Комплексная автоматизация 1.1" на "1С:Бухгалтерия предприятия 3.0" с помощью наших правил конвертации будет максимально комфортным!

43889 39500 руб.

25.02.2015    167967    286    240    

370

SALE! 10%

Перенос данных из УПП 1.3 в ЗУП 3.1 или из КА 1.1 в ЗУП 3.1

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Сложные периодические расчеты 1С:Комплексная автоматизация 1.х 1С:Управление производственным предприятием 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Платные (руб)

Перенос кадровых и расчетных данных и справочной информации из "1С:Комплексная автоматизация, ред. 1.1" или "1С:Управление производственным предприятием, ред.1.3" в "1С:Зарплата и управление персоналом", ред. 3.1. Правила позволяют перенести кадровые данные сотрудников за весь период ведения учета в КА 1.1 / УПП 1.3 и расчетные данные за выбранный период (минимально необходимый - 2 года). Позволяют осуществить переход на ведение учета зарплаты и кадров в программе 1С:Зарплата и управление персоналом, ред. 3.1.

50722 45650 руб.

29.10.2018    53933    52    97    

55

Перенос данных из УТ 10.3 в УТ 11.5. Переносятся документы (обороты за период), справочная информация и остатки

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. За основу были взяты стандартные правила переноса остатков и справочной информации. Правила тестировались на конфигурациях УТ 10.3 (10.3.87.x) и УТ 11.5 (11.5.15.x).

28000 руб.

23.07.2020    45234    192    63    

149

Загрузка номенклатуры c картинками (несколько потоков одновременно) и сопутствующими данными в базу и любые документы из yml, xls, xlsx, xlsm, ods, ots, csv для УТ 10.3, УТ 11 (все), БП 3, КА 2, ERP 2, УНФ 1.6/3.0, Розница 2

Загрузка и выгрузка в Excel Логистика, склад и ТМЦ Ценообразование, анализ цен Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Платные (руб)

Эволюция не стоит на месте - новая удобная версия функциональной обработки для Вашего бизнеса! Что же Вы получаете? Удобный и интуитивно понятный интерфейс с 3-мя этапами работы. 2 режима - автоматический и ручной. Чтение XLSX, XLSM, CSV, XML/YML форматов без офиса, на любом сервере! Визуальное связывание колонок файла и реквизитов простым перетаскиванием колонок. Создание или обновление номенклатуры с иерархией, характеристик, доп. реквизитов, упаковок, загрузка практически неограниченного количества картинок на одну номенклатуру (с возможностью загрузки в несколько потоков одновременно), с хранением в томах или в базе. Загрузка номенклатуры поставщиков или поиск по их данным номенклатуры. Загрузка доп. реквизитов в характеристики. Загрузка штрихкодов с генерацией новых. Создание элементов справочников и ПВХ "на лету" для выбранных реквизитов. (Обновление от 11.12.2023, версия 9.5 - 9.9)

13200 руб.

20.11.2015    149443    361    375    

496
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. XSlava 157 23.10.19 08:03 Сейчас в теме
Скажите пожалуйста, а какие задачи вы решаете данным преобразованием? Сделали преобразование, а дальше?
4. mwoleg 54 24.10.19 22:50 Сейчас в теме
(1) Цель - передать иерархический массив данных в стороннюю информационную систему (например web-сайт/портал)
2. magvay_k 63 23.10.19 09:42 Сейчас в теме
Может использовать "СериализаторXDTO.ЗаписатьJSON(ЗаписьJSON, ДеревоЗначений)"
ybatiaev; litonchik; A_Max; +3 Ответить
3. XSlava 157 23.10.19 12:41 Сейчас в теме
(2)Можно на руках ходить, но многие люди ходят на ногах.
5. mwoleg 54 25.10.19 23:02 Сейчас в теме
(2)
СериализаторXDTO.ЗаписатьJSON(ЗаписьJSON, ДеревоЗначений)


Такой вариант идеален!

Но только в таких случаях, когда принимающая сторона:
1) Тоже 1С:ИБ
2) В составе конфигурации имеет те же объекты (Справочники, Перечисления и т.д.) передаваемые по JSON

Либо принимающая сторона готова обрабатывать такой формат:
Скрытый текст

ОДНАКО, когда принимающая сторона предъявляет требования и другие варианты обсуждению не подлежит ..... тогда только предложенный мной вариант в обработке ;)
7. Merkalov 8 23.09.20 02:19 Сейчас в теме
(2) Это не сработает, в JSON запишется, но прочитать его уже нельзя будет, с деревом СериализаторXDTO официально не работает, т.е корректность работы не гарантируется.
6. serg-lom89 72 27.11.19 11:01 Сейчас в теме
могли бы к этому приложить конфигурацию хотя бы небольшую что бы был пример ?
8. __v7 18.10.20 10:21 Сейчас в теме
Почему метод "СериализацияВJSON" не заполнен? Ругается на него, а без него орет, что не тот тип данных передаю
9. ybatiaev 58 09.11.22 11:03 Сейчас в теме
Господа программеры, приветствую вас! Есть вопрос. У меня есть некая переменная как соответствия, где каждому контрагенту соответствует массив чисел.
Его записать в JSON прекрасно получилось
СериализаторXDTO.ЗаписатьJSON(ЗаписьJSON, ПараметрыНастроек, НазначениеТипаXML.Явное);
а вот корректно считать с JSON-файла уже НИФИГА не получается.
ПараметрыНастроек = СериализаторXDTO.ПрочитатьJSON(ЧтениеJSON);
Ткните меня в ссылку плиз, устал от поисков решения
Оставьте свое сообщение