Интеграция АЗС ТОПАЗ и Штрих-М Магазин

17.06.20

Интеграция - Файловый обмен (TXT, XML, DBF), FTP

Обмен данными между АЗС Топаз 3.14 и 1С на примере Штрих-М: Магазин, редакция 5.1 (5.1.6.8).

Скачать файлы

Наименование Файл Версия Размер
Интеграция АЗС ТОПАЗ и Штрих-М Магазин:
.epf 14,05Kb
2
.epf 14,05Kb 2 Скачать
  1. Конфигурация файла обмена

 

1.1 Формат файла импорта

Файл который нужно выгружать из конфигурации 1с в ТОПАЗ-АЗС:

<?xml version="1.0" encoding="windows-1251"?>
<content>
	<documents/>
	<objects>
		<dcItemPrices>// Описание цены//***********
			<obj>
				<objLink field="ItemID">Внешний код товара</objLink>
				<objLink field="PriceID">Внешний кодцены</objLink>
				<Value>Значение цены</Value>
			</obj>
		</dcItemPrices>
		<dcItems>// Описание товара//***********
			<obj>
				<objLink field="ItemsGrpID"> Внешний код  группы родителя</objLink>
				<Name>Наименование товара</Name>
				<FullName>Полное Наименование товара</FullName>
				<objLink field="UnitID">Внешний код единицы</objLink>
				<objLink field="NdsID"> Внешний код НДС</objLink>
				<Rem/>
				<IsService>1</IsService>
				<ItemCode/>//Штрих код
				<FRDepartment>16</FRDepartment>//Секция ФР
				<ExtCode> Внешний код  товара</ExtCode>
				<Country/>
				<IsSet>0</IsSet>
			</obj>
		</dcItems>
		<dcItemsGrps>// Описание групп товара//***********
			<obj>
				<ParentID> Внешний код  родителя группы</ParentID>
				<Name>Наименование группы</Name>
				<Rem/>
				<ExtCode> Внешний код  группы</ExtCode>
				<objLink field="PriceID">16</objLink>
			</obj>
		</dcItemsGrps>
                            
< dcPrices >//Описание типов цен****************
	<obj>
<BasePriceID>Наименование цены</ BasePriceID >
<Name>Наименование цены</Name>
				<ProcentValue> Процент наценки в числовом выражении</ ProcentValue >
		<Rem/>				
				<ExtCode> Внешний код  типа цен</ExtCode>
				<WithinNDS> 0 или 1</ WithinNDS >
			</obj>
		</ dcPrices >

		//<dcPrices/>
		<dcUnits>// Описание единиц//***********
			<obj>
				<Name>наименование единицы</Name>
				<FullName>Полное наименование единицы</FullName>
				<Rem/>
				<ExtCode> Внешний код  единицы</ExtCode>
			</obj>
		</dcUnits>
		<dcNds>// Описание НДС//***********
			<obj>
				<Name>название НДС%</Name>
				<Tax>Значение НДС</Tax>
				<Rem/>
				<ExtCode>Внешний код НДС</ExtCode>
			</obj>
		</dcNds>
		<dcItemUnits>//Связь товара и Единиц.
			<obj>
				<objLink field="ItemID">100</objLink>
				<objLink field="UnitID">12</objLink>
				<Factor>1</Factor>
			</obj>			
		</dcItemUnits>
	</objects>
</content>

Учет количества товаров в Топаз-АЗС не будет, только в 1С - поэтому в поле "IsService" в XML-файле загрузки номенклатуры устанавливаем  IsService=1 для всех товаров. Также в ExtCode подсовываем значение ItemCode (штрих-код товара) 

    1. Формат файла экспорта

Файл который нужно выгружать из ТОПАЗ-АЗС  в конфигурацию 1с:

<?xml version="1.0" encoding="windows-1251" ?>

<DataPaket Version="3.13" DateTime="Время" Type="Aggregated" AZSCode="Код АЗС">

<Sessions>

<Session SessionNum="Номер сессии" StartDateTime="Начало время сессии" EndDateTime="Конец время сессии" UserName="Пользователь">

…

<ItemOutcomesByRetail>

<ItemOutcomeByRetail ItemName="Наименование товара" ItemFullName="Полное Наименование товара" ItemExtCode="Код в 1С" ItemGroup="Наименование родительской группы" ItemsGrpExtCode="" IsService="0" PaymentModeName="Продукты сотрудника" PaymentModeExtCode="" PartnerName="Расходы АЗС" PartnerExtCode="88800002" PartnerINN="" ItemID="Артикул" Nds="Индекс НДС" Unit="Наименование единицы" FRDepartment="16" Hash="36f02f9bc4fbf455cc6d1eb6a2d75de5" ItemCode="Штрихкод" IsReturn="Признак возврата" Quantity="Количество проданных" Amount="Сумма продажи" PriceFastTrade="30" PriceIn="Приходная цена" PriceRetail="Розничная цена" />

…

</ItemOutcomesByRetail>

</Sessions>

</DataPaket>

Что добавлять в конфигурацию

Добавим новое перечисление ТипККМOffLine - Перечисления.ТипККМOffLine.Топаз_АЗС.

В справочнике ККМ добавим для видимости «НадписиНастройкиККМ»:

ЭлементыФормы.НадписьНастройкиККМ.Доступность = (ТипККМ = Перечисления.ТипККМOffLine.ШтрихМастер)
											    ИЛИ (ТипККМ = Перечисления.ТипККМOffLine.MiniPOS)
		                                        ИЛИ (ТипККМ = Перечисления.ТипККМOffLine.ШтрихМКассир50)
		                                        ИЛИ (ТипККМ = Перечисления.ТипККМOffLine.ШтрихМКассир50ТУ)
												ИЛИ (ТипККМ = Перечисления.ТипККМOffLine.ГранулаШтрихМКассир)
												//>>
											    ИЛИ (ТипККМ = Перечисления.ТипККМOffLine.Топаз_АЗС);

Для доступности «НадписьНастройкиККМ»:

 

ЭлементыФормы.НадписьНастройкиККМ.Доступность = (ТипККМ = Перечисления.ТипККМOffLine.ШтрихМастер)
											    ИЛИ (ТипККМ = Перечисления.ТипККМOffLine.MiniPOS)
		                                        ИЛИ (ТипККМ = Перечисления.ТипККМOffLine.ШтрихМКассир50)
		                                        ИЛИ (ТипККМ = Перечисления.ТипККМOffLine.ШтрихМКассир50ТУ)
												ИЛИ (ТипККМ = Перечисления.ТипККМOffLine.ГранулаШтрихМКассир)
												//>>
											    ИЛИ (ТипККМ = Перечисления.ТипККМOffLine.Топаз_АЗС);

Для доступности «НастройкиККМ»:

ЭлементыФормы.НастройкиККМ.Доступность = (ТипККМ = Перечисления.ТипККМOffLine.ШтрихМастер)
	                                     ИЛИ (ТипККМ = Перечисления.ТипККМOffLine.MiniPOS)
										 ИЛИ (ТипККМ = Перечисления.ТипККМOffLine.ШтрихМКассир50)
		                                 ИЛИ (ТипККМ = Перечисления.ТипККМOffLine.ШтрихМКассир50ТУ)
										 //>>
										ИЛИ (ТипККМ = Перечисления.ТипККМOffLine.Топаз_АЗС);


Доступности «ПанельПараметровККМ»:

 

ЭлементыФормы.ПанельПараметровККМ.Страницы.Файлы.Доступность = (ТипККМ = Перечисления.ТипККМOffLine.PriceChecker)
	                                                           ИЛИ (ТипККМ = Перечисления.ТипККМOffLine.ШтрихИнфо)
															   ИЛИ (ТипККМ = Перечисления.ТипККМOffLine.ШтрихМастер)
	…
														   //>>
													 		   ИЛИ (ТипККМ = Перечисления.ТипККМOffLine.Топаз_АЗС);

Для выгрузки данных изменим функцию «ВыполнитьОперацииСККМ»:

 

…               
//>>
	//Добавить в спикок для выгрузки!
	Если Обмен_АЗС_Топаз.ТопазВыгрузка(ТаблицаСкладов) Тогда
		Отказ = Обмен_АЗС_Топаз.ВыгрузитьВТопаз(ТаблицаСкладов,ЭтотОбъект);
	Иначе
		Отказ = ВнешняяКомпонента.ВыполнитьОперацииККМ(ТаблицаСкладов, ПроведениеДокумента);
	КонецЕсли;	
…

Где функция «ТопазВыгрузка» из модуля «Обмен_АЗС_Топаз»:

 

Функция ВыгрузитьВТопаз(ТаблицаСкладов,ЭтотОбъект) экспорт
	Рез = Истина;
	//1. Создать файл выгрузки
	ТаблицаТоваров = СоздатьСписок(ЭтотОбъект);
	//2. Выгрузить по складам
	Файл = СоздатьXML(ТаблицаТоваров);
	Для каждого склд из ТаблицаСкладов Цикл
		Рез = СкопироватьВСклад(склд.Склад,Файл);
	КонецЦикла;
	Возврат Рез;
КонецФункции

    

         Соответственно для снятия отчета об продажах изменим обработку «СнятиеОтчетаОтдела» в процедуре «СнятьОтчетОтдела»:

 

Функция СнятьОтчетОтдела(Знач Компонента, Результат = Неопределено)
	Отказ = Ложь;
…
Если (Не Отказ) Тогда
		ЭтотОбъектПерем = ЭтотОбъект;
		//>>
		//Добавить в спикок для выгрузки!
		Если Обмен_АЗС_Топаз.ТопазВыгрузка(ЭтотОбъектПерем,Истина) Тогда
			Отказ = Обмен_АЗС_Топаз.СнятьОтчетОтдела_Топаз(ЭтотОбъектПерем,Результат);
		Иначе
			Отказ = Компонента.СнятьОтчетОтдела_бул(ЭтотОбъектПерем, Результат);
		КонецЕсли;	
	КонецЕсли;
		
	Возврат Отказ;
КонецФункции

где функция «ТопазВыгрузка»:

 

Функция ТопазВыгрузка(Склад,СнятиеОтчета=Ложь) Экспорт
	Если СнятиеОтчета Тогда
		Если Склад.ВариантСнятияОтчетаОтдела= Перечисления.ВариантыСнятияОтчетаОтдела.ПоККМ Тогда
			Если Склад.Параметр.ТипККМ = Перечисления.ТипККМOffLine.Топаз_АЗС Тогда
				Возврат Истина;
			КонецЕсли;
		ИначеЕсли Склад.ВариантСнятияОтчетаОтдела= Перечисления.ВариантыСнятияОтчетаОтдела.ПоВсемККМ Тогда	
			Если ЕстьТопазВСпискеККМ() Тогда
				Возврат Истина;
			КонецЕсли;
		КонецЕсли;
	Иначе	
		Для каждого скл из Склад Цикл
			Если КэшСистемыТопаз(скл.Склад) Тогда
				Возврат Истина;
			КонецЕсли;	
		КонецЦикла;	
	КонецЕсли;
	Возврат Ложь;//пока!
КонецФункции

и функция «СнятьОтчетОтдела_Топаз», определяет обработать файл по одному терминалу или по нескольким:

Функция СнятьОтчетОтдела_Топаз(ЭтотОбъект,Результат) экспорт
	Рез = Ложь;
	Если ЭтотОбъект.ВариантСнятияОтчетаОтдела= Перечисления.ВариантыСнятияОтчетаОтдела.ПоККМ Тогда
		Если ЭтотОбъект.Параметр.ТипККМ = Перечисления.ТипККМOffLine.Топаз_АЗС Тогда
			ИмяФайлаЗагрузки = ПолучитьИмяФайлаЗагрузки(ЭтотОбъект.Параметр);
			Рез = ОбработатьXMLДанные(ИмяФайлаЗагрузки,ЭтотОбъект.Параметр);
		КонецЕсли;
	ИначеЕсли ЭтотОбъект.ВариантСнятияОтчетаОтдела= Перечисления.ВариантыСнятияОтчетаОтдела.ПоВсемККМ Тогда
		СписокККМТопаз = ПолучитьСписокККМТопаз();
		Для каждого ккм_Топаз из СписокККМТопаз Цикл
			ИмяФайлаЗагрузки = ПолучитьИмяФайлаЗагрузки(ккм_Топаз.ККМ);
			Рез = ОбработатьXMLДанные(ИмяФайлаЗагрузки,ккм_Топаз.ККМ);
		КонецЦикла;
	КонецЕсли;
	
	
	Возврат Рез;
КонецФункции
  1. Примечание

 

Использовался ПО "Топаз-АЗС Demo" версии 3.14(Отличие данной версии программы ("Топаз-АЗС Demo") от версии "Топаз-АЗС" заключается в отсутствии поддержки внешнего оборудования (КУТРК, идентификаторов, регистраторов, уровнемеров, платежных терминлов). В "Топаз-АЗС Demo" доступны только программные эмуляторы соответствующих устройств.)

Полный код указан в обработке "Обмен_АЗС_Топаз.epf" который является только вместилищем функций.

АЗС ТОПАЗ Штрих-М

См. также

SALE! 10%

Перенос данных из ERP 2 / КА 2 / УТ 11 в БП 3.0

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос позволяет настроить собственный обмен данными между указанными программами, альтернативный предлагаемому фирмой 1С. Перенос данных осуществляется из 1С:ERP 2 / 1С:КА 2 / 1С:УТ 11 в 1С:БП 3.0. Правила обмена оперативно обновляются при выходе новых релизов программы 1С, так что вы всегда будете иметь самую актуальную версию обработки.

38500 34650 руб.

15.04.2019    67708    176    136    

107

Перенос данных из УПП 1.3 в БП 3.0. Переносятся документы (обороты за период), справочная информация и остатки

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила тестировались на конфигурациях УПП 1.3 (1.3.220.x) и БП 3.0 (3.0.147.x). Правила подходят для версии ПРОФ и КОРП.

28000 руб.

15.12.2021    19536    129    38    

85

SALE! 10%

[ED3] Обмен для ERP 2.5, КА 2.5, УТ 11.5 БП 3.0, Розница, УНФ и других с EnterpriseData (универсальный формат обмена), правила обмена

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    133497    712    291    

383

SALE! 10%

Перенос данных из ERP 2 / КА 2 в ЗУП 3

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Управленческий учет Платные (руб)

Обработка позволяет не только перенести все документы, справочную информацию и начальные остатки из ERP 2 или КА 2 в ЗУП 3, но и организовать регулярный перенос данных между программами 1С:ERP 2 / КА 2 и 1С:ЗУП 3. Вы можете выбрать период отбора данных и установить фильтр по организациям, чтобы выгружать только необходимую информацию. Более того, перенос оперативно обновляется при выходе новых релизов программы 1С, так что вы всегда будете иметь самую актуальную версию обработки.

48278 43450 руб.

03.12.2020    33640    79    57    

76

SALE! 10%

Перенос данных из УПП 1.3 / КА 1.1 в БП 3.0

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Перенос данных из УПП 1.3 в БП 3.0 (или из КА 1.1 в БП 3.0). Переносятся документы, начальные остатки и вся справочная информация. Есть фильтр по организации и множество других параметров выгрузки. Поддерживается несколько сценариев работы: как первичный полный перенос, так и перенос только новых документов. Перенос данных возможен в 1С: Бухгалтерию 3.0 версии ПРОФ, КОРП или базовую. Переход с "1С: Управление производственным предприятием 1.3" / "1С:Комплексная автоматизация 1.1" на "1С:Бухгалтерия предприятия 3.0" с помощью наших правил конвертации будет максимально комфортным!

43889 39500 руб.

25.02.2015    167965    286    240    

370

SALE! 10%

Перенос данных из УПП 1.3 в ЗУП 3.1 или из КА 1.1 в ЗУП 3.1

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Сложные периодические расчеты 1С:Комплексная автоматизация 1.х 1С:Управление производственным предприятием 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Платные (руб)

Перенос кадровых и расчетных данных и справочной информации из "1С:Комплексная автоматизация, ред. 1.1" или "1С:Управление производственным предприятием, ред.1.3" в "1С:Зарплата и управление персоналом", ред. 3.1. Правила позволяют перенести кадровые данные сотрудников за весь период ведения учета в КА 1.1 / УПП 1.3 и расчетные данные за выбранный период (минимально необходимый - 2 года). Позволяют осуществить переход на ведение учета зарплаты и кадров в программе 1С:Зарплата и управление персоналом, ред. 3.1.

50722 45650 руб.

29.10.2018    53932    52    97    

55

Перенос данных из УТ 10.3 в УТ 11.5. Переносятся документы (обороты за период), справочная информация и остатки

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. За основу были взяты стандартные правила переноса остатков и справочной информации. Правила тестировались на конфигурациях УТ 10.3 (10.3.87.x) и УТ 11.5 (11.5.15.x).

28000 руб.

23.07.2020    45234    192    63    

149

Загрузка номенклатуры c картинками (несколько потоков одновременно) и сопутствующими данными в базу и любые документы из yml, xls, xlsx, xlsm, ods, ots, csv для УТ 10.3, УТ 11 (все), БП 3, КА 2, ERP 2, УНФ 1.6/3.0, Розница 2

Загрузка и выгрузка в Excel Логистика, склад и ТМЦ Ценообразование, анализ цен Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Платные (руб)

Эволюция не стоит на месте - новая удобная версия функциональной обработки для Вашего бизнеса! Что же Вы получаете? Удобный и интуитивно понятный интерфейс с 3-мя этапами работы. 2 режима - автоматический и ручной. Чтение XLSX, XLSM, CSV, XML/YML форматов без офиса, на любом сервере! Визуальное связывание колонок файла и реквизитов простым перетаскиванием колонок. Создание или обновление номенклатуры с иерархией, характеристик, доп. реквизитов, упаковок, загрузка практически неограниченного количества картинок на одну номенклатуру (с возможностью загрузки в несколько потоков одновременно), с хранением в томах или в базе. Загрузка номенклатуры поставщиков или поиск по их данным номенклатуры. Загрузка доп. реквизитов в характеристики. Загрузка штрихкодов с генерацией новых. Создание элементов справочников и ПВХ "на лету" для выбранных реквизитов. (Обновление от 11.12.2023, версия 9.5 - 9.9)

13200 руб.

20.11.2015    149443    361    375    

496
Оставьте свое сообщение