Выгрузка XML-файла УПД для отправки через ЭДО СБИС, Диадок и т.п.

17.08.20

Функциональные - Документооборот и делопроизводство (СЭД)

С помощью этой обработки для документа "Реализация товаров и услуг" формируется XML-файл УПД, который можно отправить через ЭДО СБИС, Диадок и пр.

Скачать исходный код

Наименование Файл Версия Размер
Выгрузка XML-файла УПД для отправки через ЭДО СБИС, Диадок и т.п.:
.epf 8,25Kb
175
.epf 8,25Kb 175 Скачать

Развитие информационных технологий, отказ от бумаги, внедрение системы сплошной маркировки товаров, распространение пандемии коронавируса и другие факторы стремительно расширяют сферы бизнеса, где требуется использовать электронный документооборот (ЭДО).

В типовых решениях 1С можно отправить универсальный передаточный документ (УПД) через ЭДО прямо из документа  РеализацияТоваровУслуг. В тех случаях, когда база 1С не подключена к ЭДО, можно воспользоваться этой обработкой, которая сформирует XML-файл для отправки через сторонних операторов ЭДО. В основе лежит процедура ПодготовитьДанныеДляЗаполненияДокументов типовой обработки ОбменСКонтрагентами.

Проверялось на платформе 8.3.15.1830 и конфигурации Бухгалтерия предприятия 3.0.80.40. Также проходит аудит при загрузке в 1С:ФРЕШ.

Код модуля формы обработки ниже.


&НаСервере
Функция СформироватьЭлектронныйДокументНаСервере()
	
	// Получение файла электронного документа
	МассивСсылокНаОбъект = Новый Массив;
	МассивСсылокНаОбъект.Добавить(Документ);
	ПараметрыЗадания = Новый Структура;
	ПараметрыЗадания.Вставить("МассивСсылокНаОбъект", МассивСсылокНаОбъект);
	ПараметрыЗадания.Вставить("ОтправкаЧерезБС", Ложь);
	АдресХранилища = ПоместитьВоВременноеХранилище(Неопределено, УникальныйИдентификатор);
	Обработки.ОбменСКонтрагентами.ПодготовитьДанныеДляЗаполненияДокументов(ПараметрыЗадания, АдресХранилища);
	ТаблицаЭД = ПолучитьИзВременногоХранилища(АдресХранилища);
	
	// Подготовка структуры параметров для отображения и отправки
	СтруктураПараметров = Новый Структура;
	СтруктураПараметров.Вставить("АдресХранилища", ПоместитьВоВременноеХранилище(ТаблицаЭД[0].ДвоичныеДанныеПакета, УникальныйИдентификатор));
	СтруктураПараметров.Вставить("ФайлАрхива", Истина);
	СтруктураПараметров.Вставить("НаименованиеФайла", ТаблицаЭД[0].НаименованиеФайла);
	СтруктураПараметров.Вставить("НаправлениеЭД", ТаблицаЭД[0].НаправлениеЭД);
	СтруктураПараметров.Вставить("Контрагент", ТаблицаЭД[0].Контрагент);
	СтруктураПараметров.Вставить("УникальныйИдентификатор", ТаблицаЭД[0].УникальныйИдентификатор);
	СтруктураПараметров.Вставить("ВладелецЭД", ТаблицаЭД[0].ВладелецЭД);
	МассивСтруктур = Новый Массив;
	МассивСтруктур.Добавить(СтруктураПараметров);
	АдресМассива = ПоместитьВоВременноеХранилище(МассивСтруктур, Неопределено);
	Возврат АдресМассива;
КонецФункции

&НаКлиенте
Процедура СформироватьЭлектронныйДокумент(Команда)
	Если Документ.Пустая() Тогда
		Возврат;
	КонецЕсли;
	АдресМассива = СформироватьЭлектронныйДокументНаСервере();
	Элементы.ПоказатьЭлектронныйДокумент.Доступность = Истина;
	Элементы.СохранитьЭлектронныйДокумент.Доступность = Истина;
КонецПроцедуры

&НаКлиенте
Процедура ПоказатьЭлектронныйДокумент(Команда)
	МассивСтруктур = ПолучитьИзВременногоХранилища(АдресМассива);
	ФормаПросмотраЭД = ОткрытьФорму("Обработка.ОбменСКонтрагентами.Форма.СписокВыгружаемыхЭлектронныхДокументов", Новый Структура("СтруктураЭД", МассивСтруктур), ЭтотОбъект);
КонецПроцедуры

&НаКлиенте
Процедура СохранитьЭлектронныйДокумент(Команда)
	МассивСтруктур = ПолучитьИзВременногоХранилища(АдресМассива);
	Режим = РежимДиалогаВыбораФайла.Сохранение; 
	ДиалогСохраненияФайла = Новый ДиалогВыбораФайла(Режим); 
	ДиалогСохраненияФайла.ПолноеИмяФайла = СтрЗаменить(Документ, ":", ""); 
	Фильтр = "Текст(*.zip)|*.zip";                 
	ДиалогСохраненияФайла.Фильтр = Фильтр; 
	ДиалогСохраненияФайла.МножественныйВыбор = Ложь; 
	ДиалогСохраненияФайла.Заголовок = "Выберите файл"; 
	Если ДиалогСохраненияФайла.Выбрать() Тогда 
		ПутьКФайлу = ДиалогСохраненияФайла.ПолноеИмяФайла; 
		ДвоичныеДанные = ПолучитьИзВременногоХранилища(МассивСтруктур[0].АдресХранилища);
		ДвоичныеДанные.Записать(ПутьКФайлу);
	КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура ДокументПриИзменении(Элемент)
	Элементы.ПоказатьЭлектронныйДокумент.Доступность = Ложь;
	Элементы.СохранитьЭлектронныйДокумент.Доступность = Ложь;
КонецПроцедуры

 

обработка реализация УПД выгрузка формирование XML отправка ЭДО СБИС Диадок Такском Фреш

См. также

Автоматический заказ поставщику в 1С: загрузка прайсов и анализ цен поставщиков для УТ 10.3, УТ 11, КА2, УНФ, УПП, ERP, Розница 2

Бюджетирование и планирование Оптовая торговля Розничная торговля Логистика, склад и ТМЦ Анализ продаж Платформа 1С v7.7 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Беларусь Украина Россия Казахстан Управленческий учет Платные (руб)

Система управления запасами для 1С помогает работать с запасами правильно: автоматически рассчитывает потребность и делает заказ поставщику, загружает прайсы, перемещает товары по филиалам, анализирует продажи и позволяет управлять ассортиментом.

28500 руб.

21.04.2017    91141    111    40    

199

1С:Документооборот - цена на лицензии КОРП, ПРОФ и ДГУ

Документооборот и делопроизводство (СЭД) Типовые Платформа 1С v8.3 Управленческий учет Платные (руб)

Организуйте правильный документооборот на вашем предприятии в 1С. Ведение учета и хранения документов. Управление потоками документации между подразделениями. Работа с договорами в компании. Автоматизация подготовки, согласования и подписания документов. Сократите время и объем ошибок с 1С:Документооборот!

48500 руб.

19.02.2016    107291    104    5    

86

SALE! 10%

[ED3] Обмен для ERP 2.5, КА 2.5, УТ 11.5 БП 3.0, Розница, УНФ и других с EnterpriseData (универсальный формат обмена), правила обмена

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    135710    730    291    

392

ЕГАИС++. Опт, производство, импорт

Оптовая торговля Розничная торговля Обмен с ГосИС Платформа 1С v8.3 1С:Управление торговлей 10 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Россия Бухгалтерский учет Управленческий учет Акцизы Платные (руб)

Полнофункциональное расширение (ранее известное как Модуль 1С-ЕГАИС) для взаимодействия типовых конфигураций 1С и ЕГАИС, предоставляющее максимум возможностей по работе с УТМ. Получение и отправка ТТН, отправка акта о постановке на баланс и акта о списании. Получение остатков. Загрузка и сопоставление номенклатуры и контрагентов. Оправка в ЕГАИС отчетов о производстве и импорте.

8970 руб.

15.12.2015    166635    704    362    

390

SALE! 10%

Перенос данных из ERP 2 / КА 2 / УТ 11 в БП 3.0. Переносятся документы, начальные остатки и справочники

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

38500 34650 руб.

15.04.2019    68958    181    139    

111

Перенос данных из УПП 1.3 в БП 3.0. Переносятся документы (обороты за период), справочная информация и остатки

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.226.x) и БП 3.0 (3.0.151.x). Правила подходят для версии ПРОФ и КОРП.

28000 руб.

15.12.2021    20693    136    38    

95

SALE! 10%

Перенос данных из ERP 2 / КА 2 в ЗУП 3. Переносятся остатки, документы и справочники

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из ERP в ЗУП 3 | из КА 2 в ЗУП | Воспользовались более 79 предприятий! | Предлагаем приобрести готовые правила конвертации данных (КД 2) для переноса остатков, документов с движениями и справочной информации 3 | В продаже с 2020г. | Оперативно обновляем правила до актуальных релизов 1С | Есть перенос начальной задолженности по зарплате и начальной штатной расстановки на выбранную дату | Обороты за прошлые годы (данные для расчета среднего) переносятся свернуто в документ "Перенос данных" | Есть фильтр по организациям | Документы за текущий период переносятся сразу с движениями, поэтому не потребуется делать перерасчеты | Перенос можно проверить перед покупкой, обращайтесь!

48278 43450 руб.

03.12.2020    34518    83    58    

81

Перенос данных из УТ 10.3 в УТ 11.5. Переносятся документы (обороты за период), справочная информация и остатки

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3 (10.3.87.x) и УТ 11.5 (11.5.16.x).

28000 руб.

23.07.2020    46886    200    64    

162
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. stiv1968 07.11.20 15:27 Сейчас в теме
2. Ольга_tmp 71 09.11.20 06:18 Сейчас в теме
проблема с услугами. ошибка " - Не указан код единицы измерения в справочнике "Номенклатура".
код услуги по классификатору единиц измерения ОКЕИ не регламентирован, согласно письму Минфина России от 15.10.12 № 03-07-05/42 можно использовать «-». Собственно СБИС принимает услугу с прочерком. а обработка ОбменСКонтрагентами выдает ошибку.
3. сибирь 14 08.12.20 08:00 Сейчас в теме
Добрый день. В 1с бухгалтерии есть типовая выгрузка ЭДО в файл mxl.

Но из-за трех тег файл не загружаются в Диадок. Из-за того что стоит нижние подчеркивания в трех тегах, убрав которые в ручную, всё работает.

Это теги :
ИдПол, ИдОтпр и ИдФайл

в xml-файле необходимо убрать нижние подчеркивания "_" между ИНН-КПП в тегах ИдПол, ИдОтпр и ИдФайл.

Сейчас бухгалтер из 1с выгружает файл и в блокноте убирает в этих трех местах нижнее подчеркивание и всё работает.

Я связывался с 1с-ками --- чтобы они убрали нижнее подчеркивание -- и тогда всё будет работать, но 1с-ки ответили, что это выгрузка предназначается исключительно для обмена между 1с и не предполагает связи ни с какими диадоками.

Вот здесь нижнего подчеркивния быть не должно :

ИдФайл="ON_NSCHFDOPPR_7205284368_720501001_4205102924_420501­001_20201208_c092aa33-c0b6-493d-8758-ecdfe1bd5426" ВерсФорм="5.01" ВерсПрог="1С:Предприятие 8"> вУчДокОбор ИдОтпр="7205102924_720501001" ИдПол="7205284368_720501001">

только между ИНН и КПП,. стоит поставить вместо "_" "-" и всё прекрасно.

У меня к вам вопрос : если вы используете из 1с модуль

Обработки.ОбменСКонтрагентами.ПодготовитьДанныеДляЗаполненияДокументов

то он как раз и формирует не точно с нижними подчеркиваниями или вы формируете файл своей обработкой? В файле прикрепленном показал где выгружается файл прямо из 1с.
Прикрепленные файлы:
GopSTOP; tech96; IvStark; Legin; user1865898; Valerianich; osa92; metaeditor; sofi1584; mulla1979; +10 Ответить
18. sofi1584 04.04.22 07:41 Сейчас в теме
(3)не знаю, что там за обработка, но вам преогромнейшее спасибо за ваш абзац текста !!!
19. user1790278 27.05.22 13:33 Сейчас в теме
(3) Спасибо Вам огромное!!!
20. Vladimir_D 119 06.06.22 18:45 Сейчас в теме
(19)Судя по дате комментария, это и сейчас актуально?
Нашел в общем модуле ЭлектронныеДокументыЭдо
Функция СформироватьДанныеДокументовДляВыгрузки(ОписанияОбъектовУчета) Экспорт
//...
		Данные = ФорматыЭДО.НовыеДанныеДляФормированияОсновногоТитула();
		Данные.УникальныйИдентификатор = Строка(Новый УникальныйИдентификатор);
		Данные.Участники.ИдентификаторОтправителя = Выборка.ОрганизацияИНН + ?(ПустаяСтрока(Выборка.ОрганизацияКПП),"",
			"_" + Выборка.ОрганизацияКПП);
		Данные.Участники.ИдентификаторПолучателя = Выборка.КонтрагентИНН + ?(ПустаяСтрока(Выборка.КонтрагентКПП),"",
			"_" + Выборка.КонтрагентКПП);
//...
КонецФункции
Показать

Вероятно, если поправить
Функция СформироватьДанныеДокументовДляВыгрузки(ОписанияОбъектовУчета) Экспорт
//...
		Данные = ФорматыЭДО.НовыеДанныеДляФормированияОсновногоТитула();
		Данные.УникальныйИдентификатор = Строка(Новый УникальныйИдентификатор);
		Данные.Участники.ИдентификаторОтправителя = Выборка.ОрганизацияИНН + ?(ПустаяСтрока(Выборка.ОрганизацияКПП),"",
			"-" + Выборка.ОрганизацияКПП);
		Данные.Участники.ИдентификаторПолучателя = Выборка.КонтрагентИНН + ?(ПустаяСтрока(Выборка.КонтрагентКПП),"",
			"-" + Выборка.КонтрагентКПП);
//...
КонецФункции
Показать

То и выгрузка пойдет... Тоже надо выгрузку в Контур
Ankiss; bluntschi; Legin; yuli; ShOlga; user1543970; igor-pn; osa92; +8 Ответить
22. ShOlga 02.11.22 12:17 Сейчас в теме
(20)
СформироватьДанныеДокументовДляВыгрузки
Спасибо! ВАш комментарий помог, теперь все загружается в Контур без проблем!
23. bluntschi 06.04.23 10:31 Сейчас в теме
(20)а вы не знаете, в УТ такая функция есть? общего модуля не нашла такого(
21. user1865898 28.10.22 14:27 Сейчас в теме
(3)Спасибо огромное за комментарий!Действительно, работает, УПД подгружется в Диадок без проблем
4. artemua 120 11.01.21 16:35 Сейчас в теме
Недопустимое значение параметра (параметр номер '1')
{ВнешняяОбработка.ПолучениеЭлектронногоДокумента.Форма.Форма.Форма(13)}: ТаблицаЭД = ПолучитьИзВременногоХранилища(АдресХранилища);
{ВнешняяОбработка.ПолучениеЭлектронногоДокумента.Форма.Форма.Форма(35)}: АдресМассива = СформироватьЭлектронныйДокументНаСервере();

по причине:
Недопустимое значение параметра (параметр номер '1')


Выдает ошибку при формировании
5. pvb2003 26.01.21 12:18 Сейчас в теме
На БП 3.0.88.28 это работает? Кто то пробовал?
6. pvb2003 26.01.21 22:16 Сейчас в теме
(5)Уже попробовал ... работает!!!
7. s3nick 03.02.21 16:49 Сейчас в теме
Добрый день
у выгружаемого документа упд в печатной форме стоит статус -1
но при выгрузке в XML файл статус меняется на на -2
как победить это не понимаю и еще у нас реализация например 801й а сф806 печатает как 801й номер а должно быть 806
25. Kotyara 16 26.06.23 10:15 Сейчас в теме
(7)Тут все просто. Надо найти вот такую строку в коде:
Результат.Вставить("ИспользуетсяУПД", Ложь);
и заменить ее на:
Результат.Вставить("ИспользуетсяУПД", Истина);

Можно сделать в расширении. Тогда снимать конфигурацию с поддержки не придется.
Через Настройки не получится. Это доступно только тем, кто осуществляет обмен ЭД только посредством самой 1С. Все остальные извращайтесь - стандартная политика 1С
8. pvb2003 09.02.21 13:25 Сейчас в теме
При загрузке в Диадок пишет "неверный формат файла" ...
9. Nik_Vit 08.03.21 01:13 Сейчас в теме
так же в честный знак неверный формат файла
10. psa247 17 16.03.21 09:20 Сейчас в теме
Скачал, проверил на тестовой базе БП 3.0.88. все работает.
файл прошел проверку на диадоке:
https://www.diadoc.ru/docs/forms/validation-xml
Спасибо!
11. bumac 15.04.21 11:33 Сейчас в теме
Добрый день. Обработка плоха в том что:
1. нельзя массово выгрузить за период электронные документы. Приходиться щелкать по каждому, что занимает много времени.
2. Для того что бы например загрузить XML в СБИС, ранее созданный архив нужно разархивировать и вытащить XML форму затем загрузить уже в СБИС. Это ещё дополнительные телодвижения..
12. cmd_vasec 34 03.06.21 15:55 Сейчас в теме
(11)
Вы можете изменить обработку под свои нужды. Это пример для дальнейшей работы.
13. zexpress 07.06.21 23:15 Сейчас в теме
После обновлений 1С работать перестала
15. blackhorse1976 29 24.08.21 15:13 Сейчас в теме
(13) Обновилась библиотека электронного документооборота.
Готовлю публикацию с новым кодом
https://infostart.ru/public/1503418/
14. silverr 14 20.07.21 16:31 Сейчас в теме
Всем доброго времени суток!
Данный механизм уже реализован "стандартной" внешней обработкой от Тензора. ЭЦП на компьютере где происходит выгрузка можно не иметь, у нас вышло именно так. Внешняя обработка универсальная, т.е. для большинства конфигураций.
С оф.сайта скачиваем свой вариант (управляемые или неуправляемые формы). Запускаете обработку, выбираете в настройках обмен через каталог. Пункт главного меню "Настройки" - "Файлы настроек" - выделяете внизу левого списка УПД (рис. Файлы настроек) и добавляете их в правый список.
Далее в разделе "Продажи" выбираете подраздел "УПД", отмечаете нужные документы и жмете кнопку "Отправить".
В указанной выше в настройках папке обмена находим файлы выгрузки, их мы и будем грузить, кстати тоже списком. СБИС для каждой УПД создаст пакет самостоятельно. Файлы "KONVERT" грузить не надо.
Всем удачи. Автору плюс.
Прикрепленные файлы:
tech96; Date; mixperez; +3 Ответить
16. AlimovaOS 12.10.21 14:06 Сейчас в теме
Не работает УНФ 1.6.25.212 , не доступны кнопки выбора документа
17. A.E. 16.02.22 12:25 Сейчас в теме
(8)Добрый день. Приложение для смартфона от ЧЗ не пробовали для наполнения УПД кодами?
(16)Добрый день. Ищите xprint.PLUS
24. user1946955 12.05.23 10:45 Сейчас в теме
Добрый день.
При подписание УПД в СБИСе выходит такая ошибка:
Не совпадают подписант в файле "Передаточный документ 30.04.23 № 56 на сумму 5 038.68 р., без НДС" и реквизиты сертификата подписи
Имя в файле "-", а в сертификате "СЕРГЕЙ". Отчество в файле "", а в сертификате "МИХАЙЛОВИЧ". Фамилия в файле "-", а в сертификате "Иванов"
Месяц назад выгружала из 1С все нормально было. Где поправить в 1С?
26. Tarlich 116 12.12.23 11:49 Сейчас в теме
маркировку не реализовывали ?
Оставьте свое сообщение