Универсальная загрузка из файла (без разрывов страниц)

28.06.12

Интеграция - Файловый обмен (TXT, XML, DBF), FTP

В реальной жизни документы, которые присылаю в электронном виде сформированных в других информационных системах, в формате для печати на принтер (вставлены разрывы страниц, пустые строки, промежуточные итоги, шапки таблиц на новых листах и тд и тп). Загружает В Справочники, Табличные части документов, Регистр сведений.

Скачать исходный код

Наименование Файл Версия Размер
ЗагрузкаДанныхИзТД81+.epf
.epf 62,21Kb
23
.epf 62,21Kb 23 Скачать
ЗагрузкаДанныхИзТД82+.epf
.epf 64,36Kb
9
.epf 64,36Kb 9 Скачать

Конечно, есть много статей в интернете как загрузить из файлов различных форматов в табличную часть документа. Даже 1С на диске ИТС «\1CIts\EXE\EXTREPS\UNIREPS81\UploadFromTableDocument.epf». Но обычно все они оторваны от жизни или требуют дополнительные ручные манипуляции.


 

Инструкция по доработке обработки от 1С.


 

1. Добавляем кнопку на форме, например, «УбратьРазрывы». В обработчик «нажатия» вставляем текст и добавляем свою процедуру в модуле формы:


 
Процедура КоманднаяПанельТабличногоДокументаУбратьРазрывы(Кнопка)
        ПерваяСтрока = ПерваяСтрокаДанныхТабличногоДокумента;
        ТабличныйДокумент = ЭлементыФормы.ТабличныйДокумент;
        КоличествоСтрок = 999;         //Максимальная строка в документе
        КоличествоКолонок = 255;       //Максимальная колонка в документе 
        КолонкаНумерацииСписок = Новый Массив;
        КолонкаНумерации = 0;
        А = 1;
        
        Пока КолонкаНумерации = 0 Цикл 
               ПоискКолонкиНумерации(ТабличныйДокумент, ПерваяСтрока + А - 1, А, КолонкаНумерацииСписок);
               Если КолонкаНумерацииСписок.Количество() = 0 Тогда 
                       Прервать;                      
               ИначеЕсли КолонкаНумерацииСписок.Количество() = 1 Тогда 
                       КолонкаНумерации = КолонкаНумерацииСписок[0];
                       Прервать;
               КонецЕсли;
               А = А + 1
        КонецЦикла;;
        
        Если КолонкаНумерацииСписок.Количество() = 0 Тогда 
               Сообщить("Не удалось определить колонку нумерации.");
               Возврат;
        Иначе 
               КолонкаНумерации = КолонкаНумерацииСписок[0];
               //Сообщить("Колонка нумерации = " + КолонкаНумерации);
        КонецЕсли;
        
        ТаблицаРазрывов = Новый ТаблицаЗначений;
        ТаблицаРазрывов.Колонки.Добавить("НачалоРазрыва");
        ТаблицаРазрывов.Колонки.Добавить("КонецРазрыва");
        ТекущаяСтрока = 1;
        НачалоРазрыва = 0;
        КонецРазрыва = 0;
        
        Для А = ПерваяСтрока По КоличествоСтрок Цикл 
               Попытка
                       ТекущаяЯчейка = Число(ТабличныйДокумент.Область("r" + А + "c" + КолонкаНумерации).Текст);      
               Исключение
                       Если НачалоРазрыва = 0 Тогда 
                               НачалоРазрыва = А;     
                       КонецЕсли;
               КонецПопытки;
               
               Если ТекущаяЯчейка = ТекущаяСтрока Тогда 
                       Если НачалоРазрыва <> 0 Тогда 
                               КонецРазрыва = А - 1;
                               Строка = ТаблицаРазрывов.Добавить();
                               Строка.НачалоРазрыва = НачалоРазрыва;
                               Строка.КонецРазрыва = КонецРазрыва;
                               НачалоРазрыва = 0;
                       КонецЕсли;
                       ТекущаяСтрока = ТекущаяСтрока + 1;                           
               КонецЕсли;
        КонецЦикла;
        
        Если ТекущаяСтрока <> ТекущаяЯчейка Тогда 
               Строка = ТаблицаРазрывов.Добавить();
               Строка.НачалоРазрыва = НачалоРазрыва;
               Строка.КонецРазрыва = 0;
        КонецЕсли;     
        
        Если ТаблицаРазрывов.Количество() <> 0 Тогда 
               ТабличныйДокумент2 = Новый ТабличныйДокумент;
               Начало = 1;
               Для Каждого Элемент Из ТаблицаРазрывов Цикл 
                       Секция = ТабличныйДокумент.ПолучитьОбласть("R" + Начало + ":R" + (Элемент.НачалоРазрыва - 1));
                       ТабличныйДокумент2.Вывести(Секция);
                       Начало = Элемент.КонецРазрыва + 1;
               КонецЦикла;
               ТабличныйДокумент.Очистить();
               Секция = ТабличныйДокумент2.ПолучитьОбласть("R1:R" + (ПерваяСтрока - 1 + ТекущаяСтрока - 1));
               ТабличныйДокумент.Вывести(Секция);
        КонецЕсли;
КонецПроцедуры
 
Процедура ПоискКолонкиНумерации(ТабличныйДокумент, ПерваяСтрока, Значение, КолонкаНумерацииСписок)
        КолонкаНумерацииСписок2 = Новый Массив;
        
        Для а = 1 По 100 Цикл 
               Попытка
                       ТекущаяЯчейка = Число(ТабличныйДокумент.Область("r" + ПерваяСтрока + "c" + а).Текст);       
               Исключение
                       Продолжить;
               КонецПопытки;
               
               Если ТекущаяЯчейка = Значение Тогда 
                       КолонкаНумерацииСписок2.Добавить(а);                         
               КонецЕсли;
        КонецЦикла;
        
        Если КолонкаНумерацииСписок.Количество() = 0 Тогда 
               КолонкаНумерацииСписок = КолонкаНумерацииСписок2;
        Иначе 
               КолонкаНумерацииСписок3 = Новый Массив;
               Для Каждого Элемент из КолонкаНумерацииСписок2 Цикл 
                       Строка = КолонкаНумерацииСписок.Найти(Элемент);
                       Если Строка <> Неопределено Тогда 
                               КолонкаНумерацииСписок3.Добавить(Строка);     
                       КонецЕсли;
               КонецЦикла;
               КолонкаНумерацииСписок.Очистить();
               КолонкаНумерацииСписок = КолонкаНумерацииСписок3;
        КонецЕсли;
КонецПроцедуры

 

 

2. Инструкция по эксплуатации стандартной обработки //infostart.ru/public/97416/


 

См. также

SALE! 15%

Синхронизация и обмен для ERP 2.5, КА 2.5, УТ 11.5 БП 3.0, Розница, УНФ и других с EnterpriseData (универсальный формат обмена), правила обмена

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен и синхронизацию в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    137256    747    292    

399

Перенос данных из ERP 2 / КА 2 / УТ 11 в БП 3.0. Переносятся документы, начальные остатки и справочники

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

34650 руб.

15.04.2019    69740    172    143    

113

Перенос данных из УТ 10.3 в УТ 11.5. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3.87.x и УТ 11.5.16.x

28000 руб.

23.07.2020    47850    207    64    

169

[ED2] Обмен УПП 1.3, КА 1.1, УТ 10.3 с EnterpriseData (универсальный формат обмена), обработка

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Платформа 1C v8.2 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием Россия Платные (руб)

Регулярный обмен, выгрузка, перенос из КА 1.1, УПП 1.3, УТ 10.3 для обмена с любыми конфигурациями, поддерживающими обмен в формате EnterpriseData (КД3) - БП 3.0, ERP, КА 2, УТ 11, Розница 2, УНФ 1.6 и другими. Правила для старых и доработанных конфигураций не требуют синхронного обновления и совместимы с новыми и будущими конфигурациями. Обмен по расписанию, через папку, FTP, почту.

14580 руб.

18.02.2016    183999    570    509    

513

Переход и перенос данных из УПП 1.3 в ERP 2.5, КА 2.5. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 Бухгалтерский учет Управленческий учет Платные (руб)

Переход и перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:ERP Управление предприятием 2.5 и 1С:Комплексную автоматизацию 2.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x), ERP 2.5 (2.5.16.x), КА 2.5 (2.5.16.x) .

28000 руб.

24.06.2020    61924    47    27    

78

Перенос данных из ERP 2 / КА 2 в ЗУП 3. Переносятся остатки, документы и справочники

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из ERP в ЗУП 3 | из КА 2 в ЗУП | Воспользовались более 79 предприятий! | Готовые правила конвертации данных (КД 2) для переноса остатков, документов с движениями и справочной информации 3 | В продаже с 2020г. | Оперативно обновляем правила до актуальных релизов 1С | Есть перенос начальной задолженности по зарплате и начальной штатной расстановки на выбранную дату | Обороты за прошлые годы (данные для расчета среднего) переносятся свернуто в документ "Перенос данных" | Есть фильтр по организациям | Документы за текущий период переносятся сразу с движениями, поэтому не потребуется делать перерасчеты | Перенос можно проверить перед покупкой, обращайтесь!

43450 руб.

03.12.2020    34969    84    59    

82

Перенос данных из УПП 1.3 в БП 3.0. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x) и БП 3.0 (3.0.151.x). Правила подходят для версии ПРОФ и КОРП.

28000 руб.

15.12.2021    21361    138    40    

97

Перенос данных из УПП 1.3 / КА 1.1 в БП 3. Переносятся документы, справочники и начальные остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

В продаже с 2015 года | Воспользовались более 287 предприятий! | Перенос данных из УПП 1.3 в БП 3.0 | из КА 1.1 в БП 3.0 | Переносятся документы, начальные остатки и вся справочная информация | Сэкономьте свое время - используйте готовое решение для перехода! | Есть фильтр по организации и множество других параметров выгрузки | Поддерживается несколько сценариев работы: как первичный полный перенос, так и перенос только новых документов | Перенос данных возможен в "1С: Бухгалтерия 3.0" версии ПРОФ, КОРП или базовую | Переход с "1С: Управление производственным предприятием 1.3" / "1С:Комплексная автоматизация 1.1" на "1С:Бухгалтерия предприятия 3.0" с помощью наших правил конвертации будет максимально комфортным! | Над развитием алгоритмов и улучшением качества переноса Можно бесплатно проверить перенос на вашем сервере!

39500 руб.

25.02.2015    169234    292    251    

373
Оставьте свое сообщение