Пример обращения с файлами на тонком клиенте

17.11.15

Интеграция - Файловый обмен (TXT, XML, DBF), FTP

Статья и приложенная к ней обработка представляет академический интерес. В ней приведен пример простого и масштабируемого создания dbf-файлов на сервере. Получение их на клиенте. А затем создание архива из этих файлов внешним архиватором.

Скачать исходный код

Наименование Файл Версия Размер
Обработка с примерами
.epf 358,75Kb
9
.epf 1.0.0.1 358,75Kb 9 Скачать

Обработка по требованию пользователя создает dbf-файлы на сервере с помощью процедур, описанных в модуле объекта. Эти действия выполняет нижеприведенная процедура.

&НаКлиенте
Процедура Выгрузить(Команда)
	
	Если не ЗначениеЗаполнено(ПутьКФайлу) Тогда 
		Сообщить ("Не выбран каталог выгрузки данных!");	
		Возврат;
	КонецЕсли;	
	
	ИмяАрхива = "dict"+СтрЗаменить(Формат(ТекущаяДата(),"ДЛФ=D"),".","")+".zip";
	
	ОчиститьВременнуюПапкуНаКлиенте();
	ОчиститьВременнуюПапкуНаСервере();
	
	СоздатьПапкуНаСервере();
	СоздатьПапкуНаКлиенте();	
	
	ВыгрузитьДанныеНаСервере(ИмяАрхива);
	ПереместитьФайлыССервераНаКлиент();
	ОчиститьВременнуюПапкуНаСервере();
	
	ВрКаталогКлиента = ПолучитьИмяВременнойПапкиНаКлиенте();
	ЗапаковатьФайлыВАрхивНаКлиенте(ВрКаталогКлиента+ИмяАрхива,ВрКаталогКлиента,"*.dbf");
	КопироватьФайл(ВрКаталогКлиента+ИмяАрхива,?(Прав(ПутьКФайлу,1)="\",ПутьКФайлу+"",ПутьКФайлу+"\")+ИмяАрхива);
	ОчиститьВременнуюПапкуНаКлиенте();
	
КонецПроцедуры

Файлы создаются на сервере с помощью запросов и процедуры ПерелитьТЗвXBase.

&НаСервере
Процедура ПерелитьТЗвXBase(ИмяДБФ,ДБФ,ТЗ)
	
	ДБФ.Кодировка = КодировкаXBase.OEM;
	ДБФ.СоздатьФайл(ИмяДБФ);
	Для Каждого Строка Из ТЗ Цикл
		ДБФ.Добавить();
		Для Каждого Колонка Из ТЗ.Колонки Цикл
			ДБФ[Колонка.Имя]=Строка[Колонка.Имя];
		КонецЦикла;
		ДБФ.Записать();
	КонецЦикла;
	ДБФ.ЗакрытьФайл();
	
КонецПроцедуры	

&НаСервере
Процедура ВыгрузитьСтраны(КатВрФайлов) Экспорт;
	БД  = Новый XBase;
	БД.Поля.Добавить("Kod","S",3,0);
	БД.Поля.Добавить("Nai","S",30,0);
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	СтраныМира.Код КАК KOD,
		|	СтраныМира.Наименование КАК NAI
		|ИЗ
		|	Справочник.СтраныМира КАК СтраныМира";
	
	тз = Запрос.Выполнить().Выгрузить();
	ПерелитьТЗвXBase(СокрЛП(КатВрФайлов) + "OKSM.dbf",БД,тз);
	
КонецПроцедуры 

Единственным условием при написании процедур, аналогичных процедуре "ВыгрузитьСтраны", является то, что наименование полей XBase и наименование полей в запросе должны совпадать

Затем все файлы через временное хранилище с помощью набота процедур, приведенных в области "РаботаСФайламиКлиентСервер", переносятся во временную папку клиента. Во временной папке клиента они архивируются внешним архиватором. В моем примере использован 7z.

Архиватор хранится в одном из макетов обработки и подготавливается к работе при открытии обработки (см. метод ПриОткрытии). При закрытии обработка подчищает за собой созданные ей файлы.

Затем файл архива переносится в то место на диске, которое указл пользователь в переменой "ПутьКФайлу".

Еще раз подчеркну то, что обработка написана для примера и должна представлять академический интерес.

создание копирование файл dbf на сервере временное хранилище временная папка КаталогВременныхФайлов РабочийКаталогДанныхПользователя

См. также

SALE! 10%

[ED3] Обмен для ERP 2.5, КА 2.5, УТ 11.5 БП 3.0, Розница, УНФ и других с EnterpriseData (универсальный формат обмена), правила обмена

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    135656    730    291    

391

SALE! 10%

Перенос данных из ERP 2 / КА 2 / УТ 11 в БП 3.0. Переносятся документы, начальные остатки и справочники

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

38500 34650 руб.

15.04.2019    68928    181    139    

111

Перенос данных из УПП 1.3 в БП 3.0. Переносятся документы (обороты за период), справочная информация и остатки

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.226.x) и БП 3.0 (3.0.151.x). Правила подходят для версии ПРОФ и КОРП.

28000 руб.

15.12.2021    20672    136    38    

95

SALE! 10%

Перенос данных из ERP 2 / КА 2 в ЗУП 3. Переносятся остатки, документы и справочники

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из ERP в ЗУП 3 | из КА 2 в ЗУП | Воспользовались более 79 предприятий! | Предлагаем приобрести готовые правила конвертации данных (КД 2) для переноса остатков, документов с движениями и справочной информации 3 | В продаже с 2020г. | Оперативно обновляем правила до актуальных релизов 1С | Есть перенос начальной задолженности по зарплате и начальной штатной расстановки на выбранную дату | Обороты за прошлые годы (данные для расчета среднего) переносятся свернуто в документ "Перенос данных" | Есть фильтр по организациям | Документы за текущий период переносятся сразу с движениями, поэтому не потребуется делать перерасчеты | Перенос можно проверить перед покупкой, обращайтесь!

48278 43450 руб.

03.12.2020    34490    83    58    

81

Перенос данных из УТ 10.3 в УТ 11.5. Переносятся документы (обороты за период), справочная информация и остатки

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3 (10.3.87.x) и УТ 11.5 (11.5.16.x).

28000 руб.

23.07.2020    46866    200    64    

162

SALE! 10%

Перенос данных из БП 3.0 в УНФ 3.0 / УНФ 1.6. Переносятся остатки, документы и справочная информация

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление нашей фирмой 3.0 Россия Платные (руб)

В продаже с 2018г. | Воспользовались более 41 предприятия! | Правила конвертации (КД 2) для переноса данных из БП 3 в УНФ | Переносятся все виды документов, начальные остатки и вся возможная справочная информация | Есть фильтр по организациям | Оперативно обновляем на новые релизы | Оказываем техподдержку | В комплект файлов входит инструкция, авторская версия обработки "Универсальный обмен...", актуальные правила переноса данных и архив старых версий переноса | Учет в БП 3 должен быть корректным, некорректные данные не переносятся | Можно бесплатно проверить на вашем сервере до покупки!

50722 руб.

10.07.2018    67829    41    123    

46

Загрузка номенклатуры c картинками (несколько потоков одновременно) и сопутствующими данными в базу и любые документы из yml, xls, xlsx, xlsm, ods, ots, csv для УТ 10.3, УТ 11 (все), БП 3, КА 2, ERP 2, УНФ 1.6/3.0, Розница 2

Загрузка и выгрузка в Excel Логистика, склад и ТМЦ Ценообразование, анализ цен Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Платные (руб)

Эволюция не стоит на месте - новая удобная версия функциональной обработки для Вашего бизнеса! Что же Вы получаете? Удобный и интуитивно понятный интерфейс с 3-мя этапами работы. 2 режима - автоматический и ручной. Чтение XLSX, XLSM, CSV, XML/YML форматов без офиса, на любом сервере! Визуальное связывание колонок файла и реквизитов простым перетаскиванием колонок. Создание или обновление номенклатуры с иерархией, характеристик, доп. реквизитов, упаковок, загрузка практически неограниченного количества картинок на одну номенклатуру (с возможностью загрузки в несколько потоков одновременно), с хранением в томах или в базе. Загрузка номенклатуры поставщиков или поиск по их данным номенклатуры. Загрузка доп. реквизитов в характеристики. Загрузка штрихкодов с генерацией новых. Создание элементов справочников и ПВХ "на лету" для выбранных реквизитов. (Обновление от 09.04.2024, версия 9.9 - 9.10)

14400 руб.

20.11.2015    151547    367    376    

503

SALE! 10%

Перенос данных из УТ 10.3 в УТ 11 / КА 2 / ERP 2. Переносятся документы, справочники и остатки

Обмен между базами 1C Взаиморасчеты Оптовая торговля Логистика, склад и ТМЦ Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление торговлей 10 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Управленческий учет Платные (руб)

Можно проверить до покупки, оставьте заявку! Воспользовались более 268 компаний! Перенос в продаже с 2015г., и мы постоянно работаем над его развитием. Перенос данных из УТ 10.3 в УТ 11 | из УТ 10.3 в КА 2 | из УТ 10.3 в ERP. Предлагаем качественное и проверенное временем решение для перехода с УТ 10.3. Можно перенести начальные остатки, нормативно-справочную информацию и все возможные документы. При выгрузке можно установить отбор по периоду, организациям и складам. При выходе новых релизов конфигураций 1C оперативно выпускаем обновление переноса данных.

50722 45650 руб.

24.04.2015    190867    270    239    

270
Оставьте свое сообщение