Обработка в JSON формате + бонус "Суперсила"

23.06.16

Интеграция - Файловый обмен (TXT, XML, DBF), FTP

Пример обработки для чтения/Запись формата JSON, с источником/приемником com-массивом.

Скачать исходный код

Наименование Файл Версия Размер
json
.epf 6,73Kb
43
.epf 6,73Kb 43 Скачать

JSON

 Обработка для записи JSON потребовалась совсем недавно, заказчик переходит на данный формат, и сперва возник вопрос: зачем "?", разве не хватает xml? Но, немного почитав про данный формат, пришел к выводу, что он как раз может заменить "тормозной" и тяжелый xml, буквально на днях столкнулся с обработкой xml в данной публикации //infostart.ru/public/428819/, где содержалось 100 тыс. объектов и 1С от этого числа буквально поплохело). Начиная с версии 8.3.6 данный формат поддерживается  1С встроенными методами. 

ЗАПИСЬ

Из описания процедуры:

// При записи JSON вы самостоятельно формируете его структуру. Чтобы «подстраховать» вас от ошибок, объект ЗаписьJSON автоматически проверяет правильность записываемой структуры. 
// Для увеличения скорости работы эту проверку можно отключить. В примере ниже это строка:
ЗаписьJSON.ПроверятьСтруктуру = Ложь;

// Также при записи вы можете управлять некоторыми параметрами формируемого текста, например использованием двойных кавычек, переносом строк, символами отступа и экранированием символов. 

// Потоковая запись JSON может выглядеть следующим образом. Записывается массив из четырёх элементов. Три из них примитивного типа, а четвёртый элемент - это объект с двумя свойствами:
// Пример записи JSON. ЗаписьJSON = Новый ЗаписьJSON;
// Для увеличения скорости работы можно отключить автоматическую проверку // правильности структуры записываемого документа JSON. ЗаписьиЗСЖ.ПроверятьСтруктуру = Ложь;
// Для красоты результирующего текста можно увеличить "лесенку".
// Стандартный отступ - 1 пробел.
ПараметрыЗаписиJSON = Новый ПараметрыЗаписиJSON( , Символы.Таб);
// Либо открыть файл, в который будет выполнена запись,
// либо указать, что запись будет выполнена в строку, которую вернет метод Закрыть().
ЗаписьJSON.ОткрытьФайл("ИмяФайла", , , ПараметрыЗаписиJSON);
//ЗаписьJSON.УстановитьСтроку(ПараметрыЗаписиJSON);
// Записать массив.
ЗаписьJSON.ЗаписатьНачалоОбъекта();
ЗаписьJSON.ЗаписатьИмяСвойства("СвойствоТипаМассив");
ЗаписьJSON.ЗаписатьНачалоМассива();
// Первый элемент массива - Строка. ЗаписьJSON.ЗаписатьЗначение("Значение строка");
// Второй элемент массива - Число. ЗаписьJSON.ЗаписатьЗначение(12.345, Истина);
// Третий элемент массива - Булево. ЗаписьJSON-ЗаписатьЗначение(Истина);
// Четвертый элемент массива - объект с двумя свойствами. ЗаписьJSON.ЗаписатьНачалоОбъекта();
// Первое свойство объекта - Строка
ЗаписьJSON.ЗаписатьИмяСвойства("СвойствоТипаСтрока");
ЗаписьJSON.ЗаписатьЗначение("Значение строка");
// Второе свойство объекта - Неопределено
ЗаписьJSON.ЗаписатьИмяСвойства("СвойствоТипаНеопределено");
ЗаписьJSON.ЗаписатьЗначение(Неопределено);
ЗаписьJSON.ЗаписатьКонецОбъекта();
Запись JSON. ЗаписатьКонецМассива () ;
ЗаписьJSON.ЗаписатьКонецОбъекта();
ЗаписьJSON.Закрыть();
//CTpoKaJSON = ЗаписьJSON.Закрыть();  

Теперь как это выглядит в реальности на примере процедуры через com-массив. Почему именно массив "?", попробуйте прогнать "миллионную" таблицу через выборку полей RecordSet, и разница будет ощутимой Smile Основное назначение - синхронизация, обмен данными большого объема, структурированными данными без возможности соединиться с базами напрямую провайдерами. Если ваш EDI-провайдер еще не перешел на поддержку данного формата, это произойдет уже скоро ). 

&НаСервере
Процедура ПрайсЗаписьJSON() Экспорт
    
    Сообщить(" Выгрузка прайс-листа... ");
    
    Connection = Новый COMОбъект("ADODB.Connection");
    Connection.ConnectionString = "Provider=SQLOLEDB;User ID=sa;Password=;Initial Catalog=;Data Source=";
    Connection.Open();
    
    ИмяФайла = "C:\Price.json";
    
    Query = "...запрос TSQL...";
    
    Попытка
        COMObject = Connection.Execute(Query);
        COMSafeArray = COMObject.GetRows();
    Исключение
        Сообщить(Query + " // " + ОписаниеОшибки());
    КонецПопытки;
    
    ЗаписьJSON = Новый ЗаписьJSON;
    ЗаписьJSON.ПроверятьСтруктуру = Ложь;
    
    ПараметрыЗаписиJSON = Новый ПараметрыЗаписиJSON( , Символы.Таб);
    ЗаписьJSON.ОткрытьФайл(ИмяФайла, , , ПараметрыЗаписиJSON);
    
    providerName = "ООО";
    updateDate = Формат(ТекущаяДата(), "ДФ=дд.ММ.гггг");
    
    ЗаписьJSON.ЗаписатьНачалоОбъекта();
    ЗаписьJSON.ЗаписатьИмяСвойства("providerName"); ЗаписьJSON.ЗаписатьЗначение(providerName);
    ЗаписьJSON.ЗаписатьИмяСвойства("updateDate"); ЗаписьJSON.ЗаписатьЗначение(updateDate);
    ЗаписьJSON.ЗаписатьИмяСвойства("items");
    ЗаписьJSON.ЗаписатьНачалоМассива();
    
    Для Индекс = 0 по COMSafeArray.GetUpperBound() - 1 Цикл
        
        code = Строка(COMSafeArray.GetValue(Индекс, 0)); //Код товара поставщика
        name = Строка(COMSafeArray.GetValue(Индекс, 1)); //Наименование товара
        manufacturer = Строка(COMSafeArray.GetValue(Индекс, 2)); //Производитель
        manufacturerCountry = Строка(COMSafeArray.GetValue(Индекс, 3)); //Страна
        barcode = Строка(COMSafeArray.GetValue(Индекс, 4)); //Штрихкод производителя
        quantity = Число(COMSafeArray.GetValue(Индекс, 5)); //Количество
        price = Число(COMSafeArray.GetValue(Индекс, 6)); //Цена с НДС, руб.
        Если Число(COMSafeArray.GetValue(Индекс, 6)) > 0 Тогда
            multiplicity = (COMSafeArray.GetValue(Индекс, 7)); //Кратность
        Иначе
            multiplicity = 1; //Кратность
        КонецЕсли;
        ratends = Число(COMSafeArray.GetValue(Индекс, 8)); //Ставка НДС, %
        expirationDate = ""; //Срок годности
        
        ЗаписьJSON.ЗаписатьНачалоОбъекта();
        ЗаписьJSON.ЗаписатьИмяСвойства("code"); ЗаписьJSON.ЗаписатьЗначение(code);
        ЗаписьJSON.ЗаписатьИмяСвойства("name"); ЗаписьJSON.ЗаписатьЗначение(name);
        ЗаписьJSON.ЗаписатьИмяСвойства("manufacturer"); ЗаписьJSON.ЗаписатьЗначение(manufacturer);
        ЗаписьJSON.ЗаписатьИмяСвойства("manufacturerCountry"); ЗаписьJSON.ЗаписатьЗначение(manufacturerCountry);
        ЗаписьJSON.ЗаписатьИмяСвойства("barcode"); ЗаписьJSON.ЗаписатьЗначение(barcode);
        ЗаписьJSON.ЗаписатьИмяСвойства("quantity"); ЗаписьJSON.ЗаписатьЗначение(quantity);
        ЗаписьJSON.ЗаписатьИмяСвойства("price"); ЗаписьJSON.ЗаписатьЗначение(price);
        ЗаписьJSON.ЗаписатьИмяСвойства("multiplicity"); ЗаписьJSON.ЗаписатьЗначение(multiplicity);
        ЗаписьJSON.ЗаписатьИмяСвойства("ratends"); ЗаписьJSON.ЗаписатьЗначение(ratends);
        ЗаписьJSON.ЗаписатьИмяСвойства("expirationDate"); ЗаписьJSON.ЗаписатьЗначение(expirationDate);
        ЗаписьJSON.ЗаписатьКонецОбъекта();
        
    КонецЦикла;
    
    ЗаписьJSON.ЗаписатьКонецМассива();
    ЗаписьJSON.ЗаписатьКонецОбъекта();
    ЗаписьJSON.Закрыть();
    
    Connection.Close();
    
КонецПроцедуры

 

"СУПЕРСИЛА" - небольшое отступление от темы.

  Как создать формат json без цикла строк, казалось бы не реально? Но вот T-SQL запрос...)))

Аналог запроса можно проверить на "FOR xml PATH", "FOR json PATH" будет работать только на последней версии SQL Server.

  Посмотрел пару сериализаторов на паблике, но типовой от 1С на мой вкус самый простейший http://v8.1c.ru/o7/201501json/index.htm:

В результате будет получен файл JSON следующего содержания:

{
	"#type": "jcfg:CatalogObject.Контрагенты",
	"#value": {
		"IsFolder": false,
		"Ref": "3d710076-8d04-11dc-8ca0-000d8843cd1b",
		"DeletionMark": false,
		"Parent": "9d5c422c-8c4c-11db-a9b0-00055d49b45e",
		"Code": "000000012",
		"Description": "Мосхлеб ОАО",
		"Регион": "9d5c422f-8c4c-11db-a9b0-00055d49b45e",
		"Индекс": "456789",
		"Страна": "Россия",
		"Город": "Москва",
		"Улица": "Петровка",
		"Дом": "12",
		"Телефон": "+7(999)234-78-64",
		"ЭлектроннаяПочта": "mh@hleb.ru",
		"Факс": "",
		"ВебСайт": "",
		"ВидЦен": "9d5c4225-8c4c-11db-a9b0-00055d49b45e",
		"ДополнительнаяИнформация": "Поставка хлеба",
		"КонтактноеЛицо": "Громышева П.Р.",
		"Широта": 55.762744,
		"Долгота": 37.618102
	}
}

 

ЧТЕНИЕ

Рассмотрим, как происходит чтение, пример с обработкой формы заявки от покупателя будет опубликован чуть позже, сейчас как это выглядит в теории:

// Пример чтения JSON.
ЧтениеJSON = Новый ЧтениеJSON;
// Либо открыть файл, из которого будет выполняться чтение, // либо установить строку, из которой будет выполняться чтение.
ЧтениеJSON.ОткрытьФайл("ИмяФайла");
//ЧтениеJSON.УстановитьСтроку("СтрокаJSON");
Пока ЧтениеJSON.Прочитать() Цикл
    TипJSON = ЧтениеJSON.ТипТекущегоЗначения;
    Если TипJSON = ТипЗначенияJSON.Число ИЛИ TипJSON = ТипЗначенияJSON.Строка ИЛИ TипJSON = ТипЗначенияJSON.Булево ИЛИ TипJSON = ТипЗначенияJSON.Null Тогда
        // Обработать значение
        Значение = ЧтениеJSON.ТекущееЗначение;
    ИначеЕсли ТипJSON = ТипЗначенияJSON.Комментарий Тогда
        // Обработать комментарий
        Комментарий = ЧтениеJSON.ТекущееЗначение;
    ИначеЕсли TипJSON = ТипЗначенияJSON.ИмяСвойства Тогда
        // Обработать имя свойства
        ИмяСвойства = ЧтениеJSON.ТекущееЗначение;
    ИначеЕсли TипJSON = ТипЗначенияJSON.НачалоМассива ИЛИ TипJSON = ТипЗначенияJSON.КонецМассива ИЛИ TипJSON = ТипЗначенияJSON.НачалоОбъекта ИЛИ TипJSON = ТипЗначенияJSON.КонецОбъекта ИЛИ TипJSON = ТипЗначенияJSON.Ничего Тогда
        // Обработать начало/конец массива/объекта или отсутствие данных, // ТекущееЗначение читать не нужно.
    КонецЕсли;
КонецЦикла;
ЧтениеJSON.Закрыть();

ЗАЯВКА

Вот и пришла долгожданная заявка, но где же код адреса О_О? Пока разбираемся с этим вопросом, рассмотрим формат:

{  
   "providerName":"Феникс",
   "orderNumber":"23415",
   "orderDate":"01.12.2015",
   "filial":"Аптека 1",
   "address":"6afc1644-342c-11e6-80d6-00155d020c01",
   "items":[  
      {  
         "code":"4261",
         "name":"Капотен 25мг №40 табл Акрихин",
         "manufacturer":"Акрихин ХФК ОАО Россия",
         "manufacturerCountry":"Россия",
         "barcode":"4601969000580",
         "quantity":1,
         "price":185.92,
         "multiplicity":1,
         "expirationDate":"01.10.2019"
      },
      {  
         "code":"4264",
         "name":"Гастрофарм 2,5 №6 табл",
         "manufacturer":"НАЦИОНАЛЬНАЯ ДИСТРИБЬЮТОРСКАЯ КОМПАНИЯ",
         "manufacturerCountry":"Болгария",
         "barcode":"3800043700519",
         "quantity":2,
         "price":52.32,
         "multiplicity":1,
         "expirationDate":"01.05.2017"
      }
   ]
}

Он особо не отличается от отправленного нами прайс-листа, попробуем его обработать через наш "коннектор 1С" и передать в КИС на базе СУБД MS SQL.

FileName = КаталогЗагрузки + "\" + Строка(objFile.Name);

Сообщить(FileName);

items = 0;

ЧтениеJSON = Новый ЧтениеJSON;
ЧтениеJSON.ОткрытьФайл(FileName);
Пока ЧтениеJSON.Прочитать() Цикл
    
    TипJSON = ЧтениеJSON.ТипТекущегоЗначения;
    Если TипJSON = ТипЗначенияJSON.Число ИЛИ TипJSON = ТипЗначенияJSON.Строка ИЛИ TипJSON = ТипЗначенияJSON.Булево ИЛИ TипJSON = ТипЗначенияJSON.Null Тогда
        Значение = ЧтениеJSON.ТекущееЗначение;
    ИначеЕсли TипJSON = ТипЗначенияJSON.Комментарий Тогда
        Комментарий = ЧтениеJSON.ТекущееЗначение;
    ИначеЕсли TипJSON = ТипЗначенияJSON.ИмяСвойства Тогда
        ИмяСвойства = ЧтениеJSON.ТекущееЗначение;
    КонецЕсли;
    
    Если ИмяСвойства = "providerName" Тогда
        providerName = Значение;
    ИначеЕсли ИмяСвойства = "orderNumber" Тогда
        orderNumber = Значение;
    ИначеЕсли ИмяСвойства = "orderDate" Тогда
        orderDate = Значение;
    ИначеЕсли ИмяСвойства = "filial" Тогда
        filial = Значение;
    ИначеЕсли ИмяСвойства = "address" Тогда
        address = Значение;
    КонецЕсли;
    
    Если TипJSON = ТипЗначенияJSON.НачалоМассива Тогда
        items = 1;
        
        ТТ = Справочники.ТорговыеТочкиАптек.НайтиПоРеквизиту("GUID", address, , );
        
        Док = Документы.ЗаказыАптеки.СоздатьДокумент();
        Док.Тип = 30;
        Док.Номер = orderNumber;
        Док.Дата = ТекущаяДата();
        Док.Контрагент = ТТ.ТорговаяТочкаКИС.Ссылка;
        
    КонецЕсли;
    
    Если items = 1 Тогда
        
        Если TипJSON = ТипЗначенияJSON.НачалоОбъекта и items = 1 Тогда
            СтрокаТовара = Док.ТабличнаяЧасть.Добавить();
        КонецЕсли;
        
        Если ИмяСвойства = "code" Тогда
            code = Значение;
        ИначеЕсли ИмяСвойства = "quantity" Тогда
            quantity = Значение;
        ИначеЕсли ИмяСвойства = "price" Тогда
            price = Значение;
        КонецЕсли;
        
        Если TипJSON = ТипЗначенияJSON.КонецОбъекта Тогда
            СтрокаТовара.Номенклатура = Справочники.Номенклатура.НайтиПоКоду(code);
            СтрокаТовара.Количество = Число(quantity);
            СтрокаТовара.Цена = price; //
        КонецЕсли;
        
    КонецЕсли;
    
    Если TипJSON = ТипЗначенияJSON.КонецМассива Тогда
        items = 0;
    КонецЕсли;
    
КонецЦикла;
ЧтениеJSON.Закрыть();

//DocumentStatus
Док.НомерКИС = orderNumber;

Попытка
    Док.Записать(РежимЗаписиДокумента.Проведение);
Исключение
    Сообщить(ОписаниеОшибки());
КонецПопытки;

Сообщить("Создан заказ № " + orderNumber);

json

См. также

SALE! 10%

Синхронизация и обмен для ERP 2.5, КА 2.5, УТ 11.5 БП 3.0, Розница, УНФ и других с EnterpriseData (универсальный формат обмена), правила обмена

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен и синхронизацию в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 22572 руб.

12.06.2017    136616    730    292    

393

Перенос данных из ERP 2 / КА 2 / УТ 11 в БП 3.0. Переносятся документы, начальные остатки и справочники

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

34650 руб.

15.04.2019    69487    166    141    

112

SALE! 10%

Перенос данных из УТ 10.3 в УТ 11.5. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3 (10.3.87.x) и УТ 11.5 (11.5.16.x).

28000 25200 руб.

23.07.2020    47482    203    64    

164

SALE! 10%

Перенос данных из УПП 1.3 в БП 3.0. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x) и БП 3.0 (3.0.151.x). Правила подходят для версии ПРОФ и КОРП.

28000 25200 руб.

15.12.2021    21066    138    38    

97

Перенос данных из ERP 2 / КА 2 в ЗУП 3. Переносятся остатки, документы и справочники

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из ERP в ЗУП 3 | из КА 2 в ЗУП | Воспользовались более 79 предприятий! | Предлагаем приобрести готовые правила конвертации данных (КД 2) для переноса остатков, документов с движениями и справочной информации 3 | В продаже с 2020г. | Оперативно обновляем правила до актуальных релизов 1С | Есть перенос начальной задолженности по зарплате и начальной штатной расстановки на выбранную дату | Обороты за прошлые годы (данные для расчета среднего) переносятся свернуто в документ "Перенос данных" | Есть фильтр по организациям | Документы за текущий период переносятся сразу с движениями, поэтому не потребуется делать перерасчеты | Перенос можно проверить перед покупкой, обращайтесь!

43450 руб.

03.12.2020    34801    83    58    

81

[ED2] Обмен УПП 1.3, КА 1.1, УТ 10.3 с EnterpriseData (универсальный формат обмена), обработка

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Платформа 1C v8.2 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием Россия Платные (руб)

Регулярный обмен, выгрузка, перенос из КА 1.1, УПП 1.3, УТ 10.3 для обмена с любыми конфигурациями, поддерживающими обмен в формате EnterpriseData (КД3) - БП 3.0, ERP, КА 2, УТ 11, Розница 2, УНФ 1.6 и другими. Правила для старых и доработанных конфигураций не требуют синхронного обновления и совместимы с новыми и будущими конфигурациями. Обмен по расписанию, через папку, FTP, почту.

14580 руб.

18.02.2016    183605    565    508    

509

SALE! 10%

Переход и перенос данных из УПП 1.3 в ERP 2.5, КА 2.5. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 Бухгалтерский учет Управленческий учет Платные (руб)

Переход и перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:ERP Управление предприятием 2.5 и 1С:Комплексную автоматизацию 2.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x), ERP 2.5 (2.5.16.x), КА 2.5 (2.5.16.x) .

28000 25200 руб.

24.06.2020    61668    45    27    

75

Перенос данных из БП 3.0 в УНФ 3.0 / УНФ 1.6. Переносятся остатки, документы и справочная информация

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление нашей фирмой 3.0 Россия Платные (руб)

В продаже с 2018г. | Воспользовались более 41 предприятия! | Правила конвертации (КД 2) для переноса данных из БП 3 в УНФ | Переносятся все виды документов, начальные остатки и вся возможная справочная информация | Есть фильтр по организациям | Оперативно обновляем на новые релизы | Оказываем техподдержку | В комплект файлов входит инструкция, авторская версия обработки "Универсальный обмен...", актуальные правила переноса данных и архив старых версий переноса | Учет в БП 3 должен быть корректным, некорректные данные не переносятся | Можно бесплатно проверить на вашем сервере до покупки!

45650 руб.

10.07.2018    68400    41    124    

46
Отзывы
19. JetBrain 79 11.12.20 23:34 Сейчас в теме
(13) для такого источника данных Массив будет десериализован в массив. Объект JSON будет преобразован в соответствие или структуру:

 	СтрокаJSON    = HTTPОтвет.ПолучитьТелоКакСтроку();
	
	ЧтениеJSON = Новый ЧтениеJSON;
	ЧтениеJSON.УстановитьСтроку(СтрокаJSON);
	Данные = ПрочитатьJSON(ЧтениеJSON, Истина);
Остальные комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. aximo 2033 19.12.15 10:47 Сейчас в теме
приятно видеть, что инструментарий платформы 1с развивается.
2. vano-ekt 124 19.12.15 16:19 Сейчас в теме
//сдесь получаем массив

сдесь желание смотреть код пропало
Oslo696; NN2P; DrAku1a; BigB; +4 Ответить
3. JetBrain 79 19.12.15 18:56 Сейчас в теме
(2) vano-ekt, есть другие варианты обработать COMObject быстрее? Сами варианты то конечно есть...
Или имелось ввиду перегнать сразу за "пару секунд" массив в формат json, без циклов обхода строк, но тогда эта "сверхсекретная" информация не для данного паблика :)
4. CyberCerber 859 21.12.15 09:52 Сейчас в теме
(3) думаю, имелось в виду совсем другое... :-)
Получать массив нужно не сдесь, а здесь.
8. JetBrain 79 22.12.15 22:56 Сейчас в теме
(2) vano-ekt, специально для Вас бонус см. разделе "суперсила", дальше смотреть код и не нужно ;)
5. AndreyNit 59 22.12.15 09:00 Сейчас в теме
Познавательно, автору плюс.
6. dj_serega 392 22.12.15 18:53 Сейчас в теме
А почему:
        code                = Строка(COMSafeArray.GetValue(Индекс,0)); //Код товара поставщика
        name                = Строка(COMSafeArray.GetValue(Индекс,1)); //Наименование товара
        manufacturer        = Строка(COMSafeArray.GetValue(Индекс,2)); //Производитель
        manufacturerCountry = Строка(COMSafeArray.GetValue(Индекс,3)); //Страна
        barcode             = Строка(COMSafeArray.GetValue(Индекс,4)); //Штрихкод производителя
        quantity            = Число(COMSafeArray.GetValue(Индекс,5)); //Количество
        price               = Число(COMSafeArray.GetValue(Индекс,6)); //Цена с НДС, руб.
        Если Число(COMSafeArray.GetValue(Индекс,6)) > 0 Тогда
            multiplicity = (COMSafeArray.GetValue(Индекс,7)); //Кратность 
        Иначе 
            multiplicity = 1; //Кратность 
        КонецЕсли;
        ratends            = Число(COMSafeArray.GetValue(Индекс,8)); //Ставка НДС, %
Показать

И
        ЗаписьJSON.ЗаписатьИмяСвойства("code");                ЗаписьJSON.ЗаписатьЗначение(code);
          ЗаписьJSON.ЗаписатьИмяСвойства("name");                ЗаписьJSON.ЗаписатьЗначение(name);
          ЗаписьJSON.ЗаписатьИмяСвойства("manufacturer");        ЗаписьJSON.ЗаписатьЗначение(manufacturer);
          ЗаписьJSON.ЗаписатьИмяСвойства("manufacturerCountry"); ЗаписьJSON.ЗаписатьЗначение(manufacturerCountry);
          ЗаписьJSON.ЗаписатьИмяСвойства("barcode");             ЗаписьJSON.ЗаписатьЗначение(barcode);
          ЗаписьJSON.ЗаписатьИмяСвойства("quantity");            ЗаписьJSON.ЗаписатьЗначение(quantity);
          ЗаписьJSON.ЗаписатьИмяСвойства("price");               ЗаписьJSON.ЗаписатьЗначение(price);
          ЗаписьJSON.ЗаписатьИмяСвойства("multiplicity");        ЗаписьJSON.ЗаписатьЗначение(multiplicity);
          ЗаписьJSON.ЗаписатьИмяСвойства("ratends");             ЗаписьJSON.ЗаписатьЗначение(ratends);
          ЗаписьJSON.ЗаписатьИмяСвойства("expirationDate");      ЗаписьJSON.ЗаписатьЗначение(expirationDate);
 
Показать

не через общие функции реализовано?
EMelihoff; +1 Ответить
7. JetBrain 79 22.12.15 21:58 Сейчас в теме
(6) dj_serega, задачи такой не ставилось, пример должен быть как можно проще, и каким образом этот сделать?
9. kosmo0 109 23.12.15 10:44 Сейчас в теме
А кусок кода на запись так и должна совпадать с кодом на чтение?
10. JetBrain 79 23.12.15 11:05 Сейчас в теме
(9) kosmo0, нет так не должно быть, блок записи исправил.
11. alex_4x 86 09.02.16 13:22 Сейчас в теме
для 1С 8.2 нет реализации ? чтобы не типовыми методами 8.3 Чтение и запись делать....
12. JetBrain 79 10.02.16 07:15 Сейчас в теме
(11) alex_4x, для 8.2 самописные функции, примеры разные http://infostart.ru/public/59535/
13. user633364_seleznev.ua 17.05.20 13:16 Сейчас в теме
ЗаголовокЗапросаHTTP = Новый Соответствие();
	
	ssl1 = Новый ЗащищенноеСоединениеOpenSSL(
	Новый СертификатКлиентаWindows(СпособВыбораСертификатаWindows.Авто),
	Новый СертификатыУдостоверяющихЦентровWindows());

	//ИмяСервера = "happykids.ru";
	ЗаголовокЗапросаHTTP.Вставить("Content-type", "application/x-www-form-urlencoded;charset=utf-8");
	HTTP =  Новый HTTPСоединение(ИмяСервера,,"", "",,,ssl1);     //Адрес сайта и порт если потребуется. пример - http://localhost:8000
	запросPOST = Новый HTTPЗапрос("/pointWebHook/handler.php");          // адрес url веб-сервиса /api/v1/datafill/ 
	запросPOST.УстановитьИмяФайлаТела(ИмяВременногоФайла);
	
	Стр = ЗапросPost.ПолучитьТелоКакСтроку();
	Попытка
		//Отправляем для обрааботки на наш сервер
		ФайлРезультата = ПолучитьИмяВременногоФайла();
		HTTPОтвет = HTTP.ОтправитьДляОбработки(запросPOST, ФайлРезультата);
		ТекстовыйФайлОтвет = Новый ТекстовыйДокумент;
		ТекстовыйФайлОтвет.Прочитать(ФайлРезультата,КодировкаТекста.UTF8);
		ОтветСервера = ТекстовыйФайлОтвет.ПолучитьТекст();
		
	Исключение
		Сообщить(ОписаниеОшибки());
	КонецПопытки;
Показать
19. JetBrain 79 11.12.20 23:34 Сейчас в теме
(13) для такого источника данных Массив будет десериализован в массив. Объект JSON будет преобразован в соответствие или структуру:

 	СтрокаJSON    = HTTPОтвет.ПолучитьТелоКакСтроку();
	
	ЧтениеJSON = Новый ЧтениеJSON;
	ЧтениеJSON.УстановитьСтроку(СтрокаJSON);
	Данные = ПрочитатьJSON(ЧтениеJSON, Истина);
14. zavsom 104 02.12.20 13:35 Сейчас в теме
{ВнешняяОбработка.json.Форма.Форма.Форма(27,34)}: Переменная не определена (СтрокаЗапроса)
COMObject = Connection.Execute(<<?>>СтрокаЗапроса); (Проверка: Сервер)

Вы хоть проверяете перед тем как продавать?
15. JetBrain 79 05.12.20 09:28 Сейчас в теме
(14) читайте описание:
  Query = "...запрос TSQL...";

    Попытка
        COMObject = Connection.Execute(Query); 
        COMSafeArray = COMObject.GetRows(); 
    Исключение
        Сообщить(Query + " // " + ОписаниеОшибки());
    КонецПопытки;
16. zavsom 104 05.12.20 15:06 Сейчас в теме
Если б было так никто б Вам не написал а там так:
Query = "...запрос TSQL...";

Попытка
COMObject = Connection.Execute(Запрос);
17. zavsom 104 05.12.20 15:07 Сейчас в теме
поправьте - мелочь но некорректно жеж
18. JetBrain 79 10.12.20 09:47 Сейчас в теме
(17) добрый день.
публикация про разбор Json формата, не про работу с внешним источником через odbc. запрос Query и сам источник данных любой произвольный, поэтому и не имеет конкретного кода. его с таким же успехом можно заменить на внутренний запрос 1с .
Оставьте свое сообщение