Повелитель регламентных заданий

24.04.24

Разработка - Инструментарий разработчика

Обработка позволяет комфортно и быстро работать с регламентными и фоновыми заданиями, не требует наличия БСП. Незаменимый инструмент, если в ИБ активно используются регламентные задания.

Скачать исходный код

Наименование Файл Версия Размер
Повелитель регламентных заданий
.epf 170,61Kb
133
.epf 3.1.3 170,61Kb 133 Скачать

Является аналогом обработки из БСП, но с дополнительным функционалом, который в некоторых случаях просто незаменим.

Основные преимущества

  • Работает отдельно от БСП (но можно подключить и как дополнительную обработку, если в конфигурацию встроена БСП).
  • Работает на платформе 8.2.
  • Быстрая работа со списком фоновых заданий (в типовой обработке при большом количестве фоновых заданий работать с ними невозможно).
  • Наборы избранных заданий.
  • Просмотр списка запусков задания по журналу регистрации, а также просмотр всех событий журнала по каждому запуску.
  • Просмотр сообщений, которые выводились в фоновом задании.
  • Индикация состояния использования регламентных задания (включены/выключены), а также возможность включения/отключения блокировки регламентных заданий из обработки.
  • Исключенные задания. Если есть очень много заданий какого-то определенного вида (например, обмены или рассылка отчетов), то их можно исключить из общего списка.
  • Группировка по виду задания (актуально, если по одному виду задания есть несколько экземпляров).
  • Отбор по состоянию задания (активные, включенные, с ошибками и т.д.).
  • Поиск фоновых заданий по регламентному заданию (или виду задания), а также поиск регламентного по фоновому.
  • Отмена выполняющегося регламентного задания из списка (в типовой можно отменять только фоновое задание).
  • Запуск регламентного задания непосредственно (для удобства отладки).
  • Запуск регламентного задания как регламентного (в типовой обработке задание запускается как фоновое).
  • Просмотр всех параметров регламентного задания.

Описание изменений

 

Версия 3.1.3 от 2023-08-05

  • Добавлена возможность не показывать в журнале события "Транзакция начата" и "Транзакция зафиксирована".
  • Исправлены ошибки отображения состояния регламентных и фоновых заданий на новых версиях платформы.

Версия 3.1.0 от 2020-06-28

  • Журнал регистрации разделен на две разные формы: Журнал запусков и Журнал событий. Теперь можно одновременно открыть журнал событий по разным запускам.
  • В форме фоновых заданий теперь можно установить отбор по нескольким регламентным заданиям или видам заданий.
  • В форму фоновых заданий добавлен отбор по признаку «Запущено по регламентному заданию». Теперь можно легко отобрать фоновые задания, запущенные в сеансах пользователей, либо в регламентных заданиях.
  • В журнал запусков добавлена информация о виде регламентного задания.

Версия 3.0.0 от 2020-06-17

  • Изменено название обработки.
  • Добавлен просмотр списка запусков задания по журналу регистрации, а также просмотр всех событий журнала по каждому запуску.
  • Добавлен просмотр сообщений, которые выводились в фоновом задании.
  • Существенно переработан интерфейс, в том числе:
    • Список фоновых заданий теперь открывается в отдельном окне, соответственно, можно открыть несколько таких окон по разным регламентным заданиям.
    • Переработаны отборы по состоянию, теперь пользоваться ими удобнее.
  • Наборы избранных заданий. Теперь можно создать несколько наборов с разным списком избранных заданий.
  • Для многих операций добавлена возможность обработки всех выделенных заданий.
  • Исключенные задания. Теперь можно скрыть некоторые виды регламентных заданий, чтобы они не мешались.
  • Добавлено сохранение настроек в файл.
  • В таблицы регламентных и фоновых заданий добавлено общее время выполнения задания.

Проверено на следующих конфигурациях и релизах:

  • Зарплата и управление персоналом, редакция 3.1, релизы 3.1.27.208

регламентные фоновые задания

См. также

Infostart Toolkit: Инструменты разработчика 1С 8.3 на управляемых формах

Инструментарий разработчика Роли и права Запросы СКД Программист Платформа 1С v8.3 Управляемые формы Запросы Система компоновки данных Конфигурации 1cv8 Платные (руб)

Набор инструментов программиста и специалиста 1С для всех конфигураций на управляемых формах. В состав входят инструменты: Консоль запросов, Консоль СКД, Консоль кода, Редактор объекта, Анализ прав доступа, Метаданные, Поиск ссылок, Сравнение объектов, Все функции, Подписки на события и др. Редактор запросов и кода с раскраской и контекстной подсказкой. Доработанный конструктор запросов тонкого клиента. Продукт хорошо оптимизирован и обладает самым широким функционалом среди всех инструментов, представленных на рынке.

10000 руб.

02.09.2020    131054    711    390    

758

Infostart PrintWizard - создание и редактирование печатных форм в 1С 8.3

Пакетная печать Печатные формы Инструментарий разработчика Программист Платформа 1С v8.3 Запросы 1С:Зарплата и кадры бюджетного учреждения 1С:Конвертация данных 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 Платные (руб)

Инструмент, позволяющий абсолютно по-новому взглянуть на процесс разработки печатных форм. Благодаря конструктору можно значительно снизить затраты времени на разработку печатных форм, повысить качество и "прозрачность" разработки, а также навести порядок в многообразии корпоративных печатных форм.

18000 руб.

06.10.2023    9391    27    6    

49

Infostart УДиФ: Управление данными и формами 1С

Инструменты администратора БД Инструментарий разработчика Роли и права Программист Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Расширение позволяет без изменения кода конфигурации выполнять проверки при вводе данных, скрывать от пользователя недоступные ему данные, выполнять код в обработчиках. Не изменяет данные конфигурации, легко устанавливается практически на любую конфигурацию на управляемых формах.

10000 руб.

10.11.2023    5508    14    2    

39

SALE! %

PowerTools

Инструментарий разработчика Инструменты администратора БД Системный администратор Программист Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Россия Платные (руб)

Универсальный инструмент программиста для администрирования конфигураций. Сборник наиболее часто используемых обработок под единым интерфейсом.

3600 2880 руб.

14.01.2013    179946    1095    0    

868

OneDebugger - инструмент для отладки кода без использования режима конфигуратора

Инструментарий разработчика Программист Платформа 1С v8.3 Платные (руб)

Инструмент для написания и отладки кода в режиме «1С:Предприятие». Представляет собой консоль кода с возможностью пошаговой отладки, просмотра значений переменных любых типов, использования процедур и функций, просмотра стека вызовов, вычисления произвольных выражений на встроенном языке в контексте точки останова, синтаксического контроля и остановки по ошибке. В консоли используется удобный редактор кода с подсветкой, контекстной подсказкой, возможностью вызова конструкторов запроса и форматной строки.

5400 руб.

17.05.2024    6254    13    12    

38

Бустер Конвертации данных 3 (Infostart Toolkit)

Инструментарий разработчика Программист 8.3.14 1С:Конвертация данных Россия Платные (руб)

Расширение для конфигурации “Конвертация данных 3”. Добавляет подсветку синтаксиса, детальную контекстную подсказку, глобальный поиск по коду.

15000 руб.

07.10.2021    15436    3    12    

38

Многопоточность. Универсальный «Менеджер потоков» 2.1

Инструментарий разработчика Программист Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Восстановление партий или взаиморасчетов, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

5000 руб.

07.02.2018    100352    240    97    

299

[ЕХТ] Фреймворк для Расширений 1С

Инструментарий разработчика Программист Платформа 1С v8.3 Управляемые формы Платные (руб)

"Фреймворк для Расширений 1С" это универсальное и многофункциональное решение, упрощающее разработку и поддержку создаваемых Расширений. Поставляется в виде комплекта из нескольких Расширений с открытым исходным кодом. Работает в любых Конфигурациях в режиме Управляемого приложения с режимом совместимости 8.3.12 и выше без необходимости внесения изменений в Конфигурацию.

3000 руб.

27.08.2019    18862    7    8    

42
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Kyrales 145 22.11.16 18:53 Сейчас в теме
Отличная штука.
Просьба поправить заголовок при редактировании регламентного задания: там опечатка.

Объясните как может пригодится возможность добавлять свои параметры при редактировании?
2. krv2k 376 22.11.16 19:26 Сейчас в теме
(1) Kyrales,
Просьба поправить заголовок при редактировании регламентного задания: там опечатка.

Спасибо, исправлю.

Объясните как может пригодится возможность добавлять свои параметры при редактировании?

Это может пригодиться при исправлении ошибок механизмов конфигурации. Например, несколько лет назад в типовой УТ11 некорректно заполнялись параметры одного из заданий (не хватало одного параметра), из-за чего запуск регламентного задания завершался с ошибкой.
3. alfa_1969 65 24.11.16 04:33 Сейчас в теме
работает на обычных формах?
4. krv2k 376 24.11.16 09:33 Сейчас в теме
5. ZLENKO 398 06.01.17 11:17 Сейчас в теме
Порадовала культура написания и оформления кода обработки.
6. krv2k 376 06.01.17 20:42 Сейчас в теме
(5) Приятно удивляет, что в наше время ещё есть те, кто смотрит на код. Спасибо!
8. fixin 4256 26.04.17 10:31 Сейчас в теме
(6) мы, профи, всегда смотрим на код... ггггг...
7. fixin 4256 26.04.17 10:23 Сейчас в теме
Скачал обработку тупо, чтобы отключить все регламентные задания, т.к. доступа к консоли не было, а на копии базы они мешали.

и что же?

Она отключает только одно задание...

Надо переписать примерно так:

&НаКлиенте
Процедура ВключитьВыключитьРегламентноеЗадание(Команда)
	
	//Если Не ЭтоРегламентноеЗадание() Тогда
	//	
	//	Возврат;
	//	
	//КонецЕсли;
	Для Каждого Строка ИЗ Элементы.ДеревоРегламентныхЗаданий.ВыделенныеСтроки Цикл
		ТекущиеДанные = Элементы.ДеревоРегламентныхЗаданий.ДанныеСтроки(Строка);
		ВключитьВыключитьРегламентноеЗаданиеНаСервере(ТекущиеДанные.УникальныйИдентификатор);
	КонецЦикла;
	
	ОбновитьСписокРегламентныхЗаданий();
	
КонецПроцедуры
Показать



Единственно, я выключал группировку и отбирал только включенные задания, чтобы они нормально инвертировались.

Автору, короче, есть еще над чем поработать. Действия должны выполняться не над текущей задачей, а над выделенными.
9. krv2k 376 07.05.17 20:07 Сейчас в теме
(7)
Действия должны выполняться не над текущей задачей, а над выделенными.

Забавно, сегодня у меня появилась такая же необходимость ещё до того, как открыл Ваш комментарий. В следующей версии будет.
10. fixin 4256 07.05.17 23:44 Сейчас в теме
(9) и добавь кнопки Выкл и Вкл активности заданий, а не инверсии их состояния, плиз
13. krv2k 376 29.06.20 09:21 Сейчас в теме
(10) Добавил кнопки вкл/выкл.
17. fixin 4256 29.06.20 18:42 Сейчас в теме
12. krv2k 376 29.06.20 09:21 Сейчас в теме
(7) Добавил обработку выделенных.
11. Dzenn 876 02.10.17 13:57 Сейчас в теме
Добрый день! Хорошая, годная обработка, но есть одно "но" — использование модальных окон нынче не фэншуйно, хорошо бы избавиться от них.
14. krv2k 376 29.06.20 09:22 Сейчас в теме
(11) Пока нужна версия для 8.2, так что не получится избавиться.
15. Kyrales 145 29.06.20 12:37 Сейчас в теме
"Повелитель регламентных заданий" можно ли подключать как внешнюю обработку в конфигурации БСП?
16. krv2k 376 29.06.20 14:40 Сейчас в теме
(15) Да.
Прикрепленные файлы:
18. Kyrales 145 10.07.20 16:32 Сейчас в теме
Если добавить как обработку, потом открыть и далее закрывать, то возникает сообщение о модальности.
Прикрепленные файлы:
21. krv2k 376 14.07.20 20:27 Сейчас в теме
(18) Особенность совместимости с 8.2. В настройках можно отключить этот вопрос.
19. Kyrales 145 10.07.20 16:33 Сейчас в теме
Нельзя свернуть по умолчанию раздел доп.отборы и общие отборы? Очень много места занимает.
20. krv2k 376 14.07.20 20:24 Сейчас в теме
(19) Так как обработка под 8.2, то проблематично. К тому же, доп. отборы часто используются при администрировании заданий, зачем их скрывать?
22. чингачгук 24 03.02.21 20:55 Сейчас в теме
Спасибо за разработку!
Столкнулся с ситуацией, что база самописная, с нуля, соответственно стандартных общих модулей нет. Не мог найти ни одну рабочую обработку по регламентным заданиям, что работала бы в моей ситуации. Ваша заработала!
23. anri99 19.01.23 21:52 Сейчас в теме
За обработку спасибо, но это зачем?
Если ДиалогНастройки.ОткрытьМодально() Тогда

Если вдруг кому понадобится в режиме без модальности:

&НаКлиенте
Процедура НастроитьРасписаниеНаКлиенте()

Если Не ЭтоРегламентноеЗадание() Тогда

Возврат;

КонецЕсли;
ТекущиеДанные = Элементы.ДеревоРегламентныхЗаданий.ТекущиеДанные;
Расписание = РасписаниеРегламентногоЗадания(ТекущиеДанные.УникальныйИдентификатор);
ДиалогНастройки = Новый ДиалогРасписанияРегламентногоЗадания(Расписание);

ОписаниеОповещения = Новый ОписаниеОповещения("ОткрытьРасписаниеЗавершение",ЭтотОбъект,ТекущиеДанные);
ДиалогНастройки.Показать(ОписаниеОповещения);


КонецПроцедуры

&НаКлиенте
Процедура ОткрытьРасписаниеЗавершение(НовоеРасписание, ТекущиеДанные) Экспорт

Если НовоеРасписание <> Неопределено Тогда
УстановитьРасписаниеРегламентногоЗадания(ТекущиеДанные.УникальныйИдентификатор, НовоеРасписание);
ОбновитьСписокРегламентныхЗаданий();
КонецЕсли;

КонецПроцедуры
24. user1374747 215 24.04.24 12:33 Сейчас в теме
Привет. Обработка еще актуальна? Можно скачивать?
25. krv2k 376 24.04.24 13:14 Сейчас в теме
(24) Да, актуальна. Рекомендую скачать свежую версию, когда она пройдет модерацию.
26. user1374747 215 24.04.24 17:15 Сейчас в теме
ОК. Как раз, нужна. Смотрю обновлялось уже сегодня. Скачивать или ждать отмашки?
27. user1374747 215 26.04.24 13:47 Сейчас в теме
Скачал. Посмотрел. Вроде, помимо прочего, делает то, что требовалось.
Собираешь список избранного и разом отключаешь - включаешь все нужные задания.
А то при обновлении забодался уже. Заданий много и часто. Фиг обновишь просто так.
А самому написать все как то не сподвигся.

Спасибо.

Плюс, однозначно.
Оставьте свое сообщение