IE2017

Регламентные и фоновые задания (ТУРБО)

Администрирование - Сервисные утилиты

Обработка позволяет комфортно и быстро работать с регламентными и фоновыми заданиями, даже если у Вас нет БСП.

Функционально это аналог обработки из БСП, но с дополнительным функционалом, который, в некоторых случаях, просто незаменим.

Основные преимущества:

  • Работает отдельно от БСП (но можно подключить и как дополнительную обработку, если в конфигурацию встроена БСП).
  • Работает на платформе 8.2.
  • Быстрая работа со списком фоновых заданий (в типовой обработке при большом количестве фоновых заданий работать с ними невозможно).
  • Индикация состояния использования регламентных задания (включены/выключены), а также возможность включения/отключения блокировки регламентных заданий из обработки.
  • Избранные задания и отбор по ним.
  • Группировка по виду задания (актуально, если по одному виду задания есть несколько экземпляров).
  • Отбор по состояниию задания (активные, включенные, с ошибками и т.д.).
  • Поиск фоновых заданий по регламентному заданию (или виду задания), а также поиск регламентного по фоновому.
  • Отмена выполняющегося регламентного задания из списка (в типовой можно отменять только фоновое задание).
  • Запуск регламентного задания непосредственно (для удобства отладки).
  • Запуск регламентного задания как регламентного (в типовой обработке задание запускается как фоновое).
  • Просмотр всех параметров регламентного задания.

Обновление от 2016-11-30 (версия 2.1)

  • Возможность добавлять задания в избранное и показывать только избранные задания.
  • Для интерфейса "Такси" добавлено цветовое выделение состояния использования регламентных заданий.
  • Добавлен отбор заданий, у которых есть параметры.
  • Добавлена возможность запуска регламентного задания, которое на текущий момент не подходит по расписанию.
  • Много мелких улучшений и исправлений.

Скачать файлы

Наименование Файл Версия Размер
Регламентные и фоновые задания
.epf 56,77Kb
22.11.16
47
.epf 2.1 56,77Kb 47 Скачать

См. также

Комментарии
1. Олег Каратаев (Kyrales) 118 22.11.16 18:53 Сейчас в теме
Отличная штука.
Просьба поправить заголовок при редактировании регламентного задания: там опечатка.

Объясните как может пригодится возможность добавлять свои параметры при редактировании?
2. Руслан Климачев (krv2k) 362 22.11.16 19:26 Сейчас в теме
(1) Kyrales,
Просьба поправить заголовок при редактировании регламентного задания: там опечатка.

Спасибо, исправлю.

Объясните как может пригодится возможность добавлять свои параметры при редактировании?

Это может пригодиться при исправлении ошибок механизмов конфигурации. Например, несколько лет назад в типовой УТ11 некорректно заполнялись параметры одного из заданий (не хватало одного параметра), из-за чего запуск регламентного задания завершался с ошибкой.
3. Константин Крыжановский (alfairus) 54 24.11.16 04:33 Сейчас в теме
работает на обычных формах?
4. Руслан Климачев (krv2k) 362 24.11.16 09:33 Сейчас в теме
5. Владимир Зленко (ZLENKO) 366 06.01.17 11:17 Сейчас в теме
Порадовала культура написания и оформления кода обработки.
6. Руслан Климачев (krv2k) 362 06.01.17 20:42 Сейчас в теме
(5) Приятно удивляет, что в наше время ещё есть те, кто смотрит на код. Спасибо!
7. Осипов Сергей (fixin) 3575 26.04.17 10:23 Сейчас в теме
Скачал обработку тупо, чтобы отключить все регламентные задания, т.к. доступа к консоли не было, а на копии базы они мешали.

и что же?

Она отключает только одно задание...

Надо переписать примерно так:

&НаКлиенте
Процедура ВключитьВыключитьРегламентноеЗадание(Команда)
	
	//Если Не ЭтоРегламентноеЗадание() Тогда
	//	
	//	Возврат;
	//	
	//КонецЕсли;
	Для Каждого Строка ИЗ Элементы.ДеревоРегламентныхЗаданий.ВыделенныеСтроки Цикл
		ТекущиеДанные = Элементы.ДеревоРегламентныхЗаданий.ДанныеСтроки(Строка);
		ВключитьВыключитьРегламентноеЗаданиеНаСервере(ТекущиеДанные.УникальныйИдентификатор);
	КонецЦикла;
	
	ОбновитьСписокРегламентныхЗаданий();
	
КонецПроцедуры
...Показать Скрыть



Единственно, я выключал группировку и отбирал только включенные задания, чтобы они нормально инвертировались.

Автору, короче, есть еще над чем поработать. Действия должны выполняться не над текущей задачей, а над выделенными.
8. Осипов Сергей (fixin) 3575 26.04.17 10:31 Сейчас в теме
(6) мы, профи, всегда смотрим на код... ггггг...
9. Руслан Климачев (krv2k) 362 07.05.17 20:07 Сейчас в теме
(7)
Действия должны выполняться не над текущей задачей, а над выделенными.

Забавно, сегодня у меня появилась такая же необходимость ещё до того, как открыл Ваш комментарий. В следующей версии будет.
10. Осипов Сергей (fixin) 3575 07.05.17 23:44 Сейчас в теме
(9) и добавь кнопки Выкл и Вкл активности заданий, а не инверсии их состояния, плиз
Оставьте свое сообщение