Правила обмена УТ 10.3 - БП 3.0

06.02.24

Интеграция - Файловый обмен (TXT, XML, DBF), FTP

Правила обмена УТ 10.3 - БП 3.0 для использования с типовой обработкой Универсальный обмен данными в формате XML.

Скачать исходный код

Наименование Файл Версия Размер
ПравилаОбменаДанными-УТ103-БП30_5.xml
.xml 1,77Mb
301
.xml 1,77Mb 301 Скачать

Правила обмена для выгрузки документов и справочников из конфигурации Управление торговлей 10.3 в конфигурацию Бухгалтерия предприятия 3.0.

Это типовые правила обмена взятые из конфигурации Управление Торговлей 10.3.47.2, адаптированные для работы в ручном режиме с обработкой Универсальный обмен данными в формате XML. Никаких изменений (реквизитов, планов обмена) добавлять не требуется, обработки обмена используются типовые, встроенные в конфигурации.

Обязательно перед выгрузкой необходимо выбрать нужную организацию на вкладке Параметры выгрузки.

Протестировано на конфигурациях:

УТ 10.3.49.4, 10.3.63.1;

БП 3.0.103.21, 3.0.106.40, 3.0.107.37.

выгрузка универсальный обмен XML

См. также

SALE! 10%

Перенос данных из УПП 1.3 в ERP 2 / УТ 11 / КА 2. Переносятся документы, справочная информация и остатки

Обмен между базами 1C Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос документов, начальных остатков и справочной информации из УПП 1.3 в ERP 2 | из УПП 1.3 в УТ 11 | из УПП в КА 2 | Правила конвертации (КД 2) в продаже с 2015 года, постоянно работаем над их развитием | Более 360 предприятий выполнили переход с использованием этого продукта! | Сэкономьте время - используйте готовое решение для перехода! | Позволяет перенести из УПП 1.3 в ERP / УТ 11 / КА 2 всю возможную информацию | В переносе есть фильтр по организации и множество других опциональных параметров выгрузки | Есть несколько алгоритмов выгрузки остатков на выбор

50722 45650 руб.

04.08.2015    160100    367    267    

348

[ED3] Обмен для ERP 2.5, КА 2.5, УТ 11.5 БП 3.0, Розница, УНФ и других с EnterpriseData (универсальный формат обмена), правила обмена

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    135378    728    291    

388

SALE! 10%

Перенос данных из ERP 2 / КА 2 / УТ 11 в БП 3.0. Переносятся документы, начальные остатки и справочники

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

38500 34650 руб.

15.04.2019    68711    179    139    

111

Перенос данных из УТ 10.3 в УТ 11.5. Переносятся документы (обороты за период), справочная информация и остатки

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3 (10.3.87.x) и УТ 11.5 (11.5.16.x).

28000 руб.

23.07.2020    46622    199    64    

162

Перенос данных из УПП 1.3 в БП 3.0. Переносятся документы (обороты за период), справочная информация и остатки

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.223.x) и БП 3.0 (3.0.149.x). Правила подходят для версии ПРОФ и КОРП.

28000 руб.

15.12.2021    20477    134    38    

92

SALE! 10%

Перенос данных из БП 3.0 в УТ 11 / КА 2 / ERP 2. Переносятся начальные остатки, документы и справочники

Обмен между базами 1C Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

В продаже с 2014г. | Воспользовались более 122 предприятий! | Перенос данных из БП 3.0 в УТ 11 | из БП 3.0 в КА 2 | из БП 3.0 в ERP | Сэкономьте свое время - используйте готовое решение для перехода! | Постоянно работаем над развитием переноса данных | Обновляем на новые релизы 1С | Есть фильтр выгрузки по организациям | Переносятся начальные остатки на выбранную дату, документы за период времени и вся возможная справочная информация | Перенос сделан на технологии КД 2 (правила конвертации данных)

50722 45650 руб.

31.10.2014    231702    124    327    

296

SALE! 10%

Перенос данных из БП 3.0 в УНФ 3.0 / УНФ 1.6. Переносятся остатки, документы и справочная информация

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление нашей фирмой 3.0 Россия Платные (руб)

В продаже с 2018г. | Воспользовались более 41 предприятия! | Правила конвертации (КД 2) для переноса данных из БП 3 в УНФ | Переносятся все виды документов, начальные остатки и вся возможная справочная информация | Есть фильтр по организациям | Оперативно обновляем на новые релизы | Оказываем техподдержку | В комплект файлов входит инструкция, авторская версия обработки "Универсальный обмен...", актуальные правила переноса данных и архив старых версий переноса | Учет в БП 3 должен быть корректным, некорректные данные не переносятся | Можно бесплатно проверить на вашем сервере до покупки!

50722 45650 руб.

10.07.2018    67648    41    122    

46

SALE! 10%

Перенос данных из ERP 2 / КА 2 в ЗУП 3. Переносятся остатки, документы и справочники

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из ERP в ЗУП 3 | из КА 2 в ЗУП | Воспользовались более 79 предприятий! | Предлагаем приобрести готовые правила конвертации данных (КД 2) для переноса остатков, документов с движениями и справочной информации 3 | В продаже с 2020г. | Оперативно обновляем правила до актуальных релизов 1С | Есть перенос начальной задолженности по зарплате и начальной штатной расстановки на выбранную дату | Обороты за прошлые годы (данные для расчета среднего) переносятся свернуто в документ "Перенос данных" | Есть фильтр по организациям | Документы за текущий период переносятся сразу с движениями, поэтому не потребуется делать перерасчеты | Перенос можно проверить перед покупкой, обращайтесь!

48278 43450 руб.

03.12.2020    34338    80    58    

78
Комментарии
Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. zhuravlev_as 394 31.10.18 19:27 Сейчас в теме
Очень интересна задача, ради которой получилась данная разработка. В голову приходит лишь только необходимость отбора за период - но это есть в обмене УТ 10.3 - БП 3.0. Или необходимость просто выгружать отдельные виды документов? Но тогда напрашивается вывод, что это больше обработка для тех.специалиста, нежели для бухглатера.
user996871; +1 Ответить
2. slknnk 66 01.11.18 03:20 Сейчас в теме
(1) Варианты использования:
выгружать отдельные документы;
выгружать из старых версий, там где нет встроенного обмена.
Бухгалтеры используют с удовольствием - это ведь не сложно выбрать нужный список видов документов и сохранить этот список.
Vitalyos; +1 Ответить
3. zhuravlev_as 394 01.11.18 07:42 Сейчас в теме
(2) понятно, спасибо за ответ, и удачи этим бухгалтерам
4. user996871 18.12.18 06:42 Сейчас в теме
Станислав, здравствуйте. Подскажите, пожалуйста, как выйти из следующей ситуации:
Выгружаю данные из УТ 10 в БП 3.0, но базовую версию. В параметрах выгрузки (в УТ) выбираю выгружаемую организацию (ИП), иначе ничего не выгружается. Но при загрузке в БП происходит ошибка, так как в БП, помимо загружаемых данных, пытается загрузится данные об ИП, другими словами еще раз этот же ИП, и на этом загрузка прерывается. Если проводить загрузку в профверсию БП, то после загрузки создается новый ИП, чисто его название, но с пустыми данными об ФИО. Я подозреваю, что при загрузке в базовую версию, БП не может сопоставить выгружаемые данные по ИП и пытается создать новую, но из-за ограничения базовой версии, загрузка прерывается. Хотя в УТ я заполнил все что можно в карточке ИП. Смущает то, что в УТ нет нигде данных о ФИО предпринимателя. Как быть в такой ситуации? Спасибо.
5. slknnk 66 18.12.18 07:02 Сейчас в теме
(4)
Я подозреваю, что при загрузке в базовую версию, БП не может сопоставить выгружаемые данные по ИП и пытается создать новую, но из-за ограничения базовой верси

Все верно, синхронизация организаций выполняется по внутреннему идентификатору.
Сейчас добавил дополнительный поиск по полям ИНН/КПП для справочника Организации.
user996871; +1 Ответить
6. user996871 19.12.18 04:56 Сейчас в теме
(5) Все отлично, заработало, спасибо :)
7. nnbond@mail.ru 19.12.18 12:10 Сейчас в теме
Добрый день. Выгрузка работает с последними изменениями НДС?
8. slknnk 66 19.12.18 20:45 Сейчас в теме
(7) Пока нет. Планирую обновить.
9. slknnk 66 21.12.18 21:31 Сейчас в теме
(7) Протестировано, работает.
10. Stas84 09.01.19 19:25 Сейчас в теме
Добрый вечер, планируется обновление правил под новый релиз БП 3.0.67.54 ?
11. slknnk 66 17.01.19 15:02 Сейчас в теме
(10) У вас какие-то ошибки? Проверил на 3.0.67.67, ошибок не поймал.
12. m-sla 5 03.02.19 07:13 Сейчас в теме
Добрый день!
Скачала правила, выбрала при выгрузке только документы, период правильный при отборе документы показывает, но при выгрузке пишет выгружено 0 объектов, в чем может быть проблема?
13. m-sla 5 03.02.19 07:36 Сейчас в теме
Нашла в чем проблема, у меня в базе несколько организаций, выгрузка нужна по всем, но если я на вкладке параметры выгрузки организацию не выбираю, то ничего не выгружается
14. slknnk 66 03.02.19 08:28 Сейчас в теме
(13) Все верно, так и должно быть. Выгружаются документы только по выбранной организации.
15. Zonder 15.02.19 16:32 Сейчас в теме
Добрый день, из УТ 10.3.21.1 выгрузка будет работать?
18. slknnk 66 16.02.19 13:09 Сейчас в теме
(15) Скорее всего нет. Нужно допиливать до вашей версии.
16. nano1c 171 15.02.19 20:26 Сейчас в теме
В последних ут 10.3 эти правила зашиты в план обмена - как вы их выдернули? Я помню делал аналогичную задачу и помню что это было не просто..
19. slknnk 66 16.02.19 13:10 Сейчас в теме
(16) Они там в макете плана обмена. Можно просто выгрузить и модифицировать.
22. nano1c 171 18.02.19 21:03 Сейчас в теме
(19) да это понятно, как вы модифицировали - вот в чем вопрос? В КД и в блокноте все это довольно долго...
23. slknnk 66 18.02.19 21:15 Сейчас в теме
(22) Пользовался и КД и notepad++
😀
17. nano1c 171 16.02.19 11:00 Сейчас в теме
Да, кстати, правила не работают - выгрузка документов пролетает пулей но ничего не выгружает.
20. slknnk 66 16.02.19 13:10 Сейчас в теме
(17)
Да, кстати, правила не работают - выгрузка документов пролетает пулей но ничего не выгружает.

Может организацию не выбрали?
21. nano1c 171 18.02.19 21:02 Сейчас в теме
(20) да, действительно) Не заметил что там обязательный отбор.
24. kofeinik 28 12.07.19 20:10 Сейчас в теме
Выгрузка-загрузка работает, одно НО - во всех документах не заполняется склад, после загрузки пустой реквизит. Не подкинете идею, почему? В ПКО Склады убрал условие выгрузки, все равно пусто.
25. slknnk 66 12.07.19 21:14 Сейчас в теме
(24) Только что проверил: завел новый склад в УТ, выгрузил документ РТиУ в БП, склад в документе присутствует.
Проверьте в самом файле выгрузки, для документа свойство Склад присутствует? Пример на скриншоте во вложении.
Прикрепленные файлы:
26. kofeinik 28 13.07.19 11:40 Сейчас в теме
(25) У меня на одной базе все отлично работает, но там склада три, и они все оптовые. А во второй базе складов 20, они все розничные (но это тут не при чем), и в файл выгрузки данный реквизит просто не попадает, всю голову сломал, почему. Указание складов в ТЧ в константах явно выставил. Сможете по удаленке глянуть (небесплатно)? Думаю, причина в чем-то простом, тут просто нужен свежий взгляд.
27. slknnk 66 13.07.19 13:43 Сейчас в теме
(26) Ну значит в шапке документа реквизит склад у вас не заполнен в базе источнике, других причин наверное нет.
28. kofeinik 28 13.07.19 17:21 Сейчас в теме
(27) Как не заполнен, все заполнено, во всех документах, они проведены. Других варантов нет?
29. slknnk 66 13.07.19 17:34 Сейчас в теме
(28) В шапке? Или может только в ТЧ?
30. kofeinik 28 14.07.19 11:17 Сейчас в теме
(29) В ТЧ склады не используются. Только в шапке.
31. slknnk 66 14.07.19 12:30 Сейчас в теме
(30) Понятно. Нужно смотреть уже на копиях баз, очень странно конечно.
32. kofeinik 28 14.07.19 23:29 Сейчас в теме
Нашел, в чем дело. В справочнике "Склады" есть нетиповой реквизит "Организация", он был незаполнен, поэтому в выгрузку не попадало ни одно значение. Как только заполнил реквизит в нужных складах - реквизит в выгрузку пошел. Тут вопрос, где происходит эта фильтрация?
LetsTryAgain; +1 Ответить
33. slknnk 66 14.07.19 23:32 Сейчас в теме
(32) В общем обработчике Перед конвертацией объекта, в самом конце модуля.
34. slknnk 66 16.07.19 14:58 Сейчас в теме
(32) Удалось изменить под ваши условия?
35. kofeinik 28 16.07.19 15:49 Сейчас в теме
(34) Да, я не стал убирать реквизит из справочника, даже добавил еще в паре справочников организацию, теперь в обмен уходят только элементы справочника по нужной организации, если знать про эту фичу, то довольно удобно. Спасибо!
81. LetsTryAgain 12.04.22 12:50 Сейчас в теме
(32)Если кому актуально, меняем в алгоритме "ВозможностьВыгрузкиОбъектаПоФильтрам" сверху фильтр по полю "Организация"
//фильтр по организациям

Если (НЕ Отказ)
		И Параметры.ИспользоватьФильтрПоОрганизациям
		И ОбщегоНазначения.ЕстьРеквизитДокумента("Организация", МетаданныеОбъекта) 
		И Параметры.МассивОрганизаций.Найти(ПараметрИсточник.Организация) = Неопределено
		И ТипЗнч(ПараметрИсточник) <> Тип("СправочникСсылка.Склады")
	Тогда
	Отказ = Истина;
КонецЕсли;
Показать

Исключил склады из проверки, после этого выгружаются без привязки к организации
36. abs604704@mail.ru 15.01.20 04:28 Сейчас в теме
НЕ работает обработка, пишет пишет Поле объекта не обнаружено (Факс) (10.3.35.1)
37. slknnk 66 15.01.20 07:58 Сейчас в теме
(36) старый релиз УТ у вас.
38. iamleopo 25.11.20 19:55 Сейчас в теме
39. slknnk 66 25.11.20 19:57 Сейчас в теме
40. iamleopo 25.11.20 19:59 Сейчас в теме
выбираешь любой документ и ничего не выгружает, конфигурация УТ 10.3.49.4
Прикрепленные файлы:
41. slknnk 66 25.11.20 20:00 Сейчас в теме
(40)А в параметрах выгрузки что указано?
42. iamleopo 25.11.20 20:01 Сейчас в теме
43. slknnk 66 25.11.20 20:02 Сейчас в теме
(42)может организация неверно выбрана.
44. iamleopo 25.11.20 20:03 Сейчас в теме
45. iamleopo 25.11.20 20:03 Сейчас в теме
(43)ну и в базе одна организация с документами
46. slknnk 66 25.11.20 20:18 Сейчас в теме
(45)Флаг БУ стоит в документах?
47. iamleopo 25.11.20 20:18 Сейчас в теме
48. slknnk 66 25.11.20 20:19 Сейчас в теме
(47)Ну вот, а должен стоять.
49. iamleopo 25.11.20 20:27 Сейчас в теме
(48)точно, спасибо, наш косяк, только теперь все документы переделывать(
50. slknnk 66 25.11.20 20:28 Сейчас в теме
(49)Ну можете просто в коде обработчика в правилах убрать это условие и выгрузить.
51. marat.coolls 29.06.21 21:00 Сейчас в теме
А обмен для новой конфы будет?
52. slknnk 66 29.06.21 22:45 Сейчас в теме
(51) Для новой это для какой? Я не слежу за обновлениями.
53. sa6ne6k6 42 19.07.21 08:25 Сейчас в теме
(52) Есть для БП (3.0.96.30)? Ругается немножко


Ошибка в обработчике события ПослеЗагрузкиОбъекта
ИмяПКО = ДоговорыКонтрагентов
ТипОбъекта = Договор
Объект = Основной договор
Обработчик = ПослеЗагрузкиОбъекта
ОписаниеОшибки = Метод объекта не обнаружен (КонтрагентРезидентТаможенногоСоюза)
ПозицияМодуля = {(8)}: Объект.УдалитьПредъявляетНДС = НЕ УчетНДС.КонтрагентРезидентТаможенногоСоюза(Объект.Владелец);
{Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(8940)}: Выполнить(Правило.ПослеЗагрузки);
{Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(12705)}: ПоследнийОбъектЗагрузки = ПрочитатьОбъект();
{Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(13035)}: ПроизвестиЧтениеДанных();
{Обработка.УниверсальныйОбменДаннымиXML.Форма.УправляемаяФорма.Форма(1418)}: ОбъектДляСервера.ВыполнитьЗагрузку();

КодСообщения = 21
54. slknnk 66 23.10.21 19:44 Сейчас в теме
55. user1265617 21.11.21 15:15 Сейчас в теме
Добрый день! Будут ли данные правила работать на ут 10.3.14 ?
56. slknnk 66 22.11.21 08:39 Сейчас в теме
(55) Здравствуйте. Надо проверять. У меня такой старой демобазы нет.
57. user1265617 22.11.21 09:48 Сейчас в теме
(56)Скачаю, настрою, если что-то не так пойдет - подскажите что подправить?
58. slknnk 66 22.11.21 12:15 Сейчас в теме
(57)Обещаний я вам дать не могу. Все зависит от масштаба того что надо подправить. Если это будут мелочи, то вы и сами справитесь.
59. user1265617 30.11.21 14:18 Сейчас в теме
Не подскажете, как проведение документов при выгрузке есть? Если есть, то где? Проверила обработчики выгрузки, не нашла
60. slknnk 66 30.11.21 23:10 Сейчас в теме
(59)У вас документы загружаются непроведенными?
61. user1265617 30.11.21 23:15 Сейчас в теме
(60)да, вручную без ошибок проводятся, но при загрузке нет.
62. slknnk 66 01.12.21 14:57 Сейчас в теме
(61)Загружаются как проведенные, но без движений - это так и должно быть.
Перепроведение лучше выполнить уже после загрузки.
63. user1265617 01.12.21 16:16 Сейчас в теме
(62)ну вот я в тех обработчиках и не нашла кода с проведением, т е это нужно дописывать?
64. slknnk 66 01.12.21 16:30 Сейчас в теме
(63)Думаю да. Это надо в обработчике ПослеЗагрузкиДанных все документы перепровести.
65. Светлый ум 406 28.12.21 07:38 Сейчас в теме
+1, актуальны и работают.
66. MasI 9 09.01.22 14:22 Сейчас в теме
Добрый день!

Можете ли помочь настроить обмен с помощью Ваших правил УТ 10.3 - > БП 3, у нас очень старый релиз УТ поэтому правила не сработали. Подскажите как с Вами связаться?
68. slknnk 66 09.01.22 20:17 Сейчас в теме
(66)
нас очень старый релиз УТ поэтому правила не сработали. Подскажите как с Вами связаться?

Написал в личные сообщения.
67. MasI 9 09.01.22 18:49 Сейчас в теме
Сейчас при загрузке в Бухгалтерию (3.0.106.40) выдается вот такая ошибка


Ошибка при загрузке данных: Тип не определен (СправочникСсылка.КлассификаторСтранМира)
{Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(6769)}: Возврат Тип(СтроковыйТипСвойства);
{Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(6775)}: ТипСвойства = ПолучитьТипСвойства();
{Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(8728)}: ТипСвойства = ПолучитьТипСвойстваПоДополнительнымДанным(ИнформацияОТипах, Имя);
{Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(12793)}: ПоследнийОбъектЗагрузки = ПрочитатьОбъект();
{Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(13132)}: ПроизвестиЧтениеДанных();
{Обработка.УниверсальныйОбменДаннымиXML.Форма.УправляемаяФорма.Форма(1421)}: ОбъектДляСервера.ВыполнитьЗагрузку();
69. slknnk 66 10.01.22 11:08 Сейчас в теме
(67) Проверил на релизе БП 3.0.106.40. Все выгрузилось-загрузилось как и раньше.
70. zenz 16.02.22 17:41 Сейчас в теме
УТ 10.3.69.2 - БУХ3.0.106.40
Выдает ошибку

Ошибка при загрузке данных: Ошибка в обработчике события ПослеЗагрузкиОбъекта
ИмяПКО = ДоговорыКонтрагентов
ТипОбъекта = Договор
Объект = Основной
Обработчик = ПослеЗагрузкиОбъекта
ОписаниеОшибки = Метод объекта не обнаружен (КонтрагентРезидентТаможенногоСоюза)
ПозицияМодуля = {(8)}: Объект.УдалитьПредъявляетНДС = НЕ УчетНДС.КонтрагентРезидентТаможенногоСоюза(Объект.Владелец);
{ВнешняяОбработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(8991)}: Выполнить(Правило.ПослеЗагрузки);
{ВнешняяОбработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(12793)}: ПоследнийОбъектЗагрузки = ПрочитатьОбъект();
{ВнешняяОбработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(13132)}: ПроизвестиЧтениеДанных();
{ВнешняяОбработка.УниверсальныйОбменДаннымиXML.Форма.УправляемаяФорма.Форма(1421)}: ОбъектДляСервера.ВыполнитьЗагрузку();

КодСообщения = 21
{ВнешняяОбработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(1316)}: ВызватьИсключение СтрокаСообщенияОбОшибке;
{ВнешняяОбработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(8999)}: ЗаписатьИнформациюОбОшибкеЗагрузкиОбработчикаПКО(21, ПодробноеПредставлениеОшибки(ИнформацияОбОшибке()), ИмяПравила, Источник,
{ВнешняяОбработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(12793)}: ПоследнийОбъектЗагрузки = ПрочитатьОбъект();
{ВнешняяОбработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(13132)}: ПроизвестиЧтениеДанных();
{ВнешняяОбработка.УниверсальныйОбменДаннымиXML.Форма.УправляемаяФорма.Форма(1421)}: ОбъектДляСервера.ВыполнитьЗагрузку();

Как Победить ? Заранее спасибо.
71. slknnk 66 16.02.22 18:26 Сейчас в теме
72. zenz 17.02.22 17:03 Сейчас в теме
Большое спасибо. Все сработало- без единой ошибки. Советую.
73. user595823_knn-it 04.03.22 09:51 Сейчас в теме
Приветствую!
при начале выгрузки, выдает ошибку
как победить?

Ошибка в обработчике события ПередВыгрузкойДанных (конвертация)
Обработчик = ПередВыгрузкойДанных (конвертация)
ОписаниеОшибки = Метод объекта не обнаружен (Вставить)
ПозицияМодуля = <Неизвестный модуль>(224)
КодСообщения = 62
74. slknnk 66 04.03.22 09:55 Сейчас в теме
(73) У вас УТ какой версии?
75. LetsTryAgain 29.03.22 21:20 Сейчас в теме
добрый вечер, напишите в личку, хотелось бы приобрести правила
76. slknnk 66 29.03.22 21:24 Сейчас в теме
(75) Так скачивайте, всего 1 см :)
77. пользователь 29.03.22 21:57
Сообщение было скрыто модератором.
...
78. пользователь 29.03.22 22:36
Сообщение было скрыто модератором.
...
79. spraite 01.04.22 02:53 Сейчас в теме
Здраствуйте, УТ10.3.73.2 - БП 3.0.106.101 полет нормальный, только задублировал контрагентов.
80. slknnk 66 02.04.22 23:04 Сейчас в теме
(79) Здравствуйте. Ну тут вам уже надо настроить ключевые поля поиска контрагентов под ваши особенности.
82. swwb 18 14.07.22 13:16 Сейчас в теме
Подскажите, можно ли как-то настроить, чтобы в Бухгалтерию выгружался только "Основной склад", без аналитики по складам УТ шла выгрузка?
83. slknnk 66 14.07.22 14:21 Сейчас в теме
(82)Настроить можно. Смотрите алгоритм ЗаполнитьРеквизитыПоУмолчанию, реквизиты со значениями складов не выгружать в на стороне источника.
84. mrd2008 62 10.08.22 11:30 Сейчас в теме
Добрый день, подскажите, подружить эти правила обмена с типовым планом обмена между бухгалтерией 3 и управлением торговлей 10.3 можно, чтобы выгружать не все, а только зарегистрированные изменения, чтобы ускорить процесс выгрузки? И что для этого будет нужно?
85. slknnk 66 10.08.22 11:52 Сейчас в теме
(84) мне кажется по такой логике работает типовой обмен ут-бр 3.0. Наверное вам его и следует использовать.
86. alfaservice 17 09.10.22 20:38 Сейчас в теме
С небольшими доработками правила в работу запустил, однако почему-то доки после выгрузки не проводятся, т.е. признак проведения есть а движений нет!

Раньше при обмене УТ10_3 БП 2 было так, правда правила кто-то писал
Объект.ЗаполнитьСчетаУчетаВТабЧасти(Объект.Товары, "Товары", Истина, Объект.ОтражатьВНалоговомУчете);
Объект.ЗаполнитьСчетаУчетаВТабЧасти(Объект.ВозвратнаяТара, "ВозвратнаяТара", Истина, Объект.ОтражатьВНалоговомУчете);
СчетаУчета = ПолучитьСчетаРасчетовСКонтрагентом(Объект.Организация, Объект.Контрагент, Объект.ДоговорКонтрагента);
Если Объект.ДоговорКонтрагента.ВидДоговора = Перечисления.ВидыДоговоровКонтрагентов.СКомиссионером Тогда
	Объект.СчетУчетаРасчетовСКонтрагентом = ПланыСчетов.Хозрасчетный.ПустаяСсылка();
	Объект.СчетУчетаРасчетовПоАвансам     = ПланыСчетов.Хозрасчетный.ПустаяСсылка();
	Объект.СчетУчетаРасчетовПоТаре        = ПланыСчетов.Хозрасчетный.ПустаяСсылка();
Иначе
	Объект.СчетУчетаРасчетовСКонтрагентом = СчетаУчета.СчетРасчетовПокупателя;
	Объект.СчетУчетаРасчетовПоАвансам     = СчетаУчета.СчетАвансовПокупателя;
	Объект.СчетУчетаРасчетовПоТаре        = СчетаУчета.СчетУчетаТарыПокупателя;
КонецЕсли;
Объект.СчетУчетаРасчетовПоТаре        = СчетаУчета.СчетУчетаТарыПокупателя;
Если ПрименениеУСН(Объект.Организация, Объект.Дата) Тогда
	Объект.СчетУчетаРасчетовСКонтрагентомУСН = СчетаУчета.СчетРасчетовПокупателяУСН;
	Объект.СчетУчетаРасчетовПоАвансамУСН     = СчетаУчета.СчетАвансовПокупателяУСН;
КонецЕсли;
Объект.ЗаполнитьСчетаУчетаВТабЧастиУслуги(Истина, Объект.ОтражатьВНалоговомУчете);

Объект.Склад = Константы.СкладДляОбменаДаннымиСУТ.Получить();

Объект.Записать();
Показать


Сейчас это выглядит так
Если Объект.ДоговорКонтрагента.ВидДоговора = Перечисления.ВидыДоговоровКонтрагентов.СПокупателем
	И Объект.ВозвратнаяТара.Количество() = 0 Тогда
	
	Если Объект.Услуги.Количество() = 0 Тогда
		Объект.ВидОперации = Перечисления.ВидыОперацийРеализацияТоваров.Товары;
	ИначеЕсли Объект.Товары.Количество() = 0 Тогда
		Объект.ВидОперации = Перечисления.ВидыОперацийРеализацияТоваров.Услуги;
	КонецЕсли;
	
КонецЕсли;

//склад и организация по умолчанию
Если Объект.ЭтоНовый() Тогда
	СсылкаНового = Объект.ПолучитьСсылкуНового();
	Параметры.ДокументыСОпределениемДопРеквизитов.Добавить(СсылкаНового);
	СтрокаСсылки = Параметры.ТоварыТабличнаяЧасть.Добавить();
	СтрокаСсылки.Ссылка = СсылкаНового;
Иначе
	Параметры.ДокументыСОпределениемДопРеквизитов.Добавить(Объект.Ссылка);
	СтрокаСсылки = Параметры.ТоварыТабличнаяЧасть.Добавить();
	СтрокаСсылки.Ссылка = Объект.Ссылка;
КонецЕсли;

Если ПараметрыОбъекта <> Неопределено Тогда
	ТаблицаПараметровТовары = ПараметрыОбъекта["ТоварыТабличнаяЧасть"];
	Если ТипЗнч(ТаблицаПараметровТовары) = Тип("ТаблицаЗначений") Тогда
		СтрокаСсылки.ТоварыТабличнаяЧасть = ТаблицаПараметровТовары.Скопировать();
	КонецЕсли;
КонецЕсли;

Выполнить(Алгоритмы.ЗаполнитьКодТНВЭД);

Выполнить(Алгоритмы.ЗаполнитьДеятельностьНаПатентеПоУмолчанию);
Показать


в ваших правилах упоминаний о счетах и записи нет (
87. slknnk 66 09.10.22 22:16 Сейчас в теме
(86)
1. Документы без движений потому что загружаются в режиме обмена.
2. Счета определяются и подставляются на уровне объекта, а не в правилах.
88. alfaservice 17 09.10.22 22:34 Сейчас в теме
Тогда вопрос! как сделать проведение документа после его загрузки?
89. slknnk 66 10.10.22 00:18 Сейчас в теме
(88) В этом нет смысла, так как групповое проведение нужно выполнять регламентными инструментами.
90. alfaservice 17 10.10.22 21:35 Сейчас в теме
Согласен, с этим ок! Но... есть небольшая просьба. В доках по типу Отчеты о розничных продажах на счет дохода не проставляется номенклатурная группа ее надо после ручками ставить, может подскажешь?

с моей стороны вот такая доработка для ПКО:

в ПКС Контрагент для заполнения склада при розничной выручке. После загрузки:
Если Источник.ВидОперации = Перечисления.ВидыОперацийПКО.ПолучениеНаличныхДенежныхСредствВБанке Тогда
	Значение = Источник.СчетОрганизации;
ИначеЕсли Источник.ВидОперации = Перечисления.ВидыОперацийПКО.ПриходДенежныхСредствРозничнаяВыручка Тогда
    Значение = Источник.ДокументОснование.Склад;
Конецесли;


И в ТЧ Товары ставка НДС в ПКС СтавкаНДС при выгрузке, автоматом не проставляется:

Если Значение = Перечисления.СтавкиНДС.ПустаяСсылка() Тогда
    Значение = Перечисления.СтавкиНДС.БезНДС;
КонецЕсли;


это если работают без НДС
91. slknnk 66 10.10.22 21:56 Сейчас в теме
(90) Ну наверное в карточке номенклатуры не заполнена номенклатурная группа.
Заполнение счетов и аналитики полностью выполняется на стороне БП типовой логикой.
92. alfaservice 17 10.10.22 22:20 Сейчас в теме
(91) Пробовал проставлял, нефига . Попробовал даже взять из отчета комиссионера строчки

Если ЗначениеПараметра = Истина Тогда
				СтрокаТЧ.СчетУчета = ПланыСчетов.Хозрасчетный.ТоварыНаСкладе;
				Если СтрокаТЧ.СчетДоходов.ВидыСубконто.Количество() > 0 Тогда
					СтрокаТЧ.Субконто = Новый(СтрокаТЧ.СчетДоходов.ВидыСубконто[0].ВидСубконто.ТипЗначения.Типы()[0]);
					Если ТипЗнч(СтрокаТЧ.Субконто) = Тип("СправочникСсылка.НоменклатурныеГруппы") Тогда
						СтрокаТЧ.Субконто = СтрокаТЧ.Номенклатура.НоменклатурнаяГруппа;
					КонецЕсли;
				Иначе
					СтрокаТЧ.Субконто = Неопределено;
				КонецЕсли;
			КонецЕсли;

Показать


Тоже не помогло.
93. alfaservice 17 10.10.22 22:26 Сейчас в теме
(91) Единственное чего не пробовал это заполнить группы в номенклатуре на стороне БП. Но опять же какой смысл если я делаю выгрузку и Ут где все это есть
94. slknnk 66 10.10.22 22:44 Сейчас в теме
(93) вы не поняли. На стороне УТ этого нет. Счета и аналитика заполняется на стороне БП. При записи на стороне приёмника определяются счета учёта/дохода и аналитика. Выполняются те же действия, что и при ручном заполнении при вроде строки. Если при вводе строки и выбора номенклатуры у вас не заполняется счета и аналитика, то и при загрузке не будет. Настраивайте счета учёта номенклатуры.
95. noof 12.10.22 13:43 Сейчас в теме
Привет. Как с тобой связаться? Мне нужно эти правила запилить для конкретного релиза УТ для последней Бухии. Через инфостарт просто невозможный гем...ой дописаться.
96. slknnk 66 12.10.22 13:56 Сейчас в теме
(95) Привет. В личку можно написать. Какой релиз УТ?
97. noof 12.10.22 14:40 Сейчас в теме
(96) 10.3.32.1 Я чето не могу разобраться как в личку писать...
98. mhs0699 07.12.22 17:36 Сейчас в теме
Приветствую! Ошибка при выгрузке из УТ 10.3.49.4:

Ошибка при выгрузке данных: {Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(1694)}: Ошибка в обработчике события ПриВыгрузке (объекта коллекции)
	ПКО                    =  ПоступлениеТоваровУслуг  (Документ: Поступление товаров и услуг)
	ПКГС                   =  18  (Услуги --> Услуги)
	Объект                 =  Поступление товаров и услуг УТТр0001230 от 11.10.2022 9:00:00  (Поступление товаров и услуг)
	Обработчик             =  ПриВыгрузкеГруппыСвойств
	ОписаниеОшибки         =  Поле объекта недоступно для записи (СтавкаНДС)
	ПозицияМодуля          =  <Неизвестный модуль>(2)
	КодСообщения           =  51
99. mhs0699 07.12.22 17:54