Автоматизация печатной формы (автоформирование табличного документа на основе любой таблицы значений)

Публикация № 1043728

Разработка - Практика программирования

универсальный код пример автоматическое формирование табличного документа управляемая форма

3
Автоматическое формирование табличного документа из выбранной таблицы значений. Пример как можно рутинные действия по оформлению внешнего вида печатной формы переложить на программу. Статья предназначена в первую очередь для тех, кто не сильно владеет СКД (как я, например), но которым не хочется тратить свое время на формирование разных макетов, если вывести документ нужно в стандартном виде. Код полностью открыт, пользуйтесь на здоровье. :)

Доброе время суток всем.

Для упрощения вывода информации в табличный документ предлагается следующий код, выводящий таблицу значений с формы на экране в некий стандартный табличный документ по определенным правилам:

  1. Выводятся только видимые колонки
  2. Ширина колонок рассчитывается из максимальной ширины данных в колонке ( если не указана фикс. ширина)
  3. Формат вывода и (печатное наименование) для каждой колонки можно задать произвольно
  4. По тем колонкам, где нужно, выводятся итоги.

Код рекомендуется подключить как дополнительный общий модуль в конфигурацию.

Для примеры показан вывод списка реализаций из демонстрационной базы "Комплексной автоматизации".

Но применить можно в любой конфигурации с УФ.

 

Описание:

 


&НаСервере
//*** формат входных данных: ПечатьПоШаблону(Знач Табл,НКолонки,ТекстЗаголовка,ПоляВывода,ТекстПодвала)
// (     Табл      - исходная таблица
//         НКолонки - первая строка ШАПКИ вывода
//         ТекстЗаголовка ...
//         ПоляВывода - список выводимых колонок , в представлении значения - формат вывода:
//                        "Вес","Вес|10|ЧДЦ=2|*"
//                        |     |   |   |    | выводим итог по этой колонке
//                        |     |   |   | формат вывода колонки
//                          |     |   | фикс. ширина колонки ( если не указана, то - рассчитывается автоматически )
//                          |     | представление колонки при выводе на печать
//                        | выводимая колонка ( имя должно совпадать с именем в исходной таблице)
//        ТекстПодвала ...
//      )
//Пример 1:
//*********************************
//ПоляВывода = Новый СписокЗначений;
//ПоляВывода.Добавить("Заказ","Заказ||");
//ПоляВывода.Добавить("СкладКорр","Склад (корр)|10|ДФ=гггг-ММ-дд");
//ПоляВывода.Добавить("СкладФакт","Склад (факт)|10|ДФ=гггг-ММ-дд");
//ПоляВывода.Добавить("Контейнер","Контейнер||");
//Если фВесОбъем Тогда
//    ПоляВывода.Добавить("Объем","Объем|12|ЧДЦ=4");
//    ПоляВывода.Добавить("Вес","Вес|10|ЧДЦ=2|*");
//КонецЕсли;
//ТекстПодвала="";
//*********************************
//
//ПечатнаяФорма = ПечатьПоШаблону(ТаблицаДокументов,4,"Заказы на поставку",ПоляВывода,ТекстПодвала);
//
//Пример 2:
//*********************************
//ПоляВывода = Новый СписокЗначений;
//ПоляВывода.Добавить("Артикул","Артикул||");
//ПоляВывода.Добавить("Номенклатура","Номенклатура||");
//ПоляВывода.Добавить("КоличествоОжидаемое","Кол.(ожидаемое)|||*");
//ТекстПодвала = "Вес: "+Строка(ИтогоВес)+" (кг)  ;  объем : "+Строка(ИтогоОбъем)+" (м.куб).";
//*********************************
//
//ПечатнаяФорма = ПечатьПоШаблону(ТаблицаПрогнозаПоступлений,4,"Ожидаемые поставки на : "+Формат(ДатаПрогнозаПоступлений,"ДФ=гггг-ММ-дд"),ПоляВывода,ТекстПодвала);

Пример кода формата вывода:


 


&НаКлиенте
Процедура Печать(Команда)
    ПоляВывода = Новый СписокЗначений;
    
    //*** автопечать всего видимого из таблицы
    ВывТаблица="ТабДокументов";
    Для каждого Т Из Элементы Цикл
        Если Т.Имя=ВывТаблица Тогда
            Для каждого Эл Из Т.ПодчиненныеЭлементы Цикл
                Если Эл.Видимость Тогда
                    ВывПоле=Прав(Эл.Имя,СтрДлина(Эл.Имя)-СтрДлина(ВывТаблица));
                    ПоляВывода.Добавить(ВывПоле,ВывПоле+"||")
                КонецЕсли;
            КонецЦикла;
        КонецЕсли;
    КонецЦикла;

    //*** корректировка избранных полей
    Для каждого Эл Из ПоляВывода Цикл
        Если       Эл.Значение="СкладКорр" Тогда
             Эл.Представление="Склад (корр)|10|ДФ=гггг-ММ-дд";
        ИначеЕсли Эл.Значение="СкладФакт" Тогда    
             Эл.Представление="Склад (факт)|10|ДФ=гггг-ММ-дд";
        ИначеЕсли Эл.Значение="ОтгрФакт" Тогда    
             Эл.Представление="Отгр (Факт)|10|ДФ=гггг-ММ-дд";
        ИначеЕсли Эл.Значение="Дата" Тогда    
             Эл.Представление="Дата|10|ДФ=гггг-ММ-дд";
        ИначеЕсли Эл.Значение="Сумма" Тогда    
             Эл.Представление="Сумма|12|ЧДЦ=2|*";
        ИначеЕсли Эл.Значение="Объем" Тогда    
             Эл.Представление="Объем|12|ЧДЦ=4|*";
        ИначеЕсли Эл.Значение="Вес" Тогда    
             Эл.Представление="Вес|10|ЧДЦ=2|*";
        КонецЕсли;
    КонецЦикла;
    
    //////*** печать только выбранных колонок
    ////ПоляВывода.Очистить();
    ////ПоляВывода.Добавить("Заказ","Заказ||");
    ////ПоляВывода.Добавить("СкладКорр","Склад (корр)|10|ДФ=гггг-ММ-дд");
    ////ПоляВывода.Добавить("СкладФакт","Склад (факт)|10|ДФ=гггг-ММ-дд");
    ////ПоляВывода.Добавить("Контейнер","Контейнер||");
    ////Если фВесОбъем Тогда
    ////    ПоляВывода.Добавить("Объем","Объем|12|ЧДЦ=4");
    ////    ПоляВывода.Добавить("Вес","Вес|10|ЧДЦ=2");
    ////КонецЕсли;
    
    ТекстЗаголовка="Реализации: ("+Формат(ДатаНачалаПериода,"ДФ=гггг-ММ-дд")+"-"+Формат(ДатаКонцаПериода,"ДФ=гггг-ММ-дд")+") :";;
    //Для каждого Эл Из Элементы.Фильтр1.ПодчиненныеЭлементы Цикл
    //    Если НЕ ПустаяСтрока(Эл.ВыделенныйТекст) Тогда
    //        ТекстЗаголовка=ТекстЗаголовка+" "+Эл.ВыделенныйТекст+" ; ";
    //    КонецЕсли;
    //КонецЦикла;
    
    ТекстПодвала="";

    //непосредственно обработка:
    ПечатнаяФорма = ПечатьПоШаблону(ТабДокументов,4,ТекстЗаголовка,ПоляВывода,ТекстПодвала);

    ПечатнаяФорма.Показать(
        "Печать. "  // заголовок окна с отчётом
    );
КонецПроцедуры

&НаСервере
Функция ПечатьПоШаблону(Знач Табл,НКолонки,ТекстЗаголовка,ПоляВывода,ТекстПодвала)экспорт
	
	Н=Табл.Выгрузить();
	
	спШирКол=Новый СписокЗначений;
	спИтого=Новый СписокЗначений;

	спШирКол=ПоляВывода.Скопировать();
	
	Для К=1 По спШирКол.Количество() Цикл
		ОписаниеКолонки=СтрРазделить(спШирКол[К-1].Представление,"|");
		Если ОписаниеКолонки.Количество()>3 тогда
			//проверим на итоги
			Если ОписаниеКолонки[3] = "*" тогда
				//выводим итоги по колонке
				спИтого.Добавить(спШирКол[К-1].Значение,"0");
			КонецЕсли;	
		КонецЕсли;	
		ШирИмениКолонки=СтрДлина(спШирКол[К-1].Значение);
		ШирПредставления=ШирИмениКолонки;
		Если ОписаниеКолонки.Количество()>1 тогда
			//Ширина представления колонки
			Если ПустаяСтрока(ОписаниеКолонки[1]) Тогда
				//нет фикс. длины
				ШирПредставления=СтрДлина(ОписаниеКолонки[0]);
			Иначе
				ШирПредставления=Число(ОписаниеКолонки[1]);
			КонецЕсли;
		КонецЕсли;	
		Если ШирПредставления>ШирИмениКолонки Тогда
			ШирИмениКолонки=ШирПредставления;
		КонецЕсли;
		спШирКол[К-1].Представление=Строка(ШирИмениКолонки+1);
	КонецЦикла;
	
	
	//Определим оптимальную ширину колонок
	Для СтрокаН=1  По Н.Количество() Цикл
		Для К=1 По Н.Колонки.Количество() Цикл
			ИмяКолонки=Н.Колонки[К-1].Имя;
			Имя = спШирКол.НайтиПоЗначению(ИмяКолонки);
			Если Имя <> НЕОПРЕДЕЛЕНО  Тогда
				ШирКол=СтрДлина(СокрЛП(Строка(Н[СтрокаН-1][К-1])));
				Если ШирКол > Число(Имя.Представление) Тогда
					Имя.Представление = Строка(ШирКол);
				КонецЕсли;
			Иначе
				//*** запрет доступа
			КонецЕсли;
		КонецЦикла;
	КонецЦикла;
	
	
	ТабДок = Новый ТабличныйДокумент;
	//*** сначала - Заголовок
	ТекущаяДата="Печать: "+Строка(ТекущаяДата());
	
	ТабДок.Область(1,1).Шрифт = Новый Шрифт(,7,Ложь,) ;
	//ТабДок.Область("R2C1").Шрифт = Новый Шрифт(<Имя шрифта>, <Размер>, <Жирный>, <Наклонный>, <Подчеркнутый>, <Зачеркнутый>) ;
	//Рамка = Новый Линия(ТипЛинииЯчейкиТабличногоДокумента.Сплошная, 1);
	//ТабДок.Область(3,Сч).Обвести(Рамка,Рамка,Рамка,Рамка); 
	ТабДок.Область(1,1).Текст = ТекущаяДата;

	ТабДок.Область(2,1).Шрифт = Новый Шрифт(,10,Истина,) ;
	ТабДок.Область(2,1).ЦветТекста = Новый Цвет(,,152) ;
	//ТабДок.Область("R2C1").Шрифт = Новый Шрифт(<Имя шрифта>, <Размер>, <Жирный>, <Наклонный>, <Подчеркнутый>, <Зачеркнутый>) ;
	//Рамка = Новый Линия(ТипЛинииЯчейкиТабличногоДокумента.Сплошная, 1);
	//ТабДок.Область(3,Сч).Обвести(Рамка,Рамка,Рамка,Рамка); 
	ТабДок.Область(2,1).Текст = ТекстЗаголовка;

	Сч=1;
	Для Каждого Эл из ПоляВывода Цикл
		ИмяКолонки=Эл.Значение;
		Для Каждого Нкол из Н.Колонки Цикл
			Имя = Нкол.Имя;
			Если Имя = ИмяКолонки  Тогда
				ОписаниеКолонки=СтрРазделить(Эл.Представление,"|");
				ШиринаКолонки = "";
				Если ОписаниеКолонки.Количество()>1 Тогда
					ИмяКолонки=ОписаниеКолонки[0];
					ШиринаКолонки=ОписаниеКолонки[1];
					ФорматКолонки=ОписаниеКолонки[2];
				КонецЕсли;
				
				ТабДок.Область(НКолонки,Сч).Шрифт = Новый Шрифт(,9,Истина,) ;
				//ТабДок.Область("R2C1").Шрифт = Новый Шрифт(<Имя шрифта>, <Размер>, <Жирный>, <Наклонный>, <Подчеркнутый>, <Зачеркнутый>) ;
				Рамка = Новый Линия(ТипЛинииЯчейкиТабличногоДокумента.Сплошная, 1);
				ТабДок.Область(НКолонки,Сч).Обвести(Рамка,Рамка,Рамка,Рамка); 
				
				ТабДок.Область(НКолонки,Сч).Текст = ИмяКолонки;
				Если ПустаяСтрока(ШиринаКолонки) Тогда
					ТабДок.Область(НКолонки,Сч).ШиринаКолонки = Число(спШирКол.НайтиПоЗначению(Имя).Представление);
					//ТабДок.Область(НКолонки,Сч).ШиринаКолонки = Число(спШирКол.НайтиПоЗначению(ИмяКолонки).Представление);
				Иначе	
					ТабДок.Область(НКолонки,Сч).ШиринаКолонки = ШиринаКолонки;
				КонецЕсли;
				Сч=Сч+1;
				Прервать;
			Иначе
				//*** запрет доступа
			КонецЕсли;
		КонецЦикла;
	КонецЦикла;
	
	
	//*** теперь - строки
	Для СтрокаН=1  По Н.Количество() Цикл
		Сч=1;
		Для Каждого Эл из ПоляВывода Цикл
			ИмяКолонки=Эл.Значение;
			К=0;
			Для Каждого Нкол из Н.Колонки Цикл
				Имя = Нкол.Имя;
				К=К+1;
				Если Имя = ИмяКолонки  Тогда
					ОписаниеКолонки=СтрРазделить(Эл.Представление,"|");
					ШиринаКолонки = "";
					Если ОписаниеКолонки.Количество()>1 Тогда
						ИмяКолонки=ОписаниеКолонки[0];
						ШиринаКолонки=ОписаниеКолонки[1];
						ФорматКолонки=ОписаниеКолонки[2];
					КонецЕсли;
					ТабДок.Область(НКолонки+СтрокаН,Сч).Шрифт = Новый Шрифт(,8,Ложь,) ;
					//ТабДок.Область("R2C1").Шрифт = Новый Шрифт(<Имя шрифта>, <Размер>, <Жирный>, <Наклонный>, <Подчеркнутый>, <Зачеркнутый>) ;
					Рамка = Новый Линия(ТипЛинииЯчейкиТабличногоДокумента.Сплошная, 1);
					ТабДок.Область(НКолонки+СтрокаН,Сч).Обвести(Рамка,Рамка,Рамка,Рамка); 
					Если НЕ ПустаяСтрока(ФорматКолонки) Тогда
						ТабДок.Область(НКолонки+СтрокаН,Сч).Формат = ФорматКолонки;
					КонецЕсли;
					ТабДок.Область(НКолонки+СтрокаН,Сч).Текст = Н[СтрокаН-1][К-1];
					//ТабДок.Область(НКолонки+СтрокаН,Сч).ГоризонтальноеПоложение = ГоризонтальноеПоложение.Право;
					Сч=Сч+1;
					Прервать;
				Иначе
					//*** запрет доступа
				КонецЕсли;
			КонецЦикла;
			//проверим на нужность итогов
			Имя = спИтого.НайтиПоЗначению(ИмяКолонки);
			Если Имя <> НЕОПРЕДЕЛЕНО  Тогда
				Имя.Представление=Строка(Число(Имя.Представление)+Число(Н[СтрокаН-1][К-1]));	
			КонецЕсли;
		КонецЦикла;
	КонецЦикла;

	//*** теперь итоги (если заказаны)
	Если спИтого.Количество()>0 тогда
		ТабДок.Область(СтрокаН+НКолонки+1,1).Шрифт = Новый Шрифт(,9,Истина,) ;
		ТабДок.Область(СтрокаН+НКолонки+1,1).ЦветТекста = Новый Цвет(,,152) ;
		ТабДок.Область(СтрокаН+НКолонки+1,1).Текст = "Итого: ";
		ТабДок.Область(СтрокаН+НКолонки+1,1).ГоризонтальноеПоложение = ГоризонтальноеПоложение.Лево;

		Сч=1;
		Для Каждого Эл из ПоляВывода Цикл
			ИмяКолонки=Эл.Значение;
			Имя = спИтого.НайтиПоЗначению(ИмяКолонки);
			Если Имя <> НЕОПРЕДЕЛЕНО  Тогда
					ФорматКолонки="";
					ОписаниеКолонки=СтрРазделить(Имя.Представление,"|");
					Если ОписаниеКолонки.Количество()>2 Тогда
						ФорматКолонки=ОписаниеКолонки[2];
					КонецЕсли;
					ТабДок.Область(СтрокаН+НКолонки+1,Сч).Формат = ФорматКолонки;
					ТабДок.Область(СтрокаН+НКолонки+1,Сч).Шрифт = Новый Шрифт(,9,Истина,) ;
					ТабДок.Область(СтрокаН+НКолонки+1,Сч).ЦветТекста = Новый Цвет(,,152) ;
					ТабДок.Область(СтрокаН+НКолонки+1,Сч).Текст = Число(Имя.Представление);
					ТабДок.Область(СтрокаН+НКолонки+1,Сч).ГоризонтальноеПоложение = ГоризонтальноеПоложение.Право;
			КонецЕсли;
			Сч=Сч+1;
		КонецЦикла;
	КонецЕсли;
	
	//*** теперь - подвал (если нужен)
	ТабДок.Область(СтрокаН+НКолонки+2,1).Шрифт = Новый Шрифт(,9,Истина,) ;
	ТабДок.Область(СтрокаН+НКолонки+2,1).ЦветТекста = Новый Цвет(,,152) ;
	ТабДок.Область(СтрокаН+НКолонки+2,1).Текст = ТекстПодвала;
	ТабДок.Область(СтрокаН+НКолонки+2,1).ГоризонтальноеПоложение = ГоризонтальноеПоложение.Лево;
	
	ТабДок.ФиксацияСверху = НКолонки;

	Возврат ТабДок;
	
	
	
КонецФункции


Тестировалось на платформах 8.3.13.1513 и 8.3.14.1630 , конфигурация "Комплексная автоматизация 2.2 - 2.4".

На другом не проверялась, но работать должна на любых, где используются управляемые формы.

3

Специальные предложения

Избранное Подписка Сортировка: Древо
В этой теме еще нет сообщений.
Оставьте свое сообщение

См. также

Агрегатные функции СКД, о которых мало кто знает 315

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    9620    ids79    42       

Обмен данными. Консистентность vs Многопоточность 25

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Интеграция

Рассмотрим теоретические основы обмена данными. Какие бывают обмены, какие гарантии при этом даются, зачем идти на компромиссы и что при этом может пойти не так. Есть ли идеальная схема?

03.09.2019    3063    m-rv    1       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив 240

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    10000    ids79    22       

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    4721    m-rv    2       

Как настроить правильную техподдержку (helpdesk, service desk на коленке) 38

Статья Программист Бизнес-аналитик Руководитель проекта Нет файла v8 УУ Управление взаимоотношениями с клиентами (СRM) Документооборот и делопроизводство Монитор заказов Учет рабочего времени Бесплатно (free) Управление услугами и сервисом

Эта статья будет полезна для компаний, которые оказывают техническую поддержку своим пользователям - внешним или внутренним клиентам. В статье я расскажу, как оказываем поддержку мы, как выстроили этот бизнес-процесс, что контролируем и на что обращаем внимание в работе. Вы можете использовать наш опыт при построении собственной системы поддержки или обратиться к нам за помощью за построением такой системы, будем рады помочь. В статье формируется основной набор правил, которые мы сформировали при настройке системы для себя, а так же небольшие примеры того, как мы эти правила применяем.

24.04.2019    7084    siddy    0       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    7233    m-rv    16       

Информирование пользователя. Работа с объектом «СообщениеПользователю» 249

Статья Программист Нет файла v8::УФ 1cv8.cf Бесплатно (free) Практика программирования Разработка

Различные варианты и нюансы использования объекта СообщениеПользователю и другие способы информирования пользователя: без привязки к какой-либо форме и с выводом сообщения в отдельном окне.

15.02.2019    16715    ids79    34       

Копирование числовых ячеек из 1С в Excel 26

Статья Системный администратор Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Загрузка и выгрузка в Excel Администрирование данных 1С

Решение проблемы, когда значения скопированных ячеек из табличных документов 1С в Excel воспринимаются последним как текст, т.е. без дополнительного форматирования значений невозможно применить арифметические операции. Поводом для публикации послужило понимание того, что целое предприятие с более сотней активных пользователей уже на протяжении года мучилось с такой, казалось бы на первый взгляд, тривиальной проблемой. Варианты решения, предложенные специалистами helpdesk, обслуживающими данное предприятие, а так же многочисленные обсуждения на форумах, только подтвердили убеждение в необходимости описания способа, который позволил мне качественно и быстро справиться с ситуацией.

15.01.2019    10332    itriot11    21       

Универсальные функции ЗУП 3.1 / ЗКГУ 3.1, которые помогут в разработке 462

Статья Программист Нет файла v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Зарплата Управление персоналом (HRM) Бесплатно (free) Универсальные функции

В статье размещен список стандартных процедур и функций с примерами, которые могут помочь при разработке (доработке) конфигураций Зарплата и управление персоналом ред. 3.1 и Зарплата и кадры государственного учреждения 3.1. Иногда бывает довольно сложно правильно получить данные или долго, поэтому лучшим вариантом будет использование стандартных процедур. Буду очень признателен, если Вы поделитесь своим опытом и предложите свои варианты стандартных процедур которые помогают в работе. Или предложите, как дополнить имеющиеся процедуры.

14.11.2018    31368    GeterX    93       

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С 125

Статья Программист Нет файла v8 v8::blocking 1cv8.cf Бесплатно (free) Математика и алгоритмы Практика программирования

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    20685    ids79    40       

Git + 1С. Часть 1. Как подключиться к команде разработки и начать использовать Git 266

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Инструментарий разработчика Управление проектом

Первая статья из цикла инструкций по работе с Git в 1С-разработке. Рассмотрим, как настроить рабочее место, как получить свою "копию" проекта для разработки и приступить к полезным действиям. Все примеры будут изложены в рамках трёх практических кейсов: 1. Моя команда дорабатывает типовую конфигурацию, использует приватный репозиторий на BitBucket, в котором версионируются внешние отчеты/обработки, расширения конфигураций и правила обмена; 2. Я участвую в стартап-команде, которая разрабатывает свою конфигурацию с использованием Git и GitLab; 3. Я принимаю участие в развитии OpenSource-продукта на GitHub как заинтересованный разработчик (контрибьютор).

18.10.2018    33312    stas_ganiev    72       

Вспомогательные инструкции в коде 1С 104

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    20329    tormozit    100       

Из Excel в 1С запросом 33

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

... ну, конечно, не прям так типовым языком запросов, а расширенным языком запросов. Речь пойдет о том, как "залить" данные в таблицы 1С и не пилить при этом бесконечного количества наколеночных обработок.

14.08.2018    13466    m-rv    5       

Повышаем эффективность разработки правил обмена 122

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    19184    olegtymko    43       

Как сделать запрос на изменение данных 75

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    21078    m-rv    21       

Строим графы средствами 1С (без GraphViz) 42

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    16840    slozhenikin_com    19       

Распределение расходов пропорционально продажам 9

Статья Программист Пользователь Нет файла v8 v8::ОУ УТ10 УУ Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Бесплатно (free) Практика программирования

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    11249    Rustig    9       

Универсальный обмен между идентичными конфигурациями через REST интерфейс OData. Часть І: Справочники 96

Статья Программист Нет файла v8 Бесплатно (free) Перенос данных из 1C8 в 1C8

Сейчас все чаще интеграции различных конфигураций проектируются через HTTP-сервисы - они и работают быстрее, и "войти" в режим отладки гораздо проще, тем самым обойдя "черный ящик" универсального обмена через xml, например. Более года назад я начал работать в компании, в которой разработчики работали с конфигурациями 1С в режиме совместимости еще 8.2.16 (менять режим совместимости в типичных базах мы не хотели) - а как Вы наверное знаете, если интересовались HTTP-сервисами в 1С, их использование в режиме совместимости 8.3.4 и ниже недопустимо - и здесь я уже не надеялся на разработку и использование HTTP-сервисов. Но позже меня заинтересовал такой "сервис" как REST интерфейс OData, так как его можно использовать не меняя режим совместимости конфигурации - именно он и стал для меня идеальным вариантом решения "нетривиальных" задач.

11.05.2018    16147    V.Stavinsky    11       

Минимализмы 3 350

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    35381    ildarovich    44       

Этюды по программированию. Взаимодействие с Microsoft Word 108

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Часто приходится заниматься созданием сложных документов Word с таблицами, вложенными фрагментами, хитрым оформлением и прочими радостями жизни. Это - попытка как-то структурировать полученный опыт, чтобы не приходилось перерывать ворох старых обработок в поисках крупиц истины. Надеюсь, эта статья будет полезна и Вам.

11.12.2017    25738    milkers    23       

Метод формирования движений в типовых регистрах нетиповыми регистраторами 31

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    21226    itriot11    34       

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена) 720

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    136936    MaxS    251       

Как работает серверный вызов в 1С 456

Статья Программист Нет файла v8::УФ Бесплатно (free) Математика и алгоритмы

Клиент-серверная архитектура заложена в платформе изначально — со времен «1С:Предприятие 8.0». Однако при разработке на 8.0 и 8.1 о разделении кода на клиентскую и серверную часть можно было не заботиться, поскольку на клиенте (на толстом клиенте) был доступен тот же функционал, что и на сервере. Всё изменилось с выходом платформы «1С:Предприятие 8.2», когда появился тонкий клиент. Теперь на клиенте доступен один функционал, на сервере — другой. Клиент и сервер «общаются» между собой с помощью серверного вызова. Конечно, это усложнило процесс разработки, но с другой стороны – можно создавать более оптимальные (быстрые) решения, поскольку все сложные задачи выполняются на сервере.

18.11.2017    42746    pahich    75       

Обзор имеющихся библиотек OneScript 298

Статья Системный администратор Программист Нет файла v8 Бесплатно (free) OneScript

Экосистема OneScript активно развивается. Количество пользователей данного интерпретатора и имеющихся библиотек неуклонно растет, количество решаемых проблем - тоже. Однако остро встает вопрос некоторой разобщенности и размазанности информации по имеющимся библиотекам, их функциональности и проблемам, которые они решают. Данная статья призвана навести порядок в этой теме.

14.11.2017    30674    nixel    85       

Программные перечисления, ч.2: приемы кэширования при разработке 66

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Все знают, что такое кэш, и зачем он нужен. Но в 1С разработчик обычно использует кэширование только на уровне конфигурации, а в какой-нибудь обработке скорее ломает голову над запросом - как получить все данные за один заход... Хочется рассказать о том, как можно добиться хороших результатов с стратегией "разделяй и властвуй".

30.10.2017    20949    unichkin    17       

Легкий способ обновления измененной конфигурации 41

Статья Системный администратор Программист Нет файла v8 Бесплатно (free) Инструментарий разработчика

Легкий способ обновления измененной конфигурации. Сервис подготовки расширения конфигурации

25.10.2017    18493    avk72    63       

Работа с Excel 287

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Собрал различные полезности для работы с Excel из 1С. Иногда приходится форматировать документ Excel программно из 1С. Так вот, чтобы не искать постоянно на просторах интернета как сделать левое выравнивание в ячейке Excel из 1С и т.п. решил опубликовать это...

23.10.2017    24440    arakelyan    39       

Подбор в управляемой форме - что может быть проще? 119

Статья Программист Нет файла v8::УФ 1cv8.cf Бесплатно (free) Работа с интерфейсом

Технологии модальности сейчас меняются на технологии асинхронности, многопоточности и прочие дивные вещи, что, в свою очередь, заставляет людей еще чаще спрашивать о том, что да как в этой новой нелегкой жизни. Разбираемся!

19.09.2017    27717    starik-2005    51       

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере 125

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Практика программирования

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    34101    tormozit    72       

Ускоряем 1С: модули с повторным использованием возвращаемых значений 136

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

По роду своей деятельности, мне часто приходится обсуждать с программистами детали реализации той или иной функциональности. Очень часто, разговаривая даже с квалифицированными специалистами я сталкиваюсь с незнанием сути платформенной функциональности Повторного использования возвращаемых значений общих модулей. В данной статье я постараюсь дать краткий обзор и основные особенности этой функциональности.

04.09.2017    42966    m-rv    60       

Как просто запомнить алгоритм программного вывода в СКД 205

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования

Порой нужно быстро вывести на экран таблицу значений, используя СКД \ получить данные отчета в таблицу значений.. Несмотря на очевидность алгоритма - раньше мне проще было загуглить программный вывод, благо эта инфа есть везде. Но постепенно понял как его можно быстро вспомнить, и лишний раз ничего не искать. Конечно эта статья не для Гуру :) Но я думаю - что любой неопытный в СКД программист сделает для себя небольшое открытие...

01.09.2017    41384    unichkin    15       

Как формируется GUID? 461

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

"Коллеги, есть идеи, как получить последнюю созданную характеристику? Реквизиты полностью идентичны(код, наименование, и т.п.)."(c) "Насколько я знаю, ссылка не обеспечивает последовательность, а только уникальность."(c) "Я сделал по Максимум(Ссылка). Но, чета, мне кажется, это неправильно."(c) "Слышал что в ГУИд содержится как раз время создания и по всей логике вещей сортировка по ссылке должна сортировать по моменту создания объекта"(c) Сколько раз вы слышали такие фразы? На удивление я не обнаружил информации по этой теме, пришлось разбираться самому...

16.06.2017    52072    kuzyara    55       

Использование инструментов разработчика для отладки обменов КД 2.0 67

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

Пара трюков, благодаря которым жить становится намного проще...

05.05.2017    22512    unichkin    3       

Работа с конвертацией данных 349

Статья Программист Нет файла v8 КД Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Поскольку к конвертации обращаюсь время от времени и какие-то детали забываются, хочу выделить несколько пунктов, чтобы "было где посмотреть". Статья сделана преимущественно «для себя», так что просьба не судить строго. (Примечание читающим/комментирующим: код в примерах очень сильно сокращен.)

16.03.2017    61612    perepetulichka    25       

Online телефонный справочник из 1С: Зарплата и управление персоналом 33

Статья Системный администратор Программист Нет файла v8 ЗУП3.x Россия Управление персоналом (HRM) Бесплатно (free) WEB

В интернете представлено много реализаций online телефонных справочников организаций. Есть справочники, которые использует для хранения информации базу Active Directory (LDAP), есть справочники, которые реализованы с использованием СУБД (например, MySQL). Но я не нашел справочника, который использует информацию из базы 1С. Далее я рассмотрю данную разработку.

10.03.2017    18992    ruha    14       

Библиотека стандартных подсистем (Механизм БСП) 74

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем)

Конфигурации в 1С пишутся для пользователей и по их «правилам» (клиент всегда прав), поэтому в основном все конфигурации разные, но достаточно часто в них используются одни и те же объекты, которые незначительно отличаются друг от друга. Действительно, сложно представить конфигурацию, где не фигурировали бы такие сущности как номенклатура, контрагенты, пользователи, валюта. И некоторые задачи являются типичными: возможность базового разграничения прав, работа с электронной почтой, задачи пользователям и т.д. Но...!

03.03.2017    51105    V.Stavinsky    21       

Автоматизированная проверка конфигураций… и пара слов о стандартах разработки 265

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Практика программирования Тестирование и исправление

Предлагаю познакомиться с инструментом "Автоматизированная проверка конфигураций" и получить практику его применения

18.01.2017    43268    3    Vladimir Litvinenko    19       

Отладка подключаемых обработок 195

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

На самом деле для этого не нужно ни изменять конфигурацию, ни пользоваться вспомогательной обработкой-отладчиком.. Все просто :)

04.01.2017    43385    unichkin    77       

Использование программных перечислений, ч.1: строковые константы 142

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    29830    unichkin    45       

РИБ 200 узлов. Середина пути 116

Статья Системный администратор Программист Нет файла v8 Розница Россия Бесплатно (free) Распределенная БД (УРИБ, УРБД)

Между настройкой и поддержкой РИБ на 2 узла и на 10 большой разницы нет, а вот когда число удаленных точек переваливает за сотню, приходится решать уже совсем другие вопросы

25.10.2016    34069    comol    215       

Использование git для доработки типовых конфигураций 1С 229

Статья Программист Нет файла v8 Беларусь Украина Россия Бесплатно (free) Математика и алгоритмы

Рассмотрены способы доработок типовой конфигурации 1C для различных изменений, и на картинках продемонстрирован подход к разработке с использованием git и частично с тестами.

11.10.2016    185859    pumbaE    31       

Отладка конфигураций на мобильной платформе 107

Статья Программист Нет файла v8 Бесплатно (free) Мобильная разработка

Настройка и подключение отладчика для отладки конфигураций на мобильной платформе.

25.09.2016    34899    spezc    44       

Обновление доработанной Бухгалтерии предприятия. Как проверить и убедиться, что все сделано хорошо? 89

Статья Системный администратор Программист Бухгалтер Нет файла v8 БП2.0 Бесплатно (free) Практика программирования

На тему обновления нетиповых конфигураций написано немало. Но в основном все это касается самого процесса обновления, его технической стороны. Что нажимать, на что не нажимать в том или ином случае. В данной статье хотелось бы обратить внимание на действия, которые требуются для последующего анализа обновленной конфигурации.

05.09.2016    24759    kraynev-navi    33       

Старые обработки в новом (Управляемом) интерфейсе 101

Статья Программист Нет файла v8 v8::УФ Windows Бесплатно (free) Практика программирования

Многие разработчики привыкли использовать какие-либо обработки, разработанные для приложений с обычным интерфейсом. Но они не работают в приложениях на управляемых формах. Как вариант, эту обработку можно включить в состав конфигурации, указать в свойствах конфигурации, что возможно использование обычных форм

12.08.2016    57928    valerasv    7