Загрузка платежных поручений в формате казначейства (TXPP170101) в БГУ 1.0

Публикация № 1082522

Учет и отчетность - Банковские операции

Загрузка Бюджет СУФД УФК ФК СЭД Платежка Платежное поручение ПП Казначейство Формат TXPP170101 БГУ Заявка кассовый расход

Загружает в базу (БГУ 1.0) Платежные поручения из файлов *.pp* расположенных в указанном каталоге. Считывает данные из файла в соответствии с описанием формата.

1) Указываем Учреждение, Каталог (где лежат файлы), Договор (затычка для аналитики 302х счетов), Контрагент ЗП (Контрагент для аналитики 302.1Х - на кого начисляется зарплата).

2) "Считать данные" - подготовительный этап на котором файлы считываются во ВнутреннееПредставлениеДанных (далее по тексту, см скриншот 2).

3) "Заполнить"

4) Установить соответствие прочитанным в файлах КБК (PPST.KBK), Тип КБК (PPST.TYPE_KBK), ДК - Код цели (PPST.ADD_KLASS) И КБК в Базе данных

5) "Выполнить" для загрузки документов.

 

С помощью этой обработки я загружал ПП из файлов в базу Автономного учреждения (Конфигурация БГУ 1.0). Сразу предупрежу, что большое влияние на процесс загрузки сыграет региональная специфика. У нас в регионе используется определенная структура Назначения платежа, и обработка очень много информации берёт именно из него. (КВД, КЭК, ДК - код цели, РК - региональная классификация, СчетДебета в конце концов)

нпр: (013.244:12363,91) ЭК 223 л/с 3001304ХХХХ ДК 1.0113.4940110020.01 РК 2231 БО 3604131201900430 упд №6301/УС/16485 от 30.04.2019г, за теплоэнергию за апрель 2019, в т.ч 2060,65 НДС 20%

 

Ну а теперь немного хороших новостей: Велика вероятность, что обработка может существенно упростить вам загрузку любого другого Документа из файла в формате ФК. Обработка открывает первый файл в папке, считывает в нём название и версию формата (TXPP170101, TXZR170101). Считывает из базы данных описание формата (FK.NUM_VER, FK.FORMER,..., PPT.INN_PAY...) и в соответствии с этим описанием формирует ВнутреннееПредставлениеДанных в виде Структуры (см. скриншот №2) Теоретически ВнутреннееПредставлениеДанных сформируется для любого файла соответствующего формату казначейства, описание которого есть в базе данных  (Справочники.Форматы) Вам не придётся отсчитывать палочки ("|"), а процесс заполнения документов, вы будете описывать приблизительно сл. образом 

Объект.ИННПлательщика = PPT.INN_PAY;

Велика вероятность, что написанная вами обработка спокойно продолжит работать даже после обновления форматов.

Тестировалось на релизе 1.0.58.2.

Скачать файлы

Наименование Файл Версия Размер
Загрузка Платежных поручений в формате казначейства (TXPP170101) в БГУ 1.0:

.epf 22,29Kb
24.06.19
12
.epf 2.00 22,29Kb 12 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. psa247 4 26.10.20 15:55 Сейчас в теме
2. psa247 4 04.11.20 15:45 Сейчас в теме
Денис, вроде, на файлах-реестрах (где в один файл выгружается несколько ПП) некорректно считывает все платежки. Точнее, цепляет только последнюю запись, т.е. создает один контейнер с описанием файла, вместо N-штук
3. dvsidelnikov 17 04.11.20 17:52 Сейчас в теме
(2) В каком формате грузим? Пришли пример файла.

P.S. когда считывал TXBD натыкался на проблему, решал её буквально исправлением пары строчек, но вот каких без отладки мне не вспомнить.
6. psa247 4 05.11.20 13:44 Сейчас в теме
Предыдущий пост делать не обязательно, но хуже не будет. Короче, как Я решил эту проблему:

в функции

Функция ВнутреннееПредставлениеДанных(ДанныеВФорматеКазначейства) Экспорт
//Определимся с форматом
КодФормата = ВерсияФормата(ДанныеВФорматеКазначейства);
Если КодФормата = Неопределено Тогда
Сообщить("Формат не определён.");
Возврат Неопределено;
КонецЕсли;

Формат = Справочники.КС_Форматы.НайтиПоНаименованию(КодФормата);
ВнутреннееОписаниеФормата = ВнутреннееОписаниеФормата(Формат);

МассивРазделителейПС = Новый Массив;
МассивРазделителейПС.Добавить(Символы.ПС);
МассивСтрокФайла = СтрРазделить(ДанныеВФорматеКазначейства, МассивРазделителейПС);

МассивРазделителейПолей = Новый Массив;
МассивРазделителейПолей.Добавить("|");

РезультатРаботы = Новый Массив; // ПРОФ
Результат = Новый Структура;

результат работы функции превратил в массив "результатов", далее ....

//Построчно читаем содержимое файла
//0) FK|TXPP170101|1С:Предприятие|8||
//1) FROM|2|10504131|...
Для Каждого СтрокаФайла из МассивСтрокФайла Цикл
Если ПустаяСтрока(СтрокаФайла) Тогда
Продолжить;
КонецЕсли;
//Разбираем строку файла на поля (в первом поле название группы полей)
//0)FK
//1)TXPP170101
//2)1С:Предприятие
МассивПолейСтрокиФайла = СтрРазделить(СтрокаФайла,МассивРазделителейПолей);
ГруппаПолей = МассивПолейСтрокиФайла[0];
СоставГруппыПолей = ВнутреннееОписаниеФормата[ГруппаПолей].Состав;
Если ВнутреннееОписаниеФормата.Свойство(ГруппаПолей) Тогда
Если ВнутреннееОписаниеФормата[ГруппаПолей].Тип = "КоллекцияРеквизитов" Тогда
//FK, FROM...
//{ ПРОФ
Если Результат.Свойство(ГруппаПолей) = ИСТИНА Тогда
Врем = СкопироватьСтруктуру(Результат);
РезультатРаботы.Добавить(Врем);

Результат = Новый Структура;
КонецЕсли;
//} ПРОФ


Результат.Вставить(ГруппаПолей, Новый Структура);
СчетчикПолей = 0;
Для Каждого ИмяПоля из ВнутреннееОписаниеФормата[ГруппаПолей].Состав Цикл
СчетчикПолей = СчетчикПолей + 1;
Результат[ГруппаПолей].Вставить(ИмяПоля, МассивПолейСтрокиФайла[СчетчикПолей]);
КонецЦикла;


добавил признак появления новых "документов". И в случае, если в одном файле находится несколько документов, то сохранял то, что уже "прочитали" из файла в массив результатов и создавали новую структуру для чтения в нее нового документа.
4. psa247 4 05.11.20 08:18 Сейчас в теме
5. psa247 4 05.11.20 13:07 Сейчас в теме
Скорее всего здесь идет не создание нового контейнера, а перезатирание созданного, проверь, плиз:

Функция ВнутреннееОписаниеФормата(пФормат) 
	Результат = Новый Структура;
	Результат.Вставить("Тип", "Файл");
	Результат.Вставить("Имя", "Файл");
	//Результат.Вставить("МассивОбъектов", Новый Массив);
	ПредыдущееЛевоеЗначение = "";
	МассивРазделителей = Новый Массив;
	МассивРазделителей.Добавить(".");
	НачалоОбъекта = Ложь;
	Объект = Неопределено;

	Для Каждого СтрокаПравилаОбмена из пФормат.ПравилаОбмена Цикл
		Если СтрокаПравилаОбмена.Отключить Тогда
			Продолжить;
		КонецЕсли;
		
		тПолеФайла = СтрокаПравилаОбмена.ПолеФайлаПередачи;
		МассивСтрок = СтрРазделить(тПолеФайла, МассивРазделителей);
		ЛевоеЗначение = МассивСтрок[0];
		ПравоеЗначение = МассивСтрок[1];
		НачалоОбъекта = СтрокаПравилаОбмена.Условие = "*НачалоОбъекта";
		СменилосьЛевоеЗначение = ПредыдущееЛевоеЗначение <> ЛевоеЗначение;
		ЭтоТабличнаяЧасть = Не ПустаяСтрока(СтрокаПравилаОбмена.ТабличнаяЧасть);
Показать


Если СменилосьЛевоеЗначение Тогда
Результат.Вставить(ЛевоеЗначение, Новый Структура);
Результат[ЛевоеЗначение].Вставить("Имя", ЛевоеЗначение);
Результат[ЛевоеЗначение].Вставить("Состав", Новый Массив);

Результат[ЛевоеЗначение].Состав.Добавить(ПравоеЗначение);
			Результат[ЛевоеЗначение].Вставить("Тип");
			Результат[ЛевоеЗначение].Вставить("Владелец");
8. dvsidelnikov 17 05.11.20 14:16 Сейчас в теме
(5) Готово. Нужно заменить процедуру:

Функция ВнутреннееОписаниеФормата(пФормат) 
	Результат = Новый Структура;
	Результат.Вставить("Тип", "Файл");
	Результат.Вставить("Имя", "Файл");
	//Результат.Вставить("МассивОбъектов", Новый Массив);
	ПредыдущееЛевоеЗначение = "";
	МассивРазделителей = Новый Массив;
	МассивРазделителей.Добавить(".");
	НачалоОбъекта = Ложь;
	Объект = Неопределено;

	Для Каждого СтрокаПравилаОбмена из пФормат.ПравилаОбмена Цикл
		Если СтрокаПравилаОбмена.Отключить Тогда
			Продолжить;
		КонецЕсли;
		
		тПолеФайла = СтрокаПравилаОбмена.ПолеФайлаПередачи;
		МассивСтрок = СтрРазделить(тПолеФайла, МассивРазделителей);
		ЛевоеЗначение = МассивСтрок[0];
		ПравоеЗначение = МассивСтрок[1];
		НачалоОбъекта = СтрокаПравилаОбмена.Условие = "*НачалоОбъекта";
		СменилосьЛевоеЗначение = ПредыдущееЛевоеЗначение <> ЛевоеЗначение;
		ЭтоТабличнаяЧасть = Не ПустаяСтрока(СтрокаПравилаОбмена.ТабличнаяЧасть);
		//костыль конкретно для TXBD180101
		//Если СменилосьЛевоеЗначение и ЛевоеЗначение = "BD" Тогда
		//	НачалоОбъекта = Истина;
		//КонецЕсли;
		
		Если СменилосьЛевоеЗначение и ЛевоеЗначение = "ZR" Тогда
			НачалоОбъекта = Истина;
		КонецЕсли;
		
		Если СменилосьЛевоеЗначение и ЛевоеЗначение = "ZRST" Тогда
			ЭтоТабличнаяЧасть = Истина;
		КонецЕсли;

				
		Если СменилосьЛевоеЗначение Тогда
			Результат.Вставить(ЛевоеЗначение, Новый Структура);
			Результат[ЛевоеЗначение].Вставить("Имя", ЛевоеЗначение);
			Результат[ЛевоеЗначение].Вставить("Состав", Новый Массив);
			Результат[ЛевоеЗначение].Состав.Добавить(ПравоеЗначение);
			Результат[ЛевоеЗначение].Вставить("Тип");
			Результат[ЛевоеЗначение].Вставить("Владелец");
			
			
			Если НачалоОбъекта Тогда
				Результат[ЛевоеЗначение].Тип = "Объект";
				Результат[ЛевоеЗначение].Владелец = Результат;
				Объект = Результат[ЛевоеЗначение];
			КонецЕсли;
			
			Если ЭтоТабличнаяЧасть Тогда
				Результат[ЛевоеЗначение].Тип = "ТЧ";
				Результат[ЛевоеЗначение].Владелец = Объект;
			КонецЕсли;
			
			Если Результат[ЛевоеЗначение].Владелец = Неопределено Тогда
				Результат[ЛевоеЗначение].Владелец = Результат;
				Результат[ЛевоеЗначение].Тип = "КоллекцияРеквизитов";
			КонецЕсли;
			
		Иначе
			Результат[ЛевоеЗначение].Состав.Добавить(ПравоеЗначение);
		КонецЕсли;
		ПредыдущееЛевоеЗначение = ЛевоеЗначение;
	КонецЦикла;
	Возврат Результат;
КонецФункции
Показать


P.S. Проблема в том, что я так и не придумал как глядя в правила обмена отличить начало нового объекта от начала новой строки... Приходится указывать явно условие в Функции
9. psa247 4 05.11.20 14:19 Сейчас в теме
(8) Это придется под каждый формат подстраиваться. Рассмотри мой вариант в 6м и 7м ответе
11. psa247 4 05.11.20 14:27 Сейчас в теме
(8) Я бы сделал следующим образом. Если произошла смена левой части, то проверил бы. В структуре Результата уже есть такая "левая часть", если есть - то это новый документ
12. dvsidelnikov 17 05.11.20 14:36 Сейчас в теме
(11) ... или это строка табличной части документа... лучше уж сверять левую часть с интерактивно набранными списками наименований Объектов и ТабличныхЧастей

схематично:

        Если СменилосьЛевоеЗначение и НаименованияОбъектов.Найти(ЛевоеЗначение) Тогда
            НачалоОбъекта = Истина;
        КонецЕсли;
        
        Если СменилосьЛевоеЗначение и НаименованияТабличныхЧастей.Найти(ЛевоеЗначение) Тогда
            ЭтоТабличнаяЧасть = Истина;
        КонецЕсли;
13. psa247 4 05.11.20 14:38 Сейчас в теме
(12) Данный подход требует подготовки алгоритма действий и запоминания. Через год, когда понадобится уже и не вспомнить что и где интерактивно набирать. Мне мой вариант предпочтительнее. Сделал и забыл. Работает как часы
14. psa247 4 05.11.20 14:47 Сейчас в теме
(12) Если это строка табличной части, то она идет друг-за-другом, если был "перерыв" в "левых" частях, то это однозначно признак нового документа. В общем, решай сам
7. psa247 4 05.11.20 13:47 Сейчас в теме
Но, чтобы уже прочитанный результат не "затерся" конструкцией Результат = Новый Структура;
использовал копирование:

Врем = СкопироватьСтруктуру(Результат);
РезультатРаботы.Добавить(Врем);

сама фукнкция копирования структуры:

Функция СкопироватьСтруктуру(Входящая)
	КопияСтруктуры = Новый Структура;
	Для Каждого ЭлементСтруктуры Из Входящая Цикл
		КопияСтруктуры.Вставить(ЭлементСтруктуры.Ключ, ЭлементСтруктуры.Значение);
	КонецЦикла;
	Возврат(КопияСтруктуры);
КонецФункции
Показать

В результате вышеперечисленного получил массив состоящий из нескольких прочитанных документов. Недостатком будет только то, что у всех остальных документов, что идут за первым не будет "шапочных" данных типа FR, FROM. Но и без них хорошо, так как информации необходимой для испорта документов они не несут.
10. psa247 4 05.11.20 14:21 Сейчас в теме
Да, если по моему варианту, то Массив результатов надо обработать в цикле, естественно. С тебя стармани ))
Оставьте свое сообщение

См. также

Пакетное пробитие чеков на Онлайн-кассе при оплатах от физических лиц на расчетный счет Промо

Банковские операции Кассовые операции Обработка документов v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Автоматизация процесса пробития чеков онлайн при поступлениях на расчетный счет от физических лиц. Помогает сократить трудозатраты таким организациям, как МФЦ, Управляющие компании и т.д. Подходит для 1С:Бухгалтерия 3.0 любой версии (базовая, ПРОФ, КОРП). Не изменяет конфигурацию. Конфигурация остается на поддержке (типовая).

2 стартмани

24.09.2019    11717    3    r.resh39    6    

Улучшенная обработка универсального обмена данными в формате XML (УФ)

Универсальные обработки Внешние источники данных Обмен через XML v8 v8::УФ 1cv8.cf Абонемент ($m)

Улучшенная обработка "Универсальный обмен данными" с полноценными возможностями СКД для выборки данных (не только для отборов).

1 стартмани

23.06.2020    4860    63    Lem0n    1    

Взаимодействие HTML (COM объект, WebKit) с 1С (обычные и управляемые формы)

Внешние источники данных WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Показан пример использования HTML (COM объект, WebKit) в 1С (8.3).

2 стартмани

18.01.2020    8415    24    Deniskinr83    0    

Google drive - менеджер файлов

WEB Внешние источники данных v8 1cv8.cf Россия Абонемент ($m)

Синхронизация с гугл диском легко и просто!

10 стартмани

05.12.2019    10079    29    zykov_vitaliy    26    

Конвертация данных Парус 7, 10 - ЗУП 2.5, ЗИКБУ 1.0, КА 1.1, УПП Промо

Внешние источники данных Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 КА1 ЗУП2.5 УПП1 БГУ Россия БУ Госбюджет Абонемент ($m)

Перенос данных Парус 7, 10 - ЗУП 2.5, ЗИКБУ 1.0, КА 1.1, УПП Переносит данные сотрудника, физического лица и начисления за произвольный период

1 стартмани

10.06.2014    32846    38    kns77    81    

Использование хранимых процедур MS SQL Server в 1С

Внешние источники данных v8 1cv8.cf Абонемент ($m)

Потребовалось мне как-то построить сложный запрос к внешнему источнику данных, на что платформа радостно послала меня в гугл. Немного подумав, решил написать в SQL процедуру, которая принимала бы какие-то параметры и возвращала какую-то таблицу значений с данными.

1 стартмани

03.12.2019    11062    4    Dedushka    26    

Получение изображения с IP-камеры

Внешние источники данных v8 1cv8.cf Абонемент ($m)

Получение изображения JPG с IP-камеры в виде двоичных данных. В 1С может применяться для фотографирования объектов.

1 стартмани

10.09.2019    11438    35    sivin-alexey    8    

Согласование задач из Outlook

Внешние источники данных v8 1cv8.cf Абонемент ($m)

Согласование задач непосредственно из почтовой программы, в моем случае Outlook 2013 без каких-либо дополнительных настроек. Из почты отправляется GET запрос к HTTP-сервису 1С, который в свою очередь выполняет задачу.

1 стартмани

06.09.2019    8857    12    duhh    17    

Загрузка данных из М-Аптеки+ в 1С:Бухгалтерия 8 (ред. 3.0) Промо

Внешние источники данных Файловые протоколы обмена, FTP v8 v8::БУ БП3.0 Фармацевтика, аптеки БУ Абонемент ($m)

Обработка для загрузки файлов выгрузки из программы для автоматизации аптек и аптечных сетей М-Аптека+ в 1С:Бухгалтерия 8, редакция 3.0.

11.07.2014    35421    31    1C_MApteka    37    

Телеграм 1С – почти коробка

Внешние источники данных v8 Абонемент ($m)

Почему это решение называется «почти коробка»? Потому, что это почти коробочное решение. С его помощью, просто добавив подсистему в конфигурацию, уже можно начинать взаимодействовать с мессенджером Telegram.

10 стартмани

20.08.2019    14048    25    zfilin    66    

Расширение Бром для интеграции с 1С

Внешние источники данных WEB v8 Абонемент ($m)

Из этой статьи вы узнаете, как можно быстро и просто синтегрироваться с любой конфигурацией 1С при помощи расширения Бром.

1 стартмани

06.08.2019    6938    4    itworks    13    

Конфигурация для обмена данными (интеграционная шина)

Внешние источники данных WEB v8 1cv8.cf Абонемент ($m)

Система позволяет организовать обмен данными, как с базами 1С, так и любыми другими приложениями. Система представляет собой отдельную конфигурацию. Система позволяет организовать гибкие возможности по настройке обмена. В качестве брокера сообщений, для передачи данных, используется отдельная самостоятельная конфигурация на 1С. Комплект поставки содержит файл расширения для "клиентской" части шины, данное расширение позволяет без снятия "ключа" организовать гибкий механизм обмена данными.

4 стартмани

08.07.2019    12762    31    miha-28    17    

Менеджер загрузки данных из весов с печатью этикеток Промо

Внешние источники данных Весы Учет ТМЦ Учет ТМЦ v8 УТ10 УПП1 Абонемент ($m)

Программное обеспечение "Менеджер загрузки данных из весов с печатью этикеток" предназначено для автоматического получения данных по сети Ethernet из весов МАССА-К моделей ВПМ и ТВ_Р3 (модификация MF) в режиме On-Line.

1 стартмани

20.12.2011    22979    4    hrip    10    

Шаблон http-сервиса для вашего проекта

Внешние источники данных WEB Мобильная разработка v8 v8::Mobile 1cv8.cf Абонемент ($m)

Http-сервис для обмена данными в формате JSON. Обработчики этого сервиса находятся во внешней обработке, что позволяет дорабатывать его без изменения конфигурации. Также прилагаю пример мобильного приложения для работы с данным сервисом (получает номенклатуру и остатки на складе). Сервис очень быстро разворачивается и масштабируется под ваши задачи.

3 стартмани

04.05.2019    19941    76    MarkoSokolov    48    

Доработка функционала отправки дополнительных реквизитов 1С: ЭДО для Татнефть

Внешние источники данных Документооборот и делопроизводство Документооборот и делопроизводство v8 ERP2 БУ Абонемент ($m)

Подключаемое расширение к конфигурации ERP с функционалом отправки дополнительных реквизитов 1С ЭДО для Татнефть (№ и дата договора, подразделение, автор, примечание) в электронных документах Счет-фактуры и ТОРГ-12 Проверялось на 1С:ERP Управление предприятием 2.4.6.160.

2 стартмани

07.04.2019    9996    16    sapervodichka    10    

Генерация схемы xsd из файла xml

Инструментарий разработчика Внешние источники данных v8 Абонемент ($m)

Утилита, генерирующая xsd схему на основании xml файла.

1 стартмани

25.03.2019    15667    27    nbeliaev    11    

Работа с Active Directory из 1С (загрузка / выгрузка данных)

Внешние источники данных v8 1cv8.cf Россия Абонемент ($m)

Загрузка данных из Active Directory / Изменение информации пользователя в AD из 1С.

1 стартмани

26.02.2019    12298    89    Смешной 1С    7    

HTTP API Диадок. Загружаем в Диадок любой документ. Посредством POST и GET запросов

Внешние источники данных v8 1cv8.cf Абонемент ($m)

Поставили задачу через HTTP API Диадок (diadoc-api.kontur.ru) отправить любой файл в Диадок и подписать его (например, служебную записку в формате пдф). Посредством POST и GET запросов.

2 стартмани

14.01.2019    12425    35    John_d    11    

Интеграция WhatsApp в 1С (botcorp.io и api-messenger.com)

Внешние источники данных v8 Абонемент ($m)

Сейчас у WhatsApp более 1 млрд. пользователей во всём мире. В России мессенджер держится на верхних строчках по популярности среди всех мессенджеров. Из чего следует, что WhatsApp является самым желанным мессенджером для интеграции с 1С.

3 стартмани

22.11.2018    25828    59    17808849    49    

Что нам стоит Push построить Промо

Внешние источники данных v8 v8::Mobile Абонемент ($m)

Попробовал некоторое время назад, push сообщения, реализованные в платформе. Понравилось, но есть несколько минусов, на примере одной программы сообщений (не буду показывать пальцем), спустя некоторое время, сообщения переставали приходить онлайн, а на компьютере приходили моментально, при этом сами смартфоны звались флагманами. Читал позднее статью, где описывалось, что проблема на стороне смартфонов, что-то вроде технологий энергосбережения, но точно не помню. Также немалый минус доступно только для смартфонов.

1 стартмани

08.09.2016    28078    17    PloAl    8    

Исправление ошибки универсального обмена Бухгалтерия предприятия, редакция 3.0 (3.0.65.х, расширение конфигурации)

Внешние источники данных Адаптация типовых решений v8 БП3.0 Абонемент ($m)

Уже у третьего клиента вижу ошибку Ошибка проверки данных XDTO: Структура объекта не соответствует типу: {http://www.1c.ru/SSL/Exchange/Message}Header Значит, как говаривал Винни-Пух - это неспроста. Ну и точно неспроста, 1С что-то подшаманили в обмене через универсальный формат.

1 стартмани

19.10.2018    18415    37    capitan    15    

Загрузка чека онлайн-касс (загрузка товаров из чека)

Внешние источники данных WEB Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 1cv8.cf Абонемент ($m)

Обработка-пример, позволяет любому и из любой конфигурации загрузить информацию о товарах из чека(и не только) из почтового сообщения, отправленного из приложения ФНС проверка чеков.

2 стартмани

08.10.2018    21776    39    echo77    73    

Мониторинг показателей систем 1С 8.3 с помощью Zabbix

Внешние источники данных Zabbix v8 1cv8.cf Абонемент ($m)

Опишу свой опыт мониторинга наших систем 1С с помощью Zabbix и ту пользу, которую можно извлечить из этого.

1 стартмани

05.10.2018    41657    58    akimych    48    

Отправка сообщений через Telegram (через прокси)

Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Простая обработка для отправки сообщений из 1с в Телеграм конкретному пользователю. Используя прокси-сервер: jqlwb.teletype

1 стартмани

20.07.2018    19384    20    Deda    14    

RabbitMQ + 1С. Быстрый старт

Внешние источники данных v8 1cv8.cf Абонемент ($m)

Внешняя компонента для отправки сообщения из 1С в кролика. Сервис прослушивания и перенаправления сообщений из кролика в http или web-сервис.

1 стартмани

10.06.2018    31536    95    Goleff74    42    

Выгрузка и подготовка данных для программы "Перечень льготных профессий" для 1С: ЗУП 2.5 (ОТКРЫТЫЙ КОД) Промо

Рабочее место Внешние источники данных Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП2.5 Россия БУ ФОМС, ПФ, ФСС Абонемент ($m)

Обработка для формирования и редактирования данных для перечня льготных профессий. В связи с прекращением поддержки ЗУП 2.5 и отсутствием времени на доработку для сдачи годовой отчетности открыл код модуля. Не очередная выгрузка стажей, а практически полный аналог перечня для 1С. Формирование и редактирование стажей с последующей выгрузкой в формат перечня, но только ГОРАЗДО удобнее и быстрее. В общем, смотрите видео. Где-то половина времени на написание обработки ушла именно на удобство и скорость работы. Внимание: код модуля обработки открыт

5 стартмани

09.11.2015    51968    84    Black-fog    62    

Экономим время на ввод операций в 1С: Деньги

Внешние источники данных Обработка документов Банковские операции Банковские операции v8 1cv8.cf Домашние учет и финансы Абонемент ($m)

Рабочее решение автоматического создания операций в 1С: Деньги. Основано на анализе СМС.

1 стартмани

14.05.2018    14236    16    vsbronnikov    25    

Интеграция между Atlassian Jira и 1С:Предприятие 8.3 используя Jira REST API (выборка, создание и изменение запросов, чтение, создание и удаление записей о работах, чтение комментариев и другие возможности)

Внешние источники данных WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка на управляемой форме для 1С:Предприятие 8.3 по интеграции с Atlassian Jira используя Jira REST API. Ключевые функции: выборка запросов с использованием JQL; добавление и изменение запросов; добавление, изменение и удаление записей о работах; чтение комментариев к запросам; сохранение всех ключевых параметров между сеансами работы. Тестирование проводилось на платформе 1С (8.3.11.2954) совместно с JIRA Server platform (7.3.7)

1 стартмани

24.04.2018    33535    185    Ko1t    82    

Чтение и запись из таблиц гугл (google sheets) в табличный документ 1С (8.3, управляемые формы)

Внешние источники данных WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка на управляемой форме для 1С версии 8.3 для доступа к сервисам Google Sheets c использованием протокола авторизации OAuth 2.0. Выполняет получение списка листов таблицы гугл, чтение таблицы гугл в табличный документ 1С и запись из табличного документа 1С в таблицу гугл. Тестирование проводилось на платформе 1С:Предприятие 8.3 (8.3.11.2954).

1 стартмани

09.04.2018    41188    273    Ko1t    76    

Выгрузка реестра зарплаты в ГазПромБанк ЗУП 2.5 c ведущими нулями Промо

Обмен с банком Банковские операции Зарплата Банковские операции Зарплата v8 v8::СПР ЗУП2.5 Россия БУ Абонемент ($m)

Корректно выгружает в текстовый формат поля, начинающиеся на НОЛЬ (Например, серии паспортов вида 0803)

5 стартмани

16.05.2016    32292    16    asher72    1    

Чат бот в 73 строки на 1С - ИИ наступает

Практика программирования Внешние источники данных v8 1cv8.cf Абонемент ($m)

Интеграция с уже готовой системой чат-бота для различных случаев жизни. Используется API от DialogFlow Google. Обработка тестировалась на 1С:Предприятие 8.3 (8.3.10.2252) Должно работать на всех 8.3 версиях.

1 стартмани

09.04.2018    13255    30    Lapitskiy    7    

Оповещения из ЗУП и ERP в TELEGRAM

Внешние источники данных v8 ERP2 ЗУП3.x Абонемент ($m)

Начитался статей про интеграцию 1С -> Telegram, решил аккумулировать опыт и попробовать сделать какую-нибудь полезную обработку. Как результат - внешняя обработка, уведомляющая ответственных сотрудников по расписанию о необходимости оплаты отпусков, материальной помощи, премий. Данные посылаются в виде PDF файла (Отчет, созданный на основании макета). Можно использовать обработку как обучающую. Тестировалось на ERP 2.4.2.139, на ЗУП 3.X тоже должно работать.

1 стартмани

01.03.2018    15028    55    khabibullin.tu    14    

Подписка на события, преобразование объекта в JSONAPI, отправка в RabbitMQ

Внешние источники данных Универсальные функции v8 1cv8.cf Абонемент ($m)

Обработка содержит функции: - сериализация объекта 1с в JSONAPI - отправка в RabbitMQ по HTTP

1 стартмани

26.02.2018    12104    22    yaxinr    4    

Формирование платежных поручений на заданную в поступлениях товаров дату Промо

Обработка документов Банковские операции Банковские операции v8::БУ БП3.0 Россия БУ Абонемент ($m)

Данная обработка предназначена для автоматического формирования платежных поручений на выбранный день на основании документов "Поступление товаров и услуг" и "Счета от поставщиков". Для определения срока оплаты документов используется "Срок оплаты", указанный в документах. Предполагается, что эти документы еще не оплачивались. При этом, если есть несколько документов от поставщика с одним договором, которые необходимо оплатить в один день, будет создано одно платежное поручение, в назначении которого будут перечислены все оплачиваемые документы.

8 стартмани

09.11.2016    24041    23    INTECH1    11    

HTTP API Диадок. Пример авторизации и обращения к методам посредством POST и GET запросов

Внешние источники данных v8 1cv8.cf Абонемент ($m)

Поставили задачу через HTTP API Диадок (diadoc-api.kontur.ru) получить статус документа. Посредством POST и GET запросов.

2 стартмани

19.02.2018    17838    51    John_d    4    

К вопросу об интеграции 1С и Битрикс24

Внешние источники данных v8 1cv8.cf Абонемент ($m)

Обработка реализует 4 метода из Rest API Битрикс24 - получение списка бизнес-процессов, получение списка задач, создание задачи и получение свойств задачи по ее идентификатору.

1 стартмани

19.02.2018    15839    93    bulpi    15    

[Расширение] Контекстная подсказка и автозаполнение данных используя DaData.ru без снятия с поддержки БП + УТ + CRM

Обработка справочников Внешние источники данных WEB v8 УНФ БП3.0 УТ11 1С:CRM Абонемент ($m)

Удобно искать, выбирать варианты и заполнять справочники Контрагенты\партнеры\адреса по частям строк, адресов, ИНН, чему угодно, благодаря сервису DaData.ru. Подключается в режиме Предприятие, конфигурация полностью остаётся на поддержке. Не требует наличия подписки ИТС и загрузки КЛАДРа (ФИАС) в базу, при этом не отключает штатный функционал по автозаполнению.

2 стартмани

07.01.2018    16743    124    ipetrochenko    88    

Чтение отчета ОФД (ПлатформаОФД/СБИС Тензор) + получение состава кассового чека

Внешние источники данных Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 v8::ОУ УТ10 Розничная и сетевая торговля (FMCG) Россия БУ Абонемент ($m)

Чтение отчетов оператора ПлатформаОФД/СБИС Тензор с возможностью получения детализации по кассовым чекам для Управление торговлей 10.3.Х.ХХХ.

1 стартмани

12.12.2017    17077    17    independ    9    

Автоматическое заполнение реквизитов контрагентов по ИНН для ERP 2.4, ERP 2.2, УТ 11.4, УТ 11.3, УТ 11.2, КА 2.4, КА 2.2 и БП 3.0 (расширение конфигурации)

Обработка справочников Внешние источники данных WEB Расширения v8 v8::БУ v8::ОУ v8::УФ УПП1 ERP2 БП3.0 УТ11 КА2 Россия Абонемент ($m)

Универсальное расширение конфигурации для автоматической загрузки реквизитов контрагентов (партнеров) из ОГРН для 1С:ERP Управление предприятием 2 (1С:ERP Управление предприятием 2, редакция 2.4), 1С:ERP Управление предприятием 2 (1С:ERP Управление предприятием 2, редакция 2.2), 1С:Управление торговлей 8 (Управление торговлей, редакция 11.4), 1С:Управление торговлей 8 (Управление торговлей, редакция 11.3), 1С:Управление торговлей 8 (Управление торговлей, редакция 11.2), 1С:Комплексная автоматизация 8 (1С:Комплексная автоматизация, редакция 2.4), 1С:Комплексная автоматизация 8 (1С:Комплексная автоматизация, редакция 2.2) и 1С:Бухгалтерия 8 (Бухгалтерия предприятия, редакция 3.0)

3 стартмани

08.11.2017    31879    239    AlexeyT1978    175    

Универсальная выгрузка данных в формате CSV

Внешние источники данных v8 1cv8.cf Абонемент ($m)

Универсальная обработка для выгрузки данных из 1С в файл формата CSV.

3 стартмани

06.11.2017    29477    220    ltfriend    33    

Подсистема обмена данными с порталом ИМНС по электронным счетам-фактурам (автоматический обмен) Промо

Внешние источники данных WEB Инструментарий разработчика v8 1cv8.cf Беларусь БУ НДС Абонемент ($m)

Подсистема включает документы и обработки для автоматического обмена данными с порталом ИМНС через web-сервис. Присутствует возможность заполнения данными типовых операций за период, учёта входящих документов, учёта произвольных исходящих документов. Приложены обработки для запуска задания планировщика на автоматический обмен данными.

1 стартмани

28.07.2016    34087    19    c1nil    4    

Обмен с системой Меркурий через Ветис.API

Внешние источники данных v8 КА1 БП2.0 Сельское хозяйство и рыболовство Россия Абонемент ($m)

Дополнение к основной конфигурации, для обмена с Меркурием. Пока идет тестирование на Бухгалтерии и Комплексной. Версия альфа, т.е. идет доработка функционала. Версия API 1.4.

1 стартмани

12.09.2017    16376    181    and1024    20    

Работа с интегрированным терминалом Сбербанка через утилиту upwin.exe

Обмен с банком Банковские операции Розничная торговля Банковские операции Розничная торговля v8 v8::УФ 1cv8.cf Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Утилита UPWIN.exe от Сбербанка, коды команд для управления интегрированным банковским терминалом (управляемые формы, обычные под 8.1). Обработка на управляемых формах запускается под любой конфигурацией, обработка на обычных формах также запускается под любой конфигурацией на платформе от 8.1 и выше

1 стартмани

05.09.2017    25379    88    independ    12    

Загрузка всех онлайн-чеков с сервиса проверки чеков ФНС – обработка для получения данных о покупках по чекам онлайн-касс с загрузкой в Авансовый отчет

Внешние источники данных WEB Документооборот и делопроизводство Кассовые операции Розничная торговля Учет ТМЦ Кассовые операции Розничная торговля Учет ТМЦ v8 1cv8.cf Россия Абонемент ($m)

В продолжение статьи «Свой кусочек информационного пирога по 54-ФЗ – обработка для получения данных о своих покупках по чекам ОФД» (на примере сети магазинов «Лента») (http://infostart.ru/public/647711/). Однако, в предыдущей публикации был показан пример получения данных с сервиса ОФД Такском по одному магазину, в новой публикации – показан пример загрузки всех чеков по всем ОФД непосредственно с сервиса проверки чеков ФНС. Опубликованы обработки, позволяющие работать по двум схемам: вносить данные по каждому чеку, получая данные с ФНС, или загружать чеки в мобильное приложение ФНС, выбирая в последующем для загрузки нужные чеки из списка. К публикации приложен файл расширения для печати Заявления на возмещения затрат подотчетного лица.

3 стартмани

26.07.2017    26497    124    delta    76    

 Интеграция 1С и C#. Обращение к 1С через COM. Создание номенклатуры и выполнение запроса к 1С из C# на примере интеграции с Союз-PLM (система информационной поддержки жизненного цикла изделий). Обработка «Загрузка заказа на сборку». (ERP) Промо

Загрузка и выгрузка в Excel Внешние источники данных Интеграция v8 ERP2 Абонемент ($m)

Союз-PLM представляет собой полнофункциональный программный комплекс для решения  широкого спектра задач управления инженерной технической информацией наукоемких изделий и сложных инженерных объектов в области машиностроения, приборостроения, архитектуры, строительства. На практике, это управление конструкторской документацией, интегрированное с САПР, бизнес-процессы, файловый архив. Все это работает в SQL и шевелится с помощью скриптов на C#. Скрипты свободно  отлаживаются в MS Visual Studio. Подробнее смотрите на их сайте: http://www.programsoyuz.ru/products/system-soyuz-plm.html  Редактирование, конструирование и использование бизнес-процессов на порядок лучше систем на базе 1С из тех, что я изучил.

1 стартмани

25.07.2016    45917    5    milkers    2    

«Горыныч - то НЕ НАСТОЯЩИЙ!» … или О Конвертации Данных ред.3 (КД 3) и обменах в универсальном формате Enterprise Data… доступным русско-народным языком

Внешние источники данных Обмен через XML Перенос данных из 1C8 в 1C8 v8 КД Абонемент ($m)

Тем, кто хочет быстро разобраться с темой инструмента Конвертация данных 3.0 и технологией обмена по новому формату 1С, активно применяемому во всех новых конфигурациях от 1С на БСП, расширяющем возможности интеграции, пакет полезных материалов.

1 стартмани

13.06.2017    22276    143    Davlad_A    16