Загрузка прайс-листа из EXCEL в справочник Номенклатура, с картинками и иерархией, без установленного MS Office на компьютере

Публикация № 1106415 10.08.19

Учет и отчетность - Розничная торговля

обработка Управление Торговлей Прайс лист загрузка excel табличный документ картинки иерархия

Загрузка прайс листа из EXCEL или табличного документа 1С MXL с сохранением структуры иерархии. А так же с картинками. При этом нет необходимости устанавливать Mcrosoft Office на компьютер. Загрузка в УТ 11.4

Дисклеймер:

Данная статья является больше описанием моего собственного опыта решения данного вопроса, но не в кой мере каким-то универсальным решением для всех и каждого. Поэтому заранее прошу прощения за некоторые упущения и тонкости, которые я мог упустить в процессе её написания.

Предисловие:

Захотелось как-то помочь всем тем несчастным вроде меня, кто знает, что можно читать EXCEL и уже не раз загружал что-то из него в 1С. Но вот тут возникла потребность загрузить картинки из ячеек, да так, что бы понимать какой строке таблицы соответствует какая картинка, что очень даже важно, если загружаешь прайс-лист поставщика.

Покопавшись немного в интернете появилось понимание, что EXCEL 2010 никак не предоставляет возможности выдернуть из себя картинку. И многие используют сторонние библиотеки, для переноса картинки из буфера обмена в файл. Источник //infostart.ru/public/16800/ К Сожалению у меня это не заработало. Библиотека регистрируется нормально но не работает, по причине не ясной до сих пор.

Тогда было принято решение поступить радикально и работать не с объектом EXCEL, а непосредственно с табличным документом, так как есть методы позволяющие прочитать файл xlsx и загрузить его в табличный документ и работать уже конкретно с ним. К счастью у табличного документа 1С у рисунка есть метод позволяющий сохранить его в файл, что уже огромный плюс.

Но тут уже встала другая проблема. Как понять какая картинка, какой строке соответствует? Наивно пологая, что через ширину столбцов и строк можно получить координаты картинки, я «наступил на огромные грабли». Вообще мне не понятно почему так происходит? Почему координаты ячейки не соответствуют координатам картинки. Почему нет какого-то соответствия или индекса или ещё чего-то в 1С, что бы можно было это сопоставить. Это был тупик, пока я не наткнулся на маленькую статейку с кодом вот тут:
https://medium.com/1c-tricks/-c146cf0af7d1                
Спасибо автору Дмитрий Марочко, теперь хоть и через костыли, но всё же я мог найти координаты картинки для нужной строки.

Дальше были только мелочные проблемы, например в Экселе есть возможность получить уровень группировки с помощью Лист1.rows(Х).OutlineLevel А вот в табличном документе такого свойства нет. Ещё возникали проблемы при загрузке картинки уже непосредственно в 1С, но это лишь от незнания особенностей конфигурации УТ 11.4

Платформа: 1С:Предприятие 8.3 (8.3.13.1690)
Конфигурация:  Управление торговлей, редакция 11 (11.4.6.207)

Хватит рассусоливать, погнали код.

Я выложу основные моменты в виде текста, что бы любой мог ими воспользоваться. Но для особо ленивых будет доступна обработка, в которой уже всё готово.  А так же пример прайс-листа. 

  1. Самое простое – это прочитать Эксель в табличный документ. Тут ничего сложно. Единственное есть нюанс, что чтение происходит на сервере и файл у вас должен быть доступен со стороны сервера. У меня это условие выполнялось, так что тут я особо не заморачивался.
    EXCEL открывается в табличном документе, при этом даже не обязательно, что бы на компьютере был установлен какой-то из продуктов Microsoft Office.

    Объект.ТабДок.Прочитать(Объект.ПутьКФайлу);


    В данном случае Объект.ТабДок – это реквизит на форме типа ТабличныйДокумент. Таким образом, у нас файл EXCEL открывается в табличном документе, при этом даже не обязательно, что бы на компьютере был установлен какой-то из продуктов Microsoft Office.

    Следующий код выполняется на клиенте

  2. Следующим этапом надо определить, где находятся нужные нам колонки. Что бы ни подгонять каждый раз таблицу под какой-то определённый шаблон, чего конечные пользователи делать не будут, я написал алгоритм, который позволяет автоматически определять, в каких колонках какие данные находятся.
    При этом, список данных, которые нужны заранее задан как колонки таблицы значений на форме. В моём случае это: Артикул Аналоги, Бренд, Номенклатура, Применяемость, Цена. Алгоритм анализирует начало таблицы в поисках имён и сам определяет по наименованию в какой колонке какие данные лежат. При этом у меня был довольно таки сложный прайс лист, так как в нём присутствовали повторяющиеся названия в колонках, например слово «номенклатура» встречалось несколько раз. Поэтому было дополнительное условие, выбирающее название колонки с наименьшей длинной.

     

    //Создадим структуру, которая будет хранить номер строки и номер колонки табличного документа в которых расположены соответсвующие данные
    	КолПрайсЛист = Новый Структура;
    	Для каждого Эл из Элементы.ТабЛист.ПодчиненныеЭлементы Цикл
    		КолИмя = НРЕГ(СтрЗаменить(Эл.Имя,"ТабЛист",""));
    		КолПрайсЛист.Вставить(КолИмя+"Строка",0);
    		КолПрайсЛист.Вставить(КолИмя+"Колонка",0);
    		КолПрайсЛист.Вставить(КолИмя+"Длинна",99);//Так как названия колонок могут повторятся, нам нужно выбрать название с минимальной длинной
    	КонецЦикла;
    	
    	Для Х=1 По КоличествоКолонок Цикл  //что бы не по всей таблице ведь мы ищем только шапку а она где-то вверху
    		Для У=1 По КоличествоКолонок Цикл
    			
    			ТекстХУ = НРЕГ(Объект.ТабДок.Область(Х,У,Х,У).Текст);
    			
    			Если СтрНайти(ТекстХУ,"бренд")<>0 тогда
    				КолПрайсЛист.брендСтрока = Х;
    				КолПрайсЛист.брендКолонка = У;
    			КонецЕсли;
    			
    			Если СтрНайти(ТекстХУ,"номенклатура")<>0 тогда //как раз таки слово "Номенклатура" у нас встречается несколько раз
    				Если СтрДлина(ТекстХУ)<=КолПрайсЛист.номенклатураДлинна Тогда
    				  	КолПрайсЛист.номенклатураСтрока = Х;
    					КолПрайсЛист.номенклатураКолонка = У;
    					КолПрайсЛист.номенклатураДлинна =  СтрДлина(ТекстХУ);
    				КонецЕсли;
    			КонецЕсли;
    			
    			Если СтрНайти(ТекстХУ,"артикул")<>0 тогда
    				КолПрайсЛист.артикулСтрока = Х;
    				КолПрайсЛист.артикулКолонка = У;
    			КонецЕсли;
    			
    			Если СтрНайти(ТекстХУ,"аналог")<>0 тогда
    				КолПрайсЛист.аналогиСтрока = Х;
    				КолПрайсЛист.аналогиКолонка = У;
    			КонецЕсли;
    			
    			Если СтрНайти(ТекстХУ,"применяемость")<>0 тогда
    				КолПрайсЛист.применяемостьСтрока = Х;
    				КолПрайсЛист.применяемостьКолонка = У;
    			КонецЕсли;
    			
    			Если СтрНайти(ТекстХУ,"цена")<>0 тогда  //Так же как и цена, так же может быть не одна
    				Если СтрДлина(ТекстХУ)<=КолПрайсЛист.ценаДлинна Тогда
    					КолПрайсЛист.ценаСтрока = Х;
    					КолПрайсЛист.ценаКолонка = У;
    					КолПрайсЛист.ценаДлинна =  СтрДлина(ТекстХУ);
    				КонецЕсли;
    			КонецЕсли;
    			
    			Если СтрНайти(ТекстХУ,"картинка")<>0 тогда
    				КолПрайсЛист.картинкаСтрока = Х;
    				КолПрайсЛист.картинкаКолонка = У;
    			КонецЕсли;
    			
    		КонецЦикла;
    	КонецЦикла;
    
  3. Таким образом мы находим всю шапку табличного документа и здесь же понимаем с какой строки начинать загрузку непосредственно данных. Конкретно в моём случае данные начинались через две строки после шапки, так как и сама шапка высотой в две ячейки.
     

    максимальныйX = 1;
    Для каждого Эл из КолПрайсЛист Цикл
    	Если СтрНайти(Эл.Ключ,"Строка")<>0 Тогда
    		Если максимальныйX<Эл.Значение Тогда
    			максимальныйX = Эл.Значение;
    		КонецЕсли;
    	КонецЕсли;
    КонецЦикла;
    Сообщить("Обход начинается с "+Строка(максимальныйX)+"+2");
    
  4. Дальше происходит непосредственно обход табличного документа по строкам с изъятием данных из колонок, которые мы нашли и добавлением в таблицу значений. Всё это происходит на клиенте.
     

    максимальныйX = максимальныйX + 2;
    	ТабЛист.Очистить();
    	ВремФ = КаталогВременныхФайлов()+"tempIMG.";
    	УровеньГруппировки = 0;
    	
    	//обход по таблице с данными до конца прайс листа. 
    	//Предполагается что у прайс листа нет никаких подвалов, 
    	//тем не менее этот момент тоже предусмотрен и если подвал всё же есть, 
    	//то в таблицу значений не будут добавлены пустые строки
    	Для Х=максимальныйX По КоличествоСтрок Цикл 
    		Если ПустаяСтрока(Объект.ТабДок.Область(Х,КолПрайсЛист.номенклатураКолонка,Х,КолПрайсЛист.номенклатураКолонка).текст) Тогда //Если колонка с номенклатурой пуста, то это скорее всего начало группы. А значит добавляем наименование группы
    			Если НЕ ПустаяСтрока(Объект.ТабДок.Область(Х,КолПрайсЛист.брендКолонка,Х,КолПрайсЛист.брендКолонка).текст) Тогда //Если нет названия группы, то и не будем ничего создавать
    				Нов = ТабЛист.Добавить();
    				Нов.группа = Объект.ТабДок.Область(Х,КолПрайсЛист.брендКолонка,Х,КолПрайсЛист.брендКолонка).текст;
    				//вот тут интересно. У Экселя есть Лист1.rows(Х).OutlineLevel 
    				//а у табличного документа такого нет, но есть "Отступ (Indent)" который может, хоть и косвенно, но указывать на иерархию, если выгрузка прайс листа идёт из 1С 
    				УровеньГруппировки = Объект.ТабДок.Область(Х,КолПрайсЛист.брендКолонка,Х,КолПрайсЛист.брендКолонка).Отступ/2;//каждый уровень иерархии прибавляет по 2 символа отступа 
    				Нов.УровеньГруппировки = УровеньГруппировки;
    			КонецЕсли;
    		Иначе
    			Нов = ТабЛист.Добавить();
    			Нов.Бренд = Объект.ТабДок.Область(Х,КолПрайсЛист.брендКолонка).текст;
    			Нов.Номенклатура = Объект.ТабДок.Область(Х,КолПрайсЛист.номенклатураКолонка).текст;
    			Нов.Артикул = Объект.ТабДок.Область(Х,КолПрайсЛист.артикулКолонка).текст;
    			Нов.Аналоги = Объект.ТабДок.Область(Х,КолПрайсЛист.аналогиКолонка).текст;
    			Нов.Применяемость = Объект.ТабДок.Область(Х,КолПрайсЛист.применяемостьКолонка).текст;
    			Попытка
    				Нов.Цена = Объект.ТабДок.Область(Х,КолПрайсЛист.ценаКолонка).text;
    			Исключение
    				Сообщить("Не число в "+Строка(Х)+" "+ОписаниеОшибки());
    			КонецПопытки;
    			Нов.УровеньГруппировки = УровеньГруппировки+1; //уровень группировки элемента на уровень больше группы
    			//Создадим временную картинку. 
    			ВремКартинка = Объект.ТабДок.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Текст);
    			ВремКартинка.Имя = "Линейка"+Формат(Х,"ЧН=; ЧГ=");
    			//расположим её в следующей колонке после самой последней, в строке, в которой сейчас находимся
    			ВремКартинка.Расположить(Объект.ТабДок.Область(Х,КоличествоКолонок+1,Х,КоличествоКолонок+1));
    			//Таким образом мы получаем точный отступ сверху для картинки, которая содержит рисунок нашей номенклатуры
    			ТочноеПоложениеКартинки = ВремКартинка.Верх;
    			//Временная картинка больше не нужна
    			Объект.ТабДок.Рисунки.Удалить(ВремКартинка); 			
    			
    			//Обходим коллекцию рисунков и сравниваем отступ сверху с тем, который мы запомнили для данной строки
    			Для каждого Изо ИЗ Объект.ТабДок.Рисунки Цикл
    				Если ИЗО.Верх = ТочноеПоложениеКартинки Тогда  
    					ФК = Изо.Картинка.Формат();
    					Нов.Расширение = Строка(ФК);
    					Изо.Картинка.Записать(ВремФ+Нов.Расширение);  //Когда нашли, сохраняем картинку в файл
    					Нов.Картинка = Новый Картинка(ВремФ+Нов.Расширение); //после этого из файла добавляем её в нашу таблицу значений
    					Прервать;//Для экономии времени, если картинка нашлась, не нужно дальше обходить оставшиеся элементы коллекции
    				КонецЕсли;
    			КонецЦикла;
    			
    		КонецЕсли;
    	КонецЦикла;
    

     

  5. После всего этого весь прайс лист у нас в таблице значений на клиенте. И дальше мы можем обойти таблицу значений и создать как группы справочника, так и элементы с нужными значениями. Заострять на этом внимания я не буду. Тут многое зависит от конфигурации. Лишь покажу, как извлечь картинку из таблицы значений и поместить её в справочник номенклатура. Хоть данный код и справедлив только для УТ 11.4.6.207 но я думаю многим он будет полезен. (Потому что раньше это было просто. Добавляешь объект в ХранилищеДополнительнойИнформации и всё. А вот тут оказалось всё по другому)


     

    Если Не ПустаяСтрока(РасширениеКартинки) Тогда //Это колонка Стр.расширение,, если она не пустая, значит есть картинка в колонке Стр.Картинка
    				Найд = Справочники.НоменклатураПрисоединенныеФайлы.НайтиПоРеквизиту("ВладелецФайла",НовНом.Ссылка);
    				Если ЗначениеЗаполнено(Найд) Тогда  //Если вообще какой-то файл или картинка был загружен ранее, то он удаляется. 
    					Найд.ПолучитьОбъект().Удалить();
    				КонецЕсли;
    				//Помещаем двоичные данные картинки во временное хранилище
    				АдресФайлаВХранилище = ПоместитьВоВременноеХранилище(КартинкаСтроки.ПолучитьДвоичныеДанные(), УникальныйИдентификатор);
    				//Создаём структуру
    				ПараметрыФайлаКартинки = Новый Структура();
    				ПараметрыФайлаКартинки.Вставить("Автор", Пользователи.АвторизованныйПользователь());
    				ПараметрыФайлаКартинки.Вставить("ВладелецФайлов", НовНом.Ссылка);
    				ПараметрыФайлаКартинки.Вставить("ИмяБезРасширения", НовНом.Наименование);
    				ПараметрыФайлаКартинки.Вставить("РасширениеБезТочки", "PNG");
    				ПараметрыФайлаКартинки.Вставить("ВремяИзмененияУниверсальное", ТекущаяДата());
    				//И используем один из механизмов, доступных в УТ 11.4.6.207 
    				ПрисоединенныйФайл = РаботаСФайлами.ДобавитьФайл(
    					ПараметрыФайлаКартинки,
    					АдресФайлаВХранилище,
    					"",
    					"НоменклатураПрисоединенныеФайлы");
    				//Который возвращает нам ссылку на Справочники.НоменклатураПрисоединенныеФайлы
    				НовНом.ФайлКартинки = ПрисоединенныйФайл;
    				//Это значение присваивается реквизиту справочника номенклатура с именем "ФайлКартинки"
    			КонецЕсли;
    

     

  6. По большей части всё. Дальше просто создаёте номенклатуру, затем номенклатуру поставщика, создаёте между ними связь. А затем регистрируете цены поставщика.

Надеюсь, мой пример сэкономит кому-то время и нервы. Я собирал всю информацию около недели, так как нет всего этого в одном месте. Где-то одно, где-то другое. Много всего перепробовал, много не получилось, много ошибок допустил и исправил.R03;R03;R03;R03;R03;R03;R03;

Скачать файлы

Наименование Файл Версия Размер
ЗагрузитьПрайсЛистЭксельНеИспользуяЭксель

.zip 75,85Kb
22
.zip 75,85Kb 22 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. 2casp 25 06.12.19 09:29 Сейчас в теме
Не совсем универсальный механизм заполнения ТабЛист, по которому в дальнейшем создается номенклатура. Сильно привязано к текущему прайс листу.
Оставьте свое сообщение

См. также

5 способов загрузки из Excel в 1С

Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Конфигурация, состоящая из внешнего источника данных и одной обработки. Обработка содержит 5 примеров, как можно загрузить данные в 1С из Excel.

1 стартмани

29.03.2021    8875    16    elephant_x    4    

[Расширение] Временное отключение онлайн-эквайринга в РМК (УТ 11.4, Розница 2.3)

Розничная торговля Рабочее место Эквайринг v8 v8::ОУ УТ11 Розничная и сетевая торговля (FMCG) УУ Абонемент ($m)

Расширение предназначено для исправления исключительных ситуаций, когда оплата по эквайринговому терминалу с подключением оборудования прошла успешно, но чек на ККТ не был фискализирован. Расширение позволит временно отключить онлайн-эквайринг непосредственно из формы РМК.

1 стартмани

14.12.2020    7101    32    RocKeR_13    12    

Генератор маршрута по "документам отгрузки" в Google.Maps

Оптовая торговля Розничная торговля WEB v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Данная обработка будет полезна для построения маршрута по документам реализаций за выбранный период.

7 стартмани

08.11.2020    7212    14    quazare    20    

Загрузка прайс-листов в БП 3.0, УНФ 1.6, Розница 2.3, УТ 11.4, КА 2 и ERP Промо

Ценообразование, прайсы Загрузка и выгрузка в Excel v8 v8::ОУ Розница УНФ ERP2 БП3.0 УТ11 КА2 УУ Абонемент ($m)

Внешняя обработка для загрузки прайс-листов Excel (и не только) в конфигурации: Бухгалтерия предприятия, редакция 3.0; Управление нашей фирмой, редакция 1.6; Розница, редакция 2.3; Управление торговлей, редакция 11; Комплексная автоматизация 2; ERP Управление предприятием 2 без использования COM-объектов (установленного Excel), для толстого, тонкого и веб-клиента.

5 стартмани

16.04.2020    11217    146    LamerSoft    15    

Заготовка обработки (внешняя печатная форма) заполнения Excel документа из 1С

Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Умеет заполнять как отдельные ячейки, так и таблицы в рамках листов Excel. Удобно при разработке различных “дашбордов” (с графиками, диаграммами), отчетов финансистов (где много формул), заполнения форм документов организации. Эксель шаблон может сделать пользователь (с нужным ему оформлением, формулами и т.д.) и впоследствии самостоятельно этот шаблон менять. Программисту нужно только настроить выдачу данных для заполнения шаблона. Может подключаться как внешняя печатная форма (для обычных и управляемых форм).

2 стартмани

29.07.2020    4253    19    wonderboy    0    

Загрузка из XML файла ЭДО в документ поступления для конфигураций 1С: Розница 2.2/2.3, Управление торговлей 10.3/11.4

Розничная торговля Обработка документов Документооборот и делопроизводство Обмен через XML v8 УТ10 Розница Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Внешние обработки загрузки данных из XML файлов формата ON_NSCHFDOPPRMARK ЭДО в документы поступления 1С Розница версия 2.2.10.19 и выше, Управление торговлей 10.3.52.2 и выше, Управление торговлей 11.4.5.63 и выше

1 стартмани

04.06.2020    24085    275    independ    130    

Печать, создание XML и сохранение в базу 1С кодов маркировки

Пакетная печать Розничная торговля v8 1cv8.cf Абонемент ($m)

Внешняя обработка для печати кодов марок, полученных из системы "Честный знак".

1 стартмани

14.01.2020    34749    410    user635667    322    

Обмен данными между УТ 10.3 и Розницей 2.2 (правила обмена данными между "Управлением торговлей" ред. 10.3. и "Розницей" ред. 2.2) Промо

Обмен через XML Перенос данных из 1C8 в 1C8 Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 УТ10 Розница УУ Абонемент ($m)

Данные правила предназначены для обмена в формате XML данных из программы «Управление торговлей» ред. 10.3. и "Розница" ред. 2.2 по основным группам документов и основных справочников. Загрузка данных осуществляется через встроенную обработку «Универсальный обмен данными XML». Основная цель обработки – корректировка типовых правил на выявленные ошибки и расширение выгрузки для корректной выгрузки данных по ЕГАИС и продажам в целом. Протестировано до УТ 10.3.47.х и Розница 2.2.11.х

3 стартмани

16.09.2016    53544    4    SEOAngels    65    

Маркировка. Формирование и печать марок с CSV-файла "Честный Знак" и подготовка файла ввода в оборот

Розничная торговля v8 Розница УНФ УТ11 Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Внешняя обработка для формирования и печати марок с кодом DataMatrix, на основании полученных CSV-файлов с кодами из системы "Честный знак". Формирование файла о вводе марок в оборот для загрузке на сайт системы "Честный знак"

3 стартмани

09.01.2020    42615    286    Turbokey    169    

Рекомендательный сервис на основе коллаборативной фильтрации на 1С. Расширение формы подбора для УТ 11.4

Оптовая торговля Розничная торговля Практика программирования Математика и алгоритмы v8 ERP2 УТ11 КА2 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

В данной разработке реализован механизм рекомендаций товаров по принципу схожести товаров в корзине на основе алгоритма Item-to-Item от Amazon. Разобран алгоритм с демо базой и сделано расширение для УТ11.4 которое добавляет в форму подбора таблицу рекомендаций. Протестировано на 8.3.13.1865 на Управление торговлей, редакция 11 (11.4.8.63)

3 стартмани

25.09.2019    14995    14    informa1555    24    

Аналоги номенклатуры для УТ 11.4, КА 2.4, ERP 2.4, Розница 2.2, Розница 8. Магазин автозапчастей. Расширение

Рабочее место Оптовая торговля Розничная торговля Управление торговлей Оптовая торговля Розничная торговля v8 Розница ERP2 УТ11 КА2 Автомобили, автосервисы Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Расширение для работы с аналогами номенклатуры. Отлично подходит для работы с кроссами запчастей и товаров с аналогичными свойствами. Поддерживаемые конфигурации: УТ 11.4, КА 2.4, ERP 2.4, Розница 2.2, Розница 8. Магазин автозапчастей. Лёгкое подключение, без изменения конфигурации.

1 стартмани

30.08.2019    27726    54    AleSSandre    28    

Загрузка весового товара в весы Масса-К ВПМ-Ф (1С Предприятие, УТ 11.2-11.4 управляемые формы) Промо

Весы Розничная торговля Розничная торговля v8 v8::ОУ v8::УФ УТ10 Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Данная обработка загружает весовой товар из базы в весы. Данная обработка тестировалась только на версии УТ 11.2-11.4 (1С Предприятие 8.3) и весах ВПМ-Ф.

2 стартмани

21.07.2016    22488    55    user594264_e.sitnik    5    

Выгрузка номенклатуры в социальную сеть Вконтакте

WEB Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 1cv8.cf Абонемент ($m)

Обработка для быстрой и легкой выгрузки товаров Вконтакт. Так просто еще не было)))

2 стартмани

14.08.2019    20586    59    kaliuzhnyi    48    

Загрузка из Excel (без использования com-объектов, без установленного Excel)

Обработка документов Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Обработка не использует com-объект для чтения из файла, не нужен установленный Excel.

1 стартмани

22.03.2019    24019    236    Смешной 1С    28    

Автоматическая рассылка прайс-листов Промо

Ценообразование, прайсы Email Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 УТ10 Абонемент ($m)

Устали от утомительной рассылки прайс-листов своим клиентам? Тогда эта обработка как раз для вас, она сделает полностью все сама! Сформирует прайс с нужными настройками и отправит его по электронной почте, как, куда и когда надо.

1 стартмани

24.03.2014    45687    22    skyadmin    20    

Обработки для 1С: Розница по работе с ЕГАИС

Розничная торговля Обработка документов Обработка справочников Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Россия БУ Абонемент ($m)

Несколько простых и нужных обработок для упрощения работы с ЕГАИС в 1С Розница версий 2.2.10.ХХХ и выше.

1 стартмани

25.02.2019    23819    54    independ    15    

Выполнение проверки поступившей алкопродукции в ТТН ЕГАИС одним нажатием. 1С: Розница

Розничная торговля Обработка документов Розничная торговля v8 v8::УФ Розница Розничная и сетевая торговля (FMCG) Россия БУ Абонемент ($m)

Расширение и код для 1С: Розница 2.2.9/2.2.10/2.2.11 для быстрой проверки поступившего алкоголя ЕГАИС.

1 стартмани

05.02.2019    16227    12    independ    8    

1С: Розница/УТ 10.3. ЕГАИС, загрузка акцизных марок в справочник Штрихкоды и Упаковки, регистр Акцизные марки из XML-сообщений входящих ТТН ЕГАИС + Печать акцизных марок

Розничная торговля Обработка справочников Обмен через XML Ценники Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Пакетная загрузка/обновление списка акцизных марок ЕГАИС из входящих ТТН ЕГАИС. Для 1С Розница 2.2.9.ХХХ/2.2.10.ХХХ//2.2.11.ХХХ/2.2.12.ХХХ/Управление торговлей 10.3.49.ХХХХ и выше с возможностью печати

1 стартмани

31.01.2019    31262    219    independ    131    

Прыг-Скок...или из MS EXCEL в 1С (8.2) (открытый код) Промо

Обработка документов Обработка справочников Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Универсальная загрузка данных из Microsoft Office Excel. Автоматическая загрузка из любых по форме документов с очень удобным редактором. Почти готовый шаблон для любой конфигурации. Не требует регистрации-бесплатно.

1 стартмани

16.09.2015    70894    363    Tatitutu    50    

Конструктор мобильного клиента Simple WMS Client: способ создать полноценный ТСД без мобильной разработки. Теперь новая версия - Simple UI (обновлено 14.11.2019)

Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Мобильная разработка Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ v8 v8::Mobile БУ УУ Абонемент ($m)

Simple WMS Client – это визуальный конструктор мобильного клиента для терминала сбора данных(ТСД) или обычного телефона на Android. Приложение работает в онлайн режиме через интернет или WI-FI, постоянно общаясь с базой посредством http-запросов (вариант для 1С-клиента общается с 1С напрямую как обычный клиент). Можно создавать любые конфигурации мобильного клиента с помощью конструктора и обработчиков на языке 1С (НЕ мобильная платформа). Вся логика приложения и интеграции содержится в обработчиках на стороне 1С. Это очень простой способ создать и развернуть клиентскую часть для WMS системы или для любой другой конфигурации 1С (УТ, УПП, ERP, самописной) с минимумом программирования. Например, можно добавить в учетную систему адресное хранение, учет оборудования и любые другие задачи. Приложение умеет работать не только со штрих-кодами, но и с распознаванием голоса от Google. Это бесплатная и открытая система, не требующая обучения, с возможностью быстро получить результат.

5 стартмани

09.01.2019    57610    262    informa1555    234    

Загрузка чека онлайн-касс (загрузка товаров из чека)

Внешние источники данных WEB Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 1cv8.cf Абонемент ($m)

Обработка-пример, позволяет любому и из любой конфигурации загрузить информацию о товарах из чека(и не только) из почтового сообщения, отправленного из приложения ФНС проверка чеков.

2 стартмани

08.10.2018    26946    40    echo77    73    

Выгрузка и загрузка данных из файла Excel с поиском по любым полям (есть поиск по ссылке, всего три итерации поиска. Управляемые формы или "Такси") Промо

Загрузка и выгрузка в Excel Обработка документов v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка позволяет загружать данные с поиском по ссылке как для загружаемого объекта, так и его свойств. Загружает справочники, документы, планы видов характеристик. Будет полезна как замена использования конвертации данных для задач переноса, а также как классическая загрузка из табличного документа (Excel). Поиск объекта при загрузке выполняется до трех раз с разными полями поиска (поля поиска настраиваются). Также реализована выгрузка в Excel по ссылкам. У обработки удобный интерфейс, в котором разберется даже начинающий пользователь. Загрузка накладных из файлов xls реализована с интеллектуальным поиском колонок с данными. В интеллектуальном поиске поддерживаются все основные типовые печатные формы.

5 стартмани

16.10.2015    65918    517    primat    35    

Кое-что простое о сложных штрих-кодах

Сканер штрих-кода Бухгалтерский учет Розничная торговля Розничная торговля v8 1cv8.cf УУ Абонемент ($m)

На просторах и-нета часто встречаю публикации, в которых авторы с энтузиазмом рассказывают о том, как в штрих-код внести информацию о нескольких сущностях: например, как сделать, чтобы при сканировании одного штрих-кода на ярлыке товара, 1С определяла что это за товар, его качество и приходную накладную по которой этот товар поступил. Увы, но делается это "в лоб". Я предлагаю более разумный способ. Он очевиден - так что не претендую на лавры первооткрывателя.

1 стартмани

28.09.2018    19962    9    torch    15    

Расширение "Интерфейс Плюс"

Розничная торговля Рабочее место Розничная торговля v8 v8::ОУ Розница УТ11 Россия УУ Абонемент ($m)

Расширение для 1С:Розница 2.2/2.3 и 1С:Управление Торговлей 11, которое позволит повысить удобство работы!

1 стартмани

22.09.2018    33624    170    RocKeR_13    133    

Помощник корректировки остатков ЕГАИС в небольшом магазине. Розница 2.2

Розничная торговля Обработка документов Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Абонемент ($m)

Данная обработка упрощает корректировку остатков алкогольной продукции небольшого магазина, где предполагается передача всей продукции в торговый зал сразу после приемки.

5 стартмани

08.09.2018    40982    84    asdfgcom    47    

ЕГАИС 3 Контролёр для 1С:Розница

Терминал сбора данных Розничная торговля Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Оградите себя от рисков отзыва лицензии на торговлю алкоголем, штрафов и блокировок в ЕГАИС. Проверяйте поступающую алкогольную продукцию помарочно на соответствие ТТН ЕГАИС v3 перед тем, как подтвердить получение и принять её на баланс в ЕГАИС. С 01.07.2018 начинается переход ЕГАИС на помарочный учет алкогольной продукции на всех стадиях товародвижения, начиная от производства или ввоза на территорию России, до реализации в розничной торговле, т.н. "ЕГАИС 3.0". В типовой Рознице уже появилась обработка для контроля поступивших акцизных марок на ПК. Предлагаю ознакомиться с мобильным решением. Контроль производится в Android приложении на ТСД или на обычном смартфоне.

1 стартмани

13.06.2018    24859    17    kuld    30    

Пробитие чеков через ККМ в офисе (для курьеров)

ККМ Фискальный регистратор Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 v8::ОУ Розница УТ11 Россия БУ Абонемент ($m)

Предлагается интеграция 1С с ККТ СтарРус. Поддерживается одновременная работа с разных рабочих мест. ККТ СтарРус работает как сервер, и принимает команды через API по http-протоколу, что позволяет пробивать чеки через центральную базу 1С для интернет-магазина и для курьеров.

1 стартмани

07.06.2018    37669    28    Kutuzov    12    

Корректировка остатков ЕГАИС для 1С:Розница/УТ 10.3 - альтернативный вариант

Обработка документов Розничная торговля Учет ТМЦ Розничная торговля Учет ТМЦ v8 Розница Розничная и сетевая торговля (FMCG) БУ Абонемент ($m)

Обработка корректировки остатков ЕГАИС для 1С Розница версии 2.2.7/2.2.8/2.2.9/2.2.10/2.2.11/УТ 10.3.47.ХХХ-48.XXX-49.XXX-50.XXX раздельно по маркируемому/немаркируемому алкоголю + создание документов постановки/списания по пересортице.

1 стартмани

02.06.2018    42249    431    independ    289    

Вы больше не будете разбирать Excel как раньше

Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Кому не приходилось разбирать файлы в формате Excel? Все матерятся, плюются, требуют обещаний что "это в последний раз", но таки пишут загрузку из Excel. Потом форматы меняются, строки съезжают, колонки переставляют... Вам это не надоело?

1 стартмани

07.05.2018    33411    64    m-rv    34    

СМС-верификация при регистрации клиента, списании бонусных баллов, СМС о начислении баллов

SMS рассылки Управление взаимоотношениями с клиентами (СRM) Розничная торговля Розничная торговля v8 v8::ОУ Розница УТ11 Розничная и сетевая торговля (FMCG) УУ Абонемент ($m)

Предлагаемое расширение для конфигурации 1С Управление Торговлей 11, и Розница 2 позволяет подтверждать операции с бонусными баллами с помощью СМС, отправляемых на телефон клиента. Также предлагается внешняя обработка для отправки информации о начислении бонусных баллов по СМС.

2 стартмани

16.03.2018    33728    201    Kutuzov    112    

Корректировка остатков ЕГАИС, возврат из регистра 2, загрузка ТТН из файлов, другое для УТ10.3

Розничная торговля Обработка документов Розничная торговля v8 v8::ОУ УТ10 Россия БУ Абонемент ($m)

Набор обработок для автоматизации работы с ЕГАИС: Обработка корректировки остатков ЕГАИС для УТ 10.3, аналогичная имеющимся в УТ 11, Рознице 2.2. Автоматически формирует документы "Передача в торговый зал", "Акт постановки на баланс в торговом зале", "Акт списания в торговом зале". Обработка возврата из регистра 2 с подбором справок Б. Обработка формирования ТТН из файлов xml.

1 стартмани

24.01.2018    42894    18    biz-intel    6    

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника. ЗУП 3.1

Обработка документов Загрузка и выгрузка в Excel Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Абонемент ($m)

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника по данным экономического отдела. ЗУП 3.1.

3 стартмани

20.12.2017    57916    34    mvv1975    7    

Приемы эффективной загрузки данных из Excel в 1С

Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Показаны приемы эффективной работы с Excel для загрузки данных в 1С.

1 стартмани

13.12.2017    71038    122    alexey.kutya    89    

Чтение отчета ОФД (ПлатформаОФД/СБИС Тензор) + получение состава кассового чека

Внешние источники данных Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 v8::ОУ УТ10 Розничная и сетевая торговля (FMCG) Россия БУ Абонемент ($m)

Чтение отчетов оператора ПлатформаОФД/СБИС Тензор с возможностью получения детализации по кассовым чекам для Управление торговлей 10.3.Х.ХХХ.

1 стартмани

12.12.2017    19172    20    independ    9    

Android беспроводной Bluetooth сканер 1D/2D штрихкода и терминал сбора данных для 1С

Сканер штрих-кода Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 1cv8.cf УУ Абонемент ($m)

Бесплатное приложение, превращающее Android-смартфон в беспроводной 1D/2D Bluetooth сканер и терминал сбора данных для 1С и прочих POS систем. Не требует драйверов и доработки конфигураций.

1 стартмани

12.09.2017    47609    27    kuld    45    

Работа с интегрированным терминалом Сбербанка через утилиту upwin.exe

Обмен с банком Банковские операции Розничная торговля Банковские операции Розничная торговля v8 v8::УФ 1cv8.cf Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Утилита UPWIN.exe от Сбербанка, коды команд для управления интегрированным банковским терминалом (управляемые формы, обычные под 8.1). Обработка на управляемых формах запускается под любой конфигурацией, обработка на обычных формах также запускается под любой конфигурацией на платформе от 8.1 и выше

1 стартмани

05.09.2017    29858    103    independ    20    

Терминал сбора данных штрихкодов на планшете Windows

Розничная торговля Терминал сбора данных Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Терминал сбора данных штрихкодов с использованием планшета WIndows и беспроводного сканера - простое решение

1 стартмани

18.08.2017    23089    24    independ    16    

Редактирование цен и остатков в карточке номенклатуры для 1С: Розница

Ценообразование, прайсы Обработка справочников Розничная торговля Ценообразование, анализ цен Розничная торговля Ценообразование, анализ цен v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Возможность быстрого изменения цен и остатков номенклатуры непосредственно в форме справочника. Работает на 1С: Рознице, начиная с 2.2.2.ххх

1 стартмани

18.08.2017    21028    29    independ    7    

Загрузка дополнительных реквизитов и сведений справочника Номенклатура из Excel и таблиц УТ 11, ERP 2

Обработка справочников Загрузка и выгрузка в Excel Учет ТМЦ Учет ТМЦ v8 v8::ОУ ERP2 УТ11 Россия УУ Абонемент ($m)

Внешняя обработка "Загрузка дополнительных реквизитов и сведений справочника Номенклатура"

1 стартмани

07.08.2017    49406    315    Windyhead    45    

Расширенный подбор товаров [Расширение]

Комиссионная торговля Оптовая торговля Розничная торговля Учет ТМЦ Обработка документов Обработка справочников Комиссионная торговля Оптовая торговля Розничная торговля Учет ТМЦ v8 ERP2 УТ11 КА2 Оптовая торговля, дистрибуция, логистика БУ УУ Абонемент ($m)

Расширенные возможности подбора товаров. Отображаются цены и свободные остатки, доступен переход к ожидаемым поступлениям и информация по складам.

5 стартмани

31.07.2017    35659    150    mrXoxot    98