Три урока 1С81 для переходящих с 1с77

Публикация № 116371

Разработка - Практика программирования

Три урока, которых я решил сам при изучении восьмерки, когда переходил с семерки.
Уроки касаются работы с коллекциями, регистрами и формами восьмерки.

// //

Учебные планы.

Я программист, три года с ноября 1999 года программировавший на 1С:Предприятие 7.7. На дворе зима 2003 года, 1С выпускает новую платформу, очень хочется ее изучить.

Договариваюсь со знакомыми и вот в моем распоряжении 1С:Предприятие 8.0 и около трех дней рабочего времени, чтобы ее изучить, пока ключ не отдали другому программисту. Кряк периодически выбивает систему, работать с ним неудобно. Буду изучать на нормальном "переходящем" ключе.

Итак, ставлю себе задачу: написать почти простейшую конфигурацию складского учета для ячеистого склада:

  1. Имееются склады, номенклатура
  2. Учет ведется только по количеству, без единиц измерения
  3. Документы Приход, Расход, Перемещение
  4. При проведении должен быть контроль: нельзя превышать остаток при расходе и нельзя ставить в занятую ячейку.
  5. Должен быть отчет по движению товаров по складам и ячейкам.
  6. Настроить удобный интерфейс пользователя.

Склад может состоять из ячеек, товар может быть размещен на паллетах. У склада есть параметры флИспользоватьЯчейки и флИспользоватьПаллеты, которые определяют, используются ли на складе ячейки и паллеты.

Если на складе не используются ни ячейки, ни паллеты, то это самый обычный склад.

Наспех прочитан С.А.Митичкин "Разработка в системе 1С:Предприятие 8.0". Освоена буквально за половину рабочего дня и его остаток в двухчасовой электричке. Читается запоем. Наступает время попробовать теорию на практике.

Вот, как я учился 1с 8-ке. Получилась некоторая последовательность шагов. Шаги были не только прямо к конфигурации, но и влево-вправо.

 

Урок 1. Проведение документов в 1С:8.0

// //

Создаю из шаблона демо-конфигурацию "Управление торговлей" и пустую базу. В демо-конфигурации уже имеются данные, пустая база девственно чиста.

Создаю справочник Номенклатура, Ячейки и подчиненный номенклатуре справочник ЕдиницыИзмерения.

Создаю документ WHSПриход.
Оказывается у документа есть параметр Движения, который предоставляет доступ к фиксированному набору записей по каждому регистру.

Оперативное проведение

Для удобства пользователей проведение бывает двух видов - оперативное и неоперативное.
При оперативном проведении принимается решение - дать совершить операцию или нет, т.е. нужно проверить имеется остаток или нет. При неоперативном проведении факт операции уже зафиксирован и нужно только повторить движения.

При перепроведении документов используется неоперативное проведение - экономится время на контроль остатков, к тому же перепроведение не останавливается, если остатков не хватает.

В принципе, можно игнорировать эти два способа и проводить однообразно, но это действительно грамотный ход. К тому же, на эти два способа можно разграничить доступ.

При проведении документа до точки актуальности итогов (ТА) спрашивается как его проводить - оперативно или нет? Если оперативно по умолчанию время ставится после точки актуальности.

Проведение документов

Простой пример проведения (записывается в модуле документа):

Процедура ОбработкаПроведения(Отказ, Режим)
	Набор=Движения["WHSОстатки"];
  	Для каждого СтрокаТЧ из Товары Цикл
  		Движ=Набор.ДобавитьРасход();
		Движ.Период=Дата;
		Движ.Склад=Склад;
		Движ.Ячейка=СтрокаТЧ.Ячейка;
		Движ.Паллет=СтрокаТЧ.Паллет;
		Движ.Номенклатура=СтрокаТЧ.Номенклатура;
  		Движ.Количество=СтрокаТЧ.Количество*СтрокаТЧ.ЕдиницаИзмерения.Коэффициент;
  КонецЦикла
 КонецПроцедуры // ОбработкаПроведения
 

Сначала через обращение к доступной в модуле документа переменной Движения определяется набор движений по регистру WHSОстатки.
Затем в переменной СтрокаТЧ перебираются все строки табличной части Товары.
Затем в набор добавляется очередное движение прихода Движ.
Устанавливаются реквизиты движения.
Набор в конце не записывается, 1С запишет его сама.
Для каждого движения нужно указать период движения (можно указывать разные даты).
По умолчанию регистратором движения указывается текущий документ.

Как видно, все реквизиты документа доступны по именам, но можно обращаться к ним и так, например: ЭтотОбъект.Дата.

Проверка наличия остатков

Сразу решил отказаться от использование функции Остатки, т.к. при изменении измерений регистров придется переписывать вызов этой функции, т.к. в ней количество и порядок параметров определяется количеством и порядком измерений регистра.

Итак, будем использовать запрос.

Если Режим=РежимПроведенияДокумента.Оперативный Тогда
		Для каждого СтрокаТЧ из Товары Цикл
			ТекКоличество=СтрокаТЧ.Количество*СтрокаТЧ.ЕдиницаИзмерения.Коэффициент;
			ТекТовар=СтрокаТЧ.Номенклатура;
			ТекДата=Дата;
			ТекстЗапроса="
				|ВЫБРАТЬ
				|	WHSОстатки.Номенклатура КАК Номенклатура,
				|	WHSОстатки.КоличествоОстаток КАК Остаток
				|ИЗ
				|  	РегистрНакопления.WHSОстатки.Остатки(&Дата) КАК WHSОстатки 
				|ГДЕ
				|  	(Номенклатура=&Товар)
				|";
			
			КонецЦикла;
			флДостаточноОстатка=Истина;
			
			Запрос=Новый Запрос(ТекстЗапроса);
			Запрос.УстановитьПараметр("Дата",Дата);
			Запрос.УстановитьПараметр("Товар",ТекТовар);
			РезультатЗапроса=Запрос.Выполнить();
			Выборка=РезультатЗапроса.Выбрать();
			Пока Выборка.Следующий() Цикл
				Если Выборка.Остаток < ТекКоличество Тогда
					Сообщить("Недостаточно остатка товара "+Выборка.Номенклатура+" нужно "+ТекКоличество+", а имется только "+Выборка.Остаток);
					флДостаточноОстатка=Ложь;
				КонецЕсли;
			КонецЦикла;
			Если Не флДостаточноОстатка Тогда
				Отказ=Истина;
				Возврат;
			КонецЕсли;
	КонецЕсли;
 

Запрос написан на SQL-подобном языке запросов 1С, SQL - это приятно.

Итак, мы строим запрос к таблице остатков регистров накопления WHSОстатки на дату (позицию) документа.
Остатки получаем только в разрезе номенклатуры. Строим запрос для каждой номенклатуры в документе и сравниваем количества.

Отказ в проведении осуществляется через выставление параметра Отказ, переданного в Обработку проведения в Истину.

Контроль остатков осуществляется только при оперативном проведении.

Конечно, это не самый производительный код, было бы удобнее прямо в запросе сравнить количество товара из табличной части и остаток товара из регистра.

Ковыряния в интерфейсе

Мне нужно было, чтобы ячейка в табличной части выбиралась только из списка ячеек, подчиненных данному складу (реквизиту документа). Оказывается, у реквизитов формы есть параметр "Использовать владельца"

 

Урок 2. Игра "Угадай животное" для 1С:8.0

Компьютер пробует угадать животное, загаданное человеком, задавая вопросы. Если компьютер не угадал, он спрашивает человека, кого он загадал и чем загаданное отличается от того животного, что назвал компьютер.

 

Можно обойтись практически без элементов интерфейса, используя только диалоговые окна.

Результаты игры сохраняются в файл "C:\zoo.txt"

В обработке мы можем поучиться работать с объектом "Структура", как создавать такие объекты, как оперировать с значениями структуры.

Также попутно я выяснил, что обработчики событий формы определяются не по имени процедуры, а назначаются в форме.

В игре используются два вида структур: одна (Да, Нет, Содержание) а другая (Животное). Значением ключа может быть опять же структура. Я например, обнаружил, что если вызываешь Структура.Животное, выдается ошибка, если такого ключа нет. Поэтому для проверки нужно использовать Если Структура.Свойство("Животное") Тогда.

Обработку 1s8zoo.zip прилагаю к статье.

Вот текст обработки:

Перем Дерево;


Процедура Сдаться(Узел)
	Животное="";
	Отличие="";
    //Определяем у пользователя название нового животного
	Если ВвестиЗначение(Животное, "Сдаюсь, что за животное вы задумали?","Строка") Тогда
        //Определяем у пользователя отличие нового животного
		Если Узел <> Неопределено Тогда
			Если НЕ ВвестиЗначение(Отличие, "Отличается от "+Узел.Животное+",  оно (какое?):","Строка") Тогда
				Возврат;
			КонецЕсли;
		КонецЕсли;

		УзелЖивотное=Новый Структура("Животное", Животное);
		
		Если Узел<>Неопределено Тогда
			УзелСтароеЖивотное=Новый Структура("Животное", Узел.Животное);
			Узел.Вставить("Отличие",Отличие);
			Узел.Вставить("Да",УзелЖивотное);
			Узел.Вставить("Нет",УзелСтароеЖивотное);
			Узел.Удалить("Животное");
			Предупреждение("Заведено новое животное "+Животное+". Оно "+Отличие);
		Иначе
			Предупреждение("Заведено новое животное "+Животное+".");
			Дерево=УзелЖивотное;
		КонецЕсли;

	КонецЕсли;
КонецПроцедуры

Процедура Выигрыш()
	Предупреждение("То-то же, вам не стоит тягаться с искусственным интеллектом");
КонецПроцедуры


Процедура Угадай(Узел)
	Если Узел=Неопределено Тогда
		Сдаться(Узел);
		Возврат;
	КонецЕсли;

	Если Узел.Свойство("Животное") Тогда
		//Если подошли к животному
		Если 
			Вопрос("Попробую угадать. Гм... Это "+Узел.Животное+"?", РежимДиалогаВопрос.ДаНет)=КодВозвратаДиалога.Да 
		Тогда
			Выигрыш();
		Иначе
			Сдаться(Узел);
		КонецЕсли;
	Иначе
		//Если находимся в вопросе
		Если 
			Вопрос("Оно "+Узел.Отличие+"?", РежимДиалогаВопрос.ДаНет)=КодВозвратаДиалога.Да 
		Тогда
			Угадай(Узел.Да);
		Иначе
			Угадай(Узел.Нет);
		КонецЕсли;
	КонецЕсли;
КонецПроцедуры



// ОБРАБОТЧИКИ СОБЫТИЙ ФОРМЫ

Процедура ПриОткрытии()
	Сообщить("Открылись");
	Попытка
		Дерево=ЗначениеИзФайла("C:\zoo.txt");
	Исключение 
	КонецПопытки;
КонецПроцедуры // ПриОткрытии()

Процедура ПриЗакрытии()
	Сообщить("Закрылись");
	Если Вопрос("Сохранить игу в файл C:\zoo.txt?", РежимДиалогаВопрос.ДаНет)=КодВозвратаДиалога.Да  Тогда
		Попытка
			Дерево=ЗначениеВФайл("C:\zoo.txt", Дерево);
		Исключение 
			Предупреждение("Сохранить не удалось");
		КонецПопытки;
	КонецЕсли;
КонецПроцедуры // ПриОткрытии()


//

Процедура Игра()
	Предупреждение("Загадайте животное и нажмите < ОК >");
	Угадай(Дерево);
КонецПроцедуры

Процедура КнопкаВыполнитьНажатие(Элемент)
	// Вставить содержимое обработчика.
	Игра();
КонецПроцедуры


//Для восстановления обработки из ее текста создайте обработку, назовите ее "животные"
//Создайте форму обработки
//На закладке "Диалог" на пустом месте щелкните "Свойства"
//В событиях ПриОткрытии и ПриЗакрытии пропишите вызов процедур ПриОткрытии и ПриЗакрытии
//В корень диска C: поместите файл zoo.txt
//В обработчике главной кнопки КнопкаВыполнитьНажатие пропишите вызов Игра()
//Запустите обработку.
//Все, можно играть!
 


 Урок 3. Несколько иерархий справочника

//

Когда готовилась восьмерка еще только готовилась к выходу, один мудрый человек (не я) мечтал о том, что можно будет заводить несколько иерархий для справочников и система будет разрешать пользователю выбирать, какой иерархией пользоваться при навигации по списку.

Например, справочник товаров может быть сгруппирован по виду товаров (как это обычно и делается) - Промтовары, Бакалея, Алкоголь и т.п., но может быть сгруппирован и по производителям товаров, т.е. Наши товары, Импортные товары, Российские, Китайские и т.п.

Ожидания не оправдались, однако восьмерка легко позволяет сделать такую иерархию самостоятельно. Единственное неудобство - это не делается автоматически, системой.

Моделирование нескольких иерархий

Имеются иерархические (с группами) справочники товаров Номенклатура и производителей Производители.

Для иерархии по производителям в справочнике Номенклатура заведем реквизит Производитель типа СправочникСсылка.Производители.

Заведем новую форму списка для Номенклатуры. На ней разместим поле ДереваЗначений "МастерДерево" и поле ТаблицыЗначений "ПодчТаблица":

В МастерДерево будет отображаться группы текущей иерархии. А в ПодчТаблица будут выводиться только те товары, которые попадают в группу иерархии. В надписи НадпГруппа будет отображаться текущая выбранная группа МастерДерево, а в надписи НадписьОтбор - список элементов текущей иерархии, входящих в эту группу.

Для учебных целей мы рассмотрим только отбор по иерархии Производители. Можно конечно в дереве делать иерархию на выбор - по Производителю, по группам номенклатуры, по поставщику и т.п. Было бы желание.

Вот как выглядит форма, когда мы просматриваем товары отечественных производителей:

А вот так, когда просматриваем импортных производителей:

 

А вот просмотр только по одному производителю:

Когда пользователь выбирает группу из дерева (щелкает дважды мышью или нажимает Enter, происходит событие Выбор объекта формы МастерДерево). В обработчике этого события содержится код, который отображает ПодчТаблица согласно выбранной группе:

Процедура СправочникДеревоВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)

	//Находим отбор по производителю
	//Внимание! Его может и не быть...
	ТекОтбор=ЭлементыФормы.ПодчТаблица.Значение.Отбор["Производитель"];

	//Если группа в дереве не выбрана (в начале)
	Если  ЭлементыФормы.МастерДерево.ТекущиеДанные=Неопределено Тогда
		МастерГруппа=Неопределено;
		ТекОтбор.Использование=Ложь;
	Иначе
	
		МастерГруппа=ЭлементыФормы.МастерДерево.ТекущиеДанные.Ссылка;

		//Формируем список производителей, которые входят
		//в группу МастерГруппа                    
		
		Список=Новый СписокЗначений;	//Создаем список значений

		ТекстЗапроса=" //Условие запроса - элемент входит в группу
		|ВЫБРАТЬ
		|	МастерСправочник.Ссылка КАК Элемент
		|ИЗ
		|  	Справочник.Производители КАК МастерСправочник
		|ГДЕ
		|  	МастерСправочник.Ссылка В ИЕРАРХИИ (&ГруппаИерархии)
		|";

		
		Запрос=Новый Запрос(ТекстЗапроса); //Создаем запрос
		
		Запрос.УстановитьПараметр("ГруппаИерархии",МастерГруппа);	//Устанавливаем параметр запроса
		РезультатЗапроса=Запрос.Выполнить(); //Выполняем запрос
		Таб=РезультатЗапроса.Выгрузить(ОбходРезультатаЗапроса.Прямой);

		//Выгружаем производителей из таблицы в массив, из массива в список
		Список.ЗагрузитьЗначения(Таб.ВыгрузитьКолонку("Элемент")); 

		//Устанавливаем отбор
		//Вид - в списке, значение - наш список
		ТекОтбор.ВидСравнения=ВидСравнения.ВСписке;
		ТекОтбор.Значение=Список;


		//Включаем отбор
		ТекОтбор.Использование=Истина;
	КонецЕсли;


 КонецПроцедуры
 

Дополнительно нужно завести реквизиты формы:

МастерСправочник - служит источником записей для МастерДерево, а ПодчСправочник - источником записей для ПодчТаблица.

При выборе производителя в МастерДерево в ПодчТаблица устанавливается отбор по производителям, входящим в выбранную группу производителя, или (если выбран элемент) с выбранным производителем.

Объект, к которому привязано табличное поле в 1С8 имеет возможность использовать отбор. Отборов может быть несколько, причем различных (по коду, наименованию, диапазону значений, подчинению группе, вхождению в список). Получить привязанный объект можно через ЭлементыФормы.ПодчТаблица.Значение, а элемент отбора по производителю через ЭлементыФормы.ПодчТаблица.Значение.Отбор["Производитель"]. Отбор и элемент отбора - это тоже объекты и описания их можно прочитать в RTFM.

Так как фильтра вхождения реквизита в группу не существует, формируем простой запрос, который выдает нам список элементов, соответствующих выбранному производителю (иерархически входящих в выбранную группу). И по данному списку устанавливаем отбор, затем его включаем.

Если производитель не выбран, отбор отключается.

Код простой и сердитый. Можете брать за основу.

Вывод в формы произвольной таблицы значений

Я захотел вывести в форму таблицу значений и знаете, пришлось возиться полчаса, прежде чем понял, как это сделать. Дело в том, что источником данных для табличного поля в форме может выступать только реквизит формы, саму таблицу нельзя передать в качестве источника данных.

Поэтому я завел табличное поле, завел реквизит формы, указал в поле "Данные" табличного поля реквизит формы, затем сформировал нужную мне таблицу значений и присвоил ее реквизиту формы. Тип значения реквизита формы был "ТаблицаЗначений", поэтому при присваивании таблица скопировалась. Если бы тип был "ТаблицаЗначений.Ссылка", то была бы только ссылка.

После этого еще нужно вызвать для табличного поля процедуру СформироватьКолонки(), чтобы сформировать набор колонок, исходя из переданной таблицы значений.

Приведенный ниже код формирует список элементов справочника Номенклатура и выводит его в таблицу значений Таб а затем в табличное поле ТабПоле на форме, используя реквизит формы ТабПолеДанные:

ТекстЗапроса="
		|ВЫБРАТЬ
		|	Номенклатура.Ссылка КАК Элемент
		|ИЗ
		|  	Справочник.Номенклатура КАК Номенклатура
		|";
	Запрос=Новый Запрос(ТекстЗапроса);
	РезультатЗапроса=Запрос.Выполнить();	//Выполняем запрос
	Таб=РезультатЗапроса.Выгрузить(ОбходРезультатаЗапроса.Прямой);	//Выгружаем запрос в таблицу
	ТабПолеДанные=Таб; //Перекачиваем данные из таблицы в реквизит формы
	ЭлементыФормы.ТабПоле.СоздатьКолонки(); //Создаем выводимые колонки
 

Точно так же можно выгружать данные и в дерево, только используя не прямой способ выгрузки, а иерархический.

 

Скачать файлы

Наименование Файл Версия Размер
1s8zoo.zip

.zip 5,44Kb
09.02.12
44
.zip 5,44Kb 44 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. AnryMc 723 09.02.12 21:09 Сейчас в теме
2. stormtg 13.02.12 14:40 Сейчас в теме
А мне интересно было прочитать, спасибо!
3. fixin 3992 13.02.12 15:34 Сейчас в теме
4. Veduin 15.02.12 10:32 Сейчас в теме
Я программист, три года с ноября 1999 года, а на дворе 2012год.
Серьезная шутка!!!!
6. fixin 3992 15.02.12 10:47 Сейчас в теме
(4) вы никогда не читали рассказы, написанные в сложной форме времени? Т.е. когда действие происходит в прошлом, но герой говорит в настоящем времени? Не буквоедствуйте, хотя реально забавно. Статья старая, но не утратившая актуальности. Это мой опыт.

(5) запрос в цикле не всегда зло. Помнится когда то все пытались запихнуть в один запрос, а счас в моде пакетные запросы. ;-0
5. StAsya_1C 23 15.02.12 10:42 Сейчас в теме
Наверное, много лет прошло с написания статьи... сейчас за запрос в цикле убивают, а не пишут "не самый оптимальный код" )))
А вообще спасибо, интересная статья!
7. Nata 7 26.02.12 02:57 Сейчас в теме
Спасибо! Очень не плохой пример как начинать. Обычно начало намного хуже, методом "тыка" и без литературы, пытаясь сделать какую-нибудь реальную задачу.
8. ГСГ 24.09.12 08:53 Сейчас в теме
Чет слишком сложно написано.
9. fixin 3992 24.09.12 11:00 Сейчас в теме
(8) Эх, если бы 1с мне заплатило, я бы написал степ-бай-степ, а так нету времени.
11. AlexO 129 04.12.12 11:31 Сейчас в теме
(9)
Сергей, я постоЯнно на 7.7 перехожу - мне бы уроки в обратку, а? А то забываю через месяц, каждый раз заново надо привыкать к простоте 7.7... :)
10. a1ex4ndr 1 04.12.12 11:28 Сейчас в теме
животного кто нибудь угадал? :)
12. AlexO 129 04.12.12 11:35 Сейчас в теме
По этим урокам - Сергей в кои-то веки! написал уроки! с картинками и разжеванные! :)
Однозначно плюс и - Серега, давай исчо! по любым темам :)
Оставьте свое сообщение

См. также

Вам нравятся запросы в 1С? Промо

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    18707    4    m-rv    86    

Конвейер проверки качества кода

Инструментарий разработчика Практика программирования Математика и алгоритмы v8 1cv8.cf Абонемент ($m)

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    22273    21    Stepa86    44    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    20276    13    RocKeR_13    16    

HTTP Сервисы: Путь к своему сервису. Часть 3

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    33148    51    dsdred    15    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") Промо

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    28969    86    m-rv    57    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    26321    26    informa1555    26    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    42574    17    kalyaka    16    

Полезные примеры составления схемы компоновки данных #2

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Еще один набор примеров как решить частные задачи в СКД

1 стартмани

22.05.2018    28532    11    SITR-utyos    13    

Заполняем по шаблону (по умолчанию) Промо

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    26713    19    mvxyz    17    

Создание в 1С 7.7 XML в формате EnterpriseData (универсальный формат обмена), версия 1.5. Инструкции и примеры переноса данных из устаревшей конфигурации 1С 7.7 в любую современную 1С 8.3, поддерживающую EnterpriseData, через Конвертацию данных 3

Перенос данных из 1С7.7 в 1C8.X Обмен через XML v7.7 v8 1cv7.md Россия Абонемент ($m)

Воспользоваться современным средством переноса данных "Конвертация данных 3.0.5.3" можно только выгрузив из системы - источника данных XML в формате обмена данными EnterpriseData. В этой публикации можно скачать приемы выгрузки из 1С 7.7 универсального формата обмена для Конвертации данных 3. Выполняем перенос данных из «1С:Предприятие 7.7» в «1С:Предприятие 8.3». Используем Конвертацию данных КД 3.0 из 1c 7.7 --> 1С 8.3. На первой стадии еще не опубликовано иного способа подложить файл для Конвертации данных 3 кроме как сформировать его вручную, постараемся решить данную проблему.

1 стартмани

26.02.2018    37621    51    ksnik    3    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    25597    49    kwazi    6    

Паузы при исполнении кода (Sleep для 1С)

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Решил проверить все найденные варианты паузы для 1С. В результате получилась обработка для тестирования и небольшая статья с итогом.

1 стартмани

28.11.2017    40419    11    swimdog    41    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    26117    67    vasvl123    9    

Telegram-боты

Практика программирования v8 Абонемент ($m)

Описание теории, разбор архитектуры и пример реализации telegram-ботов. Сразу скажу, со структурированием изложения мало что могу поделать. :) редакция от 18.07.2018 Правки последней редакции выделены жирным.

1 стартмани

01.09.2017    30294    128    PLAstic    54    

Умный дом на 1С + ардуино

Практика программирования v8 Абонемент ($m)

Конфигурация для автоматизации быта программиста 1C и не только. В данной статье будет рассказано, как можно использовать 1С для задач, не входящих в стандартные рамки этой платформы. Например, управление домом. В качестве периферии для подключения будет использован микроконтроллер (МК) Ардуино, но на нём не будет никакой логической нагрузки, весь процесс будет проходить на сервере 1С. Работа с пинами ввода/вывода происходит напрямую из 1С.

1 стартмани

07.08.2017    21353    20    sasha777666    63    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    120884    13    signum2009    46    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут Промо

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    46402    36    Demanoidos    60    

Регулярные выражения – это просто. Построитель и отладчик регулярных выражений

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагается к использованию построитель регулярных выражений. Выполненный в виде внешней обработки, он позволит строить сложно-структурированные выражения на основе параметрического описания, тестировать их, и в результате получить программный код 1С.

1 стартмани

13.03.2017    29735    112    romasna    49    

Распознавание текста с помощью нейросетей Google Cloud Vision и 1С

Практика программирования v8 1cv8.cf Абонемент ($m)

Возможности Google Cloud Vision в распознавании текста.

1 стартмани

08.02.2017    26707    120    kiv1c    18    

Графическая схема. Управление при помощи XDTO.

Практика программирования v8 Абонемент ($m)

В статье описывается методика программного управления элементами графической схемы при помощи механизма XDTO. Приложена готовая к использованию библиотека функций для создания и удаления графических объектов, а также для связи элементов схемы соединительными линиями.

2 стартмани

16.01.2017    20474    100    Alxby    21    

Быстрое определение интервалов в запросе Промо

Практика программирования v8 Абонемент ($m)

В статье описывается новый метод определения интервалов между данными различных записей в запросе. В отличие от общеизвестного метода, время работы предлагаемого метода зависит от объема данных ЛИНЕЙНО. Это обеспечивает ему значительный выигрыш по быстродействию на больших объемах данных. В качестве иллюстрации возможностей метода приведен отчет, показывающий гистограмму распределения времени между продажами.

1 стартмани

01.10.2015    49482    35    ildarovich    41    

Несколько шаблонов для доработки типовых конфигураций

Практика программирования Инструментарий разработчика v8 v8::УФ Абонемент ($m)

Предлагаю несколько каркасов для создания новых объектов в типовых конфигурациях. Это выжимка из кода нескольких конфигураций, которая позволит быстро и красиво создавать и дорабатывать объекты метаданных с соблюдением идеологии исходной системы

1 стартмани

03.10.2016    35139    95    json    25    

HTTP-сервис: отчеты [Расширение]

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Это HTTP-сервис, который возвращает почти любой отчет в HTML, XLSX или в JSON. Сохраните вариант отчета, получите на него ссылку и можно получить данные без захода в 1С. Работает в конфигурациях на основе БСП 2.3.3+, для отчетов на СКД и в 1С 8.3.8+

2 стартмани

30.08.2016    25003    132    Stepa86    15    

Недокументированное использование стандартных форм Upd.

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Вам не хватает возможностей в платформе 1С или у Вас нет времени на углубленное изучение платформы 1С? Рассмотрены возможности использования стандартных форм, вызываемых из платформы.

1 стартмани

26.07.2016    26635    75    ZhokhovM    60    

Хранение файлов в томах на диске (для УПП 1.3)

Практика программирования v8 УПП1 Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    54617    7    wowik    32    

БСП 2.3 и БСП 3.0: Просто про выполнение внешней обработки в фоне (c индикацией прогресса выполнения)

Инструментарий разработчика Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Простое пояснение о том, как сделать внешнюю обработку с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП 2.3.2. UPDATE 20/09/19: добавлен вариант обработки с индикацией процента выполнения и статусом выполнения для БСП 3.0.

1 стартмани

18.05.2016    58268    167    rozer    64    

Остатки на каждый день в запросе

Практика программирования Учет ТМЦ Учет ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    54136    19    arakelyan    18    

Еще один способ расчета остатков на каждый день в запросе

Математика и алгоритмы Практика программирования v8 Абонемент ($m)

Предлагается новый способ расчета остатков на каждый день (час, минуту, секунду) в запросе. Способ не требует предварительного формирования таблицы дат и также подходит для расчета курсов валют, цен номенклатуры и других периодических сведений на каждую дату периода. На больших объемах данных предлагаемый способ может превосходить по быстродействию ранее известные методы из-за линейной (в лучшем случае) зависимости трудоемкости от длины периода.

1 стартмани

24.04.2016    32949    48    ildarovich    23    

Выполнение JavaScript кода из 1С в объекте Поле HTML Документа (HTML 5) и вызов события в 1С ПриНажатии

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример выполнения JS кода из 1С в Поле HTML Документа под управляемыми формами, с удобным получением результата в 1С(С помощью вызова привязанного события ПриНажатии к элементу ПолеHTMLДокумента)

1 стартмани

22.03.2016    76749    152    igo1    53    

Количество дней недели (понедельников/вторников/...) в заданном диапазоне одним запросом

Практика программирования v8 Абонемент ($m)

При реализации периодического авто-заполнения маршрутных листов по графику (недельному) необходимо было просчитать стоимость всего периода, с условием выездов только по определенным дням. Заморачиваться с обходом результата не хотелось. Пришлось написать "Небольшой" запрос.

1 стартмани

03.03.2016    17082    1    Alexander.Shvets    5    

Простые радости жизни программиста 1С: выбор типа значения

Работа с интерфейсом Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    47691    50    yuraos    17    

Отображение прогресса выполнения длительных операций в БСП и их отладка в текущем сеансе.

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

В статье описан способ исполнения длительных операций в конфигурациях, в которых используется библиотека стандартных подсистем, с визуализацией прогресса исполнения и отображения хода обработки данных. Также дается краткое описание процесса отладки длительных операций в текущем сеансе.

1 стартмани

17.02.2016    51525    167    balanton    23    

Яндекс.Деньги "Благотворительность"

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Яндекс.Деньги теперь в 1С. Форма для приема благотворительных взносов. Форму легко сделать и вставить на любую страницу сайта или блога. Платежи будут приходить на ваш кошелек. На форме есть три способа платежа: из кошелька, с банковской карты, с баланса мобильного.

1 стартмани

16.02.2016    22092    8    Tatitutu    5    

Мастер рассылки e-mail 2.2 для управляемых форм

Практика программирования Email v8 v8::УФ ERP2 БП3.0 УТ11 Абонемент ($m)

Для пользователей: переделанный из старый разработки под 8.2 с использованием библиотеки Мастер рассылки e-mail 2.2 (ERP, УТ, БП) (Только управляемые формы), который теперь может запускаться под любой версией платформы с разрешенными или запрещенными модальными/синхронными вызовами в конфигурации. Также удобный выбор e-mail и их владельцев с помощью отбора динамического списка по любым критериям и галочки исключения.

1 стартмани

29.12.2015    35906    19    milkers    4    

Передача больших пакетов через веб-сервисы

Практика программирования Администрирование данных 1С Внешние источники данных v8 Абонемент ($m)

Реализация механизма передачи больших пакетов через веб-сервисы. С его помощью передать файл размером в несколько гигабайт не составит проблем.

1 стартмани

06.12.2015    54424    47    YPermitin    19    

Пример связи 1С и мессенджера Telegram. Получение данных из 1С запросом из Telegram

Практика программирования Внешние источники данных v8 1cv8.cf Абонемент ($m)

В результате чтения публикации Вы получите готовую внешнюю обработку, позволяющую получать из 1С данные, запрашиваемые через Telegram. В данной статье рассмотрим следующее: Использование HTTPСоединение; Чтение JSON для версии 1С 8.3.6 и выше, а также аналог JSON для версии 1С ниже 8.3.6; Подключение обработчика ожидания; Некоторые основные возможности API Telegram; Как создать бота для Telegram; Программное создание колонок дерева на управляемой форме;

1 стартмани

19.11.2015    87861    446    Luchik    202    

Полезные приемы при работе с Excel из 1С (Версия 3.1)

Практика программирования Разработка внешних компонент Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Программисту 1С часто приходится работать с таблицами Excel из 1С. Я постарался собрать небольшой FAQ и набор функций для работы с файлами Excel. Надеюсь, кому-то будет полезна данная статья.

1 стартмани

22.09.2015    185838    432    Zerocl    65    

Javascript и 1С. Кросс-платформенное взаимодействие

Практика программирования v8 1cv8.cf Абонемент ($m)

Что делать, если необходим богатый интерфейс, а управляемые формы нам его не могут обеспечить? Использовать HTML и JavaScript. В статье рассмотрено взаимодействие кода 1С и JavaScript, работающее на любой платформе: толстый, тонкий и веб-клиент, под Windows и Linux.

1 стартмани

14.09.2015    64147    200    VitaliyCeban    59    

Code First и Linq to EF на примере 1С версии 7.7 и 8.3 часть I

Практика программирования v8 Абонемент ($m)

Данный проект является чисто исследовательским примером использования Code First и Linq to EF на примере 1С версии 7.7. Так как сам я программист 1С, то мне всегда было интересно, как можно перенести модель объектов 1С на компилируемые языки, и использовать мощь Linq to EF. С появлением Code First давно хотел прикрутить, но все как-то руки не доходили, и вот, наконец ..

1 стартмани

28.08.2015    21943    3    Serginio    2    

Универсальная учетная система с конструктором документов и справочников в режиме 1С: Предприятие

Инструментарий разработчика Практика программирования v8 1cv8.cf УУ Абонемент ($m)

Заголовок статьи звучит фантастично, но это не шутка. Занимаясь внедрениями, я часто сталкивался с ситуацией, когда надо было к типовой конфе приделать простенький модуль учета чего-нибудь, не специфичного для самой конфы. Например в УТ учет материалов в эксплуатации. Модуль обычно состоял из пары справочников (2-3), 3-х документов и регистра или пары регистров. Однажды подобные пристройки понадобились одновременно на 3 проектах. Скучно делать одинаковую работу, и я подумал, а что, если сделать универсальный инструмент, в котором пользователь сам сможет нарисовать себе справочники, реквизиты к ним, документы и движения. Т.е. конструктор полноценных документов в пользовательском режиме. Это оказалось не так сложно - все дело в подходящей архитектуре данных.

1 стартмани

29.07.2015    30687    88    informa1555    41