JSON viewer/editor/редактор, удобный и простой визуальный просмотр JSON для WebKit 1С на базе Ace

Публикация № 1348459 22.12.20

Интеграция и обмен данными - WEB-интеграция

JSON отличный формат для обмена, но с ним абсолютно неудобно работать в 1С при файлах большого размера, нет нормального и красивого просмотра формата JSON, а если еще хочется интерактивно редактировать и видеть результат? Решение сделаем на базе Ace в публикации с полностью открытым кодом и бесплатной обработкой JSONeditor.

Подсистема EDIbot для 1С позволяет быстро и практически без программирования создавать приложения для мобильных и десктопов, в качестве основного формата обмена используется JSON. Однако, в процессе эксплуатации мы столкнулись с необходимостью удобного визуального просмотра JSON (форматирования, сворачивание/разворачивание узлов, свойств и т.п.) и редактирования JSON сообщений обмена (добавления новых узлов, изменения свойств ключей и т.п.) с одновременным просмотром будущего результата.

Для примера возьмем JSON диаграмм из публикации про Dashboard и давайте сразу посмотрим конечный результат нашей статьи:

 

Теперь разберем, как такое Вам сделать у себя, используя 1С платформу с WebKit (начиная с 8.3.14 релиза).

Пример будем делать в тестовой обработке, вот скрин-шот:

(слева у нас визуальный редактор (JSON formatter), справа текстовое представление JSON, редактировать можно в любой стороне)

 

Подготовим index.html - JSON editor на базе Ace editor

Итак, сначала мы подключаем JS JSON редактора:

  <link href="dist/jsoneditor.min.css" rel="stylesheet" type="text/css">
    <script src="dist/jsoneditor.min.js"></script>

 

Далее, чтобы в WebKit отслеживать события визуального редактора, мы разместим в HTML невидимую кнопку и будем ее нажимать при событии onChange:

<button id="onChange" style="display: none"></button>

 

Событие onChange на кнопку мы повесим при инициализации нашего JSON editor в JS wrapper1C:

function Init()  {  

	const container = document.getElementById("jsoneditor")
        const options = { mode: 'code', 
			onChange: function() {onChange.click()} }
        const editor = new JSONEditor(container, options)

	return editor
}

 

Добавим в index.html блок с нашим "jsoneditor":

   <div id="jsoneditor" style="width: 100%; height: 100%;"></div>

 

В итоге наш index.html будет выглядеть следующим образом:

<!DOCTYPE HTML>
<html lang="ru">
<head>
    <meta charset="utf-8">

    <link href="dist/jsoneditor.min.css" rel="stylesheet" type="text/css">
    <script src="dist/jsoneditor.min.js"></script>
    <script src="dist/wrapper1C.js"></script>
</head>
<body>
    <div id="jsoneditor" style="width: 100%; height: 100%;"></div>
    <button id="onChange" style="display: none"></button>
</body>
</html>

 

Следующий шаг - это автоматически разворачивать JSON компонент - index.html и все его JS в общую папку или некую временную. Поэтому запакуем это в архив zip и разместим в макете обработки. Кстати, альтернативным вариантом является разворачивание и настройка IIS сервера и открытие JSON редактора по его адресу. 

 

Теперь сделаем все на стороне 1С, для начала установим компонент (JSON formatter):

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
	JSONHTML = УстановитьJSONEditor();
	
КонецПроцедуры

 

&НаСервере
Функция УстановитьJSONEditor() экспорт
	
	РабочийКаталог = КаталогПрограммы(); //тут пишем  общую папку
	
	КаталогКомпоненты = "EDIbotJSONEditor";
	
	КаталогНаДиске = Новый Файл(РабочийКаталог+КаталогКомпоненты);
	Если НЕ КаталогНаДиске.Существует() Тогда
				 
		Чтение = Новый ЧтениеДанных(РеквизитФормыВЗначение("Объект").ПолучитьМакет("EDIbotJSONEditor"));
		
		Файл = Новый ЧтениеZipФайла(Чтение.ИсходныйПоток());
		
		Файл.ИзвлечьВсе(РабочийКаталог+КаталогКомпоненты);
		
	КонецЕсли;

	Возврат РабочийКаталог+КаталогКомпоненты+"\index.html";
КонецФункции

 

Дальше, после формирования документа сделаем инициализацию JSON editor:

&НаКлиенте
Перем editorJSON;

&НаКлиенте
Процедура JSONHTMLДокументСформирован(Элемент)
	
	editorJSON = Элементы.JSONHTML.Документ.defaultView.Init();
	
	ТекущийЭлемент = Элементы.JSONHTML;

	editorJSON.focus();
	
КонецПроцедуры

 

Далее, если нам нужно отслеживать изменение в обычном текстовом редакторе (справа) и обновлять визуальный редактор JSON слева, то ПриИзменении текста вызываем метод по установке его в объект editorJSON.

&НаКлиенте
Процедура JSONПриИзменении(Элемент)
	
	editorJSON.setText(JSON);

КонецПроцедуры

 

Сделаем и наоборот, при редактировании в визуальном JSON редакторе отображать изменения в текстовом:

&НаКлиенте
Процедура JSONHTMLПриНажатии(Элемент, ДанныеСобытия, СтандартнаяОбработка)
	
	Если НЕ _ОбщегоНазначенияКлиентСервер.ПолучитьЗначениеКоллекции(ДанныеСобытия, "Button.id")="onChange" Тогда
		Возврат;
	КонецЕсли;	
		
	JSON = editorJSON.getText();

КонецПроцедуры

Обратите, внимание, что я использовал модифицированную функцию ПолучитьЗначениеКоллекции, которую разбирал в публикации Чтение вложенных свойств Структур Структуры, Соответствий, свойства через точку, разбор JSON (внес изменения в публикацию).

 

Собственно и всё )  Редактируем слева - отображается справа, редактируем справа - отображается слева, удобно просматривать JSON, вносить правки, добавлять разделы и узлы, менять значения свойств, добавлять новые свойства. 

UPD. 

Отключить возможность редактирования в JSON редакторе:

editorJSON.aceEditor.setReadOnly(Истина);

Перейти программно к определенной строке в JSON редакторе:

editorJSON.aceEditor.gotoLine(100);

Перейти в режим представления TreeView 

editorJSON.setMode("tree");

(обратно вернуться - "code")

Вот скрин-шот:

 

Управлять стилями панели JSON formatter:

//универсально
 	ЭлементыРедактора = Элементы.JSONHTML.Документ.getElementsByClassName("jsoneditor-menu");
	ЭлементыРедактора[0].style.backgroundColor = "red";
//а можно и так 
editorJSON.menu.style.backgroundColor = "red";

 

Установить фокус на JSON редактор:

&НаКлиенте
Процедура JSONHTMLДокументСформирован(Элемент)
	
	editorJSON = Элементы.JSONHTML.Документ.defaultView.Init();
	
	ТекущийЭлемент = Элементы.JSONHTML;

	editorJSON.focus();

КонецПроцедуры

А вот если нужно установить фокус по нажатию кнопки, то тут хитрее:

&НаКлиенте
Процедура Команда1(Команда)
	
	ТекущийЭлемент = Элементы.JSONHTML;
	
	Оповестить("Фокус");
		
КонецПроцедуры

&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
	
	Если ИмяСобытия="Фокус" Тогда
		editorJSON.focus();
	КонецЕсли;	
	
КонецПроцедуры

 

Спасибо автору компоненты JS - https://github.com/josdejong/jsoneditor, Jos de Jong, там есть примеры, как можно адаптировать редактор под свои потребности (валидация JSON, исправление JSON, и многое другое) 

 

Ссылка на пример обработки (бесплатный) - https://cloud.mail.ru/public/YPz9/ndzUJ9GER

За стартмани тоже самое - для донатов)

 

Надеюсь, моя публикация была Вам полезна и сэкономит Ваше время, ссылка на все публикации SizovE

думаю Вам также понравится HTML редактор (Wysiwyg) для WebKit 1С (CMS, B2B), альтернатива TinyMCE и стандартному ФорматированныйДокумент.

 

Подписывайтесь на мой канал (наверху), будет много интересного бесплатного контента :)

Скачать файлы

Наименование Файл Версия Размер
JSON viewer/editor/редактор, удобный и простой визуальный просмотр JSON для WebKit 1С на базе Ace editor

.epf 610,01Kb
90
.epf 610,01Kb 90 Скачать бесплатно

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. tormozit 6729 22.12.20 07:44 Сейчас в теме
При открытии получил ошибку
{ВнешняяОбработка.EDIbotJSONРедактор.Форма.Форма.Форма(14,10)}: Переменная не определена (_ОбщегоНазначенияКлиентСервер)
	Если НЕ <<?>>_ОбщегоНазначенияКлиентСервер.ПолучитьЗначениеКоллекции(ДанныеСобытия, "Button.id")="onChange" Тогда
4. SizovE 236 22.12.20 09:45 Сейчас в теме
(1) Как указано в публикации функция ПолучитьЗначениеКоллекции была описана в Чтение вложенных свойств Структур Структуры, Соответствий, свойства через точку, разбор JSON, у нас она расположена в модуле _ОбщегоНазначенияКлиентСервер
5. tormozit 6729 22.12.20 10:58 Сейчас в теме
(4) Так ты выложил внешнюю обработку как заявлено "для произвольной конфигурации". Но в ней она не работает. Получается некорректное обещание, либо некорректный код.
6. SizovE 236 22.12.20 11:26 Сейчас в теме
(5) ) В публикации ни где не написано, что пример сделан для произвольной конфигурации )
Собрал обработку для произвольной
Прикрепленные файлы:
EDIbotJSONРедактор.epf
7. tormozit 6729 22.12.20 11:49 Сейчас в теме
8. SizovE 236 22.12.20 12:21 Сейчас в теме
(7) ) буду знать, что означает данный выбор
10. SizovE 236 22.12.20 17:37 Сейчас в теме
(5) )) оказывается и эта была не рабочая для произвольной конфигурации, держи рабочую, специально проверил )
Прикрепленные файлы:
EDIbotJSONРедактор.epf
2. tormozit 6729 22.12.20 08:59 Сейчас в теме
Как установить выделение по номеру строки и колонки или по начальной и конечной позиции?
3. tormozit 6729 22.12.20 09:37 Сейчас в теме
Как отключить возможность редактирования?
Как уменьшить высоту и изменить цвет командной панели?
9. SizovE 236 22.12.20 13:48 Сейчас в теме
(3) Добавил в публикацию
tormozit; +1 Ответить
11. tormozit 6729 23.12.20 22:03 Сейчас в теме
Нашел еще проблему. JSON редактор получает фокус ввода только кликом. Например я разместил его на странице и при активации страницы хочу сразу приступить к редактированию текста. Но пока не кликнешь в нем, он не принимаем ввод клавиш. Решил вызовом метода JSONEditor.focus(). Рекомендую добавить это в демо обработку.
12. SizovE 236 23.12.20 22:22 Сейчас в теме
(11) ) только что добавил в апдейт публикации. Правда, выяснился нюанс, что если ее повесить на кнопку, то сработает только со второго раза. Т.е. ему нужно сначала перейти фокусом на поле, а потом видимо уже следующим шагом и отдельно перейти на фокус редактирования. ПодключитьОбработчикОжидания не помогает.
13. SizovE 236 23.12.20 22:29 Сейчас в теме
(11) Нашел решение )))) забавно, Оповестить("Фокус");

&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)

editorJSON.focus();

КонецПроцедуры
14. tormozit 6729 02.01.21 09:37 Сейчас в теме
Еще есть неудобство в потере позиции при переключении режима отображения через JSON.setMode(). Особенно неудобно, если текст большой - приходится заново искать нужное место в тексте при каждом переключении в любую строну между "code" и "tree". Можно как то просто решить эту проблему? Возможно там есть какие то методы для сохранения восстановления позиции через синтаксическое дерево типа getBookmark и showBookmark?
15. SizovE 236 02.01.21 13:21 Сейчас в теме
(14) Я такого не встречал, мне не требовалось ) исходники JS открыты, так что можно допилить под себя и пересобрать
16. tormozit 6729 02.01.21 13:38 Сейчас в теме
(15) Задача непростая. Поэтому не хотелось бы ее решать самому. Написал автору на гитхабе https://github.com/josdejong/jsoneditor/issues/1209 .
18. SizovE 236 02.01.21 13:52 Сейчас в теме
(16) ага ) видел, тут видимо да, придется какую-то метку ставить или по узлу как-то смотреть, автор-то точно в курсах как проще, может и сделает, он ее развивает
17. tormozit 6729 02.01.21 13:38 Сейчас в теме
Еще заметил, что вызов метода setText в режиме дерева не меняет дерево - оно продолжает отображать старый текст. https://github.com/josdejong/jsoneditor/issues/1210
19. tormozit 6729 02.01.21 22:41 Сейчас в теме
(17) Оказалось причина была в моем коде. В самом редакторе тут нет проблемы.
20. SizovE 236 03.01.21 09:46 Сейчас в теме
21. tormozit 6729 27.04.21 07:28 Сейчас в теме
В ОС linux возникает ошибка
Метод объекта не обнаружен (Init)
мРедакторJSON = Элемент.Документ.defaultView.Init();

Из-за того в теле документа HTML в секции scripts идет подключение:
file:///tmp/JSONEditor/dist/wrapper1C.js

А имя файла в действительности с "1c" в нижнем регистре.
22. SizovE 236 27.04.21 10:36 Сейчас в теме
23. tormozit 6729 21.08.21 10:36 Сейчас в теме
Можно ли найти уже инициализированный объект JSONEditor в поле HTML?
24. SizovE 236 22.08.21 12:49 Сейчас в теме
(23) Не очень понял, а зачем?
25. tormozit 6729 22.08.21 13:26 Сейчас в теме
(24) Затем что мне нужно для унификации работы с разными редакторами на базе поля HTML. Например редактор Monaco такое позволяет.
26. SizovE 236 22.08.21 16:56 Сейчас в теме
(25) Есть такой код
<!DO CTYPE HTML>
<ht ml lang="ru">
<head>
    <met a charset="utf-8">

    [*]
    <sc ript src="dist/jsoneditor.min.js"></sc ript>
    <sc ript src="dist/wrapper1C.js"></sc ript>
</head>
<body>
    <div id="jsoneditor" style="width: 100%; height: 100%;"></div>
    <button id="onChange" style="display: none"></button>
</body>
</html>
Показать

Что Вы хотите в нем найти?
далее, Вы получаете объект в 1С и им управляете editorJSON = Элементы.JSONHTML.Документ.defaultView.Init();
27. tormozit 6729 22.08.21 17:21 Сейчас в теме
(26) Если я правильно понял, то метод Init() всегда создает новый экземпляр редактора. А мне нужен существующий, чтобы его состояние при этом не изменилось.
28. SizovE 236 23.08.21 15:09 Сейчас в теме
(27) Да, он его создает и возвращает в 1С, в текущей реализации вы его так не получите. Нужно тогда иначе писать JS.
29. vladnet 343 03.12.21 00:01 Сейчас в теме
А делать редактор 1с на нем не пробовали? Я что то так и нормального решения для редактирования 1с кода с раскраской не нашел под управляемые формы. Ace вроде то что надо, особенно после того как на ВебКит перешла 1с.
30. SizovE 236 03.12.21 08:46 Сейчас в теме
Оставьте свое сообщение

См. также

Помощник работы с VirtueMart Промо

WEB-интеграция Розничная торговля Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление производственным предприятием Россия Бесплатно (free)

Обработка для обмена данными с интернет-магазином на базе VirtueMart. Позволяет выгружать товары с изображениями и загружать заказы покупателей. Управлять интернет-магазином теперь стало просто!

19.04.2012    30334    215    salexdv    13    

Реализация распознавания номера автомашины на удаленном сервисе с помощью штатного 1С HTTP

WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Если у Вас есть каталог фото автомашин, или с камеры (IP или web) можете забирать фото и сохранять их в каталог (если нет, то в списке моих публикаций есть соответствующая обработка), то Вы можете с помощью приложенной обработки штатными средствами 1С посылать на сервер картинку, и получать ответом гос. номер (как строка - например, X890AM152), вырезанную картинку гос. номера (в двоичных данных), координаты гос. номера в картинке, описательный шаблон гос. номера, время распознавания.

19.05.2022    2566    107    protexprotex    15    

Исправление ошибки ЕИС РДИК_0210

WEB-интеграция Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Бесплатно (free)

Исправление ошибки РДИК_0210 при выгрузке документов в ЕИС.

04.04.2022    3354    126    oleg-x    2    

Формирование дерева групп для обмена с 1С-Битрикс

WEB-интеграция Платформа 1С v8.3 1С:Комплексная автоматизация 1.х Бесплатно (free)

Обычные формы. КА 1.х Данная обработка формирует дерево групп для сайта на CMS Битрикс по справочнику "Номенклатура", учитывая иерархию. Не всегда группы выгружаются в Битрикс так, как хотелось бы. Чтобы это поправить, производители модуля обмена с 1С придумали дерево групп, которое задается в 1С и "распределяет" товары и категории, предписывая Битриксу расположить их определенным образом. Но проблема в том, что делать это приходится руками, что не является проблемой если у вас 20 товаров, 100 товаров. Но когда товаров более 1000, 3000 или, как в моём случае, больше 10 000 номенклатурных позиций... Получается проблема.

27.09.2021    2759    30    h2lion    2    

Консоль HTTP запросов

Инструментарий разработчика WEB-интеграция Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Бесплатно (free)

Простая консоль для отправки и тестирования HTTP запросов и WEB сервисов. Есть функция сохранения в файл. 

05.10.2020    10376    518    zarankony    5    

Каталожик 2.0: Загрузка каталога товаров для 1C

WEB-интеграция Оптовая торговля Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 11 Управленческий учет Бесплатно (free)

Загрузка из интернет каталога товаров для программы 1C из файлов xml (yml) и скаченных с Яндекс диска для разных поставщиков.

04.03.2020    10207    39    wrooom    8    

Запрос к ГАС Правосудие по номеру дела и субъекту РФ

WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Аудит и бухгалтерские услуги, юриспруденция Россия Бесплатно (free)

Обработка возвращает результат запроса в виде таблицы из ГАС "Правосудие"

14.09.2016    9504    16    Guyer    4    

Информация по регионам и ФО с использованием Яндекс.Карт

WEB-интеграция Работа с интерфейсом Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Пример использования Yandex.Map API для отображения информации по регионам или федеральным округам РФ. Раскраска регионов и ФО, вывод меток, работа в режиме картограммы. Не привязан к какой-либо конфигурации. Просто пример. В 8.2 работает на толстом, тонком и WEB*-клиентах. *(WEB не во всех браузерах).

30.11.2011    9212    145    mgor    3    

Форма выбора координат Yandex карт (управляемая форма)

Универсальные обработки WEB-интеграция Работа с интерфейсом Платформа 1С v8.3 Конфигурации 1cv8 Россия Бесплатно (free)

Обработка позволяет найти нужный адрес на карте Yandex. Отправить сообщение форме-владельцу или всем формам, со строкой координат.

06.09.2011    22475    425    motkot    27    

IBridges - новый, бесплатный сервис обмена документами между пользователями программы 1С:Предприятие

СRM Обработка документов WEB-интеграция Обмен между базами 1C Платформа 1С v8.3 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 Россия Бесплатно (free)

Основная задача сервиса IBridges – сделать документооборот между разными организациями - Легким - Быстрым - Бесплатным - Оперативным - Безопасным

11.08.2011    29199    240    O-Planet    61    

"Кривая" интеграция twitter

WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Россия Бесплатно (free)

После введения сервисом Twitter новой системы авторизации работа с ним из 1С стала проблематичной... Тем не менее, была поставлена задача, и я попробовал ее решить...

04.08.2011    7671    19    Mike1978    13    

Загрузка курсов валют с сайта Национального Банка Азербайджана. 1С8

Обработка справочников WEB-интеграция Банковские операции Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Обработка, позволяющая загружать курсы валют с сайта Национального Банка Азербайджана, www.cbar.az. 1С8

22.04.2011    28671    99    PaRaDoX    4    

Очередная обработка контрагентов STA.GOV.UA

Обработка справочников WEB-интеграция Платформа 1С v8.3 1С:Управление торговлей 10 Украина Бесплатно (free)

Доработанная обработка публикации http://infostart.ru/public/19921/ для типовой УТП, которая проставляет по контрагенту, с которым возникли нал. обязательства, информацию, найденную на сайте http://sta.gov.ua. Может кому пригодится - пользуйтесь на здоровье.

21.07.2010    10041    51    narus    2    

Выгрузка прайс-листов из линейки программ Далион-Авто на портал информационный Japancar.ru

Оптовая торговля WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Автомобили, автосервисы Россия Бесплатно (free)

Выгрузка на сайты www.greenparts.ru , www.japancar.ru , www.qx9.ru , www.jcboat.ru , www.wiweb.ru , www.jcmoto.ru (относительно несложно переделать под УТ, БП , УПП и т.д.)

05.07.2010    18111    44    lame    3    

Танцы с Гуглом

Универсальные обработки WEB-интеграция Работа с интерфейсом Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Работа с картами гугл из локального кэша формата google titles. Всего две функции: показать по координатам и получить координаты под курсором. Применяется для отображения на карте объектов, имеющих координатную привязку.

27.03.2010    11439    200    Путин    7    

Загрузка программы НТВ-плюс

WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Россия Бесплатно (free)

Загрузка телепрограммы на основные каналы через web-обработку сайта НТВ-плюс. Выбор дней недели, 133 канала любимых передач, оповещения времени наступления любимой передачи, просмотр программы на текущий момент.

08.02.2010    9656    123    maxlenium    15    

Загрузка курсов валют национального банка РБ с использованием web-сервиса.

WEB-интеграция Платформа 1С v8.3 Беларусь Бесплатно (free)

Написана под самописную конфигурацию, поэтому под типовыми она не заведется. Но можно использовать код получения данных с web-сервиса.

25.10.2009    12311    73    serg_gres    12    

[TinyMCE] - редактор HTML WYSIWYG кода.

WEB-интеграция Работа с интерфейсом Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Редактор HTML кода, использующий java-редактор TinyMCE (использующийся, кстати, на Инфостарте) Без внешних компонент. Сделан исключительно средствами 1С.

09.09.2009    49212    1945    Душелов    57    

[SendGoogleSMS] Отправка SMS уведомлений через сервис Google Calendar

WEB-интеграция SMS рассылки Разработка внешних компонент Платформа 1С v7.7 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv7 Бесплатно (free)

Компонента генерирует события в Google Calendar с извещением по SMS. В архивах ВК для 7.7 (работает и в 8-ке) и ActiveX - для работы в контексте сервера 1С 8.х

07.08.2009    34665    559    Душелов    37    

Архив к статье "Интеграция 1С с сервисной шиной OpenESB"

WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Россия Бесплатно (free)

Архив к статье "Интеграция 1С с сервисной шиной OpenESB"

30.07.2009    10635    121    mini_root    1    

Облако 1С

WEB-интеграция Работа с интерфейсом Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Обработка для 1С Предприятие 8.1 предназначена для навигации по справочникам и документам через новый для 1С орган управления - облако. В обработку добавлена ДемоФорма, которую можно назначить основной и посмотреть как построить свое облако.

14.02.2009    19995    644    leksmut    24    

Навеяно кризисом

Универсальные обработки WEB-интеграция Работа с интерфейсом Банковские операции Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Используя эту обработку Вы всегда будете знать состояние кризиса на данный момент :)

11.11.2008    23483    1182    ValeriVP    27    

"WebCam" - ActiveX-компонента для 1С

WEB-интеграция Разработка внешних компонент Платформа 1С v7.7 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv7 Бесплатно (free)

Компонента работает с устройствами, поддерживающими Twain32 драйвер (вебкамеры, фотоаппараты и др.)

28.09.2008    50134    1216    Душелов    77    

Яndex.Погода - узнаем погоду, не отрываясь от работы!

Универсальные обработки WEB-интеграция Платформа 1С v8.3 Россия Бесплатно (free)

Погодный информер от Яндекса, интегрированный в 1С.

18.08.2008    23735    1276    coder1cv8    26    

Загрузка цитат с сайта bash.org.ru

WEB-интеграция Работа с интерфейсом Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Обработка для загрузки цитат с сайта bash.org.ru в таблицу.

08.06.2008    26320    453    Aleksey.Bochkov    11    

Пример работы УРИБД для УТ 8.0

WEB-интеграция Обмен между базами 1C Платформа 1С v8.3 1С:Управление торговлей 10 Россия Бесплатно (free)

Пример работы УРИБД для 1С Управление торговлей 8.0 (тестировалась - УТ 10.2.12.1). Обмен файлами производится через встроенного в конфигурацию почтового клиента.

30.10.2006    11394    637    researcher01    1