Внешняя компонента для безопасной работы с базами данных по интерфейсу ADO

Публикация № 15365 13.12.07

Приемы и методы разработки - Разработка внешних компонент

Внешняя компонента для работы с базами данных по интерфейсу ADO. Приводит типы данных, умеет работать со ссылочными типами 1С:Предприятие.

Чем лучше AdoDB.Connection?


1) Умеет работать с различными типами данных, которые можно привести к строке, числу или дате.
2) Не теряет точность для вещественных чисел
3) Умеет читать дату и время из поля соответствующего типа.
4) Содержит удобный интерфейс для обновления записей (Insert или Update в зависимости от наличия записи с указанными ключивыми полями).
5) Поддерживает параметризацию (невозможно хакнуть программу подменой закавыченных значений).
6) Умеет работать со ссылочными типами 1С:Предприятие (справочники, документы), упаковывая их в 16-символьное представление

Чтение записей

Отличие от традиционного ADODB.Connection - умеет читать самые разные типы данных.

//*******************************************
Процедура Сформировать()
    //Открываем соединение
    ado.Open("Driver={Microsoft Access Driver (*.mdb)};Dbq="+ф_ИмяMDB+";Uid=Admin;Pwd=;");
    
    таб=СоздатьОбъект("Таблица");
    таб.ИсходнаяТаблица("Таблица");
    таб.ВывестиСекцию("Шапка");
    таб.Опции(0);
    
    
     Запрос="SELECT * FROM ТестоваяТаблица;";
    ado.Execute(Запрос);
    
    Пока ado.EOF=0 Цикл //Цикл по записям 
        таб.ВывестиСекцию("Строка|Начало");
        зн=ado.GetField("id"); таб.ПрисоединитьСекцию("Строка|Данные");
        зн=ado.GetField("text1"); таб.ПрисоединитьСекцию("Строка|Данные");
        зн=ado.GetField("memo1"); таб.ПрисоединитьСекцию("Строка|Данные");
        зн=ado.GetField("Байт1"); таб.ПрисоединитьСекцию("Строка|Данные");
        зн=ado.GetField("Целое1"); таб.ПрисоединитьСекцию("Строка|Данные");
        зн=ado.GetField("ДлинноеЦелое1"); таб.ПрисоединитьСекцию("Строка|Данные");
        зн=ado.GetField("Single1"); таб.ПрисоединитьСекцию("Строка|Данные");
        зн=ado.GetField("Double1"); таб.ПрисоединитьСекцию("Строка|Данные");
        зн=ado.GetField("КодРепликации1"); таб.ПрисоединитьСекцию("Строка|Данные");
        зн=ado.GetField("ДатаВремя1"); таб.ПрисоединитьСекцию("Строка|Данные");
        зн=ado.GetFieldAsDateTime("ДатаВремя1"); таб.ПрисоединитьСекцию("Строка|Данные");
        зн=ado.GetField("Денежный1"); таб.ПрисоединитьСекцию("Строка|Данные");
        зн=ado.GetField("Логический1"); таб.ПрисоединитьСекцию("Строка|Данные");
        зн=ado.GetField("Действительное1"); таб.ПрисоединитьСекцию("Строка|Данные");
        ado.MoveNext(); //Переходим к след. записи 
    КонецЦикла;

  ado.Close(); //Закрываем соединение
  таб.Показать("Запрос");
КонецПроцедуры



Добавление записей


В этом примере я использую параметризацию: Prepare и Bind. Это позволяет исключить атаки злоумышленников, или сбои в работе, если я по какой-то причине не проставлю кавычки для экранирования текстовых полей. Полноценная параметризация не реализована.

//____________________________________________________________________________________________________
Процедура ф_Добавить()
  //  //Открываем соединение
  ado.Open("Driver={Microsoft Access Driver (*.mdb)};Dbq="+ф_ИмяMDB+";Uid=Admin;Pwd=;");
  
  //Подготовка запроса
  Запрос="INSERT INTO ТестоваяТаблица (text1,memo1,Байт1,Целое1,ДлинноеЦелое1, Single1, Double1,КодРепликации1,ДатаВремя1,Денежный1,Логический1,Действительное1) VALUES (?,?,?,?,?,?,?,?,?,?,?,?)";
  ado.PrepareQuery(Запрос);
  ado.Bind("это text");
  ado.Bind("это memo");
  ado.Bind(257);
  ado.Bind(32767);
  ado.Bind(9999999);
  ado.Bind(12.34);
  ado.Bind(56.78);
  ado.Bind("{AB634001-F13D-11D0-A459-004095E1DAEA}");
  ado.Bind('26.01.2007');
  ado.Bind(33.33);
  ado.Bind(1);
  ado.Bind(111);
  ado.Execute();
  ado.Close(); //Закрываем соединение
    
КонецПроцедуры



Обновление записей

Данный пример смотрит, есть ли запись с указанным ID. Если ее нет, то добавляет (Insert) ее, затем делает Update.

//____________________________________________________________________________________________________
Процедура ф_Обновить()
  //  //Открываем соединение
  ado.Open("Driver={Microsoft Access Driver (*.mdb)};Dbq="+ф_ИмяMDB+";Uid=Admin;Pwd=;");
     Запрос="SELECT id FROM ТестоваяТаблица WHERE id=?;";
     ado.PrepareQuery(Запрос);
    ado.Bind(1);
    ado.Execute();
    Если ado.EOF=1 Тогда
        Запрос="INSERT INTO ТестоваяТаблица (id) VALUES (?)"; 
        ado.PrepareQuery(Запрос);
        ado.Bind(1);
        ado.Execute();
    КонецЕсли;    
    
      Запрос="UPDATE ТестоваяТаблица SET "+
      "text1=?,memo1=?,Байт1=?,Целое1=?,ДлинноеЦелое1=?, Single1=?, Double1=?,КодРепликации1=?,ДатаВремя1=?,Денежный1=?,Логический1=?,Действительное1=?"+
      " WHERE id=?";
      
      ado.PrepareQuery(Запрос);
      
      ado.Bind("это text");
      ado.Bind("это memo");
      ado.Bind(257);
      ado.Bind(32767);
      ado.Bind(9999999);
      ado.Bind(12.34);
      ado.Bind(56.78);
      ado.Bind("{AB634001-F13D-11D0-A459-004095E1DAEA}");
      ado.Bind('26.01.2007');
      ado.Bind(33.33);
      ado.Bind(1);
      ado.Bind(111);
      ado.Bind(1);
    
      ado.Execute();
          
  ado.Close(); //Закрываем соединение
    
КонецПроцедуры



Удобное обновление записей

Этот пример делает то же самое, что и предыдущий, но записан в более удобном для восприятия виде.
//____________________________________________________________________________________________________
Процедура ф_Обновить1()
  //  //Открываем соединение
  ado.Open("Driver={Microsoft Access Driver (*.mdb)};Dbq="+ф_ИмяMDB+";Uid=Admin;Pwd=;");
  ado.OpenRec("ТестоваяТаблица");
  ado.KeyField("id", 1); //Ключевое поле
  ado.DataField("text1", "это текст");
  ado.DataField("memo1", "это memo");
  ado.DataField("Байт1", 255);
  ado.DataField("Целое1", 32767);
  ado.DataField("ДлинноеЦелое1", 88889999);
  ado.DataField("Single1", 12.34);
  ado.DataField("Double1", 56.78);
  ado.DataField("КодРепликации1", "{AB634001-F13D-11D0-A459-004095E1DAEA}");
  ado.DataField("ДатаВремя1", '26.01.1976');
  ado.DataField("Денежный1", 100.55);
  ado.DataField("Логический1", 1);
  ado.DataField("Действительное1", 1234);
  ado.SaveRec();
  ado.Close(); //Закрываем соединение
    
КонецПроцедуры



Работа со ссылочными типами

Приведенный ниже пример обновляет таблицу, которая содержит код, наименование и ссылку на элемент товаров. Метод GetFieldAsObject("Товар") извлекает товар из таблицы как ссылку на объект 1С:Предприятие!

//____________________________________________________________________________________________________
Процедура ф_Реквизиты()
  //Открываем соединение
  ado.Open("Driver={Microsoft Access Driver (*.mdb)};Dbq="+ф_ИмяMDB+";Uid=Admin;Pwd=;");
  спр=СоздатьОбъект("Справочник.Товары");
  спр.ВыбратьЭлементы();
  Пока спр.ПолучитьЭлемент() = 1 Цикл
     Запрос="SELECT Код FROM Товары WHERE Код=?;";
     ado.PrepareQuery(Запрос);
    ado.Bind(0+спр.Код);
    ado.Execute();
    Если ado.EOF=1 Тогда
        Запрос="INSERT INTO Товары (Код) VALUES (?)"; 
        ado.PrepareQuery(Запрос);
        ado.Bind(0+спр.Код);
        ado.Execute();
    КонецЕсли;    
    
      Запрос="UPDATE Товары SET "+
      "Товар=?,Наименование=?"+
      " WHERE Код=?";
      
      ado.PrepareQuery(Запрос);
      
      ado.Bind(спр.ТекущийЭлемент());
      ado.Bind(спр.Наименование);
      ado.Bind(0+спр.Код);
    
      ado.Execute();
  КонецЦикла;

//Читаем элементы
     Запрос="SELECT * FROM Товары";
    ado.Execute(Запрос);
    
    Пока ado.EOF=0 Цикл //Цикл по записям 
        зн=ado.GetField("Код"); Сообщить("Код="+зн+" ");
        зн=ado.GetField("Наименование"); Сообщить("Наименование="+зн+" ");
        зн=ado.GetFieldAsObject("Товар"); Сообщить("Товар="+зн+" ");
        ado.MoveNext(); //Переходим к след. записи 
    КонецЦикла;
  ado.Close(); //Закрываем соединение
КонецПроцедуры



То же самое, с использованием OpenRec-SaveRec.

//____________________________________________________________________________________________________
Процедура ф_Реквизиты1()
  //Открываем соединение
  ado.Open("Driver={Microsoft Access Driver (*.mdb)};Dbq="+ф_ИмяMDB+";Uid=Admin;Pwd=;");
  
  //Пишем товары в таблицу
  спр=СоздатьОбъект("Справочник.Товары");
  спр.ВыбратьЭлементы();
  Пока спр.ПолучитьЭлемент() = 1 Цикл
      
      ado.OpenRec("Товары");
      ado.KeyField("Код", 0+спр.Код); //Ключевое поле
      ado.DataField("Наименование", спр.Наименование);
      ado.DataField("Товар", спр.ТекущийЭлемент());
      ado.SaveRec();
      
  КонецЦикла;

//Читаем элементы
     Запрос="SELECT * FROM Товары";
    ado.Execute(Запрос);
    
    Пока ado.EOF=0 Цикл //Цикл по записям 
        зн=ado.GetField("Код"); Сообщить("Код="+зн+" ");
        зн=ado.GetField("Наименование"); Сообщить("Наименование="+зн+" ");
        зн=ado.GetFieldAsObject("Товар"); Сообщить("Товар="+зн+" ");
        ado.MoveNext(); //Переходим к след. записи 
    КонецЦикла;
  ado.Close(); //Закрываем соединение
КонецПроцедуры


Получение имен полей по их номеру (13.02.2007)
     Запрос="SELECT * FROM ТестоваяТаблица;";
    ado.Execute(Запрос);
    
    Для й= 0 По ado.КоличествоПолей-1 Цикл
        Сообщить("Имя поля: "+ado.ИмяПоля(й));
    КонецЦикла;

Скачать файлы

Наименование Файл Версия Размер
-

.1197542242 106,55Kb
1479
.1197542242 106,55Kb 1479 Скачать бесплатно

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. German 413 13.12.07 16:43 Сейчас в теме
А если в двух словах чем лучше GameWithFire ?
2. German 413 13.12.07 16:47 Сейчас в теме
3. logarifm 17.12.07 12:10 Сейчас в теме
Но а что мешает сделать для 8.х приммер кода логики есть...
4. OnCheck 11.07.08 09:15 Сейчас в теме
А можно получить время из поля типа время/дата?
5. kanalex 27 26.09.12 13:04 Сейчас в теме
а кому-нить удалось использовать эту dll на 8-ке?
Расскажите как.
Оставьте свое сообщение

См. также

GraphViz1С: внешняя компонента 1С Native API для построения графов Промо

Разработка внешних компонент v8 1cv8.cf Бесплатно (free)

Внешняя компонента Native API для Windows с исходными кодами на C++ для построения графов посредством библиотеки GraphViz. Граф строится на основании текстового описания в формате dot. Реализован экспорт в большинство графических форматов. Поддерживаются версии платформы от 8.3.14 и выше до 8.3.18.

22.12.2020    7548    171    kandr    15    

Делаем табло в обозревателе из 1Ски с нуля за полчаса. Без бутстрапов, реактов и ангуляров. Жизнетрюки от kuzkov.info

Разработка внешних компонент WEB v8 Бесплатно (free)

На Инфостарте много разработок, которые предназначены для отображения в обозревателе данных на связи из 1С. С разными способами подключения, на разных технологиях. Есть платные, есть бесплатные. В данной публикации я хочу показать, как можно сделать сопряжение 1С обозреватель своими 1Сными силами с базовыми навыками верстки с нуля за полчаса и бесплатно.

02.05.2022    2624    112    Steelvan    0    

PinkRabbitMQ - Native API компонента 1С с открытым исходным кодом, для обмена сообщениями через RabbitMQ

Разработка внешних компонент v8 Бесплатно (free)

PinkRabbitMQ представляет собой Native API компоненту для 1С Предприятия 8 (Windows 32bit и 64bit) с открытым исходным кодом на с++ (можно собрать компоненту самостоятельно). PinkRabbitMQ это низкоуровневая компонента которая реализует обмен по протоколу AMQP с брокером сообщений RabbitMQ. Для организации высокоуровнего обмена между информационными базами предназначен Адаптер. Компонента разрабатывается в рамках проекта Адаптер.

29.07.2019    31331    1467    Begemoth80    192    

Внешняя компонента для ping (под win)

Разработка внешних компонент v8 1cv8.cf Бесплатно (free)

Цель: выполнение ping из 1С без использования команд системы. Может быть полезна разработчикам для проверки доступности компьютеров.

05.01.2019    9393    45    milut    4    

Miracle Native - ВК для V8 Промо

Разработка внешних компонент v8 Россия Бесплатно (free)

Настоящая ВК написана по технологии 1С-Native. По методам и свойствам является наследницей MIracveV8 с планируемым развитием функционала. Версия 1.2.1.1 Не триальная, подправлена некорректная работа под х64

23.04.2012    37457    689    Abadonna    81    

Мини-Эверест: Native ВК для 8.х

Разработка внешних компонент v8 1cv8.cf Бесплатно (free)

Список и свойства HDD, список и свойства ОЗУ, список запущенных процессов (для терминала - всех пользователей с указанием номера сессии), список запущенных сервисов, характеристики BIOS

20.08.2014    19358    45    Abadonna    7    

ВК для работы с файлами FilesNative.dll

Разработка внешних компонент v8 1cv8.cf Бесплатно (free)

Компонента реализует некоторые методы работы с файлами (архивами). Поддерживаемые форматы распаковки архивов: ZIP, JAR, XPI, BZ2, BZIP2, TBZ2,TBZ,RAR, R00, ARJ, Z, TAZ, LZH, LHA, 7Z, CAB, LZMA, LZMA86, ISO, XAR, MSI,RPM, TAR, GZ, TGZ, TPZ

18.06.2014    20431    94    Abadonna    9    

NetNative: ВК для работы с сетью

Разработка внешних компонент Сети v8 1cv8.cf Россия Бесплатно (free)

Прослушивание UDP-портов, посылка UDP-сообщений, возможность организации UDP-чата, некоторые сетевые команды. Написана по технологии Native

23.02.2014    23300    177    Abadonna    12    

ICQ и Jabber для 1С Промо

WEB Разработка внешних компонент Россия Бесплатно (free)

Внешняя компонента для обмена сообщениями в сети ICQ и Jabber.

29.10.2006    49691    1046    Душелов    107    

Отслеживание изменений каталога в REAL-TIME: Native ВК для 8.х

Разработка внешних компонент v8 Россия Бесплатно (free)

Давно у меня была задумка отследить, например, появление определенного файла в каталоге базы данных без использования различных таймеров и обработчиков ожидания. Настоящая ВК отслеживает изменения в выбранном каталоге в реальном времени и генерирует в 1С соответствующие внешние события. Выбранный каталог может быть как папкой, так и целым диском.

09.10.2013    24200    274    Abadonna    38    

Внешняя компонента для работы со строками

Разработка внешних компонент v8 Россия Бесплатно (free)

ВК по технологии Native для работы со строками: хеши по различным алгоритмам, крутое шифрование, вычисление релевантности (схожести) строк. Событие переключения подсистем.

20.03.2013    29677    498    Abadonna    105    

ВК для 1С:Предприятие 8.2 NativeAPI на Delphi (запуск приложений, раскладка клавиатуры, события и др.)

Разработка внешних компонент v8 1cv8.cf Россия Бесплатно (free)

Внешняя компонента на основе разработки Крипича http://infostart.ru/public/81644/ - NativeAPI на Delphi реализует запуск процесса с заданным приоритетом и видимостью окна, переключение раскладки клавиатуры, всплывающие сообщения в трее, паузу sleep без загрузки процессора и внешние события.

01.08.2011    51599    1343    romix    57    

1sqlite Промо

Внешние источники данных Разработка внешних компонент Файловые протоколы обмена (TXT, XML, DBF), FTP v77::ОУ v77::БУ v77::Расчет 1cv7.md Бесплатно (free)

Внешняя компонента для работы с базами данных SQLite, плюс прямые запросы в ДБФ-базах 1С.

23.06.2008    66275    5632    orefkov    290    

Драйвер клавиатурного сканера

Разработка внешних компонент v8 Россия Бесплатно (free)

Драйвер сканеров USB-HID (эмуляция клавиатуры) для 1С Предприятие 8.2. Дополнительно может отсылать текст на дисплей покупателя Posiflex PD2601.

13.07.2011    13841    442    Ma_X_X    12    

DLL-Loader: ВК для 1С

Разработка внешних компонент Россия Бесплатно (free)

Иногда хочется с минимальными усилиями добавить какой-нибудь интересный метод для работы с 1С, но писать каждый раз компоненту по технологии создания внешних компонент (ТСВК) от 1С достаточно трудоемко, да и иногда просто лень разбираться. Между тем, написать обычную (не COM, и не AciveX) DLL в состоянии практически любой программист. Кроме того, использование обычной DLL имеет несомненный плюс, заключающийся в отсутствии регистрации ее в реестре, что снимает проблемы недостаточности прав у пользователей без локальных административных прав на данную машину.

13.06.2011    35683    0    Abadonna    44    

Компонента для создания прогрессбара и статус бара на формах 1С 7.7

Разработка внешних компонент v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free)

Компонента предназначена для вывода на формы отчетов или обработок 1С:Предприятие 7.7 прогрессбара и/или статусбара. Написана на VB.Net (.Net 4.0)

01.05.2011    13007    134    Ma_X_X    7    

Thermal Print Library - ActiveX библиотека для печати на термопринтерах Godex BZB2/EZ2/EZ4, C.Itoh EZ2/EZ4, Citizen CLP-521/621

Разработка внешних компонент v8 1cv8.cf 1cv7.md Россия Бесплатно (free)

Библиотека Thermal Print Library является COM сервером и предназначается для использования в любых средах, которые в состоянии выступить в роли OLE-клиента (MS Office, 1С Предприятие, VB, VBScript, и т.д.). Допускается применение со следующими моделями термопринтеров : Godex BZB2/EZ2/EZ4, C.Itoh EZ2/EZ4, Citizen CLP-521/621.

20.09.2010    26133    275    GreenLab    23    

[BackgroundWorker] - Фоновые задания в файловом режиме 1С 8.x

Разработка внешних компонент v8 1cv8.cf Бесплатно (free)

ActiveX-компонента позволяет выполнять задачи в фоне с индикацией прогресса и возможностью прерывания выполнения. Также работает и клиент/серверном варианте, в качестве альтернативы типовым фоновым заданиям

04.03.2010    27448    420    Душелов    15    

Архивация базы 1С-Предприятие

Разработка внешних компонент Архивирование (backup) v8 1cv8.cf Россия Бесплатно (free)

Используем стандартный планировщик Windows и файл Visual Basic Script с файлом настроек, для плановой выгрузки базы данных.

29.12.2009    13850    271    alves    4    

ActiveX - плейер для 1С

Разработка внешних компонент v8 1cv8.cf Россия Бесплатно (free)

Для тех, кто любит всё внутри 1С ;) Форматы: mp3 и wav

01.12.2009    21066    210    Abadonna    39    

Использование визуальных (ActiveX) компонент в тонком клиенте 1С 8.2

Разработка внешних компонент Инструменты администратора БД v8 1cv8.cf Россия Бесплатно (free)

В данной статье рассматривается вопрос использования визуальных компонент (ActiveX) на форме тонкого клиента 1С 8.2 и веб-клиента на базе MS Internet Explorer.

19.11.2009    46489    614    Душелов    59    

Хранитель COM - объектов

Разработка внешних компонент v8 1cv8.cf Россия Бесплатно (free)

Позволяет сохранять COM - объект между серверными вызовами в 8.2. Сохраняет и получает ссылку на объект в ROT (Running Object Table). БЕТА!

18.11.2009    15657    80    Hadgehogs    14    

[GoogleCalendar] ActiveX-компонента для 1С

Разработка внешних компонент Россия Бесплатно (free)

Компонента работает с сервисом Google Calendar. Позволяет создавать новые календари, управлять событиями календарей. Google Calendar — сервис для планирования встреч, событий, дел с привязкой к календарю. Можно задавать время встречи, повторения, напоминания, приглашать других участников (им высылается приглашение по электронной почте).

14.11.2009    96432    472    Душелов    27    

[CursorManager] Внешняя компонента для управления курсором мыши.

Разработка внешних компонент Периферийные устройства Россия Бесплатно (free)

Компонента позволяет выводить процент выполнения обработки данных из 1С, заменяя стандартный 1С-овский курсор. Загружает обычные курсоры из файлов (*.cur) и анимированные (*.ani), а так же системные курсоры. Есть возможность установки курсора на нужное окно (форму) 1С.

28.10.2009    19623    182    Душелов    28    

Выгрузка в OpenOffice Calc. Платформа 7.7. Формирование прайса и формы заказа

Загрузка и выгрузка в Excel Разработка внешних компонент v77::ОУ 1cv7.md Бесплатно (free)

Выгрузка в OpenOffice Calc (форматирование, формулы, гиперссылки, закрепление областей, добавление листов, удаление сетки).

28.10.2009    22102    291    a_shpak    4    

MiracleV8: Расширенная версия

Разработка внешних компонент Загрузка и выгрузка в Excel Россия Бесплатно (free)

Универсальная компонента для 1С 7.7 и 1С 8.x

24.10.2009    71258    4550    Abadonna    350    

Работаем с пропускной системой Perco прямо из 1С

Внешние источники данных Разработка внешних компонент Учет рабочего времени v7.7 1cv7.md Бесплатно (free)

Система работы с карточками пропусков достаточно распространена. Зачастую приходится пользоваться некими выгрузками из этой системы, но можно работать и напрямую. Данная обработка посвящена именно этому.

20.10.2009    26404    349    ge_ni    10    

Универсальная загрузка любых документов из Excel с использованием нечеткого сравнения по реквизиту типа "Справочник"

Загрузка и выгрузка в Excel Обработка документов Разработка внешних компонент v7.7 1cv7.md Бесплатно (free)

В помощь антиглобалистам! Для мелких и очень мелких 1С - это дорого (ноутбук стоит дешевле). Поэтому практикуется такой порядок работы: в центральном офисе выгружают в Excel из 1С "Продажный лист"; торгуют и отмечают продажи в файле; приносят в офис вечером файл результата и загружают отчет о продажах за день. Грузить можно и заявки, и перемещения, и поступления, и списания, и счета, и все для ОС, НМА, МБП... была бы табличная часть!

02.09.2009    24431    907    ge_ni    39    

[SendGoogleSMS] Отправка SMS уведомлений через сервис Google Calendar

WEB SMS рассылки Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Компонента генерирует события в Google Calendar с извещением по SMS. В архивах ВК для 7.7 (работает и в 8-ке) и ActiveX - для работы в контексте сервера 1С 8.х

07.08.2009    33597    557    Душелов    37    

[PDF Viewer] - Просмотр PDF в 1С

Разработка внешних компонент Работа с интерфейсом v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

ActiveX-компонента для просмотра PDF. Позволяет сохранить в виде текста, картинки и PostScript. Реализованы механизмы поиска текста и печати.

15.07.2009    41326    966    Душелов    77    

Набор плагинов для FAR

Разработка внешних компонент Россия Бесплатно (free)

Набор плагинов к FAR

24.06.2009    26475    537    newbas    34    

Элемент управления Scintilla

Разработка внешних компонент v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free)

1sci.dll - внешняя компонента для 1С:Предприятие ВК реализует элемент управления Scintilla. Не требует регистрации в реестре.

15.06.2009    28681    349    steban    32    

Плагин 1С 7.7 для RvAlgo.

Разработка внешних компонент v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free)

RvAlgo - Универсальный инструмент создания корпоративных отчетов и систем анализа данных. Тут представлен плагин, скрипт импорта данных и выполнения OLAP. Пример конфигурации. Вся документация RvAlgo на русском.

28.05.2009    12403    467    metallist    5    

СуперОкна и 1С7.7-8.х

Разработка внешних компонент Россия Бесплатно (free)

внешняя компонента для получения данных из БД СуперОкна в 1С!

20.05.2009    15474    287    zaverax    15    

Подпись к полю ввода в самом поле

Работа с интерфейсом Разработка внешних компонент v8 1cv8.cf Бесплатно (free)

Все чаще в интерфейсе программных продуктов используется новый способ подписи или комментирования полей ввода. Выглядит это так: пока поле пустое - в нем отображается подпись серого цвета, если в поле что то начинают вводить, подпись исчезает.

30.04.2009    20140    322    Stepa86    22    

[IFilter] Поиск в содержании файлов из 1С (ВК, .NET)

Разработка внешних компонент Поиск данных v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Компонента для работы с фильтрами поисковых систем. Получает текст из файла по установленном в системе фильтрам. Индексирует и ищет файлы по их содержанию (аналог Desktop Search) Поддерживает *.doc, *.xls, *.txt, *.ppt. Дополнительные фильтры можно скачать с http://www.ifilter.org/Links.htm

24.03.2009    36955    143    Душелов    44    

[Сервер событий] Клиент + Сервер + Внешние события

Разработка внешних компонент Обмен между базами 1C v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Средство для генерирования событий между разными сеансами, базами и платформами 1С

17.03.2009    25175    150    Душелов    32    

1С - теперь играет и поет! (компонента для проигрывания видео и звука)

Разработка внешних компонент Россия Бесплатно (free)

Ну и жизнь настала, теперь 1С:Предприятие не только отлично считает финансы, но еще может проигрывать звуки и даже показывать видео там, где его показать практически невозможно - хоть на панели инструментов главного окна программы. Но правда, не без помощи WIN32API

08.03.2009    15873    685    developer    30    

[Генератор внешних событий] Внешняя компонента для 1С

Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Компонента генерирует внешние события с заданным интервалом и с заданными значениями.

06.03.2009    44068    1134    Душелов    82    

Внешняя обработка для работы с купюроприемником CashCode SM протокол ССNet.

Разработка внешних компонент Россия Бесплатно (free)

Внешняя обработка для работы с купюроприемником CashCode SM протокол ССNet.

03.03.2009    7632    189    sumerian    9    

[Проверка правописания] - ActiveX-компонента для 1С

Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Компонента проверяет правописание текста. Основана на технологии OpenOffice MySpell. Не требует установленного офиса. В комплекте словари для 5 языков, включая русский (с "ё").

09.02.2009    34204    1137    Душелов    66    

[ExcelEditor] Чтение/запись файла Excel напрямую из 1С без Excel (формат 97/2003)

Загрузка и выгрузка в Excel Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Чтение и запись файла Excel напрямую из 1С Компонента читает и редактирует напрямую файл Excel без загрузки самого Excel (формат Microsoft Office 97/2003)

08.01.2009    54813    1248    Душелов    92