Как сделать простой парсер сложных запросов

Публикация № 194001

Разработка - Инструментарий разработчика

Первым делом скажу, что опишу не столько парсер запросов, сколько анализатор круглых скобок ().
В статье приводится код, адаптированный для управляемых форм.

Как сделать простой парсер сложных запросов.

Первым делом скажу, что опишу не столько парсер запросов, сколько анализатор круглых скобок (). Все очень просто, каждый вложенный запрос берется в круглые скобки, поэтому нам остается проверить на наличие внутри скобок ключевого слова «ВЫБРАТЬ».

Для поиска скобок и ключевого слова частично был задействован механизм регулярных выражений. Все вложенные запросы в Дереве значений добавляются дочерними узлами к ветви запроса. Имя ветви – это имя вложенного запроса. Все параметры запроса будут, для удобства, копироваться в ветви вложенных запросов.

Для распарсивания используется процедура РазобратьЗапрос(), описанная ниже. Обратная процедура СобратьЗапрос() работает следующим образом. В текущем запросе вложенные запросы заменяются запросами из дочерних ветвей дерева запросов. Замена происходит только на текущем уровне, без рекурсии в глубину или на вершину, поэтому сборка происходит последовательно, начиная с нижнего уровня. Это сделано умышленно, давая возможность на каждом уровне проверить после сборки правильность выполнения запроса. Основное требование перед сборкой вложенных запросов – наличие тех же возвращаемых переменных которые были при разборке.

Процедуры и функции я тщательно прокомментировал, так что трудностей с кодом не должно возникнуть. Данный механизм был использован в сторонних консолях запросов. http://forum.infostart.ru/forum24/topic20163/message861068/#message861068
и для управляемых форм http://forum.infostart.ru/forum24/topic61272/message934313/#message934313
В статье приводится код адаптированный для управляемых форм.

&НаКлиенте
Процедура РазобратьЗапрос(Команда)

    // строка запроса
    мТекущаяСтрока = ЭтаФорма.Элементы.ДеревоЗапросов.ТекущиеДанные;

    //сам текст запроса
    ПолныйТекстЗапроса = мТекущаяСтрока.ТекстЗапроса;

    //Формирование массива с адресами скобок и ключевого слова "ВЫБРАТЬ"
    Массив = ПозиционныйМассив(ПолныйТекстЗапроса);
    
    //формирование дочерних ветвей строки нашего запроса
    строки = мТекущаяСтрока.ПолучитьЭлементы();
    строки.Очистить();
        
    Для индекс = 0 по Массив.ВГраница() цикл
        если Массив[индекс][1] = "(" тогда
            индекс = СозданиеВетви(Массив, индекс, мТекущаяСтрока, ПолныйТекстЗапроса);    
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры


&НаКлиенте
Процедура СобратьЗапрос(Команда)
    мТекущаяСтрока = ЭтаФорма.Элементы.ДеревоЗапросов.ТекущиеДанные;
    ПолныйТекстЗапроса = мТекущаяСтрока.ТекстЗапроса;
    
    //Формирование массива с с адресами скобок и ключевого слова "ВЫБРАТЬ"
    Массив = ПозиционныйМассив(ПолныйТекстЗапроса);
    
    строки = мТекущаяСтрока.ПолучитьЭлементы();
    РазмерМассива = строки.Количество();
    Если РазмерМассива > 0 тогда
        //формируем массив вложенных запросов
        Фрагмент = Новый Массив(РазмерМассива) ;  
        номерВетви = 0;
        Для каждого строка из строки цикл
            Фрагмент[номерВетви] = строка.ТекстЗапроса;    
            номерВетви = номерВетви + 1;
        КонецЦикла;
        
        //заменяем подзапрос в запросе на запрос из массива дочерних запросов
        номерВетви = 0;
        сдвиг = 0;
        длинаТекста = СтрДлина(ПолныйТекстЗапроса);
        Для индекс = 0 по Массив.ВГраница() цикл
            если Массив[индекс][1] = "(" тогда
                //поиск индекса соответствующей закрывающейся скобки
                индексВозврата = ВГлубину(Массив, индекс);                 
                
                //замена вложеного запроса
                ПолныйТекстЗапроса = Лев(ПолныйТекстЗапроса,Массив[индекс][0]+1+сдвиг) + Фрагмент[номерВетви] + Прав(ПолныйТекстЗапроса, длинаТекста-Массив[индексВозврата][0]);
                
                //вычисление смещения адресации
                сдвиг = сдвиг + СтрДлина(Фрагмент[номерВетви]) - (Массив[индексВозврата][0]-Массив[индекс][0]-1);
                
                номерВетви = номерВетви + 1;
                индекс = индексВозврата;    
            КонецЕсли;
        КонецЦикла;
        
        мТекущаяСтрока.ТекстЗапроса = ПолныйТекстЗапроса;
    КонецЕсли;
    
КонецПроцедуры




&НаКлиенте
Функция ПозиционныйМассив(ПолныйТекстЗапроса)
    //формирование массивов с адресами скобок и ключевого слова
    Открытие = МассивВхождений(ПолныйТекстЗапроса, "\(");     
    Закрытие = МассивВхождений(ПолныйТекстЗапроса, "\)");     
    Выбрать = МассивВхождений(ПолныйТекстЗапроса, "ВЫБРАТЬ");
    
    //объединение трех массивов в один с сортировкой адресов по возрастанию    
    Массив = СложитьМассивы(Открытие, Закрытие);
    Массив = СложитьМассивы(Массив, Выбрать);

    //удаление информации о не значимых скобках
    УбратьВсеДоСкобки(Массив);
    удалено = 1;
    Пока удалено > 0 цикл
        удалено = УбратьЛишниеСкобки(Массив);
    КонецЦикла;
    
    Возврат Массив;

КонецФункции // ПозиционныйМассив()


&НаКлиенте
Функция МассивВхождений(текст, подстрока, предел = Неопределено)
     //для поиска используем регулярные выражения
RegExp = Новый COMОбъект("VBScript.RegExp");
    RegExp.IgnoreCase = Истина; //Игнорировать регистр
    RegExp.Global = Истина; //Поиск всех вхождений шаблона
    RegExp.MultiLine = Истина; //Многострочный режим
    
    RegExp.Pattern = подстрока;
    Matches=RegExp.Execute(текст);
    ЧислоВхождений=Matches.Count();

    //определяемся с длиной массива вхождений
    если предел = Неопределено тогда
        предел = ЧислоВхождений;
    иначеесли ЧислоВхождений < предел тогда
        предел = ЧислоВхождений;
    КонецЕсли;

    Если предел > 0 тогда
        //формирование массива с адресами вхождений подстроки
        Массив = Новый Массив(предел,2);     
        Для СубСчетчик = 0 По предел-1 Цикл
            SubMatch = Matches.Item(СубСчетчик);
            Массив[СубСчетчик][0] = SubMatch.FirstIndex;    //адрес
            Массив[СубСчетчик][1] = SubMatch.Value;    //значение
        КонецЦикла;
    иначе
        Массив = Неопределено;
    КонецЕсли;
    
    Возврат Массив;
КонецФункции // МассивВхождений()


// объединение массивов с сортировкой по возрастанию
&НаКлиенте
Функция СложитьМассивы(Массив1, Массив2)
    Если Массив1 = Неопределено тогда
        ВГраница1 = -1;
    иначе
        ВГраница1 = Массив1.ВГраница();
    КонецЕсли;
    
    Если Массив2 = Неопределено тогда
        ВГраница2 = -1;
    иначе
        ВГраница2 = Массив2.ВГраница();
    КонецЕсли;
    
    РазмерМассива = ВГраница1+ВГраница2+2;
    Если РазмерМассива > 0 тогда
        Массив = Новый Массив(ВГраница1+ВГраница2+2,2);
        индекс1 = 0;
        индекс2 = 0;
        Для индекс = 0 по Массив.ВГраница() цикл
            если индекс1 > ВГраница1 тогда
                Массив[индекс][0] = Массив2[индекс2][0];
                Массив[индекс][1] = Массив2[индекс2][1];
                индекс2 = индекс2+1;
            иначеесли индекс2 > ВГраница2 тогда
                Массив[индекс][0] = Массив1[индекс1][0];
                Массив[индекс][1] = Массив1[индекс1][1];
                индекс1 = индекс1+1;
            иначеесли Массив1[индекс1][0] < Массив2[индекс2][0] тогда
                Массив[индекс][0] = Массив1[индекс1][0];
                Массив[индекс][1] = Массив1[индекс1][1];
                индекс1 = индекс1+1;
            иначе
                Массив[индекс][0] = Массив2[индекс2][0];
                Массив[индекс][1] = Массив2[индекс2][1];
                индекс2 = индекс2+1;
            КонецЕсли;
            
        КонецЦикла;
        Возврат Массив;
    иначе
        Возврат Неопределено;
    КонецЕсли;
КонецФункции // СложитьМассивы()

//убираем все до первой открывающейся скобки
&НаКлиенте
Функция УбратьВсеДоСкобки(Массив)
        индекс = 0;
    удалено = 0;
    
    Пока индекс         если Массив[индекс][1] = "(" тогда
            Прервать;    
        иначе
            Массив.Удалить(индекс);
            удалено = удалено + 1;
        КонецЕсли;
    КонецЦикла;

    Возврат удалено;    
КонецФункции // УбратьВсеДоСкобки()

// удаление пар скобок не содержащих ключевого слова «ВЫБРАТЬ»
&НаКлиенте
Функция УбратьЛишниеСкобки(Массив)
        индекс = 0;
    удалено = 0;
    
    Пока индекс         если Массив[индекс][1] = "(" и Массив[индекс+1][1] = ")" тогда
            Массив.Удалить(индекс);
            Массив.Удалить(индекс);
            удалено = удалено + 1;
        иначе
            индекс = индекс + 1;
        КонецЕсли;
    КонецЦикла;

    Возврат удалено;    
КонецФункции // УбратьЛишниеСкобки()

// рекурсивная функция для создания ветвей вложенных запросов
&НаКлиенте
Функция СозданиеВетви(Массив, ВходящийИндекс, Родитель, ПолныйТекстЗапроса)
    Ветви = Родитель.ПолучитьЭлементы();
    мТекущаяСтрока = Ветви.Добавить();                 //ветвь подзапроса
    СкопироватьПараметры(Родитель, мТекущаяСтрока); //копирование параметров запроса
    
    Для индекс = ВходящийИндекс+1 по Массив.ВГраница() цикл
        если Массив[индекс][1] = "(" тогда
            //если у текущего запроса есть вложеный запрос, то делаем рекурсивно дочернюю ветвь
            индекс = СозданиеВетви(Массив, индекс, мТекущаяСтрока, ПолныйТекстЗапроса);    
        иначеесли Массив[индекс][1] = ")" тогда
            //встречен конец текущего запроса
            Прервать;
        КонецЕсли;
    КонецЦикла;

    запрос = Сред(ПолныйТекстЗапроса, Массив[ВходящийИндекс][0]+2, Массив[индекс][0]-Массив[ВходящийИндекс][0]-1);

    //формирование имени подзапроса
    если индекс < Массив.ВГраница() тогда
        //фрагмент между закрывающейся и следующей скобкой
        строка = Сред(ПолныйТекстЗапроса, Массив[индекс][0]+1, Массив[индекс+1][0]-Массив[индекс][0]);
    иначе
        //фрагмент запроса за закрывающейся скобкой
        строка = Сред(ПолныйТекстЗапроса, Массив[индекс][0]+1, СтрДлина(ПолныйТекстЗапроса)-Массив[индекс][0]);
    КонецЕсли;
    
    имя = НайтиИмя(строка);
    
    если имя = "БезИмени" тогда
        имя = имя+индекс;
    КонецЕсли;
    
    мТекущаяСтрока.ИмяЗапроса = имя;                 
    мТекущаяСтрока.ТекстЗапроса = запрос;
    Возврат индекс;    
КонецФункции // СозданиеВетви()

&НаКлиенте
Процедура СкопироватьПараметры(Родитель, мТекущаяСтрока)
    мТекущаяСтрока.ПараметрыЗапроса.Очистить();
    Для каждого парам из Родитель.ПараметрыЗапроса цикл
        новыйПарам = мТекущаяСтрока.ПараметрыЗапроса.Добавить();
        новыйПарам.ИмяПараметра = парам.ИмяПараметра;
        новыйПарам.СпособУстановки = парам.СпособУстановки;
        новыйПарам.ЗначениеПараметра = парам.ЗначениеПараметра;
        новыйПарам.ТипЗначения = парам.ТипЗначения;
    КонецЦикла;
КонецПроцедуры

//вычисление имени подзапроса по фрагменту за закрывающейся скобкой
&НаКлиенте
Функция НайтиИмя(текст)
    если СтрДлина(СокрЛП(текст)) > 0 тогда
        //анализ связки пробел-неПробел до 3 элементов
        //идея следующая
        //если 0-й адрес за закрывающейся скобкой ключевое слово "КАК"
        //значит имя между 1-ым и 2-ым адресами
        Массив = МассивВхождений(текст, "\s\S", 3);
        если Массив = Неопределено тогда
            имя = "БезИмени";
        иначеесли Массив.ВГраница() = 2 тогда
            как = ВРег(СокрЛП(Сред(текст, Массив[0][0]+1, Массив[1][0]-Массив[0][0])));
            если как = "КАК" тогда
                имя = СокрЛП(Сред(текст, Массив[1][0]+2, Массив[2][0]-Массив[1][0]-1));
            иначе
                имя = "БезИмени";
            КонецЕсли;    
        иначеесли Массив.ВГраница() = 1 тогда
            имя = СокрЛП(Сред(текст, Массив[1][0]+2, СтрДлина(текст)-Массив[1][0]-1));
        иначе
            имя = "БезИмени";
        КонецЕсли;
    иначе
        имя = "БезИмени";
    КонецЕсли;
    
    Возврат имя;
КонецФункции // НайтиИмя()

//рекурсивная функция для поиска закрывающейся скобки, соответствующей скобке и индексом «ВходящийИндекс»
&НаКлиенте
Функция ВГлубину(Массив, ВходящийИндекс)
    Для индекс = ВходящийИндекс+1 по Массив.ВГраница() цикл
        если Массив[индекс][1] = "(" тогда
            индекс = ВГлубину(Массив, индекс);    
        иначеесли Массив[индекс][1] = ")" тогда
            Прервать;
        КонецЕсли;
    КонецЦикла;
    
    Возврат индекс;
КонецФункции // ВГлубину()


Скачать файлы

Наименование Файл Версия Размер
Как сделать простой парсер сложных запросов.txt
.txt 10,85Kb
11.07.13
14
.txt 10,85Kb 14 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. y22-k 229 11.07.13 10:31 Сейчас в теме
Переписать все под пакетные запросы не?
2. blockcode 32 11.07.13 11:00 Сейчас в теме
а нужно ли?
в пакетном режиме выполняются отлаженные запросы, а распарсивание и отладка выполняется для каждого запроса отдельно.
4. blockcode 32 12.07.13 08:17 Сейчас в теме
Нужно - значит сделаю... со временем))
Там делов-то, каждый запрос пакета обработать как вложенный запрос и проблема сводится к уже решенной. Код я выложил, т.ч. кому интересно можете доработать))))
5. DrAku1a 1311 17.07.13 02:25 Сейчас в теме
пробный парсер запросов:
http://infostart.ru/public/137294/

и его применение
http://infostart.ru/public/190493/
blockcode; +1 Ответить
6. CagoBHuK 32 18.07.13 11:04 Сейчас в теме
Использовать регулярные выражения, не?
7. blockcode 32 18.07.13 11:20 Сейчас в теме
Я их частично использовал... Не хватило терпения построить полноценное регулярное выражение, чтобы избавиться от пары лишних функций. На функциональности это не отразилось, а вот красота написания кода пострадала... Предложения помощи приветствуются. ))
Оставьте свое сообщение

См. также

Вам нравятся запросы в 1С?

Инструменты и обработки Программист Конфигурация (md, cf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования Разработка

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    13499    4    m-rv    86       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Модель объекта

Инструменты и обработки Программист Конфигурация (md, cf) v8 Абонемент ($m) Инструментарий разработчика

Подсистема позволяет описать модель данных объекта, где описана зависимость между реквизитами, и затем использовать эту модель в разных сценариях работы с объектом. Версия платформы: 8.3.6 и выше. С небольшими доработками будет работать на 8.2.

1 стартмани

30.06.2019    5951    1    vadim1980    4       

Безопасная работа с транзакциями во встроенном языке

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    21061    9    tormozit    44       

Управление ИТ-проектами. Модуль 2: продвинутый онлайн-курс по классическим методам управления проектами. Вебинары проходят с 12 марта по 11 июня 2020 года. Промо

Продвинутый онлайн-курс по классическому управлению ИТ-проектами позволит слушателям освоить инструменты из PMBoK® и 1С:Технологии корпоративного внедрения и научиться их применять для проектов любого масштаба. Курс включает в себя 12 вебинаров и 12 видеолекции, разбор кейсов и рекомендации экспертов по проектам слушателей. Ведущая курса - Мария Темчина.

от 13000 рублей

Редактор объектов информационной базы 8.3

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Windows Абонемент ($m) Инструментарий разработчика Универсальные обработки

Универсальная внешняя обработка для редактирования реквизитов и табличных частей объектов информационной базы, редактирование движений документов. Доступ ко всем реквизитам объектов, есть возможность выгрузки и загрузки данных (объекты и движения документов) через XML. Платформа 8.3, управляемые формы. Версия 1.1.0.37 от 14.12.2019

2 стартмани

23.01.2019    14979    188    ROL32    29       

Конструктор мобильного клиента Simple WMS Client: способ создать полноценный ТСД без мобильной разработки. Теперь новая версия - Simple UI (обновлено 14.11.2019)

Инструменты и обработки Программист Архив с данными v8 v8::Mobile БУ УУ Android Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Абонемент ($m) Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Мобильная разработка

Simple WMS Client – это визуальный конструктор мобильного клиента для терминала сбора данных(ТСД) или обычного телефона на Android. Приложение работает в онлайн режиме через интернет или WI-FI, постоянно общаясь с базой посредством http-запросов (вариант для 1С-клиента общается с 1С напрямую как обычный клиент). Можно создавать любые конфигурации мобильного клиента с помощью конструктора и обработчиков на языке 1С (НЕ мобильная платформа). Вся логика приложения и интеграции содержится в обработчиках на стороне 1С. Это очень простой способ создать и развернуть клиентскую часть для WMS системы или для любой другой конфигурации 1С (УТ, УПП, ERP, самописной) с минимумом программирования. Например, можно добавить в учетную систему адресное хранение, учет оборудования и любые другие задачи. Приложение умеет работать не только со штрих-кодами, но и с распознаванием голоса от Google. Это бесплатная и открытая система, не требующая обучения, с возможностью быстро получить результат.

5 стартмани

09.01.2019    30099    245    informa1555    200       

1C:Предприятие для программистов: Расчетные задачи (зарплата). Онлайн-интенсив с 01 по 17 июня 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для автоматизации периодических расчетов, а именно - для расчета зарплаты. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Зарплата и управление персоналом” и прочих прикладных решений, в которых реализован функционал расчета зарплаты.

4900 рублей

Навигатор по конфигурации базы 1С 8.3

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Windows Абонемент ($m) Инструментарий разработчика Универсальные обработки

Универсальная внешняя обработка (СДРНавигаторУпр) для просмотра метаданных конфигураций баз 1С 8.3. Отображает свойства и реквизиты объектов конфигурации, их количество, основные права доступа и т.д. Отображаемые характеристики объектов: свойства, реквизиты, стандартные рекизиты, реквизиты табличных частей, предопределенные данные, регистраторы для регистров, движения для документов, команды, чужие команды, подписки на события, подсистемы. Отображает структуру хранения объектов базы данных, для регистров доступен сервис "Управление итогами". Небольшой набор сервисных функций для повседневной работы. Для программистов и пользователей. Платформа 8.3, управляемые формы. Версия 1.1.0.51 от 08.01.2020

3 стартмани

28.10.2018    21136    219    ROL32    63       

Работа с публикациями "Инфостарт"

Инструменты и обработки Программист Архив с данными v8 УУ Абонемент ($m) Практика программирования О сообществе WEB

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    12413    12    RocKeR_13    16       

Базовый курс по обмену данными в системе 1С:Предприятие. Онлайн-интенсив с 12 по 28 мая 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, обеспечивающих обмен данными между различными прикладными 1С-решениями и взаимодействие с другими информационными системами. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”.

5500 рублей

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструменты и обработки Программист Бизнес-аналитик Приложение (apk) v8 Windows Абонемент ($m) Инструментарий разработчика Практика программирования

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    19394    25    informa1555    26       

Работа с данными выбора

Инструменты и обработки Программист Архив с данными v8 Россия Абонемент ($m) Практика программирования Работа с интерфейсом

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    29352    17    kalyaka    16       

​​​​​​​CorelDRAW Graphics Suite 2019 Промо

CorelDRAW – пакет профессиональных инструментов для редактирования фотографий, разработки дизайна, создания макетов страниц и векторных иллюстраций

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар")

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    22521    86    m-rv    57       

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования БСП (Библиотека стандартных подсистем)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    33495    31    dsdred    36       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Как выполнить отчет на СКД через COM и получить данные отчета?

Статья Программист Архив с данными v8 УПП1 Россия Windows Абонемент ($m) Практика программирования

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    20771    11    wowik    3       

Работа со схемой запроса

Статья Программист Конфигурация (md, cf) v8 v8::Запросы Абонемент ($m) Инструментарий разработчика Практика программирования

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    33669    77    kalyaka    34       

Голосование за доклады на INFOSTART MEETUP Kazan - до 25 февраля. Промо

Выбирайте и голосуйте за самые интересные доклады! Лучшие из лучших попадут в окончательную программу казанского митапа. Оставить свой голос можно до 25 февраля 2020 года.

Заполняем по шаблону (по умолчанию)

Инструменты и обработки Программист Архив с данными v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    20286    20    mvxyz    17       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Бесплатная проверка контрагентов в ФНС (общий модуль с алгоритмом). На примере выводим статус в список справочника контрагентов

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования

Если вам интересно проверить контрагенте в ФНС, вам поможет данная публикация. Весь алгоритм работы строится на основе данных, полученных с сервиса http://npchk.nalog.ru совершенно бесплатно.

1 стартмани

01.02.2018    28618    63    rpgshnik    48       

Расширение возможностей печати: Вывод произвольного нижнего и верхнего колонтитула

Отчеты и формы Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Печатные формы документов Практика программирования Универсальные функции

Расширяем функционал вывода нижнего / верхнего колонтитула. Стандартно 1С имеет достаточно ограничений по выводу и наполнению колонтитулов содержимым, взять хотя бы такие, как вывод только текста и отсутствие ограничения на номер конечной страницы. А при разработке кода сталкиваешься с тем, что свой блок с нижним колонтитулом нужно прижимать к низу страницы. Казалось бы быстро решаемый вопрос, но и в нем есть нюансы. Сейчас я расскажу о том, как решалась эта задача. UPD 15.02.2018. Добавлен вывод верхнего колонтитула; Вывод колонтитулов на первой и последней странице управляется параметрами; Научился считать страницы: Добавлено заполнение переменных аналогичных стандартным из колонтитулов; Задаются форматы даты и времени. Ограничения прежние: 1. Повторно сформировать табличный документ после смены параметров страницы интерактивно.; 2. Передавать данные для более плотной печати как можно более мелко нарезанными кусками.

1 стартмани

29.12.2017    27869    25    agent00mouse    0       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Инструменты и обработки Программист Расширение (cfe) v8 БП3.0 Абонемент ($m) Практика программирования Универсальные печатные формы

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    20956    52    kwazi    6       

Программное формирование форматированной строки в стиле html+inline CSS

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом Инструментарий разработчика

Если вам приходилось работать с форматированными строками программно, то вы знаете, какая это боль. Данное решение облегчает программное формирование таких строк.

1 стартмани

18.11.2017    23339    29    bonv    9       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Расширения конфигураций 1С: учимся перехватывать методы

Инструменты и обработки Программист Расширение (cfe) v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    99039    14    signum2009    45       

Многопоточность. Универсальный «Менеджер потоков» (фреймворк) с отслеживанием зависимости объектов

Статья Программист Архив с данными v8 1cv8.cf Россия Абонемент ($m) Практика программирования Математика и алгоритмы Универсальные функции Производительность и оптимизация (HighLoad)

Восстановление партий, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

26.05.2017    42429    168    DarkAn    86       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Набор подсистем "Умные таблицы"

Инструменты и обработки Системный администратор Программист Архив с данными v8 Беларусь Россия Казахстан Абонемент ($m) Инструментарий разработчика

Данный набор подсистем – прикладная библиотека, призванная помочь программисту 1С быстрее решать ряд типовых задач бизнес-логики, таких как: ведение статусов объектов, отправка почтовых сообщений в определенное время, ведение произвольных таблиц с возможностью редактирования, сохранения и группировки, ориентированные на расчет бюджетных таблиц (план продаж, ретробонусы B2C, проценты по договорам B2B и договорные условия по КАМ), расчет коммерческой политики для бюджетных таблиц, исполнение произвольных алгоритмов с хранением кода в информационной базе, определение рабочих баз, хранение файлов во внешних СУБД (Postgre SQL, MS SQL и MongoDB) и выполнение произвольного кода после изменений ссылочного объекта вне транзакции изменения.

1 стартмани

22.05.2017    27044    99    Silenser    33       

Простой способ индексирования интервалов

Статья Программист Конфигурация (md, cf) v8 Абонемент ($m) Практика программирования

Предлагается простой способ индексирования интервалов для решения задач выборки записей, включающих заданный момент времени, пересекающихся с заданным интервалом или множеством интервалов. Способ основан на добавлении к исходной таблице особого числового индексированного поля, рассчитываемого по специальной формуле. Приведен код функций, необходимых для расчетов поля поиска и параметров поисковых запросов. Приведены также результаты тестирования метода, доказывающие его высокую эффективность.

1 стартмани

28.09.2016    34800    39    ildarovich    22       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Конструктор-тестер http запросов в 1С

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) WEB Инструментарий разработчика

Данная обработка позволяет в несколько кликов конструировать http запросы на языке 1С и просматривать результаты их выполнения.

3 стартмани

19.08.2016    36450    304    hlopik    17       

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут

Инструменты и обработки Системный администратор Программист Компонента, плагин (dll, vbs,..) v8 Windows Абонемент ($m) Практика программирования

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    41269    35    Demanoidos    60