Демонстрационная конфигурация работы с API ВКонтакте

Публикация № 195276

Разработка - Системная интеграция - Интеграция с WEB

130
В статье представлен обзор работы с API ВКонтакте из 1С. А так же рассматривается демонстрационная конфигурация по работе с API.

Создание приложения "ВКонтакте".

Прежде чем приступить к работае с API необходимо создать приложение, от имени которого будут выполняться все действия (размещение записей и фотографий на стене, добавление и чтение комментариев, чтение данных пользователя и т.п).

Для создания приложения необходимо перейти по этой ссылке: https://vk.com/editapp?act=create

На станице создания приложения необходимо ввести название вашего приложения и выбрать тип "Standalone-приложение".

Для подтверждения действия необходимо получить на мобильный телефон сообщение с кодом.

В результате будет создано приложение. Смысл всех этих действий в получении ID приложения, которое и будет использоваться в запросах к API.

Авторизация на сайте ВКонтакте.

Перед работой с API необходимо авторизироваться. ВКонтакте используется способ авторизации OAuth 2.0.

Если в кратце и попростому, то необходимо открыть браузер, перейти по определнному адресу на странице, на которой необходимо ввести данные пользователя. После успешной авторизации возвращается access_token. Его и нужно сохранить, так как он будет использоваться в запросах.

Более подробную информацию можно посмотреть здесь: http://vk.com/dev/auth_mobile

Я же опишу как все это можно реализовать на 1С.

Необходимо создать обработку для авторизации. На форму вывести поле HTML документа (элемент формы ПолеHTMLДокумента). При открытии формы переходить по адресу

https://oauth.vk.com/authorize?client_id=&scope=&redirect_uri=http://api.vk.com/blank.html&display=page&response_type=token

Ниже приведен пример кода. Переход на страницу вставлен в процедуру "ПриОткрытии()"

Процедура ПриОткрытии()
	
	ЭлементыФормы.ПолеHTMLДокумента1.Перейти("https://oauth.vk.com/authorize?client_id=12345" +
		"&scope=photos,wall,offline&redirect_uri=http://api.vk.com/blank.html&" +
		"display=page&response_type=token");
	
КонецПроцедуры

Со списком прав доступа можно ознакомиться на этой странице: http://vk.com/dev/permissions

Единственное, что можно упомянуть - это то, что если вы не хотите постоянно авторизироваться (по умолчанию access_token действует сутки, после чего его необходимо вновь получать), используйте параметр доступа offline. В таком случае срок действия access_token будет неограничен и авторизация потребуется только один раз.

После того, как пользователь верно введен пароль и разрешит приложению использовать необходимые данные будет произведен переход по адресу типа http://api.vk.com/blank.html#access_token=a1dfc7ef2b763d776350375f8a22678a59f28e1ac7e090b4a8486274564d38e9e8a069d10e596223d80d7&expires_in=0&user_id=5184504. Остается отследить такой переход и извлеч из строки адреса необходимую информацию (обымно требуется только access_token).

Для этого необходимо обрабатывать событие "ДокументСформирован" элемента "ПолеHTMLДокумента".

Ниже приведен пример обработки данного события.

Процедура ПолеHTMLДокумента1ДокументСформирован(Элемент)
	
	access_token = "";
	
	Если Элемент.Документ.location.host = "api.vk.com" Тогда
		hash = Сред(Элемент.Документ.location.hash, 2);
		МассивСтрок = СтроковыеФункцииКлиентСервер.РазложитьСтрокуВМассивПодстрок(hash, "&");
		
		Для каждого Параметр ИЗ МассивСтрок Цикл
			
			ИмяПараметра = "";
			ЗначениеПараметра = "";
			
			Поз = Найти(Параметр, "=");
			Если Поз = 0 Тогда
				ИмяПараметра = Параметр;
				ЗначениеПараметра = "";
			Иначе
				ИмяПараметра = НРег(СокрЛП(Лев(Параметр,Поз-1)));
				ЗначениеПараметра = СокрЛП(Сред(Параметр, Поз+1));
			КонецЕсли;
			
			Если ИмяПараметра = "access_token" Тогда
				access_token = ЗначениеПараметра;
			КонецЕсли;
			
		КонецЦикла;
		
		Константы.access_token = access_token;
		
		Закрыть();
	КонецЕсли;
	
КонецФункции

Отправка запросов к API ВКонтакте.

После того, как получен access_token можно выполнять запросы к API.

Для этого производится GET запрос по определенному адресу и читается ответ. Общий вид HTTP адреса выглядит следующим образом:

https://api.vk.com/method/ИМЯ_МЕТОДА.xml?параметр1=значение1&параметрN=значениеN&access_token=a1dfc7ef2b763d776350375f8a22678a59f28e1ac7e090b4a8486274564d38e9e8a069d10e596223d80d7

Например, для размещения записи "Привет, ВКонтакт!" на стене пользователя http://vk.com/id5184504 будет такой адрес:

https://api.vk.com/method/wall.post.xml?owner_id=5184504&message=Привет, ВКонтакт!&access_token=a1dfc7ef2b763d776350375f8a22678a59f28e1ac7e090b4a8486274564d38e9e8a069d10e596223d80d7

Примечание. Если необходимо произвести действие со стеной группы, то в owner_id устанавливается значение со знаком "-".

Ниже приведен код процедуры, выполняющий запросы к API (следует заметить что используется HTTPS соединение).

Процедура ВызватьМетодAPI(ИмяМетода, Параметры, access_token) Экспорт
	
	ИмяВыходногоФайла = ПолучитьИмяВременногоФайла("xml");
	
	Соединение = Новый HTTPСоединение("api.vk.com",,,,, Истина);
	
	Соединение.Получить("method/" + ИмяМетода + ".xml?" +
				?(ТипЗнч(Параметры) = Тип("Строка"), Параметры + ?(ЗначениеЗаполнено(Параметры), "&", "") + "access_token="+access_token,
				СформироватьСтрокуПараметровЗапроса(Параметры, access_token)),
				ИмяВыходногоФайла);
	
КонецПроцедуры

Описание всех методов вы можете найти на странице для разработчиков ВКонтакте: http://vk.com/dev/methods

Отправка фотографий.

Как производить отправку фотографий можно прочитать в документации ВКонтакте (или посмотреть в демонстационной конфигурации). В этой статье я хочу остановиться лишь на одном моменте.

Изображение отправляется методом POST. Отправляемый файл имеет следующую структуру:

--0123456789
Content-Disposition: form-data; name="photo"; filename="image.jpg"
Content-Type: image/jpeg




--0123456789

где 0123456789 - Boundary: некая последовательность символов. Так же необходимо установить HTTP заголовки Content-Type и Content-Length.

Так как в 1С нет методов для работы с двоичными файлами был придуман следующий способ. Формируются 2 текстовый файла: с началом конченого файла:

--0123456789
Content-Disposition: form-data; name="photo"; filename="image.jpg"
Content-Type: image/jpeg

и окончанием

--0123456789

Итого получается 3 файла:

1. текстовый файл с началом
2. само изображение
3. текстовый файл с окончанием

Используя метод "ОбъединитьФайлы" соединяем 3 файла в один и отправляем уже полученный файл.

Ниже приведен код демонстирующий отправку файла. 

ИмяВходногоФайла = ПолучитьИмяВременногоФайла("in");
ИмяВходногоФайла1 = ПолучитьИмяВременногоФайла("in1");
ИмяВходногоФайла2 = ПолучитьИмяВременногоФайла("in2");
ИмяВходногоФайла3 = ПолучитьИмяВременногоФайла("in2");
ИмяВыходногоФайла = ПолучитьИмяВременногоФайла("out");

Boundary = СтрЗаменить(Строка(Новый УникальныйИдентификатор()), "-", "");

ВходнойФайл = Новый ЗаписьТекста(ИмяВходногоФайла1, КодировкаТекста.ANSI, Символы.ПС);
ВходнойФайл.ЗаписатьСтроку("--"+Boundary);
ВходнойФайл.ЗаписатьСтроку("Content-Disposition: form-data; name=""photo""; filename=""image.jpg""");
ВходнойФайл.ЗаписатьСтроку("Content-Type: image/jpeg");
ВходнойФайл.ЗаписатьСтроку("");
ВходнойФайл.Закрыть();

Изображение.Записать(ИмяВходногоФайла2);

ВходнойФайл = Новый ЗаписьТекста(ИмяВходногоФайла3, КодировкаТекста.ANSI, Символы.ПС);
ВходнойФайл.ЗаписатьСтроку("");
ВходнойФайл.ЗаписатьСтроку("--"+Boundary);
ВходнойФайл.Закрыть();

МассивФайлов = Новый Массив;
МассивФайлов.Добавить(ИмяВходногоФайла1);
МассивФайлов.Добавить(ИмяВходногоФайла2);
МассивФайлов.Добавить(ИмяВходногоФайла3);

ОбъединитьФайлы(МассивФайлов, ИмяВходногоФайла);

ФайлОтправки = Новый Файл(ИмяВходногоФайла);
РазмерФайлаОтправки = XMLСтрока(ФайлОтправки.Размер());

ЗаголовокHTTP = Новый Соответствие;
ЗаголовокHTTP.Вставить("Content-Type", "multipart/form-data; boundary="+Boundary);
ЗаголовокHTTP.Вставить("Content-Length", РазмерФайлаОтправки);

Соединение = Новый HTTPСоединение(АдресЗагрузки);
Соединение.ОтправитьДляОбработки(ИмяВходногоФайла, АдресРесурса, ИмяВыходногоФайла, ЗаголовокHTTP);

Прикрепление карты к сообщению на стене.

В текущей реализации API отсутствует возможность прикрепления карты к сообщению. Что бывает не очень удобно. Например, если в сообщении идет речь о какой-нибудь проводимой акции, то хорошо бы было к нему прикрепить карту с местом проведения акции. Данная задача была решена мной следующим образом: обращением к Google Maps API получается изображение карты, а потом оно прикрепляется к сообщению как обычная картина.

Для того, чтобы получить изображение карты с нужным местом необходимо отправить запрос по адресу

http://maps.google.com/maps/api/staticmap?center=LAT,LONG&zoom=14&size=320x100&maptype=roadmap&markers=color:red%7Ccolor:red%7Clabel:C%7CLAT,LONG&sensor=false

где LAT и LONG географические координаты места. Описание остальных параметров можно найти в описании Google Maps API. Скажу лишь, что приведенные в данном примере по моему мнению являются оптимальными и их можно не менять. В ответ приходит изображение карты.

Ниже приведен пример использования.

// после выполнения вызова в этом файле будет изображение с картой
ИмяФайлаКарты = ПолучитьИмяВременногоФайла("jpg");

Соединение = Новый HTTPСоединение("maps.google.com");
Соединение.Получить("maps/api/staticmap?center="+lat+","+long+"&zoom=14&size=320x100&maptype=roadmap" +
    "&markers=color:red%7Ccolor:red%7Clabel:C%7C"+lat+","+long+"&sensor=false", ИмяФайлаКарты);

Демонстрационная конфигурация.

Для демонстрации работы с API и более лучшего понимания всего вышесказанного была создана демонстрационная конфигурация. В этой конфигурации реализован механизм авторизации и отправка сообщения на стену с возможностью прикрепления изображения. Кроме того, в конфигурации существует общий модуль "РаботаССайтомВКонтакте" в котором реализованы готовые вызовы следующих методов API в виде соответсвующих процедур и функций 1С:

  • размещение и удаление записей на стене;
  • добавление, чтение и удаление комментариев к записям;
  • работа с рекламой - получение списка рекламных кабинетов, работа с рекламными кампаниями и рекламными объявлениями (создание, изменение и удаление);
  • работа со списком пользоваталей и получение информации о них;
  • работа с географическими местами;
  • размещение фотографий.

т.е., например, чтобы получить информацию о пользователях можно воспользоваться следующим кодом

РаботаССайтомВКонтакте.ПолучитьИнформациюОПользователях("a1dfc7ef2b763d776350375f8a22678a59f28e1ac7e090b4a8486274564d38e9e8a069d10e596223d80d7", "5184504");

первый параметр access_token, второй - id пользователя.

Возвращаемым значением функций является Структура либо массив структур в завимости от формата ответа сервера. Ключами структуры являются параметры возвращаемые в ответе сервером. Приведенный ниже пример демонстрирует вывод имен пользователей с ID 123456 и 654321.

ДанныеОПользователях = ПолучитьИнформациюОПользователях(access_token, "123456,654321");
Для каждого ДанныеОПользователе Из ДанныеОПользователях Цикл
	Сообщить("Имя пользователя " + ДанныеОПользователе.uid +
		" - " + ДанныеОПользователе.first_name);
КонецЦикла;

Используя написанную выше информации, документацию разработчика ВКонтакте и примеры из демострационной конфигурации можно достаточно просто добавить отсутствующий функционал.

Общий модуль "РаботаССайтомВКонтакте" и обработку "АвторизацияНаСайте" можно как есть перенести в рабочую конфигурацию и начать использовать API ВКонтакте.

Демонстрационная база работает как в режиме управляемых форм так и в обычном приложении.

Примечание.

Код демонстрационной конфигурации может использоваться в других разработках без каких-либо органичений.

130

Скачать файлы

Наименование Файл Версия Размер
Демонстрационная конфигурация работы с API ВКонтакте
.cf 47,57Kb
21.05.17
252
.cf 47,57Kb 252 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Yashazz 2860 24.07.13 17:33 Сейчас в теме
Класс! Обожаю задачки подобной интеграции, спасибо!

И вопрос из серии "некогда самому глянуть" - где-инбудь нормальное описание API там есть?
2. lamelioss 140 24.07.13 17:53 Сейчас в теме
автору +, тема интересна =)
3. Elisy 918 31.07.13 05:23 Сейчас в теме
Не смотрели Facebook на тему создания приложений? Можно ли из FB загружать список друзей с телефонами в 1С и отправлять сообщения пользователям?
4. musatov1c.ru 19.08.13 09:52 Сейчас в теме
Интересно. Спасибо за выкладку. Есть запрос на ведение рекламной деятельности через контакт, которую бы можно было учитывать и обсчитывать. Данная разработка может быть путем решения данной задачи.
5. Boudybuilder 60 03.11.13 23:59 Сейчас в теме
Интересная обработка.
Буду качать.

Раз уж есть эта тема , так давайте ее обсудим поподробнее.

Имеем 3 самых больших СоцСети: "ОК" , "ВК" и "FB". Ну и Твиттер тут можно вставить с ними в один ряд, так как его используют на всех сайта для размещения постов.
Самое наверное интересное для меня было бы - так это создать обработку универсальную для всех вышеперечисленных ресурсов.

Но для чего она нам могла бы быть полезной?! Давайте , кто знает о полезностях взаимодействий сайта или 1С с даными сетями , пишите сюда. Не ленитьсь.

Мне кажется , что самое главное - это посты! Выкласть информацию с фоткой на стенку группы , чтобы все ее учасники могли увидеть.

Второе , это сбор контактной информации учасников ,если таковое возможно и предусмотрено АРІ.

Дальше что может быть?
jobkostya1c8; +1 Ответить
6. 3762515 22.07.14 17:10 Сейчас в теме
(5) Boudybuilder, а что за соцсеть "ОК"?
KroVladS; kuzyara; +2 Ответить
16. NewLifeMan 02.04.16 13:32 Сейчас в теме
7. Yashazz 2860 31.07.14 11:04 Сейчас в теме
(0) Не работает даже попытка получения ключа, т.е. по адресной строке https://oauth.vk.com/authorize итд - говорит, что "не удалось загрузить authorize из oauth.vk.com, и всё. Что неправильно?
8. Vix 24 30.08.14 11:19 Сейчас в теме
вошли на сайт, а выход с него как организовать?
9. Boudybuilder 60 29.10.14 00:28 Сейчас в теме
Кто знает , какими символами делать перевод строки. А то уже все перепробовали а вкотнакте все одной строчкой на стенке.
10. ltfriend 412 30.10.14 08:29 Сейчас в теме
(9) Boudybuilder, Перевод строки выполняется обычным способом. Только нужно сообщение кодировать в кодировке URL (urlencode). В предоставленной демо конфигурации можно сделать следующим образом:
ТекстСообщения = РаботаСВнешнимВебСервером.URLEncode(ТекстСообщения);
11. jobkostya1c8 01.02.15 09:08 Сейчас в теме
Запомню. Довольно интересная разработка.
12. vladnet 253 22.04.15 19:39 Сейчас в теме
Спасибо за разработку!

В функции:

Функция СформироватьСтрокуПараметровЗапроса(Параметры, access_token)

Надо проверять на тип число:

СтрокаПараметров = СтрокаПараметров + Параметр.Ключ + "=" + ?(ТипЗнч(Параметр.Значение)=Тип("Число"), Формат(Параметр.Значение, "ЧГ=0"), Параметр.Значение) + "&";
13. Midasu 17.08.15 19:29 Сейчас в теме
Не могу разобраться с загрузкой изображения.
Не пойму что должно быть в АдресЗагрузки и АдресРесурса.
Конкретно нужно установить картинку конференции в переписках.
Методы photos.getChatUploadServer и messages.setChatPhoto описаны в api, но как они с файлами взаимодействуют мне не ясно.
В первом методе получаю upload_url, а как туда фото загрузить не ясно, ибо во втором методе его нужно установить.

UPD: А что за Изображение.Записать(...)? Изображение - реквизит типа Картинка? Но зачем оно?
14. s3nsay 21.09.15 20:24 Сейчас в теме
Ребята скиньте у кого есть эта конфигурация на почту leonov_den89@mail.ru, а то средств не хватает на загрузку.
15. dj_serega 367 04.02.16 12:46 Сейчас в теме
"Так как в 1С нет методов для работы с двоичными файлами был придуман следующий способ."
уже в планах :) так что планируйте дорабатывать публикацию :)
http://v8.1c.ru/o7/201602bin/index.htm
17. Xershi 717 08.10.16 00:48 Сейчас в теме
Дополнил конфигурацию справочником всех прав, для получения токена, но автоматическое получение крашит приложение.
У меня авторизация двухфакторная. но через браузер легко получил.

Еще хотел узнать как понять какое апи использую, у них в новых версиях параметры у методов другие, но версию же я не задавал или тут нужно платформу сайта смотреть?
18. Xershi 717 09.10.16 15:05 Сейчас в теме
(17) Xershi, сам разобрался. При формировании начального запроса они добавили опционально версию апи, сейчас это
&v=5.57

Плюс перешли на шифрованное соединение и поменяли формат прикрепляемых фоток. Изучив их апи все стало на свои места!
Спасибо за реализацию формирования и парсилки запроса!
19. KRaSH13 15.10.16 00:09 Сейчас в теме
(18) Xershi,
Сервер = "api.vk.com";
Ресурс = СтрШаблон("%1/method/messages.send?user_id=%2&message=%3&access_token=%4&v=5.57", Сервер, IDАккаунта, Сообщение, Токен);

Соединение = Новый HTTPСоединение(Сервер,443,,,,,Новый ЗащищенноеСоединениеOpenSSL());
Запрос = Новый HTTPЗапрос(Ресурс);
Ответ = Соединение.Получить(Запрос);
СообщитьПользователю(Строка(Ответ.КодСостояния));

Остальные параметры тоже есть, токен получен. Ответ на запрос постоянно "404", что бы ни делал. Не пойму в чем проблема, бьюсь 3й час.
20. Xershi 717 15.10.16 00:18 Сейчас в теме
(19) KRaSH13, у него там метод подключения через ком идет. Я только добавил букву s к отсечению! Так что качай конфу и смотри код.
21. ltfriend 412 15.10.16 11:21 Сейчас в теме
(19) KRaSH13, Зачем вы в "Ресурс" добавляете адрес сервера?
Нужно так
Ресурс = СтрШаблон("method/messages.send?user_id=%2&message=%3&access_token=%4&v=5.57", IDАккаунта, Сообщение, Токен);
22. capitan 1284 22.10.16 21:16 Сейчас в теме
Автор красавчик )


Функция ЗагрузитьФотографиюНаСтену(access_token, uid="", gid="", Изображение) Экспорт

АдресЗагрузки = СтрЗаменить(РаботаССайтомВКонтакте.ПолучитьАдресДляЗагрузкиФотографийНаСтену(access_token, uid, gid), "http://", "");

АдресЗагрузки = СтрЗаменить(РаботаССайтомВКонтакте.ПолучитьАдресДляЗагрузкиФотографийНаСтену(access_token, uid, gid), "https://", "");


23. ltfriend 412 26.10.16 10:08 Сейчас в теме
(22) capitan, Ну так, стараюсь ))
24. seva1405 33 07.04.17 13:45 Сейчас в теме
А в этой конфигурации только как загружать фото или есть пример скачивания на диск новостей с картинками?
25. a2kat 25.04.17 15:39 Сейчас в теме
Уважаемые форумчане! Перешлите на kg.og@mail.ru конфигурацию работы с API VK please!
26. Serega-artem 11 11.05.17 14:31 Сейчас в теме
Автору огромное спасибо, пригодилось!

Мои пять копеек. Если при загрузке фото на сервер возвращается:

<html> <head><title>301 Moved Permanently</title></head> <body bgcolor="white"> <center><h1>301 Moved Permanently</h1></center> <hr><center> Apache </center> </body> </html>


То вместо

Новый HTTPСоединение(АдресЗагрузки)


Пишем:

ssl4 = Новый ЗащищенноеСоединениеOpenSSL( неопределено, неопределено );
Соединение = Новый HTTPСоединение(АдресЗагрузки,,,,,,ssl4)
27. Santa4527 18.05.17 00:43 Сейчас в теме
Может кто то сталкивался при выгрузки на стену изображения ошибка

Ошибка при загрузке изображения на стену: {ОбщийМодуль.РаботаССайтомВКонтакте.Модуль(1529)}: Ошибка при вызове метода контекста (ОтправитьДляОбработки): Ошибка работы с Интернет: Couldn't resolve host name

8.3.8.1652
Режим совместимости Версия 8.3.7

просто текст отправляет в vk
28. ltfriend 412 21.05.17 13:27 Сейчас в теме
(27) Выложена обновлённая версия демонстрационной конфигурации, где исправлены некоторые ошибки (в том числе и ошибка загрузки изображений).
29. vizgallova 23.05.17 12:56 Сейчас в теме
30. kmpok 01.08.17 15:04 Сейчас в теме
Может кому пригодится. Сделал функцию отправки фотографий на сервер с использованием двоичных данных без записи файлов на диск.
Входящие параметры:
Изображение = двоичные данные картинки.
АдресЗагрузкиФото = Адрес, полученный ранее методом photos.getWallUploadServer. Без "https://"

Функция ВыполнитьОтправкуФото(Изображение, АдресЗагрузкиФото)
	
	Boundary 	 = СтрЗаменить(Строка(Новый УникальныйИдентификатор()), "-", "");
	
	Тело		 = Новый ПотокВПамяти();
	ЗаписьДанных = Новый ЗаписьДанных(Тело,КодировкаТекста.ANSI);
	ЗаписьДанных.ЗаписатьСтроку("--"+Boundary);
	ЗаписьДанных.ЗаписатьСтроку("Content-Disposition: form-data; name=""photo""; filename=""photo.jpeg""");
	ЗаписьДанных.ЗаписатьСтроку("Content-Type: image/jpeg");
	ЗаписьДанных.ЗаписатьСтроку("");
	ЗаписьДанных.Записать(Изображение);
	ЗаписьДанных.ЗаписатьСтроку("");
	ЗаписьДанных.ЗаписатьСтроку("--"+Boundary);

	ДвоичныеДанныеДляОтправки = Тело.ЗакрытьИПолучитьДвоичныеДанные();
			
	ЗаголовокHTTP = Новый Соответствие;
	ЗаголовокHTTP.Вставить("Content-Type", "multipart/form-data; boundary="+Boundary);
	ЗаголовокHTTP.Вставить("Content-Length", XMLСтрока(ДвоичныеДанныеДляОтправки.Размер()));
		
	НТТР = Новый HTTPСоединение(АдресЗагрузкиФото,,,,,,Новый ЗащищенноеСоединениеOpenSSL);
	   
	ЗапросHTTP      = Новый HTTPЗапрос("",ЗаголовокHTTP);
	ЗапросHTTP.УстановитьТелоИзДвоичныхДанных(ДвоичныеДанныеДляОтправки);
	
	ОтветHTTP       = НТТР.ОтправитьДляОбработки(ЗапросHTTP);
		
	СтрокаJSON 	  = ОтветHTTP.ПолучитьТелоКакСтроку();	
	ЧтениеJSON 	  = Новый ЧтениеJSON;
	ЧтениеJSON.УстановитьСтроку(СтрокаJSON);
	
	ПараметрыОтвета = ПрочитатьJSON(ЧтениеJSON);
	
	Возврат ПараметрыОтвета;
		
КонецФункции	
Показать
GalMig; fuxic; puabrueha; jobkostya1c8; +4 Ответить
31. kmpok 02.08.17 14:54 Сейчас в теме
Как реализовать отправку смайлов в сообщении? кто-нибудь сталкивался?
Дело в том, что символьные коды смайлом идут с &, а данный символ используется при перечислении параметров.В результате чего логика строки запроса нарушается.
32. Gang031 09.01.18 16:40 Сейчас в теме
А что делать, если вк потребует ввод капчи? если много сообщений допустим отправляешь, то может потребовать
33. Luck_DMST 22 07.02.18 16:35 Сейчас в теме
Спасибо огромное, очень выручили!
34. r0m1n 06.03.18 18:13 Сейчас в теме
У кого выходит ошибка что-то типа "v version is required" - теперь в запросе необходимо явно указывать номер версии API ВК (https://vk.com/dev/version_update), поэтому добавляем соответствующий параметр при вызове любого метода ВК.
35. Serega-artem 11 21.03.18 22:02 Сейчас в теме
(34) Золотой Вы человек! Спасибо большое, полчаса мозг ломал. Немного конкретизирую:

В процедуре СформироватьСтрокуПараметровЗапроса(Параметры, access_token)

Находим строку

СтрокаПараметров = СтрокаПараметров + "access_token=" + access_token";

И приводим её к такому виду:

СтрокаПараметров = СтрокаПараметров + "access_token=" + access_token+"&v=5.73";

Где 5.73 - версия API
36. Wrols 78 07.08.18 07:53 Сейчас в теме
Несколько моментов по поводу размещении публикации поста для группы:

1. В обработках приложенной конфигурации есть управляемые и обычные формы. Рекомендую смотреть управляемые - в них меньше ошибок.

2. При размещении записи на стене с картинкой происходит сначала загрузка фотографии, в результате которой возвращается owner_id, отличающийся от ID пользователя группы. Именно этот owner_id и нужно передавать в attachments.

Процедура РазместитьЗапись(Команда)
	
	Если Не ПустаяСтрока(Объект.file_name) Тогда
		
		Если Лев(Объект.owner_id, 1) = "-" Тогда
			uid = "";
			gid = Сред(Объект.owner_id, 2);
			//{{AZ
			from_group = "1";
			//}}az
		Иначе
			uid = Объект.owner_id;
			gid = "";
			//{{AZ
			from_group = "";
			//}}az
		КонецЕсли;
		
		Попытка
			Параметрыизображения = РаботаССайтомВКонтакте.ЗагрузитьФотографиюНаСтену(Объект.access_token, uid, gid, Новый ДвоичныеДанные(Объект.file_name));
			
			//{{AZ
			//attachments = РаботаССайтомВКонтакте.СохранитьЗагруженнуюФотографиюНаСтене(Объект.access_token,
			//					Параметрыизображения.server, Параметрыизображения.photo, Параметрыизображения.hash, uid, gid).id;

			ПараметрыВложения = РаботаССайтомВКонтакте.СохранитьЗагруженнуюФотографиюНаСтене(Объект.access_token,
								Параметрыизображения.server, Параметрыизображения.photo, Параметрыизображения.hash, uid, gid);
			//}}az
		Исключение
			Сообщить("Ошибка при загрузке изображения на стену: " + ОписаниеОшибки());
			Возврат;
		КонецПопытки;
		
	КонецЕсли;
	
	Попытка
		//{{AZ
		//post_id = РаботаССайтомВКонтакте.РазместитьЗаписьНаСтене(Объект.access_token, Объект.owner_id, Объект.message, attachments,, from_group);
		post_id = РаботаССайтомВКонтакте.РазместитьЗаписьНаСтене(Объект.access_token, Объект.owner_id, Объект.message, ПараметрыВложения,, from_group);
		//}}az
		Сообщить("Запись на стене успешно размещена. post_id = " + post_id);
	Исключение
		Сообщить("Ошибка при размещении записи на стене: " + ОписаниеОшибки());
	КонецПопытки;
	
КонецПроцедуры

Функция РазместитьЗаписьНаСтене(access_token, owner_id="", message, ПараметрыВложения= Неопределено, services="", from_group="", signed="", friends_only="") Экспорт
	
	//{{AZ
	Если ПараметрыВложения <> Неопределено Тогда
		attachments = "photo" + ПараметрыВложения.owner_id + "_" + ПараметрыВложения.id;
	Иначе
		attachments = "";
	КонецЕсли;
	//}}az
	ПараметрыЗапроса = Новый Структура("owner_id,message,attachments,services,from_group,signed,friends_only",
										owner_id,message,attachments,services,from_group,signed,friends_only);
										
	ПараметрыЗапроса.message = РаботаСВнешнимВебСервером.URLEncode(ПараметрыЗапроса.message);
										
	ОтветСервера = ВызватьМетодAPI("wall.post", ПараметрыЗапроса, access_token);
	
	Если ОтветСервера.Свойство("error_code") Тогда
		// произошла ошибка
		ВызватьИсключение СформироватьТекстОшибкиAPI("Произошла ошибка при размещении записи", ОтветСервера);
	КонецЕсли;
	
	Возврат ОтветСервера.post_id;
										
КонецФункции

Показать
38. user1137665 29.01.19 13:51 Сейчас в теме
Ребята подскажите что я делаю не так??. не удается выгрузить запись на стену
Прикрепленные файлы:
39. echo77 1094 22.07.19 22:08 Сейчас в теме
У меня ошибка еще при авторизации: не удалось скачать authorize из oauth.vk.com
Это про что вообще?
Прикрепленные файлы:
Оставьте свое сообщение

См. также

Интеграция 1С с сайтом (магазином) WordPress (WooCommerce) с помощью Rest API сайта. Часть 1. Авторизация 37

Статья Программист Конфигурация (md, cf) v8 Windows Абонемент ($m) WEB

Интеграция 1С с сайтом (магазином) WordPress (WooCommerce) с помощью функционала Rest API предоставляемого платформой (CMS) WordPress (WooCommerce). Без дополнительных приложений на PHP/вставьте сюда любой другой язык программирования/.

1 стартмани

12.10.2019    2029    5    osivv    27       

Telegram бот на 1С 39

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) WEB

Telegram бот на 1С в виде внешней обработки, встраиваемой в типовые 1С 8.3.

1 стартмани

24.09.2019    3564    11    budidich    15       

Выгрузка номенклатуры в социальную сеть Вконтакте 30

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Оптовая торговля Розничная торговля Абонемент ($m) WEB

Обработка для быстрой и легкой выгрузки товаров Вконтакт. Так просто еще не было)))

2 стартмани

14.08.2019    2202    11    kalyuzhny    20       

Путеводитель по истории релизов 36

Отчеты и формы Системный администратор Программист Внешний отчет (ert,erf) v8 1cv8.cf Абонемент ($m) WEB

Отчет по истории выпуска релизов и анализа информации по обновлениям.

2 стартмани

13.08.2019    2618    7    YPermitin    15       

Подключение к сайту и отправка или получение данных по API (POST, GET...) (с описанием кода) 27

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) WEB

Простая обработка по отправке или получение данных с любого сервера главное знать ресурс (выполняемую функцию) и тело запроса.

1 стартмани

12.08.2019    2753    4    MaxPowerr    5       

Управление сообществом ВК (получение статистики, пользователей сообщества) 3

Инструменты и обработки Программист Пользователь Стажер Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) WEB

Данная обработка не является еще рабочей конфигурацией, а больше знакомством с API Vkontakte. Скажем, это мой небольшой проект, чтобы скоротать вечер Может, в будущем выльется во что-то больше, и при наличии свободного времени буду допиливать все задуманное. API VK предоставляет на самом деле большие возможности для разработки интеграции со своим приложением, так что можно пробовать.

1 стартмани

06.08.2019    815    1    serg-lom89    0       

Использование HTTP-сервиса для создания "фронтенда" HTML/CSS/jQuery с кэшированием 94

Статья Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) WEB

В статье описан способ создания "фронтенда" на HTML/CSS/jQuery и скрипт кеширования AJAX запросов на PHP.

1 стартмани

06.08.2019    4851    6    Sedaiko    22       

Конфигурация для обмена данными (интеграционная шина) 23

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Windows Абонемент ($m) Внешние источники данных WEB

Система позволяет организовать обмен данными, как с базами 1С, так и любыми другими приложениями. Система представляет собой отдельную конфигурацию. Система позволяет организовать гибкие возможности по настройке обмена. В качестве брокера сообщений, для передачи данных, используется отдельная самостоятельная конфигурация на 1С. Комплект поставки содержит файл расширения для "клиентской" части шины, данное расширение позволяет без снятия "ключа" организовать гибкий механизм обмена данными.

4 стартмани

08.07.2019    3103    15    miha-28    14       

Шаблон http-сервиса для вашего проекта 70

Инструменты и обработки Программист Архив с данными v8 v8::Mobile 1cv8.cf Абонемент ($m) Внешние источники данных WEB Мобильная разработка

Http-сервис для обмена данными в формате JSON. Обработчики этого сервиса находятся во внешней обработке, что позволяет дорабатывать его без изменения конфигурации. Также прилагаю пример мобильного приложения для работы с данным сервисом (получает номенклатуру и остатки на складе). Сервис очень быстро разворачивается и масштабируется под ваши задачи.

2 стартмани

04.05.2019    6082    49    MarkoSokolov    47       

1C + Python + Django Rest Framework + Vue.js. Опыт несложной full-stack разработки 121

Статья Программист Архив с данными v8 1cv8.cf Абонемент ($m) Практика программирования Внешние источники данных Обмен через XML WEB Разработка

В этой статье мы рассмотрим путь и основные моменты создания небольшого вэб-сервиса, который мы называем "Онлайн Прайс-лист". Выгрузка из 1С, бэкенд, фронтенд, получение заказов в 1С.

1 стартмани

22.04.2019    16067    14    riposte    63       

1С и WebKit. Вариант взаимодействия 46

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) WEB

В результате перехода на WebKit тип свойства Документ у поля, имеющего вид ПолеHTMLДокумента, изменился с COMОбъект на ВнешнийОбъект. Также изменилась DOM модель документа, доступная через это свойство.

2 стартмани

23.02.2019    9958    29    mi1man    35       

Строим маршруты на картах в 1С с помощью OpenStreetMap, OSRM и Leaflet 74

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Транспорт, автопарки, такси Абонемент ($m) WEB

Краткая статья о том как вывести на карту (в 1С) маршруты с помощью OpenStreetMap, OSRM и Leaflet. По данной системе очень мало примеров, но так как OpenStreetMap является бесплатным сервисом и не требует никаких ключей и регистраций, и является довольно мощным механизмом, решил написать небольшую статью "как это сделать?". В первую очередь скажу, все намного проще, если вы используете последнюю версию платформы (8.3.14), где есть поддержка практически всех браузеров (IE 11, EDGE, Mozilla), но что делать если у нас не самая свежая платформа, где поддержка только IE 9?

2 стартмани

12.02.2019    9164    51    Ditron    15       

Яндекс карта в документе "Заказ клиента" на закладке "Доставка". (Расширение) УТ 11.4 28

Инструменты и обработки Пользователь Расширение (cfe) v8 УТ11 Россия УУ Оптовая торговля Абонемент ($m) Обработка документов WEB

Показ яндекс карты в документе "Заказ клиента" на закладке "Доставка" и печать карты для курьера с контактными данными. (Расширение)

3 стартмани

05.02.2019    3818    11    ret    6       

Коннектор: удобный HTTP-клиент для 1С:Предприятие 8 514

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования Внешние источники данных WEB Универсальные функции Инструментарий разработчика Универсальные обработки

Коннектор - библиотека для работы с HTTP запросами. Библиотека берет на себя всю рутину работы с HTTP запросами. Буквально в одну строку можно получать данные, отправлять, не заботясь о необходимости конструирования URL, кодирования данных и т.п.

1 стартмани

31.01.2019    25578    245    bonv    108       

Яндекс карты 2.1. Построение маршрута. Передача длины маршрута в реквизит формы 32

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) WEB

Пригодится как пример использования Яндекс карты 2.1 для построения маршрута.

1 стартмани

24.01.2019    4728    43    John_d    26       

Проверка VAT номеров 2

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) WEB

Обработка для вызова сервиса проверка VAT номера.

1 стартмани

26.11.2018    3771    wtlz    0       

Веб-форма авторизации/регистрации/восстановления пароля для веб-клиента 1С с помощью HTML/CSS/PHP/HTTP-сервисов 1С 27

Инструменты и обработки Программист Архив с данными v8 1cv8.cf Абонемент ($m) WEB

Пришла в голову идея создать универсальную веб-форму входа в веб-клиент 1С на HTML/CSS/PHP/HTTP-сервисы 1С. Чтобы прямо как на нормальных сайтах. Заодно и для ознакомления с 1С с новой, для себя, стороны. Интересно было попробовать интеграцию PHP - 1С.

1 стартмани

08.11.2018    7522    20    Бэнни    15       

Загрузка чека онлайн-касс (загрузка товаров из чека) 38

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 1cv8.cf Кассовые операции Розничная торговля Абонемент ($m) Внешние источники данных WEB

Обработка-пример, позволяет любому и из любой конфигурации загрузить информацию о товарах из чека(и не только) с сервера ФНС proverkacheka.nalog.ru

2 стартмани

08.10.2018    7327    23    echo77    32       

Работа с публикациями "Инфостарт" 13

Инструменты и обработки Программист Архив с данными v8 УУ Абонемент ($m) Практика программирования О сообществе WEB

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    8333    10    RocKeR_13    12       

SOAP для чайников 86

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Обмен через XML WEB

Немножко про SOAP сервис. И пример работы с подключением и получением данных по SOAP за 5 минут.

1 стартмани

05.09.2018    18705    25    dusha0020    18       

Класс-обработка “Работа с картами Яндекс” 58

Инструменты и обработки Программист Конфигурация (md, cf) v8 Абонемент ($m) Разработка внешних компонент WEB

Как показать точку или маршрут на карте Яндекс. Как получить координаты по строке адреса (геокодирование).

1 стартмани

01.08.2018    10711    129    RSConsulting    13       

HTTP Сервисы: Путь к своему сервису. Часть 1 260

Статья Системный администратор Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Практика программирования WEB

Уже много было написано про http-сервисы, но то и дело всплывают «Новые» статьи по обмену между базами V8 по COM, что «Немножко» удивляет. Решил внести свои 5 копеек, поработаем с http-сервисом.

1 стартмани

15.07.2018    35559    15    dsdred    22       

Пример использования REST API Яндекс Диска 33

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) WEB

Пример использования REST API Яндекс Диска: чтение диска, добавление каталога, загрузка файла, скачивание файлов или каталогов, удаление файлов или каталогов.

1 стартмани

26.06.2018    12481    23    MKFreeUser    12       

Обмен файловыми базами данных через Yandex диск 7

Инструменты и обработки no Приложение (exe) v8 Россия Windows Абонемент ($m) WEB

Выполнение операций обмена с Yandex диском для файловых БД, по протоколу WebDav, в автоматическом или ручном режимах.

1 стартмани

11.06.2018    9923    6    slimper    1       

Чтение сжатого gzip, deflate HTTP ответа сервера. Без ВК. Уменьши время загрузки и сократи трафик в 3 раза 69

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) WEB

В платформе 1С:Предприятие не реализовано штатного механизма декодирования ответа веб серверов, в которых присутствует gzip сжатие. Некоторые использовали WinHttpRequest.5.1 , кто-то писал ВК. Друзья, хватит. Вот вам решение.

1 стартмани

08.06.2018    8106    45    Malfarion    14       

Конфигурация для просмотра публичных телеграм каналов 10

Инструменты и обработки Программист Конфигурация (md, cf) v8 Абонемент ($m) WEB

Просмотр и каталогизация в более удобном виде публичных телеграм каналов, групп и чатов.

1 стартмани

02.06.2018    9969    7    DO_WHILE_LOOP    7       

Простой эмулятор вызова веб-сервиса 1С с просмотром результата 24

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Обмен через XML WEB

Последнее время все чаще сталкиваюсь с разработкой веб-сервисов средствами 1С. Для ускорения разработки и отладки написал внешнюю обработку. На какой-то сверх-крутой функционал она не претендует, но, может, кому-то пригодится.

1 стартмани

24.04.2018    7397    17    anvolkov1cbit    9       

Интеграция между Atlassian Jira и 1С:Предприятие 8.3 используя Jira REST API (выборка, создание и изменение запросов, чтение, создание и удаление записей о работах, чтение комментариев и другие возможности) 80

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Внешние источники данных WEB

Внешняя обработка на управляемой форме для 1С:Предприятие 8.3 по интеграции с Atlassian Jira используя Jira REST API. Ключевые функции: выборка запросов с использованием JQL; добавление и изменение запросов; добавление, изменение и удаление записей о работах; чтение комментариев к запросам; сохранение всех ключевых параметров между сеансами работы. Тестирование проводилось на платформе 1С (8.3.11.2954) совместно с JIRA Server platform (7.3.7)

1 стартмани

24.04.2018    16969    113    Ko1t    63       

Простая и пошаговая интеграция Яндекс-Алисы и 1С 76

Инструменты и обработки Программист Конфигурация (md, cf) v8 Windows Абонемент ($m) WEB

Интеграция Алисы и 1С через http сервис на платформе 8.3.9. Используем виртуальный сервер, сертификат от letsencrypt, и делаем простые запросы к базе из Алисы.

1 стартмани

09.04.2018    14939    15    kiv1c    33       

Чтение и запись из таблиц гугл (google sheets) в табличный документ 1С (8.3, управляемые формы) 148

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Внешние источники данных WEB

Внешняя обработка на управляемой форме для 1С версии 8.3 для доступа к сервисам Google Sheets c использованием протокола авторизации OAuth 2.0. Выполняет получение списка листов таблицы гугл, чтение таблицы гугл в табличный документ 1С и запись из табличного документа 1С в таблицу гугл. Тестирование проводилось на платформе 1С:Предприятие 8.3 (8.3.11.2954).

1 стартмани

09.04.2018    21405    164    Ko1t    50       

Внешняя компонента для работы по Web-socket протоколу 21

Инструменты и обработки Программист Архив с данными v8 Windows Абонемент ($m) Разработка внешних компонент WEB

Кто когда-нибудь сталкивался с обменом данными по Web-Socket (wss) протоколу из 1С, тому известно, что в платформе отсутствуют данные механизмы (не путать с HTTP запросами и WebServices). Предлагается использовать внешнюю компоненту, написанную по технологии NativeAPI, для подключения и обмена с серверами из 1С-Предприятия, работающими по протоколу Web-Socket.

6 стартмани

30.03.2018    13025    9    Ditron    62       

2 в 1: Проверить действительность паспорта / Получить ИНН по паспорту 38

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::УФ ERP2 БП3.0 ЗУП3.x Россия БУ Управление персоналом (HRM) Абонемент ($m) Обработка справочников WEB

Представляю вашему вниманию внешнюю обработку заполнения элемента справочника "Физические лица". Обработка выполнена с использованием API (для работы необходим доступ в интернет), содержит полностью открытый код и 2 команды: Проверка документа, удостоверяющего личность, в списке недействительных паспортов и Заполнение ИНН по паспортным данным.

1 стартмани

27.02.2018    11611    124    VladimirElohov    33       

Построение маршрута доставки с расчётом расстояния для любой базы УФ 56

Инструменты и обработки Руководитель проекта Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Оптовая торговля Абонемент ($m) Универсальные обработки WEB

Графическое изображение маршрутного листа по картам гугл. Работает на любой конфигурации с управляемыми формами. Использует новую версию api google-карт от 13.02.2018 года под IE11.

10 стартмани

24.02.2018    18606    36    KorotkovRV    16       

А чё это вы здесь делаете, а? 142

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) WEB

Разработчикам тиражных обработок близка и понятна проблема обратной связи с пользователем. Много важного и полезного можно почерпнуть, зная, что делает бухгалтер, который запустил обработку. В большом мире вэба сбор статистики на сайте дело привычное и даже обязательное. Эта статья покажет практику применения инструментов сбора статистики из мира веба для обработок на платформе 1С:Предприятие.

1 стартмани

21.01.2018    16626    28    infosoft-v    42       

Пример заполнения/создания файла XML из XSD схемы, используя XDTO 128

Статья Программист Документ XML v8 1cv8.cf Абонемент ($m) Обмен через XML WEB

Добрый день, коллеги! Наконец-то дошли руки написать сию статью. Хочу поделиться своим опытом по разбору xsd схемы используя Фабрику XDTO, а также связанным с этим XML файлом. Думаю, наверняка кому-то понадобится.

1 стартмани

21.12.2017    28743    40    sandybaev    23       

Сервер push сообщений “Push0k“ 18.05 12

Инструменты и обработки no Архив с данными v8 1cv8.cf Абонемент ($m) WEB

Аналог других “мессенджеров“. Позволяет практически все то же самое, что и другие решения. За исключением смайлов, эмодзи, голосовой и видео связи. Основное отличие от других решений, открыта и доступна для изменения серверная и клиентская часть месенджера. Общедоступной серверной части нет, за серверную часть отвечаете вы сами.

1 стартмани

19.12.2017    10453    11    PloAl    20       

Проверка орфографии средствами Yandex Speller 78

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки WEB

Проверка орфографии средствами Yandex Speller с опциями и коррекцией ошибок. Возможность вызова как с сервера, так и с клиента (с последующим исправлением).

1 стартмани

09.11.2017    13123    50    🅵🅾️🆇    38       

Веб-сервисы 1С и PHP 31

Инструменты и обработки Программист Архив с данными v8 1cv8.cf Украина Windows Абонемент ($m) WEB

Пример создания веб-сервиса на 1С, использование пагинации в запросах 1С, примеры кода на php - передача параметров, получение и разбор данных.

1 стартмани

20.10.2017    18609    41    serg1234    12       

Ведение локального каталога обработок с Инфостарт 67

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки WEB

Обработка наводит порядок в ваших скачанных и локально хранимых обработках с Инфостарта. Это особенно удобно тем коллегам, которые уже скачали немалый объем обработок и хотят получить удобный инструмент навигации по списку.

1 стартмани

06.10.2017    18368    55    rpgshnik    48       

Подсистема Вики - интеграция 1С и сайта под управлением MediaWiki 90

Инструменты и обработки Программист Архив с данными v8 Абонемент ($m) WEB

Редактирование статей сайта Mediawiki из 1С. Формирование функционального описания конфигурации на сайте Вики.

1 стартмани

19.09.2017    20585    31    shmalevoz    18       

Отправка HTTP запроса из 1С на сайт. 25

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) WEB

Задача: Передать данные из 1С на сайт. Данные будут передаваться в PHP скрипт, через HTTP запрос, вызываемый из 1С.

1 стартмани

07.05.2017    43637    67    sm2701    14       

Web сервис 1С 24

Инструменты и обработки Программист Архив с данными v8 1cv8.cf Россия Абонемент ($m) Практика программирования WEB Универсальные функции

Пример реализации простого web сервиса. Особенность: не используются XDTO пакеты, определяемые в дереве конфигураций; возможность передачи любых структур данных: списки значений, таблицы значений, табличные документы и т.п.

1 стартмани

21.03.2017    22306    74    hiduk    33       

Разбор адреса на составляющие с помощью Яндекс API и Google API 44

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки WEB

Есть адрес строкой, а нужно разбить его на составляющие? Для этого не обязательно писать собственный код, пользуемся Яндекс API и Google API.

1 стартмани

10.02.2017    17907    95    Ivon    22       

Передача большого количества объектов через Web-сервисы 43

Статья Программист Внешняя обработка (ert,epf) v8 УТ11 Абонемент ($m) WEB

Один из вариантов передачи большого количества объектов при использовании Web-сервисов.

1 стартмани

31.01.2017    12408    6    SinglCOOLer    14       

JSON парсер для профессиональных разработчиков 51

Инструменты и обработки Программист Архив с данными v8 1cv8.cf Россия Абонемент ($m) WEB Инструментарий разработчика Практика программирования

Описана методика создания парсеров json-файлов для любой конфигурации 1С. Приложена тестовая конфигурация и обработки-парсеры для обычного и управляемого приложений. Материал предназначен для разработчиков на базе 1С, занимающихся вопросами автоматизации бизнес процессов, обмена данными, сопряжения 1С с web-сайтами и сервисами.

4 стартмани

09.01.2017    19491    33    O-Planet    29       

Telegram bot. Обработка для управления ботом 24

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Универсальные обработки Внешние источники данных WEB

Может быть основой для ваших ботов, или если нужно создать быстро бота и управлять. Так как управление из 1С, вы можете писать боту разные команды для получения данных из базы. Обработка работает целиком на клиенте, без серверных вызовов! Это очень полезно, для развития максимальных скоростей. Настройки хранятся в каталоге пользователя. Тестировалась на 8.3.8, тонкий клиент, для любых конфигураций.

1 стартмани

14.11.2016    8107    46    silberRus    10       

Подключение к Яндекс.Диску через REST API 29

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) WEB

Эта обработка позволит подключить вашу конфигурацию к Яндекс.Диску. В ней есть графический интерфейс, поэтому можно проверить работоспособность до встраивания обработки в конфигурацию.

1 стартмани

14.11.2016    11064    71    vitaliy1911    11