Разбор HTML страниц на примере сайта Лучший пользователь информационной системы 1С:ИТС

Публикация № 393005

Разработка - Практика программирования

web html dom parse парсинг разбор html

В этом году фирма 1С и ее партнеры проводят IV Всероссийский конкурс «Лучший пользователь информационной системы 1С:ИТС». 20 августа закончился отборочный тур и появилась информация об участниках регионального тура на сайте thebest.its.1c.ru. Информация об участниках представлена по центрам проведения регионального тура (около 90 центров). Баллы за отборочный тур формировались из баллов за пройденный тест, баллов за акцию, проведенную в Вконтакте, и баллов, которые разыгрывали партнеры 1С, но на сайте отображались данные баллы общим числом. В этой статье я поделюсь тем, как я собирал информацию обо всех участниках регионального тура и детализировал полученные баллы.

 

Анализ раздела "Участники регионального тура" сайта thebest.its.1c.ru

Для того, чтобы брать информацию со страницы, нам надо изучить ее. Посмотрев исходный код страницы, можно выделить следующие фрагменты:

<select name="partner" id="partner" class="form-control">
<option value="e3506426-dd64-11e4-9573-e41f13bdf6c4" selected="selected">г. Абакан, ООО "Хакасия.ру"</option>
<option value="e3a39c36-dd64-11e4-9573-e41f13bdf6c4">г. Апатиты, ООО "КОЛА ДИГЕСТА"</option>
...
<option value="f391e760-dd64-11e4-9573-e41f13bdf6c4">г. Ярославль, ООО "Ярософт"</option>
</select>

В списке выбора партнера можем увидеть, что каждый элемент списка имеет атрибут value. Данное значение используется для получение информации об участниках выбраного партнера. Например, для получения информации об участниках в центре проведения г. Апатиты, ООО "Кола Дигеста" можно по ссылке http://thebest.its.1c.ru/public/reg_tour?partner=e3a39c36-dd64-11e4-9573-e41f13bdf6c4 либо http://thebest.its.1c.ru/public/reg_tour/e3a39c36-dd64-11e4-9573-e41f13bdf6c4. Если мы получим все значения атрибута value, то мы сможем получить доступ ко всем страницам партнеров с участниками.

Теперь необходимо разобраться, как получать информацию о самих участниках. Опять же глянем исходный код страницы:

<tbody>
<tr>
<td class="regional_tour__fio">...</td>
<td class="regional_tour__nomination_td"><span class="nomination k" title="Кадровый учет и трудовое право"></span></td>
<td title="Тест: 84, акция Вконтакте: 15, акция от партнера: 15" class="text-center">114</td>
<td>2015-03-ххххх</td>
</tr>
...
</tbody>

В таблице каждая строка представлена 4 ячейками:

  1. Ячейка с классом regional_tour_fio. В данной ячейке размещается фамилия, имя и отчество участника
  2. Ячейка с классом regional_tour__nomination_td. В данной ячейке размещается элемент span, класс которого зависит от номинации, в которой участвовал пользователь. Таких номинаций три:
    • Бухгалтерский учет и налогообложение (класс nomination b)
    • Кадровый учет и трудовое право (класс nomination k)
    • Платформа 1С:Предприятие 8 – разработка и администрирование (класс nomination it)
  3. Ячейка с классом text-center. В данной ячейке размещается количество баллов, набранных за отборочный тур. Также здесь можно увидеть атрибут title, в котором хранится калькуляция баллов. Например "Тест: 84, акция Вконтакте: 15, акция от партнера: 15". Здесь хотелось бы отметить, что обязательно указывается только "Тест", остальные значения могут не указываться, если участник не принимал участия в акциях партнера или проводимых Вконтакте.
  4. Ячейка без опозновательных знаков :) В ней находится номер сертификата Профессионал 1С:ИТС. Ее будем определять как ячейку без атрибута class.

Создание справочников

Создадим пустую конфигурацию и добавим справочники Участники и Партнеры. На рисунке ниже показаны реквизиты справочников

Реквизиты справочников

В справочнике Участники реквизиты Фамилия, Имя, Отчество, Сертификат имеют тип Строка, БаллыЗаТест, БаллыВК, БаллыПартнер, ОбщиеБаллы имеют тип число и реквизит Партнер имеет тип СправочникСсылка.Партнеры. В справочнике Партнеры все реквизиты имеют тип строка.

Теперь создадим общую форму, с помощью которой будем обновлять информацию в справочниках. В данной форме создадим две команды: ОбновитьИнформацию и ЗакрытьФорму.

Разбор адреса

Начнем писать код в модуле этой формы. Для удобства работы напишем сперва функцию СтруктураАдреса, которая будет разбирать наш адрес по частям и возвращать структуру. Согласно RFC1738, адрес страницы строится следующим образом:

<scheme>://<user>:<password>@<host>:<port>/<url-path>,

где

  • scheme - протокол подключения http, https, ftp и т. д; обязательный;
  • user -  имя пользователя; необязательный;
  • password - пароль пользователя; необязательный;
  • host - имя сервера; обязательный;
  • port - порт соединения; необязательный;
  • url-path - путь к странице; необязательный. 
&НаКлиенте
Функция СтруктураАдреса(Знач Адрес) Экспорт
	
	Адрес = СокрЛП(Адрес);
	
	// схема
	Схема = "";
	Позиция = Найти(Адрес, "://");
	Если Позиция > 0 Тогда
		Схема = Лев(Адрес, Позиция - 1);
		Адрес = Сред(Адрес, Позиция + 3);
	КонецЕсли;
		
	// строка соединения и путь на сервере
	СтрокаСоединения = Адрес;
	ПутьНаСервере = "";
	Позиция = Найти(СтрокаСоединения, "/");
	Если Позиция > 0 Тогда
		ПутьНаСервере = Сред(СтрокаСоединения, Позиция + 1);
		СтрокаСоединения = Лев(СтрокаСоединения, Позиция - 1);
	КонецЕсли;
	
	// информация пользователя и имя сервера
	МассивРазбора = СтрРазделить(СтрокаСоединения,"@");
	ИмяПользователя = ?(МассивРазбора.Количество() = 1,Неопределено,МассивРазбора [0]);
	ИмяСервера = ?(ИмяПользователя = Неопределено, СтрокаСоединения, МассивРазбора [1]);
	
	// пользователь и пароль
	Если ИмяПользователя <> Неопределено Тогда
		 МассивРазбора = СтрРазделить(ИмяПользователя,":");
		 ИмяПользователя = МассивРазбора [0];
		 ПарольПользователя = ?(МассивРазбора.Количество() = 1,Неопределено,МассивРазбора [1]);
	КонецЕсли; 
	
	// имя сервера и пароль
	МассивРазбора = СтрРазделить(ИмяСервера,":");
	ИмяСервера = МассивРазбора [0];
	Порт = ?(МассивРазбора.Количество() = 1,Неопределено, Число(МассивРазбора [1]));
		
	Результат = Новый Структура;
	Результат.Вставить("Схема", Схема);
	Результат.Вставить("Логин", ИмяПользователя);
	Результат.Вставить("Пароль", ПарольПользователя);
	Результат.Вставить("ИмяСервера", ИмяСервера);
	Результат.Вставить("Порт", Порт);
	Результат.Вставить("ПутьНаСервере", ПутьНаСервере);
	Возврат Результат;
КонецФункции

Получение DOM-объектов с веб-страницы

Для работы с элементами (тегами) нам надо получить исходный текст страницы и преобразовать его в DOM-объекты. Для этого напишем функцию ПолучитьСтраницуВОбъектDOM(Адрес). Алгоритм функции следующий: мы создаем переменную типа HTTPСоединение, в конструкторе которого указываем имя сервера и порт. Используя данное соединение, мы создаем HTTPзапрос к необходимой нам страницы и пытаемся прочесть результат. Если получить результат не удалось, то выводим сообщение об ошибке, иначе получаем исходный код в кодировке UTF8.

&НаКлиенте
Функция ПолучитьСтраницуВОбъектDOM(Знач Адрес)
	Адрес = СтруктураАдреса(Адрес);	
	Соединение = Новый HTTPСоединение(Адрес.ИмяСервера, Адрес.Порт);
	ВебЗапрос = Новый HTTPЗапрос(Адрес.ПутьНаСервере);
	Попытка
		Результат = Соединение.Получить(ВебЗапрос);
	Исключение
		Сообщить("Ошибка соединения");
		ВызватьИсключение;
	КонецПопытки; 
	Ответ = Результат.ПолучитьТелоКакСтроку(КодировкаТекста.UTF8);
	Чтение = Новый ЧтениеHTML;
	Чтение.УстановитьСтроку(Ответ);
	ОбъектыDOM = Новый ПостроительDOM;
	Возврат ОбъектыDOM.Прочитать(Чтение);
КонецФункции

Получение и обработка данных из DOM-объектов

Чтобы получить необходимую информацию, нам необходимо загрузить страницу, где она расположена. Но у нас таких страниц несколько, и для этого нам необходимо обработать элементы списка партнеров. Чтобы получить список партнеров и адреса страниц, нам надо просмотреть все элементы option и получить значение атрибута value, из которого получим адреса страниц и сам текст этого элемента. Поиск элемента в объектах DOM будем осуществлять с помощью метода построителя DOM - ПолучитьЭлементыПоИмени(). В результате работы этого метода мы получим переменную с типом СписокЭлементовDOM(), в котором будут содержаться все элементы option и его содержимое. Для получения атрибута используем метод ПолучитьАтрибут(), а для получения содержимого элемента используем метод ТекстовоеСодержимое() Получить. Эти данные мы сохраним в структуре Партнер("Город", "НомерНаСайте", "Партнер"), которую в свою очередь добавим в массив. Вот тут у меня вопрос к читателям: как лучше сделать - передавать по одной структуре на сервер и там сохранять в справочнике или собрать все структуры в массив и передать массив на сервер? Я попробовал оба варианта, и по мне лучше второй. Далее мы подгружаем все страницы с информацией о участниках поочередно. Для получения информации об участниках необходимо найти таблицу без шапки (элемент tbody) и в нем получить все строки (элемент tr). После этого просматриваем все ячейки строки (элемент td) на соответствие атрибута class одному из условий. Все условия мы с вами рассмотрели ранее. Когда получаем элементы ячеек, нам необходимо выполнить некоторую обработку:

  1. В ячейке "Номинация" необходимо найти элемент span и на основании атрибута class данного элемента получить номинацию;
  2. Разобрать атрибут title в ячейке с количеством баллов, чтобы получить отдельно баллы за тест, за акцию ВК и баллы от партнеров.

Все полученные данные сохраняем в структуру Участник("ФИО", "Номинация", "БаллыТест", "БаллыВК", "БаллыПарт", "ОбщиеБаллы", "Сертификат", "Партнер"). Как и в случае с партнерами, данную структуру добавляем в массив. Полученные массивы отправляем на сервер для сохранения. В итоге функция получилась следующая:

&НаКлиенте
Процедура ОбновляемИнформацию(Знач Адрес)
	Страница = ПолучитьСтраницуВОбъектDOM(Адрес);	
	ОбъектыСписка = Страница.ПолучитьЭлементыПоИмени("option");
	Партнер = Новый Структура;                   
	МассивПартнеров = Новый Массив;
	МассивУчастников = Новый Массив;
	Для каждого Объект Из ОбъектыСписка Цикл
		ПартнерГород = СтрРазделить(Объект.ТекстовоеСодержимое,",");
		Номер  = Объект.ПолучитьАтрибут("value");
		Партнер.Вставить("Город",СокрЛП( ПартнерГород[0]));
		Партнер.Вставить("НомерНаСайте",Номер);
		Партнер.Вставить("Партнер",СокрЛП(ПартнерГород[1]));
		МассивПартнеров.Добавить(Новый Структура ("Город,НомерНаСайте,Партнер",Партнер ["Город"], Партнер ["НомерНаСайте"], Партнер ["Партнер"])    );
		СтраницаПартнер = ПолучитьСтраницуВОбъектDOM("http://thebest.its.1c.ru/public/reg_tour/"+Партнер ["НомерНаСайте"]);
		Участник = Новый Структура;
		Таблица = СтраницаПартнер.ПолучитьЭлементыПоИмени("tbody");
		СтрокиТаблицы = Таблица[0].ПолучитьЭлементыПоИмени("tr");
		Для каждого Строка Из СтрокиТаблицы Цикл
			ПоляТаблицы = Строка.ПолучитьЭлементыПоИмени("td");
			Для каждого Поле Из ПоляТаблицы Цикл
				Если Поле.ПолучитьАтрибут("class") = "regional_tour__fio"  Тогда
					Участник.Вставить("ФИО",Поле.ТекстовоеСодержимое);	
				КонецЕсли; 
				Если Поле.ПолучитьАтрибут("class") = "regional_tour__nomination_td"  Тогда
					Номинации = Поле.ПолучитьЭлементыПоИмени("span");
					Номинация = "";
					Номинация = ?(Номинации[0].ПолучитьАтрибут("class")="nomination it","Информационные технологии",Номинация);
					Номинация = ?(Номинации[0].ПолучитьАтрибут("class")="nomination k","Кадры",Номинация);
					Номинация = ?(Номинации[0].ПолучитьАтрибут("class")="nomination b","Бухгалтерия",Номинация);
					Участник.Вставить("Номинация",Номинация);	
				КонецЕсли;
				Если Поле.ПолучитьАтрибут("class") = "text-center"  Тогда
					МассивБаллов = СтрРазделить(Поле.ПолучитьАтрибут("title"),",");
					БаллыТест = 0; БаллыВК = 0; БаллыПарт = 0;
					Для каждого Элемент Из массивБаллов Цикл
						Баллы = СтрРазделить(Элемент,":");
						Если СокрЛП(Баллы [0]) = "Тест"  Тогда
							БаллыТест=СокрЛП(Баллы [1]);
						ИначеЕсли СокрЛП(Баллы [0]) = "акция Вконтакте"  Тогда
							БаллыВК=СокрЛП(Баллы [1]);
						ИначеЕсли СокрЛП(Баллы [0]) = "акция от партнера"  Тогда 
							БаллыПарт=СокрЛП(Баллы [1]);
						КонецЕсли; 
						Участник.Вставить("БаллыТест", БаллыТест);
						Участник.Вставить("БаллыВК", БаллыВК); 
						Участник.Вставить("БаллыПарт", БаллыПарт);
					КонецЦикла; 
					Участник.Вставить("ОбщиеБаллы", Поле.ТекстовоеСодержимое);
				КонецЕсли;
				Если Поле.ПолучитьАтрибут("class") = Неопределено  Тогда
					Участник.Вставить("Сертификат",Поле.ТекстовоеСодержимое);	
				КонецЕсли; 
			КонецЦикла; 
			МассивУчастников.Добавить(Новый Структура ("ФИО,Номинация,БаллыТест,БаллыВК,БаллыПарт,ОбщиеБаллы,Сертификат,Партнер", Участник ["ФИО"],Участник ["Номинация"],Участник ["БаллыТест"],Участник ["БаллыВК"],Участник ["БаллыПарт"],Участник ["ОбщиеБаллы"],Участник ["Сертификат"],Партнер ["НомерНаСайте"]  ));
		КонецЦикла; 
	КонецЦикла; 
	ОбновитьПартнеров(МассивПартнеров);
	ОбновитьУчастников(МассивУчастников);
КонецПроцедуры

Сохранение данных в справочниках

Для сохранения данных в справочниках мы создадим функции ОбновитьУчастников(МассивУчастников) и ОбновитьПартнеров(МассивПартнеров):

&НаСервере
Процедура ОбновитьПартнеров(Знач МассивПартнеров)
	Для каждого Партнер Из МассивПартнеров Цикл
		ТекущийПартнер = Справочники.Партнеры.НайтиПоРеквизиту("НомерНаСайте", Партнер ["НомерНаСайте"]);
		Если ТекущийПартнер = Справочники.Партнеры.ПустаяСсылка() Тогда
			ТекущийПартнер = Справочники.Партнеры.СоздатьЭлемент();
		Иначе
			ТекущийПартнер = ТекущийПартнер.ПолучитьОбъект();
		КонецЕсли; 
		ТекущийПартнер.НомерНаСайте = Партнер ["НомерНаСайте"];
		ТекущийПартнер.Город = Партнер ["Город"];
		ТекущийПартнер.Партнер = Партнер ["Партнер"];
		ТекущийПартнер.Наименование = Партнер ["Город"] + ", " + Партнер ["Партнер"];
		ТекущийПартнер.Записать();
	КонецЦикла; 
КонецПроцедуры

&НаСервере
Процедура ОбновитьУчастников(Знач МассивУчастников)
	Для каждого Участник Из МассивУчастников Цикл
		ТекущийУчастник = Справочники.Участники.НайтиПоНаименованию(Участник["ФИО"]);
		Если ТекущийУчастник = Справочники.Участники.ПустаяСсылка() Тогда
			ТекущийУчастник = Справочники.Участники.СоздатьЭлемент();
		Иначе
			ТекущийУчастник = ТекущийУчастник.ПолучитьОбъект();
		КонецЕсли;
		ФИО = СтрРазделить(Участник ["ФИО"], " ");
		ТекущийУчастник.Фамилия = ФИО [0];
		ТекущийУчастник.Имя = ФИО [1];
		ТекущийУчастник.Отчество = ФИО [2];
		ТекущийПартнер = Справочники.Партнеры.НайтиПоРеквизиту("НомерНаСайте", Участник ["Партнер"] );
		ТекущийУчастник.Партнер = ТекущийПартнер;
		ТекущийУчастник.БаллыЗаТест = Участник ["БаллыТест"];
		ТекущийУчастник.БаллыВК = Участник ["БаллыВК"];
		ТекущийУчастник.БаллыПартнер = Участник ["БаллыПарт"];
		ТекущийУчастник.ОбщиеБаллы = Участник ["ОбщиеБаллы"];
		ТекущийУчастник.Наименование = Участник ["ФИО" ];
		ТекущийУчастник.Сертификат = Участник ["Сертификат" ];
		ТекущийУчастник.Записать();
	КонецЦикла; 
КонецПроцедуры

Осталось только сделать приятные мелочи по оформлению, но каждый делает на свой вкус и цвет. Я вывел форму списка справочника Участники единственной на рабочую облать начальной страницы, и вместо вывода номера сертификата я применил условное форматирование (строка выделяется цветом, если человек получил сертификат). В итоге получилось следующее:

Итог

Скачать файлы

Наименование Файл Версия Размер
Конфигурация 1С: Лучший пользователь 1С ИТС
.cf 19,18Kb
19.09.18
12
.cf 0.01 19,18Kb 12 Скачать

Специальные предложения

Вознаграждение за ответ
Показать полностью
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
В этой теме еще нет сообщений.
Оставьте свое сообщение

См. также

Безопасная работа с транзакциями во встроенном языке Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    28378    9    tormozit    44    

Краткое руководство по внесению изменений в конфигурацию

Практика программирования v8 1cv8.cf Абонемент ($m)

Кратко описаны основополагающие моменты при старте групповой разработки конфигурации несколькими программистами. Полезно для проектной документации как требование к разработчикам или сопровождающей компании.

1 стартмани

13.01.2020    13011    17    sapervodichka    41    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Абонемент ($m)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

1 стартмани

07.10.2019    24665    13    HostHost    40    

Описание формата внутреннего представления данных 1С в контексте обмена данными

Практика программирования Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Фирма 1С не рекомендует использовать внутреннее представление данных для любых целей, которые отличны от обмена с 1С:Предприятием 7.7. Но сама возможность заглянуть на "внутреннюю кухню" платформы с помощью функций ЗначениеВСтрокуВнутр(), ЗначениеВФайл(), ЗначениеИзСтрокиВнутр() и ЗначениеИзФайла(), дала возможность сообществу программистов 1С разработать новые приемы разработки и анализа. Так, именно на использовании внутреннего представления был построен алгоритм "быстрого массива", который позволяет практически мгновенно создать массив в памяти на основании строки с разделителями. С помощью разбора внутреннего представления можно "на лету" программным кодом выполнить анализ обычной формы и даже сделать редактор графической схемы. Во внутреннем формате сохраняют свои данные между сеансами различные популярные внешние обработки. А еще это возможность сделать быстрый обмен с внешними системами.

1 стартмани

06.09.2019    15531    11    Dementor    29    

Вам нравятся запросы в 1С? Промо

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    16508    4    m-rv    86    

Конвейер проверки качества кода

Инструментарий разработчика Практика программирования Математика и алгоритмы v8 1cv8.cf Абонемент ($m)

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    18555    20    Stepa86    44    

Процедура ПриКомпоновкеРезультата

Практика программирования v8 1cv8.cf Абонемент ($m)

Коллекция кода

1 стартмани

26.07.2019    28886    13    vasilev2015    57    

1С:Ассемблер. Немного летнего веселья!

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Все вы, наверное, слышали, что 1С-ники жалуются на свою систему, считая язык 1С недостаточно низкоуровневым, скучным и т.п. Все они с тоской поглядывают в сторону "настоящих" языков программирования. Так вот, господа, они неправы. В системе 1С есть места, где можно размять программерский мозг и получить удовольствие от низкоуровневой техники. Предлагаю вам погрузиться в недра виртуальной машины 1С и понять, как она работает. Там есть свой "ассемблер" и мы попробуем его в действии!

1 стартмани

21.06.2019    23799    74    Evil Beaver    117    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") Промо

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    26667    86    m-rv    57    

Простые примеры сложных отчетов на СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Подписи в отчете. Особенности соединения наборов: как соединить несоединяемое. Остатки на дату и обороты по месяцам в одном отчете. Курс валюты на каждую дату без группировок и соединений в запросе. Отчет с произвольными колонками и с произвольной последовательностью. "Неадекватный отчет".

1 стартмани

12.06.2019    25037    19    Hatson    22    

Баг или фича? Неожиданное поведение платформы

Практика программирования Тестирование и исправление Разработка v8 1cv8.cf Абонемент ($m)

Рассмотрим несколько случаев неожиданного поведения платформы 1С, а также что с этим можно cделать.

18.02.2019    20023    0    YPermitin    89    

HTML в новой версии 8.3.14 на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX

Универсальные обработки Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Тестируем возможности HTML в новой версии 8.3.14 платформы на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX.

1 стартмани

29.01.2019    24549    85    Synoecium    46    

Заполняем по шаблону (по умолчанию) Промо

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    24140    19    mvxyz    17    

Отладка сложных отчетов на СКД

Практика программирования v8 v8::СКД 1cv8.cf Россия Абонемент ($m)

Расширение для отладки сложных отчетов на СКД (в т.ч. для собираемых программно "на лету") и быстрого перехода к отладке таких отчетов в консоли запросов и отчетов на СКД.

1 стартмани

28.12.2018    23194    83    maxx    58    

Реализация простого http-сервиса "Просмотр карточки номенклатуры(товара) в браузере"

Практика программирования v8 1cv8.cf Абонемент ($m)

Практический пример реализации простого http-сервиса средствами 1С Предприятие 8.3. Обеспечивает просмотр списка товаров и просмотр данных товара в браузере.

1 стартмани

07.12.2018    19880    15    dmitry1975    32    

Использование подсистемы БСП "Заполнение объектов"

Практика программирования Универсальные функции БСП (Библиотека стандартных подсистем) v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Применение механизмов БСП для добавления новых команд заполнения к формам различных объектов. Использование расширений конфигурации для доработки. Шаблоны для реализации собственных команд заполнения.

1 стартмани

23.11.2018    22346    12    ids79    23    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    23804    61    vasvl123    9    

HTTP Сервисы: Путь к своему сервису. Часть 3

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    28664    45    dsdred    13    

HTTP Сервисы: Путь к своему сервису. Часть 1

Практика программирования WEB v8 1cv8.cf Абонемент ($m)

Уже много было написано про http-сервисы, но то и дело всплывают «Новые» статьи по обмену между базами V8 по COM, что «Немножко» удивляет. Решил внести свои 5 копеек, поработаем с http-сервисом.

1 стартмани

15.07.2018    68634    23    dsdred    24    

Полезные примеры составления схемы компоновки данных #2

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Еще один набор примеров как решить частные задачи в СКД

1 стартмани

22.05.2018    26410    11    SITR-utyos    13    

Работа с публикациями "Инфостарт" Промо

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    17175    12    RocKeR_13    16    

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    39524    33    dsdred    36    

Работа со схемой запроса

Инструментарий разработчика Практика программирования v8 v8::Запросы Абонемент ($m)

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    39544    83    kalyaka    34    

Асинхронная запись и чтение файла без использования модальных методов и временных файлов

Практика программирования v8 1cv8.cf Абонемент ($m)

В статье рассмотрено решение задачи формирования и записи файла на основе данных информационной базы. Формирование происходит на стороне сервера с помощью механизма потоков. Используются асинхронные методы передачи файлов между клиентом и сервером. Также рассмотрено решение обратной задачи - чтение файла и запись его данных в информационную базу. Статья ориентирована прежде всего на новичков, также приведенный код может использоваться в качестве шаблона.

1 стартмани

10.04.2018    25354    19    Alxby    23    

Как выполнить отчет на СКД через COM и получить данные отчета? Промо

Практика программирования v8 УПП1 Россия Абонемент ($m)

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    24471    8    wowik    3    

Бесплатная проверка контрагентов в ФНС (общий модуль с алгоритмом). На примере выводим статус в список справочника контрагентов

Практика программирования v8 1cv8.cf Абонемент ($m)

Если вам интересно проверить контрагенте в ФНС, вам поможет данная публикация. Весь алгоритм работы строится на основе данных, полученных с сервиса http://npchk.nalog.ru совершенно бесплатно.

1 стартмани

01.02.2018    32033    54    rpgshnik    48    

Расширение возможностей печати: Вывод произвольного нижнего и верхнего колонтитула

Печатные формы документов Практика программирования Универсальные функции v8 1cv8.cf Абонемент ($m)

Расширяем функционал вывода нижнего / верхнего колонтитула. Стандартно 1С имеет достаточно ограничений по выводу и наполнению колонтитулов содержимым, взять хотя бы такие, как вывод только текста и отсутствие ограничения на номер конечной страницы. А при разработке кода сталкиваешься с тем, что свой блок с нижним колонтитулом нужно прижимать к низу страницы. Казалось бы быстро решаемый вопрос, но и в нем есть нюансы. Сейчас я расскажу о том, как решалась эта задача. UPD 15.02.2018. Добавлен вывод верхнего колонтитула; Вывод колонтитулов на первой и последней странице управляется параметрами; Научился считать страницы: Добавлено заполнение переменных аналогичных стандартным из колонтитулов; Задаются форматы даты и времени. Ограничения прежние: 1. Повторно сформировать табличный документ после смены параметров страницы интерактивно.; 2. Передавать данные для более плотной печати как можно более мелко нарезанными кусками.

1 стартмани

29.12.2017    34521    27    agent00mouse    0    

Практика доступа в базу 1С через протокол oData. Чтение данных

Сервисные утилиты Практика программирования Администрирование данных 1С v8 1cv8.cf Абонемент ($m)

Для чего нужен доступ в базу 1С через REST-интерфейс по протокол oData? Как его организовать? Как не будучи гуру в JavaScript и .NET получить быстрый визуальный доступ к данным базы 1С? Попробую дать ответ на эти вопросы и прокомментирую некоторые нюансы, с которыми я столкнулся.

1 стартмани

11.12.2017    82998    292    Dementor    44    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции Промо

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    24188    25    informa1555    26    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    23997    49    kwazi    6    

Простой бесплатный DashBoard с помощью http сервиса

Практика программирования v8 Абонемент ($m)

Как создать свой DashBoard без дополнительных затрат и сложных технических доработок.

1 стартмани

25.11.2017    50830    62    dewersia    32    

Полезный код для программистов 1С (часть 1). Управление свойствами элементов формы. Хранение копии данных реквизитов

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

У каждого программиста за время работы накапливается полезный инструментарий, которым он привык пользоваться. Естественно и у меня он тоже имеется. И вот решено было немного поделиться с сообществом. Возможно идеи не новые. Более того, допускаю, что реализованы они не самым оптимальным образом. Но ведь для этого сообщество и существует, чтобы делиться с ним, получая обратную связь.

1 стартмани

24.09.2017    38650    15    vandalsvq    80    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут Промо

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    43900    36    Demanoidos    60    

Telegram-боты

Практика программирования v8 Абонемент ($m)

Описание теории, разбор архитектуры и пример реализации telegram-ботов. Сразу скажу, со структурированием изложения мало что могу поделать. :) редакция от 18.07.2018 Правки последней редакции выделены жирным.

1 стартмани

01.09.2017    27822    125    PLAstic    52    

Макеты СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Рассмотрены некоторые типовые задачи, которые решаются с помощью предопределенных макетов, а также перечислены несколько случаев, для которых макеты не подходят

1 стартмани

25.07.2017    87641    121    json    27    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    111500    13    signum2009    45    

Как нарисовать граф на 1С Промо

Практика программирования v8 Абонемент ($m)

Описывается реализация на языке запросов 1С метода расположения вершин графа на плоскости, основанного на использовании электромеханической аналогии. При этом вершины графа представляются одноименными электрическими зарядами, дуги - пружинками. Силы взаимодействия вершин в этой системе переводят их из случайного начального в нужное конечное положение. Приведена обработка рисования графов "ГрафОграф", реализующая данный подход, показывающая также динамику процесса. Граф можно задать списком ребер вручную, выбрать из нескольких предопределенных примеров или сформировать по данным информационной базы.

1 стартмани

09.08.2013    68067    205    ildarovich    117    

Многопоточность. Универсальный «Менеджер потоков» (фреймворк) с отслеживанием зависимости объектов

Практика программирования Математика и алгоритмы Универсальные функции Производительность и оптимизация (HighLoad) v8 1cv8.cf Россия Абонемент ($m)

Восстановление партий, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

26.05.2017    45938    15    DarkAn    86    

Регулярные выражения – это просто. Построитель и отладчик регулярных выражений

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагается к использованию построитель регулярных выражений. Выполненный в виде внешней обработки, он позволит строить сложно-структурированные выражения на основе параметрического описания, тестировать их, и в результате получить программный код 1С.

1 стартмани

13.03.2017    27706    110    romasna    49    

Разбираемся с механизмом Дополнительные отчеты и обработки в БСП

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Чуть более комплексное описание, чем на других ресурсах

1 стартмани

30.10.2016    134999    920    json    65    

Работа с данными выбора Промо

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    36820    17    kalyaka    16    

Несколько шаблонов для доработки типовых конфигураций

Практика программирования Инструментарий разработчика v8 v8::УФ Абонемент ($m)

Предлагаю несколько каркасов для создания новых объектов в типовых конфигурациях. Это выжимка из кода нескольких конфигураций, которая позволит быстро и красиво создавать и дорабатывать объекты метаданных с соблюдением идеологии исходной системы

1 стартмани

03.10.2016    33380    95    json    25    

Хранение файлов в томах на диске (для УПП 1.3)

Практика программирования v8 УПП1 Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    51853    7    wowik    29    

БСП 2.3 и БСП 3.0: Просто про выполнение внешней обработки в фоне (c индикацией прогресса выполнения)

Инструментарий разработчика Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Простое пояснение о том, как сделать внешнюю обработку с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП 2.3.2. UPDATE 20/09/19: добавлен вариант обработки с индикацией процента выполнения и статусом выполнения для БСП 3.0.

1 стартмани

18.05.2016    55364    159    rozer    64    

Быстрое определение интервалов в запросе Промо

Практика программирования v8 Абонемент ($m)

В статье описывается новый метод определения интервалов между данными различных записей в запросе. В отличие от общеизвестного метода, время работы предлагаемого метода зависит от объема данных ЛИНЕЙНО. Это обеспечивает ему значительный выигрыш по быстродействию на больших объемах данных. В качестве иллюстрации возможностей метода приведен отчет, показывающий гистограмму распределения времени между продажами.

1 стартмани

01.10.2015    46903    32    ildarovich    41    

Остатки на каждый день в запросе

Практика программирования Учет ТМЦ Учет ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    49233    19    arakelyan    18    

Выполнение JavaScript кода из 1С в объекте Поле HTML Документа (HTML 5) и вызов события в 1С ПриНажатии

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример выполнения JS кода из 1С в Поле HTML Документа под управляемыми формами, с удобным получением результата в 1С(С помощью вызова привязанного события ПриНажатии к элементу ПолеHTMLДокумента)

1 стартмани

22.03.2016    72471    145    igo1    51    

Количество дней недели (понедельников/вторников/...) в заданном диапазоне одним запросом

Практика программирования v8 Абонемент ($m)

При реализации периодического авто-заполнения маршрутных листов по графику (недельному) необходимо было просчитать стоимость всего периода, с условием выездов только по определенным дням. Заморачиваться с обходом результата не хотелось. Пришлось написать "Небольшой" запрос.

1 стартмани

03.03.2016    15908    1    Alexander.Shvets    5    

Простой способ индексирования интервалов Промо

Практика программирования v8 Абонемент ($m)

Предлагается простой способ индексирования интервалов для решения задач выборки записей, включающих заданный момент времени, пересекающихся с заданным интервалом или множеством интервалов. Способ основан на добавлении к исходной таблице особого числового индексированного поля, рассчитываемого по специальной формуле. Приведен код функций, необходимых для расчетов поля поиска и параметров поисковых запросов. Приведены также результаты тестирования метода, доказывающие его высокую эффективность.

1 стартмани

28.09.2016    37452    38    ildarovich    22    

Простые радости жизни программиста 1С: выбор типа значения

Работа с интерфейсом Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    45008    47    yuraos    17    

Отображение прогресса выполнения длительных операций в БСП и их отладка в текущем сеансе.

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

В статье описан способ исполнения длительных операций в конфигурациях, в которых используется библиотека стандартных подсистем, с визуализацией прогресса исполнения и отображения хода обработки данных. Также дается краткое описание процесса отладки длительных операций в текущем сеансе.

1 стартмани

17.02.2016    48643    161    balanton    23    

Яндекс.Деньги "Благотворительность"

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Яндекс.Деньги теперь в 1С. Форма для приема благотворительных взносов. Форму легко сделать и вставить на любую страницу сайта или блога. Платежи будут приходить на ваш кошелек. На форме есть три способа платежа: из кошелька, с банковской карты, с баланса мобильного.

1 стартмани

16.02.2016    21062    8    Tatitutu    5    

Мастер рассылки e-mail 2.2 для управляемых форм

Практика программирования Email v8 v8::УФ ERP2 БП3.0 УТ11 Абонемент ($m)

Для пользователей: переделанный из старый разработки под 8.2 с использованием библиотеки Мастер рассылки e-mail 2.2 (ERP, УТ, БП) (Только управляемые формы), который теперь может запускаться под любой версией платформы с разрешенными или запрещенными модальными/синхронными вызовами в конфигурации. Также удобный выбор e-mail и их владельцев с помощью отбора динамического списка по любым критериям и галочки исключения.

1 стартмани

29.12.2015    34957    19    milkers    4