IE2017

“Вес и Объем” в 1С:Управление торговлей 10.3

Программирование - Практика программирования

Доработка Счета на Оплату в 1С: Управление торговлей 10.3 с Весом и Объемом.

Очень удобная информация. Скажете, для чего это нужно? для логистики и вывода информации по “Номенклатуре” и подсчету веса и объема. Очень удобно, когда при выборе номенклатуры сразу выводится информация по товару в этом же окне, вес и объем, не надо сохранять и печатать как часто встречаются внешние печатные формы и обработки и отчеты.

Конфигуратор-Документ-СчетНаОплатуПокупателю-ФормаДокумента-ФормаДокумента-Модуль

Процедура ОбновитьПодвал()
//info
            Объем1=0;
            Вес1=0;
Для каждого Стр Из Товары Цикл
Объем1=Объем1+Стр.Количество*Стр.Номенклатура.ЕдиницаХраненияОстатков.Объем;            Вес1=Вес1+Стр.Количество*Стр.Номенклатура.ЕдиницаХраненияОстатков.Вес;    
КонецЦикла;   
           ЭлементыФормы.Объем.Значение=Объем1;
           ЭлементыФормы.Вес.Значение=Вес1;
//info
КонецПроцедуры // ОбновитьПодвал()

И еще если хотите, чтобы подсвечиволось номенклатура, в которой не проставлен Вес.

Конфигуратор-Документ-СчетНаОплатуПокупателю-ФормаДокумента-ФормаДокумента-Модуль

Процедура ТоварыПриПолученииДанных (Элемент, ОформленияСтрок)             

//info   
Для каждого ОформлениеСтроки из ОформленияСтрок Цикл
 Если ОформлениеСтроки.ДанныеСтроки.Номенклатура.ЕдиницаХраненияОстатков.Вес Тогда
  ЦветФона=Новый Цвет (255, 255, 255);
    Иначе
  ЦветФона=Новый Цвет (255, 147, 244);
КонецЕсли;
ОформлениеСтроки.ЦветФона=ЦветФона;
КонецЦикла;
//info


См. также

Комментарии
1. Евгений Абдуразаков (asdfgcom) 99 18.01.17 23:45 Сейчас в теме
Денис. Нет роста. С 14 года мог бы и оригинальнее что-то..
Звезду за смелость.
2. Александр Крынецкий (echo77) 740 25.01.17 19:01 Сейчас в теме
Единица хранения остатков на количество из документа говоришь?
А что если, единица хранения остатков не совпадает с единицой измерения, указанной в документе?
3. Сергей Огородников (Serg O.) 133 31.01.17 13:00 Сейчас в теме
легче добавить 2 столбца (можно и без изменения метаданных) -Вес и Объем

а при Получении данных таб.части (если эти столбцы видны) - пересчитывать прямо в таблице
вес и объем по каждой строке

да, согласен с пред.комментарием... вес и объем надо из Единиц измерения брать... прямо из таблицы
Итоги - тоже лучше прямо в таблице отражать... в Подвале, там же итоговое количество и суммы...

автоматически пересчитываются при [v] ОтображатьИтогиВПодвале - очень полезная "галочка" прямо в форме

Оставьте свое сообщение