"Картотека арбитражных дел". Запрос к картотеке из 1С (обычные формы)

Публикация № 527228

Разработка - Системная интеграция - Интеграция с WEB

Картотека

Пример работы с сервисом "Картотека арбитражных дел" для проверки новых Контрагентов. Реализовано в виде внешней обработки.

Задача - облегчить руководству проверку "на благонадежность" новых Контрагентов.

Выбор сервиса:

1) возможность бесплатной работы (что, согласитесь, немаловажно)

2) оперативное поступление новой информации об арбитражных делах

3) быстрый ответ сервиса

ПРЕДУПРЕЖДЕНИЕ: На сайте сервиса размещена защита от роботов, поэтому количество запросов к базе данных ОГРАНИЧЕНО!!!

При превышении количества обращений блокируется IP-адрес, далее только письмо к Администратору сервиса.

Поэтому будет рассмотрен пример одиночного запроса. Сайт иногда может быть перегружен запросами, поэтому таймаут выставлен побольше.

Процедура КнопкаВыполнитьНажатие(Кнопка)

    Если НЕ ЗначениеЗаполнено(Контрагент) Тогда
        ОбщегоНазначения.СообщитьОбОшибке("Не выбран Контрагент!!!");
        Возврат;
    КонецЕсли;

    Если НЕ ЗначениеЗаполнено(Контрагент.ИНН) Тогда
        ОбщегоНазначения.СообщитьОбОшибке("У Контрагента не заполнен ИНН !!!");
        Возврат;
    КонецЕсли;

    Если НачПериода <> '00010101' Тогда
        НачПериодаСтрокой = """" + ДатаВремяВФорматXMLИз1СМТ(НачПериода) + """";
    Иначе
        НачПериодаСтрокой = "null";
    КонецЕсли;

    Если КонПериода <> '00010101' Тогда
        КонПериодаСтрокой = """" + ДатаВремяВФорматXMLИз1СМТ(КонПериода) + """";
    Иначе
        КонПериодаСтрокой = "null";
    КонецЕсли;

    ПостЗапрос = Новый COMОбъект("WinHttp.WinHttpRequest.5.1");

    MSScriptControl = Новый COMОбъект("MSScriptControl.ScriptControl");
    MSScriptControl.Language = "javascript";
    Стрим = Новый COMОбъект("ADODB.Stream");
    MSScriptControl.AddObject("Стрим", Стрим);
    MSScriptControl.AddObject("Соединение", ПостЗапрос);

    Стрим.Mode = 3;
    Стрим.Type = 1;

    ПостЗапрос.SetTimeouts(50000, 50000, 50000, 50000);
    ПостЗапрос.Open("POST", "http://kad.arbitr.ru/Kad/SearchInstances", 0);

    ПостЗапрос.SetRequestHeader("Accept", "*/*");
    ПостЗапрос.SetRequestHeader("Content-Type", "application/json");

    СтрокаЗапроса = "{""Page"":1,""Count"":25,""Courts"":[],""DateFrom"":" + НачПериодаСтрокой + ",""DateTo"":" + КонПериодаСтрокой + ",""Sides"":[{""Name"":" + СокрЛП(Контрагент.ИНН) +
    ",""Type"":-1,""ExactMatch"":false}],""Judges"":[],""CaseNumbers"":[],""WithVKSInstances"":false}";

    ResponseText = "";
    Попытка
        ПостЗапрос.Send(СтрокаЗапроса);
        ПостЗапрос.WaitForResponse();
    исключение
        Сообщить(ОписаниеОшибки());
    КонецПопытки;

    Стрим.Open();
    Попытка
        MSScriptControl.Eval("Стрим.Write(Соединение.responseBody)");
    Исключение
        Отказ = Истина;
        Возврат;
    КонецПопытки;

    ИмяФайлаПолучения = ПолучитьИмяВременногоФайла();
    Стрим.SaveToFile(ИмяФайлаПолучения, 2);
    Стрим.Close();

    Текст = Новый ТекстовыйДокумент;
    Текст.Прочитать(ИмяФайлаПолучения, КодировкаТекста.UTF8);

    ResponseText = Текст.ПолучитьТекст();

    ДокументDOM = ПреобразоватьТекстВДом(ResponseText);

    ЭлементыDOM = ДокументDOM.ПолучитьЭлементыПоИмени("input");

    Для Каждого ЭлементDOM Из ЭлементыDOM Цикл

        Если ЭлементDOM.Идентификатор = "documentsTotalCount" И ЭлементDOM.Значение = "0" Тогда

            ResponseText = "  Арбитражных дел нет";

        КонецЕсли;

    КонецЦикла;

    EntranceText = СокрЛП(Контрагент) + " (ИНН: " + СокрЛП(Контрагент.ИНН) + ")<br>" + ResponseText;

    ЭлементыФормы.ДокументHTML.УстановитьТекст(EntranceText);

    // 2016-04-01T00:00:00 Вид даты "DateTo":"2016-04-26T23:59:59"

    Если РазбиратьТекст Тогда

        ЭлементыDOM    =  ДокументDOM.ПолучитьЭлементыПоИмени("div");

        Для Каждого ЭлементDOM Из ЭлементыDOM Цикл

            Если ЭлементDOM.ИмяКласса = "civil" Тогда
                Сообщить("Дата дела = " + СокрЛП(ЭлементDOM.ТекстовоеСодержимое));
            КонецЕсли;

            Если ЭлементDOM.ИмяКласса = "judge" Тогда
                Сообщить("Судья = " + СокрЛП(ЭлементDOM.ТекстовоеСодержимое));
            КонецЕсли;

            Если ЭлементDOM.ИмяКласса = "num_case" Тогда

                Сообщить("Номер дела = " + СокрЛП(ЭлементDOM.ТекстовоеСодержимое));

            КонецЕсли;

        КонецЦикла;

    КонецЕсли;

КонецПроцедуры
Функция ПреобразоватьТекстВДом(ТекстОтвета) Экспорт
   ЧтениеHTML = Новый ЧтениеHTML;
   ЧтениеHTML.УстановитьСтроку(ТекстОтвета);
   ПостроительDOM = Новый ПостроительDOM;
   Возврат ПостроительDOM.Прочитать(ЧтениеHTML);
КонецФункции
Функция ДатаВремяВФорматXMLИз1СМТ(лДатаВремя = Неопределено, Тип = "ДатаВремя") Экспорт

    ДатаВремя = ?(лДатаВремя = Неопределено, ТекущаяДата(), лДатаВремя);

    НужнаяДата = Формат(ДатаВремя, "ДФ=""гггг-ММ-дд""");

    НужноеВремя = Формат(ДатаВремя, "ДФ=""ЧЧ:мм:сс""");

    Если Тип = "Дата" Тогда
        НужноеЗначение = НужнаяДата;
    ИначеЕсли Тип = "Время" Тогда
        НужноеЗначение = НужноеВремя;
    Иначе
        Если ПустаяСтрока(НужнаяДата) или  ПустаяСтрока(НужноеВремя) Тогда
            Возврат "";
        КонецЕсли;
        НужноеЗначение = НужнаяДата + "T" + НужноеВремя;
    КонецЕсли;

    Возврат НужноеЗначение;

КонецФункции //ДатаВремяВФорматXMLИз1СМТ()

POST-запрос рабочий, опытный программист быстро адаптирует текст под собственные нужды. Если кому-то понадобится дополнительное "украшательство", то в конце процедуры есть пример частичного парсинга кода (нам не потребовалось).

Пользуйтесь на здоровье!

Удачи в разработке

Скачать файлы

Наименование Файл Версия Размер
Картотека арбитражных дел

.epf 9,22Kb
25.05.16
10
.epf 9,22Kb 10 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. luda_2008 19.04.17 15:19 Сейчас в теме
Спасибо огромное за обработку.Очень пригодилась.
2. consulting group WA 21 25.06.18 14:19 Сейчас в теме
Ох не просто все с этим КАД. Мы при разработке своего решения на 1С с функцией интеграции с kad.arbitr намучались, они на КАД все время что-то меняют, но в итоге продукт рабочий http://you-right.ru/sudebno-pretenzionnaya-rabota
3. antonpiter 13.03.20 10:53 Сейчас в теме
Добрый день! А запросы к картотеке еще актуальны? У меня приходит ответ "Доступ к сервису недоступен по юридическим причинам!"...
Оставьте свое сообщение

См. также

Внешняя компонента для работы по Web-socket протоколу Промо

Разработка внешних компонент WEB v8 Абонемент ($m)

Кто когда-нибудь сталкивался с обменом данными по Web-Socket (wss) протоколу из 1С, тому известно, что в платформе отсутствуют данные механизмы (не путать с HTTP запросами и WebServices). Предлагается использовать внешнюю компоненту, написанную по технологии NativeAPI, для подключения и обмена с серверами из 1С-Предприятия, работающими по протоколу Web-Socket.

5 стартмани

30.03.2018    24314    34    Ditron    68    

HTTP сервисы по OpenAPI спецификациям

Практика программирования WEB v8 1cv8.cf Абонемент ($m)

Начинаем путь разработки HTTP сервисов с создания спецификаций OpenAPI. Автодокументация сервисов формата Swagger UI без зависимостей. Настройка сервисов в режиме предприятия.

1 стартмани

29.06.2020    4732    1    shmalevoz    19    

Конструктор HTTP-соединений в 1С (обычные и управляемые формы)

WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Иногда возникают мысли о том, чтобы прикрутить сервисы, связанные с HTTP-соединениями, в 1С. Необходимо писать обработку и анализировать результат.

1 стартмани

02.06.2020    3199    21    Denr83    0    

DaJet QL - расширяемый язык запросов

Интеграция WEB v8 Абонемент ($m)

DaJet QL поддерживает практический полный синтаксис SQL Server 2005-2016. Кроме этого это расширяемый язык запросов. Обращение к объектам СУБД выполняется в терминах метаданных 1С. Доступ к возможностям этого языка запросов реализован в виде web api сервиса. Результаты запросов возвращаются в виде JSON.

1 стартмани

20.04.2020    5200    9    zhichkin    16    

Работа с релизами 1С и договорами ИТС Промо

WEB БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Работа с релизами 1С и партнерским кабинетом.

2 стартмани

15.08.2019    12878    38    RocKeR_13    13    

Пример работы с Trello из 1С

WEB v8 1cv8.cf Россия УУ Абонемент ($m)

Небольшая конфигурация содержит примеры обмена с онлайн-сервисом Trello.

1 стартмани

15.02.2020    9154    36    terrorion    8    

Взаимодействие HTML (COM объект, WebKit) с 1С (обычные и управляемые формы)

Внешние источники данных WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Показан пример использования HTML (COM объект, WebKit) в 1С (8.3).

2 стартмани

18.01.2020    6730    19    Deniskinr83    0    

Google drive - менеджер файлов

WEB Внешние источники данных v8 1cv8.cf Россия Абонемент ($m)

Синхронизация с гугл диском легко и просто!

10 стартмани

05.12.2019    8110    25    zykov_vitaliy    22    

Проверка VAT номеров Промо

WEB v8 1cv8.cf Абонемент ($m)

Обработка для вызова сервиса проверка VAT номера.

1 стартмани

26.11.2018    11295    1    wtlz    1    

Автозаполнение адреса по КЛАДР в УПП при выгрузке контрагента с портала компании (API dadata)

WEB v8 1cv8.cf Абонемент ($m)

Заведение, согласование контрагентов организовано на портале компании. Далее по web-сервису контрагенты выгружаются в УПП (юр.адрес и факт.адрес выгружаются строкой). Задача автоматизировать заполнение адреса в УПП по КЛАДР.

1 стартмани

03.12.2019    5679    1    John_d    10    

Работа с Яндекс-картами в 1С (вывод меток, прокладка маршрута, отображение балуна, вывод меток в кластеры) (обычное и управляемое приложение)

WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Работа с Яндекс-картами в 1С (управляемое приложение). Обработка показывает, как можно найти адреса на карте Яндекс, проложить маршрут.

2 стартмани

20.11.2019    10714    104    Denr83    0    

Пример взаимодействия HTML (COM объект, WebKit) с 1С (динамический отбор) (обычные и управляемые формы)

WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Показан пример использования WebKit в 1С (8.3).

2 стартмани

18.11.2019    8164    12    Denr83    0    

Трекинг номеров РПО в Почте России Промо

WEB Оптовая торговля Оптовая торговля v8 Оптовая торговля, дистрибуция, логистика Абонемент ($m)

Относительно недавно Почта России стандартизировала и описала сервисы получения информации о регистрируемом почтовом отправлении (РПО). Представляю вашему вниманию конфигурацию-обертку над сервисами Почты России. Она позволяет просто (http-запросы) и без изменений конфигурации подключить сервисы отслеживания к своим информационным системам.

2 стартмани

28.03.2016    25535    10    Smaylukk    3    

Яндекс сервисы [Расширение]

Универсальные обработки WEB v8 1cv8.cf Абонемент ($m)

Расширение для работы с Яндекс-сервисами (предиктор,переводчик,проверка орфографии)

1 стартмани

24.10.2019    10295    7    noprogrammer    8    

Telegram бот на 1С

WEB v8 1cv8.cf Абонемент ($m)

Telegram бот на 1С в виде внешней обработки, встраиваемой в типовые 1С 8.3.

1 стартмани

24.09.2019    13119    31    budidich    19    

Выгрузка номенклатуры в социальную сеть Вконтакте

WEB Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 1cv8.cf Абонемент ($m)

Обработка для быстрой и легкой выгрузки товаров Вконтакт. Так просто еще не было)))

2 стартмани

14.08.2019    12614    42    kaliuzhnyi    43    

Работа с картой. Кадастровый учет (Росреестр). Тематические карты Промо

WEB Рабочее место v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка для работы с картами в 1С. Получения изображения с публичной кадастровой карты России, построения тематических карт

5 стартмани

31.08.2017    16558    10    vipchep    0    

Подключение к сайту и отправка или получение данных по API (POST, GET...) (с описанием кода)

WEB v8 1cv8.cf Абонемент ($m)

Простая обработка по отправке или получение данных с любого сервера главное знать ресурс (выполняемую функцию) и тело запроса.

1 стартмани

12.08.2019    11231    18    MaxPowerr    5    

Конфигурация для обмена данными (интеграционная шина)

Внешние источники данных WEB v8 1cv8.cf Абонемент ($m)

Система позволяет организовать обмен данными, как с базами 1С, так и любыми другими приложениями. Система представляет собой отдельную конфигурацию. Система позволяет организовать гибкие возможности по настройке обмена. В качестве брокера сообщений, для передачи данных, используется отдельная самостоятельная конфигурация на 1С. Комплект поставки содержит файл расширения для "клиентской" части шины, данное расширение позволяет без снятия "ключа" организовать гибкий механизм обмена данными.

4 стартмани

08.07.2019    10197    26    miha-28    17    

Шаблон http-сервиса для вашего проекта

Внешние источники данных WEB Мобильная разработка v8 v8::Mobile 1cv8.cf Абонемент ($m)

Http-сервис для обмена данными в формате JSON. Обработчики этого сервиса находятся во внешней обработке, что позволяет дорабатывать его без изменения конфигурации. Также прилагаю пример мобильного приложения для работы с данным сервисом (получает номенклатуру и остатки на складе). Сервис очень быстро разворачивается и масштабируется под ваши задачи.

3 стартмани

04.05.2019    17846    71    MarkoSokolov    47    

Работа с картами 1С 4 в 1: Яндекс, Google , 2ГИС, OpenStreetMap(OpenLayers) Промо

Универсальные обработки WEB v8 1cv8.cf Абонемент ($m)

С каждым годом становится все очевидно, что использование онлайн-сервисов намного упрощает жизнь. К сожалению по картографическим сервисам условия пока жестковаты. Но, ориентируясь на будущее, я решил показать возможности API выше указанных сервисов: Инициализация карты Поиск адреса на карте с текстовым представлением Геокодинг Обратная поиск адреса по ее координатами Взаимодействие с картами - прием координат установленного на карте метки Построение маршрутов по указанным точками Кластеризация меток на карте при увеличении масштаба Теперь также поддержка тонкого и веб-клиента

1 стартмани

28.12.2012    102061    1156    Smaylukk    348    

1С и WebKit. Вариант взаимодействия

WEB v8 1cv8.cf Абонемент ($m)

В результате перехода на WebKit тип свойства Документ у поля, имеющего вид ПолеHTMLДокумента, изменился с COMОбъект на ВнешнийОбъект. Также изменилась DOM модель документа, доступная через это свойство.

2 стартмани

23.02.2019    25898    71    mi1man    55    

Строим маршруты на картах в 1С с помощью OpenStreetMap, OSRM и Leaflet

WEB v8 1cv8.cf Транспорт, автопарки, такси Абонемент ($m)

Краткая статья о том как вывести на карту (в 1С) маршруты с помощью OpenStreetMap, OSRM и Leaflet. По данной системе очень мало примеров, но так как OpenStreetMap является бесплатным сервисом и не требует никаких ключей и регистраций, и является довольно мощным механизмом, решил написать небольшую статью "как это сделать?". В первую очередь скажу, все намного проще, если вы используете последнюю версию платформы (8.3.14), где есть поддержка практически всех браузеров (IE 11, EDGE, Mozilla), но что делать если у нас не самая свежая платформа, где поддержка только IE 9?

2 стартмани

12.02.2019    22635    87    Ditron    71    

Яндекс карта в документе "Заказ клиента" на закладке "Доставка". (Расширение) УТ 11.4

Обработка документов WEB Оптовая торговля Оптовая торговля v8 УТ11 Россия УУ Абонемент ($m)

Показ яндекс карты в документе "Заказ клиента" на закладке "Доставка" и печать карты для курьера с контактными данными. (Расширение)

3 стартмани

05.02.2019    9788    12    ret    7    

Пример использования REST API Яндекс Диска Промо

WEB v8 1cv8.cf Абонемент ($m)

Пример использования REST API Яндекс Диска: чтение диска, добавление каталога, загрузка файла, скачивание файлов или каталогов, удаление файлов или каталогов.

1 стартмани

26.06.2018    22703    34    MKFreeUser    14    

Яндекс карты 2.1. Построение маршрута. Передача длины маршрута в реквизит формы

WEB v8 1cv8.cf Абонемент ($m)

Пригодится как пример использования Яндекс карты 2.1 для построения маршрута.

1 стартмани

24.01.2019    12380    68    John_d    32    

Веб-форма авторизации/регистрации/восстановления пароля для веб-клиента 1С с помощью HTML/CSS/PHP/HTTP-сервисов 1С

WEB v8 1cv8.cf Абонемент ($m)

Пришла в голову идея создать универсальную веб-форму входа в веб-клиент 1С на HTML/CSS/PHP/HTTP-сервисы 1С. Чтобы прямо как на нормальных сайтах. Заодно и для ознакомления с 1С с новой, для себя, стороны. Интересно было попробовать интеграцию PHP - 1С.

1 стартмани

08.11.2018    15842    25    Бэнни    18    

Загрузка чека онлайн-касс (загрузка товаров из чека)

Внешние источники данных WEB Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 1cv8.cf Абонемент ($m)

Обработка-пример, позволяет любому и из любой конфигурации загрузить информацию о товарах из чека(и не только) из почтового сообщения, отправленного из приложения ФНС проверка чеков.

2 стартмани

08.10.2018    18485    31    echo77    50    

Работа с публикациями "Инфостарт" Промо

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    20221    13    RocKeR_13    16    

SOAP для чайников

Обмен через XML WEB v8 1cv8.cf Абонемент ($m)

Немножко про SOAP сервис. И пример работы с подключением и получением данных по SOAP за 5 минут.

1 стартмани

05.09.2018    43496    37    dusha0020    18    

Класс-обработка “Работа с картами Яндекс”

Разработка внешних компонент WEB v8 Абонемент ($m)

Как показать точку или маршрут на карте Яндекс. Как получить координаты по строке адреса (геокодирование).

1 стартмани

01.08.2018    22517    189    RSConsulting    15    

Чтение сжатого gzip, deflate HTTP ответа сервера. Без ВК. Уменьши время загрузки и сократи трафик в 3 раза

WEB v8 1cv8.cf Абонемент ($m)

В платформе 1С:Предприятие не реализовано штатного механизма декодирования ответа веб серверов, в которых присутствует gzip сжатие. Некоторые использовали WinHttpRequest.5.1 , кто-то писал ВК. Друзья, хватит. Вот вам решение.

1 стартмани

08.06.2018    14198    71    Malfarion    16    

Конфигурация для просмотра публичных телеграм каналов Промо

WEB v8 Абонемент ($m)

Просмотр и каталогизация в более удобном виде публичных телеграм каналов, групп и чатов.

1 стартмани

02.06.2018    16674    10    DO_WHILE_LOOP    7    

Простой эмулятор вызова веб-сервиса 1С с просмотром результата

Обмен через XML WEB v8 1cv8.cf Россия Абонемент ($m)

Последнее время все чаще сталкиваюсь с разработкой веб-сервисов средствами 1С. Для ускорения разработки и отладки написал внешнюю обработку. На какой-то сверх-крутой функционал она не претендует, но, может, кому-то пригодится.

1 стартмани

24.04.2018    11955    19    anvolkov1cbit    9    

Интеграция между Atlassian Jira и 1С:Предприятие 8.3 используя Jira REST API (выборка, создание и изменение запросов, чтение, создание и удаление записей о работах, чтение комментариев и другие возможности)

Внешние источники данных WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка на управляемой форме для 1С:Предприятие 8.3 по интеграции с Atlassian Jira используя Jira REST API. Ключевые функции: выборка запросов с использованием JQL; добавление и изменение запросов; добавление, изменение и удаление записей о работах; чтение комментариев к запросам; сохранение всех ключевых параметров между сеансами работы. Тестирование проводилось на платформе 1С (8.3.11.2954) совместно с JIRA Server platform (7.3.7)

1 стартмани

24.04.2018    29297    167    Ko1t    77    

Простая и пошаговая интеграция Яндекс-Алисы и 1С

WEB v8 Абонемент ($m)

Интеграция Алисы и 1С через http сервис на платформе 8.3.9. Используем виртуальный сервер, сертификат от letsencrypt, и делаем простые запросы к базе из Алисы.

1 стартмани

09.04.2018    21140    18    kiv1c    34    

Обмен файловыми базами данных через Yandex диск Промо

WEB v8 Россия Абонемент ($m)

Выполнение операций обмена с Yandex диском для файловых БД, по протоколу WebDav, в автоматическом или ручном режимах.

1 стартмани

11.06.2018    16129    5    slimper    1    

Чтение и запись из таблиц гугл (google sheets) в табличный документ 1С (8.3, управляемые формы)

Внешние источники данных WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка на управляемой форме для 1С версии 8.3 для доступа к сервисам Google Sheets c использованием протокола авторизации OAuth 2.0. Выполняет получение списка листов таблицы гугл, чтение таблицы гугл в табличный документ 1С и запись из табличного документа 1С в таблицу гугл. Тестирование проводилось на платформе 1С:Предприятие 8.3 (8.3.11.2954).

1 стартмани

09.04.2018    35924    235    Ko1t    71    

2 в 1: Проверить действительность паспорта / Получить ИНН по паспорту

Обработка справочников WEB Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::УФ ERP2 БП3.0 ЗУП3.x Россия БУ Абонемент ($m)

Представляю вашему вниманию внешнюю обработку заполнения элемента справочника "Физические лица". Обработка выполнена с использованием API (для работы необходим доступ в интернет), содержит полностью открытый код и 2 команды: Проверка документа, удостоверяющего личность, в списке недействительных паспортов и Заполнение ИНН по паспортным данным.

1 стартмани

27.02.2018    21489    137    VladimirElohov    38    

(beta) Обмен 1С с интернет-магазином OpenCart

WEB Оптовая торговля Оптовая торговля v8 v8::ОУ УТ10 Оптовая торговля, дистрибуция, логистика УУ Абонемент ($m)

Обмен 1С с интернет-магазином OpenCart через ODBC и ftp. Демонстрирую основные используемые механизмы. Есть ссылка на сайт, на который все выгружаю. Буду благодарен конструктивным предложениям.

1 стартмани

14.01.2018    12038    25    ogre2007    8    

Сервер push сообщений “Push0k“ 18.05 Промо

WEB v8 1cv8.cf Абонемент ($m)

Аналог других “мессенджеров“. Позволяет практически все то же самое, что и другие решения. За исключением смайлов, эмодзи, голосовой и видео связи. Основное отличие от других решений, открыта и доступна для изменения серверная и клиентская часть месенджера. Общедоступной серверной части нет, за серверную часть отвечаете вы сами.

1 стартмани

19.12.2017    16788    12    PloAl    20    

Загрузка кассовых чеков с сервера ФНС. Расширение для 1С: Деньги

WEB Кассовые операции Кассовые операции v8 1cv8.cf Домашние учет и финансы Россия УУ Абонемент ($m)

Для тех, кто ведет домашние финансы в 1С:Деньги. Расширение поможет сократить время на ввод данных о расходах, вместо набивания данных руками, данные чека (сумму и товары) можно загрузить из электронного чека, который хранится на сервере ФНС.

1 стартмани

17.11.2017    19754    63    Bazil    49    

Построение маршрута доставки с расчётом расстояния для любой базы УФ Промо

Универсальные обработки WEB Оптовая торговля Оптовая торговля v8 v8::УФ 1cv8.cf Абонемент ($m)

Графическое изображение маршрутного листа по картам гугл. Работает на любой конфигурации с управляемыми формами. Использует новую версию api google-карт от 13.02.2018 года под IE11.

10 стартмани

24.02.2018    33797    42    KorotkovRV    16    

Проверка контрагентов по ИНН и КПП через веб-сервис ФНС (внешняя) Промо

Обработка справочников WEB v8 1cv8.cf Россия Абонемент ($m)

Обработка проверяет контрагентов по ИНН и КПП через веб-сервис ФНС на наличие регистрации в ЕГРН. Может выполняться в любых типовых конфигурациях, при наличии справочника "Контрагенты" и реквизитов "ИНН" и "КПП"

1 стартмани

25.12.2014    38769    130    Willforre    12