Простой скрипт для работы с ТСД

Публикация № 593402

Учет и отчетность - Оптовая торговля

ТСД OneScript инвентаризация TCP telnet

14
Небольшой скрипт, исполняемый в среде OneScript, реализует работу TCP-сервера с telnet-клиентом ТСД. Позволяет проводить инвентаризацию товара по штрих кодам с сохранением результатов и протокола в реальном времени на компьютер. Для работы нужен ТСД, имеющий Wi-Fi интерфейс и telnet-клиент.

Как это работает

Для запуска (компиляции) скрипта потребуется OneScript, инструкция по его использованию здесь.

Скрипт последовательно считывает входящий текстовый поток с ТСД, и когда получает завершающий символ строки или полный код (во второй версии скрипта), обрабатывает полученный код и возвращает ответ терминалу.

При запуске скрипт создает файл результатов и файл протокола. Имена файлов содержат текущую дату и код магазина, указанный как параметр при запуске скрипта. Протокол работы ТСД также отображается на сервере в окне командной строки, где запущен скрипт.

Скрипт работает с штрих-кодами EAN13. Каждый промаркированный товар имеет свой уникальный штрих код, состоящий из кода номенклатуры и порядкового номера. Для определения наименования номенклатуры, скрипт подгружает данные из xml файла выгрузки справочника номенклатуры.

Сканер ТСД отправляет отсканированный код скрипту, а он возвращает текущее насчитанное количество данной номенклатуры. В случае повторного сканирования кода, на терминал выводится предупреждающий сигнал и сообщение о повторе кода, количество не увеличивается. Код также можно ввести вручную с клавиатуры ТСД.

В процессе работы можно просмотреть текущие результаты подсчета. Для этого на клавиатуре ТСД нужно нажать 1, завершить работу скрипта - 9. В случае перезапуска скрипта, он подгрузит сохраненные результаты работы. В случае обрыва связи с сервером подсчета кодов не происходит.

Скрипт устанавливает только одно соединение, поэтому при необходимости одновременной работы с несколькими ТСД, можно запускать несколько экземпляров скрипта на разных портах. Скрипт тестировался с клиентом TelnetCE в режиме эмуляции VT200 и кодировкой windows-1251. Вторая версия тестировалась с клиентом ConnectBot под Android.

Немного кода

Процедура работы с клиентом:

Процедура ЗапуститьСервер(Порт)
	
	Сервер = Новый TCPСервер(Порт);
	Сервер.Запустить();
	ПротоколСообщить("Сервер запущен");
	Пока НЕ ОстановитьСервер Цикл
		Соединение = Неопределено;
		Пока Соединение = Неопределено Цикл
			Соединение = Сервер.ОжидатьСоединения(100);
		КонецЦикла;
		Запрос = "";
		ЗапросСтрока = "";
		ПротоколСообщить("Соединение установлено");
		Пока Соединение.Активно И НЕ ОстановитьСервер Цикл
			Если Запрос = "" Тогда
				Попытка
					ЗапросСтрока = ЗапросСтрока + Соединение.ПрочитатьСтроку("windows-1251");
				Исключение
					Продолжить
				КонецПопытки;
				Если НЕ Прав(ЗапросСтрока, 1) = Символы.ВК Тогда
					Продолжить
				КонецЕсли;
				Запрос = СтрЗаменить(ЗапросСтрока, Символы.ПС, "");
				Запрос = СтрЗаменить(Запрос, Символы.ВК, "");
				Запрос = СтрЗаменить(Запрос, "A", "");
				ЗапросСтрока = "";
				ТекВремя = Формат(ТекущаяДата(), "ДЛФ=T");
				Если СтрДлина(Запрос) = 1 Тогда
					Если Запрос = "1" Тогда
						ПоказатьРезультаты();
					ИначеЕсли Запрос = "2" Тогда
						Прервать;
					ИначеЕсли Запрос = "9" Тогда
						ОстановитьСервер = Истина;
					КонецЕсли;
					Запрос = "";
				ИначеЕсли СтрДлина(Запрос) = 13 Тогда
					Код = Сред(Запрос, 2, 6);
					ТекКоличество = Количество.Получить(Код);
					Если НЕ ТекКоличество = Неопределено Тогда
						ТекКоличество = 1 + ТекКоличество;  
						Ответ = "" + ТекКоличество + " - " + Номенклатура.Получить(Код) + " - " + Запрос;
						НайтиПовтор = ШхКоды.Получить(Запрос);
						Если НЕ ЗначениеЗаполнено(НайтиПовтор) Тогда
							Количество.Вставить(Код, ТекКоличество);
							ШхКоды.Вставить(Запрос, ТекВремя);
							Результаты.ЗаписатьСтроку(Запрос);
						Иначе
							Ответ = Символ(7) + "Повтор кода: " + Запрос + " (" + НайтиПовтор + ")"; 
						КонецЕсли;
					Иначе
						Ответ = Символ(7) + "Неверный / неизвестный код: " + Запрос;
					КонецЕсли
				Иначе
					Ответ = Символ(7) + "Неверный код / команда: " + Запрос;
				КонецЕсли;
			Иначе
				Попытка
					ОтправитьОтвет(Ответ);
					Запрос = "";
				Исключение
				КонецПопытки;
			КонецЕсли
		КонецЦикла;
		Соединение.Закрыть();
		ПротоколСообщить("Соединение закрыто");
	КонецЦикла;
	Сервер.Остановить();
	ПротоколСообщить("Сервер остановлен");

КонецПроцедуры

 

Вторая версия скрипта:

Процедура ЗапуститьСервер(Порт)
	
	Сервер = Новый TCPСервер(Порт);
	Сервер.Запустить();
        ПротоколСообщить("Сервер запущен на порту: " + Порт);
        ПротоколСообщить("Дата инвентаризации: " + ФорматДата);

	Запрос = "";
	Ответ = "";
	ЗапросСтрока = Неопределено;
	
	Пока НЕ ОстановитьСервер Цикл
		Соединение = Неопределено;
		Пока Соединение = Неопределено Цикл
			Соединение = Сервер.ОжидатьСоединения(200);
		КонецЦикла;
		Соединение.ТаймаутОтправки = 300; 
		Соединение.ТаймаутЧтения = 300;
		ПротоколСообщить("Соединение установлено");
		ОтправитьОтвет("Дата инвентаризации: " + ФорматДата + ПСВК);
		ТекВремя = Формат(ТекущаяДата(), "ДЛФ=T");
		ОтправитьОтвет(ТекВремя + " Соединение установлено" + ПСВК);
		Ошибки = 0;
		Пока Соединение.Активно И НЕ ОстановитьСервер И Ошибки < 5 Цикл
			ОтправитьОтвет(Символы.ВК);
			Если ЗапросСтрока = Неопределено Тогда
				ОтправитьОтвет(">");
				ПротоколСообщить(">");
			КонецЕсли;
			Попытка
				ЗапросСтрока = "";
				ЗапросСтрока = Соединение.ПрочитатьСтроку("windows-1251");
				ЗапросСтрока = СтрЗаменить(ЗапросСтрока, Символы.ПС, "");
				ЗапросСтрока = СтрЗаменить(ЗапросСтрока, Символы.ВК, "");
				Запрос = Запрос + ЗапросСтрока;
				//ЗапросСтрока = СтрЗаменить(ЗапросСтрока, "A", "");
			Исключение
				Если Запрос = "" Тогда
					Продолжить
				КонецЕсли;
			КонецПопытки;
			Если Запрос = "1" Тогда
				ОтправитьОтвет(ПСВК);
				ПоказатьРезультаты();
                Запрос = "";
				ЗапросСтрока = Неопределено;
				Продолжить;
			ИначеЕсли Запрос = "2" И ЗапросСтрока = "2" Тогда
				ОтправитьОтвет(ЗапросСтрока);
				ПротоколСообщить(ЗапросСтрока);
				Пока СтрДлина(Запрос) < 13 И Соединение.Активно И НЕ ОстановитьСервер И Ошибки < 5 Цикл
					Попытка
						ЗапросСтрока = "";
						ЗапросСтрока = Соединение.ПрочитатьСтроку("windows-1251");
						ЗапросСтрока = СтрЗаменить(ЗапросСтрока, Символы.ПС, "");
						ЗапросСтрока = СтрЗаменить(ЗапросСтрока, Символы.ВК, "");
						Запрос = Запрос + ЗапросСтрока;
						//ЗапросСтрока = СтрЗаменить(ЗапросСтрока, "A", "");
						ОтправитьОтвет(ЗапросСтрока);
						ПротоколСообщить(ЗапросСтрока);
					Исключение
					КонецПопытки;
				КонецЦикла;
				ОтправитьОтвет(ПСВК);
			ИначеЕсли Запрос = "9" Тогда
				ОстановитьСервер = Истина;
				Прервать;
			КонецЕсли;
			Если Лев(Запрос, 1) = "2" Тогда
				Если СтрДлина(Запрос) >= 13 Тогда
					ТекВремя = Формат(ТекущаяДата(), "ДЛФ=T");
					стрКод = Лев(Запрос, 13);
					Код = Сред(стрКод, 2, 6);
					ТекКоличество = Количество.Получить(Код);
					Ответ = стрКод + " " + ПСВК;
					Если НЕ ТекКоличество = Неопределено Тогда
						НайтиПовтор = ШхКоды.Получить(стрКод);
						Если НЕ ЗначениеЗаполнено(НайтиПовтор) Тогда
							ТекКоличество = 1 + ТекКоличество;  
							Ответ = Ответ + " " + Номенклатура.Получить(Код) + " #" + ТекКоличество;
							Количество.Вставить(Код, ТекКоличество);
							ШхКоды.Вставить(стрКод, ТекВремя);
							Результаты.ЗаписатьСтроку(стрКод);
						Иначе
							Ответ = Ответ + Символ(7) + "!Повтор кода (" + НайтиПовтор + ")"; 
						КонецЕсли;
					Иначе
						Ответ = стрКод + " " + ПСВК + Символ(7) + "Неверный код / команда";
					КонецЕсли;
					Запрос = Сред(Запрос, 14);
					ПротоколСообщить(Ответ);
					ОтправитьОтвет(Ответ + ПСВК);
					ЗапросСтрока = Неопределено;
					Продолжить
				КонецЕсли;
			КонецЕсли;
			Ответ = Запрос + " " + ПСВК + Символ(7) + "Неверный код / команда";
			ПротоколСообщить(Ответ);
			ОтправитьОтвет(Ответ + ПСВК);
			Запрос = "";
			ЗапросСтрока = Неопределено;
		КонецЦикла;
		Соединение.Закрыть();
		ПротоколСообщить("Соединение закрыто");
	КонецЦикла;
	Сервер.Остановить();
	ПротоколСообщить("Сервер остановлен");

КонецПроцедуры

Как использовать

Данный скрипт не является универсальным решением, т.к. писался под конкретную задачу. Можно взять его за основу и немного доработав, например, передавать данные напрямую в конфигурацию 1С.

14

Скачать файлы

Наименование Файл Версия Размер
ws.os
.os 9,77Kb
02.03.17
1
.os 9,77Kb 1 Скачать
ws2.os
.os 12,59Kb
10.05.18
0
.os 12,59Kb Скачать

Специальные предложения

Избранное Подписка Сортировка: Древо
В этой теме еще нет сообщений.
Оставьте свое сообщение

См. также

Компактный шаблон чека для ККТ Атол 5

Отчеты и формы Программист Архив с данными Розничная и сетевая торговля (FMCG) Россия Розничная торговля Абонемент ($m) Печатные формы документов

Всем привет! Сделали для себя максимально компактный шаблон кассового чека. В стандартном шаблоне место используется, скажем так, не очень рационально. Если вы устали менять кассовую ленту несколько раз в день, а самому возиться с редактором шаблонов лениво, то этот шаблон для вас. Шаблон тестировался на кассе Атол 22Ф (АТОЛ FPrint-22ПТК), ширина чека 48 символов (80мм).

1 стартмани

02.08.2019    2424    5    Rans    2       

Импорт товаров в весы Масса-К ВПМ, вместе с составом товаров, одним махом 0

Инструменты и обработки Программист Архив с данными Розничная торговля Абонемент ($m) Весы

В двух словах: заполненный выложенный в архиве Excel документ вам присылают Клиенты (они дополняюют его из 1С допустим, это база товаров). Вы этот докуент конвертируете с помощью конвертера(он в архиве) в промежуточную .dbf базу. И потом ее загружаете в Менеджер данных Про и корректируете. Это почти одним махом делается импорт в весы ВПМ Этот способ описывает Импорт товаров в базу программы Менеджер данных PRO, а затем в весы ВПМ. Здесь я описываю тот случай, когда 1) у Клиента нет в 1С базы весовых товаров, которые ему необходимо загрузить в весы ВПМ. Номенклатуры весовых товаров очень много, и у каждого товара есть Состав, причем состав Клиенту нужен на 2-х языках (на русском и на государственном местном, допустим, Казахском или Татарском) 2) Когда у Клиента есть в 1С есть все весовые товары, но в Карточках Товара отсутствует Состав Товара Часто при выгрузке из 1С и при этом способе, при дальнейшем редактировании товаров, не удается сохранить изменения в Менеджер Данных PRO, выходит такая ошибка "Could not convert variant of type "NULL" into type "OleStr". В инструкции я описываю, как ее устранить.

1 стартмани

25.06.2019    1456    1    brotherm    0       

Сверка 76.АВ с книгой покупок по ставкам НДС 18% и 20%. Проверка зачета аванса по ставкам НДС 18% и 20% в 1 квартале 2019 г. Переход на 20% НДС. Закрытие квартала 18% и 20% НДС 1

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::БУ 1С7:Комплекс Россия БУ Оптовая торговля НДС Абонемент ($m) Бухгалтерские Анализ учета

Отчет написан для Комплексной конфигурации 4.2. Отчет позволяет выполнить сверку кредитовых оборотов счета 76.АВ (НДС с авансов полученных) с книгой покупок, проверить правильность выписки счетов фактур на зачет аванса по счетам БУ в разрезе разных ставок НДС 18% и 20% в комплексной конфигурации 1С:Предприятия 7.7. Позволяет найти и исправить ошибки в процессе перехода на 20% НДС. Помогает с закрытием квартала 18% и 20% НДС. Отчет обновлен для анализа данных 2 квартала 2019 года и всех следующих кварталов (стал более универсальным).

1 стартмани

27.03.2019    7265    6    ksnik    5       

Конструктор мобильного клиента Simple WMS Client: способ создать полноценный ТСД без мобильной разработки. Теперь новая версия - Simple UI (обновлено 14.11.2019) 175

Инструменты и обработки Программист Архив с данными v8 v8::Mobile БУ УУ Android Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Абонемент ($m) Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Мобильная разработка

Simple WMS Client – это визуальный конструктор мобильного клиента для терминала сбора данных(ТСД) или обычного телефона на Android. Приложение работает в онлайн режиме через интернет или WI-FI, постоянно общаясь с базой посредством http-запросов (вариант для 1С-клиента общается с 1С напрямую как обычный клиент). Можно создавать любые конфигурации мобильного клиента с помощью конструктора и обработчиков на языке 1С (НЕ мобильная платформа). Вся логика приложения и интеграции содержится в обработчиках на стороне 1С. Это очень простой способ создать и развернуть клиентскую часть для WMS системы или для любой другой конфигурации 1С (УТ, УПП, ERP, самописной) с минимумом программирования. Например, можно добавить в учетную систему адресное хранение, учет оборудования и любые другие задачи. Приложение умеет работать не только со штрих-кодами, но и с распознаванием голоса от Google. Это бесплатная и открытая система, не требующая обучения, с возможностью быстро получить результат.

5 стартмани

09.01.2019    22936    223    informa1555    172       

Анализ активности продавцов для УТ 11 3

Отчеты и формы Бизнес-аналитик Пользователь Руководитель проекта Внешний отчет (ert,erf) v8 v8::ОУ v8::СКД УТ11 Розничная и сетевая торговля (FMCG) Россия УУ Розничная торговля Абонемент ($m) Управленческие

Отчет позволяет проанализировать качество работы продавцов, а также сравнить показатели розничных точек продаж (магазинов).

5 стартмани

26.11.2018    3530    Zalipaka    0       

Расширение "Интерфейс Плюс" 42

Отчеты и формы Бухгалтер Пользователь Расширение (cfe) v8 v8::ОУ Розница УТ11 Россия УУ Розничная торговля Абонемент ($m) Рабочее место

Расширение для 1С:Розница 2.2 и 1С:Управление Торговлей 11, которое позволит повысить удобство работы!

3 стартмани

22.09.2018    11094    95    RocKeR_13    81       

Как просто прочитать чеки из фискального накопителя на вашем ПК 38

Статья Системный администратор Архив с данными Розничная и сетевая торговля (FMCG) Россия Розничная торговля Абонемент ($m) ККМ

Переходник ФН-ПК USB за примерно 100 рублей. В работе часто бывают ситуации, когда нужно подключить фискальный накопитель к ПК. Ну например, касса не работает, восстанавливать работоспособность кассы неоправданно дорого, а закрыть фискальный накопитель и передать чеки в ИФНС все же нужно.

1 стартмани

12.09.2018    16069    7    roman3d    28       

Помощник корректировки остатков ЕГАИС в небольшом магазине. Розница 2.2 12

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Розничная торговля Абонемент ($m) Обработка документов

Данная обработка упрощает корректировку остатков алкогольной продукции небольшого магазина, где предполагается передача всей продукции в торговый зал сразу после приемки.

5 стартмани

08.09.2018    15682    78    asdfgcom    45       

Рабочее Место Кассира (РМК+) для фискальных регистраторов АТОЛ (всех) и Штрих (тоже всех), без 1С и вообще без АСУТ 7

Инструменты и обработки Бухгалтер Руководитель проекта Архив с данными Россия Windows Кассовые операции Розничная торговля Абонемент ($m) Фискальный регистратор Рабочее место

Не хотите покупать 1С? У вас всего 5-10 товаров или услуг? Тогда это решения для вас! Проложение Рабочее Место Кассира+ (РМК+) решает 1 задачу: соблюдение 54-ФЗ Приложение позволяет печатать чеки на фискальных регистраторах Атол и Штрих без покупки 1С. При этом выполняются все требования 54-ФЗ! Ели вам нет необходимости внедрять учет, если вам не нужно ничего, кроме печати чеков - РМК+ самое дешевое решение на рынке. Отличительная особенность: открытый код на VBS

1 стартмани

07.09.2018    5257    5    mat skywalker    10       

Загрузка файлов/картинок/изображений/фото номенклатуры PRO 20

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ Розница УНФ УТ11 Россия Оптовая торговля Розничная торговля Абонемент ($m) Управленческий учет (прочее)

Пожалуй, самая многофункциональная обработка для пополнения каталога. Сопоставление изображений с номенклатурой по артикулу, коду и подстроке; обновление/замена, удаление фото; установка основного изображения по расширению или по любой части наименования файла. Информация о файлах и результаты сопоставления с номенклатурой отображается в таблице. Для каждого изображения есть возможность предпросмотра. Процесс загрузки картинок отображается через прогресс-бар.

1 стартмани

03.08.2018    9384    70    zannv    24       

ЕГАИС 3 Контролёр для 1С:Розница 7

Инструменты и обработки Системный администратор Пользователь Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Android Розничная торговля Абонемент ($m) Терминал сбора данных

Оградите себя от рисков отзыва лицензии на торговлю алкоголем, штрафов и блокировок в ЕГАИС. Проверяйте поступающую алкогольную продукцию помарочно на соответствие ТТН ЕГАИС v3 перед тем, как подтвердить получение и принять её на баланс в ЕГАИС. С 01.07.2018 начинается переход ЕГАИС на помарочный учет алкогольной продукции на всех стадиях товародвижения, начиная от производства или ввоза на территорию России, до реализации в розничной торговле, т.н. "ЕГАИС 3.0". В типовой Рознице уже появилась обработка для контроля поступивших акцизных марок на ПК. Предлагаю ознакомиться с мобильным решением. Контроль производится в Android приложении на ТСД или на обычном смартфоне.

1 стартмани

13.06.2018    10238    16    kuld    30       

Пробитие чеков через ККМ в офисе (для курьеров) 12

Инструменты и обработки Пользователь Расширение (cfe) v8 v8::ОУ Розница УТ11 Россия БУ Кассовые операции Розничная торговля Абонемент ($m) ККМ Фискальный регистратор

Предлагается интеграция 1С с ККТ СтарРус. Поддерживается одновременная работа с разных рабочих мест. ККТ СтарРус работает как сервер, и принимает команды через API по http-протоколу, что позволяет пробивать чеки через центральную базу 1С для интернет-магазина и для курьеров.

1 стартмани

07.06.2018    18821    27    Kutuzov    12       

Валовая прибыль в текущем месяце. Актуальная себестоимость (рассчитывается из последней цены закупки с учетом доп.расходов) 12

Отчеты и формы Бизнес-аналитик Пользователь Руководитель проекта Внешний отчет (ert,erf) v8 v8::ОУ УТ11 УУ Оптовая торговля Учет доходов и расходов Абонемент ($m) Управленческие

Валовая прибыль "Вместо себестоимости - Закупочные цены + Доп. расходы". Дополнительный внешний отчет для конфигурации Управление торговлей 11. Отчет поможет предприятиям, если нет возможности: - закрывать месяц ежедневно; - считать себестоимость вообще по разным причинам. В отчет попадают закупочные цены на *конецпериода* формирования отчета + дополнительные расходы.

7 стартмани

16.03.2018    13272    61    zaika007    41       

Время продаж чеков по магазинам в УТ 11, КА. Аналитический отчет + Диаграмма 7

Отчеты и формы Руководитель проекта Внешний отчет (ert,erf) v8 v8::ОУ УТ10 УТ11 КА2 Розничная и сетевая торговля (FMCG) УУ Розничная торговля Абонемент ($m) Управленческие

Отчет "Диаграмма по времени продаж чеков" предназначен для планирования графиков работы продавцов-менеджеров, для планирования маркетинговых мероприятий.

2 стартмани

16.03.2018    11600    8    zaika007    12       

Отчет по среднему чеку в торговле УТ 11; КА 2 9

Отчеты и формы Руководитель проекта Внешний отчет (ert,erf) v8::ОУ v8::УФ УТ11 УУ Розничная торговля Абонемент ($m) Управленческие

Данный отчет позволяет посмотреть средние чеки в разрезе продавцов, магазинов и ККМ в конфигурации "Управление торговлей 11". Данный отчет был протестирован на всех версиях конфигурации Управление торговлей 11*Х. и КА 2*Х

3 стартмани

15.03.2018    11756    20    zaika007    15       

Автоматизация отдела продаж - CRM конфигурация для небольшой компании 12

Отчеты и формы Руководитель проекта Конфигурация (md, cf) v8 Россия УУ Управление взаимоотношениями с клиентами (СRM) Оптовая торговля Абонемент ($m) Управленческий учет (прочее)

Вам нужна несложная и многофункциональная автоматизированная система управления продажами для автоматизации отдела продаж? Наша CRM Система поможет Вам! Внедрение займет не более 15 минут. A-CRM - быстрая и безболезненная автоматизация отдела продаж. Без лишних затрат и сложностей. Интеграция с 1С Бухгалтерией 3 и 1С УТ 11.

1 стартмани

05.03.2018    12595    36    user718500    12       

Построение маршрута доставки с расчётом расстояния для любой базы УФ 57

Инструменты и обработки Руководитель проекта Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Оптовая торговля Абонемент ($m) Универсальные обработки WEB

Графическое изображение маршрутного листа по картам гугл. Работает на любой конфигурации с управляемыми формами. Использует новую версию api google-карт от 13.02.2018 года под IE11.

10 стартмани

24.02.2018    20255    36    KorotkovRV    16       

Анализ распределения заказов по предоплатам 6

Отчеты и формы Бизнес-аналитик Внешний отчет (ert,erf) v8 УПП1 УУ Оптовая торговля Абонемент ($m) Статистические

Отчет, в котором предоплаты разделены по интервалам (порогам) предоплат.

1 стартмани

21.02.2018    9512    1    wowik    0       

Кассовая программа "Касса" 5

Инструменты и обработки Системный администратор Бухгалтер Архив с данными БУ Windows Кассовые операции Розничная торговля Абонемент ($m) ККМ Фискальный регистратор

Кроме функционала, который есть практически во всех подобных программах, в нашей программе есть две очень полезные функции: во-первых, если вам или вашим сотрудникам, нужно постоянно знать текущую наличную и безналичную выручку во всех кассах всех ваших магазинов, то это можно сделать, обзвонив все ваши магазины, или просто установить приложение в смартфон и настроить программу Касса на всех рабочих местах кассиров во-вторых, возможно вам нужно пробивать чеки на ККМ из любого современного браузера, для этого нужно просто включить настройку в нашей программе и попросить вашего веб-программиста написать несложный код, пример которого, мы предоставим

1 стартмани

16.02.2018    11196    10    ioff83    5       

Корректировка остатков ЕГАИС, возврат из регистра 2, загрузка ТТН из файлов, другое для УТ10.3 15

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::ОУ УТ10 Россия БУ Розничная торговля Абонемент ($m) Обработка документов

Набор обработок для автоматизации работы с ЕГАИС: Обработка корректировки остатков ЕГАИС для УТ 10.3, аналогичная имеющимся в УТ 11, Рознице 2.2. Автоматически формирует документы "Передача в торговый зал", "Акт постановки на баланс в торговом зале", "Акт списания в торговом зале". Обработка возврата из регистра 2 с подбором справок Б. Обработка формирования ТТН из файлов xml.

1 стартмани

24.01.2018    18298    5    biz-intel    3       

КАССА Mobile 54-ФЗ 13

Инструменты и обработки Бухгалтер Пользователь Архив с данными Розничная и сетевая торговля (FMCG) БУ УУ Android Кассовые операции Розничная торговля Абонемент ($m) ККМ Фискальный регистратор Управление торговлей

Кассовые операции розничной торговли на смартфоне соответственно 54-ФЗ. Подключение фискального регистратора с ФН, отправка чеков ОФД.

3 стартмани

29.12.2017    12491    5    O-Planet    14       

Плагин для Internet Explorer, при просмотре автоматически сохраняющий журнал продаж ЕГАИС 3

Инструменты и обработки no Архив с данными Розничная и сетевая торговля (FMCG) Россия Windows Розничная торговля Абонемент ($m) WEB

Плагин для браузера Internet Explorer, автоматически сохраняющий при просмотре журнал продаж ЕГАИС в файлы на жестком диске.

1 стартмани

22.12.2017    6394    1    nooby123    2       

Автозаказ для 1С:Управление торговлей 11 21

Отчеты и формы Бизнес-аналитик Внешний отчет (ert,erf) v8 v8::ОУ УТ11 УУ Оптовая торговля Учет ТМЦ Абонемент ($m) Управленческие

Отчет выводит информацию, помогающую принять решение о пополнении товарного запаса.

3 стартмани

26.09.2017    15515    37    The Ded    23       

Счет-фактура+УПД+УКД с 01.10.2017 в редакции Постановления Правительства РФ от 19.08.2017 № 981. Для всех конфигураций на 1С 8 48

Отчеты и формы Бухгалтер Архив с данными v8 БП2.0 УТ10 УПП1 УНФ БП3.0 УТ11 БУ НУ Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Печатные формы документов

Внешние печатные формы с автоматической регистрацией для документа "Счет-фактура выданный" в редакции Постановления Правительства РФ №981 от 19.08.2017 года. Новые счета-фактуры № 981 применяются с 01.10.2017 года. Так же для УТ 10 очень старых релизов применяется сч.фактура в файле.

2 стартмани

18.09.2017    67446    1341    Kontakt    90       

Android беспроводной Bluetooth сканер 1D/2D штрихкода и терминал сбора данных для 1С 79

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 1cv8.cf УУ Android Оптовая торговля Розничная торговля Абонемент ($m) Сканер штрих-кода

Бесплатное приложение, превращающее Android-смартфон в беспроводной 1D/2D Bluetooth сканер и терминал сбора данных для 1С и прочих POS систем. Не требует драйверов и доработки конфигураций.

1 стартмани

12.09.2017    28342    25    kuld    43       

Видеокурс обучения кассира-продавца. 1С:Розница, ред. 2 (с инструкциями) 21

Курс Руководитель проекта Архив с данными v8::ОУ v8::УФ Розница Розничная и сетевая торговля (FMCG) Россия УУ Windows Кассовые операции Розничная торговля Абонемент ($m) Пользователю системы

Курс будет полезен при подготовке кассиров-продавцов в розничных точках, автоматизированных на 1С:Розница. Представляет собой набор инструкций и видеоуроки по операциям, с которыми кассиры-продавцы работают каждый день.

5 стартмани

12.09.2017    30345    60    kuld    15       

Программа для регистрации продаж на ККМ Атол и Штрих с изменениями в 54ФЗ от 01/07/19 10

Инструменты и обработки Системный администратор Программист Бухгалтер Архив с данными Бытовые услуги, сервис Россия УУ Кассовые операции Розничная торговля Абонемент ($m) ККМ

Маленькая и легкая программа, позволяет регистрировать продажи товаров/услуг. Замечательно подойдет для Автомоек, парикмахерских, юр.фирм и т.д., кто занимается услугами и продажей товаров, кому не нужен учет остатков. Для нее подойдет самый слабенький Pentium IV, с Windows XP. Самое главное, чтобы он потянул драйвера ККМ. НЕ 1С!!! Ставим драйвер ККМ, настраиваем файл со списком товаров (обычный текстовый файл, через блокнот) и работаем. Можно использовать ККМ с истекшим сроком ЭКЛЗ в режиме эмуляции. (т.е. программа его будет использовать как принтер чеков (без фискализации). Z-отчеты (не обнуляемые суммы) будет считать сама) В общем - бюджетное решение для тех, кто вынужден следовать букве закона, но решил сэкономить. Обновлена 26/07/19

5 стартмани

02.08.2017    18292    26    ah7777777    38       

ТСД OPTICON SMART: как увеличить размерность штрихкода 2

Статья Системный администратор Программист Архив с данными Розничная торговля Абонемент ($m) Терминал сбора данных

Статья научит, как увеличить размерность поля "Штрихкод" в программе Mobile Logistics. В статье приведён наглядный пример изменения настройки для ТСД "Opticon SMART" : использование штрихкода (Сокращение: ШК - штрихкод) длиной до 50 символов.

3 стартмани

01.08.2017    13171    1    Designer1C    5       

Сравнение цены продажи и цены по прайс-листу (отчёт для УТ11) 6

Отчеты и формы Бизнес-аналитик Пользователь Руководитель проекта Внешний отчет (ert,erf) v8::ОУ v8::УФ ERP2 УТ11 КА2 УУ Оптовая торговля Ценообразование, анализ цен Абонемент ($m) Управленческие

Отчёт для сравнения цены продажи товара и его цены по прайс-листу. Позволяет выявить отклонения цены продажи от цен по другим видам цен.

10 стартмани

11.07.2017    11418    11    mikhail.kozyrin    5       

БП 2.0 онлайн-касса (ККТ с передачей данных) 54 ФЗ 20

Инструменты и обработки Системный администратор Программист Бухгалтер Конфигурация (md, cf) v8 v8::БУ БП2.0 Россия БУ Кассовые операции Розничная торговля Абонемент ($m) ККМ Фискальный регистратор

Изменения для объединения с конфигурацией "Бухгалтерия предприятия 2.0" с функционалом для работы с ККТ с передачей данных в ОФД (онлайн-касса), сделана согласно методическим указаниям.

2 стартмани

09.07.2017    32111    137    bob_    53       

Внешние печатные формы Счет-фактура, УПД, УКД образца 2017 г. (ПП от 19.08.2017 № 981) для УПП 1.3, КА 1.1, БП 2.0 22

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 КА1 БП2.0 УПП1 БУ Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Печатные формы документов

Внешние печатные формы "Счет-фактура", "Универсальный передаточный документ", "Универсальный корректировочный документ" (в редакции постановления Правительства Российской Федерации от 19.08.2017 № 981) для типовых конфигураций УПП 1.3, КА 1.1, БП 2.0.

1 стартмани

30.06.2017    42299    712    Tavalik    63       

Счет-фактура с 01.07.2017 от 25.05.2017 №625 для ВСЕХ конфигураций 1С 8.х (БП 2.0, БП 2.0 КОРП, БАУ 2.0, БАУ 2.0 КОРП, КА 1.1, ПД 1.0, Розница 1.0, УНФ 1.3, УПП 1.3, УТ 11, УТ 10.3) 14

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ КА1 БП2.0 УТ10 Розница УПП1 УНФ БП3.0 БАУ УТ11 Россия БУ Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Печатные формы документов

С июля 2017 года применяется новая печатная форма счет-фактуры в редакции Постановления Правительства РФ от 25.05.2017 № 625. В публикации собраны внешние печатные формы для всех популярных конфигураций 1С. Будет актуально для 90% организаций, которые не ведут учет по гос. контрактам, так как новое поле не заполняется, а вместо номера гос. контракта установлен прочерк по умолчанию.

1 стартмани

29.06.2017    35663    455    a.kapustin    43       

Новые печатные формы Счет-Фактура, УПД с изменениями от 01.10.2017 для УТ 10.3 старых версий 4

Отчеты и формы Бухгалтер Архив с данными v8::ОУ УТ10 БУ Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Печатные формы документов

Внешние печатные формы счет-фактуры и УПД (Универсальный передаточный документ ) для 1С Управление Торговлей 10.3 ( УТ 10.3). Адаптирована под старые версии релизов. Включают в себе изменения от 01.07.2017 г.

2 стартмани

27.06.2017    24301    77    A7758735    4       

УПД (Универсальный передаточный документ) и Счет-фактура 2017 1137 в том числе с приказом 625 (с 01.07.17) или 981 (с 01.10.17) 6

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8::ОУ УТ10 Россия БУ Оптовая торговля Производство готовой продукции (работ, услуг) НДС Абонемент ($m) Печатные формы документов

Внешняя печатная форма УПД и СФ для УТ10. Автоматически смотрит дату СФ и выводит документ правильной на эту дату формы. Реализованы формы - 1137 до 01.07.2017 - 1137 дополнение приказ 625 с 01.07.2017 - 1137 дополнение приказ 981 с 01.10.2017

3 стартмани

25.06.2017    32364    190    Aleksey81    33       

Отчет по продажам с себестоимостью, наценками, рентабельностью (по регистру бухгалтерии) для БП 3.0 19

Отчеты и формы Бизнес-аналитик Бухгалтер Руководитель проекта Внешний отчет (ert,erf) v8::БУ БП3.0 БУ Оптовая торговля Абонемент ($m) Бухгалтерские Управленческие

С помощью этого отчета можно посмотреть продажи и их себестоимость с широкими возможностями настройки разрезов, вплоть до документа учета.

3 стартмани

26.05.2017    17523    110    kg2    20       

Инвентаризация аптеки 1

Инструменты и обработки no Архив с данными Фармацевтика, аптеки Россия УУ MobileOS Розничная торговля Абонемент ($m) Терминал сбора данных

«Инвентаризация аптеки» — простое универсальное приложение для терминалов сбора данных. ПО «Инвентаризация аптеки» подойдет для любой модели ТСД с ОС Windows mobile и Windows CE. Приложение имеет русское меню, простой интерфейс и легкую настройку. «Инвентаризация аптеки» — идеальное решении для инвентаризации медикаментов в аптеке. Если Вам требуется простое в настройке и несложное в управлении ПО, не требующее помощи специалистов, то это приложение для Вас!

1 стартмани

08.05.2017    9592    1    allegrosoft    0       

Валовая прибыль (1С: Розница 2.2) Управляемые формы 21

Отчеты и формы Бизнес-аналитик Пользователь Руководитель проекта Внешний отчет (ert,erf) v8::ОУ v8::УФ Розница Россия УУ Windows Учет доходов и расходов Розничная торговля Абонемент ($m) Управленческие

Отчет позволяет проанализировать продажи. Пригодится тем, кому не подходит или неудобен стандартный функционал расчета себестоимости в рознице 2.2.

3 стартмани

26.04.2017    31003    128    cezarj    36       

54-ФЗ: Онлайн-кассы для 1С 8.1 УТ 10.2. Поддержка Native драйверов Атол 12

Инструменты и обработки Системный администратор Программист Архив с данными v8 v8::ОУ УТ10 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Кассовые операции Оптовая торговля Розничная торговля Абонемент ($m) ККМ

Доработан и адаптирован функционал работы ККТ по 54_ФЗ на УТ 10.2 платформы 8.1. Поддержка драйверов Атол версии 9 (native) и эмулятора ККТ. Код полностью открыт и внесены комментарии для самостоятельной доработки. Протестировано на Атол 11Ф. Распространяется как есть.

10 стартмани

18.04.2017    42545    127    Atom74    69       

FR_Atol_Shtrih.exe печать чеков для ККМ АТОЛ и ШТРИХ на основании текстового файла, где содержится описание товаров, цен, НДС (все требования 54ФЗ поддержка изменений от 01/07/19). Для 1С (7.7 и:8 УФ, Обычных Формы) есть готовые обработки 68

Инструменты и обработки Системный администратор Программист Архив с данными v7.7 v8 v8::УФ 1cv8.cf 1cv7.md Россия Windows Кассовые операции Оптовая торговля Розничная торговля Абонемент ($m) ККМ Фискальный регистратор

Это программа печати чеков, которая читает обычный текстовый файл, где перечислено, что надо распечатать на ФР - описание содержимого чека. Такой механизм позволяет использовать комплект для WEB сайтов, для не типовых или сильно измененных 1с7 или 1с8. Для любых программ которые умеют работать с текстовыми файлами (будь то CLIPPER,FOXPRO,JAVA, WSH, VBS итд). Внутри комплекта лежат готовые внешние печатные формы для печати из документов Реализация товаров и услуг 1с8 УТ10, БП2, БП2Базовая, БП2Корп, УТ11, БП3, БП3Базовая, БП3Корп, Для 1с:ТиС 7.7 Реализация ТМЦ, Бух4.5, Бух1.3 и Печать из ПКО Подключать ФР к 1С не надо! Не надо открывать смену. Подходит для любой конфигурации, для любого документа. Более 300 внедрений на ккм Штрих-Мини-ФР-К, Штрих ОнЛайн Атол 11Ф, 55Ф, 30. Возможна пробитие оплаты наличным или VISA  (Электронные деньги). Поддерживает передачу в ОФД имени кассира, телефон или email покупателя. Для каждого чека можно поменять ОСН (ЕНВД, Доходы-расходы итд). Возможна печать чека с выровненными колонками, Наименование,Количество Цена, Сумма, в этом случае фискализация будет одной строкой с общей суммой. Можно пробить не фискальный чек. (чек будет, но в налоговую не уйдет). Добавлена расшифровка длинных наименований, что актуально для Штрих (программа сама переносит длинные наименования на след строку). Есть внесение и выплата денег. 29.06.17 добавлено пробитие 2 видов оплат в одном чеке.

7 стартмани

11.04.2017    52733    175    ah7777777    475       

Загрузка номенклатуры по штрихкоду: Управление Торговлей 11.3; Розница 2.2; Розница для Казахстана 2.2 100

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 v8::ОУ v8::УФ Розница УТ11 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Оптовая торговля Розничная торговля Ценообразование, анализ цен Абонемент ($m) Обработка справочников Ценообразование, прайсы

Розница 2.2, Управление Торговлей 11.3. Создание номенклатуры из интернета с помощью сканера штрихкодов либо терминала сбора данных. Варианты создания, автовыбор наилучшей позиции, источники, цены, загрузка картинки - всё это очень гибко и просто настраивается. Текущие открытые источники: barcode-list.ru(на текущий момент не работает); goodsmatrix.ru; ean13.info(может не работать капча); barcodes.olegon.ru. Автор программы не несёт ответственность за информацию, предоставляемую перечисленными выше открытыми источниками, так же не отвечает за их работоспособность. Данные источники принадлежат не автору программы. Данная программа нужна лишь для автоматизированного поиска информации на них.

10 стартмани

30.03.2017    42059    49    myALKleon    37       

Распознавание AlcoCode из 2D Barcode EGAIS 3

Инструменты и обработки Системный администратор Программист Архив с данными Розничная и сетевая торговля (FMCG) Россия Windows Розничная торговля Абонемент ($m) Сканер штрих-кода

Программное обеспечение, значительно облегчающее проведение инвентаризационный учет склада EGAIS. ПО может работать совместно с 2d сканером в режиме эмуляции клавиатуры или как отдельное ПО, распознающее BarCode.

1 стартмани

19.03.2017    9344    1    Vladraven    0       

Программа для управления терминалами Ingenico 2

Инструменты и обработки Системный администратор Приложение (exe) Windows Розничная торговля Абонемент ($m) POS терминал

Простенькая программка для управления эквайринговыми терминалами ingenico, с установленным комплексом acrus2.

2 стартмани

12.03.2017    15046    8    kolabaister    6