IE 2017

Лицевая карточка сотрудника с налогами и страховыми взносами (Версия 1.3 от 06.04.2011)

Печать - Справки

Версия 1.3 от 06.04.2011. Реализовано отображение ФСС НС для 2011 года.

Лицевая карточка сотрудника с налогами сФОТ, до 2010 года показывает зарплату+ЕСН, начиная с 2010 показывает зарплата+Страховые взносы.
Отчет для 1С: Зарплат+Кадры 7.7 (после доработки напильником подойдет для Комплекса 7.7.)

Как давече выяснилось, автор отчета Samor_Ykt. За что ему огромногое спасибо!

Сам его использую с 2004 года и ни разу не пришлось его переписывать или поправлять. Все клиенты от него в восторге. В связи с изменениями 2010 года, пришлось в него заглянуть и малость поправить, чтобы отчет продолжил успешно работать в новом году.

В планах очередная доработка:
1. Добавить информацию о действующих вычетах по НДФЛ
2. Добавить возможность автоматически суммировать карточки при внутренних совмещениях

Версия 1.3 от 06.04.2011
1. Внесены изменения в формирование сумм по ФСС НС связанное с изменениями ЗиКа в 2011 году. Раньше ФСС НС "рассчитывался на ходу", теперь же он храниться в журнале страховых взносов, как и все остальные взносы.

Версия 1.2 от 01.04.2010
1. В отчет добавлена информация о версии
2. Добавлено отображение страховых взносов от НС (ФСС_НСиПЗ)
3. Проверка на наличие ЕНВД, если нет ЕНВД то строки ПФР по ЕНВД не отображаются
4. ПФР по дополнительному тарифу отображается только в том случае, если он не нулевой
5. Добавлена возможность формирования отчета по периоду действия, по умолчанию формируется по периоду регистрации. Смотреть лицевую карточку по периоду действия удобно для проверки годового отчета по НДФЛу, а также при проверке среднего заработка. Когда карточка формируется по периоду действия в шапке отчета отображается соответсвующее предупреждение, сальдо в этом случае не отображается.

Также внесено пару строк в процедуру ПриОткрытии. Можно в справочник "Сотрудники", в форму списка вставить кнопку, для быстрого формирования карточки по текущему сотруднику. В обработку нажатия кнопки, тогда нужно внести примерно такой код:

Процедура ПечатьЛК()
   
сз=СоздатьОбъект("СписокЗначений");
   
//формируем список для выбора
   
сз.ДобавитьЗначение("ид1", "по периоду регистрации за текущий год");
   
сз.ДобавитьЗначение("ид2", "по периоду регистрации за прошлый год");
   
сз.ДобавитьЗначение("ид3", "по периоду действия за текущий год");
   
сз.ДобавитьЗначение("ид4", "по периоду действия за прошлый год");
   
зн="";поз="";
    Если
сз.выбратьЗначение(зн,,поз,,1)=1 тогда
        Если
зн="ид1" Тогда
            Если ПустоеЗначение(
ТекущийЭлемент())=0 Тогда
                Если
ЭтоГруппа()=0 Тогда
                   
Параметры = СоздатьОбъект("СписокЗначений");
                   
Параметры.Установить("Сотрудник",ТекущийЭлемент());
                   
Параметры.Установить("Год",ДатаГод(РабочаяДата()));
                   
Параметры.Установить("ПоПериодуДействия",0);
                   
глОткрытьФормуИВыполнитьКоманду("Отчет.ЛицеваяКарточка#", "Печать", Параметры);
                КонецЕсли;
            КонецЕсли;
        Иначеесли
зн="ид2" Тогда
            Если ПустоеЗначение(
ТекущийЭлемент())=0 Тогда
                Если
ЭтоГруппа()=0 Тогда
                   
Параметры = СоздатьОбъект("СписокЗначений");
                   
Параметры.Установить("Сотрудник",ТекущийЭлемент());
                   
Параметры.Установить("Год",ДатаГод(ДобавитьМесяц(РабочаяДата(),-12)));
                   
Параметры.Установить("ПоПериодуДействия",0);
                   
глОткрытьФормуИВыполнитьКоманду("Отчет.ЛицеваяКарточка#", "Печать", Параметры);
                КонецЕсли;
            КонецЕсли;
        Иначеесли
зн="ид3" Тогда
            Если ПустоеЗначение(
ТекущийЭлемент())=0 Тогда
                Если
ЭтоГруппа()=0 Тогда
                   
Параметры = СоздатьОбъект("СписокЗначений");
                   
Параметры.Установить("Сотрудник",ТекущийЭлемент());
                   
Параметры.Установить("Год",ДатаГод(РабочаяДата()));
                   
Параметры.Установить("ПоПериодуДействия",1);
                   
глОткрытьФормуИВыполнитьКоманду("Отчет.ЛицеваяКарточка#", "Печать", Параметры);
                КонецЕсли;
            КонецЕсли;
        Иначеесли
зн="ид4" Тогда
            Если ПустоеЗначение(
ТекущийЭлемент())=0 Тогда
                Если
ЭтоГруппа()=0 Тогда
                   
Параметры = СоздатьОбъект("СписокЗначений");
                   
Параметры.Установить("Сотрудник",ТекущийЭлемент());
                   
Параметры.Установить("Год",ДатаГод(ДобавитьМесяц(РабочаяДата(),-12)));
                   
Параметры.Установить("ПоПериодуДействия",1);
                   
глОткрытьФормуИВыполнитьКоманду("Отчет.ЛицеваяКарточка#", "Печать", Параметры);
                КонецЕсли;
            КонецЕсли;
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры   
// ПечатьЛК

Версия 1.1 от 11.02.2010
1. Отчет адоптирован под отображение страховых взносов с 2010 года

Версия 1.0
Под первой версией подразумеваю отчет в том виде как он попал ко мне в руки

Скачать файлы

Наименование Файл Версия Размер
Лицевая карточка сотрудника
.ert 116,00Kb
21.04.11
869
.ert 116,00Kb 869 Скачать

См. также

Комментарии
1. Эдуард (samadurov) 94 11.02.10 14:32 Сейчас в теме
+ автору и тому, кто его не забыл :)
2. Vladimir (Boroda) 90 11.02.10 14:38 Сейчас в теме
А вот за новую лицевую карточку отдельное спасибо!
3. Pavel (Zulu) 11.02.10 15:41 Сейчас в теме
Спасибо за обработку! :D
Но можно было бы добавить данные по взносам от несчастных случаев (НСиПЗ).
4. Алексей Назаров (alnazarov) 191 11.02.10 19:44 Сейчас в теме
5. rimma_n (rimma_n) 165 12.02.10 11:32 Сейчас в теме
замечательно! хорошо бы еще указать в шапке список действующих льгот по НДФЛ
6. Екатерина Ирдуганова (Katerina_) 17.02.10 11:58 Сейчас в теме
Спасибочки большущее!!!!отчет то что надо)))
7. Денис (KrakoZyabl) 77 19.02.10 07:54 Сейчас в теме
8. Марита бух (Марита Х) 20.02.10 10:41 Сейчас в теме
2009 год берет , а по 2010 дает:
СписФОТ.ДобавитьЗначение(ВидРасчета.ПФРСтраховаяЧастьс2010);
{E:\БАЗА МАРИТА\28 08 2009 БАЗЫ СЕП\PRBASIC\EXTFORMS\LICKARSOTRA.ERT(606)}: Поле агрегатного объекта не обнаружено (ПФРСтраховаяЧастьс2010)
9. Сергей (Ulfhedhinn) 241 20.02.10 12:54 Сейчас в теме
(8) подозреваю, что отчет у вас не работает, потому что у вас не обновлена база. Скажите какой у вас релиз?
10. Svetlana E (Svetlana_E) 23.02.10 11:04 Сейчас в теме
Еще было бы здорово, если бы все карточки по сотруднику складывались. Основная и внутреннее совместительство. Иначе приходится все это делать руками...
11. Сергей (Ulfhedhinn) 241 24.02.10 09:37 Сейчас в теме
(10) впринципе можно добавить такую возможность, почему бы и нет :)
12. Svetlana E (Svetlana_E) 24.02.10 10:11 Сейчас в теме
(11) И когда можно ждать обновления? :D
13. Alex (SamoR_Ykt) 02.03.10 05:08 Сейчас в теме
Мде, вот уж не думал, что по всей стране пойдет отчётик мой :)
14. Татьяна Шавлак (Stety) 143 04.03.10 12:40 Сейчас в теме
(11) Да, по логике ведения лицевого счета (как формы-карточки) он должен бы именно по физику собираться. Хотя в начислениях должно быть видно, что по какому месту работы начислялось.
15. Сергей (Ulfhedhinn) 241 06.03.10 06:26 Сейчас в теме
(13) Вот видишь как оно бывает :D
Так значица изначально твой отчет? Ну дык ща авторство тогда подрисуем! ;)
16. Alex (SamoR_Ykt) 09.03.10 03:55 Сейчас в теме
(15) Так и есть. Дело было так...
Когда работал в Франчайзи, одна бухгалтерша из клиентов попросила сделать такой отчёт. Нарисовала как должен выглядеть отчетик, всё объяснила подробно. Спасибо скажем и ей. :)
А когда уволнялся с Франчайзи, отдал коллегам для раздачи за определенные часы. Отчёт очень уж нравился бухгалтерам, кому показывал. Как раз в конце 2003 года уволнялся и в 2004 году хорошо пошел "по рукам" видать, так сказать получил свою популярность. ;)
17. Элина Муратиди (Mura) 27.03.10 19:00 Сейчас в теме
Еще не проверяла , но идея гениальная, от всех"понимающих" бухгалтеров нижайший Вам поклон много лет о таком отчете мечтала :!: :D
18. waw waw (waw_waw) 05.04.10 19:09 Сейчас в теме
Благодарю , нужная вещь.
19. Светлана С (Свет@) 20.04.11 13:45 Сейчас в теме
Скачала, но версия стоит 1.2 от 01.04.2010. Где версия 1.3?
20. Sashko-lar (sashko-lar) 20.04.11 16:58 Сейчас в теме
Хороший отчет,но ФСС НС похоже сам считает,а не берет из журнала страховых взносов. По инвалидам цифирки не соответствуют :-(
21. Сергей (Ulfhedhinn) 241 21.04.11 05:05 Сейчас в теме
(19) при последнем обновлении почему-то не залился файл, перезалил и проверил, теперь точно новая версия
(20) в старой версии действительно сам считал, в новой перезалитой точно по журналу собирает, с инвалидами должно все нормально сработать :)
22. Александр Устинов (alexu) 15.08.11 08:49 Сейчас в теме
23. Александр Журавлев (Sahs) 12.09.11 10:22 Сейчас в теме
24. Елена (m-xolding) 23.11.11 09:53 Сейчас в теме
Очень благодарна за отчет!!! Очень понравилась карточка проверяющим! Удачи во всем АВТОРУ!!!!!!
25. Елена (m-xolding) 26.01.12 11:03 Сейчас в теме
Была проверка из ФСС и пенсионного. Форма понравилась им, вся информация "на лицо". Эту ведомость можно 75 лет хранить.
26. Viktor (kurvik) 19.11.12 15:35 Сейчас в теме
Компактный и наглядный отчет по всем начислениям. Очень приглянулся бухгалтерам. Для различных проверок незаменимая вещь. Типовой отчет ограничен по количеству видов расчета на листе, приходилось корректировать алгоритм формирования отчета. Спасибо автору.
27. Татьяна Скитаева (skit) 06.02.13 12:27 Сейчас в теме
Я так понимаю для бюджетников (ЗиК) она не подойдет.
Оставьте свое сообщение