001. Криптография и цифровая подпись RSA-sha256 на платформе 1С

Публикация № 896874

Разработка - Разработка внешних компонент

Цифровая подпись в 1с шифрование RSA sha256 внешняя компонента

Внешняя компонента, исходники, обработка для 1С.

Эта статья описывает готовое решение для выполнения задач по формированию цифровых подписей, проверке подписей, а так же шифрованию и дешифрованию данных.

Обмен с онлайн кассами, биткоины – часто встречающиеся в моей практике темы для разработки, в которых используется шифрование передаваемых данных. В моем случае, под шифрованием я подразумеваю в т.ч. формирование электронной цифровой подписи с последующей валидацией.

 
 Юридическая информация

Когда мне была поставлена задача реализовать подписание ЭЦП по алгоритму SHA256-rca паддинг pkcs1 с ключами 2048 я решил, что сделаю все в 3 строки кода:

Хэш=Новый ХешированиеДанных(ХешФункция.SHA256);
Хэш.Добавить("Тра ля ля");
Сообщить(Хэш.ХешСумма);

Как выяснилось почти сразу, кроме этих магический строк в платформу встроены еще пара других алгоритмов получения хэшей и все.

Но где же RSA? А ключи? Короче ждал меня облом.

Можно задействовать внешний криптопровайдер, но это стоит денег, да и сервер на котором все должно работать находится в Америке и там же админится, дадут ли устанавливать лишний софт – большой вопрос.

Поиски в интернете готового решения не дали, пришлось садиться в студию и кодить компоненту net.

Для запуска компоненты используется C++ компонента NETLoader, скачанная с инфостарта.

В архивах к публикации можно найти демо-обработку, реализующую логику шифрования/дешифрования, создания и проверки цифровой подписи, и компоненты отдельно.

Все процедуры выполняются в один поток и на больших данных могут подвисать. Но на практике мне такое не встретилось.

В этом видео показано как все работает:

Для тестирования методов компоненты (без учета особенностей работы платформы 1с) реализовано Windows приложение (см в архиве WindowsFormsTest1.exe). Компонента адаптирована для работы как с платформой 1с, так и как самостоятельного решения для использования в других задачах. Требования – net.3.5. Тестирование производилось на платформе 8.3.12 на управляемом интерфейсе в контексте сервера. Компонента реализует:
подписание по алгоритму SHA-256 с шифрованием хеша подписи по алгоритму RCA PKCS1 при помощи, ключей размером 2048
проверку (валидацию) подписи
шифрование и дешифровку данных по алгоритму
RSA PKCS1 про помощи ключей, размером 2048
В 1с компоненту можно задействовать при помощи служебной компоненты netloader.dll (встроена в фреймворк).
 
 Описание методов компоненты CoderEncoder.dll

Создание ключей шифрования
Назначение: создает новые ключи шифрования
Имя метода: GetKeysInXML(string randomstring)
Параметры: randomstring (произвольная строка, обязательный параметр) – не используется, остался в наследие от первой версии компоненты.
Возвращаемое значение: Истина или Ложь.
Приватный и публичный ключ можно получить, обратившись к свойствам компоненты publicKey и privateKey
Значения ключей представлены в формате XML, поля которого содержат двоичные данные в формате base64

Формирование цифровой подписи
Назначение: формирует цифровую подпись переданных данных
Имя метода: SignData(string DataToSign, string privateKey)
Параметры: DataToSign (строка) – данные, которые необходимо подписать; privateKey (строка) – приватный ключ в формате XML.
Возвращаемое значение: Истина или Ложь
Значение подписи можно получить, обратившись к свойству компоненты Base64SignedHash
Значение – это двоичные данные в формате base64

Проверка цифровой подписи
Назначение: возвращает результат проверки цифровой подписи
Имя метода: VerifySignature(string DataToSign, string signature, string publicKey)
Параметры: DataToSign (строка) – данные, которые необходимо подписать; signature (строка) – цифровая подпись в формате base64; privateKey (строка) – приватный ключ в формате XML.
Возвращаемое значение: Истина или Ложь
Если подпись прошла проверку – возвращает Истина

Шифрование данных
Назначение: шифровка данных
Имя метода: EncryptData(string originalMessage, string publicKey)
Параметры:  originalMessage (строка) – данные, которые необходимо зашифровать; publicKey (строка) – публичный ключ в формате XML.
Возвращаемое значение: Истина или Ложь
Результат шифрования можно прочитать из свойства encripteddata

Дешифрование данных
Назначение: дешифровка данных
Имя метода: DecryptData(string originalMessage, string privateKey)
Параметры:  originalMessage (строка) – данные, которые необходимо расшифровать; privateKey (строка) – приватный ключ в формате XML. Возвращаемое значение: Истина или Ложь
Возвращаемое значение: Истина или Ложь
Результат шифрования можно прочитать из свойства decripteddata;

Обработка ошибок
Если методы компоненты возвращают Ложь, возможно, в передаваемых параметрах допущены ошибки. Получить описание последней ошибки можно обратившись к свойству компоненты lasterror (строка)

 

Скачать файлы

Наименование Файл Версия Размер
Обработка "все включено"

.epf 154,77Kb
24
.epf 154,77Kb 24 Скачать
Только внешняя компонента

.dll 8,00Kb
4
.dll 8,00Kb 4 Скачать
Windows приложение для тестирования функциональности

.exe 12,00Kb
3
.exe 12,00Kb 3 Скачать
Исходники

.zip 889,36Kb
7
.zip 889,36Kb 7 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. saa@kuzov.org 04.09.18 11:20 Сейчас в теме
Спасибо за исходники!
Это большая редкость, когда автор не просто выкладывает бинарник (с х.з. каким кодом внутри), а дает возможность самому проверить код и собрать его.


У меня вопрос. Я вообще не владею .Net, и не люблю его (исторически сложилось).
Насколько проще/сложнее писать Native ВК для 1С на .Net, нежели на расово верном C++ (или хотя бы Dephi)?
softbear; +1 Ответить
4. astracrypt 71 04.09.18 12:46 Сейчас в теме
(1) Респект и уважуха автору.
5. Nikola23 587 04.09.18 16:19 Сейчас в теме
(1) пишите на чем можете. Вопрос "что проще" не считаю правильным.
36. uno-c 168 25.11.18 04:47 Сейчас в теме
(1)
Насколько проще/сложнее писать Native ВК для 1С на .Net, нежели на расово верном C++
На дотнете невозможно написать внешнюю компоненту для 1С по технологии Native.
37. Nikola23 587 25.11.18 18:48 Сейчас в теме
(36) Это является проблемой, только если Native - обязательно.
В моих задачах такого не встречал.
38. uno-c 168 25.11.18 19:21 Сейчас в теме
(37) Согласен. Но правильный ответ на конкретный вопрос "Насколько проще/сложнее писать Native ВК для 1С на .Net, нежели ..." звучит так: бесконечно сложнее, поскольку невозможно )
39. spacecraft 25.11.18 19:56 Сейчас в теме
(36)
На дотнете невозможно написать внешнюю компоненту для 1С по технологии Native.

"Да-да, конечно". Для некоторых это и правда невозможно.
https://habr.com/post/304542/?hl=ru_RU&fl=ru%2Cen
40. uno-c 168 25.11.18 20:14 Сейчас в теме
(39)Опять Вы невнимательны. В прошлый раз не заметили, что дотнет вызывает встроенного в ОС криптопровайдера, теперь не заметили, что в приведенном Вами примере по технологии Native на C++ написан враппер для классов дотнета. Т.е. для запуска скомпилированной дотнет dll-ки в приведенном примере нужна дополнительная компонента на неуправляемом коде, назвается она Native ВК. Но дотнетовская dll при этом не становится Native для 1С и без Native-прослойки на C++ не работает. Псевдокод в dll дотнета по определению не может быть внешней Native компонентой для 1С. Native должна быть написана на машинном коде.
41. spacecraft 25.11.18 21:40 Сейчас в теме
(40) вам шашечки или ехать? .NET библиотеки можно использовать в ВК Native.
Псевдокод в dll дотнета по определению не может быть внешней Native компонентой для 1С. Native должна быть написана на машинном коде.

С таким же успехом можно сказать, что любая программа на .NET не является программой, так как не написана на машинном коде.
42. uno-c 168 25.11.18 23:24 Сейчас в теме
(41)Тут да, вопрос терминологии. Любая программа на дотнете действительно не является исполняемой программой по определению. В практической плоскости это означает, что не получится скомпилировать дотнет-dll-ку для 1С , вставить ее в 1С в какой-нибудь двоичный макет, и запустить на паре-тройке других win-компьютеров без костылей. Например, в приведенном Вами примере автор предлагает для запуска тестовой dll-ки размером 70 килобайт - скачать и разместить в каталоге дополнительную многомегабайтную библиотеку.
43. uno-c 168 26.11.18 00:09 Сейчас в теме
(41)В чем вообще фишка Вашего примера? Предлагается взять скомпилированную на С++ AddInNetObjectToNative.dll - которая действительно является Native компонентой, туда же рядом скачать и поместить библиотеки NetCore, и только после этого скомпилированная из сишарпа NetObjectToNative.dll заработает. Тут два костыля получается. Это Вы называете созданием ВК по Native технологии для 1С на C#? Но если Вы обратите внимание на код 1С из Вашего примера, то единственная Native-ВК, которая там подключается - это ВК на С++
49. uno-c 168 28.11.18 04:40 Сейчас в теме
(41)
вам шашечки или ехать? .NET библиотеки можно использовать в ВК Native.
Только понял. Вы просто не уловили, о чем спрашивал saa@kuzov.org, когда писал "Насколько проще/сложнее писать Native ВК для 1С на .Net, нежели на расово верном C++ (или хотя бы Dephi)?" Если перефразировать - то он спрашивал "насколько сложнее написать Native на C#, чем на C++" или "насколько сложнее на Delphi чем на Visual Basic .NET", на это был мой ответ, который можно перефразировать "на языках дотнета написать Native невозможно". То, что библиотеки дотнета можно использовать через Native ВК, очевидно уже из разработки Nikola23, в рамках которой идет наше обсуждение. Но для этого, как и в Вашем примере, в эску сначала подключается Native на неуправляемом коде.
44. uno-c 168 26.11.18 10:00 Сейчас в теме
(39)
"Да-да, конечно". Для некоторых это и правда невозможно.
https://habr.com/post/304542/?hl=ru_RU&fl=ru%2Cen
Подытожим для ищущих способ написать на C# внешнюю Native компоненту для 1С. На сишарпе в принципе невозможно скомпилировать dll-ку, которая подключалась бы в 1С методом ПодключитьВнешнююКомпоненту("ИзСиШарпа.dll", "Имя", ТипВнешнейКомпоненты.Native). NativeВК из статьи по ссылке spacecraft-а написана на C++, в этом можно убедиться, если прочитать приведенную статью, обратить внимание на строки из нее
ИмяФайла=КаталогОтчета+"\AddInNetObjectToNative.dll";
ПодключитьВнешнююКомпоненту(ИмяФайла, "NetObjectToNative",ТипВнешнейКомпоненты.Native); 
и посмотреть исходники AddInNetObjectToNative.dll, любезно предоставленные автором упомянутой статьи.
45. Nikola23 587 27.11.18 06:08 Сейчас в теме
(44) Коллега, в чем суть вашего участия в обсуждении и того, как много времени вы тратите на доказывание своей правоты?

Мне вот все равно, правы Вы или нет. Просто интересно стало: у Вас много лишнего времени? Потратьте его на семью...

П,С, пока вы строчите комментарии я решаю задачи, пусть и не идеальным/оптимальным методом - я уже перерос юношеский максимализм.
С# использую, потому что знаю. С++ не знаю, учить не хочу, даже если на основы достаточно потратить 1 день.
46. uno-c 168 27.11.18 06:15 Сейчас в теме
(45)Искал когда-то сам ответы на эти вопросы, быстро не нашел, пополняю интернет правильными ответами. Жаль, что их портят некомпенетнтыми возражениями, но если польза будет возражающему, тогда не жаль. Пока Вы решаете чужие задачи, я занимаюсь чем хочу.
47. uno-c 168 27.11.18 06:51 Сейчас в теме
(45)А Вы скажите, в чем смысл шифрования в 1С с использованием двух костылей: C++ внешней компоненты плюс C# dll-ки? Именно шифрования, не подписи sha256rsa. Менеджер криптографии эсочный с шифрованием не справился?
48. uno-c 168 27.11.18 07:03 Сейчас в теме
(45)
С# использую, потому что знаю. С++ не знаю, учить не хочу, даже если на основы достаточно потратить 1 день.
Вы зря восприняли мою реплику про С++ в свой адрес. Она была предназначена для вопрошающего, который думал, что на языках дотнета можно написать NativeВК.
2. Steelvan 96 04.09.18 11:33 Сейчас в теме
Если сервера в Америке, то это будет самый большой риск для предпринимателя.
Заблокируют и будут шантажировать.
3. astracrypt 71 04.09.18 12:46 Сейчас в теме
(2) Это тебе не Раша, там уважают закон, никто без решения конгреса или постановления суда не будет тебя шантожировать.
6. Steelvan 96 04.09.18 22:24 Сейчас в теме
(3) Подотрите сопли, перестаньте верить в бабкины сказки и выучите правила грамматики русского языка.
И посмотри другие источники информации об Америке, кроме фильмов о супергероях.
EmpireSer; +1 Ответить
7. echo77 1188 24.10.18 11:55 Сейчас в теме
(0) Классно!
Только поправьте заголовок на RSA-SHA256, а то поиском не ищется.
8. uno-c 168 11.11.18 10:11 Сейчас в теме
У меня криптопровайдер вшит в Windows, думаю у буржуев то же самое. Вот рабочий пример подписи RSA-SHA256 с его помощью на 1С. Закрытый ключ хранится в макете в виде xml, вспомогательные функции SafeИзДвоичных, ДвоичныеИзSafe и т.п. не привожу - понятно что они делают. Только что проверил - все работает, подпись рассчитывает, конечного получателя эта подпись устраивает.
Хеширование = Новый ХешированиеДанных(ХешФункция.SHA256);
Хеширование.Добавить(JWTдляСигнатуры);
Хеш = Хеширование.ХешСумма;

ОбработкаОбъект = РеквизитФормыВЗначение("Объект");
ХМЛСертификатСЗакрытымКлючом = ОбработкаОбъект.ПолучитьМакет("Макет");
ХМЛТекст = ПолучитьСтрокуИзДвоичныхДанных(ХМЛСертификатСЗакрытымКлючом);
КрПровайдер = Новый COMОбъект("System.Security.Cryptography.RSACryptoServiceProvider");
КрПровайдер.FromXmlString(ХМЛТекст);

SafeArrayBinХешДляПодписи = SafeИзДвоичных(Хеш);
SafeArrayBinПодписьДвоичная = КрПровайдер.SignHash(SafeArrayBinХешДляПодписи, "SHA256");
ПодписьДвоичная = ДвоичныеИзSafe(SafeArrayBinПодписьДвоичная); 
Показать
9. Nikola23 587 11.11.18 22:50 Сейчас в теме
(8) Раз за Вас. Спасибо за пример, может быть сообществу пригодится.
10. uno-c 168 12.11.18 00:07 Сейчас в теме
(9) Похоже, в статье вот это в заблуждение вводит:
Можно задействовать внешний криптопровайдер, но это стоит денег, да и сервер на котором все должно работать находится в Америке и там же админится, дадут ли устанавливать лишний софт – большой вопрос.
Криптопровайдер внешний не нужен, работает виндовский, без дополнительной оплаты.
11. uno-c 168 12.11.18 00:40 Сейчас в теме
(9) Более того, используемый Вами дотнет обращается к этому же виндовскому криптопровайдеру. Вы ведь в коде исходников не возводите хеш в степень закрытого ключа по модулю открытого ключа?
12. spacecraft 12.11.18 00:58 Сейчас в теме
(11)
Более того, используемый Вами дотнет обращается к этому же виндовскому криптопровайдеру

этот "виндовский криптопровайдер" не встроен в видну. Это библиотека того самого "дотнет" framework.

(10)
Криптопровайдер внешний не нужен, работает виндовский, без дополнительной оплаты.

Для приведенного примера да, не нужен. Намного интересней, когда понадобится использовать гостовский криптопровайдер.
14. uno-c 168 12.11.18 02:02 Сейчас в теме
(12)Во-первых, сам дотнет встроен в винду. Во-вторых, крипропровайдеры встроены в винду помимо дотнета. В третьих, в случае с RSA-SHA256 дотнет работает как оболочка для неуправляемого кода Microsoft Cryptography API (CryptoAPI), т.е. сам ничего не рассчитывает, а обращается API виндовского криптопровайдера, т.е. по сути делает то же самое, что я написал в коде 1С. Если в винде не будет нужного криптопровайдера - дотнет ничего не сможет с RSA-SHA256. А вот для случая с эллиптическими кривыми (например у ГОСТ такое) - там как раз да, дотнет сам все умеет вычислять в управляемом коде без обращения к CSP, т.е. по идее дотнету не нужен КриптоПро, хотя я так не пробовал, использовал cadescom.dll КриптоПрошный из 1С, он насколько помню бесплатный.
15. spacecraft 12.11.18 08:54 Сейчас в теме
(14)
Во-первых, сам дотнет встроен в винду.

Спорное утверждение. С точки зрения использования актуальной версии, ее приходится устанавливать как отдельное приложение.

(14)
В третьих, в случае с RSA-SHA256 дотнет работает как оболочка для неуправляемого кода Microsoft Cryptography API (CryptoAPI), т.е. сам ничего не рассчитывает, а обращается API виндовского криптопровайдера, т.е. по сути делает то же самое, что я написал в коде 1С. Если в винде не будет нужного криптопровайдера - дотнет ничего не сможет с RSA-SHA256.

Это в корне не верно. CryptoAPI это интерфейс, который как содержит свою реализацию криптопровайдера, так и может использовать сторонний. В данном случае System.Security.Cryptography.RSACryptoServiceProvider это сторонний криптопровайдер, который реализует интерфейс CryptoAPI. Т.е. это через CryptoAPI можно использовать криптопровайдер "дотнет".
16. uno-c 168 12.11.18 10:13 Сейчас в теме
(15)
С точки зрения использования актуальной версии, ее приходится устанавливать как отдельное приложение
Это как раз недостаток Вашего метода, поэтому метод напоминает причину отказа от операции Афенбаха из горячих голов.
Это в корне не верно
Читайте доки и смотрите свой код. "К именам неуправляемых реализаций обычно добавляется суффикс «CryptoServiceProvider» (скажем, SHA1CryptoServiceProvider), указывающий на то, что данная реализация на самом деле предоставляется криптопровайдером (Cryptographic Service Provider, CSP), который установлен на уровне операционной системы и действует как оболочка CryptoAPI. В имена управляемых реализаций включается суффикс «Managed» (например SHA1Managed). Такие реализации не опираются на CryptoAPI и содержат исключительно управляемый код." Ну и как Вас, Managed? ))
17. spacecraft 12.11.18 10:17 Сейчас в теме
(16) вы что-то попутали. Не я автор темы и никакого кода не выкладывал.
18. spacecraft 12.11.18 10:23 Сейчас в теме
(16) вы в самом деле не понимаете, что сами же в своем коде из 1С вызываете класс из библиотеки "дотнет"?
https://docs.microsoft.com/ru-ru/dotnet/api/system.security.cryptography.rsacryptoserviceprovider?view=netcore-2.0
19. uno-c 168 12.11.18 10:28 Сейчас в теме
(18)Похоже, Вы смотрите и не видите. Написано же, "предоставляемого поставщиком служб шифрования (CSP)" - т.е. дотнету нужен внешний криптопровайдер. В данном конкретном случае будет использоваться криптопровайдер винды по умолчанию - Microsoft Enhanced Cryptographic Provider или Microsoft Strong Cryptographic Provider. И где Вы в моих постах нашли утверждение, что мой код не использует класс дотнета? Я утверждал, что дотнет встроен в винду, криптопровайдер встроен в винду, и в данном случае дотнет использует бесплатный виндовский криптопровайдер. Это относилось к фразе автора
Можно задействовать внешний криптопровайдер, но это стоит денег
20. spacecraft 12.11.18 10:48 Сейчас в теме
(19) как это объясняет, что вы сами используете этот класс из 1С? "т.е. по сути делает то же самое, что я написал в коде 1С." По сути вы просто вызываете этот класс.
21. uno-c 168 12.11.18 11:04 Сейчас в теме
(20)Моему вызову не нужна конкретная версия дотнета, в отличие от разработки автора, если правильно понял Ваш вопрос. Я говорил платном криптопровайдере, который не нужен для RSA-SHA256, потому что встроен в винду и вызывается из дотнета.
22. spacecraft 12.11.18 11:16 Сейчас в теме
(21) тогда произошло недопонимание всех. Автор так же не использовал платный криптопровайдер, а воспользовался этим же встроенным классом из дотнет, только через ВК.
24. uno-c 168 12.11.18 17:04 Сейчас в теме
(22)а этот класс ничего не умеет кроме как обратиться к встроенному в винду Microsoft Enhanced Cryptographic Provider. Этот класс - просто обертка. В win-XP можно было достучаться к этому же криптопровайдеру через CAPICOM.
23. spacecraft 12.11.18 11:27 Сейчас в теме
(21) по сути, ваше решение подходит только для windows.
Решение с ВК может работать и на unix. Не знаю как сделано у автора, но теоретически это возможно.
Соответственно нужно использовать класс "System.Security.Cryptography.Algorithms".
25. uno-c 168 12.11.18 17:49 Сейчас в теме
(23)Похоже, что автор написал dll на управляемом коде и запускает ее с помощью native компоненты https://infostart.ru/public/300091/ Последняя сделана только для windows судя по описанию. Вот такой длинный путь вместо прямого обращения из кода 1С, как я предполагаю.
26. Nikola23 587 12.11.18 17:55 Сейчас в теме
(25) Что за холивар устроили Вы тут?
Компонента решает намного больше задач, чем просто создание цифровой подписи.

Но самое главное - не это. Полный интернет примеров кода, на всех языках, кроме 1с) Потому, какой пример (работающий) нашел, на том языке и скомпилил.

Напишите на 1с шифрование данных этим же алгоритмом. Уверен, сообществу будет благодарно.

Главное - не язык или технология, а решение задачи заказчика в рамках бюджета и сроков с приемлемым уровнем качества.
27. uno-c 168 12.11.18 18:22 Сейчас в теме
(26)Вам предложен более лаконичный способ решения Вашей задачи
реализовать подписание ЭЦП по алгоритму SHA256-rca
Плюс неплохо и пояснить spacecraft в чем он заблуждается, вдруг где пригодится. При чем тут холивар? Обратное тоже работает - spacecraft открывает для читающих что-то новое.
28. Nikola23 587 13.11.18 02:47 Сейчас в теме
(27) Предложен - ок, я поблагодарил сразу.
Только я не просил.

Оформите свои знания отдельной публикацией - сообщество поблагодарит...
29. uno-c 168 13.11.18 07:54 Сейчас в теме
(28)Ваша просьба не обязательна. Нашедший Ваше решение и прочитавший комментарии к нему увидит, что оно не оптимально. На отдельную статью приведенный мной способ сделать подпись RSA-SHA256 не тянет - в принципе в тех строчках кода, что я привел, и есть решение задачи, поставленной в начале Вашей статьи. Вот еще строчка - вариант проверки действительности цифровой подписи.
ПодписьВерна = КрПровайдер.VerifyHash (SafeArrayBinХешДляПодписи, "SHA256", SafeArrayBinПодписьДвоичная);
Асимметричное шифрование RSA - неактуально для 1С, но если будет нужно - принцип тот же.
30. Nikola23 587 13.11.18 21:49 Сейчас в теме
(29) По какому критерию оптимальность считаете?
31. uno-c 168 13.11.18 22:29 Сейчас в теме
(30) Эффективность по Парето. В данном случае выражается как "чем проще - тем лучше" при одинаковой функциональности. Хотя нет, функциональность в предложенном мной способе получше будет - нет завязки на версию дотнета. Ваше решение на win-10 потребует установки третьей версии дотнета.
32. Nikola23 587 14.11.18 09:38 Сейчас в теме
(31) Ваши утверждения высосаны из воздуха, что бы ваша позиция была подтверждена хоть чем-то. Конкретных цифр не предоставлено, да и вряд ли возможно, потому как Ваше решение - только куча слови и 3 строчки кода, на практике не проверялось. Не спорю, работать будет.

Лучшее решение - это то, которое решает задачу заказчика, в приемлемый срок с приемлемым качеством в рамках бюджета.

Коллега, уже не раз пишу, что функционал компоненты выходит за рамки создания ЭЦП. Почитайте описание хотя бы.
33. uno-c 168 14.11.18 10:34 Сейчас в теме
(32)Мое утверждение проверялось на Тинкофбанке при выдаче займов по схеме МФО, а также на 2LO авторизации Google API. Из двух решений, делающих одно и то же, лучшее то, которое менее требовательно к среде выполнения. Вы суть моего решения не поняли - делаете все то же самое, что у Вас написано и скомпилировано в dll, но делаете это напрямую из кода 1С, что подпись, что шифрование. И никаких dll и NETLoader при этом не нужно, работает на винде от 7 до 10 без запроса 3.5 дотнета - это из проверенного. На XP-sp3 тоже будет работать, если дотнет 35 поставить, на ранних XP даже с дотнетом 3.5 не работает, т.к. дотнет обращается к виндовому криптопровайдеру, а он в раньше не умел SHA256RSA. Добавлю из неочевидного к приведенному мной коду:
COMSafeArray = Новый COMSafeArray("VT_UI1", Байтов);//однобайтовый без знака
Он используется при передаче двоичных данных между эской и криптопровайдером.
34. Nikola23 587 14.11.18 10:45 Сейчас в теме
(33) Прошу за меня не решать, что я понял, а что нет.

Вы молодец, предлагаю перестать тешить свое ЧСВ, а сделать свои знания достоянием сообщества.
35. uno-c 168 14.11.18 10:56 Сейчас в теме
(34)Если кому-то нужно больше чем я написал, для решения задач подобной Вашей, без использования двух дополнительных dll-ок и без завязки на версию дотнет - вэлкам. Или помогу или действительно статью напишу. Что Вы поняли что нет - это не мое решение, а вывод из Ваших слов
Ваши утверждения высосаны из воздуха
Либо это из-за непонимания, либо еще хуже )
56. geniusan 06.11.19 17:03 Сейчас в теме
(35) Плюсую, сделал также для SHA512RSA. Пришлось сделать программку небольшую на C#, которая приватный ключ переводит из pfx в xml. Хранить его не очень безопасно получается в макете, пока сохранил в безопасном хранилище (от БСП), убрав все права у всех ролей, и сделав получение через привилегированный режим, но все равно - это ненадежно. В идеале бы найти способ, как можно средствами 1С, сертификат хранимый в хранилище сертификатов получить в xml, или как из него инициализировать RSACryptoServiceProvider.


Пример получения ЭЦП в base64:
PrivateKey 			= ОбщегоНазначения.ПрочитатьДанныеИзБезопасногоХранилища("PrivateKey");
ОбъектШифрования	= Новый COMОбъект("System.Security.Cryptography.RSACryptoServiceProvider");
ОбъектШифрования.FromXmlString(PrivateKey);

ВходнаяСтрока 	= "Test string";
UTF8Encoding 	= Новый COMОбъект("System.Text.UTF8Encoding");
ДаныеБинарные 	= UTF8Encoding.GetBytes_4(ВходнаяСтрока);

//Получаем подпись
BinaryЭЦП		= ОбъектШифрования.SignData_2(ДаныеБинарные, "2.16.840.1.101.3.4.2.3"); //SHA512RSA OUT:ComSafeArray
ЭЦП 			= BinaryЭЦП.Выгрузить(); //ComSafeArray -> Массив
Размер			= ЭЦП.Количество();
Буфер			= Новый БуферДвоичныхДанных(Размер); //Массив -> БуферДвоичныхДанных
Для Н = 0 По Размер - 1 Цикл
	Буфер[Н] = ЭЦП[Н];
КонецЦикла;
ВыходнаяСтрока	= ПолучитьBase64СтрокуИзБуфераДвоичныхДанных(Буфер);// БуферДвоичныхДанных -> Base64 String
Сообщить(СтрЗаменить(ВыходнаяСтрока, Символ(13) + Символ(10), ""));
Показать
57. uno-c 168 06.11.19 19:55 Сейчас в теме
(56)Для перевода pfx в xml можно запустить PowerShell и скопипастить в него подобный скрипт:
$cert = New-Object system.security.cryptography.x509certificates.x509certificate2
$pat="d:\UNSAFE\del\PrivateKey.pfx"
$password="123"
$flags = "UserKeySet,Exportable"
$cert.Import($pat, $password, $flags)
$myXml = $cert.PrivateKey.ToXmlString($True)
$myXml | Out-File "d:\UNSAFE\del\PrivateKey.xml"
Если Enter после последней строки не подхватите при копировании - дополнительно нажмите Enter в PowerShell

Для безопасного хранения закрытого ключа xml - можно зашифровать его средствами 1С:
	//шифруем ХМЛ
	МенеджерКриптографии = Новый МенеджерКриптографии("Microsoft Enhanced Cryptographic Provider v1.0","",1);
	ХранилищеСертификатов = МенеджерКриптографии.ПолучитьХранилищеСертификатов(ТипХранилищаСертификатовКриптографии.ПерсональныеСертификаты);
	Сертификат = ХранилищеСертификатов.НайтиПоОтпечатку(ПолучитьДвоичныеДанныеИзHexСтроки("908407f45198d4dd3a544c16d6b1a0cac85340cd"));
	ДвоичныеКлючаХМЛ = Новый ДвоичныеДанные("d:\UNSAFE\del\PrivateKey.xml");
	ДвоичныеЗашифрованногоХМЛ = МенеджерКриптографии.Зашифровать(ДвоичныеКлючаХМЛ, Сертификат);
	СтрокаЗашифрованныеХМЛ = Base64Строка(ДвоичныеЗашифрованногоХМЛ);
	
	//расшифровываем ХМЛ
	//МенеджерКриптографии.ПарольДоступаКЗакрытомуКлючу = "123";
	ДвоичныеЗашифрованногоХМЛ = Base64Значение(СтрокаЗашифрованныеХМЛ);
	ДвоичныеРасшифрованы = МенеджерКриптографии.Расшифровать(ДвоичныеЗашифрованногоХМЛ);
	СтрокаХМЛ = ПолучитьСтрокуИзДвоичныхДанных(ДвоичныеРасшифрованы);
	Сообщить(СтрокаХМЛ);
Показать
58. geniusan 07.11.19 00:57 Сейчас в теме
(57) Потрясающий ход :) Добавлю, пожалуй, шифрование/расшифровывание всего безопасного хранилища одним сертификатом. Не удивлюсь, если в БСП это тоже скоро допилят. Спасибо!
61. user1113173 4 09.12.20 10:15 Сейчас в теме
(8) Здравствуйте. Дошел до такой же схемы, но возникает ошибка при выполнении метода SignHash, но я в параметре указывал просто ХешСумму. И в вашем комментарии нахожу решение. Подскажите что в функциях SafeИзДвоичных и ДвоичныеИзSafe?
62. uno-c 168 09.12.20 14:35 Сейчас в теме
(61) Здравствуйте! Вам нужен именно SignHash? Выше (56) приведен пример подписи сразу данных без отдельного вычисления хеша - т.е. сразу SignData. Мне отдельное хеширование нужно было, т.к. требовалось дополнительно сам хеш высылать - и раз уж хеш был готов - то я его SignHash-ил. А SignData все сам сделает - и хеш рассчитает какой попросите и подпишет (сам процесс RSA подписания включает в себя хеширование - т.к. подпись вычисляется на хеш). Единственное - SignData отдельно хеш Вам не выдаст, а только готовый результат - цифровую подпись.
user1113173; +1 Ответить
63. user1113173 4 09.12.20 14:47 Сейчас в теме
(62) ну я изначально хотел использовать МенеджерКриптографии для своей задачи, выпустил свой сертификат. Хешировал вручную, но как оказалось не могу использовать команду МенеджерКриптографии.Подписать, т.к. она еще и хеширует сама. А там нельзя выбрать SHA256. В итоге я пришел к использованию "RSACryptoServiceProvider". Мне хеш никуда отправлять не надо, но мне нужно захешировать 2 значения, строку с json кодом и спец. ключ, как сделать это в 1с я представляю, просто 2 раза прописать "добавить". Но как сделать это через SignData не представляю.
68. uno-c 168 09.12.20 16:18 Сейчас в теме
(63)Оставлю тут листинг на память. В его процессе производится цифровая подпись RSA-SHA256, и Гугл только что эту подпись успешно проверил.
&НаКлиенте
Процедура ТестГуглТаблица(Команда)
	ТестГуглТаблицаНаСервере();
КонецПроцедуры

&НаСервере
Процедура ТестГуглТаблицаНаСервере()
	
	JWTдляСигнатуры = JWTдляСигнатуры();
	
	Хеширование = Новый ХешированиеДанных(ХешФункция.SHA256);
	Хеширование.Добавить(JWTдляСигнатуры);
	Хеш = Хеширование.ХешСумма;
	
	ОбработкаОбъект = РеквизитФормыВЗначение("Объект");
	МакетЗакрытогоКлюча = ОбработкаОбъект.ПолучитьМакет("Макет");
	ХМЛТекст = ПолучитьСтрокуИзДвоичныхДанных(МакетЗакрытогоКлюча);
	КрПровайдер = Новый COMОбъект("System.Security.Cryptography.RSACryptoServiceProvider");
	КрПровайдер.FromXmlString(ХМЛТекст);
	
	SafeArrayBinХешДляПодписи = SafeИзДвоичных(Хеш);
	SafeArrayBinПодписьДвоичная = КрПровайдер.SignHash(SafeArrayBinХешДляПодписи, "SHA256");
	ПодписьДвоичная = ДвоичныеИзSafe(SafeArrayBinПодписьДвоичная); 
	Подпись64 = Base64Url(ПодписьДвоичная);
	
	JWTдляСигнатуры = СтрЗаменить(JWTдляСигнатуры,"{","");
	JWTдляСигнатуры = СтрЗаменить(JWTдляСигнатуры,"}","");
	JWT = JWTдляСигнатуры + "."+Подпись64;
	
	OpenSSL = Новый ЗащищенноеСоединениеOpenSSL();
	HTTPСоединение = Новый HTTPСоединение("www.googleapis.com",,,,,,OpenSSL);
	
	Заголовки = Новый Соответствие;
	Заголовки.Вставить("Content-Type", "application/x-www-form-urlencoded");
	
	grant_type = "urn:ietf:params:oauth:grant-type:jwt-bearer";
	grant_type = КодироватьСтроку(grant_type,СпособКодированияСтроки.КодировкаURL);
	
	HTTPЗапрос = Новый HTTPЗапрос("/oauth2/v4/token", Заголовки);
	HTTPЗапрос.УстановитьТелоИзСтроки("grant_type="+grant_type+"&assertion="+JWT);
	Ответ = HTTPСоединение.ОтправитьДляОбработки(HTTPЗапрос);
	
	СтрокаОтвета = Ответ.ПолучитьТелоКакСтроку();
	ЧтениеЖсон = Новый ЧтениеJSON;
	ЧтениеЖсон.УстановитьСтроку(СтрокаОтвета);
	СтруктураОтвета = ПрочитатьJSON(ЧтениеЖсон);
	Токен = СтруктураОтвета.access_token;
	
	Сообщить(Токен);
	
	HTTPСоединение = Новый HTTPСоединение("sheets.googleapis.com",,,,,,OpenSSL);
	
	урл = "/v4/spreadsheets/1H_nu10s9gB787gy4Qhx2bbCyGPrfRnkGGEuZrtV4-0s/values/Sheet1!A1?valueInputOption=RAW";
	
	Заголовки = Новый Соответствие;
	Заголовки.Вставить("Content-Type", "application/json; charset=UTF-8");
	Заголовки.Вставить("Authorization", "Bearer " + Токен);
	
	СтрокаJson = "{""range"":""Sheet1!A1"", ""values"":[[777999000]],}";
	HTTPЗапрос2 = Новый HTTPЗапрос(урл, Заголовки);
	HTTPЗапрос2.УстановитьТелоИзСтроки(СтрокаJson);
	
	Ответ = HTTPСоединение.Записать(HTTPЗапрос2);
	СтрокаОтвета = Ответ.ПолучитьТелоКакСтроку();
	
	Сообщить(СтрокаОтвета);
	
КонецПроцедуры

&НаСервере
Функция ПолучитьСтрокуЖсон(СтруктураДляЖсон)

	ЗаписьJson = Новый ЗаписьJson;
	ЗаписьJson.УстановитьСтроку(Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Нет));
	ЗаписатьJSON(ЗаписьJson, СтруктураДляЖсон);
	Возврат ЗаписьJson.Закрыть();

КонецФункции // ПолучитьСтрокуЖсон(СтруктураДляЖсон)
 

&НаСервере
//create base64url header + clame for jwt
//https://developers.google.com/identity/protocols/OAuth2ServiceAccount 
//на странице ↑ найти и кликнуть HTTP/REST
Функция JWTдляСигнатуры()
	
	//это все время одинаковое, можно сразу base64урл
	СтруктураДляЖсон = Новый Структура;
	СтруктураДляЖсон.Вставить("alg", "RS256"); 
	СтруктураДляЖсон.Вставить("typ", "JWT");
	СтруктураДляЖсон.Вставить("alg", "RS256");
	СтрокаЖсонХедер = ПолучитьСтрокуЖсон(СтруктураДляЖсон);
	Хедер64 = Base64Url(ПолучитьДвоичныеДанныеИзСтроки(СтрокаЖсонХедер));
	
	СтруктураДляЖсон.Очистить();
	
	//iss 	The email address of the service account.
	СтруктураДляЖсон.Вставить("iss", "xxx*xxx.iam.gserviceaccount.com"); 
	
	//scope 	A space-delimited list of the permissions that the application requests.
	//смотреть что нужно например: https://developers.google.com/sheets/api/guides/authorizing
	СтруктураДляЖсон.Вставить("scope", "https://www.googleapis.com/auth/spreadsheets"); 
	
	//aud 	A descriptor of the intended target of the assertion. 
	//When making an access token request this value is always https://www.googleapis.com/oauth2/v4/token.
	СтруктураДляЖсон.Вставить("aud", "https://www.googleapis.com/oauth2/v4/token"); 
	
	//exp 	The expiration time of the assertion, specified as seconds since 00:00:00 UTC, January 1, 1970. 
	//This value has a maximum of 1 hour after the issued time.
	ВремяДо = УниверсальноеВремя(ТекущаяДата())+60*60;// запас на поправку времени
	СекундДо = ВремяДо - Дата(1970,1,1);
	СтруктураДляЖсон.Вставить("exp", СекундДо);
	
	//iat 	The time the assertion was issued, specified as seconds since 00:00:00 UTC, January 1, 1970.
	СтруктураДляЖсон.Вставить("iat", СекундДо-60*60);
	
	СтрокаЖсонКлэймСет = ПолучитьСтрокуЖсон(СтруктураДляЖсон);;
	КлэймСет64 = Base64Url(ПолучитьДвоичныеДанныеИзСтроки(СтрокаЖсонКлэймСет));
	
	Возврат Хедер64+"."+КлэймСет64;
	
КонецФункции

&НаСервере
//существует изменённый Base64 для URL, где не используется заполнение символом = 
//и символы + и / соответственно заменяются на * и -
//Base64-кодирования URL адресов признается вариант, 
//когда символы + и / заменяются, соответственно, на - и _ (RFC 3548, раздел 4). 
Функция Base64Url(ДвоичныеДанные)
	
	бейс64строка = Base64Строка(ДвоичныеДанные);
	бейс64строка = стрЗаменить(бейс64строка, "+", "-");
	бейс64строка = стрЗаменить(бейс64строка, "/", "_");
	бейс64строка = стрЗаменить(бейс64строка, Символы.ВК, "");
	бейс64строка = стрЗаменить(бейс64строка, Символы.ПС, "");
	
	Если Прав(бейс64строка, 2) = "==" Тогда
		бейс64строка = Лев(бейс64строка,СтрДлина(бейс64строка)-2);
		
	ИначеЕсли Прав(бейс64строка, 1) = "=" Тогда
		бейс64строка = Лев(бейс64строка,СтрДлина(бейс64строка)-1);
	КонецЕсли;
	
	Возврат бейс64строка;
	
КонецФункции

&НаСервере
Функция SafeИзUTF(strUtf)
	Буфер = ПолучитьБуферДвоичныхДанныхИзСтроки(strUtf);
	Байтов = Буфер.Размер;
	COMSafeArray = Новый COMSafeArray("VT_UI1", Байтов);//однобайтовый без знака
	Для сч = 0 по Байтов-1 Цикл
		COMSafeArray.SetValue(сч, Буфер.Получить(сч));
	КонецЦикла;
	Возврат COMSafeArray;
КонецФункции

&НаСервере
Функция SafeИзДвоичных(ДвоичныеДанные)
	Буфер = ПолучитьБуферДвоичныхДанныхИзДвоичныхДанных(ДвоичныеДанные);
	Байтов = Буфер.Размер;
	COMSafeArray = Новый COMSafeArray("VT_UI1", Байтов);//однобайтовый без знака
	Для сч = 0 по Байтов-1 Цикл
		COMSafeArray.SetValue(сч, Буфер.Получить(сч));
	КонецЦикла;
	Возврат COMSafeArray;
КонецФункции

&НаСервере
Функция ДвоичныеИзSafe(SafeArrayBin) 
	Буфер = Новый БуферДвоичныхДанных(SafeArrayBin.GetLength());
	Для сч = 0 по SafeArrayBin.GetUpperBound() Цикл
		Буфер.Установить(сч, SafeArrayBin.GetValue(сч));
	КонецЦикла;
	Возврат ПолучитьДвоичныеДанныеИзБуфераДвоичныхДанных(Буфер);
КонецФункции

Показать
69. uno-c 168 10.12.20 08:26 Сейчас в теме
(68) Извините за дубль. Возможно, длинные посты как-то модерируются администрацией. Сначала я отправил (67) пост - но он не появился ни здесь ни на "Моя страница" - там где видны все мои посты в обратной хронологии. Я решил, что глюк в процессе отправки. Сделал (68) - но он снова не появился ни здесь ни на "Моя страница". А сегодня случайно заметил, что и на "Моя страница" все появилось, и здесь )
64. uno-c 168 09.12.20 14:55 Сейчас в теме
(61) Вот, вроде нашел.
&НаСервере
Функция SafeИзДвоичных(ДвоичныеДанные)
	Буфер = ПолучитьБуферДвоичныхДанныхИзДвоичныхДанных(ДвоичныеДанные);
	Байтов = Буфер.Размер;
	COMSafeArray = Новый COMSafeArray("VT_UI1", Байтов);//однобайтовый без знака
	Для сч = 0 по Байтов-1 Цикл
		COMSafeArray.SetValue(сч, Буфер.Получить(сч));
	КонецЦикла;
	Возврат COMSafeArray;
КонецФункции

&НаСервере
Функция ДвоичныеИзSafe(SafeArrayBin) 
	Буфер = Новый БуферДвоичныхДанных(SafeArrayBin.GetLength());
	Для сч = 0 по SafeArrayBin.GetUpperBound() Цикл
		Буфер.Установить(сч, SafeArrayBin.GetValue(сч));
	КонецЦикла;
	Возврат ПолучитьДвоичныеДанныеИзБуфераДвоичныхДанных(Буфер);
КонецФункции
Показать
user1113173; +1 Ответить
65. user1113173 4 09.12.20 15:00 Сейчас в теме
(64) Спасибо большое. Удивительно что спустя 2 года у вас это сохранилось.
66. uno-c 168 09.12.20 15:04 Сейчас в теме
(65) Вам повезло, на самом деле я их полгода назад потерял вместе с полетевшим HDD, но сейчас Вы спросили - мысль появилась где еще поискать.
user1113173; +1 Ответить
67. uno-c 168 09.12.20 16:12 Сейчас в теме
(65) Оставлю тут листинг на память. Он пишет значение в гугл-таблицу, а что касается этой темы - перед записью идет получение токена, в процессе которого производится цифровая подпись по алгоритму RSA-SHA256 и Гугл проверяет подлинность этой подписи. Код рабочий, только что проверил - в ячейку гуглшита записалось 777999000. Где в коде xxxxx - в оригинале другие символы )
&НаКлиенте
Процедура ТестГуглТаблица(Команда)
	ТестГуглТаблицаНаСервере();
КонецПроцедуры

&НаСервере
Процедура ТестГуглТаблицаНаСервере()
	
	JWTдляСигнатуры = JWTдляСигнатуры();
	
	Хеширование = Новый ХешированиеДанных(ХешФункция.SHA256);
	Хеширование.Добавить(JWTдляСигнатуры);
	Хеш = Хеширование.ХешСумма;
	
	ОбработкаОбъект = РеквизитФормыВЗначение("Объект");
	МакетЗакрытогоКлюча = ОбработкаОбъект.ПолучитьМакет("Макет");
	ХМЛТекст = ПолучитьСтрокуИзДвоичныхДанных(МакетЗакрытогоКлюча);
	КрПровайдер = Новый COMОбъект("System.Security.Cryptography.RSACryptoServiceProvider");
	КрПровайдер.FromXmlString(ХМЛТекст);
	
	SafeArrayBinХешДляПодписи = SafeИзДвоичных(Хеш);
	SafeArrayBinПодписьДвоичная = КрПровайдер.SignHash(SafeArrayBinХешДляПодписи, "SHA256");
	ПодписьДвоичная = ДвоичныеИзSafe(SafeArrayBinПодписьДвоичная); 
	Подпись64 = Base64Url(ПодписьДвоичная);
	
	JWTдляСигнатуры = СтрЗаменить(JWTдляСигнатуры,"{","");
	JWTдляСигнатуры = СтрЗаменить(JWTдляСигнатуры,"}","");
	JWT = JWTдляСигнатуры + "."+Подпись64;
	
	OpenSSL = Новый ЗащищенноеСоединениеOpenSSL();
	HTTPСоединение = Новый HTTPСоединение("www.googleapis.com",,,,,,OpenSSL);
	
	Заголовки = Новый Соответствие;
	Заголовки.Вставить("Content-Type", "application/x-www-form-urlencoded");
	
	grant_type = "urn:ietf:params:oauth:grant-type:jwt-bearer";
	grant_type = КодироватьСтроку(grant_type,СпособКодированияСтроки.КодировкаURL);
	
	HTTPЗапрос = Новый HTTPЗапрос("/oauth2/v4/token", Заголовки);
	HTTPЗапрос.УстановитьТелоИзСтроки("grant_type="+grant_type+"&assertion="+JWT);
	Ответ = HTTPСоединение.ОтправитьДляОбработки(HTTPЗапрос);
	
	СтрокаОтвета = Ответ.ПолучитьТелоКакСтроку();
	ЧтениеЖсон = Новый ЧтениеJSON;
	ЧтениеЖсон.УстановитьСтроку(СтрокаОтвета);
	СтруктураОтвета = ПрочитатьJSON(ЧтениеЖсон);
	Токен = СтруктураОтвета.access_token;
	
	Сообщить(Токен);
	
	HTTPСоединение = Новый HTTPСоединение("sheets.googleapis.com",,,,,,OpenSSL);
	
	урл = "/v4/spreadsheets/1H_nu10s9gB787gy4Qhx2bbCyGPrfRnkGGEuZrtV4-0s/values/Sheet1!A1?valueInputOption=RAW";
	
	Заголовки = Новый Соответствие;
	Заголовки.Вставить("Content-Type", "application/json; charset=UTF-8");
	Заголовки.Вставить("Authorization", "Bearer " + Токен);
	
	СтрокаJson = "{""range"":""Sheet1!A1"", ""values"":[[777999000]],}";
	HTTPЗапрос2 = Новый HTTPЗапрос(урл, Заголовки);
	HTTPЗапрос2.УстановитьТелоИзСтроки(СтрокаJson);
	
	Ответ = HTTPСоединение.Записать(HTTPЗапрос2);
	СтрокаОтвета = Ответ.ПолучитьТелоКакСтроку();
	
	Сообщить(СтрокаОтвета);
	
КонецПроцедуры

&НаСервере
Функция ПолучитьСтрокуЖсон(СтруктураДляЖсон)

	ЗаписьJson = Новый ЗаписьJson;
	ЗаписьJson.УстановитьСтроку(Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Нет));
	ЗаписатьJSON(ЗаписьJson, СтруктураДляЖсон);
	Возврат ЗаписьJson.Закрыть();

КонецФункции // ПолучитьСтрокуЖсон(СтруктураДляЖсон)
 

&НаСервере
//create base64url header + clame for jwt
//https://developers.google.com/identity/protocols/OAuth2ServiceAccount 
//на странице ↑ найти и кликнуть HTTP/REST
Функция JWTдляСигнатуры()
	
	//это все время одинаковое, можно сразу base64урл
	СтруктураДляЖсон = Новый Структура;
	СтруктураДляЖсон.Вставить("alg", "RS256"); 
	СтруктураДляЖсон.Вставить("typ", "JWT");
	СтруктураДляЖсон.Вставить("alg", "RS256");
	СтрокаЖсонХедер = ПолучитьСтрокуЖсон(СтруктураДляЖсон);
	Хедер64 = Base64Url(ПолучитьДвоичныеДанныеИзСтроки(СтрокаЖсонХедер));
	
	СтруктураДляЖсон.Очистить();
	
	//iss 	The email address of the service account.
	СтруктураДляЖсон.Вставить("iss", "xxxxxxxxxxxxxx*dans-test-project-xxxxxxxxx.iam.gserviceaccount.com"); 
	
	//scope 	A space-delimited list of the permissions that the application requests.
	//смотреть что нужно например: https://developers.google.com/sheets/api/guides/authorizing
	СтруктураДляЖсон.Вставить("scope", "https://www.googleapis.com/auth/spreadsheets"); 
	
	//aud 	A descriptor of the intended target of the assertion. 
	//When making an access token request this value is always https://www.googleapis.com/oauth2/v4/token.
	СтруктураДляЖсон.Вставить("aud", "https://www.googleapis.com/oauth2/v4/token"); 
	
	//exp 	The expiration time of the assertion, specified as seconds since 00:00:00 UTC, January 1, 1970. 
	//This value has a maximum of 1 hour after the issued time.
	ВремяДо = УниверсальноеВремя(ТекущаяДата())+60*60;// запас на поправку времени
	СекундДо = ВремяДо - Дата(1970,1,1);
	СтруктураДляЖсон.Вставить("exp", СекундДо);
	
	//iat 	The time the assertion was issued, specified as seconds since 00:00:00 UTC, January 1, 1970.
	СтруктураДляЖсон.Вставить("iat", СекундДо-60*60);
	
	СтрокаЖсонКлэймСет = ПолучитьСтрокуЖсон(СтруктураДляЖсон);;
	КлэймСет64 = Base64Url(ПолучитьДвоичныеДанныеИзСтроки(СтрокаЖсонКлэймСет));
	
	Возврат Хедер64+"."+КлэймСет64;
	
КонецФункции

&НаСервере
//существует изменённый Base64 для URL, где не используется заполнение символом = 
//и символы + и / соответственно заменяются на * и -
//Base64-кодирования URL адресов признается вариант, 
//когда символы + и / заменяются, соответственно, на - и _ (RFC 3548, раздел 4). 
Функция Base64Url(ДвоичныеДанные)
	
	бейс64строка = Base64Строка(ДвоичныеДанные);
	бейс64строка = стрЗаменить(бейс64строка, "+", "-");
	бейс64строка = стрЗаменить(бейс64строка, "/", "_");
	бейс64строка = стрЗаменить(бейс64строка, Символы.ВК, "");
	бейс64строка = стрЗаменить(бейс64строка, Символы.ПС, "");
	
	Если Прав(бейс64строка, 2) = "==" Тогда
		бейс64строка = Лев(бейс64строка,СтрДлина(бейс64строка)-2);
		
	ИначеЕсли Прав(бейс64строка, 1) = "=" Тогда
		бейс64строка = Лев(бейс64строка,СтрДлина(бейс64строка)-1);
	КонецЕсли;
	
	Возврат бейс64строка;
	
КонецФункции

&НаСервере
Функция SafeИзUTF(strUtf)
	Буфер = ПолучитьБуферДвоичныхДанныхИзСтроки(strUtf);
	Байтов = Буфер.Размер;
	COMSafeArray = Новый COMSafeArray("VT_UI1", Байтов);//однобайтовый без знака
	Для сч = 0 по Байтов-1 Цикл
		COMSafeArray.SetValue(сч, Буфер.Получить(сч));
	КонецЦикла;
	Возврат COMSafeArray;
КонецФункции

&НаСервере
Функция SafeИзДвоичных(ДвоичныеДанные)
	Буфер = ПолучитьБуферДвоичныхДанныхИзДвоичныхДанных(ДвоичныеДанные);
	Байтов = Буфер.Размер;
	COMSafeArray = Новый COMSafeArray("VT_UI1", Байтов);//однобайтовый без знака
	Для сч = 0 по Байтов-1 Цикл
		COMSafeArray.SetValue(сч, Буфер.Получить(сч));
	КонецЦикла;
	Возврат COMSafeArray;
КонецФункции

&НаСервере
Функция ДвоичныеИзSafe(SafeArrayBin) 
	Буфер = Новый БуферДвоичныхДанных(SafeArrayBin.GetLength());
	Для сч = 0 по SafeArrayBin.GetUpperBound() Цикл
		Буфер.Установить(сч, SafeArrayBin.GetValue(сч));
	КонецЦикла;
	Возврат ПолучитьДвоичныеДанныеИзБуфераДвоичныхДанных(Буфер);
КонецФункции

Показать
user1113173; +1 Ответить
13. uno-c 168 12.11.18 01:45 Сейчас в теме
50. stash_84 08.08.19 09:35 Сейчас в теме
(13) В связи с тем, что внутренние сообщения не работают, хотел бы тут обратиться к Вам - не могли бы Вы пояснить о своём решении, основанном на штатном криптопровайдере ОС?
51. Nikola23 587 08.08.19 22:31 Сейчас в теме
52. stash_84 09.08.19 07:04 Сейчас в теме
(51) вопрос был неверным - работа с криптографией средствами Крипто Про.
53. Nikola23 587 09.08.19 18:37 Сейчас в теме
(52) В этой компоненте крипто про не поддерживается. У крипто про есть свои методы.
54. stash_84 13.08.19 08:47 Сейчас в теме
(53) по этим методам есть подобные статьи или только на сайте "Крипто Про" необходимо брать документацию и разбираться?
55. Nikola23 587 13.08.19 21:06 Сейчас в теме
(54) Этот вопрос я не разбирал. Поэтому Вам надо самому разбираться. В т.ч. с поиском документации.
59. overclock 31.05.20 17:14 Сейчас в теме
Добрый день. Скачал отдельно библиотеку, хочу подключить ее через компоненту netloader.dll, используя CreateObjectFromFile, но там нужно указать класс. Подскажите его название.
ПодключитьВнешнююКомпоненту("ОбщийМакет.NETLoader", "NET") ;
Компонента = Новый("AddIn.NET.NETLoader");
Компонента.CreateObjectFromFile("C:\coderEncoder.dll", ???);
60. Nikola23 587 31.05.20 23:39 Сейчас в теме
(59) кто ж его помнит) Библитека с инфостарта - поищите по имени NetLoader.
А вообще в комментах к публикации есть описание решения на WinAPI без внешних компонент. Те же самые, фактически, методы, но без лишних оберток.
Оставьте свое сообщение

См. также

Внешняя компонента: Android tools Промо

Мобильная разработка Разработка внешних компонент v8 v8::Mobile Абонемент ($m)

Несколько дополнительных функций для мобильного приложения\клиента под Android. Размер архива внешних компонент под архитектуры ARM и x86 - 230KB.

1 стартмани

12.01.2021    1717    3    KAV2    6    

Описание работы внешней компоненты 1С SBRFCOM.DLL для обслуживания банковских карт

Эквайринг Разработка внешних компонент v8 1cv8.cf Россия Абонемент ($m)

Описание работы внешней компоненты 1С SBRFCOM.DLL для обслуживания банковских карт, приведены методы и функции по работе с данной компонентой.

1 стартмани

09.03.2021    1017    2    artemua    7    

Использование встроенного сканера ТСД на Android в мобильном клиенте и мобильном приложении (драйвер сканера Android для 1С)

Разработка внешних компонент Мобильная разработка v8 Абонемент ($m)

Используя данный драйвер, можно без единой строки кода, просто установив на ТСД мобильный клиент 1С, сразу начать подбирать товары в документах вашей учётной системы. А, адаптировав нужные формы под небольшой размер экрана ТСД, можно просто создать полноценное рабочее место для выполнения операций с помощью ТСД, не прибегая к стороннему софту. Если же на складе плохая связь (или её нет вовсе), то можно использовать возможности мобильного клиента в автономном режиме (потребуется доработка вашей конфигурации). Драйвер также можно использовать и для Android приложения на мобильной платформе. В результате чего можно обойтись без ненужных полей ввода и клавиатуры «на пол-экрана».

3 стартмани

09.10.2020    10317    96    ltfriend    90    

Отрубаем зависшие на сервере процессы

Разработка внешних компонент v8 1cv8.cf Абонемент ($m)

Вы любите COM объекты? Я их просто обожаю! Практически все, чего не может 1С, можно доделать ими. Но есть у них небольшой косячок: иногда они зависают и висят, пока не отрубишь их через диспетчер задач или до перезагрузки, жрут память и в конце концов перестают запускаться. Что делать? Рубить!

1 стартмани

28.07.2020    3157    1    zarankony    3    

Внешняя компонента для работы по Web-socket протоколу x32 x64 Промо

Разработка внешних компонент WEB v8 Абонемент ($m)

Кто когда-нибудь сталкивался с обменом данными по Web-Socket (wss) протоколу из 1С, тому известно, что в платформе отсутствуют данные механизмы (не путать с HTTP запросами и WebServices). Предлагается использовать внешнюю компоненту, написанную по технологии NativeAPI, для подключения и обмена с серверами из 1С-Предприятия, работающими по протоколу Web-Socket.

1 стартмани

30.03.2018    30555    38    Ditron    90    

Диагностика контекста выполнения (внешняя компонента)

Разработка внешних компонент v8 1cv8.cf Абонемент ($m)

Небольшая экспериментальная внешняя компонента для получения дополнительной информации о контексте выполнения.

1 стартмани

24.07.2020    6413    2    YPermitin    14    

Универсальная обертка для использования NATIVE компонент на платформе 1С 7.7, 8.0 и 8.1

Разработка внешних компонент v8 Абонемент ($m)

Используете 1С 7.7, 8.0 или 8.1 и вас раздражает, что под вашу 1С уже не выпускаются современные компоненты. А хотелось бы?

1 стартмани

07.07.2020    4594    7    karpik666    5    

Нано HTTP сервер - внешняя компонента для мобильного приложения 1C, на Android

Разработка внешних компонент Мобильная разработка v8 v8::Mobile 1cv8.cf Абонемент ($m)

Нано HTTP сервер на терминале сбора данных "ATOL Smart.Lite android 7.0". Работает только с GET и POST запросами. Аутентификация BASE64. Не поддерживает HTTPS и не передает файлы. В прикрепленном архиве исходники на компоненту (С++ и java для Android Studio 3.6.2), ЦФ - мобильного приложения и тестовая обработка.

1 стартмани

22.06.2020    4496    10    SanyMaga    19    

TextRadar - нечеткий поиск в тексте Промо

Разработка внешних компонент Поиск данных v8 1cv8.cf Абонемент ($m)

В отличие от нечеткого сравнения строк, когда обе сравниваемых строки равнозначны, в задаче нечеткого поиска выделяются строка поиска и строка данных, а вычислить необходимо не степень похожести двух строк, а степень присутствия строки поиска в строке данных. Нормированный коэффициент, находящийся между 0 и 1 позволяет отсечь заведомо низкие результаты, организовать поиск по синонимам и т.д. Наглядное отображение результатов в кратком и детальном виде поможет быстро найти интересующий фрагмент.

1 стартмани

19.09.2018    20226    30    TSSV    19    

Получение фото с веб-камеры

Разработка внешних компонент v8 Абонемент ($m)

Получение фото с веб-камеры без ActiveX. Внешняя компонента по технологии Native API.

1 стартмани

25.03.2020    7856    71    berezdetsky    40    

Пауза без загрузки процессора. Внешняя компонента Native API на C++

Разработка внешних компонент v8 Абонемент ($m)

Внешняя компонента Native API на C++ для Win32 и Win64 позволяет установить паузу на заданное количество секунд без загрузки процессора.

2 стартмани

21.03.2020    3523    4    DNN13    26    

Быстрая печать этикеток (ZPL, EPL, TSPL, EZPL, GEPL, TSPL-EZ)

Разработка внешних компонент v8 v8::УФ 1cv8.cf Абонемент ($m)

Качественная и быстрая печать на внутреннем языке принтеров этикеток.

4 стартмани

02.02.2020    9599    41    Johny_v    13    

Использование сборок .NET в 1С 7. и 8.x. Создание внешних Компонент. Промо

Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Данная разработка создана для использования сборок .Net в 1С через преобразование объектов и классов в COM-объекты, которые можно использовать в 1С. Достигается это путем создания класса, реализующего методы интерфейса IReflect public class AutoWrap: IReflect.

1 стартмани

28.11.2013    87485    282    Serginio    74    

Сканирование по TWAIN в 1С (обычные и управляемые формы)

Разработка внешних компонент v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка показывает пример, как можно в 1С проводить сканирование с помощью компоненты TWAIN.

3 стартмани

03.01.2020    7225    28    Denr83    0    

Вставка картинки из буфера обмена (на выбор: JavaScript / внешняя компонента / штатно)

Разработка внешних компонент v8 Абонемент ($m)

Вставка картинки из буфера обмена с помощью JavaScript в поле HTML в web-клиенте, с помощью внешней компоненты в тонком/толстом клиенте и путем преобразования данных картинки формата Base64 из поля HTML в любом клиенте, начиная с платформы 8.3.16. Механизм протестирован на платформах 8.2 и 8.3 Для запуска опубликованной конфигурации требуется платформа релиза не ниже 8.3.14.

1 стартмани

05.12.2019    6006    7    Andreyyy    10    

Клиент событий в «бесконечном» HTTP-соединении для 1С: Предприятие 8

Разработка внешних компонент v8 1cv8.cf Абонемент ($m)

Native Компонента в отдельном потоке обрабатывает пакеты событий, в "бесконечном" http соединении и передаёт данные в очередь внешних событий.

1 стартмани

02.12.2019    5657    2    starovton    11    

Tool1CD Beta в деле Промо

Разработка внешних компонент v8 Абонемент ($m)

Пс, парень! Не хочешь немного сырых байтов?

1 стартмани

09.05.2018    28293    31    baton_pk    26    

Управление окнами и мониторами в 1С

Сервисные утилиты Разработка внешних компонент v8 1cv8.cf 1С:Франчайзи, автоматизация бизнеса Абонемент ($m)

Управление размерами, активностью и положением окон из 1С с возможностью вывода окон на второй монитор и запретом изменения окна.

1 стартмани

28.10.2019    10709    11    Grigoriy251    7    

Маленькая и скромная мобильная внешняя компонента

Разработка внешних компонент v8 Абонемент ($m)

Изваять простенькую мобильную компоненту на 1С для android не так-то просто. Посему назло отдельным супостатам, не желающим делится исходниками, представляю весь свой скромный труд на публичный суд.

1 стартмани

21.10.2019    11064    7    ripreal1    34    

Обозреватель криптографии

Инструментарий разработчика Защита ПО v8 Абонемент ($m)

Отчет для просмотра доступных провайдеров и сертификатов криптографии на сервере и клиенте.

2 стартмани

21.10.2019    12275    15    YPermitin    10    

NativeDraw: Компонента рисования для 1С [V2.6.2] Промо

Разработка внешних компонент Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Рисуйте в формах 1С, также предлагается небольшое количество нерисовальных функций

1 стартмани

13.07.2015    49974    466    ПерваяСистема    147    

Native внешняя компонента для оповещения по UDP или TCP

Разработка внешних компонент v8 Абонемент ($m)

Native внешняя компонента для оповещения по UDP или TCP, которая реализует возможность в 1С передавать сообщения с сервера на клиента. Исходный код компоненты также представлен.

1 стартмани

06.10.2019    12232    28    vdv2701    31    

Внешняя компонента Sundries: несколько полезных системных функций

Разработка внешних компонент v8 Абонемент ($m)

Звук, пауза, буфер обмена, раскладки клавиатуры и т.д.

4 стартмани

30.08.2019    7253    9    sivin-alexey    15    

Native внешняя компонента для передачи/получения по UDP (теперь с Base64)

Разработка внешних компонент v8 УТ10 Россия Абонемент ($m)

Внешняя компонента Native-API для организации передачи с использованием UDP.

1 стартмани

29.07.2019    5436    10    axae    2    

Компоненты распознавания и печати штрих-кодов Промо

Разработка внешних компонент Сканер штрих-кода v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Комплект программного обеспечения для реализации функций оптического распознавания штрих-кодов различных систем при помощи обычной web-камеры, а также их отображения в печатных формах. Программы могут работать в составе конфигураций, созданных на базе платформ «1С-Предприятие» версий 7.7, 8.2, 8.3. Компонент чтения кодов реализован в виде внешней компоненты 1С с COM-интерфейсом. Компонент отображения создан по стандартной технологии ActiveX для Windows, и может быть встроен в любое приложение, поддерживающее встраивание ActiveX элементов управления, например в документ Word или Excel, или форму VBA. P.S. Добавлена новая версия программы распознавания. Новые функции: обработка видео в реальном режиме (а не по таймеру, как раньше), добавлена возможность распознавания штрих-кодов из графических файлов JPEG, PNG, GIF, BMP, а также передавать для распознавания картинки из 1С, теперь можно получить в 1С захваченное с камеры или файла изображение, как с выделением мест, содержащих коды, так и без, а также отдельные фрагменты изображений, содержащие код. Добавлены новые свойства и методы для программирования. Обновлена документация.

10 стартмани

10.07.2015    72811    88    igorberezhnov    101    

Внешняя компонента для работы с драйвером "Атол v.10". 1С:8.3

Разработка внешних компонент Кассовые операции Кассовые операции v8 Абонемент ($m)

Внешняя компонента, для работы с драйвером «Атол v.10», посредством JSON-заданий.

1 стартмани

16.07.2019    13350    30    gortrex    5    

Менеджер буфера обмена. Нативная внешняя компонента win 32/64

Разработка внешних компонент v8 1cv8.cf Абонемент ($m)

Добавляет возможности получения информации из почтовых вложений или файлов с других рабочих столов (RDP) с помощью операций копирования/вставки. Может «прослушивать»: любые изменения буфера обмена; нажатие клавиш соответствующих вставке (paste); нажатие клавиш копирования (copy); drop операции. Это новая реализация аналогичной компоненты https://infostart.ru/public/379695/, но теперь не C#, а С++ нативно для x32 / x64. (см. http://youtu.be/-PaWWFfbYo4)

1 стартмани

26.06.2019    7904    26    Bww    23    

Обработка вывода на печать QR-кода и штрихкодов в различных форматах (одномерные и двумерные)

Разработка внешних компонент Ценники v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Обработка предназначена для вывода на печать QR-кода и штрихкодов в различных форматах без установки дополнительных ActiveX компонент. Тестировалась на чистой базе платформы 1С:Предприятие 8.3 (8.3.14.1630), а так же в конфигурациях Бухгалтерия предприятия КОРП, редакция (3.0.69.35) и на Бухгалтерия предприятия (3.0.70.30)

2 стартмани

22.05.2019    12568    47    MGemini    3    

Полезные приемы при работе с Excel из 1С (Версия 3.1) Промо

Практика программирования Разработка внешних компонент Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Программисту 1С часто приходится работать с таблицами Excel из 1С. Я постарался собрать небольшой FAQ и набор функций для работы с файлами Excel. Надеюсь, кому-то будет полезна данная статья.

1 стартмани

22.09.2015    224788    477    Zerocl    76    

DLL для подключения к Asterisk (32/64 клиенты)

Разработка внешних компонент Телефония, SIP v8 1cv8.cf Абонемент ($m)

Подключение к Астериску и получение событий "Newchannel","BridgeEnter","Hangup" через ОбработкаВнешнегоСобытия.

1 стартмани

19.03.2019    9351    13    xxxAndricxxx    14    

DLL для обмена между 1С (и не только) через UDP порты (32/64 клиенты)

Разработка внешних компонент v8 1cv8.cf Россия Абонемент ($m)

Библиотеки для создания функционала для прослушивания портов из 1С и отправки сообщений на удаленный udp порт.

1 стартмани

28.02.2019    8454    9    xxxAndricxxx    2    

Эмулятор ККМ по стандарту ФФД 1.1

Разработка внешних компонент Кассовые операции ККМ Кассовые операции v8 Розница УТ11 Россия Абонемент ($m)

Эмулятор драйвера ККМ по стандарту ФФД 1.1 предназначен для использования всех возможностей программы, при отсутствии физической кассы. Подойдет как программистам при разработке интерфейса РМК, например, так и пользователям для тестирования возможностей программы.

1 стартмани

30.12.2018    25680    148    Matveymc    30    

Снимок экрана для 1С Промо

Универсальные обработки Разработка внешних компонент v8 1cv8.cf Россия Абонемент ($m)

Довольно часто люди сталкиваются с необходимостью сделать снимок экрана. Если вы или ваши сотрудники основную часть времени проводят в 1С и у вас есть необходимость прикреплять графические файлы, то эта компонента для вас.

1 стартмани

08.02.2016    29913    34    linkforget    11    

WebSocket Клиент / Сервер. Внешний компонент

Разработка внешних компонент v8 1cv8.cf Абонемент ($m)

Реализация протокола WebSocket. Клиентская часть для взаимодействия с внешними сервисами. Серверная часть для организации собственного сервера, принимающего клиентские соединения в многопоточном режиме. Возможно взаимодействие RabbitMQ Slack Asterisk и другие

1 стартмани

16.11.2018    19439    85    nomadon    66    

Внешняя компонента для выполнения регулярных выражений

Разработка внешних компонент v8 Абонемент ($m)

Внешняя Native API компонента для выполнения регулярных выражений на платформе 1С:Предприятие 8. Написана на C++. Используется движок boost::regex (v 1.69, v 1.68 - для Android). Версия синтаксиса Perl Compatible Regular Expressions.

1 стартмани

12.11.2018    14587    35    KAV2    65    

Native компонента для 8.3, реализующая метод sleep()

Разработка внешних компонент v8 Россия Абонемент ($m)

Внешняя Native 64-битная компонента для 1C 8.3, которая реализует метод sleep() - паузу выполнения кода. Пауза для большой устойчивости сделана платформозависимой и требует WinAPI. Ид компоненты - AddIn.AddInNativeSleep.NativeSleep.

1 стартмани

16.10.2018    9073    3    ripreal1    9    

Native API компонента для использования установленного в системе интерпретатора Python Промо

Разработка внешних компонент v8 1cv8.cf Абонемент ($m)

Компонента позволяет подключать к платформе 1С python-модули, оформленные в стиле внешней компоненты. Кроме этого, она позволяет запускать небольшие фрагменты python-кода прямо из модулей 1С. На данный момент поддерживаются платформы 8.2 — 8.3 x86 Windows.

1 стартмани

14.05.2013    41969    84    Принт    31    

Класс-обработка “Работа с картами Яндекс”

Разработка внешних компонент WEB v8 Абонемент ($m)

Как показать точку или маршрут на карте Яндекс. Как получить координаты по строке адреса (геокодирование).

1 стартмани

01.08.2018    29298    222    RSConsulting    17    

Распознавание лиц (off-line). Демонстрационная база.

Разработка внешних компонент v8 Абонемент ($m)

Распознавание лиц входит в нашу жизнь стремительными темпами, бизнес стремится за событиями. В публикации находится описание и пример использования нейросетей для распознавания лиц.

1 стартмани

17.07.2018    18018    75    nomadon    45    

QR-code полная версия (без шрифта и внешней компоненты для 8.2, 8.3 и любого типа клиента)

Разработка внешних компонент Сканер штрих-кода v8 1cv8.cf Абонемент ($m)

Предназначена для создания QR-code с указанием процента восстановления потерянных данных. Строка кодирования может содержать все печатаемые символы, в том числе и кириллические. Для работы не требуется внешняя компонента или шрифт.

2 стартмани

10.07.2018    13617    16    bobank    6    

Распознаем штрих-коды QR, EAN-13, Code 128 с помошью 1С и веб камеры Промо

Разработка внешних компонент v8 1cv8.cf Россия Абонемент ($m)

Внешняя компонента, поможет распознать штрих-код, используя обычную веб камеру. Умеет работать с UPC-A, UPC-E, EAN-8, EAN-13, Code 39, Code 128, QR Code, Interleaved 2 of 5, Codabar, RSS-14, Data Matrix, PDF 417, Aztec, MaxiCode.

1 стартмани

31.10.2012    80529    244    shakmaev    84    

Внешняя компонента для ping'а

Разработка внешних компонент v8 1cv8.cf Абонемент ($m)

Внешняя компонента для выполнения ping'а из 1С:Предприятия 8.

1 стартмани

04.07.2018    12204    5    frkbvfnjh    24    

JVM Native API плагин - для запуска в 1С плагинов написанных на Java

Разработка внешних компонент v8 Абонемент ($m)

Запускаем виртуальную машину Java в 1С. Собрана внешняя компонента которая позволяет запускать виртуальную машину java в среде 1С. Позволяет как передавать параметры в java - так и получать уведомление через externalevent. Предпосылкой создания являлся тот факт, что есть много готового функционала которого не хватает в 1С. Язык сpp - довольно сложен для быстрой разработки, и теперь возможно использовать готовые сборки java классов (так называемые jar-файлы) для использования в 1С.

1 стартмани

20.06.2018    14540    36    minimajack    73    

Вызов методов 1С из внешней компоненты, выполненной по технологии COM на C++

Разработка внешних компонент v8 Абонемент ($m)

Пример работы с объектами и методами 1С из внешней компоненты, разработанной по технологии COM на С++.

1 стартмани

04.06.2018    9821    5    le_    1    

Удаленное управление через Skype Промо

Разработка внешних компонент Администрирование данных 1С v8 1cv8.cf Абонемент ($m)

Удаленное управление 1С через Skype. Со стороны клиента для работы нужен только Skype. Со стороны сервера любой компьютер с 1С.

1 стартмани

09.02.2014    46064    68    moolex    29    

Внешняя компонента Native для создания штрих кода (GS1 DataBar Expanded, GS1 DataBar Expanded Stacked и другие)

Разработка внешних компонент v8 1cv8.cf Абонемент ($m)

В связи с внедрением ГИС Меркурий потребовалось внешняя компонента, которая создает штрихкод и отдает 1С. ВК создана на основе библиотеки zint www.sourceforge.net/projects/zint.

1 стартмани

27.04.2018    20693    228    artmaks1988    93    

Работа с любыми сканерами документов в 1С c помощью внешней компоненты от vintasoft.com

Разработка внешних компонент v8 v8::УФ 1cv8.cf Абонемент ($m)

Универсальная обработка для сканирования изображений на любых сканерах (поточных, планшетных) средствами ActiveX от компании Vintasoft.

1 стартмани

29.03.2018    9517    4    Dach    0    

Печать на сервере 1с. DLL для 1С, способная печатать картинки и pdf файлы в серверном контексте (например, при работе веб-сервиса)

Разработка внешних компонент v8 Россия Абонемент ($m)

Не знаю, пригодится кому или нет, писалось для себя, т.к  возникла необходимость печатать на принтере этикеток sscc напрямую с ТСД  через web - сервис. Как известно, веб сервис в 1С работает только в серверном контексте и, к сожалению, разработчики платформы пока не позаботились о возможности вызывать метод  при таких условиях. 

1 стартмани

13.03.2018    11893    34    evgeny43    13    

Внешняя компонента - Запись и воспроизведение .wav файлов. Обработка-иллюстратор. Промо

Разработка внешних компонент v8 1cv8.cf Абонемент ($m)

Обработка иллюстрирует использование внешней компоненты MMLibrary для записи и воспроизведения звуковых wav файлов. Компонента разработана по технологии Native.

1 стартмани

01.03.2014    19433    33    vozhd    7