Альтернативный пересчет упаковок товаров в типовых конфигурациях

Программирование - Практика программирования

упаковки пересчет упаковок

6
Рассмотрен вариант пересчета упаковок, при котором исходное количество товара не изменяется, а происходит пересчет упаковок друг относительно друга.

Введение

В типовых конфигурациях, таких как Управление торговлей 11 или  Комплексная автоматизация 2, для товара можно заводить наборы упаковок, например:

  1. Штука;
  2. Коробка (90 штук);
  3. Паллета (540 штук или 6 коробок);

Такие упаковки удобно использовать при продажах, особенно клиентам, которые могу оперировать как штучным количеством, так и упаковками одного и того же товара. Например, клиент может попросить оформить ему 360 штук товара, а потом подумав сказать, что ему надо еще две коробки. В таком случае удобно, что система перевела количество в коробки и оператор добавил еще две, нежели  пересчитывать коробки в штуки в голове и прибавлять к исходному количеству.

Что происходит в стандартном механизме? Указывая 360 штук и меняя единицу измерения Штука на Коробку, количество остается равным 360 и в строке у нас получается 360 Коробок, в описанном случае такой механизм работы не удобен. В нашем случае надо, чтобы система пересчитала Штуки в Коробки и получилось 360 / 90 = 4 Коробки.

Добиться указанного поведения можно, сделав необходимое расширение конфигурации, однако сделать его так, чтобы не затрагивались формы и при обновлении было минимум проблем, оказалось нетривиальной задачей.

Технические моменты

При изменение колонок табличной части запускается процедура изменения данных, для которой указывается, что необходимо выполнить, например, при изменении количества работает примерно такой код:

ТекущаяСтрока = Элементы.Товары.ТекущиеДанные;
СтруктураДействий = Новый Структура;
СтруктураДействий.Вставить("ПересчитатьКоличествоЕдиниц");
СтруктураДействий.Вставить("ПересчитатьСуммуНДС", СтруктураПересчетаСуммы);
//.....
СтруктураДействий.Вставить("ПересчитатьСуммуСУчетомАвтоматическойСкидки", Новый Структура("Очищать", Истина));
СтруктураДействий.Вставить("ЗаполнитьДубликатыЗависимыхРеквизитов", ЗависимыеРеквизиты());

ОбработкаТабличнойЧастиКлиент.ОбработатьСтрокуТЧ(ТекущаяСтрока, СтруктураДействий, КэшированныеЗначения);

где СтруктураДействий и есть список операций. Нашей точкой для переопределения является операция ПересчитатьКоличествоЕдиниц, процедура, которая обрабатывает этот ключ, находится в модуле ОбработкаТабличнойЧастиКлиентСервер и имеет вид:

Процедура ПересчитатьКоличествоЕдиницВСтрокеТЧ(ТекущаяСтрока, СтруктураДействий, КэшированныеЗначения) Экспорт 

	Перем УпаковкаНоменклатура;
	
	Если СтруктураДействий.Свойство("ПересчитатьКоличествоЕдиниц", УпаковкаНоменклатура) Тогда
		ПараметрыПересчета = НормализоватьПараметрыПересчетаЕдиниц(ТекущаяСтрока, УпаковкаНоменклатура);
		ДанныеУпаковки = ПолучитьКоэффициентУпаковки(ПараметрыПересчета.Упаковка, КэшированныеЗначения, ПараметрыПересчета.Номенклатура);
		Количество = ТекущаяСтрока.КоличествоУпаковок * ДанныеУпаковки.Коэффициент;
		
		Если ДанныеУпаковки.НужноОкруглятьКоличество
			И ПараметрыПересчета.НужноОкруглять Тогда
			ТекущаяСтрока.Количество = Окр(Количество, 0 ,РежимОкругления.Окр15как20);
		Иначе
			ТекущаяСтрока.Количество = Количество;
		КонецЕсли;
		
	КонецЕсли;
	
КонецПроцедуры

Процедура пересчитывает всегда поле Количество, которое скрыто от пользователя, а работает пользователь с полем КоличествоУпаковок, меняя в нем количество, это поле нам и необходимо пересчитать, а поле Количество, которое отвечает за количество в единицах хранения, изменять не надо. Однако пересчитывать надо поле  КоличествоУпаковок, только когда меняется единица измерения. Этот момент удалось определить по операциям в СтруктуреДействий, при изменении упаковки присутствует операция ПересчитатьЦенуЗаУпаковку, которой нет в других случаях.

Расширяем общий модуль ОбработкаТабличнойЧастиКлиентСервер, получаем следующий код:

&Вместо("ПересчитатьКоличествоЕдиницВСтрокеТЧ")
Процедура Расш1_ПересчитатьКоличествоЕдиницВСтрокеТЧ(ТекущаяСтрока, СтруктураДействий, КэшированныеЗначения) Экспорт 

	Перем УпаковкаНоменклатура;
			                                    
	Если СтруктураДействий.Свойство("ПересчитатьКоличествоЕдиниц", УпаковкаНоменклатура) Тогда
		
                // вставка для пересчета упаковок
		Если СтруктураДействий.Свойство("ПересчитатьЦенуЗаУпаковку") Тогда
			
			ПараметрыПересчета = НормализоватьПараметрыПересчетаЕдиниц(ТекущаяСтрока, УпаковкаНоменклатура);
			ДанныеУпаковки = ПолучитьКоэффициентУпаковки(ПараметрыПересчета.Упаковка, КэшированныеЗначения, ПараметрыПересчета.Номенклатура);			
			ТекущаяСтрока.Цена = ТекущаяСтрока.Цена / (ТекущаяСтрока.Количество / ТекущаяСтрока.КоличествоУпаковок) * ДанныеУпаковки.Коэффициент;
			ТекущаяСтрока.КоличествоУпаковок = ТекущаяСтрока.Количество / ДанныеУпаковки.Коэффициент;			

	        // -------------------------------
		Иначе			
			ПараметрыПересчета = НормализоватьПараметрыПересчетаЕдиниц(ТекущаяСтрока, УпаковкаНоменклатура);
			ДанныеУпаковки = ПолучитьКоэффициентУпаковки(ПараметрыПересчета.Упаковка, КэшированныеЗначения, ПараметрыПересчета.Номенклатура);
			Количество = ТекущаяСтрока.КоличествоУпаковок * ДанныеУпаковки.Коэффициент;			
			Если ДанныеУпаковки.НужноОкруглятьКоличество
				И ПараметрыПересчета.НужноОкруглять Тогда
				ТекущаяСтрока.Количество = Окр(Количество, 0 ,РежимОкругления.Окр15как20);
			Иначе
				ТекущаяСтрока.Количество = Количество;
			КонецЕсли;
			
		КонецЕсли;
	КонецЕсли;
	
КонецПроцедуры

В итоге получаем достаточно простую доработку, которую легко поддерживать.

К статье приложено расширение для конфигурации:

  1. 1С:Комплексная автоматизация 2, тестировалось на версии  2.4.5.135, Платформа 8.3.12.1685.
  2. 1С: Управление торговлей 11, тестировалось на версии 11.4.5.32, Платформа 8.3.12.1685.
6

Скачать файлы

Наименование Файл Версия Размер
Переопределение пересчета упаковок
.cfe 5,31Kb
23.11.18
2
.cfe 5,31Kb 2 Скачать

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. CheBurator 3569 26.11.18 04:09 Сейчас в теме
Это все хорошо (сграбил в https://infostart.ru/community/groups/22/publications/)
а вот как "правильно" отработать если количество штук не делится нацело на количество коробок? оперировать менеджеру величинами типа "2целых1десятая коробки" - как-то некузяво... Ваши мысли на этот счет?
2. ifal 248 26.11.18 06:48 Сейчас в теме
(1) общего решения нет, раньше на УТ 10.3, КА 1.1, УПП 1.1 работало также как и это расширение, в новых "управляемых" версиях переделали. Каждая организация решает отдельно и при может еще отталкиваться от вида товара, например, более-менее крупные оптовики только в целых величинах могут отгружать более 1 упаковки, те кто поменьше могут дробить, но скажем, максимум по полам, то есть кратно 0.5. Но по-моему опыту обычно при отгрузке стараются указывать количество в единицах хранения.
3. CheBurator 3569 26.11.18 15:48 Сейчас в теме
Сделайте еще приблуду чтобы модифицировать заказ. У меня такая есть. типа клиент прислал заказ. натравливаем обработку. она показывает возможные варианты подгонки под целые упаковки - кратно блокам/минипакам, кратно мастер-коробкам - с указанием прироста по сумме.

у меян 4 кнокпи типа
- согласиться с вариантом клиента
- предложить тактично
- предложить настойчиво
- предложить в грубой форме.

;-) от выбора пункта зависит степень округления.

продажный отдел вовсб пользуется.
для всякой шушеры которая берет много позиций но мелкими порциями - не применяется.
а клиенты покрупнее - продажи манагеры своих клиентов знают - округляют.
и хотя прайсы выдаются с указанием самой "младшей" упаковки - клиентам как-то похрен, они привыкли считать десятками, а поставки идут кратно дюжине и все от дюжины идет в большую и меньшую сторону. и проще при при заказе 40 штук при 12 в коробке - подогнать в 48 штук.
4. ifal 248 26.11.18 16:06 Сейчас в теме
(3) Хорошее предложение, подумаю.
5. CheBurator 3569 26.11.18 16:15 Сейчас в теме
(4) будет интересно - стукайся, покажу как это у меня выглядит (на 77).
надо еще посмотреть - пользуются ли этим сейчас, раньше активно пользовались. формировался также отчет по "подгонке", который можно было юзверю отправить
Оставьте свое сообщение