Расчет SHA-1 хеша средствами 1С. Битовые операции в 1С или урок двоичной математики

Публикация № 99739

Разработка - Практика программирования

Расчет хеша SHA-1 без использования каких-либо внешних компонет - возможно ли это в 1Cv8? Оказывается вполне возможно!

Я думаю если провести опрос, то многие программисты ответят, что в 1С нет штатных средств для работы с отдельными битами, нет операторов XOR, OR, AND над числами.

Расчет хеша SHA-1 без использования каких-либо внешних компонет - возможно ли это в 1Cv8? Оказывается вполне возможно!

В прикрепленном файле содержится готовая обработка, которая возвращает SHA-1 хеш от указанной строки.

Для понимания как это реализовано на 1с вспомним двоичную систему счисления. В принципе, если представить целое десятичное число в двоичной системе счисления, то как раз получим последовательность бит. Например число 128 в двоичной счисления будет иметь вид 10000000 для 8-битного представления или 00000000000000000000000010000000 для 32-битного, а 129 соответственно 10000001 или 00000000000000000000000010000001.

Т.е. число в десятичной системе = ΣBi·2i, где Bi - бит из двоичного числа, а отсчет битов начинается с нуля. Т.е. для числа 10000001 получаем 128·1+64·0+32·0+16·0+8·0+4·0+2·0+1·1=129

 Для обратного перевода можно пользоваться несколькими способами:

1) Для получения битов начиная со старшего, заканчивая младшим:

Исходное число, например 129, делим на 2^7, если получается больше единицы, то первый бит - 1, иначе 0. Далее Из исходного числа 129 вычитаем 2^7*бит и получаем 129-128*1=1. Далее получаем следующий бит - 1 делим на 2^6, получаем число меньшее единицы, т.е. текущий бит будет равен нулю. Теперь повторем вычитание текущего множителя 2^6 - 1-2^6*0=1. Таким образо дроходим до множителя 2^0 - 1/2^0=1 - т.е. последний бит равен 1.

Число = 129;
Битность = 8;
Биты = "";
Для
й = 1 По Битность Цикл
   
Множитель = pow(2, Битность - й);
   
Бит = Цел(Число / Множитель);
   
Число = Число - Множитель * Бит;
   
Биты = Биты + Бит;
КонецЦикла;
Сообщить(Биты);

2) Для получения битов начиная с младшего до страшего:

Исходное число, например 129, делим оператором % на 2, получаем остаток от деления 1 - это крайний левый бит. Теперь делим нацело 129/2, получаем 64. Далее 64 опять делим оператором % на 2 - получаем следующий бит - 0. Продолжаем так вычислять пока не получим нужные 8 бит.

Число = 129;
Битность = 8;
Биты = "";
Для
й = 1 По Битность Цикл
   
Бит = Число % 2;
   
Число = Цел(Число / 2);
   
Биты = Строка(Бит) + Биты;
КонецЦикла;
Сообщить(Биты);

3) В вышеописаных способах мы изменяем входное число, например 129, но можно вычислять биты не изменяя его. Например старший бит это ЦЕЛ(129/2^7)%2=1, следующий ЦЕЛ(129/2^6)%2=0 и так далее до младшего бита ЦЕЛ(129/2^0)%2=1

Число = 129;
Битность = 32;
Биты = "";
Для
й = 1 По Битность Цикл
   
Бит = Цел(Число / pow(2, Битность - й)) % 2;
   
Биты = Биты + Строка(Бит);
КонецЦикла;
Сообщить(Биты);

Привожу код готовых функций XOR, LR, RR, AND, OR при помощи которых можно вычислить практически любой распространенный хэш

Функция _XOR(Знач A, Знач B, L = 8)
   
R = 0;
    Для
I = 1 по L Цикл
       
M = POW(2, L - I);
       
R = R + M * ?((A < M) = (B < M), 0, 1);
       
A = ?(A < M, A, A - M);
       
B = ?(B < M, B, B - M);
    КонецЦикла;
    Возврат
R;
КонецФункции
 
Функция _LR(Знач A, S, L = 8)
    Возврат
Цел(A / POW(2, L - S)) + POW(2, S) * (A % POW(2, L - S));
КонецФункции

Функция
_RR(Знач A, S, L = 8)
    Возврат
Цел(A / POW(2, S)) + POW(2, S) * (A % POW(2, S));
КонецФункции

Функция
_AND(Знач A, Знач B, L = 8)
   
R = 0;
    Для
I = 1 по L Цикл
       
M = POW(2, L - I);
       
R = R + M * ?((A >= M) AND (B >= M), 1, 0);
       
A = ?(A < M, A, A - M);
       
B = ?(B < M, B, B - M);
    КонецЦикла;
    Возврат
R;
КонецФункции

Функция
_OR(Знач A, Знач B, L = 8)
   
R = 0;
    Для
I = 1 по L Цикл
       
M = POW(2, L - I);
       
R = R + M * ?((A >= M) OR(B >= M), 1, 0);
       
A = ?(A < M, A, A - M);
       
B = ?(B < M, B, B - M);
    КонецЦикла;
    Возврат
R;
КонецФункции

Так же в обработку встроен простой замер производительности, который показывает, что циклы в одну строку показывают заметный прирост только при включенном сеансе отладки :)

Скачать файлы

Наименование Файл Версия Размер
Калькулятор SHA-1 хеша от строки

.epf 10,11Kb
13.03.13
146
.epf 10,11Kb 146 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. AlexO 130 13.03.13 17:34 Сейчас в теме
Антон, вы поразрядно сравниваете числа. По позиции, мантиссе числа.
А не биты.
2. Антон Ширяев 481 13.03.13 17:40 Сейчас в теме
(1)
Чем по сути отличается поразрядное сравнение числа от сравнения битов из которых состоит это число?
3. AlexO 130 13.03.13 17:44 Сейчас в теме
(2) Антон Ширяев,
Вы сравниваете мантиссу чисел, по позиции-разрядности.
А такое работает только там, где байтам поставлено в соответствии какое-либо число (любой системы счисления) - например, с кодировками такое прокатывает, где только числа в качестве кода. А вот реальный двоичный код, где нужно настоящее ПОБИТОВОЕ сравнение - данным методом уже никакого результат не получим.
4. Антон Ширяев 481 13.03.13 17:57 Сейчас в теме
(3) Проблема в том, что нет возможности в 1С8 прочитать двоичный файл побайтово. Можно прочитать только его весь в ДвоичныеДанные. Дальше эти ДвоичныеДанные можно закодировать в BASE64 и уже постепенно раскодируя из BASE64 в числа делать с ними что угодно. Писать обратно опять через то же место :)
5. andrewks 1290 13.03.13 18:00 Сейчас в теме
(4) Антон Ширяев, а почему бы не попробовать читать как unicode? (вот только вопрос, что считается, когда в конце останется один байт, а не два - надо проверять)
7. Антон Ширяев 481 13.03.13 18:15 Сейчас в теме
(5) andrewks,
В обработке как раз идет разбор Unicode-строки на байты и последующее хэширование строки. Кириллица в Unicode занимает от двух байт для основных букв и более (например буква ё).
Если читать бинарные файлы как Unicode думаю ничего хорошего не выйдет, т.к. 100% попадется символ не используемый в Unicode.
Обработку писал давно - больше года назад, нашел время опубликовать только сейчас. В статье не указал как разобрать Unicode-строку на байты, возможно дополню позже.
8. andrewks 1290 13.03.13 20:48 Сейчас в теме
(7) Антон Ширяев,
Кириллица в Unicode занимает от двух байт для основных букв и более (например буква ё)

Вы путаете с UTF-8. Unicode-символ в виде UTF-16LE занимает стабильно 2 байта (хоть английские, хоть русские буквы)
13. Антон Ширяев 481 14.03.13 09:08 Сейчас в теме
(8) andrewks,
Вы путаете с UTF-8. Unicode-символ в виде UTF-16LE занимает стабильно 2 байта (хоть английские, хоть русские буквы)


Для начала заглянем в Википедию.
UTF-8 и UTF-16LE это способы представления Юникода.
Посмотрим пример где используются хеши SHA-1 в 1C - на память приходит пока только хеши паролей пользователей.
Кодируется как раз представление пароля в UTF-8.

Сейчас посмотрел - в списке доступных кодировок в 1С есть UTF-16. Попробую поиграться и отпишусь о результатах.

Действительно все что я писал выше я подразумевал, что Юникод закодирован UTF-8.
35. premierex 17.02.16 08:35 Сейчас в теме
(7) Антон Ширяев, Ildarovich вот в этой публикации "предлагает ограничиться только символами, имеющимися в таблице windows-1251". И даже приводит функцию преобразования. Вполне рабочий вариант.
А идея реализации бинарных операций очень даже неплохая. Только про инверсию забыли, незаслуженно, имхо.
40. MuI_I_Ika 773 27.08.19 15:08 Сейчас в теме
Очень большая просьба к автору разжевать как работает данный цикл. Уже всю голову сломал. Комментариев в описании не хватает.

// Разбираем исходную строку в массив из 16 слов W (1 слово - 32-битное число)
	// Переводим UNICODE номер символа в UTF-8 представление (1 символ может занимать от 1 до 6 байт)
	Для I=1 По СтрДлина(S) Цикл
		
		C=КодСимвола(S,I);
		
		Если C<128 Тогда
			// Если код символа меньше 128, то на выходе получаем один байт N
			N=C;
			G=0;
		Иначе
			// Вычмсляем количество дополнительных байт G для преобразования символов с кодом больше 127
			G=Цел((Log©/Log(2)-6)/5)+1;
			// Вычисляем старшие биты D для первого байта
			D=128;
			Для J=1 По G Цикл
				D=D+pow(2,7-J);
			КонецЦикла;
			M=pow(64,G);
			// Получаем значение первого байта
			N=Цел(C/M)+D;
			// Отрезаем старшие биты от исходного кода символа
			C=C%M;
		КонецЕсли;
		
		Для J=0 По G Цикл
			
			// Записываем байт N в нужное положение слова R
			R=R+pow(256,3-L%4)*N;
			L=L+1;
			Если L%4=0 Тогда
				// Длина сообщения кратна 4 - записываем времееное слово R в массив стов W и обнуляем R
				W[Цел((L-1)%64/4)]=R;
				R=0;
				Если L%64=0 Тогда
					// Длина сообщения достигла 512 бит - выполняем раунд SHA-1
					_SHA1_ROUND(W,H);
				КонецЕсли;
			КонецЕсли;
			Если J=G Тогда
				// Это последня итерация, дальше рассчитывать не нужно
				Прервать;
			КонецЕсли;
			M=pow(64,G-J-1);
			// Получаем значение дополнительного байта
			N=Цел(C/M)+128;
			// Отрезаем старшие биты от текущего кода символа
			C=C%M;
			
		КонецЦикла;
		
	КонецЦикла;
Показать
21. andrewks 1290 14.03.13 14:31 Сейчас в теме
возможно, выгоднее тогда будет заюзать ЧтениеТекста с кодировкой ANSI и посимвольным чтением Прочитать(1)
однако ж здесь тоже таится засада - в 8-ке 1с перекодирует строки в 2-х байтовый Unicode
28. Антон Ширяев 481 18.03.13 10:26 Сейчас в теме
Попробовал прочитать заранее подготовленный файл со всеми двухбайтовыми символами

Текст = Новый ЧтениеТекста("c:\1.bin", КодировкаТекста.UTF16);
Для й = 0 По 65535 Цикл
С = Текст.Прочитать(1);
Если Кодсимвола(С) <> й Тогда
Сообщить("Кодсимвола = " + Кодсимвола(С) + " Й = " + й);
КонецЕсли;
КонецЦикла;
Текст.Закрыть();

Вместо символов "00 D8" - "FF DF", кроме символов "FF DB" и "00 DC" читается символ "FD FF".

Т.е. никак не получается прочитать бинарный файл через ЧтениеТекста...
29. AlexO 130 18.03.13 10:43 Сейчас в теме
(28) Антон Ширяев,
Т.е. никак не получается прочитать бинарный файл через ЧтениеТекста

Так это ЧТЕНИЕ ТЕКСТА :)
А не бинарника. 1С не осилила реализовать "ПрочитатьБинарныйФайлПобайтово".
Да и текст читает эта ЧтениеТекста - сплошной мрак и тормоза. Лучше и быстрее на порядок для чтения текста - использовать FileSystemObject.
6. andrewks 1290 13.03.13 18:03 Сейчас в теме
а если абстрагироваться от кросс-платформенности, то можно привлечь SAPI.spFileStream, например
9. andrewks 1290 13.03.13 20:53 Сейчас в теме
т.к. 100% попадется символ не используемый в Unicode.

вот этого не понял вообще. двухбайтный юникод идёт от 0000 до FFFF. что значит "символ не используемый в Unicode"?
10. Поручик 4434 14.03.13 01:04 Сейчас в теме
Я тоже вброшу. символ не используемый в Unicode. Символ EOF или имеется в виду, что размер файла не будет кратен 2?
11. aet 43 14.03.13 05:00 Сейчас в теме
Мне тоже нравятся всякие математические штуки на 1С ненужные в реальных системах учета, поэтому плюс.
12. yuraos 972 14.03.13 06:28 Сейчас в теме
(11)
Математические штучки, олимпиадные задачки.
Это все хорошо с познавательной точки зрения.
---
Только вот беда...
Для практического применения реализация алгоритмов в коде 1С
не самый лутший вариант с точки зрения производительности.
---
ВК эти же алгоритмы выполняют более эффективнее.
Можно сравнить хотя бы на примере
задачи выгрузки результата запроса ADO
Можно сделать все в коде 1С,
но средствами ВК получается на порядок эффективней
14. Aleksey.Bochkov 3398 14.03.13 09:48 Сейчас в теме
(0) а в 8.3 для вычисления хэша уже сделали полноценные методы встроенного языка
15. AlexO 130 14.03.13 10:00 Сейчас в теме
(14) Aleksey.Bochkov,
а в 8.3

а в 9.0 обещают, что кодить не надо будет совсем :)
27. yuraos 972 14.03.13 17:26 Сейчас в теме
(15)
ага, вся платформа будет "управляемой", конфигуратор - тоже.
в нем останутся одни "ТЫЧИ".
НАЖМИ НА "ТЫЧУ" - И ПОЛУЧИШЬ РЕЗУЛЬТАТ!!!
;)))
16. Антон Ширяев 481 14.03.13 10:11 Сейчас в теме
Итак, попробовал записать в файл все символы средствами 1с

Текст = Новый ЗаписьТекста("c:\t2.txt", КодировкаТекста.UTF16);
Для й = 0 По 65535 Цикл
Текст.Записать(Символ(й));
КонецЦикла;
Текст.Закрыть();

Получил следующие проблемы
1) В начало файла пишется лишний символ - заголовок "FF FE"
2) Вместо символа "0A 00" пишется 2 символа "0A 00 OD 00"
3) Вместо символов "00 D8" - "FF DF", кроме символов "FF DB" и "00 DC" пишется символ "FD FF"

Т.е. через ЗаписьТекста() бинарные файлы писать не получится. Поэкспериментирую еще с чтением.
17. AlexO 130 14.03.13 10:18 Сейчас в теме
(16) Антон Ширяев,
1) В начало файла пишется лишний символ - заголовок "FF FE"

это "стандарт" у 1С (один из многих "стандартов 1С", за соблюдение которых тут ратуют тру-1сники): в любой, даже пустой текстовик - писать перевод каретки в начале. За кой - тайна за семью печатями.
18. Антон Ширяев 481 14.03.13 10:51 Сейчас в теме
(17)
Снова смотрим Википедию :)
1С тут ни при чем, "FF FE" - это заголовок обозначающий что файл закодирован UTF-16LE. Для UTF-8 пишется "EF BB BF"
19. AlexO 130 14.03.13 11:53 Сейчас в теме
(18) Антон Ширяев,
Да, похоже, насчет первых символов - это от кодировок..
а на кой тогда? все равно путаница с кодировками...
24. AlexO 130 14.03.13 15:09 Сейчас в теме
(18) Антон Ширяев,
так ведь эти символы вообще практического никакого влияния и значения не оказывают..
только под ногами "мешаются".
Видимо, 1С - как всегда! - запользовало при разработке платформы некую сторонне-бесплатную (когда 1С что-либо лицензировало у третьих фирм? ну, собственно, и качество отсюда, сама-то ни в дугу, ни в красную армию разработать что-либо...) примочку, которая "на автомате" пихает "лишние" символы в файл.
25. andrewks 1290 14.03.13 16:37 Сейчас в теме
(24) не сказать, чтобы они лишние, просто неплохо было бы предоставить возможность управлять выводом маркеров, чего сделано ими не было
20. andrewks 1290 14.03.13 14:25 Сейчас в теме
(16) Антон Ширяев, да, с BOM в 1С засада - нельзя управлять записью маркера, она его пишет всегда. вот только речь-то была не про запись, а про чтение :-)
однако, видимо, траблы с перекодировкой некоторых служебных символов всё равно будут
22. andrewks 1290 14.03.13 14:33 Сейчас в теме
видимо, извращаться через разбор BASE64 единственный гарантированный способ, если религией запрещены ВК
23. AlexO 130 14.03.13 15:02 Сейчас в теме
Самое интересное - что сама 1С юзает вовсю двоичную запись в платформе, но программистам - ни-ни.
(22) andrewks,
видимо, извращаться

Почему извращаться?! Обычная сериализация нетекствоого содержимого.
через разбор BASE64

Так кто-бы еще сохранил в BASE64, чтобы потом разбирать в 1С....
26. andrewks 1290 14.03.13 16:39 Сейчас в теме
а уж за то, что объект ДвоичныеДанные недоделан, и не позволяет практически ничего с ними делать - я готов был 1соцев укусить, когда писал свою обработку по шифрованию файлов отчётности для ФСРАР
30. LexSeIch 208 20.03.13 05:35 Сейчас в теме
Мир этому дому. Статья заинтересовала - взял на заметку. Автору спасибо.
31. NGPhoenix 8 03.06.14 22:08 Сейчас в теме
Проверил обработку на предмет совпадения пароля пользователя и заявленного хеша. Совпало!!! Значит обработка точно кодирует. Хочу на основе данной обработки попробывать обратный подход (брутфорс). Посмотрим, что получиться.
32. NGPhoenix 8 04.06.14 07:37 Сейчас в теме
Брутфорс SHA1 утомительное дело. Слишком долго. Даже трехзначный пароль за 5 часов полностью не перебрался. Но к работе обработки это дела не имеет.
33. andrushok_7 20.01.15 15:55 Сейчас в теме
Обработка неверно считает хэш по алгоритму SHA-1, проверил на многочисленных онлайн-генераторах
34. Brawler 476 04.02.16 10:56 Сейчас в теме
Скоро, скоро придет мир в этот дом, однако не на 100%
http://v8.1c.ru/o7/201602bin/index.htm
36. premierex 02.03.16 14:31 Сейчас в теме
(0) Раз автор публикации не желает обнародовать функцию инверсии числа, попытаюсь сделать это сам:
Функция _INV(Знач A, L = 32) Экспорт
    Возврат POW(2, L) - 1 - A;
КонецФункции 
37. ildarovich 7117 22.06.16 12:15 Сейчас в теме
Вот в этой статье: Простая и быстрая эмуляция операций с битовыми строками приведен другой способ реализации операций с битовыми строками в языке 1С. Он не требует использования циклов и поэтому гораздо быстрее. По оценкам, сделанным в той статье, если длина битовой строки равна 300 символов, то выигрыш достигает 15-ти раз.
Не знаю, подойдет ли метод из упомянутой статьи для решения этой задачи.
38. renmy 89 17.04.17 15:34 Сейчас в теме
Сдвиг вправо неправильно работает.
Мой вариант:
Функция _RR(Знач A, S)
    Возврат Цел(A / POW(2, S)) + ?(A<0,A % POW(2, S),0);
КонецФункции


И сдвиг вправо с замещением(>>>):
Функция _RRR(Знач A, S)
    Возврат Цел(A / POW(2, S)) * ?(A<0,-1,1);
КонецФункции
39. Mails79 12 26.02.18 23:18 Сейчас в теме
Большое спасибо, для версий платформы ниже 8.3.11 просто незаменимо.
Оставьте свое сообщение

См. также

Вам нравятся запросы в 1С? Промо

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    20413    4    m-rv    86    

Интерактивная справка по объектам 1С (автономное расширение)

Практика программирования Работа с интерфейсом v8 ERP2 Абонемент ($m)

База знаний, подключаемая к объектам основной базы. Ведётся интерактивно, формируется в виде статей прямо в 1С (текст, картинки, таблицы, ссылки). Есть возможность прикрепления файлов, привязки к объектам 1С, возможности рейтинга и комментирования пользователями.

3 стартмани

29.09.2020    5543    25    sapervodichka    30    

Конвейер проверки качества кода

Инструментарий разработчика Практика программирования Математика и алгоритмы v8 1cv8.cf Абонемент ($m)

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    24382    22    Stepa86    45    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    21644    13    RocKeR_13    16    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") Промо

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    30321    86    m-rv    57    

HTTP Сервисы: Путь к своему сервису. Часть 3

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    37063    54    dsdred    15    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    28004    26    informa1555    26    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    47043    17    kalyaka    16    

Заполняем по шаблону (по умолчанию) Промо

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    28169    19    mvxyz    17    

Полезные примеры составления схемы компоновки данных #2

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Еще один набор примеров как решить частные задачи в СКД

1 стартмани

22.05.2018    30673    11    SITR-utyos    13    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    26950    52    kwazi    6    

Паузы при исполнении кода (Sleep для 1С)

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Решил проверить все найденные варианты паузы для 1С. В результате получилась обработка для тестирования и небольшая статья с итогом.

1 стартмани

28.11.2017    44997    12    swimdog    41    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    27618    70    vasvl123    9    

Telegram-боты

Практика программирования v8 Абонемент ($m)

Описание теории, разбор архитектуры и пример реализации telegram-ботов. Сразу скажу, со структурированием изложения мало что могу поделать. :) редакция от 18.07.2018 Правки последней редакции выделены жирным.

1 стартмани

01.09.2017    32344    132    PLAstic    59    

Умный дом на 1С + ардуино

Практика программирования v8 Абонемент ($m)

Конфигурация для автоматизации быта программиста 1C и не только. В данной статье будет рассказано, как можно использовать 1С для задач, не входящих в стандартные рамки этой платформы. Например, управление домом. В качестве периферии для подключения будет использован микроконтроллер (МК) Ардуино, но на нём не будет никакой логической нагрузки, весь процесс будет проходить на сервере 1С. Работа с пинами ввода/вывода происходит напрямую из 1С.

1 стартмани

07.08.2017    22650    21    sasha777666    63    

Генератор штрихкодов

Инструментарий разработчика v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка для формирования штрихкодов средставами 1С без использования внешних компонент.

10 стартмани

07.08.2017    8808    9    renmy    6    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут Промо

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    48018    36    Demanoidos    60    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    128764    13    signum2009    48    

Регулярные выражения – это просто. Построитель и отладчик регулярных выражений

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагается к использованию построитель регулярных выражений. Выполненный в виде внешней обработки, он позволит строить сложно-структурированные выражения на основе параметрического описания, тестировать их, и в результате получить программный код 1С.

1 стартмани

13.03.2017    31295    112    romasna    49    

HMAC на встроенном языке 1С

Защита и шифрование v8 1cv8.cf Россия Абонемент ($m)

Внешняя обработка хеширования данных HMAC (SHA-1, MD5, SHA-256, CRC-32) без использования внешних компонент.

1 стартмани

25.02.2017    26424    74    Knup    36    

Определение кратчайших путей, критических путей одним запросом Промо

Математика и алгоритмы v8 1cv8.cf Абонемент ($m)

Еще два примера применения алгоритма каскадного матричного умножения, впервые описанного в статье «Транзитивное замыкание запросом» http://infostart.ru/public/158512/

1 стартмани

07.04.2014    37613    22    ildarovich    31    

Распознавание текста с помощью нейросетей Google Cloud Vision и 1С

Практика программирования v8 1cv8.cf Абонемент ($m)

Возможности Google Cloud Vision в распознавании текста.

1 стартмани

08.02.2017    28779    124    kiv1c    18    

Графическая схема. Управление при помощи XDTO.

Практика программирования v8 Абонемент ($m)

В статье описывается методика программного управления элементами графической схемы при помощи механизма XDTO. Приложена готовая к использованию библиотека функций для создания и удаления графических объектов, а также для связи элементов схемы соединительными линиями.

2 стартмани

16.01.2017    22124    105    Alxby    23    

Простой редактор плана помещения JavaScript

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

На ресурсе сейчас очень много решений, которые позволяют редактировать карты, используя географические схемы. Так же много решений, которые позволяют редактировать объекты онлайн веб-карт. Мне же нужно было простое решение, для того чтобы расставить квадратные объекты на плане, показать их пользователю. Ну и распечатать, опять же. Я решил написать простенький редактор на JavaScript с использованием библиотеки Raphael.

1 стартмани

23.11.2016    20964    94    igel9780    22    

Быстрое определение интервалов в запросе Промо

Практика программирования v8 Абонемент ($m)

В статье описывается новый метод определения интервалов между данными различных записей в запросе. В отличие от общеизвестного метода, время работы предлагаемого метода зависит от объема данных ЛИНЕЙНО. Это обеспечивает ему значительный выигрыш по быстродействию на больших объемах данных. В качестве иллюстрации возможностей метода приведен отчет, показывающий гистограмму распределения времени между продажами.

1 стартмани

01.10.2015    51340    35    ildarovich    41    

Работа с двоичными данными на примере чтения файлов изображений. Новые возможности 8.3.9

Практика программирования WEB v8 1cv8.cf Россия Абонемент ($m)

В статье приводятся новые функции по работе с двоичными данными, появившимися в версии платформы 8.3.9 , на примере анализа формата и размера изображений. А также пример отправки изображения через API ВКонтакте с помощью новых объектов (без использования ОбъединитьФайлы())

1 стартмани

14.11.2016    25636    16    Anton64    22    

Несколько шаблонов для доработки типовых конфигураций

Практика программирования Инструментарий разработчика v8 v8::УФ Абонемент ($m)

Предлагаю несколько каркасов для создания новых объектов в типовых конфигурациях. Это выжимка из кода нескольких конфигураций, которая позволит быстро и красиво создавать и дорабатывать объекты метаданных с соблюдением идеологии исходной системы

1 стартмани

03.10.2016    36550    95    json    25    

HTTP-сервис: отчеты [Расширение]

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Это HTTP-сервис, который возвращает почти любой отчет в HTML, XLSX или в JSON. Сохраните вариант отчета, получите на него ссылку и можно получить данные без захода в 1С. Работает в конфигурациях на основе БСП 2.3.3+, для отчетов на СКД и в 1С 8.3.8+

2 стартмани

30.08.2016    26680    135    Stepa86    15    

Интеграция 1С + Liqpay средствами 1С

WEB v8 1cv8.cf Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Абонемент ($m)

Возникла необходимость взаимодействовать с сервисом платежей для интернет магазинов https://www.liqpay.com. Для этих целей была написана тестовая обработка, которую и предлагаю вашему вниманию.

1 стартмани

12.08.2016    8351    20    narodukr    6    

Недокументированное использование стандартных форм Upd.

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Вам не хватает возможностей в платформе 1С или у Вас нет времени на углубленное изучение платформы 1С? Рассмотрены возможности использования стандартных форм, вызываемых из платформы.

1 стартмани

26.07.2016    28148    76    ZhokhovM    60    

Хранение файлов в томах на диске (для УПП 1.3)

Практика программирования v8 УПП1 Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    57184    10    wowik    32    

БСП 2.3 и БСП 3.0: Просто про выполнение внешней обработки в фоне (c индикацией прогресса выполнения)

Инструментарий разработчика Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Простое пояснение о том, как сделать внешнюю обработку с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП 2.3.2. UPDATE 20/09/19: добавлен вариант обработки с индикацией процента выполнения и статусом выполнения для БСП 3.0.

1 стартмани

18.05.2016    61175    178    rozer    65    

Остатки на каждый день в запросе

Практика программирования Учет ТМЦ Учет ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    58195    19    arakelyan    18    

Еще один способ расчета остатков на каждый день в запросе

Математика и алгоритмы Практика программирования v8 Абонемент ($m)

Предлагается новый способ расчета остатков на каждый день (час, минуту, секунду) в запросе. Способ не требует предварительного формирования таблицы дат и также подходит для расчета курсов валют, цен номенклатуры и других периодических сведений на каждую дату периода. На больших объемах данных предлагаемый способ может превосходить по быстродействию ранее известные методы из-за линейной (в лучшем случае) зависимости трудоемкости от длины периода.

1 стартмани

24.04.2016    34414    48    ildarovich    23    

Выполнение JavaScript кода из 1С в объекте Поле HTML Документа (HTML 5) и вызов события в 1С ПриНажатии

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример выполнения JS кода из 1С в Поле HTML Документа под управляемыми формами, с удобным получением результата в 1С(С помощью вызова привязанного события ПриНажатии к элементу ПолеHTMLДокумента)

1 стартмани

22.03.2016    80708    158    igo1    54    

Количество дней недели (понедельников/вторников/...) в заданном диапазоне одним запросом

Практика программирования v8 Абонемент ($m)

При реализации периодического авто-заполнения маршрутных листов по графику (недельному) необходимо было просчитать стоимость всего периода, с условием выездов только по определенным дням. Заморачиваться с обходом результата не хотелось. Пришлось написать "Небольшой" запрос.

1 стартмани

03.03.2016    18205    1    Alexander.Shvets    5    

Простые радости жизни программиста 1С: выбор типа значения

Работа с интерфейсом Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    49771    50    yuraos    17    

Отображение прогресса выполнения длительных операций в БСП и их отладка в текущем сеансе.

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

В статье описан способ исполнения длительных операций в конфигурациях, в которых используется библиотека стандартных подсистем, с визуализацией прогресса исполнения и отображения хода обработки данных. Также дается краткое описание процесса отладки длительных операций в текущем сеансе.

1 стартмани

17.02.2016    54739    178    balanton    23    

Яндекс.Деньги "Благотворительность"

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Яндекс.Деньги теперь в 1С. Форма для приема благотворительных взносов. Форму легко сделать и вставить на любую страницу сайта или блога. Платежи будут приходить на ваш кошелек. На форме есть три способа платежа: из кошелька, с банковской карты, с баланса мобильного.

1 стартмани

16.02.2016    23190    8    Tatitutu    5    

Мастер рассылки e-mail 2.2 для управляемых форм

Практика программирования Email v8 v8::УФ ERP2 БП3.0 УТ11 Абонемент ($m)

Для пользователей: переделанный из старый разработки под 8.2 с использованием библиотеки Мастер рассылки e-mail 2.2 (ERP, УТ, БП) (Только управляемые формы), который теперь может запускаться под любой версией платформы с разрешенными или запрещенными модальными/синхронными вызовами в конфигурации. Также удобный выбор e-mail и их владельцев с помощью отбора динамического списка по любым критериям и галочки исключения.

1 стартмани

29.12.2015    36977    20    milkers    4    

Передача больших пакетов через веб-сервисы

Практика программирования Администрирование данных 1С Внешние источники данных v8 Абонемент ($m)

Реализация механизма передачи больших пакетов через веб-сервисы. С его помощью передать файл размером в несколько гигабайт не составит проблем.

1 стартмани

06.12.2015    56695    48    YPermitin    19    

Пример связи 1С и мессенджера Telegram. Получение данных из 1С запросом из Telegram

Практика программирования Внешние источники данных v8 1cv8.cf Абонемент ($m)

В результате чтения публикации Вы получите готовую внешнюю обработку, позволяющую получать из 1С данные, запрашиваемые через Telegram. В данной статье рассмотрим следующее: Использование HTTPСоединение; Чтение JSON для версии 1С 8.3.6 и выше, а также аналог JSON для версии 1С ниже 8.3.6; Подключение обработчика ожидания; Некоторые основные возможности API Telegram; Как создать бота для Telegram; Программное создание колонок дерева на управляемой форме;

1 стартмани

19.11.2015    92535    458    Luchik    205