gifts2017

"WebCam" - ActiveX-компонента для 1С

Опубликовал Василий Демидов (Душелов) в раздел Программирование - Внешние компоненты

Компонента работает с устройствами, поддерживающими Twain32 драйвер (вебкамеры, фотоаппараты и др.)

*** Для работы компоненты потребуется установленный Microsoft .NET Framework 2.0, который можно скачать отсюда.
http://www.microsoft.com/downloads/details.aspx?displaylang=ru&FamilyID=0856eacb-4362-4b0d-8edd-aab15c5e04f5

Чтобы зарегистрировать компоненту в Windows - запустить reg.bat
(для удаления информации о компоненте в Windows - запустить unreg.bat)
или использовать совместно с хранилищем внешних компонент: http://infostart.ru/projects/2863/

*** Приложены демо-примеры для 1С 7.7 и 8.1

*** Добавление на форму 1С:

v7: Использовать 1С++:

Перем Вебкамера;

Процедура ПослеОткрытия()
    Вебкамера = СоздатьОбъект("АктивИкс"); 
    Вебкамера.УстановитьАтрибут(Форма, "АктХ"); 
    //"АктХ" - идентификатор элемента диалога, на месте которого будет создан элемент ActiveX.
    //только для реквизитов диалога типа "Текст".
    Вебкамера.СоздатьЭУ("Душелов.WebCam"); 
    Вебкамера.УстановитьФокус();
КонецПроцедуры

Процедура АктХ_ПослеСохраненияКартинки(Файл)
    Сообщить(Файл);  
КонецПроцедуры

v8: Меню "Форма" - "Вставить ActiveX..." - Выбрать элемент "Душелов.WebCam"

*** Методы:

  • Запустить видео:
    Старт();

  • ОСТАНОВИТЬ ВИДЕО:
    Стоп();

  • ПОЛУЧИТЬ КАРТИНКУ
    СохранитьКартинку(Файл, Текст);

*** События:

  • ПослеСохраненияКартинки(Файл);

Скачать файлы

Наименование Файл Версия Размер
- 628
.1235035799 220,83Kb
25.09.09
628
.1235035799 220,83Kb Бесплатно

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Василий Демидов (Душелов) 28.09.08 15:19
Ах да, требуется директ-икс, не ниже 8.1
2. Андрей Скляров (coder1cv8) 28.09.08 18:34
3. Сhe Burashka (CheBurator) 28.09.08 19:44
4. artem666 Bogomaz (artem666) 28.09.08 23:54
На сколько помню вебкамеру можно подхатить через COM... но все равно клево!
5. Сергей Лунев (luns) 30.09.08 09:59
Прикольно. Фотки в базу добавлять..
6. Максим Костюкевич (MaxiSoft) 30.09.08 12:25
Супер как можно получить добро на использование компоненты в своей разработке, довольно удобно вводить фотографий клиентов в базу, достаточно просто подключить камеру и сделать снимок! Большой респект за разработку.!!!
cmax; sCHTASS; +2 Ответить 1
7. Василий Демидов (Душелов) 30.09.08 12:58
(6) все мои разработки можно использовать в своих разработках. можно где-нить в коде в комменте меня упомянуть и все :)
8. gavril (gavril) 30.09.08 15:31
Зачет.
Так же новый товар можно добавлять ;)
9. Дуб (Дуб) 01.10.08 09:10
А видео оно показывает? В своё время прикручивал систему ввода в БД фотографий пользователей. Прикрутил, работает, но в режиме видео не пашет. Т.е. чтобы "прицелиться", использую отдельную программку (запускается из 1С, но как Active-X не прикрутить её никак), а потом уже перехватываю камеру ВК и ловлю снимок..
10. Василий Демидов (Душелов) 01.10.08 09:13
(9) Пример советую посмотреть. Видео в левом окошке, скриншот полученный - в правом.
11. alexpa (alexpa2005) 01.10.08 19:11
Что-то не скачивается. :(( Может, ссылку удалили, или с сервером проблемы. Пишет - "не удается загрузить download.php". Попробую завтра. А плюсик ставлю сегодня!!!
12. Евгений Кабанов (kabanoff) 02.10.08 11:52
Молодца! Интересная разработка.
13. Дуб (Дуб) 02.10.08 14:42
(10) посмотрел. Прикольно. Но через раз выдаёт "Не удалось настроить графические параметры. Значение не попадает в ожидаемый диапазон". В принципе, если 1С (Предприятие) перезапустить - то запускается.
В целом - мне понравилось. Тем более, что до этого искал - ничего похожего не находил.
14. Константин (Fisherru) 02.10.08 15:16
Наверное, возможно такое прикрутить к ЧеБурашкиной "[КОНТРОЛЬ] Охрана 1.0 - пропускной пункт"
Она бы тогда ещё и сотояние сотрудников на вползании/выползании фиксировала. :)))))
15. Дмитрий Васильев (pioneex) 03.10.08 11:40
Интересно! Вопрос: как мне добавить в произвольной форме элемент управления "Душелов.WebCam", кроме копирования с демо примера?
16. Евгений Мартыненков (JohnyDeath) 03.10.08 12:08
(15) наверное так: v8: Меню "Форма" - "Вставить ActiveX..." - Выбрать элемент "Душелов.WebCam"
17. Дмитрий Васильев (pioneex) 03.10.08 13:11
Спасибо. Всё получилось!
18. Дмитрий Васильев (pioneex) 03.10.08 16:47
Всё хорошо, но второй раз в одной сессии v8 открыть не получается...
19. Сергей (seermak) 02.11.08 14:41
я тоже уже прикрутил обработку в программу - а ошибку (18) нельзя никак исправить?!
20. Василий Демидов (Душелов) 05.11.08 09:44
Я посмотрю, почему второй раз нельзя открыть, видимо придется добавить команду очистки буфера и отключения от девайсов, и вызывать ее при закрытии обработки.
21. Василий Демидов (Душелов) 08.11.08 16:04
(18) Ошибку воспроизвести не удалось. При закрытии формы точно вызываете команду Стоп(); ?
22. Сергей (seermak) 08.11.08 16:17
Процедура ПередЗакрытием(Отказ, СтандартнаяОбработка)
Если НЕ ВебКамера = Неопределено Тогда
ВебКамера.Стоп();
КонецЕсли;
КонецПроцедуры
(21) - из программы
23. Василий Демидов (Душелов) 08.11.08 16:26
А мой пример как отрабатывает?
24. Сергей (seermak) 08.11.08 16:42
(23) специально еще раз поставил - одинаково Картинку выложил: http://infostart.ru/projects/2817/ рис 4 - тоже самое и на Вашей обработке
25. Василий Демидов (Душелов) 08.11.08 22:43
(24) Давай конфигурацию, посмотрю ;)
26. Сергей (seermak) 09.11.08 07:20
(25) обработка на : http://infostart.ru/projects/2817/ - еще заметил что после закрытия обработки камера остается подключенной и больше ни на какие программы работы с камерой не реагирует, отключается только тогда, когда закрываешь сессию. я на viste, но (по комментариям) проблема не в ней. Дрова: Sonix / 24.04.2007 / 5.7.28.500 /Acer Crystal Eye webcam
27. Василий Демидов (Душелов) 09.11.08 12:13
(26) Скачал, посмотрю. А мой детектор движений как с камерой твоей работает? Там технология другая используется.
28. Василий Демидов (Душелов) 09.11.08 12:23
(26) Твоя обработка у меня нормально работает, закрыл, открыл, заново запустил - все ок.
Ладно, попробую пошаманить в "Остановить()"...
29. Сергей (seermak) 09.11.08 13:58
(27) ага, во всяком случае, закрывается и стартует без ошибок.
30. Василий Демидов (Душелов) 13.11.08 13:12
(29) Попробуйте теперь, и тест камеры тоже. Как это работает? (в тесте камера запускается 2 кнопкой слева, останавливается 3-ей)
31. Сергей (seermak) 13.11.08 18:25
(30) по TestCam - по 2 кнопке - подключается +, по 3 - выключается, но только изображение с камеры, сама же камера остается включенной (сигнализирует светодиод возле камеры) Камера полностью отрубается только тогда, когда "положу" Form1. Ну и, соответственно, пример демо работает также. Ладно, Василь, видать так мой бук работает. :-( (Хотя детектор движения работает же нормально - а нельзя никак туда слить нужные функции?). У меня в конторе еще пока не купили камеру, (может на их камере пойдет без затыков) так что время терпит. Все равно, большое спасибо!
32. Gens76 (Gens76) 29.12.08 23:21
33. arjuna (arjuna) 07.01.09 03:14
Реально ли сделать просмотр видео из файла???
34. Василий Демидов (Душелов) 07.01.09 03:20
(33) Берем АктивХ Windows Media Player и вперед.
36. dmam 11.02.09 10:13
У меня тоже выскакивает ошибка при повторном открытии обработки и запуске.
Сделал то-же самое с помощью wiaaut.dll:

Перем ВебКамера;

Процедура ПослеОткрытия()
ВебКамера = СоздатьОбъект("АктивИкс");
ВебКамера.УстановитьАтрибут(Форма, "АктХ");
ВебКамера.СоздатьЭУ("WIA.VideoPreview");
КонецПроцедуры
//******************
Процедура ПолучитьКартинку()

Item = ВебКамера.Объект.Device.ExecuteCommand("{AF933CAC-ACAD-11D2-A093-00C04F72DC3C}");
Image = Item.Transfer("{557CF401-1A04-11D3-9A73-0000F81EF32E}");
Если ФС.СуществуетФайл("C:\WebCam.jpg") = 1 Тогда
ФС.УдалитьФайл("C:\WebCam.jpg");
КонецЕсли;
Image.SaveFile("C:\WebCam.jpg");
КартинкаКамеры.Загрузить("C:\WebCam.jpg");

КонецПроцедуры
37. Василий Демидов (Душелов) 13.02.09 19:36
Для получения демо-версии или покупки обращайтесь по контактам, указанным в профиле.
38. Владимир (Martyn) 01.04.09 11:54
Плюс ставлю чичас - смотрю потом! Долго искал нечто подобное.... Автору БОЛЬШОЙ респект!
39. ev-kov (ev-kov) 17.04.09 20:20
Компонента WIA не использует случаем ?
40. Василий Демидов (Душелов) 18.04.09 11:24
41. ev-kov (ev-kov) 18.04.09 11:55
Душелов

WIA это Microsoft® Windows® Image Acquisition (WIA) Automation Library version 2.0

какая то ошибочка есть в ВК скрин ошибки(http://slil.ru/27461401). на тестовом примере и ловится, после того как получили картинку и закрыли форму обработки в 1с, открываем по новой обработку, жмем старт, в появившемся активиксе выбираем параметры потока, нажимаем ОК и дальше не работает ничего - ошибка.

Хотелось бы ускорить отладку ошибки, плюс есть некоторые вопросы, не бесплатно, можно обсудить в асе (62-387-523).
42. Василий Демидов (Душелов) 18.04.09 11:58
Эту компоненту я более не развиваю.
43. ev-kov (ev-kov) 18.04.09 12:47
(42) очень жаль, а как насчет исходников ?
44. Василий Демидов (Душелов) 19.04.09 00:31
(43) Исходники не распространяю.
45. Дмитрий (Skobelev) 02.06.09 09:46
Классно, хочу прикрутить к системе пропусков
46. Jelena Rjabaja (Jejer) 20.06.09 01:30
Супер, спа.
А можно сделать, чтобы при старте каждый раз не появлялось окно Properties?
pashoid; yurir; +2 Ответить
47. Шевелев Дмитрий (CAIN) 06.08.09 16:42
У меня при запуске выдал ошибку: "не удалось нгастроить графические параметры"
48. Александр Медведев (anig99) 28.03.10 04:10
Такая же фигня что и у многих с повторным стартом после остановки. Пробовал на ноуте со встроенной камерой на XP. Если выбирать прямой драйвер к камере, то повторно запустить не получается. Если же выбирать virtual driver (ноут asus поставляется с утилитами, в т.ч. и драйвером для пост-обработки), то стартует заново нормально.
49. dushelov (Душелов) 28.03.10 21:32
50. Александр Медведев (anig99) 29.03.10 07:58
(49) но это не значит, что другие ими не пользуются и не читают комменты?
51. mirco brons (mirco) 30.11.10 21:23
А под 8.2 существует способ использовать компоненту ?
52. Василий Демидов (Душелов) 01.12.10 07:03
(51) Управляемые формы? Читайте мою статью.
53. Ruslan (rus_2403) 03.12.10 11:00
Компонента работает в демо-режиме или нет.Если да то в чем он выражается.Спасибо
54. Евгений (Lokky) 15.01.11 05:20
Автору БОЛЬШУЩЕЕ СПАСИБО!!
Только вопрос.. А можно ли как-нибудь при старт() чтоб она запускалась не спрашивая настройки камеры?
55. Yevgen Yuschenko (yus12) 13.10.11 16:54
А скажите пожалуйста а в 8.2 упр. приложении будет работать?
56. Yevgen Yuschenko (yus12) 13.10.11 21:20
57. Алексей Горнеев (gorneev) 12.11.11 18:25
Огромное спасибо автору, на управляемом приложении работает.
58. Саргей Максимов (ronron) 24.11.11 22:48
Автору спасибо и уважуха! Если заработаю на этом деньжат (что сделать постараюсь) - приду поделиться.
60. Дмитрий Фамилия (freek) 28.12.11 14:06
На основе данной компоненты сделали конфу по учету рабочего времени сотрудников
61. Сергей Писларь (serpisal) 10.03.12 15:32
62. Михаил Гомбоев (yoyoman) 04.04.12 05:08
Я был бы несказано рад, если бы можно было отключить появление настроек :(
63. Npoen Dzogchen (Dansur) 18.10.12 11:01
(62) yoyoman, Автора уже нет в живых. светлая память.
64. Евгений Рачковский (eugen91) 04.01.13 13:18
Супер, работает! Спасибо большое! тестировали на УТ 10.3
65. Алексей Трошкин (Alex_241) 04.01.13 13:50
Добрый день, а откуда можно скачать вашу разработку желательно с описанием и примером, хотел потестировать. Заранее благодарен)))
66. Виталий Барилко (Diversus) 01.08.13 14:11
Внешняя компонента аналогичной направленности, только Native API для 1С 8.2 и 8.3: Внешняя компонента MediaBuild (создание фото и видео с веб-камер и IP-камер) для 1С:Предприятие 8.2, 8.3 (NativeAPI).
Умеет:
- делать фото с пред просмотром и без него
- снимать видео
- делать скриншоты
- поддерживает работу с веб-камерами и IP-камерами
- поддерживает наложение на видео дополнительного текста
67. Семён Павлюков (7OH) 21.10.13 12:34
Спасибо за компоненту - локально работает на 5+.
Кто подскажет, можно ли и как сделать работу через RDP-APP ?
68. Семён Павлюков (7OH) 27.12.13 16:56
А не поможете с проблемой ?
Создал ПолеHtmlДокумента на форме (толстый клиент пока - для отладки).
Далее
ЭлементыФормы.Актив.УстановитьТекст("<HT ML><body><OB JECT id=vk classid=CLSID:2F29718C-BA95-3F0D-A1E5-F75CBF88285D width=""100%"" height=""100%""></OBJECT></body></HTML>");

На форме сначала запрос на разрешение использования ActiveX - потом появляется черное окно.
Но при попытке доступа к свойствам
ЭлементВК = ЭлементыФормы.Актив.Документ.getElementById("vk");
	Если ЭлементВК = Неопределено Тогда
		Сообщить("Не найден объект компоненты!");
		Возврат;
	КонецЕсли;
...Показать Скрыть

виснет и всё.
Если уираю проверку и делаю стразу Старт() - тоже виснет.
Похоже не может показать запрос окна свойств камеры.
69. Александр (Иной) 23.04.14 00:24
А получать изображение с камер к которым доступ по IP никто не пробовал?
70. zsergey_ (zsergey_) 14.12.15 20:04
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа