gifts2017

Интернет-информеры в 1С 8.1

Опубликовал Сергей Начина (serg_gres) в раздел Программирование - Практика программирования

Обработка, которая выводит в форму интернет-информеры. Например  курсы валют, погоду, анекдоты и пр. Сам интернет информер создается в справочнике "ИнтернетИнформеры" с реквизитами "ТекстHTML,ВысотаПоля,Кодировка" (см. модуль формы элемента в справочнике). Порядок вывода информеров и какие из них выводить сохраняется в отдельные рег. сведений "ДополнительныеНастройки" (конфигурация самописная - лучше адаптируйте под свою)

Скачать файлы

Наименование Файл Версия Размер
- 74
.epf 10,28Kb
28.10.09
74
.epf 10,28Kb Скачать
- 26
.nduvrftollqemusujxzlszhgcrzljbexfytwdmlpxbtkwle 2,39Kb
28.10.09
26
.nduvrftollqemusujxzlszhgcrzljbexfytwdmlpxbtkwle 2,39Kb Скачать
все в одном архиве 181
.zip 7,83Kb
28.10.09
181
.zip 7,83Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. serg__k (serg__k) 28.10.09 12:50
объедини, пожалуйста, все в один архив
2. Сергей Начина (serg_gres) 28.10.09 17:00
Большая часть моих информеров - с сайта www.epwr.ru.
3. Андрей Янакаев (YAN) 28.10.09 18:37
(0) а зачем справочник! Ведь можно без внесения изменений в конфу, достаточно обойтись табличной частью в которую и добавлять "информеры", хранить можно тч в любой конфе штатными средствами, ну и на всякий случай можно сделать экспорт/импорт настроек обработки.
4. Rusk (Rusk51) 29.10.09 10:18
Кто такая Яна Джангирова?
5. Яков Коган (Yashazz) 29.10.09 17:58
Внешними обработками надыть.

Прикольно, хотя попытка сгрести всё в одну кучу мне кажется не самым оригинальным ходом.

Времени смотреть нету, потому спрошу: чем сделано-то? DOM-модель парсится?
6. Сергей Начина (serg_gres) 29.10.09 21:54
(5) я вообще таких умных слов не знаю
7. Олег Каратаев (Kyrales) 30.10.09 07:35
Хорошая идейка с информерами
8. Александр (Sanek) 05.11.09 08:05
Вот бы к 7.7 такую штуку .......
9. Сергей Начина (serg_gres) 20.11.09 16:50
Процедура СохранитьДополнительнуюНастройку(ИмяНастройки,Значение) Экспорт
Запись = РегистрыСведений.ДополнительныеНастройки.СоздатьМенеджерЗаписи();
Запись.Измерение = ИмяНастройки;
Запись.Ресурс = Значение;
Запись.Записать();
КонецПроцедуры

Функция ЗагрузитьДополнительнуюНастройку(ИмяНастройки) Экспорт

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ДополнительныеНастройки.Измерение,
| ДополнительныеНастройки.Ресурс
|ИЗ
| РегистрСведений.ДополнительныеНастройки КАК ДополнительныеНастройки
|ГДЕ
| ДополнительныеНастройки.Измерение = &Измерение";

Запрос.УстановитьПараметр("Измерение",ИмяНастройки);

Результат = Запрос.Выполнить().Выгрузить();

Значение = ЗначениеВСтрокуВнутр("");
Если Результат.Количество()>0 тогда
Значение = Результат[0].Ресурс;
КонецЕсли;

Возврат(Значение);

КонецФункции
10. Дмитрий Сарычев (pers) 08.02.10 00:09
Идея помогла, спасибо. Только вот не могу разобраться, как избавиться от боковой полосы прокрутки. У тебя на первом и втором информере их нет, на четвертом -есть. Не могу вкурить - почему?
11. solarlion (solarlion) 08.11.11 16:07
идея хорошая, помогла в одной задаче
12. Smoke221180 Smoke221180 (Smoke221180) 14.12.11 17:59
Взяв за основу, сделал себе пару виджетов)
13. Сергей Начина (serg_gres) 14.12.11 18:12
14. Дандронтий Крузенштерн (dandrontiy) 19.01.12 09:22
Мне понравилась идея. Удобно, функционально.
Я бы еще предложил добавить функционал сохранения новостей с возможностью поиска потом.