gifts2017

Завершение работы пользователей. Файловый и клиент-серверный вариант. Без доработки конфигураций.

Опубликовал Damian (Damian) в раздел Администрирование - Защита, права, пароли

Обработка позволяет отключить сеансы всех пользователей, подключенных к базе данных. При этом обеспечивается возможность быстрого входа в заблокированную базу.

Данная обработка похожа на типовую "Блокировка установки соединений с информационной базой", но имеет некоторые существенные отличия:

1. Отображение списка активных пользователей

2. Возможность создать ярлык на рабочем столе для запуска информационной базы с кодом разрешения

При выполнении команды "Установить блокировку" будут отключены все сеансы, в том числе и тот, из которого вы запустили обработку. Однако, у вас есть возможность при установке блокировки заблаговременно создать на своем Рабочем столе ярлык, при помощи которого вы можете войти в заблокированную базу. Иными словами, вам не придется мучаться, прописывая в свойствах ярлыка необходмые параметры запуска.

Есть, конечно, и некоторые минусы. Например, обработка не выкинет пользователей, у которых открыто модальное окно типа предупреждения "Документ не проведен". Вопросы типа "Объект изменен. Сохранить изменения?" игнорируются и сеанс пользователя завершается без сохранения данных.

Также, обработка будет корректно работать только в тех конфигурациях, которые при старте сеанса пользователя подключают обработчик ожидания с проверкой блокировок соединений. Как правило, все типовые конфигурации содержат данный функционал. Для самописных конфигураций придется его предварительно реализовать.

Было бы, конечно, весьма полезно прикрутить сюда и отправку сообщений пользователям, но вариантов реализации данного действа средствами 1С без использования "Регистр сведений+ОбработчикОжидания" нигде найти не удалось. Так что, пока так.

Основная задача стояла так, чтобы выкидывать пользователей в любых конфигурациях без их модификации. Вроде что-то получилось :)

PS. Реализована возможность выбирать сообщение пользователям из шаблонов, причем в шаблон будет подставлено время окончания блокировки. Только вот редактировать эти  шаблоны придется в Конфигураторе, в модуле формы, а именно - в процедуре "КнопкаИзШаблонаНажатие(Элемент)". Писать какой-либо другой механизм для их хранения лень.

 

Update от 14.09.2011

Благодаря пользователям cbr900 и 7OH, предоставивших свои алгоритмы создания ярлыка для клиент-серверного варианта, реализован и этот режим.

Также устранена ошибка, указанная пользователем tezin, заключавшаяся в том, что при создании ярлыка вылетала ошибка о невозможности присвоить значение переменной "РабочийСтол".

Теперь о нюансах.

В клиент-серверном варианте работы обработка работает корректно, создает правильный ярлык, НО возможна ситуация, что после запуска базы в режиме Конфигуратора с кодом разрешения не удается запустить отладку, т.к. база остается заблокированной. При этом, если отдельно запустить базу с кодом разрешения, то все нормально. С чем это связано пока не разобрался.

PS. Если в клиент-серверном варианте воспользоваться типовой обработкой, то результат - тот же: из Конфигуратора не запускается отладка.

 

Update от 05.10.2011

Реализована управляемая форма обработки, а также учтены замечания пользователей maxx и r0610201.

 

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Отключение пользователей
.epf 20,96Kb
06.10.11
2265
.epf 20,96Kb 2265 Скачать

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение

Комментарии

1. cbr900 (cbr900) 14.09.11 05:28
Хорошая штука! Главное, что механизм работает.
Для клиент-серверного варианта также хотелось быт увидеть))
2. cbr900 (cbr900) 14.09.11 07:37
Измени модуль документа для обработки создания ярлыка для клиент-серверного варианта.
В строке
строкаРабочийСтол = WShell.SpecialFolders().Item("Desktop");
Переменная РабочийСтол заменена строкаРабочийСтол, т.к. РабочийСтол определяет цвет рабочего стола и использовать для записи нелья

Код
 //Получить представление информационной базы для отображения пользователю.
// Пример возвращаемого результата:
// - для ИБ в файлом режиме: \\FileServer\1c_ib\
// - для ИБ в серверном режиме: ServerName:1111 / information_base_name
Функция ПолучитьПредставлениеИнформационнойБазы(ЭтоФайловаяИБ, СтрокаСоединенияИнформационнойБазы, ИмяИБНаСервере) Экспорт
   
   Если ПустаяСтрока(СтрокаСоединенияИнформационнойБазы) Тогда
      СтрокаСоединенияИнформационнойБазы =  СтрокаСоединенияИнформационнойБазы();
   КонецЕсли;
   
   ЭтоФайловаяИБ = Найти(Врег(СтрокаСоединенияИнформационнойБазы), "FILE=") = 1;
   
   Если ЭтоФайловаяИБ Тогда
      ПутьКБД = Сред(СтрокаСоединенияИнформационнойБазы, 7, СтрДлина(СтрокаСоединенияИнформационнойБазы) - 8);
   Иначе
      // надо к имени сервера прибавить имя пути информационной базы
      ПозицияПоиска = Найти(Врег(СтрокаСоединенияИнформационнойБазы), "SRVR=");
      
      Если ПозицияПоиска <> 1 Тогда
         Возврат Неопределено;
      КонецЕсли;
      
      ПозицияТочкиСЗапятой = Найти(СтрокаСоединенияИнформационнойБазы, ";");
      НачальнаяПозицияКопирования = 6 + 1;
      КонечнаяПозицияКопирования = ПозицияТочкиСЗапятой - 2; 
      
      ИмяСервера = Сред(СтрокаСоединенияИнформационнойБазы, НачальнаяПозицияКопирования, КонечнаяПозицияКопирования - НачальнаяПозицияКопирования + 1);
      
      СтрокаСоединенияИнформационнойБазы = Сред(СтрокаСоединенияИнформационнойБазы, ПозицияТочкиСЗапятой + 1);
      
      // позиция имени сервера
      ПозицияПоиска = Найти(Врег(СтрокаСоединенияИнформационнойБазы), "REF=");
      
      Если ПозицияПоиска <> 1 Тогда
         Возврат Неопределено;
      КонецЕсли;
                        
      НачальнаяПозицияКопирования = 6;
      ПозицияТочкиСЗапятой = Найти(СтрокаСоединенияИнформационнойБазы, ";");
      КонечнаяПозицияКопирования = ПозицияТочкиСЗапятой - 2; 
      
      ИмяИБНаСервере = Сред(СтрокаСоединенияИнформационнойБазы, НачальнаяПозицияКопирования, КонечнаяПозицияКопирования - НачальнаяПозицияКопирования + 1);
      
      ПутьКБД = ИмяСервера + "/ " + ИмяИБНаСервере;
   КонецЕсли;
   
   Возврат ПутьКБД;
   
КонецФункции    

Процедура СоздатьЯрлык() Экспорт
   
   Кавычка = Символ(34);
   
   // COM-объекты
   Shell = Новый COMОбъект("Shell.Explorer");
   WShell=Новый COMОбъект("WScript.Shell");
   
   // определим необходимые переменные
   ИсполняемыйФайл = Shell.FullName();
   строкаРабочийСтол = WShell.SpecialFolders().Item("Desktop");
   
   ЭтоФайловаяИБ = Ложь;
   ИмяИБНаСервере = "Текущая";
   ПредставлениеПутиИБ = ПолучитьПредставлениеИнформационнойБазы(ЭтоФайловаяИБ, СтрокаСоединенияИнформационнойБазы(), ИмяИБНаСервере);
   //ПредставлениеПутиИБ = СтрокаСоединенияИнформационнойБазы();
   //ПредставлениеПутиИБ = СтрЗаменить(ПредставлениеПутиИБ,"File=","");
   //ПредставлениеПутиИБ = СтрЗаменить(ПредставлениеПутиИБ,";","");
   //ПредставлениеПутиИБ = СтрЗаменить(ПредставлениеПутиИБ,Кавычка,"");
   Если ЭтоФайловаяИБ Тогда 
      Путь = СтрЗаменить(ПредставлениеПутиИБ,"","-");
      Путь = СтрЗаменить(Путь,":","");
      Путь = СтрЗаменить(Путь," ","");
      Путь = СтрЗаменить(Путь,".","");
         
      ИмяЯрлыка = строкаРабочийСтол + "" + Путь + ".lnk";
      Аргументы = " /CONFIG /F" + Кавычка + ПредставлениеПутиИБ + Кавычка + " /UC" + КодРазрешения;
   Иначе
      
      ИмяЯрлыка = строкаРабочийСтол + "" + ИмяИБНаСервере + ".lnk";
      Аргументы = " /CONFIG /S" + Кавычка + ПредставлениеПутиИБ + Кавычка + " /UC" + КодРазрешения;
      
   КонецЕсли;
   
   oShellLink = WShell.CreateShortcut(ИмяЯрлыка); 
   oShellLink.TargetPath = ИсполняемыйФайл;
   oShellLink.Arguments = Аргументы;
   oShellLink.WindowStyle = 1;
   oShellLink.WorkingDirectory = ""; 
   oShellLink.Save();   
   
КонецПроцедуры
Показать полностью
3. tezin Тезин (tezin) 14.09.11 14:38
Создание ярлыка вылетает с ошибкой

{ВнешняяОбработка.ОтключениеПользователей.МодульОбъекта(79)}: Поле объекта недоступно для записи (РабочийСтол)
РабочийСтол = WShell.SpecialFolders().Item("Desktop");
4. Семён Павлюков (7OH) 14.09.11 14:48
1. При открытии и после выполнения надо проверять, что блокировка есть.
Да и на блокировку надо ровняться а не на галочку про пользователей.

2. Вариант файл-серверного ярлыка
КаталогБазы = СтрокаСоединенияИнформационнойБазы();
	флФайловый=Истина;
	Если Найти(КаталогБазы,"File=")=0 Тогда
		флФайловый=Ложь;
	КонецЕсли;
	
	Если флФайловый Тогда
		КаталогБазы = СтрЗаменить(КаталогБазы,"File=","");
	Иначе
		КаталогБазы = СтрЗаменить(КаталогБазы,"Srvr=","");
		КаталогБазы = СтрЗаменить(КаталогБазы,"Ref=","/");
	КонецЕсли;
	
	КаталогБазы = СтрЗаменить(КаталогБазы,";","");
	КаталогБазы = СтрЗаменить(КаталогБазы,Кавычка,"");
		
	Путь = СтрЗаменить(КаталогБазы,"\","-");
	Путь = СтрЗаменить(КаталогБазы,"/","-");
	Путь = СтрЗаменить(Путь,":","");
	Путь = СтрЗаменить(Путь," ","");
	Путь = СтрЗаменить(Путь,".","");
		
	ИмяЯрлыка = РабочийСтол + "\" + Путь + ".lnk";
	
	Аргументы = " CONFIG "+?(флФайловый,"/F","/S") + Кавычка + КаталогБазы + Кавычка + " /uc" + КодРазрешения;
...Показать Скрыть

Немного проще и перед CONFIG слэш не нужен ;)

3. А вот идея отличная.
5. Damian (Damian) 14.09.11 21:27
Спасибо cbr900 и 7OH, ваши замечания в ближайшее время учту.
6. Damian (Damian) 14.09.11 21:30
tezin, это тот момент, о котором написал cbr900: нельзя использовать переменную с именем "РабочийСтол". Исправлю в скором времени.
7. Damian (Damian) 14.09.11 22:03
Замечания учтены, ошибки исправлены.
Текст публикации и файл обработки обновлен.

ОФФ: Я смотрю мне за написание комментов СтартМани начисляется. Уже вижу, как публикации пестрят тучей ничего не значащих комментариев :D
Посмотрим, как эти СтартМани аукнутся на качестве сайта.
8. Александр Медведев (anig99) 14.09.11 23:53
Хммм. КрестНаПузе...

Крест на пузе.
Пьют без меры.
Кто такие?
Тамплиеры!
9. Ledok (Ledok) 15.09.11 06:30
В случае, когда пользователь работает в УТ11 и у него остался не сохраненный документ, обработка НЕ МОЖЕТ завершить его сеанс, так как появляется сообщение "Сохранить изменения?".
Может, кто встречался с такой проблемой? Если да, поделитесь решением..
10. Виталий (PVG_73) 15.09.11 12:48
У меня не получилось завершить сессии, правда я пробовал это на своем же компе. Открыл несколько сессий, запустил обработку, но ничего не произошло. Ярлык для базы создался на рабочем столе.
Когда закрыл и попытался зайти, то уже не смог сие сделать, только через ярлык.
В чем может быть проблема?
11. Иван (SinglCOOLer) 15.09.11 13:21
Хорошая идея, особенно если нет возможности вносить изменения в конфу :)
12. Виталий (PVG_73) 15.09.11 13:27
(10) Да забыл отметить.... Качал обработку вчера около 18:00 по мск.... :)
13. Владимир Денисов (den_vladimir) 15.09.11 14:38
Заметил, что типовая форма блокировки для БП 2.0 вообще нормально не работает! Буду пробовать с этим решением!
Спасибо за труд!
14. Damian (Damian) 15.09.11 22:11
(9) Ledok, пробовал в разных конфигурациях для Украины (БП, УТП, УПП, ЗУП). Во всех случаях обработка выбрасывает пользователя, даже если у него открыт несохраненный документ/элемент справочника.
Происходит при этом следующее (с интервалом в 1 минуту):
1. Обработка честно сообщает, что работа завершается
2. Выскакивает окно с вопросом "Данные были изменены. Сохранить изменения?"
3. Опять обработка сообщает, что работа завершается
4. Работа, таки, завершается.
Сей опыт был проведен в нескольких базах путем простого наблюдения при политике невмешательства.
Что происходит в УТ сказать не могу. Однако, справедливости ради, хочется отметить, что начал прикручивать к обработке управляемую форму и в конфигурации УНФ такая же ситуация, как и у Вас: при открытом окне с несохраненными данными сеанс не сбрасывается.
Возможно, это просто нюанс управляемых форм, а возможно особенности конфигураций. Надо разбираться, но сие будет долгим процессом.
15. Ledok (Ledok) 16.09.11 04:18
Damian, я уже давно пользуюсь самописным bat файлом, который делает тоже самое и отлично работает на большинстве баз,
а вот именно УТ11, как вы отметили с управляемыми формами, не работает.
Попробовала выполнить для БП 2.0 на платформе 8.2, сработало на ура.
Так что делаю вывод, что это связано с управляемыми формами...
16. Виталий (PVG_73) 16.09.11 09:59
Damian, все таки поясните что я не так могу делать....
конфа самописная... создаю на своем компе 2 разные сессии и никаких сообщений и завершений сеансов... :(
17. Виталий (PVG_73) 16.09.11 10:05
(16) Попробовала на типовой... действительно работает..... даже вопрос на выходе не помешал.... :)
странно что тогда может не хватает в самописе.... :(
18. Виталий (PVG_73) 16.09.11 10:14
(17) Единственно у меня сразу же заново начался перестарт этих двух сеансов (то же самое у меня было и в терминальных сессиях на сервере, когда я убиваю сеанс а он заново рисуется)..... (кстати, с чем это может быть связано?)
и те два убитых сеанса остались мотыляться в активных зверЪях.... пока не закрыл у себя последний конфигуратор.... :)
19. Виталий (PVG_73) 16.09.11 10:23
Спасибо, за обработку.
Damian, если получится понять что может не хватать в самописе, черканите, если мне удастся разобраться то отпишусь здесь.
20. Alexey Pak (Alexey55) 16.09.11 12:36
21. Антон (anton.fly7) 17.09.11 08:11
ая так делаю

СтрокаСоединения = СтрокаСоединенияИнформационнойБазы();

Если
Найти(ВРег(СтрокаСоединения), "FILE") <> 0 Тогда
File = "";
Выполнить(
СтрокаСоединения);
СтрокаСоединения = "/F""" + File + """";
Иначе
Srvr = ""; Ref = "";
Выполнить(
СтрокаСоединения);
СтрокаСоединения = "/S""" + Srvr + "" + Ref + """";
КонецЕсли;
22. valek Valek (valek82) 19.09.11 11:07
Хотелось, бы конечно, чтобы можно было выбирать , кого блокировать.
23. Сергей Сергеев (SERJ_1CC) 19.09.11 15:50
Полезная вещица, пригодится...
24. Сергей Семенов (cerg110) 21.09.11 14:32
очень полезна, ато часто если работают через удаленный рабочий стол на серваке есть зависшие сеансы.
25. Брест Беларусь (zhleonid8) 21.09.11 14:47
26. Master07 (Master07) 21.09.11 16:14
27. Soul Power (SoulPower) 21.09.11 21:30
28. Олег Крапивный (powerpc) 21.09.11 23:51
29. Константин Гейнрих (CyberCerber) 23.09.11 14:38
Спасибо, вещь незаменимая.
30. Руслан Климачев (krv2k) 24.09.11 23:25
(0) Это шутка или намеренная дезинформация?
Не вводите людей в заблуждение, обработка никакие сеансы не отключает, а просто устанавливает блокировку соединений. А то, что сеансы отваливаются, так это заслуга механизма типовых конфигураций (поэтому у пользователя PVG_73 обработка "не работает").
Или меняйте описание, или удаляйте обработку с сайта.
31. Виталий (PVG_73) 25.09.11 20:58
(30) Уважаемый, krv2k, подскажите, а что это за механизмы типовой. Просто времени разбираться не было, но понимаю, что сие должно лежать на поверхности... :)
32. Damian (Damian) 26.09.11 00:16
(30) Руслан, позвольте с Вами не согласиться. Блокировка сеансов устанавливается не на уровне типовых конфигураций, а на уровне платформы. Почитайте синтакс-помощник, раздел "Глобальный контекст"-"Процедуры и функции работы с информационной базой"-"УстановитьБлокировкуСеансов".
Как Вы думаете, мы с Вами сможем написать конфигурацию, на которую эти правила распространяться не будут?
Хотя, смотря какую таблетку выбрать :) (с) Matrix
33. Руслан Климачев (krv2k) 26.09.11 04:59
(32) Damian, спасибо, синтаксис-помощник я читал. Еще раз повторюсь: не путайте "Блокировку сеансов" и "Завершение работы пользователей". Перед написанием следующего комментария, обязательно посмотрите как реализовано "Завершение работы пользователей" в типовых конфигурациях.
34. Руслан Климачев (krv2k) 26.09.11 05:10
(31) Этот механизм основан на обработчике ожидания, подключаемом для каждого пользователя при входе в систему (вызывается каждые 60 секунд). В обработчике проверяется, установлена ли блокировка сеансов, и если установлена, то сеанс завершается.
KrivosheevEV; susorov; +2 Ответить 1
35. Виталий (PVG_73) 26.09.11 12:47
(34) Спасибо, Руслан, нашел я этот кусок кода... :)
36. Иван (Sairys) 26.09.11 23:42
давно искал что то подобное. Спасибо за обработку.
37. Сергей Сергеевич (onyx) 27.09.11 04:07
Очень нужная и полезная штуковина....
38. Pavel Nevzorov (MrXaN) 27.09.11 05:42
Огромное спасибо за обработку
39. Serg Nyk (sergnik) 27.09.11 10:26
40. Дмитрий (r0610201) 27.09.11 12:29
Обязательно необходимо отметить, что работать это будет только в типовых конфигурациях. Чтобы это работало не только в типовых, надо завершать сеансы самому, через V82.COMConnector.
41. - - (Rebelx) 27.09.11 12:57
(40) не всегда получится - надо через DCOM, а это права и прочие проблемы.
а в самописках надо прописывать обработку параметра запуска аналогично как в типовых
42. Михаил Кишенков (mihas1001) 27.09.11 19:01
Интересно, корректно ли обрабатывается случай когда в момент отключения пользователь редактирует информацию в БД?
43. Владимир Пильгуй (volodyapgu) 27.09.11 22:47
Большое спасибо за обработку. Помогает в крупных фирмах корректно "отключать" большую часть сотрудников, а с отдельными лицами уже проще решить вопрос.
44. Юрий Пермитин (YPermitin) 28.09.11 08:10
Огромное спасибо за труды))) Очень полезная утилита.
45. Людмила Иванова (silver-fox87) 28.09.11 09:44
Спасибо! Очень нужна была такая обработка!
46. Евгений Зорин (evn-zorin) 28.09.11 09:46
(42) mihas1001,
В любом случае можно будет протестировать БД средствами 1С на наличие ошибок.
47. владимир демченко (jour) 28.09.11 12:32
на терминалке очень любят оставлять все, нужная вещь!
48. шрэк иванов (nshrek2) 30.09.11 10:37
Спасибо, вещь хорошая, пригодится.
49. Kris (mikit) 30.09.11 14:40
Спасибо огромное давно искала что-то подобное
50. ooosnika ooosnika (ooosnika) 03.10.11 18:23
мне очень пригодилась обработка,спасибо автору
51. bah bah (bahbah) 04.10.11 15:36
Очень полезная штука, не раз пользовался.
Глюков не встречал.
Спасибо, лови плюс.
52. KSM MAtus (KSM) 05.10.11 11:30
53. Damian (Damian) 06.10.11 00:24
Учтены замечания пользователей krv2k и r0610201 - описание изменено.
А также добавлена управляемая форма.
54. Олег Смирнов (mrdug) 07.10.11 10:54
что-то не пойму что с файлом? Предприятие его не видит.
55. Александр Горбачёв (SanyaGrek) 07.10.11 11:10
Спасибо! Главная проблема теперь решена. А то юзеров не выгонишь. Так работать хотят.
56. olga pt (pt_olga) 07.10.11 22:22
хотелось бы попробовать эту обработку... но пока нет денех :(
57. olga pt (pt_olga) 07.10.11 22:43
хотя пока вполне хватает стандартных средств... :)
58. tvv (pmtvv) 07.10.11 23:16
59. Андрей Черняховский (andos77) 10.10.11 11:23
60. Игорь Размета (Gar1ck) 11.10.11 15:43
За шаблоны отдельное спасибо!!!
61. Mike (air_mike) 11.10.11 16:23
Удобная штука для клиентского варианта. Но в "сервере" стандартная блокировка, через консоль, намного удобнее для меня.
62. Виталий Журавлев (dmd) 11.10.11 20:26
Поигрался немного, но пользуюсь стандартными методами.
63. aragor (aragor) 12.10.11 13:42
64. Сергей Сергеевич (onyx) 17.10.11 09:11
Спасибо огромное давно искала что-то подобное
66. Сергей (1C82) 21.10.11 04:41
ШИКАРНО! Кашерно ! Просто супер ! А то taskill уже надоело , да и не вежливо это. В файловой базе пока альтернативы не вижу.
67. Ninelle 27.10.11 19:43
Классная штука! особенно, когда приходишь к клиенту с большим количеством "медленных" сотрудников. недождешься, когда выйдут сами :)
68. Александр Сазонов (Asaqura) 28.10.11 23:57
69. orel (orel) 02.11.11 23:52
+100500 Спасибо! Уже пару раз пригодилась!
70. Serg Nyk (sergnik) 07.11.11 22:00
Спасибо, помогла выбросить юзера, который пару дней висел в файловой базе, и из-за не могли сохранить базу
и боялись перезагрузить комп ))
71. cs25 (cs25) 15.11.11 09:36
Выдаёт ошибку (клиент-серверный вариант):
Ошибка при прерывании соединений: {Форма.ФормаСписка.Форма(264)}: Ошибка при вызове метода контекста (ConnectAgent): Произошла исключительная ситуация (V81.COMConnector.1): Различаются версии клиента и сервера (8.1.15.14 - 8.2.14.519), клиентское приложение: COM-администратор
72. Антон Котов (Attest) 21.11.11 14:47
Спасибо! Однозначно в арсенал!
73. Ruslan Ahmetshin (AruslanM) 07.12.11 13:46
Заметил, что типовая форма блокировки неохотно выгоняет пользователей!
Буду пробовать с этим решением!
Спасибо за труд!
74. alex alex (temp2003) 09.12.11 14:11
В файловом варианте работает хорошо... И список пользователей виден четко, никогда не задваивается, в отличае от типового монитора пользователей... Правда, вот этот ярлычек на рабочем столе...Каждый раз раз как-то думаешь " а вдруг потом сам войти не сможешь..." )))) это единственный недостаток )))
75. Damian (Damian) 09.12.11 22:28
(74), не бойтесь, мой друг :)!
Если Вы запомнили код разрешения, который сами же и установили, то в базу всегда войти сможете.
В файловом варианте, на крайний случай, можно удалить файл 1Cv8.cdn из папки с базой для снятия всех блокировок.
76. Dmitry Chernykh (dim0n_la) 10.12.11 17:57
Я немного не понял.
Как именно реализован процесс завершения работы пользователей в файловом варианте работы БД?
Я так понял из описания, что обработка имеет два основных отличия от типовой.
Но я не вижу как она может выполниться для "любой" конфигурации? Может имелось ввиду для любой типовой конфигурации? Если так, то опять же не вижу в чем ценность обработки, ведь нетиповую надо дорабатывать функционалом в модуле приложения с обработчиками ожидания и пр.
77. alex alex (temp2003) 11.12.11 22:51
(76) dim0n_la,
Обработка, скажем так, упрощает типовой функционал по выгонялке пользователей ))) Интерфейс пользователя улучшен ))) а ценность в этом и заключается - удобнее работать... А если конфигурация совсем новая у вас, вы ее сами разработали, то конечно, придется встроить предварительно часть блока из типовых конфигураций....
78. Dem Dem (dem_mad) 19.12.11 14:21
Спасибо! Все просто и надежно...
79. Юлия Петрова (petrovaUL) 20.12.11 06:31
Возьму на "вооружение" для небольших БД, стандарные 1С-кие обработки для завершения работы пользователей часто не срабатывают. Спасибо. Плюс +.
80. Нурислам Ямбаев (nurislam) 23.12.11 20:02
81. Ledok (Ledok) 26.01.12 05:21
Доброго времени суток!
Не слышно ли чего нового по поводу завершения работы пользователей для баз на управляемых формах (таких как Управление торговлей 11 и Управление небольшой фирмой ред.1.3) ?
до сих пор очень актуально,
а то уже замучилась по утрам убирать файлы блокировок..
82. Damian (Damian) 26.01.12 18:07
(81), насчет нового не в курсе. А по поводу файлов - напишите батник, который будет удалять эти файлы за полчаса (час, два, в полночь :) до начала рабочего дня.
83. Юрий Сафонов (Ted1982) 27.01.12 17:30
Очень полезная обработка. Спасибо. После того, как закрыли права на использование консоли серверов и стало невозможно выкинуть из базы бухов (уходят в отпуск, сами в базе, а территориально находятся через пол-страны) Ваша обработка реально выручает.
84. Svetlana (vishenka) 06.02.12 09:15
У меня не работает почему-то. Запускаю в файловом варианте. Предупреждение выдает, а пользователей не выкидывает (хотя если поставить типовую блокировку - выкидывает)
В чем может быть причина?
85. Гость 17.02.12 10:11
Огромное спасибо! Незаменимая вещь!
86. Den LEO (s3nsay) 28.02.12 22:22
Огромное спасибо! Незаменимая вещь!Ваша обработка реально выручает.
Возьму на "вооружение" для небольших БД, стандарные 1С-кие обработки для завершения работы пользователей часто не срабатывают. Спасибо. Плюс +.
88. Oscar Oscar (OscarTT) 05.03.12 23:24
89. Viktor Kupko (zipik) 25.03.12 17:25
90. Viktor Kupko (zipik) 25.03.12 17:25
91. NtS (NtS) 26.03.12 22:40
у меня не работает на УТ, ничего не пойму, можно пошагово расписать, как работать с обработкой?
92. Damian (Damian) 27.03.12 11:27
(91) на типовой УТ должно работать 100%. Что именно не работает?
93. NtS (NtS) 27.03.12 11:49
(92)запускаю, ставлю галку "отключить пользователей", нажимаю "установить блокировку" и ничего не происходит((
ярлык на рабочем столе создается нормально
94. NtS (NtS) 27.03.12 11:52
(92) разобралась )) надо похоже время с запасом ставить, не за минуту до завершения
95. Андрей (karloson) 06.07.12 15:27
Пользователей выкидывает и пускает обратно по времени, но не создается ярлык на рабочем столе((
УТ 11 8.2
96. Mabuta (mabuta_serg) 24.09.12 07:19
Здоров разработчикам.
У меня не работает почему-то. Запускаю в файловом варианте. Предупреждение выдает, а пользователей не выкидывает
Может это из-за управляемой формы?
Что я не так делаю
97. Сергей Ломоносов (djserega) 14.11.12 08:16
У меня тоже самое (96), висит на предупреждении о завершении работы и не закрывается
98. Сергей Шепелев (redgoll) 24.11.12 09:36
Спасибо, большое за обработку, сейчас скачаю и протестирую. Типовая обработка отчего то не сработала, правда в слегка настроенной конфигурации, которая непонятно как обновлялась. Ставлю в ней блокировку, но вхожу легко и без пароля и конфигуратор не закрылся даже. Хотя раньше вроде бы пробовал и все получалось. Никто не знает в чем может быть дело?
99. Сергей Шепелев (redgoll) 24.11.12 10:56
Протестил, все работает. И очень удобно, что конфигуратор не закрывается. Правда, как быть, если его открыл не я? )) Выходит, что тот, другой пользователь не будет выгнан?
100. Андрей Акулов (DrAku1a) 19.12.12 02:56
+1, но сейчас можно указать в настройках подключения к ИБ на последней вкладке "Дополнительные параметры запуска" ключ /UC<код_разблокировки>, например /UC012345 - и никаких ярлыков создавать не нужно будет...
101. Игор Мудрицкий (Zas1402) 20.12.12 17:31
Отлично, я бы сказал идеально...
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа