Пример создания кадрового отчета для ЗУП 3.1

Публикация № 1349201 22.12.20

Разработка - Практика программирования

Отчет ЗУП 3.1 СхемаЗапроса Представления программный интерфейс

Пример создания отчёта "Изменение графиков работы" для ЗУП 3.1 с использованием механизма представлений и объекта СхемаЗапроса.

Заказчику на производственном предприятии понадобился отчет, содержащий информацию об истории изменения графиков работы сотрудников. Штатного отчёта в конфигурации ЗУП 3.1 (3.1.14.334) не оказалось. Потребовалось написать новый внешний отчет. За основу был взят отчет Кадровая история сотрудников. На практике именно этот отчет дорабатывался. Для статьи же я написал отдельный отчет, чтобы можно было использовать его как шаблон создания своих отчетов.

Введение

Типовые отчеты в ЗУП построены так, что текст запроса для отчета формируется программно в процедуре ПриКомпоновкеРезультата(). В ней необходимо вызвать следующую процедуру: ЗарплатаКадрыОбщиеНаборыДанных.ЗаполнитьОбщиеИсточникиДанныхОтчета(ЭтотОбъект), которая подготовит реальный запрос для нашего отчета. Используется так называемый механизм представлений. В Схеме компоновки же составляется обычно запрос-пустышка. В запросе по определенным правилам составляются имена виртуальных таблиц. Далее процедуры общих модулей ЗУП заменяют такие виртуальные таблицы на реально исполняемые. Механизм замены представлений в совокупности с программным интерфейсом позволяет безболезненно получать данные из базы.

  Ранее коллеги  уже описывали функции для получения данных. Например, вот здесь: //infostart.ru/1c/articles/841337/ и здесь: //infostart.ru/1c/articles/942569/

Если игнорировать использование программного интерфейса при получении данных в Зарплате, можно испытать много боли и разочарования. Даже если вы опытный сеньор и знаете особенности проектирования Зарплаты, никто не гарантирует, что в следующем релизе разработчики, как минимум, не переименуют реквизиты.  Поэтому, самостоятельно запрашивать у ЗУП данные, если для из получения имеется программный интерфейс, это не наш метод. Наша задача сделать так, чтобы отчет пережил как можно больше релизов.

На мой взгляд, серьезный недостаток программного интерфейса, это отсутствие описания процедур и функций, и взаимосвязи между ними. Плюс не описано, какие именно выходные поля можно запросить. Мечта, если бы все функции были описаны так же как КадровыйУчет.КадровыеДанныеСотрудников(...). И несмотря на это описание, какие имена полей допустимы в параметре КадровыеДанные, не так просто найти. Также нет информации о том, из какиз таблиц и какие данные можно получать с помощью виртуальных таблиц Представлений.

Для понимания, как же устроен этот механизм пришлось изучать типовые отчеты и пользоваться глобальным поиском. Также очень выручает вот эта обработка с ИТС https://its.1c.ru/db/metod81/content/7329/hdoc

Процедура ЗарплатаКадрыОбщиеНаборыДанных.ЗаполнитьОбщиеИсточникиДанныхОтчета(ЭтотОбъект) Содержит еще процедуру, которая заменяет тексты запросов. Эта большая процедура, в свою очередь, ищет, в каком из общих модулей содержится код по замене данного конкретного представления. То есть во многих общих модулях содержатся целые области по формированию запросов к базе данных. Эти области кода также используются в документах и справочниках соответствующих подсистем. Как правило, помимо сбора запроса представления, эти области содержат процедуры по получению данных в менеджер временных таблиц. Очень жаль, что они не описаны разработчиками и приходится самостоятельно их исследовать и подсматривать использование в типовых документах. Чтобы иметь представление, какие данные мы можем получать через представления, я составил вот такую табличку названий, которые встречаются в конфигурации.

 

"СотрудникиПодлежащиеАттестации"
"РезультатыАттестацииСотрудников"
"Периоды"
"ТаблицаРегистра"
"СрезПоследних"
"СрезПервых"
"ТаблицаРегистра"
"ТаблицаРегистра"а
"СрезПоследних"а
"КадровыеДанныеФизическихЛиц"
"КадровыеДанныеСотрудников"
"РабочиеМестаСотрудников"
"СотрудникиОрганизации"
"ОтработанноеВремя"
"КадровыеДанныеСотрудниковАнализНачисленийИУдержаний"
"ПодразделенияСортировкиСотрудников"
"НачисленныеДоходыНДФЛ"
"ШтатноеРасписание"
"ТекущаяКадроваяРасстановка"
"ФункциональныеОпцииОрганизаций"
"ФактическиеОтпускаСотрудников"
"ПлановыеНачисленияСотрудников"
"ПлановыеУдержанияСотрудников"
"СтажиСотрудников"
"СвойстваСтатейФинансирования"
"ПлановоеВремя"

 

Например, представление ШтатноеРасписание используется в отчетах по штатному расписанию. В недрах функций по замене представлений есть функция, получающая набор источников данных для заменяемой таблицы. И конкретно по штатному расписанию источник построения запроса далеко не один

"ВТОТБОРПОЗИЦИЙШТАТНОГОРАСПИСАНИЯ" Структура
"СПРАВОЧНИКШТАТНОЕРАСПИСАНИЕ" Структура
"РЕГИСТРСВЕДЕНИЙИСТОРИЯИСПОЛЬЗОВАНИЯШТАТНОГОРАСПИСАНИЯ" Структура
"РЕГИСТРСВЕДЕНИЙТЕРРИТОРИАЛЬНЫЕУСЛОВИЯПФР" Структура
"РЕГИСТРСВЕДЕНИЙКЛАССЫУСЛОВИЙТРУДАПОДОЛЖНОСТЯМ" Структура
"РЕГИСТРСВЕДЕНИЙЗАНЯТОСТЬПОЗИЦИЙШТАТНОГОРАСПИСАНИЯ" Структура
"РЕГИСТРСВЕДЕНИЙСТРОКИОТЧЕТНОСТИМОНИТОРИНГАРАБОТНИКОВСОЦИАЛЬНОЙСФЕРЫ" Структура
"РЕГИСТРСВЕДЕНИЙМЕСТОПОЗИЦИИШТАТНОГОРАСПИСАНИЯВСТРУКТУРЕПРЕДПРИЯТИЯ" Структура

 

Ну и финальный запрос выглядит устрашающе:

 
 Финальный запрос по штатному расписанию

Запрос-пустышка выглядел так:

 

 

В финальном запросе можно посмотреть. какие поля доступны для получения.

При компоновке макета СКД, естественно, запрос сильно похудеет...

 

Часть 1 

От разработчика отчета требуется правильно подготовить запрос-пустышку.

Итак приступим.

Откуда брать информацию по графикам работы? Так как у нас по сути всего получение одной сущности, это график работы, вряд-ли нам нужен большой контейнер-представление, вроде ШтатноеРасисание. Можно посмотреть, какой запрос строит функция КадровыйУчет.КадровыеДанныеСотрудников(..), например. Я посмотрел, куда делает движения документ Изменение графиков работы. Всего 4 регистра. Очевидно, что наш регистр ГрафикРаботыСотрудников. Допустим, мы бы захотели сами построить запрос. Но в базе 3 регистра!!! Один основной и 2 вспомогательных (ГрафикРаботыСотрудниковИспр и ГрафикРаботыСотрудниковИнтервальный).   Лучше построим запрос к этому регистру правильно. Готовим так называемую таблицу отбора, таблицу-фильтр. 

ВЫБРАТЬ
	&НачалоПериода КАК ДатаНачала,
	&ОкончаниеПериода КАК ДатаОкончания,
	Сотрудники.Ссылка КАК Сотрудник
ПОМЕСТИТЬ ВТОтборДляТаблицыРегистра
ИЗ
	Справочник.Сотрудники КАК Сотрудники

Далее основная пустышка:

ВЫБРАТЬ
	ДАТАВРЕМЯ(1, 1, 1) КАК Период,
	ДАТАВРЕМЯ(1, 1, 1) КАК ПериодЗаписи,
	ДАТАВРЕМЯ(1, 1, 1) КАК ПериодВозвратногоСобытия,
	ЗНАЧЕНИЕ(Документ.ИзменениеГрафикаРаботыСписком.ПустаяСсылка) КАК Регистратор,
	ЛОЖЬ КАК ЭтоВозвратноеСобытие,
	ЗНАЧЕНИЕ(Справочник.Сотрудники.ПустаяСсылка) КАК Сотрудник,
	ЗНАЧЕНИЕ(Справочник.Организации.ПустаяСсылка) КАК ГоловнаяОрганизация,
	ЗНАЧЕНИЕ(Справочник.ГрафикиРаботыСотрудников.ПустаяСсылка) КАК ГрафикРаботы
ПОМЕСТИТЬ Представления_ТаблицаРегистра_ГрафикРаботыСотрудников
ИЗ
	ВТОтборДляТаблицыРегистра КАК ОтборДляТаблицыРегистра
ГДЕ
	"ТолькоРазрешенные" = ИСТИНА
	И "ПараметрыПостроения_ФормироватьСПериодичностьДень" = ЛОЖЬ
	И "ПараметрыПостроения_ВключатьЗаписиНаНачалоПериода" = ИСТИНА

 

Выборка данных в пустышке идет из Таблицы для отбора. Однако никаких полей мы не выбрали. Переживать не стоит, это необходимо для получения реального запроса. Очень важно правильно назвать эту таблицу, обработка подскажет нам как..

Еще нам потребуется некоторая кадровая информация по сотрудникам, ее также получаем похожим образом. Только кадровые данные могут быть очень различны и содержатся в разных регистрах (как и штатное расписание), поэтому строим пустышку не по _ТаблицаРегистра_

Таблица для отбора кадровых данных:

ВЫБРАТЬ
	Представления_ТаблицаРегистра_ГрафикРаботыСотрудников.Период КАК Период,
	Представления_ТаблицаРегистра_ГрафикРаботыСотрудников.Сотрудник КАК Сотрудник
ПОМЕСТИТЬ ВТСотрудникиПериоды
ИЗ
	Представления_ТаблицаРегистра_ГрафикРаботыСотрудников КАК Представления_ТаблицаРегистра_ГрафикРаботыСотрудников

Поскольку в ЗУП период получения данных ахриважен, для получения кадровых данных нам нужен сам сотрудник и дата получения кадрвоых данных. Поэтому таблица содержит 2 "параметра": Сотрудник, Период. Брать эти данные мы будем из таблицы выше. Ведь для предыдущей таблицы нам как раз не хватает колонок с кадровыми данными. Для каждой строки (которая как раз содержит Сотрудника и дату изменения его графика) мы ниже и получим недостающие колонки.

Теперь. когда готова таблица для отбора, основная пустышка для получения кадровых данных:

ВЫБРАТЬ
	ДАТАВРЕМЯ(1, 1, 1) КАК Период,
	ЗНАЧЕНИЕ(Справочник.Сотрудники.ПустаяСсылка) КАК Сотрудник,
	ЗНАЧЕНИЕ(Справочник.ПодразделенияОрганизаций.ПустаяСсылка) КАК Подразделение,
	ЗНАЧЕНИЕ(Справочник.Организации.ПустаяСсылка) КАК Организация,
	ЗНАЧЕНИЕ(Справочник.ШтатноеРасписание.ПустаяСсылка) КАК ДолжностьПоШтатномуРасписанию,
	ЗНАЧЕНИЕ(Справочник.Должности.ПустаяСсылка) КАК Должность
ПОМЕСТИТЬ Представления_КадровыеДанныеСотрудников
ИЗ
	ВТСотрудникиПериоды КАК СотрудникиПериоды

И в этой таблице в наименовании видим Представление_...., необходимое для работы программного интерфейса.

Итак, осталось только сделать выборку данных (см. приложенном к статье отчёте).

Часть 2

При анализе похожих отчетов ( КадроваяИсторияСотрудников, ФактическиеОтпускаСотрудников) обратил внимание на то, что что виртуальную таблицу Представления_ТаблицаРегистра_ИмяРегистраизКоторогоПолучаютсяДанные разработчики ЗУП собирают объединением. Конкретно, собираются пустые ссылки в поле Регистратор. Сначала было предположение, что механизм представлений сделает ограничение по типам регистратора, но отладчик не подтвердил гипотезу. При этом, если не собирать данную виртуальную таблицу объединением а поставить наобум любой тип из перечня регистраторов, отчет также успешно отработает, и покажет все типы регистраторов. Для чего так сделали разработчики, пока непонятно, если кто знает, прошу разъяснить в комментариях. Предполагаю, что разработчики будут развивать механизм представлений и такое построение типовых отчетов - задел на будущее. Поэтому решено было в своем отчете сделать также.

В отчёте КадроваяИсторияСотрудников объединение собрано из 12 запросов (соответственно, 12 типов регистраторов). У регистра ГрафикРаботыСотрудников (основа нашего отчета) в данный момент 9 регистраторов. На данный момент непонятно:

1. Будут ли разработчики развивать механизм представлений и какое влияние это окажет на разрабатываемый отчет, если не собрать объединение пустых ссылок регистраторов; 

2. Изменится ли состав регистраторов. 

Поэтому виртуальную таблицу Предстваления_ТаблицаРегистра_ГрафикРаботыСотрудников решено было доработать программно. Для этого в схеме компоновки отчета конструктором создана таблица Представлений с одной пустой ссылкой регистратора, и уже эта таблица дорабатывается в процедуре ДополнитьЗапросПредставленияТаблицыРегистра(). 

Ранее при вклинивании в монстры-запросы ЗУП была идея попробовать для этих целей такой объект как СхемаЗапроса. Слышал много нелестных отзывов об этом объекте, что он очень медленный и применять его надо с осторожностью. В конфигурации ЗУП, однако, данный объект используется. разработчики даже написали несколько функций в общем модуле ЗарплатаКадрыОбщиеНаборыДанных для работы со схемой запроса. Специально замеров производительности не проводил, но в рамках доработанного отчета схема запроса прекрасно прижилась, проблем с работой не было. Также она оказалась очень удобной в разработке. Как инструкция по работе со схемой была использована вот эта статья : Объектная модель запроса "Схема запроса" - теория и примеры использования (infostart.ru).

Итак, сама процедура ДополнитьЗапросПредставленияТаблицыРегистра()

     

		ТекстДляДополнения = ЭтотОбъект.СхемаКомпоновкиДанных.НаборыДанных.НаборДанныхГрафик.Запрос;
		
		Схема = Новый Схемазапроса;
		
		Схема.УстановитьТекстЗапроса(ТекстДляДополнения);
		
		ЗапросПакета = ЗарплатаКадрыОбщиеНаборыДанных.ЗапросСхемыФормирующийВТ(Схема, "Представления_ТаблицаРегистра_ГрафикРаботыСотрудников");
		
		Если ЗапросПакета = Неопределено Тогда
			
			Возврат;
			
		КонецЕсли;
		
		НаборЗаписей = РегистрыСведений.ГрафикРаботыСотрудников.СоздатьНаборЗаписей();
		
		Для к = 0 по НаборЗаписей.Отбор.Регистратор.ТипЗначения.Типы().Количество() - 1 цикл
			
			ПромТип = НаборЗаписей.Отбор.Регистратор.ТипЗначения.Типы()[к];
			
			Если ПромТип = Тип("ДокументСсылка.ИзменениеГрафикаРаботыСписком") Тогда
				
				Продолжить;
				
			КонецЕсли;
			
			МДОбъект = Метаданные.НайтиПоТипу(ПромТип);
			
			Если МДОбъект <> Неопределено тогда
				
				ОператорВыбораРегистратора = ЗапросПакета.Операторы.Добавить();
				
				Для каждого ПолеОператора Из ЗапросПакета.Операторы[0].ВыбираемыеПоля Цикл
					
					Если ПолеОператора = Новый	ВыражениеСхемыЗапроса("ЗНАЧЕНИЕ(Документ.ИзменениеГрафикаРаботыСписком.ПустаяСсылка)") Тогда
						
						Регистратор = ОператорВыбораРегистратора.ВыбираемыеПоля.Добавить("Значение(Документ."+МДОбъект.Имя+".ПустаяСсылка)");
						
					Иначе
						
						Регистратор = ОператорВыбораРегистратора.ВыбираемыеПоля.Добавить("NULL");
						
					КонецЕсли;					
					
				КонецЦикла; 
				
			КонецЕсли;
			
		КонецЦикла;
		
		ЭтотОбъект.СхемаКомпоновкиДанных.НаборыДанных.НаборДанныхГрафик.Запрос = Схема.ПолучитьТекстЗапроса();

   Как можно заметить, виртуальная таблица Представления... была получена функцией из общего модуля.  Далее Происходит получение массива регистраторов для регистра ГрафикРаботыСотрудников и работа с коллекцией Операторы конкретного пакета запроса Схемы запроса. Первый элемент этой коллекции это и есть наш запрос, созданный в конструкторе. Для сопоставления полей получившегося объединения было как минимум три варианта действий.   Сначала сделал вариант, где в виртуальной таблице Представлений выбрал регистратор первым в списке, а во вновь создаваемых операторах просто добавлял выбираемое поле с пустой ссылкой следующего регистратора. Но в случае, если другой разработчик изменит порядок полей в схеме компоновки, отчет перестанет работать. Можно было попробовать сопоставить поля как описано в статье выше. Но решил остановиться на варианте с обходом коллекции выбираемых полей первого оператора. 

Весь код модуля объекта получившегося отчета ниже:

#Если Сервер Или ТолстыйКлиентОбычноеПриложение Или ВнешнееСоединение Тогда
	
	#Область ОбработчикиСобытий
	
	Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
		
		УстановитьПривилегированныйРежим(Истина);
		
		ИнициализироватьОтчет();
		
		УстановитьПривилегированныйРежим(Ложь);
		
	КонецПроцедуры
	
	#КонецОбласти
	
	#Область СлужебныеПроцедурыИФункции
	
	Функция СведенияОВнешнейОбработке() Экспорт
		
		ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке();
		ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительныйОтчет();
		ПараметрыРегистрации.Версия = "1.0";
		ПараметрыРегистрации.Наименование = НСтр("ru = 'Изменения графиков работы'");
		ПараметрыРегистрации.Информация = НСтр("ru = 'Изменения графиков работы'");
		
		ПараметрыРегистрации.БезопасныйРежим = Ложь;
		
		Команда = ПараметрыРегистрации.Команды.Добавить();
		Команда.Представление = НСтр("ru = 'Изменения графиков работы'");
		Команда.Идентификатор = "КадровыеИзмененияИГрафикиРаботыСотрудниковВнешний";
		Команда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();
		Команда.ПоказыватьОповещение = ИСТИНА;
		Команда.Модификатор="ПечатьMXL";
		
		
		Возврат ПараметрыРегистрации;
		
	КонецФункции
	
	Процедура ИнициализироватьОтчет() Экспорт
		
		ДополнитьЗапросПредставленияТаблицыРегистра();
		
		ЗарплатаКадрыОбщиеНаборыДанных.ЗаполнитьОбщиеИсточникиДанныхОтчета(ЭтотОбъект);
		
	КонецПроцедуры
	
	Процедура ДополнитьЗапросПредставленияТаблицыРегистра()
		//
		ТекстДляДополнения = ЭтотОбъект.СхемаКомпоновкиДанных.НаборыДанных.НаборДанныхГрафик.Запрос;
		
		Схема = Новый Схемазапроса;
		
		Схема.УстановитьТекстЗапроса(ТекстДляДополнения);
		
		ЗапросПакета = ЗарплатаКадрыОбщиеНаборыДанных.ЗапросСхемыФормирующийВТ(Схема, "Представления_ТаблицаРегистра_ГрафикРаботыСотрудников");
		
		Если ЗапросПакета = Неопределено Тогда
			
			Возврат;
			
		КонецЕсли;
		
		НаборЗаписей = РегистрыСведений.ГрафикРаботыСотрудников.СоздатьНаборЗаписей();
		
		Для к = 0 по НаборЗаписей.Отбор.Регистратор.ТипЗначения.Типы().Количество() - 1 цикл
			
			ПромТип = НаборЗаписей.Отбор.Регистратор.ТипЗначения.Типы()[к];
			
			Если ПромТип = Тип("ДокументСсылка.ИзменениеГрафикаРаботыСписком") Тогда
				
				Продолжить;
				
			КонецЕсли;
			
			МДОбъект = Метаданные.НайтиПоТипу(ПромТип);
			
			Если МДОбъект <> Неопределено тогда
				
				ОператорВыбораРегистратора = ЗапросПакета.Операторы.Добавить();
				
				Для каждого ПолеОператора Из ЗапросПакета.Операторы[0].ВыбираемыеПоля Цикл
					
					Если ПолеОператора = Новый	ВыражениеСхемыЗапроса("ЗНАЧЕНИЕ(Документ.ИзменениеГрафикаРаботыСписком.ПустаяСсылка)") Тогда
						
						Регистратор = ОператорВыбораРегистратора.ВыбираемыеПоля.Добавить("Значение(Документ."+МДОбъект.Имя+".ПустаяСсылка)");
						
					Иначе
						
						Регистратор = ОператорВыбораРегистратора.ВыбираемыеПоля.Добавить("NULL");
						
					КонецЕсли;					
					
				КонецЦикла; 
				
			КонецЕсли;
			
		КонецЦикла;
		
		ЭтотОбъект.СхемаКомпоновкиДанных.НаборыДанных.НаборДанныхГрафик.Запрос = Схема.ПолучитьТекстЗапроса();
		
	КонецПроцедуры
	
	#КонецОбласти
	
	
#Иначе
	ВызватьИсключение НСтр("ru = 'Недопустимый вызов объекта на клиенте.'");
#КонецЕсли

В целях развития данного подхода к созданию отчетов для ЗУП 3.1 можно вынести процедуру ДополнитьЗапросПредставленияТаблицыРегистра() в общий модуль( планирую  с повторным использованием) , немного доработать чтобы можно было использовать в других отчетах. В функции есть что улучшить, но сейчас цель не в оптимизации кода, а в том, чтобы попробовать отвязаться от метаданных (в данном случае от регистраторов) с помощью СхемыЗапроса.

Надеюсь, данный шаблон поможет начинающим свой путь в дебрях ЗУП избежать ошибок и боли, и полюбить эту прекрасную конфигурацию так, как люблю её я.

Скачать файлы

Наименование Файл Версия Размер
Пример создания кадрового отчёта для ЗУП 3.1:

.erf 12,52Kb
62
.erf 12,52Kb 62 Скачать бесплатно

Специальные предложения

Оставьте свое сообщение

См. также

Аналог PIVOT в запросе 1С (как выполнить транспонирование таблицы в запросе 1С) Промо

Практика программирования v8 Бесплатно (free)

В статье показывается простой метод реализации аналога оператора PIVOT в запросе 1С без использования соединений.

12.12.2020    3582    Eugen-S    20    

Полезные примеры СКД, ч.2

Практика программирования v8 v8::СКД Бесплатно (free)

Еще несколько примеров решения задач в СКД.

06.04.2021    9692    Neti    8    

Неочевидные нюансы записи управляемой формы

Практика программирования v8 v8::УФ Платформа 1C v8.2 1cv8.cf Бесплатно (free)

Разберем несколько нюансов записи управляемой формы.

02.04.2021    11079    SeiOkami    52    

Обзор полезных методов БСП 3.1.4

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Бесплатно (free)

Библиотека стандартных подсистем (далее - БСП) является частью любой типовой конфигурации, поэтому умение применять готовые процедуры и функции повышает качество разработки и избавляет от написания лишнего кода. К сожалению, не у всех есть время и упорство овладеть всей документацией, поэтому я собрал воедино наиболее популярный функционал.

25.03.2021    35210    rayastar    51    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    84706    Serginio    113    

Звуковое управление в 1С 8.3

Практика программирования v8 1cv8.cf Бесплатно (free)

В данной статье описано создание библиотеки для звукового управления (выполнение команд голосом) для платформы 1С 8.3. Задача была поставлена так, чтобы модуль функционировал непосредственно на клиенте 1С, осуществляя управление формами, и взаимодействовал с интерфейсом.

16.03.2021    6682    velemir    31    

Доработка проведения в ERP 2.5. (Регистры накопления, Регистры сведений)

Практика программирования v8 ERP2 БУ Бесплатно (free)

Покажу точки входа для доработки "типового" проведения документов в ERP для регистров оперативного учета. Рассмотрим три основные ситуации: нужно изменить имеющееся проведение документа; нужно сделать записи в существующие регистры; нужно с нуля описать алгоритм проведения в добавленный регистр. Пример реализован на 1С:ERP Управление предприятием 2 (2.5.4.120)

10.01.2021    9954    BuriyLesha    10    

Serverless (Faas) в 1С. Создание и вызов Yandex Cloud Functions

Универсальные функции Практика программирования v8 Бесплатно (free)

"Я не могу просто взять и скопировать код с гитхаба", "у нас 1С микросервисами окружена", "возможностей мало" - частые фразы 1С разработчиков. которым не хватает возможностей платформы в современном мире. Faas, конечно, история не новая, но нас сдерживало 152ФЗ и задержки по пингам. Для того, чтобы действительно использовать в 1С код, к примеру, на Python, надо было приложить усилия. Теперь всё намного проще - берём и используем.

28.12.2020    8369    comol    31    

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    40716    unichkin    74    

Базовые вещи БСП, которые облегчат жизнь программисту 1С

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Россия Бесплатно (free)

В данной публикации я опишу полезные процедуры и функции модуля общего назначения библиотеки стандартных подсистем, обязательные к использованию любым программистом 1С.

30.08.2020    18961    quazare    34    

Серверные вызовы, которые нельзя вызывать

Практика программирования v8 v8::УФ 1cv8.cf Бесплатно (free)

Не баян, а классика. Рассмотрим особенность платформы настолько же древнюю, как сами УФ.

12.05.2020    8902    SeiOkami    34    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    35574    tormozit    106    

Форма выбора (подбор) в управляемых формах

Практика программирования v8 v8::УФ 1cv8.cf Россия Бесплатно (free)

Разбор небольших примеров того, как правильно открывать форму выбора (подбора) в управляемых формах, не прибегая к модальным окнам.

08.05.2020    69952    user5300    19    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    61497    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    41595    John_d    22    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    82416    tormozit    131    

Последовательности событий при проведении документа 1С. Шпаргалка + про формы + про расширения

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    33240    kuzyara    38    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    23322    YPermitin    62    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    11868    Sibars    19    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    53771    tormozit    51    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Бесплатно (free)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    38764    HostHost    41    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    51188    Yashazz    56    

О программе Postman для тестирования API и для чего она нужна 1С-нику

Практика программирования Программное обеспечение (software) v8 Бесплатно (free)

Для чего нужна программа Postman для тестирования API и какая от него польза для 1С-программиста.

24.09.2019    19415    budidich    31    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    50519    tormozit    74    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    95759    rpgshnik    75    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    74368    ids79    55    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    44489    YPermitin    25    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    17776    m-rv    3    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    29819    YPermitin    81    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    43978    ids79    22    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    143803    ids79    75    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    23007    m-rv    18    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    58159    avalakh    26    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    39808    json    16    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    100974    ids79    16    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    36224    m-rv    23    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    47158    ids79    27    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    33137    YPermitin    14    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    22267    SeiOkami    53    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    30595    itriot11    34    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    80748    ids79    18    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    73641    ids79    28    

Регистры накопления. Виртуальные таблицы. Часть №2: "Остатки" и "Остатки и обороты"

Практика программирования v8 1cv8.cf Бесплатно (free)

Описание работы платформы 1С:Предприятие 8.2 с виртуальными таблицами регистров накопления "Остатки" и "Остатки и обороты". Анализ SQL-запрос при работе с виртуальными таблицами

22.05.2019    42311    YPermitin    8    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    61381    YPermitin    31    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    41942    ellavs    131    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    31576    ellavs    90    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    40393    YPermitin    53