Тормоза при сканировании в рабочем месте кассира

07.08.23

База данных - HighLoad оптимизация

На низкоскоростных каналах связи в УТ 11 в РМК подтормаживает поиск по штрихкоду.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Тормоза при сканировании в рабочем месте кассира:
.cfe 25,31Kb
0
0
1 SM
Скачать Купить за 1 850 руб.

Столкнулся с проблемой, на низкоскоростных каналах связи в УТ 11 в РМК подтормаживает поиск по штрихкоду.

Обнаружил серверный вызов, который и вызывает торможение.

Речь идет о процедуре ИнформацияОбОплатеЛокализация в форме ФормаДокументаРМК документа Чек ККМ.

Сама процедура может вызываться с клиента, но имеет 3 серверных вызова, которые и приводят к задержке.

На современных каналах связи эта задержка не столь существенна и незаметна, но если работа ведётся в глубинке, то значительно ухудшает работу пользователей.

Привожу доработанный код в расширении. Тестирование проводил на версии УТ 11.5.12.95, но думаю, будет работать и на других версиях.

Процедура СБП_ИнформацияОбОплатеЛокализация(Форма, ИнформацияОбОплате)
		
	//++ Локализация
	#Удаление
	СуммаОплатыЭСФССПоДокументу = СуммаОплатыЭСФССПоДокументу(Форма.Объект.ОплатаПлатежнымиКартами);
    #КонецУдаления
	#Вставка     
	СуммаОплатыЭСФСС = 0;
	
	Для Каждого СтрокаТЗ Из Форма.Объект.ОплатаПлатежнымиКартами Цикл
		
		Если СтрокаТЗ.ВидОплаты = ПредопределенноеЗначение("Перечисление.ТипыПлатежнойСистемыККТ.СертификатНСПК") Тогда
			СуммаОплатыЭСФСС = СуммаОплатыЭСФСС + СтрокаТЗ.Сумма;
		КонецЕсли;
		
	КонецЦикла;
	СуммаОплатыЭСФССПоДокументу = СуммаОплатыЭСФСС;
	#КонецВставки
	
	Форма.ЭтоОплатаЭСФСС = (СуммаОплатыЭСФССПоДокументу > 0);
	ИнформацияОбОплате.Вставить("ЭСФСС", СуммаОплатыЭСФССПоДокументу);

	ИтогоОплачено = ИнформацияОбОплате.ИтогоОплачено
	+ ИнформацияОбОплате.ЭСФСС;
	ИнформацияОбОплате.Вставить("ИтогоОплачено", ИтогоОплачено);

	#Удаление
	СуммаОплатыСБППоДокументу = СуммаОплатыСБППоДокументу(Форма.Объект.ОплатаПлатежнымиКартами);
    #КонецУдаления
	#Вставка     
	СуммаОплатыСБП = 0;
	ТолькоОплатаВыполнена = Истина;
	
	Для Каждого СтрокаТЗ Из Форма.Объект.ОплатаПлатежнымиКартами Цикл
		
		Если СтрокаТЗ.ВидОплаты = ПредопределенноеЗначение("Перечисление.ТипыПлатежнойСистемыККТ.СистемаБыстрыхПлатежей") Тогда
			
			Если ТолькоОплатаВыполнена И СтрокаТЗ.СтатусОплатыСБП = ПредопределенноеЗначение("Перечисление.ТипыСтатусовОплатыСБП.Выполнена")
				ИЛИ Не ТолькоОплатаВыполнена Тогда
				
				СуммаОплатыСБП = СуммаОплатыСБП + СтрокаТЗ.Сумма;
			КонецЕсли;
		КонецЕсли;
		
	КонецЦикла;
	СуммаОплатыСБППоДокументу = СуммаОплатыСБП;
	#КонецВставки
	#Удаление
	СуммаОжиданиеОплатыСБППоДокументу = СуммаОжиданиеОплатыСБППоДокументу(Форма.Объект.ОплатаПлатежнымиКартами);
    #КонецУдаления
	#Вставка     
	ТолькоОплатаВыполнена = Ложь;
	СуммаОплатыСБП = 0;
	
	Для Каждого СтрокаТЗ Из Форма.Объект.ОплатаПлатежнымиКартами Цикл
		
		Если СтрокаТЗ.ВидОплаты = ПредопределенноеЗначение("Перечисление.ТипыПлатежнойСистемыККТ.СистемаБыстрыхПлатежей") Тогда
			
			Если ТолькоОплатаВыполнена И СтрокаТЗ.СтатусОплатыСБП = ПредопределенноеЗначение("Перечисление.ТипыСтатусовОплатыСБП.Выполнена")
				ИЛИ Не ТолькоОплатаВыполнена Тогда
				
				СуммаОплатыСБП = СуммаОплатыСБП + СтрокаТЗ.Сумма;
			КонецЕсли;
		КонецЕсли;
		
	КонецЦикла;
	СуммаОжиданиеОплатыСБППоДокументу = СуммаОплатыСБП;
 	#КонецВставки

	Форма.ЕстьОплатаСБП = (СуммаОплатыСБППоДокументу > 0);
	ИнформацияОбОплате.Вставить("СБП", СуммаОплатыСБППоДокументу);
	ИнформацияОбОплате.Вставить("СБПОжидание", СуммаОжиданиеОплатыСБППоДокументу);

	ИтогоОплачено = ИнформацияОбОплате.ИтогоОплачено
	+ ИнформацияОбОплате.СБП;
	ИнформацияОбОплате.Вставить("ИтогоОплачено", ИтогоОплачено);
	//-- Локализация

КонецПроцедуры

 

Тормоза при сканировании РМК УТ11

См. также

HighLoad оптимизация Программист Платформа 1С v8.3 Бесплатно (free)

Метод очень медленно работает, когда параметр приемник содержит намного меньше свойств, чем источник.

06.06.2024    7310    Evg-Lylyk    61    

42

HighLoad оптимизация Программист Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Анализ простого плана запроса. Оптимизация нагрузки на ЦП сервера СУБД используя типовые индексы.

13.03.2024    4276    spyke    28    

48

HighLoad оптимизация Программист Платформа 1С v8.3 Бесплатно (free)

Оказывается, в типовых конфигурациях 1С есть, что улучшить!

13.03.2024    6494    vasilev2015    20    

40

HighLoad оптимизация Инструменты администратора БД Системный администратор Программист Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Обработка для простого и удобного анализа настроек, нагрузки и проблем с SQL сервером с упором на использование оного для 1С. Анализ текущих запросов на sql, ожиданий, конвертация запроса в 1С и рекомендации, где может тормозить.

2 стартмани

15.02.2024    10233    207    ZAOSTG    74    

110

HighLoad оптимизация Системный администратор Программист Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Принимать, хранить и анализировать показания счетчиков (метрики) в базе 1С? Почему бы нет? Но это решение быстро привело к проблемам с производительностью при попытках построить какую-то более-менее сложную аналитику. Переход на PostgresSQL только временно решил проблему, т.к. количество записей уже исчислялось десятками миллионов и что-то сложное вычислить на таких объемах за разумное время становилось все сложнее. Кое-что уже практически невозможно. А что будет с производительностью через пару лет - представить страшно. Надо что-то предпринимать! В этой статье поделюсь своим первым опытом применения СУБД Clickhouse от Яндекс. Как работает, что может, как на нее планирую (если планирую) переходить, сравнение скорости работы, оценка производительности через пару лет, пример работы из 1С. Все это приправлено текстами запросов, кодом, алгоритмами выполненных действий и преподнесено вам для ознакомления в этой статье.

1 стартмани

24.01.2024    4426    glassman    17    

40

HighLoad оптимизация Программист Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Встал вопрос: как быстро удалить строки из ТЗ? Рассмотрел пять вариантов реализации этой задачи. Сравнил их друг с другом на разных объёмах данных с разным процентом удаляемых строк. Также сравнил с выгрузкой с отбором по структуре.

09.01.2024    9362    doom2good    49    

70
Оставьте свое сообщение