РИБ для УНФ

13.01.14

Интеграция - Обмен между базами 1C

Штатного механизма типового полного обмена (РИБ) нет. Добавляем этот функционал. Данный способ подойдет для типового релиза УНФ начиная с версии 1.4.7.37 или для конфигураций на основе БСП.

За основу взята статья: //infostart.ru/public/156559/

Для включения данного обмена необходимо будет добавить и изменить  следующие метаданные:

Подсистемы

 -СервисныеУслуги (изменить состав)

Общие модули 

 -ОбменДаннымиПереопределяемый (изменить типовую процедуру)

 -ОбменДаннымиПолный  

Планы обмена  

 -Полный   

Подписки на события   

 -ОбменДаннымиПолныйЗарегистрироватьИзменение   

 -ОбменДаннымиПолныйЗарегистрироватьИзменениеДокумента   

 -ОбменДаннымиПолныйЗарегистрироватьИзменениеКонстанты    

 -ОбменДаннымиПолныйЗарегистрироватьИзменениеНабораЗаписей    

 -ОбменДаннымиПолныйЗарегистрироватьУдаление   

Общие команды  

 -ВыполнитьОбменДанными    (изменить тип параметра команды)

 -НастроитьПараметрыТранспортаСообщенийОбмена (изменить тип параметра команды)   

 -ОткрытьПравилаРегистрацииОбъектов (изменить тип параметра команды)   

 -ОткрытьСценарииОбменовДанными  (изменить тип параметра команды)  

 -ПерейтиВЖурналРегистрацииСобытийВыгрузкиДанных (изменить тип параметра команды)   

 -ПерейтиВЖурналРегистрацииСобытийЗагрузкиДанных   (изменить тип параметра команды) 

 -ПолучитьНастройкиОбменаДаннымиДляВторойИнформационнойБазы  (изменить тип параметра команды) 

Справочники   

 -ИдентификаторыОбъектовМетаданных   (закоментировать часть процедуру). 


Общее дерево изменяемых метаданных:

 

За основу для дальнейшего упрощения можно использовать УТ 11 или модули с диска ИТС и БСП. В качестве упрощения также можно взять штатные обмены с БП и оттуда взять часть процедур,заменив в них обработчики на "заглушки".

Необходимые этапы доработки конфигурации:

1. Добавляем новый ПланОбмена:Полный или копируем из УТ 11.

    Обязательно ставим галку РИБ.

2. Редактируем состав плана обмена Полный.

Включаем в состав все объекты,исключив объекты,аналоличные в УТ.(Перечислять здесь долго,в основном Константы,Справочники,остальные все объекты).

Добавляем дополнительно:

Производственные календари и все объекты,связанные с расчетными задачами.

Общие виды объектов состава:

3. Отменяем авторегистрацию у всех объектов.

4. Включаем ПланОбмена Полный в подсистему: СервисныеФункции.

5. В модуль объекта ПланОбмена Полный вставляем код:


Перем КоличествоОбъектовЗагружено;
Перем
КоличествоОбъектовВыгружено;

Процедура
ПриОтправкеДанныхПодчиненному(ЭлементДанных, ОтправкаЭлемента, СозданиеНачальногоОбраза)
 
КоличествоОбъектовВыгружено = КоличествоОбъектовВыгружено + 1;
КонецПроцедуры

Процедура
ПриОтправкеДанныхГлавному(ЭлементДанных, ОтправкаЭлемента)
 
КоличествоОбъектовВыгружено = КоличествоОбъектовВыгружено + 1;
КонецПроцедуры

Процедура
ПриПолученииДанныхОтПодчиненного(ЭлементДанных, ПолучениеЭлемента, ОтправкаНазад)
 
КоличествоОбъектовЗагружено = КоличествоОбъектовЗагружено + 1;
КонецПроцедуры

Процедура
ПриПолученииДанныхОтГлавного(ЭлементДанных, ПолучениеЭлемента, ОтправкаНазад)
 
КоличествоОбъектовЗагружено = КоличествоОбъектовЗагружено + 1;
КонецПроцедуры

Процедура
ПередЗаписью(Отказ)
  Если
ОбменДаннымиСервер.НадоВыполнитьОбработчикПослеВыгрузкиДанных(ЭтотОбъект, Ссылка) Тогда
   
ПослеВыгрузкиДанных(Отказ);
  ИначеЕсли
ОбменДаннымиСервер.НадоВыполнитьОбработчикПослеЗагрузкиДанных(ЭтотОбъект, Ссылка) Тогда
   
ПослеЗагрузкиДанных(Отказ);
  КонецЕсли;
КонецПроцедуры

Процедура
ПослеВыгрузкиДанных(Отказ)

 
Сообщить("КоличествоОбъектовВыгружено: " + Строка(КоличествоОбъектовВыгружено));

КонецПроцедуры



Процедура
ПослеЗагрузкиДанных(Отказ)
 
Сообщить("КоличествоОбъектовЗагружено: " + Строка(КоличествоОбъектовЗагружено));
КонецПроцедуры

КоличествоОбъектовЗагружено = 0;
КоличествоОбъектовВыгружено = 0;

 6. В модуль менеджера ПланОбмена Полный вставляем код:

 Функция ПояснениеДляНастройкиПараметровУчета() Экспорт
     Возврат
"";
 КонецФункции

 Функция
ЗначенияПоУмолчаниюНаУзле(ВерсияКорреспондента, ИмяФормы) Экспорт
     Возврат Неопределено;
 КонецФункции

 Функция
ЗначенияПоУмолчаниюНаУзлеБазыКорреспондента(ВерсияКорреспондента, ИмяФормы) Экспорт
     Возврат Неопределено;
 КонецФункции

 Функция
ИмяФайлаНастроекДляПриемника() Экспорт
     Возврат
НСтр("ru = 'Настройки обмена УНФ-УНФ Полный обмен РИБ'");
 КонецФункции

 Функция
ИспользуемыеТранспортыСообщенийОбмена() Экспорт
    
Результат = Новый Массив;
    
Результат.Добавить(Перечисления.ВидыТранспортаСообщенийОбмена.FILE);
    
Результат.Добавить(Перечисления.ВидыТранспортаСообщенийОбмена.FTP);
     Возврат
Результат;
 КонецФункции

 Функция
ИмяФормыСозданияНачальногоОбраза() Экспорт
     Возврат
"ОбщаяФорма.СозданиеНачальногоОбразаСФайлами";
 КонецФункции

 Функция
ЗаголовокКомандыДляСозданияНовогоОбменаДанными() Экспорт
     Возврат
НСтр("ru = 'Создать обмен УНФ-УНФ(Полный) обмен РИБ'");
 КонецФункции

 Функция
ИспользоватьПомощникСозданияОбменаДанными() Экспорт
     Возврат Истина;
 КонецФункции

 Функция
НастройкаОтборовНаУзле(ВерсияКорреспондента, ИмяФормы) Экспорт
     Возврат Новый
Структура;
 КонецФункции

 Функция
НастройкаОтборовНаУзлеБазыКорреспондента(ВерсияКорреспондента, ИмяФормы) Экспорт
     Возврат Неопределено;
 КонецФункции

 Функция
ОписаниеЗначенийПоУмолчанию(ЗначенияПоУмолчаниюНаУзле, ВерсияКорреспондента) Экспорт
     Возврат
"";
 КонецФункции

 Функция
ОписаниеЗначенийПоУмолчаниюБазыКорреспондента(ЗначенияПоУмолчаниюНаУзле, ВерсияКорреспондента) Экспорт
     Возврат
"";
 КонецФункции

 Функция
ОписаниеОграниченийПередачиДанных(НастройкаОтборовНаУзле, ВерсияКорреспондента) Экспорт
     Возврат
"";
 КонецФункции

 Функция
ОписаниеОграниченийПередачиДанныхБазыКорреспондента(НастройкаОтборовНаУзле, ВерсияКорреспондента) Экспорт
     Возврат
"";
 КонецФункции

 Функция
КраткаяИнформацияПоОбмену() Экспорт
     Возврат
"Полный обмен РИБ УНФ-УНФ";
 КонецФункции

 Функция
ПодробнаяИнформацияПоОбмену() Экспорт
     Возврат
"Полный обмен РИБ между конфигурациями УНФ-УНФ"
 
КонецФункции

 Функция
ПланОбменаИспользуетсяВМоделиСервиса() Экспорт
     Возврат Ложь;
 КонецФункции

 Функция
ОбщиеДанныеУзлов(ВерсияКорреспондента, ИмяФормы) Экспорт
     Возврат
"ДатаНачалаВыгрузкиДокументов, Организации, РежимВыгрузкиПриНеобходимости, ЗагружатьДокументыИзБухгалтерииПредприятия, РучнойОбмен";
 КонецФункции

 Функция
РежимЗапускаСинхронизацииДанных(УзелИнформационнойБазы) Экспорт
     Возврат
"АвтоматическаяСинхронизация";
 КонецФункции

7. Создаем новый общий модуль ОбменДаннымиПолный (сервер,внешнее соединение) и вставляем в него код:

////////////////////////////////////////////////////////////////////////////////
// Обмен Полный

// Процедура-обработчик события "ПередЗаписью" ссылочных типов данных (кроме документов) для механизма регистрации объектов на узлах
//
// Параметры:
//  ИмяПланаОбмена – Строка – имя плана обмена, для которого выполняется механизм регистрации
//  Источник       - источник события, кроме типа ДокументОбъект
//  Отказ          - Булево - флаг отказа от выполнения обработчика
//
Процедура ОбменДаннымиПолныйПередЗаписью(Источник, Отказ) Экспорт
   
ОбменДаннымиСобытия.МеханизмРегистрацииОбъектовПередЗаписью("Полный", Источник, Отказ);
КонецПроцедуры

// Процедура-обработчик события "ПередЗаписью" документов для механизма регистрации объектов на узлах
//
// Параметры:
//  ИмяПланаОбмена – Строка – имя плана обмена, для которого выполняется механизм регистрации
//  Источник       - ДокументОбъект - источник события
//  Отказ          - Булево - флаг отказа от выполнения обработчика
//
Процедура ОбменДаннымиПолныйПередЗаписьюДокумента(Источник, Отказ, РежимЗаписи, РежимПроведения) Экспорт
   
ОбменДаннымиСобытия.МеханизмРегистрацииОбъектовПередЗаписьюДокумента("Полный", Источник, Отказ, РежимЗаписи, РежимПроведения);
КонецПроцедуры

// Процедура-обработчик события "ПередЗаписью" константы для механизма регистрации объектов на узлах
//
// Параметры:
//  ИмяПланаОбмена – Строка – имя плана обмена, для которого выполняется механизм регистрации
//  Источник       - КонстантаМенеджерЗначения - источник события
//  Отказ          - Булево - флаг отказа от выполнения обработчика
//
Процедура ОбменДаннымиПолныйПередЗаписьюКонстанты(Источник, Отказ) Экспорт
   
ОбменДаннымиСобытия.МеханизмРегистрацииОбъектовПередЗаписьюКонстанты("Полный", Источник, Отказ);
КонецПроцедуры

// Процедура-обработчик события "ПередЗаписью" регистров для механизма регистрации объектов на узлах
//
// Параметры:
//  ИмяПланаОбмена – Строка – имя плана обмена, для которого выполняется механизм регистрации
//  Источник       - НаборЗаписейРегистра - источник события
//  Отказ          - Булево - флаг отказа от выполнения обработчика
//  Замещение      - Булево - признак замещения существующего набора записей
//
Процедура ОбменДаннымиПолныйПередЗаписьюРегистра(Источник, Отказ, Замещение) Экспорт
   
ОбменДаннымиСобытия.МеханизмРегистрацииОбъектовПередЗаписьюРегистра("Полный", Источник, Отказ, Замещение);
КонецПроцедуры

// Процедура-обработчик события "ПередУдалением" ссылочных типов данных для механизма регистрации объектов на узлах
//
// Параметры:
//  ИмяПланаОбмена – Строка – имя плана обмена, для которого выполняется механизм регистрации
//  Источник       - источник события
//  Отказ          - Булево - флаг отказа от выполнения обработчика
//
Процедура ОбменДаннымиПолныйПередУдалением(Источник, Отказ) Экспорт
   
ОбменДаннымиСобытия.МеханизмРегистрацииОбъектовПередУдалением("Полный", Источник, Отказ);
КонецПроцедуры

8. Создаем ПодпискиНаСобытие и назначем для каждой одноименный обработчик из указанного выше модуля:

8.1.ОбменДаннымиПолныйЗарегистрироватьИзменение

Источник:

Все справочники,за исключением:

АвансовыйОтчетПрисоединенныеФайлы

ДоговорыКонтрагентовПрисоединенныеФайлы

ЗаданиеНаРаботуПрисоединенныеФайлы

ЗаказПокупателяПрисоединенныеФайлы

ЗаказПоставщикуПрисоединенныеФайлы

ИдентификаторыОбъектовМетаданных

ИнвентаризацияЗапасовПрисоединенныеФайлы

КлючевыеОперации

НоменклатураПрисоединенныеФайлы

ОрганизацииПрисоединенныеФайлы

ОчередьЗаданий

ОчередьЗаданийОбластейДанных

ПапкиФайловПрисоединенныеФайлы

ПоставляемыеДанные

ПоставляемыеДополнительныеОтчетыИОбработки

ПоступлениеНаСчетПрисоединенныеФайлы

ПриходнаяНакладнаяПрисоединенныеФайлы

ПроизводственныеКалендари

РасходСоСчетаПрисоединенныеФайлы

СообщенияОбластейДанных

СообщенияСистемы

СпецификацииПрисоединенныеФайлы

СценарииОбменовДанными

СчетНаОплатуПоставщикаПрисоединенныеФайлы

СчетФактураПолученныйПрисоединенныеФайлы

СчетФактураПрисоединенныеФайлы

ТомаХраненияФайлов

ЭДПрисоединенныеФайлы

Отметить все ПланВидовХарактеристикОбъект.

Событие: ПередЗаписью.

 

8.2.ОбменДаннымиПолныйЗарегистрироватьИзменениеДокумента

Источник: Все документы.

Событие: ПередЗаписью.


8.3.ОбменДаннымиПолныйЗарегистрироватьИзменениеКонстанты

Источник: КонстантаМенеджерЗначения,за исключением:

АдресАгентаСервиса

БлокировкаОтправкиБыстрыхСообщений

ВыполнитьРезервноеКопированиеОбластиДанных

ВыполнятьЗамерыПроизводительности

ВыполнятьПроверкуЭЦПНаСервере

ДатаОбновленияПовторноИспользуемыхЗначенийМРО

ДатаПоследнейВыгрузкиЗамеровПроизводительностиUTC

ДетализироватьОбновлениеИБВЖурналеРегистрации

ЗаголовокСистемы

ЗапрещатьЗагрузкуФайловПоРасширению

ЗарегистрированыИзмененияДанных

ИзвлекатьТекстыФайловНаСервере

ИмяСлужебногоПользователяМенеджераСервиса

ИспользоватьАвтономнуюРаботуВМоделиСервиса

ИспользоватьНапоминанияПользователя

ИспользоватьНесколькоПроизводственныхКалендарей

ИспользоватьОбменСПодключаемымОборудованиемOffline

ИспользоватьОтложеннуюОтправкуЭлектронныхДокументов

ИспользоватьПолнотекстовыйПоиск

ИспользоватьРазделениеПоОбластямДанных

ИспользоватьСинхронизациюДанных
ИспользоватьСинхронизациюДанныхВЛокальномРежиме
ИспользоватьСинхронизациюДанныхВМоделиСервиса
ИспользоватьСинхронизациюДанныхВМоделиСервисаСЛокальнойПрограммой
ИспользоватьСинхронизациюДанныхВМоделиСервисаСПриложениемВИнтернете

КаталогВременныхФайловДляLinux
КаталогВременныхФайловДляWindows
КлючОбластиДанных

КонечнаяТочкаМенеджераСервиса
КонтекстАвторизации
КонтекстКриптографии

КопироватьОбластиДанныхИзЭталонной

МаксимальнаяДлительностьВыполненияИсполняющегоФоновогоЗадания
МаксимальноеКоличествоИсполняющихФоновыхЗаданий
МаксимальныйРазмерФайла
МаксимальныйРазмерФайлаОбластиДанных
МинимальныйИнтервалРегламентныхЗаданийДополнительныхОтчетовИОбработокВМоделиСервиса
НастройкаАвтономногоРабочегоМестаЗавершена
НастройкаПодчиненногоУзлаРИБЗавершена
НастройкаПроксиСервера
НастройкиВыполненияРегламентныхЗаданий
НастройкиПодчиненногоУзлаРИБ

НезависимоеИспользованиеДополнительныхОтчетовИОбработокВМоделиСервиса
НеИспользоватьРазделениеПоОбластямДанных

ОбщийКаталогВременныхФайлов
ОбщийКаталогВременныхФайловLinux

ПараметрыАдминистрированияИБ

ПараметрыИтоговИАгрегатов
ПараметрыОграниченияДоступа
ПараметрыРаботыПользователей
ПараметрыСлужебныхСобытий
ПарольДляОтправкиSMS
ПарольПользователяАгентаСервиса

ПарольСлужебногоПользователяМенеджераСервиса

ПоддержкаРезервногоКопирования

ПредставлениеОбластиДанных
ПрефиксДляОбменаССайтом
ПрефиксОбластиДанных
ПрефиксПоследнегоАвтономногоРабочегоМеста
ПрефиксУзлаРаспределеннойИнформационнойБазы
ПровайдерSMS

РазделыОписанияИзмененийСистемы
РазмерБлокаПередачиФайла
РазрешитьВыполнениеДополнительныхОтчетовИОбработокРегламентнымиЗаданиямиВМоделиСервиса
РежимИспользованияИнформационнойБазы

СинхронизироватьДанныеСПриложениемВИнтернетеПриЗавершенииРаботыПрограммы
СинхронизироватьДанныеСПриложениемВИнтернетеПриНачалеРаботыПрограммы
СообщениеБлокировкиПриОбновленииКонфигурации
СообщениеОбменаДаннымиИзГлавногоУзла

СписокЗапрещенныхРасширений
СписокЗапрещенныхРасширенийОбластиДанных

СписокРасширенийФайловOpenDocument
СписокРасширенийФайловOpenDocumentОбластиДанных

СтатусОбновленияКонфигурации

ХранитьФайлыВТомахНаДиске
ЧасовойПоясОбластиДанных

ЭтоАвтономноеРабочееМесто

Событие: ПередЗаписью.

8.4.ОбменДаннымиПолныйЗарегистрироватьИзменениеНабораЗаписей

Источник:  Все РегистрыНакопленияНаборЗаписей.

РегистрСведенийНаборЗаписей, за исключением:

БлокировкиСеансовОбластейДанных

ВерсииПодсистем
ВерсииПодсистемОбластейДанных

ДанныеПроизводственногоКалендаря

ЗависимостиПравДоступа

ЗамерыВремени

ИзмененияОбщихДанныхУзлов

ИспользованиеПоставляемыхДополнительныхОтчетовИОбработокВОбластяхДанных

КэшПрограммныхИнтерфейсов

НапоминанияПользователя

НастройкиОтправителя

НастройкиТранспортаОбмена
НастройкиТранспортаОбменаОбластейДанных
НастройкиТранспортаОбменаОбластиДанных
НеразделенныеПользователи

ОбластиДанных
ОбластиПерсональныхДанных
ОбластиТребующиеОбработкиПоставляемыхДанных
ОбщиеНастройкиУзловИнформационныхБаз

ОчередьИзвлеченияТекста
ОчередьИнсталляцииПоставляемыхДополнительныхОтчетовИОбработокВОбластиДанных

ПодпискиПолучателей

ПоставляемыеДанныеТребующиеОбработки
ПраваПоЗначениямДоступа
ПраваРолей
ПравилаДляОбменаДанными

ПутиМодулейКриптографииСерверовLinux
РабочиеКаталогиФайлов
РезультатыОбменаДанными
РейтингАктивностиОбластейДанных
РучныеИзмененияГрафиковРаботы
СессииОбменаСообщениямиСистемы

СообщенияОбменаДанными
СообщенияОбменаДаннымиОбластейДанных
СоответствияОбъектовИнформационныхБаз

СостоянияОбменовДанными
СостоянияОбменовДаннымиОбластейДанных

СостоянияУспешныхОбменовДанными
СостоянияУспешныхОбменовДаннымиОбластейДанных

УдалитьОбластиДанных
УдалитьОбластиКРезервномуКопированию
УдалитьОчередьЗаданий

ФайлыВРабочемКаталоге

Событие: ПередЗаписью.

8.5.ОбменДаннымиПолныйЗарегистрироватьУдаление

Источник: Все ПланВидовХарактеристикОбъект,ДокументОбъект.

СправочникОбъект,за исключением:

ДоговорыКонтрагентовПрисоединенныеФайлы

ЗаданиеНаРаботуПрисоединенныеФайлы
ЗаказПокупателяПрисоединенныеФайлы
ЗаказПоставщикуПрисоединенныеФайлы

ИнвентаризацияЗапасовПрисоединенныеФайлы

КлючевыеОперации

КонтрагентыПрисоединенныеФайлы

НоменклатураПрисоединенныеФайлы

ОрганизацииПрисоединенныеФайлы
ОчередьЗаданий
ОчередьЗаданийОбластейДанных

ПапкиФайловПрисоединенныеФайлы

ПолныеПутиКФормам

ПоставляемыеДанные
ПоставляемыеДополнительныеОтчетыИОбработки
ПоступлениеНаСчетПрисоединенныеФайлы

ПредопределенныеВариантыОтчетов
ПриходнаяНакладнаяПрисоединенныеФайлы

ПроизводственныеКалендари

РасходСоСчетаПрисоединенныеФайлы

СценарииОбменовДанными
СчетНаОплатуПоставщикаПрисоединенныеФайлы
СчетФактураПолученныйПрисоединенныеФайлы
СчетФактураПрисоединенныеФайлы

Ячейки

Событие: ПередУдалением.

9. В общем модуле  ОбменДаннымиПереопределяемый  в процедуру ПолучитьПланыОбмена в конце процедуры добавить:

ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.Полный);

 

10. В Общие команды  добавить новый тип параметра команды:ПланОбменасСсылка.Полный.

     для команд:

    ВыполнитьОбменДанными    

    НастроитьПараметрыТранспортаСообщенийОбмена    

    ОткрытьПравилаРегистрацииОбъектов    

    ПерейтиВЖурналРегистрацииСобытийВыгрузкиДанных    

    ПерейтиВЖурналРегистрацииСобытийЗагрузкиДанных    

    ПолучитьНастройкиОбменаДаннымиДляВторойИнформационнойБазы  

 

На этом этапе все необходимые доработки внедрены,осталось только установить префикс у ИБ и создать новую настройку сихронизацию через Мастер.

 

Также можно вручную создать начальный образ ИБ через ПланыОбмена.

 

   На этом все,можно пользоваться обменом. Тестировалось на релизе УНФ 1.4.7.37.

РИБ УНФ распределенная информационная база обмен Полный синхронизация

См. также

SALE! 10%

Синхронизация и обмен для ERP 2.5, КА 2.5, УТ 11.5 БП 3.0, Розница, УНФ и других с EnterpriseData (универсальный формат обмена), правила обмена

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен и синхронизацию в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 22572 руб.

12.06.2017    136412    733    291    

393

Перенос данных из УПП 1.3 в ERP 2 / УТ 11 / КА 2. Переносятся документы, справочная информация и остатки

Перенос данных 1C Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос документов, начальных остатков и справочной информации из УПП 1.3 в ERP 2 | из УПП 1.3 в УТ 11 | из УПП в КА 2 | Правила конвертации (КД 2) в продаже с 2015 года, постоянно работаем над их развитием | Более 360 предприятий выполнили переход с использованием этого продукта! | Сэкономьте время - используйте готовое решение для перехода! | Позволяет перенести из УПП 1.3 в ERP / УТ 11 / КА 2 всю возможную информацию | В переносе есть фильтр по организации и множество других опциональных параметров выгрузки | Есть несколько алгоритмов выгрузки остатков на выбор

45650 руб.

04.08.2015    161238    359    269    

350

Перенос данных из БП 3.0 в УТ 11 / КА 2 / ERP 2. Переносятся начальные остатки, документы и справочники

Перенос данных 1C Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

В продаже с 2014г. | Воспользовались более 122 предприятий! | Перенос данных из БП 3.0 в УТ 11 | из БП 3.0 в КА 2 | из БП 3.0 в ERP | Сэкономьте свое время - используйте готовое решение для перехода! | Постоянно работаем над развитием переноса данных | Обновляем на новые релизы 1С | Есть фильтр выгрузки по организациям | Переносятся начальные остатки на выбранную дату, документы за период времени и вся возможная справочная информация | Перенос сделан на технологии КД 2 (правила конвертации данных)

45650 руб.

31.10.2014    233100    91    328    

299

Перенос данных из ERP 2 / КА 2 / УТ 11 в БП 3.0. Переносятся документы, начальные остатки и справочники

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

34650 руб.

15.04.2019    69442    166    141    

112

SALE! 10%

Перенос данных из УТ 10.3 в УТ 11.5. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3 (10.3.87.x) и УТ 11.5 (11.5.16.x).

28000 25200 руб.

23.07.2020    47433    202    64    

163

SALE! 10%

Перенос данных из УПП 1.3 в БП 3.0. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.226.x) и БП 3.0 (3.0.151.x). Правила подходят для версии ПРОФ и КОРП.

28000 25200 руб.

15.12.2021    21004    137    38    

96

Перенос данных из ERP 2 / КА 2 в ЗУП 3. Переносятся остатки, документы и справочники

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из ERP в ЗУП 3 | из КА 2 в ЗУП | Воспользовались более 79 предприятий! | Предлагаем приобрести готовые правила конвертации данных (КД 2) для переноса остатков, документов с движениями и справочной информации 3 | В продаже с 2020г. | Оперативно обновляем правила до актуальных релизов 1С | Есть перенос начальной задолженности по зарплате и начальной штатной расстановки на выбранную дату | Обороты за прошлые годы (данные для расчета среднего) переносятся свернуто в документ "Перенос данных" | Есть фильтр по организациям | Документы за текущий период переносятся сразу с движениями, поэтому не потребуется делать перерасчеты | Перенос можно проверить перед покупкой, обращайтесь!

43450 руб.

03.12.2020    34771    83    58    

81

SALE! 10%

Перенос данных из УПП 1.3 в ERP 2.5, КА 2.5. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:ERP Управление предприятием 2.5 и 1С:Комплексную автоматизацию 2.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x), ERP 2.5 (2.5.16.x), КА 2.5 (2.5.16.x) .

28000 25200 руб.

24.06.2020    61630    44    27    

75
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. gull22 95 15.01.14 12:49 Сейчас в теме
2. sudo90 09.02.14 12:59 Сейчас в теме
Уточните пожалуйста что нужно закоментировать в Справочнике ИдентификаторыОбъектовМетаданных, в статье не увидел.

Заранее спасибо
3. ZhAmAn 50 09.02.14 15:45 Сейчас в теме
(2) sudo90,
В процедуре модуля объекта ПередЗаписью:
//Если ОбщегоНазначения.ЭтоПодчиненныйУзелРИБ() Тогда
//
// Если ЭтоНовый() Тогда
// ВызватьИсключениеПоОшибке(
// НСтр("ru = 'Добавление новых элементов может быть выполнено
// |только в главном узле распределенной информационной базы.'"));
// КонецЕсли;
//
// Если НЕ ПометкаУдаления Тогда
// Если ВРег(ПолноеИмя) <> ВРег(ОбщегоНазначения.ПолучитьЗначениеРеквизита(Ссылка, "ПолноеИмя")) Тогда
// ВызватьИсключениеПоОшибке(
// НСтр("ru = 'Изменение реквизита ""Полное имя"" может быть выполнено
// |только в главном узле распределенной информационной базы.'"));
// КонецЕсли;
// КонецЕсли;
//КонецЕсли;
//

sart-b@mail.ru; kosta_ks; sudo90; +3 Ответить
4. sudo90 14.02.14 09:58 Сейчас в теме
5. alexanderal 12.03.14 16:48 Сейчас в теме
ПодпискаНаСобытие.ОбменДаннымиПолныйЗарегистрироватьИзменение: Обработчик события должен быть задан
ПодпискаНаСобытие.ОбменДаннымиПолныйЗарегистрироватьИзменениеДокумента: Обработчик события должен быть задан
ПодпискаНаСобытие.ОбменДаннымиПолныйЗарегистрироватьИзменениеКонстанты: Обработчик события должен быть задан
ПодпискаНаСобытие.ОбменДаннымиПолныйЗарегистрироватьИзменениеНабораЗаписей: Обработчик события должен быть задан
ПодпискаНаСобытие.ОбменДаннымиПолныйЗарегистрироватьУдаление: Обработчик события должен быть задан

не нахожу где в тексте об обработчиках есть
6. alexanderal 31.03.14 14:22 Сейчас в теме
разобрался, заработала, только инструкция немного неполная... надфилем пришлось обработать и открытый вопрос остался с плпном счетов - новые счета не уходят в перефирийку ... чешим репу... ищем где... может кто то решал - подскажите
7. goshua 08.10.14 19:35 Сейчас в теме
(6) alexanderal, так что там в обработчиках надо указать?
11. Ygich 129 29.12.15 21:26 Сейчас в теме
(6) alexanderal, нужно добавить новую подписку на событие изменения плана счетов. Либо в подписке ОбменДаннымиПолныйЗарегистрироватьИзменение поставить галку план счетов управленческий.
8. kosikov_oleg 31.01.15 08:25 Сейчас в теме
Спасибо за полезную статью.

Подскажите, пожалуйста, как бороться со следующей проблемой.
При первоначальном старте подчиненного узла добавляется "Администратор", а потом после атоперезапуска вылетает ошибка


{ОбщийМодуль.Пользователи.Модуль(620)}: Ошибка при вызове метода контекста (Записать)
Пользователь.Записать();
по причине:
Ошибка при выполнении обработчика - 'ПередЗаписью'
по причине:
{ОбщийМодуль.ОбменДаннымиСервер.Модуль(7708)}: Ошибка при вызове метода контекста (Записать)
НаборЗаписей.Записать();
по причине:
Ошибка при выполнении обработчика - 'ПередЗаписью'
по причине:
{ОбщийМодуль.ПользователиСлужебный.Модуль(316)}: Авторизация не выполнена. Работа системы будет завершена.
Пользователь: Администратор не найден в справочнике "Пользователи".

При попытке добавления пользователя в справочник возникла ошибка:
"Попытка получения неинициализированного значения параметра сеанса".

Обратитесь к администратору.
ВызватьИсключение ТекстСообщенияОбОшибке;
9. titanium2008 43 20.11.15 12:41 Сейчас в теме
Добрый день, кто нибудь для 1.5 реализовывал?
10. comptr 33 20.11.15 12:47 Сейчас в теме
(9) titanium2008, месяца два назад делал обновление УНФ 1.4, где уже был реализован РИБ подобным образом, до 1.5. Сейчас уже точно не вспомню, что именно делал, но принцип простой - запускаешь, получаешь ошибку, смотришь на неё, смотришь в код УТ 11, перетаскиваешь оттуда и пробуешь опять. Пару-тройку итераций и оно работает. Можно сразу смотреть код УТ 11 и тянуть оттуда. Насколько помню, там некоторые методы поменялись, некоторые добавились.
12. mind-rubbish 16.06.16 15:30 Сейчас в теме
Кто-нибудь может ответить, уважаемые, что делать с РИБ для УНФ 1.6? Я стала делать по данной статье, тестово сделала для 1.4, вроде все нормально было (Честно говоря, я столько раз уже пробовала и переделывала, что запуталась даже в количестве и какие ошибки на каких версиях были).. Но в УНФ 1.6, а конкретно 1.6.4.27, я вижу следующее - появились разные документы новые и справочники и тд, и я естественно оставляла на них подписку, может быть кто-то знает логику, почему на некоторые объекты в подписке на события снимается галка?

Плюс второй момент - Глобальные команды. Некоторых команд нет в УНФ 1.6, а именно:

ВыполнитьОбменДанными - есть в УНФ 1.5
НастроитьПараметрыТранспортаСообщенийОбмена - есть в УНФ 1.6
ОткрытьПравилаРегистрацииОбъектов - есть в УНФ 1.5
ПерейтиВЖурналРегистрацииСобытийВыгрузкиДанных - есть в УНФ 1.5
ПерейтиВЖурналРегистрацииСобытийЗагрузкиДанных - есть в УНФ 1.5
ПолучитьНастройкиОбменаДаннымиДляВторойИнформационнойБазы - в УНФ 1.5 это есть, в УНФ 1.6 есть похожее - ПолучитьНастройкиОбменаДанныхДляДругойПрограммы. Судя по комментариям это одно и то же.

Но все равно не ясно - просто добавить эти команды из УНФ 1.5 или УНФ 1.4?

Еще для таких невнимательных как я - в модуле менеджера появились дополнительные параметры в некоторых функциях, я первый раз просто заменяла функции на те, которые в этой статье, в общем сама виновата =) Зато в справочнике ИдентификаторыОбъектовМетаданных больше нечего комментировать - там всего одна строчка
13. alexstav 8 01.08.16 09:20 Сейчас в теме
Присоединяюсь к вопросу. Как настроить для 1.6?
14. Shaldryn 08.11.16 15:08 Сейчас в теме
Кто нибудь делал это в 1.6? Сделал, РИБ запускается, но проблема в том что разделы не все отображает и добавить невозможно, из списка доступных нет
15. vitalya24 239 06.12.16 17:45 Сейчас в теме
делал, не без напильника, но взлетело, спасибо
16. TMV 14 09.12.16 10:37 Сейчас в теме
(15), если в виде публикации оформлено, есть ссылка?
17. margo2007 15 12.12.16 05:03 Сейчас в теме
Кто нибудь разобрался, как отобразить разделы?
18. n.s.gnedash 3 03.07.17 12:15 Сейчас в теме
Делаю настройку в УНФ 1.4. Сделал начальный образ, когда из главного узла делаю синхронизацию, получаю ошибку Для состава плана обмена Полный не указана регистрация объекта РегистрСведений.СостоянияОбменовДанными, но по инструкции данный регистр не включен. Как победить ошибку?
19. vas2005 8 02.02.18 01:55 Сейчас в теме
Всем доброго времени!!!
Подскажите, не могу понять, что надо сделать с пунктом
10. В Общие команды добавить новый тип параметра команды:ПланОбменасСсылка.Полный.
...????
Что именно надо вставить для команд:

ВыполнитьОбменДанными

НастроитьПараметрыТранспортаСообщенийОбмена

ОткрытьПравилаРегистрацииОбъектов

ПерейтиВЖурналРегистрацииСобытийВыгрузкиДанных

ПерейтиВЖурналРегистрацииСобытийЗагрузкиДанных

ПолучитьНастройкиОбменаДаннымиДляВторойИнформационнойБазы


Заранее спасибо!!!
20. Shaldryn 02.02.18 10:21 Сейчас в теме
(19) с версии 1.6.11 1С:Управление нашей фирмой поддерживает механизм распределенных информационных баз (РИБ)
21. vas2005 8 03.02.18 00:41 Сейчас в теме
(20) У меня конфигурация 1С:Предприятие 8. Автосервис (1.4.9.27), она на основе Управление нашей фирмой, и обновить до версии 1.6.11 пока нет возможности, вот и стоит задача доработать имеющуюся
22. Shaldryn 05.02.18 08:33 Сейчас в теме
(21) В 10 пункте написано добавить тип параметра команды, в указанных командах зайдите в свойства и там будет этот пункт и меняйте его
23. vas2005 8 09.02.18 23:31 Сейчас в теме
(22) Спасибо, разобрался, теперь буду дальше пробовать)))
24. vas2005 8 09.02.18 23:45 Сейчас в теме
Продолжает ругаться(((

{ОбщийМодуль.ОбменДаннымиСервер.Модуль(7642)}: Ошибка при вызове метода контекста (Записать)
НаборЗаписей.Записать();
по причине:
Не удалось записать: "Состояния успешных обменов данными"!
25. baracuda 2 09.02.18 23:52 Сейчас в теме
Использовать РИБ для УНФ утопия...
26. vas2005 8 10.02.18 00:39 Сейчас в теме
(25)Посоветуй что делать для объединения филиалов..???
РДП не устраивает, интернет часто отваливается(((
27. vas2005 8 10.02.18 00:43 Сейчас в теме
Процесс сдвинулся с мёртвой точки)))
Создание первичного прошло успешно, но при попытке первой синхронизации возникла ошибка

Не удалось записать: "Префикс информационной базы"!

Подскажите куда теперь копать..???
28. ptkrzy 94 18.04.18 17:48 Сейчас в теме
Оставьте свое сообщение