РИБ для УНФ

Публикация № 249881

Разработка - Обмен данными 1С - Распределенная БД (УРИБ, УРБД)

РИБ УНФ распределенная информационная база обмен Полный синхронизация

Штатного механизма типового полного обмена (РИБ) нет. Добавляем этот функционал. Данный способ подойдет для типового релиза УНФ начиная с версии 1.4.7.37 или для конфигураций на основе БСП.

За основу взята статья: //infostart.ru/public/156559/

Для включения данного обмена необходимо будет добавить и изменить  следующие метаданные:

Подсистемы

 -СервисныеУслуги (изменить состав)

Общие модули 

 -ОбменДаннымиПереопределяемый (изменить типовую процедуру)

 -ОбменДаннымиПолный  

Планы обмена  

 -Полный   

Подписки на события   

 -ОбменДаннымиПолныйЗарегистрироватьИзменение   

 -ОбменДаннымиПолныйЗарегистрироватьИзменениеДокумента   

 -ОбменДаннымиПолныйЗарегистрироватьИзменениеКонстанты    

 -ОбменДаннымиПолныйЗарегистрироватьИзменениеНабораЗаписей    

 -ОбменДаннымиПолныйЗарегистрироватьУдаление   

Общие команды  

 -ВыполнитьОбменДанными    (изменить тип параметра команды)

 -НастроитьПараметрыТранспортаСообщенийОбмена (изменить тип параметра команды)   

 -ОткрытьПравилаРегистрацииОбъектов (изменить тип параметра команды)   

 -ОткрытьСценарииОбменовДанными  (изменить тип параметра команды)  

 -ПерейтиВЖурналРегистрацииСобытийВыгрузкиДанных (изменить тип параметра команды)   

 -ПерейтиВЖурналРегистрацииСобытийЗагрузкиДанных   (изменить тип параметра команды) 

 -ПолучитьНастройкиОбменаДаннымиДляВторойИнформационнойБазы  (изменить тип параметра команды) 

Справочники   

 -ИдентификаторыОбъектовМетаданных   (закоментировать часть процедуру). 


Общее дерево изменяемых метаданных:

 

За основу для дальнейшего упрощения можно использовать УТ 11 или модули с диска ИТС и БСП. В качестве упрощения также можно взять штатные обмены с БП и оттуда взять часть процедур,заменив в них обработчики на "заглушки".

Необходимые этапы доработки конфигурации:

1. Добавляем новый ПланОбмена:Полный или копируем из УТ 11.

    Обязательно ставим галку РИБ.

2. Редактируем состав плана обмена Полный.

Включаем в состав все объекты,исключив объекты,аналоличные в УТ.(Перечислять здесь долго,в основном Константы,Справочники,остальные все объекты).

Добавляем дополнительно:

Производственные календари и все объекты,связанные с расчетными задачами.

Общие виды объектов состава:

3. Отменяем авторегистрацию у всех объектов.

4. Включаем ПланОбмена Полный в подсистему: СервисныеФункции.

5. В модуль объекта ПланОбмена Полный вставляем код:


Перем КоличествоОбъектовЗагружено;
Перем
КоличествоОбъектовВыгружено;

Процедура
ПриОтправкеДанныхПодчиненному(ЭлементДанных, ОтправкаЭлемента, СозданиеНачальногоОбраза)
 
КоличествоОбъектовВыгружено = КоличествоОбъектовВыгружено + 1;
КонецПроцедуры

Процедура
ПриОтправкеДанныхГлавному(ЭлементДанных, ОтправкаЭлемента)
 
КоличествоОбъектовВыгружено = КоличествоОбъектовВыгружено + 1;
КонецПроцедуры

Процедура
ПриПолученииДанныхОтПодчиненного(ЭлементДанных, ПолучениеЭлемента, ОтправкаНазад)
 
КоличествоОбъектовЗагружено = КоличествоОбъектовЗагружено + 1;
КонецПроцедуры

Процедура
ПриПолученииДанныхОтГлавного(ЭлементДанных, ПолучениеЭлемента, ОтправкаНазад)
 
КоличествоОбъектовЗагружено = КоличествоОбъектовЗагружено + 1;
КонецПроцедуры

Процедура
ПередЗаписью(Отказ)
  Если
ОбменДаннымиСервер.НадоВыполнитьОбработчикПослеВыгрузкиДанных(ЭтотОбъект, Ссылка) Тогда
   
ПослеВыгрузкиДанных(Отказ);
  ИначеЕсли
ОбменДаннымиСервер.НадоВыполнитьОбработчикПослеЗагрузкиДанных(ЭтотОбъект, Ссылка) Тогда
   
ПослеЗагрузкиДанных(Отказ);
  КонецЕсли;
КонецПроцедуры

Процедура
ПослеВыгрузкиДанных(Отказ)

 
Сообщить("КоличествоОбъектовВыгружено: " + Строка(КоличествоОбъектовВыгружено));

КонецПроцедуры



Процедура
ПослеЗагрузкиДанных(Отказ)
 
Сообщить("КоличествоОбъектовЗагружено: " + Строка(КоличествоОбъектовЗагружено));
КонецПроцедуры

КоличествоОбъектовЗагружено = 0;
КоличествоОбъектовВыгружено = 0;

 6. В модуль менеджера ПланОбмена Полный вставляем код:

 Функция ПояснениеДляНастройкиПараметровУчета() Экспорт
     Возврат
"";
 КонецФункции

 Функция
ЗначенияПоУмолчаниюНаУзле(ВерсияКорреспондента, ИмяФормы) Экспорт
     Возврат Неопределено;
 КонецФункции

 Функция
ЗначенияПоУмолчаниюНаУзлеБазыКорреспондента(ВерсияКорреспондента, ИмяФормы) Экспорт
     Возврат Неопределено;
 КонецФункции

 Функция
ИмяФайлаНастроекДляПриемника() Экспорт
     Возврат
НСтр("ru = 'Настройки обмена УНФ-УНФ Полный обмен РИБ'");
 КонецФункции

 Функция
ИспользуемыеТранспортыСообщенийОбмена() Экспорт
    
Результат = Новый Массив;
    
Результат.Добавить(Перечисления.ВидыТранспортаСообщенийОбмена.FILE);
    
Результат.Добавить(Перечисления.ВидыТранспортаСообщенийОбмена.FTP);
     Возврат
Результат;
 КонецФункции

 Функция
ИмяФормыСозданияНачальногоОбраза() Экспорт
     Возврат
"ОбщаяФорма.СозданиеНачальногоОбразаСФайлами";
 КонецФункции

 Функция
ЗаголовокКомандыДляСозданияНовогоОбменаДанными() Экспорт
     Возврат
НСтр("ru = 'Создать обмен УНФ-УНФ(Полный) обмен РИБ'");
 КонецФункции

 Функция
ИспользоватьПомощникСозданияОбменаДанными() Экспорт
     Возврат Истина;
 КонецФункции

 Функция
НастройкаОтборовНаУзле(ВерсияКорреспондента, ИмяФормы) Экспорт
     Возврат Новый
Структура;
 КонецФункции

 Функция
НастройкаОтборовНаУзлеБазыКорреспондента(ВерсияКорреспондента, ИмяФормы) Экспорт
     Возврат Неопределено;
 КонецФункции

 Функция
ОписаниеЗначенийПоУмолчанию(ЗначенияПоУмолчаниюНаУзле, ВерсияКорреспондента) Экспорт
     Возврат
"";
 КонецФункции

 Функция
ОписаниеЗначенийПоУмолчаниюБазыКорреспондента(ЗначенияПоУмолчаниюНаУзле, ВерсияКорреспондента) Экспорт
     Возврат
"";
 КонецФункции

 Функция
ОписаниеОграниченийПередачиДанных(НастройкаОтборовНаУзле, ВерсияКорреспондента) Экспорт
     Возврат
"";
 КонецФункции

 Функция
ОписаниеОграниченийПередачиДанныхБазыКорреспондента(НастройкаОтборовНаУзле, ВерсияКорреспондента) Экспорт
     Возврат
"";
 КонецФункции

 Функция
КраткаяИнформацияПоОбмену() Экспорт
     Возврат
"Полный обмен РИБ УНФ-УНФ";
 КонецФункции

 Функция
ПодробнаяИнформацияПоОбмену() Экспорт
     Возврат
"Полный обмен РИБ между конфигурациями УНФ-УНФ"
 
КонецФункции

 Функция
ПланОбменаИспользуетсяВМоделиСервиса() Экспорт
     Возврат Ложь;
 КонецФункции

 Функция
ОбщиеДанныеУзлов(ВерсияКорреспондента, ИмяФормы) Экспорт
     Возврат
"ДатаНачалаВыгрузкиДокументов, Организации, РежимВыгрузкиПриНеобходимости, ЗагружатьДокументыИзБухгалтерииПредприятия, РучнойОбмен";
 КонецФункции

 Функция
РежимЗапускаСинхронизацииДанных(УзелИнформационнойБазы) Экспорт
     Возврат
"АвтоматическаяСинхронизация";
 КонецФункции

7. Создаем новый общий модуль ОбменДаннымиПолный (сервер,внешнее соединение) и вставляем в него код:

////////////////////////////////////////////////////////////////////////////////
// Обмен Полный

// Процедура-обработчик события "ПередЗаписью" ссылочных типов данных (кроме документов) для механизма регистрации объектов на узлах
//
// Параметры:
//  ИмяПланаОбмена – Строка – имя плана обмена, для которого выполняется механизм регистрации
//  Источник       - источник события, кроме типа ДокументОбъект
//  Отказ          - Булево - флаг отказа от выполнения обработчика
//
Процедура ОбменДаннымиПолныйПередЗаписью(Источник, Отказ) Экспорт
   
ОбменДаннымиСобытия.МеханизмРегистрацииОбъектовПередЗаписью("Полный", Источник, Отказ);
КонецПроцедуры

// Процедура-обработчик события "ПередЗаписью" документов для механизма регистрации объектов на узлах
//
// Параметры:
//  ИмяПланаОбмена – Строка – имя плана обмена, для которого выполняется механизм регистрации
//  Источник       - ДокументОбъект - источник события
//  Отказ          - Булево - флаг отказа от выполнения обработчика
//
Процедура ОбменДаннымиПолныйПередЗаписьюДокумента(Источник, Отказ, РежимЗаписи, РежимПроведения) Экспорт
   
ОбменДаннымиСобытия.МеханизмРегистрацииОбъектовПередЗаписьюДокумента("Полный", Источник, Отказ, РежимЗаписи, РежимПроведения);
КонецПроцедуры

// Процедура-обработчик события "ПередЗаписью" константы для механизма регистрации объектов на узлах
//
// Параметры:
//  ИмяПланаОбмена – Строка – имя плана обмена, для которого выполняется механизм регистрации
//  Источник       - КонстантаМенеджерЗначения - источник события
//  Отказ          - Булево - флаг отказа от выполнения обработчика
//
Процедура ОбменДаннымиПолныйПередЗаписьюКонстанты(Источник, Отказ) Экспорт
   
ОбменДаннымиСобытия.МеханизмРегистрацииОбъектовПередЗаписьюКонстанты("Полный", Источник, Отказ);
КонецПроцедуры

// Процедура-обработчик события "ПередЗаписью" регистров для механизма регистрации объектов на узлах
//
// Параметры:
//  ИмяПланаОбмена – Строка – имя плана обмена, для которого выполняется механизм регистрации
//  Источник       - НаборЗаписейРегистра - источник события
//  Отказ          - Булево - флаг отказа от выполнения обработчика
//  Замещение      - Булево - признак замещения существующего набора записей
//
Процедура ОбменДаннымиПолныйПередЗаписьюРегистра(Источник, Отказ, Замещение) Экспорт
   
ОбменДаннымиСобытия.МеханизмРегистрацииОбъектовПередЗаписьюРегистра("Полный", Источник, Отказ, Замещение);
КонецПроцедуры

// Процедура-обработчик события "ПередУдалением" ссылочных типов данных для механизма регистрации объектов на узлах
//
// Параметры:
//  ИмяПланаОбмена – Строка – имя плана обмена, для которого выполняется механизм регистрации
//  Источник       - источник события
//  Отказ          - Булево - флаг отказа от выполнения обработчика
//
Процедура ОбменДаннымиПолныйПередУдалением(Источник, Отказ) Экспорт
   
ОбменДаннымиСобытия.МеханизмРегистрацииОбъектовПередУдалением("Полный", Источник, Отказ);
КонецПроцедуры

8. Создаем ПодпискиНаСобытие и назначем для каждой одноименный обработчик из указанного выше модуля:

8.1.ОбменДаннымиПолныйЗарегистрироватьИзменение

Источник:

Все справочники,за исключением:

АвансовыйОтчетПрисоединенныеФайлы

ДоговорыКонтрагентовПрисоединенныеФайлы

ЗаданиеНаРаботуПрисоединенныеФайлы

ЗаказПокупателяПрисоединенныеФайлы

ЗаказПоставщикуПрисоединенныеФайлы

ИдентификаторыОбъектовМетаданных

ИнвентаризацияЗапасовПрисоединенныеФайлы

КлючевыеОперации

НоменклатураПрисоединенныеФайлы

ОрганизацииПрисоединенныеФайлы

ОчередьЗаданий

ОчередьЗаданийОбластейДанных

ПапкиФайловПрисоединенныеФайлы

ПоставляемыеДанные

ПоставляемыеДополнительныеОтчетыИОбработки

ПоступлениеНаСчетПрисоединенныеФайлы

ПриходнаяНакладнаяПрисоединенныеФайлы

ПроизводственныеКалендари

РасходСоСчетаПрисоединенныеФайлы

СообщенияОбластейДанных

СообщенияСистемы

СпецификацииПрисоединенныеФайлы

СценарииОбменовДанными

СчетНаОплатуПоставщикаПрисоединенныеФайлы

СчетФактураПолученныйПрисоединенныеФайлы

СчетФактураПрисоединенныеФайлы

ТомаХраненияФайлов

ЭДПрисоединенныеФайлы

Отметить все ПланВидовХарактеристикОбъект.

Событие: ПередЗаписью.

 

8.2.ОбменДаннымиПолныйЗарегистрироватьИзменениеДокумента

Источник: Все документы.

Событие: ПередЗаписью.


8.3.ОбменДаннымиПолныйЗарегистрироватьИзменениеКонстанты

Источник: КонстантаМенеджерЗначения,за исключением:

АдресАгентаСервиса

БлокировкаОтправкиБыстрыхСообщений

ВыполнитьРезервноеКопированиеОбластиДанных

ВыполнятьЗамерыПроизводительности

ВыполнятьПроверкуЭЦПНаСервере

ДатаОбновленияПовторноИспользуемыхЗначенийМРО

ДатаПоследнейВыгрузкиЗамеровПроизводительностиUTC

ДетализироватьОбновлениеИБВЖурналеРегистрации

ЗаголовокСистемы

ЗапрещатьЗагрузкуФайловПоРасширению

ЗарегистрированыИзмененияДанных

ИзвлекатьТекстыФайловНаСервере

ИмяСлужебногоПользователяМенеджераСервиса

ИспользоватьАвтономнуюРаботуВМоделиСервиса

ИспользоватьНапоминанияПользователя

ИспользоватьНесколькоПроизводственныхКалендарей

ИспользоватьОбменСПодключаемымОборудованиемOffline

ИспользоватьОтложеннуюОтправкуЭлектронныхДокументов

ИспользоватьПолнотекстовыйПоиск

ИспользоватьРазделениеПоОбластямДанных

ИспользоватьСинхронизациюДанных
ИспользоватьСинхронизациюДанныхВЛокальномРежиме
ИспользоватьСинхронизациюДанныхВМоделиСервиса
ИспользоватьСинхронизациюДанныхВМоделиСервисаСЛокальнойПрограммой
ИспользоватьСинхронизациюДанныхВМоделиСервисаСПриложениемВИнтернете

КаталогВременныхФайловДляLinux
КаталогВременныхФайловДляWindows
КлючОбластиДанных

КонечнаяТочкаМенеджераСервиса
КонтекстАвторизации
КонтекстКриптографии

КопироватьОбластиДанныхИзЭталонной

МаксимальнаяДлительностьВыполненияИсполняющегоФоновогоЗадания
МаксимальноеКоличествоИсполняющихФоновыхЗаданий
МаксимальныйРазмерФайла
МаксимальныйРазмерФайлаОбластиДанных
МинимальныйИнтервалРегламентныхЗаданийДополнительныхОтчетовИОбработокВМоделиСервиса
НастройкаАвтономногоРабочегоМестаЗавершена
НастройкаПодчиненногоУзлаРИБЗавершена
НастройкаПроксиСервера
НастройкиВыполненияРегламентныхЗаданий
НастройкиПодчиненногоУзлаРИБ

НезависимоеИспользованиеДополнительныхОтчетовИОбработокВМоделиСервиса
НеИспользоватьРазделениеПоОбластямДанных

ОбщийКаталогВременныхФайлов
ОбщийКаталогВременныхФайловLinux

ПараметрыАдминистрированияИБ

ПараметрыИтоговИАгрегатов
ПараметрыОграниченияДоступа
ПараметрыРаботыПользователей
ПараметрыСлужебныхСобытий
ПарольДляОтправкиSMS
ПарольПользователяАгентаСервиса

ПарольСлужебногоПользователяМенеджераСервиса

ПоддержкаРезервногоКопирования

ПредставлениеОбластиДанных
ПрефиксДляОбменаССайтом
ПрефиксОбластиДанных
ПрефиксПоследнегоАвтономногоРабочегоМеста
ПрефиксУзлаРаспределеннойИнформационнойБазы
ПровайдерSMS

РазделыОписанияИзмененийСистемы
РазмерБлокаПередачиФайла
РазрешитьВыполнениеДополнительныхОтчетовИОбработокРегламентнымиЗаданиямиВМоделиСервиса
РежимИспользованияИнформационнойБазы

СинхронизироватьДанныеСПриложениемВИнтернетеПриЗавершенииРаботыПрограммы
СинхронизироватьДанныеСПриложениемВИнтернетеПриНачалеРаботыПрограммы
СообщениеБлокировкиПриОбновленииКонфигурации
СообщениеОбменаДаннымиИзГлавногоУзла

СписокЗапрещенныхРасширений
СписокЗапрещенныхРасширенийОбластиДанных

СписокРасширенийФайловOpenDocument
СписокРасширенийФайловOpenDocumentОбластиДанных

СтатусОбновленияКонфигурации

ХранитьФайлыВТомахНаДиске
ЧасовойПоясОбластиДанных

ЭтоАвтономноеРабочееМесто

Событие: ПередЗаписью.

8.4.ОбменДаннымиПолныйЗарегистрироватьИзменениеНабораЗаписей

Источник:  Все РегистрыНакопленияНаборЗаписей.

РегистрСведенийНаборЗаписей, за исключением:

БлокировкиСеансовОбластейДанных

ВерсииПодсистем
ВерсииПодсистемОбластейДанных

ДанныеПроизводственногоКалендаря

ЗависимостиПравДоступа

ЗамерыВремени

ИзмененияОбщихДанныхУзлов

ИспользованиеПоставляемыхДополнительныхОтчетовИОбработокВОбластяхДанных

КэшПрограммныхИнтерфейсов

НапоминанияПользователя

НастройкиОтправителя

НастройкиТранспортаОбмена
НастройкиТранспортаОбменаОбластейДанных
НастройкиТранспортаОбменаОбластиДанных
НеразделенныеПользователи

ОбластиДанных
ОбластиПерсональныхДанных
ОбластиТребующиеОбработкиПоставляемыхДанных
ОбщиеНастройкиУзловИнформационныхБаз

ОчередьИзвлеченияТекста
ОчередьИнсталляцииПоставляемыхДополнительныхОтчетовИОбработокВОбластиДанных

ПодпискиПолучателей

ПоставляемыеДанныеТребующиеОбработки
ПраваПоЗначениямДоступа
ПраваРолей
ПравилаДляОбменаДанными

ПутиМодулейКриптографииСерверовLinux
РабочиеКаталогиФайлов
РезультатыОбменаДанными
РейтингАктивностиОбластейДанных
РучныеИзмененияГрафиковРаботы
СессииОбменаСообщениямиСистемы

СообщенияОбменаДанными
СообщенияОбменаДаннымиОбластейДанных
СоответствияОбъектовИнформационныхБаз

СостоянияОбменовДанными
СостоянияОбменовДаннымиОбластейДанных

СостоянияУспешныхОбменовДанными
СостоянияУспешныхОбменовДаннымиОбластейДанных

УдалитьОбластиДанных
УдалитьОбластиКРезервномуКопированию
УдалитьОчередьЗаданий

ФайлыВРабочемКаталоге

Событие: ПередЗаписью.

8.5.ОбменДаннымиПолныйЗарегистрироватьУдаление

Источник: Все ПланВидовХарактеристикОбъект,ДокументОбъект.

СправочникОбъект,за исключением:

ДоговорыКонтрагентовПрисоединенныеФайлы

ЗаданиеНаРаботуПрисоединенныеФайлы
ЗаказПокупателяПрисоединенныеФайлы
ЗаказПоставщикуПрисоединенныеФайлы

ИнвентаризацияЗапасовПрисоединенныеФайлы

КлючевыеОперации

КонтрагентыПрисоединенныеФайлы

НоменклатураПрисоединенныеФайлы

ОрганизацииПрисоединенныеФайлы
ОчередьЗаданий
ОчередьЗаданийОбластейДанных

ПапкиФайловПрисоединенныеФайлы

ПолныеПутиКФормам

ПоставляемыеДанные
ПоставляемыеДополнительныеОтчетыИОбработки
ПоступлениеНаСчетПрисоединенныеФайлы

ПредопределенныеВариантыОтчетов
ПриходнаяНакладнаяПрисоединенныеФайлы

ПроизводственныеКалендари

РасходСоСчетаПрисоединенныеФайлы

СценарииОбменовДанными
СчетНаОплатуПоставщикаПрисоединенныеФайлы
СчетФактураПолученныйПрисоединенныеФайлы
СчетФактураПрисоединенныеФайлы

Ячейки

Событие: ПередУдалением.

9. В общем модуле  ОбменДаннымиПереопределяемый  в процедуру ПолучитьПланыОбмена в конце процедуры добавить:

ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.Полный);

 

10. В Общие команды  добавить новый тип параметра команды:ПланОбменасСсылка.Полный.

     для команд:

    ВыполнитьОбменДанными    

    НастроитьПараметрыТранспортаСообщенийОбмена    

    ОткрытьПравилаРегистрацииОбъектов    

    ПерейтиВЖурналРегистрацииСобытийВыгрузкиДанных    

    ПерейтиВЖурналРегистрацииСобытийЗагрузкиДанных    

    ПолучитьНастройкиОбменаДаннымиДляВторойИнформационнойБазы  

 

На этом этапе все необходимые доработки внедрены,осталось только установить префикс у ИБ и создать новую настройку сихронизацию через Мастер.

 

Также можно вручную создать начальный образ ИБ через ПланыОбмена.

 

   На этом все,можно пользоваться обменом. Тестировалось на релизе УНФ 1.4.7.37.

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. gull22 87 15.01.14 12:49 Сейчас в теме
2. sudo90 09.02.14 12:59 Сейчас в теме
Уточните пожалуйста что нужно закоментировать в Справочнике ИдентификаторыОбъектовМетаданных, в статье не увидел.

Заранее спасибо
3. ZhAmAn 48 09.02.14 15:45 Сейчас в теме
(2) sudo90,
В процедуре модуля объекта ПередЗаписью:
//Если ОбщегоНазначения.ЭтоПодчиненныйУзелРИБ() Тогда
//
// Если ЭтоНовый() Тогда
// ВызватьИсключениеПоОшибке(
// НСтр("ru = 'Добавление новых элементов может быть выполнено
// |только в главном узле распределенной информационной базы.'"));
// КонецЕсли;
//
// Если НЕ ПометкаУдаления Тогда
// Если ВРег(ПолноеИмя) <> ВРег(ОбщегоНазначения.ПолучитьЗначениеРеквизита(Ссылка, "ПолноеИмя")) Тогда
// ВызватьИсключениеПоОшибке(
// НСтр("ru = 'Изменение реквизита ""Полное имя"" может быть выполнено
// |только в главном узле распределенной информационной базы.'"));
// КонецЕсли;
// КонецЕсли;
//КонецЕсли;
//

sart-b@mail.ru; kosta_ks; sudo90; +3 Ответить
4. sudo90 14.02.14 09:58 Сейчас в теме
5. alexanderal 12.03.14 16:48 Сейчас в теме
ПодпискаНаСобытие.ОбменДаннымиПолныйЗарегистрироватьИзменение: Обработчик события должен быть задан
ПодпискаНаСобытие.ОбменДаннымиПолныйЗарегистрироватьИзменениеДокумента: Обработчик события должен быть задан
ПодпискаНаСобытие.ОбменДаннымиПолныйЗарегистрироватьИзменениеКонстанты: Обработчик события должен быть задан
ПодпискаНаСобытие.ОбменДаннымиПолныйЗарегистрироватьИзменениеНабораЗаписей: Обработчик события должен быть задан
ПодпискаНаСобытие.ОбменДаннымиПолныйЗарегистрироватьУдаление: Обработчик события должен быть задан

не нахожу где в тексте об обработчиках есть
6. alexanderal 31.03.14 14:22 Сейчас в теме
разобрался, заработала, только инструкция немного неполная... надфилем пришлось обработать и открытый вопрос остался с плпном счетов - новые счета не уходят в перефирийку ... чешим репу... ищем где... может кто то решал - подскажите
7. goshua 08.10.14 19:35 Сейчас в теме
(6) alexanderal, так что там в обработчиках надо указать?
11. Ygich 127 29.12.15 21:26 Сейчас в теме
(6) alexanderal, нужно добавить новую подписку на событие изменения плана счетов. Либо в подписке ОбменДаннымиПолныйЗарегистрироватьИзменение поставить галку план счетов управленческий.
8. kosikov_oleg 31.01.15 08:25 Сейчас в теме
Спасибо за полезную статью.

Подскажите, пожалуйста, как бороться со следующей проблемой.
При первоначальном старте подчиненного узла добавляется "Администратор", а потом после атоперезапуска вылетает ошибка


{ОбщийМодуль.Пользователи.Модуль(620)}: Ошибка при вызове метода контекста (Записать)
Пользователь.Записать();
по причине:
Ошибка при выполнении обработчика - 'ПередЗаписью'
по причине:
{ОбщийМодуль.ОбменДаннымиСервер.Модуль(7708)}: Ошибка при вызове метода контекста (Записать)
НаборЗаписей.Записать();
по причине:
Ошибка при выполнении обработчика - 'ПередЗаписью'
по причине:
{ОбщийМодуль.ПользователиСлужебный.Модуль(316)}: Авторизация не выполнена. Работа системы будет завершена.
Пользователь: Администратор не найден в справочнике "Пользователи".

При попытке добавления пользователя в справочник возникла ошибка:
"Попытка получения неинициализированного значения параметра сеанса".

Обратитесь к администратору.
ВызватьИсключение ТекстСообщенияОбОшибке;
9. titanium2008 16 20.11.15 12:41 Сейчас в теме
Добрый день, кто нибудь для 1.5 реализовывал?
10. borodatii 3 20.11.15 12:47 Сейчас в теме
(9) titanium2008, месяца два назад делал обновление УНФ 1.4, где уже был реализован РИБ подобным образом, до 1.5. Сейчас уже точно не вспомню, что именно делал, но принцип простой - запускаешь, получаешь ошибку, смотришь на неё, смотришь в код УТ 11, перетаскиваешь оттуда и пробуешь опять. Пару-тройку итераций и оно работает. Можно сразу смотреть код УТ 11 и тянуть оттуда. Насколько помню, там некоторые методы поменялись, некоторые добавились.
12. mind-rubbish 16.06.16 15:30 Сейчас в теме
Кто-нибудь может ответить, уважаемые, что делать с РИБ для УНФ 1.6? Я стала делать по данной статье, тестово сделала для 1.4, вроде все нормально было (Честно говоря, я столько раз уже пробовала и переделывала, что запуталась даже в количестве и какие ошибки на каких версиях были).. Но в УНФ 1.6, а конкретно 1.6.4.27, я вижу следующее - появились разные документы новые и справочники и тд, и я естественно оставляла на них подписку, может быть кто-то знает логику, почему на некоторые объекты в подписке на события снимается галка?

Плюс второй момент - Глобальные команды. Некоторых команд нет в УНФ 1.6, а именно:

ВыполнитьОбменДанными - есть в УНФ 1.5
НастроитьПараметрыТранспортаСообщенийОбмена - есть в УНФ 1.6
ОткрытьПравилаРегистрацииОбъектов - есть в УНФ 1.5
ПерейтиВЖурналРегистрацииСобытийВыгрузкиДанных - есть в УНФ 1.5
ПерейтиВЖурналРегистрацииСобытийЗагрузкиДанных - есть в УНФ 1.5
ПолучитьНастройкиОбменаДаннымиДляВторойИнформационнойБазы - в УНФ 1.5 это есть, в УНФ 1.6 есть похожее - ПолучитьНастройкиОбменаДанныхДляДругойПрограммы. Судя по комментариям это одно и то же.

Но все равно не ясно - просто добавить эти команды из УНФ 1.5 или УНФ 1.4?

Еще для таких невнимательных как я - в модуле менеджера появились дополнительные параметры в некоторых функциях, я первый раз просто заменяла функции на те, которые в этой статье, в общем сама виновата =) Зато в справочнике ИдентификаторыОбъектовМетаданных больше нечего комментировать - там всего одна строчка
13. alexstav 5 01.08.16 09:20 Сейчас в теме
Присоединяюсь к вопросу. Как настроить для 1.6?
14. Shaldryn 08.11.16 15:08 Сейчас в теме
Кто нибудь делал это в 1.6? Сделал, РИБ запускается, но проблема в том что разделы не все отображает и добавить невозможно, из списка доступных нет
15. vitalya24 226 06.12.16 17:45 Сейчас в теме
делал, не без напильника, но взлетело, спасибо
16. TMV 14 09.12.16 10:37 Сейчас в теме
(15), если в виде публикации оформлено, есть ссылка?
17. margo2007 12 12.12.16 05:03 Сейчас в теме
Кто нибудь разобрался, как отобразить разделы?
18. n.s.gnedash 3 03.07.17 12:15 Сейчас в теме
Делаю настройку в УНФ 1.4. Сделал начальный образ, когда из главного узла делаю синхронизацию, получаю ошибку Для состава плана обмена Полный не указана регистрация объекта РегистрСведений.СостоянияОбменовДанными, но по инструкции данный регистр не включен. Как победить ошибку?
19. vas2005 8 02.02.18 01:55 Сейчас в теме
Всем доброго времени!!!
Подскажите, не могу понять, что надо сделать с пунктом
10. В Общие команды добавить новый тип параметра команды:ПланОбменасСсылка.Полный.
...????
Что именно надо вставить для команд:

ВыполнитьОбменДанными

НастроитьПараметрыТранспортаСообщенийОбмена

ОткрытьПравилаРегистрацииОбъектов

ПерейтиВЖурналРегистрацииСобытийВыгрузкиДанных

ПерейтиВЖурналРегистрацииСобытийЗагрузкиДанных

ПолучитьНастройкиОбменаДаннымиДляВторойИнформационнойБазы


Заранее спасибо!!!
20. Shaldryn 02.02.18 10:21 Сейчас в теме
(19) с версии 1.6.11 1С:Управление нашей фирмой поддерживает механизм распределенных информационных баз (РИБ)
21. vas2005 8 03.02.18 00:41 Сейчас в теме
(20) У меня конфигурация 1С:Предприятие 8. Автосервис (1.4.9.27), она на основе Управление нашей фирмой, и обновить до версии 1.6.11 пока нет возможности, вот и стоит задача доработать имеющуюся
22. Shaldryn 05.02.18 08:33 Сейчас в теме
(21) В 10 пункте написано добавить тип параметра команды, в указанных командах зайдите в свойства и там будет этот пункт и меняйте его
23. vas2005 8 09.02.18 23:31 Сейчас в теме
(22) Спасибо, разобрался, теперь буду дальше пробовать)))
24. vas2005 8 09.02.18 23:45 Сейчас в теме
Продолжает ругаться(((

{ОбщийМодуль.ОбменДаннымиСервер.Модуль(7642)}: Ошибка при вызове метода контекста (Записать)
НаборЗаписей.Записать();
по причине:
Не удалось записать: "Состояния успешных обменов данными"!
25. baracuda 2 09.02.18 23:52 Сейчас в теме
Использовать РИБ для УНФ утопия...
26. vas2005 8 10.02.18 00:39 Сейчас в теме
(25)Посоветуй что делать для объединения филиалов..???
РДП не устраивает, интернет часто отваливается(((
27. vas2005 8 10.02.18 00:43 Сейчас в теме
Процесс сдвинулся с мёртвой точки)))
Создание первичного прошло успешно, но при попытке первой синхронизации возникла ошибка

Не удалось записать: "Префикс информационной базы"!

Подскажите куда теперь копать..???
28. ptkrzy 69 18.04.18 17:48 Сейчас в теме
Оставьте свое сообщение

См. также

РИБ 200 узлов. Середина пути Промо

Распределенная БД (УРИБ, УРБД) v8 Розница Россия Бесплатно (free)

Между настройкой и поддержкой РИБ на 2 узла и на 10 большой разницы нет, а вот когда число удаленных точек переваливает за сотню, приходится решать уже совсем другие вопросы

25.10.2016    40035    comol    215    

Восстановление узла РИБ по магазинам на примере 1С:Розница 2.3.4

Распределенная БД (УРИБ, УРБД) v8 Розница Россия Бесплатно (free)

После очередного обновления узла РИБ столкнулся с ошибкой, РИБ перестал работать. Начитался много статей про восстановление РИБа, ни одна толково не помогла. Поэтому не мытьем, так катанием сам разобрался, как же быстро восстановить РИБ, чтобы он заработал.

15.06.2020    4231    maxon    1    

Восстановление данных 1С8 при помощи механизма РИБ

Распределенная БД (УРИБ, УРБД) Тестирование и исправление v8 Бесплатно (free)

Предлагаю сообществу способ восстановления утраченных данных из бэкапа используя механизм РИБ. Зачастую наличие бэкапа базы не позволяет просто взять и откатить состояние базы на утро или вечер предыдущего дня. Бывает так, что утерю важных данных заметили спустя 2 дня, и свежий бекап нам не поможет. Предлагаю относительно простой способ переноса определенных данных из резервной копии базы в рабочую. Не надо писать обработку по выгрузке, загрузке данных или по переносу через COM-соединение. Единственное условие: в базе должны работать обмены РИБ.

13.06.2020    1541    Vortigaunt    1    

Как мы РИБ на веб-сервисы переводили

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Россия Бесплатно (free)

Решение проблем обмена РИБ с 10+ баз с помощью веб-сервисов и базы обмена.

13.05.2020    4100    RSConsulting    22    

Обмен по расписанию типовыми средствами. Промо

Распределенная БД (УРИБ, УРБД) Обмен через XML Перенос данных из 1C8 в 1C8 v8 1cv8.cf Россия Бесплатно (free)

Часто перед интеграторами стоит задача организовать автообмен (по расписанию или при наступлении какого-либо события) данными между различными конфигурациями. В этой статье я попробую изложить простую инструкцию, как это можно сделать средствами, заложенными в типовые конфигурации 1С (ЗУП, БП, УПП и т.д.). Для обмена используется подсистема "Обмен данными" из БСП

20.06.2012    103380    kser87    52    

Установка расширений конфигурации, модифицирующих структуры данных, в фоновом задании запрещена

Распределенная БД (УРИБ, УРБД) v8 Бесплатно (free)

Вариант решения проблемы синхронизации узла при передаче изменений метаданных расширения, используемого в распределенной информационной базе.

20.02.2020    3013    fristaller    2    

И снова "Конфигурация узла распределенной ИБ не соответствует ожидаемой"

Распределенная БД (УРИБ, УРБД) Обмен данными 1С v8 Бесплатно (free)

Конфигурация узла распределенной ИБ не соответствует ожидаемой. Приведен очередной способ устранения этой ошибки, возникший не в результате сбоев в работе оборудования или при обмене, а в результате обновления платформы 1С.

05.11.2019    6321    Kobra_RU    11    

Cannot insert duplicate key. Кто виноват и что делать

Распределенная БД (УРИБ, УРБД) Тестирование и исправление v8 Бесплатно (free)

Ошибка "CANNOT INSERT DUPLICATE KEY" в базах 1С и связанная с ней "магия".

25.02.2019    22315    YPermitin    32    

Особенности обмена данными с использованием "ручной" регистрации Промо

Распределенная БД (УРИБ, УРБД) Перенос данных из 1C8 в 1C8 v8 1cv8.cf Бесплатно (free)

Эта статья рассчитана на программистов, которые используют обмен данными с помощью метода "ВыбратьИзменения" и последующую их запись. Только для планов обменов, имеющих "ручную" регистрацию.

14.01.2013    34162    logarifm    6    

Как отвязать информационную базу от РИБа

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Россия Бесплатно (free)

Краткая инструкция для новичков о том, как в 2 клика отвязать информационную базу от РИБа.

03.05.2018    17521    user861285    11    

Расширения конфигурации и РИБ, друзья или враги? Или как мы передаем расширения подчиненным РИБ узлам

Распределенная БД (УРИБ, УРБД) v8 Бесплатно (free)

Читая комментарии к курсу касательно новых возможностей расширений конфигурации, которые привнес релиз 8.3.11, на одном из известных сайтов с курсами, я обратил внимание, что коллегам приходится отказываться от расширений из-за решения перейти на РИБ. Мы сами относительно недавно начали переходить на РИБ, и мы также активно пользуемся расширениями и в этой статье я хотел бы рассказать, как мы решили эту проблему.

24.11.2017    19357    markers    14    

Magic Updater. Система администрирования распределенной сети 1С:РИБ

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Бесплатно (free)

Обновления 1С стали для Вас адом? Каждодневная "война" за получение данных из всех торговых точек? Обмены то проходят, то не проходят? Разрушилась база, а резервной копии нет и не было? Если у Вас тоже регулярно возникают данные вопросы - найдите пару минут прочитать статью ниже.

15.08.2017    17763    comol    15    

УНФ РИБ Промо

Распределенная БД (УРИБ, УРБД) Перенос данных из 1С7.7 в 1C8.X v8 УНФ Россия Бесплатно (free)

В типовой УНФ нет РИБа. Исправляем этот недостаток, используя УТ 11 и ИТС. Статья подойдет для настойки распределенки в любой конфе на базе БСП.

16.10.2012    39895    ptkrzy    23    

Восстановление обмена в РИБ. Запущенный случай

Распределенная БД (УРИБ, УРБД) v8 Россия Бесплатно (free)

Удачная попытка восстановить обмен в РИБ при большом количестве объектов обмена и ошибках при обмене.

03.04.2017    15316    peterxx    14    

Что делать, если параметр запуска /resetmasternode приводит к вылету с дампом

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Бесплатно (free)

Для тех, кто столкнулся с проблемой отключения узловой базы от главного узла через параметр запуска /ResetMasterNode.

01.04.2017    17721    therva    4    

Проблема с обновлением типовой конфигурации УТП 1.2 (Украина) в дочернем узле

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Украина Бесплатно (free)

При обновлении конфигурации в дочернем узле РБД , в случае, если обновление добавляет предопределенные элементы справочников, невозможно загрузить файл обмена стандартными средствами

15.02.2017    12948    bulpi    4    

Автоматическое обновление конфигурации в узлах РИБ Промо

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Бесплатно (free)

При поднятии РИБ одна из существенных проблем – как автоматически обновлять конфигурацию на периферийных узлах? Научить простых пользователей заходить в конфигуратор довольно проблематично. Предлагаю довольно простое, на мой взгляд решение с минимальными доработками в конфигурацию.

14.07.2012    53374    fixin    75    

Конфигурация узла распределенной ИБ не соответствует ожидаемой

Распределенная БД (УРИБ, УРБД) v8 Россия Бесплатно (free)

Есть куча материалов, где описано решение возникающей ошибки при обмене с РИБ, но ни одно не помогло. Пришлось включить мозг, и, о чудо, было найдено простое решение.

26.01.2017    25110    virtmon    34    

Планы обмена. Управляемый режим блокировок

Распределенная БД (УРИБ, УРБД) v8 Бесплатно (free)

Статья о том, как устроен объект конфигурации 1С:Предприятие 8 "План обмена", в том числе на уровне СУБД SQL Server. Анализируются особенности его использования при управляемом режиме блокировок.

28.11.2016    41656    zhichkin    17    

Highload обмен данными: постановка задачи

Производительность и оптимизация (HighLoad) Распределенная БД (УРИБ, УРБД) v8 Бесплатно (free)

Цели статьи: определить, что такое "highload обмен", описать типовой сценарий обмена, сформулировать основные требования к обменам такого типа и предложить методику оценки производительности (пропускной способности).

04.11.2016    14306    zhichkin    3    

Корректное отключение от главного узла РИБ и создание самостоятельной БД. Быстрое создание/восстановление узла РИБ без выгрузки начального образа для конфигураций на основе БСП

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Бесплатно (free)

В публикации описан один из способов создания тестовой БД для разработки с актуальными данными, быстрого восстановления работоспособности РИБ при "падении" одного из узлов, или "быстрого" создания/восстановления узла РИБ без выгрузки начального образа для конфигураций на основе БСП.

16.02.2016    99076    asg.aleks    12    

Автоматическое обновление конфигурации в узлах РИБ

Распределенная БД (УРИБ, УРБД) v8 Бесплатно (free)

Вариант автоматического обновления конфигурации (без участия пользователей) периферийной базы РИБ. Очень простой способ без необходимости внесения кода в конфигурацию 1С. В дополнение к публикации http://infostart.ru/public/143517/. Спасибо автору, навел на эту идею!

22.01.2016    24482    Kitri    4    

Отладка конвертации данных 2.1 в конфигурациях, построенных на БСП 2.1 (БП 3.0, УТ 11 etc.)

Практика программирования Распределенная БД (УРИБ, УРБД) Обмен через XML БСП (Библиотека стандартных подсистем) v8 1cv8.cf Бесплатно (free)

Отладка процесса выгрузки/загрузки данных при проведении синхронизации в новых конфигурациях 1С может вызвать (у меня вызвала) некоторые затруднения. О них и пойдёт речь.

29.10.2015    40437    NittenRenegade    23    

Как я восстанавливал разрушенную базу

Архивирование (backup) Распределенная БД (УРИБ, УРБД) Тестирование и исправление v8 1cv8.cf Бесплатно (free)

УТ10.3 на Платформе 8.2 на базе MSSQL была разрушена после попытки её восстановить после неудачного динамического обновления. Таблица Config целевой базы была заменена на содержимое таблицы Config от другой рабочей базы. Но на самом деле конфигурации у них существенно отличались, поэтому после таких действий целевая база рухнула окончательно. Что же делать?

21.08.2015    29912    METAL    25    

"Распил" базы "БП 3.0 ПРОФ" с дальнейшим переносом в "БП 3.0 Базовая" ОДНОЙ организации

Распределенная БД (УРИБ, УРБД) v8 Россия Бесплатно (free)

Условия: Есть "БП 3.0 ПРОФ", в которой ведется учет по трем (неважно, скольким) Организациям. Необходимо оставить учет только по одной (к примеру) организации, и при этом перенести все данные по ней в "БП 3.0. Базовая"

14.08.2015    17311    Viktor_Ermakov    10    

РИБ Бухгалтерия 3.0.39, файловый вариант базы

Распределенная БД (УРИБ, УРБД) v8 БП2.0 Россия Бесплатно (free)

Настройка обмена данных РИБ в файловом варианте базы, через планировщик задач.

18.05.2015    12520    maikl007    2    

Автоматическое обновление конфигурации периферийного узла РИБ при обмене

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Бесплатно (free)

При большом количестве периферийных узлов в РИБ достаточно проблематично производить обновление конфигурации. В данной статье опишу свой опыт решения данной проблемы.

24.03.2015    29554    kondrat1C    20    

Выделение одной организации из Бухгалтерии редакция 3 через РИБ

Распределенная БД (УРИБ, УРБД) v8 БП2.0 Россия Бесплатно (free)

Выделение одной организации из Бухгалтерии редакция 3 через РИБ (например, 3.0.36.16) может привести к большим проблемам с последующими обновлением.

16.02.2015    15682    shevelyov    4    

Обмен с помощью WMI

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Бесплатно (free)

Полный контроль над процессом, осуществляемый из единого центра.

10.11.2014    10468    loekyn    7    

Обмены данными и РИБ с использованием облачных сервисов

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Бесплатно (free)

Проверенный на практике, простой и доступный способ настройки обменов данными без использования FTP и встроенного почтового клиента.

22.10.2014    20177    rarename    14    

Реализация обмена по организации в УТ

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Бесплатно (free)

В связи с открытием филиала в другом городе возникла необходимость организации учета в конфигурации "Управление торговлей для Казахстана, ред. 3" (адаптированный аналог "Управление торговлей, ред. 11"). Как оказалось встроенного обмена по организации не оказалось, есть только "Полный". Пришлось реализовывать самому. Конечно был вариант работы через терминальное подключение и тонкий клиент, но в связи во-первых неустойчивыми каналами связи и с заделкой на будущее (большие объемы данных) решил сделать РИБ. И вот об этом моя первая статья, может поможет кому нибудь.

05.06.2014    15666    Bajo    5    

Интерактивный счетчик объектов обмена

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Бесплатно (free)

При обменах на периферийных базах счетчик обмена сделан не очень красиво – он зависает на 10% и вся загрузка не отображается на счетчике. Предлагаю методику, чтобы визуализировать прогресс загрузки/выгрузки.

16.08.2013    17309    fixin    3    

Параллельность выгрузок

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Бесплатно (free)

Рассказываю свой опыт, как добился параллельности выгрузки из центральной базы РИБ сразу в 70 узлов.

15.08.2013    24924    fixin    41    

Из главного узла не загружены изменения справочника "Идентификаторы объектов метаданных"

Распределенная БД (УРИБ, УРБД) Администрирование данных 1С v8 1cv8.cf Бесплатно (free)

Данная проблема появляется регулярно на Периферийной Базе, после проведения обновления релиза ЦБ. Всем кому данная проблема неожиданно обновила вкус жизни, посвящается. Пошаговая инструкция, 100 % гарантия, никакого программирования.

09.05.2013    41411    motorkuzbassa.it    40    

МиниКейс "Закрытие месяца в УПП без остановки работы системы (Партионный учёт)"

Распределенная БД (УРИБ, УРБД) Закрытие периода Закрытие периода Закрытие периода v8 1cv8.cf БУ Бесплатно (free)

Предлагается схема закрытия месяца на предприятии с круглосуточной работой в 1С. Используются обработки, которые доступны на infostart.ru.

24.02.2013    24333    axxell    7    

Настройка филиальных баз данных

Распределенная БД (УРИБ, УРБД) Перенос данных из 1C8 в 1C8 v8 БП2.0 ЗУП2.5 УТ10 Россия Бесплатно (free)

Клиент поставил задачу реализации работы филиалов в конфигурациях "Бухгалтерия предприятия" и "Зарплата и Управление Персоналом", в которых уже давно работает центральное отделение. Главная загвоздка в том, что, несмотря на автономную работу филиалов, отчетность нужно было продолжать сдавать от юридического лица в центральном филиале. Начали продумывать варианты реализации...

29.01.2013    17723    evgant    6    

Обмен данными в распределенной базе через e-mail.

Распределенная БД (УРИБ, УРБД) WEB v8 1cv8.cf Бесплатно (free)

Если у вас нет финансов для покупки отдельного сервера под 1С или вы просто не хотите пока вкладывать денежные средства для развития этого программного продукта, но у вас есть острая необходимость в обмене данными между двумя удаленно расположенными пользователями, то в данной статье я расскажу как настроить обмен данными без финансовых вложений по средствам e-mail.

13.01.2013    48413    Klim Bassenger    34    

Исправление ошибки в РИБ (некорректные данные в базе)

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Бесплатно (free)

Если у вас выгрузились в одну из периферийных баз данные из другой – эта инструкция для вас. :) Пример из реальной практики.

27.09.2012    17850    Korolev    11    

Обмен данными по планам обмена

Распределенная БД (УРИБ, УРБД) Перенос данных из 1C8 в 1C8 v8 1cv8.cf Бесплатно (free)

В этой статье я постараюсь рассказать, как перенести механизм обмен данными из типовой конфигурации в нетиповую и создать свои планы обмена.

19.07.2012    48901    kereo    17    

Скрипт для обмена между двумя базами УРБД на Java-Script

Распределенная БД (УРИБ, УРБД) Перенос данных из 1C8 в 1C8 v8 1cv8.cf Бесплатно (free)

Я создал копию базы, чтобы на работе и дома работать с одной и той же базой. Делать обмены мне быстро надоело, поэтому я потрудился, и за 2 часа написал скрипт на языке java-script для обмена между этими базами. Он даже обновляет конфигурацию периферийной базы! Для работы нужно, чтобы в конфигурации не было ошибок при компиляции модулей для внешнего соединения, т.к. используется внешнее соединение. Программа сделана для файловой версии, вы можете переделать ее для серверной версии.

27.03.2012    16482    fixin    7