УНФ РИБ

Публикация № 156559

Разработка - Обмен данными 1С - Распределенная БД (УРИБ, УРБД)

В типовой УНФ нет РИБа. Исправляем этот недостаток, используя УТ 11 и ИТС. Статья подойдет для настойки распределенки в любой конфе на базе БСП.

 Рецепт от http://1c39.ru. Для приготовления этого блюда потребуется УТ 11 одна штука. Открываем план обмена полный. Нажимаем состав. Создаем такой же в УНФ и снимаем галки у тех же объектов, что и в УТ. Авторегистрация - запретить. Ставим галку РИБ. Запихиваем в подсистему обмен данными. Макеты не используем. В модуль объекта пишем (из ИТС):


Перем КоличествоОбъектовЗагружено;
Перем
КоличествоОбъектовВыгружено;
Процедура
ПриОтправкеДанныхПодчиненному(ЭлементДанных, ОтправкаЭлемента, СозданиеНачальногоОбраза)
 
КоличествоОбъектовВыгружено = КоличествоОбъектовВыгружено + 1;
КонецПроцедуры

Процедура
ПриОтправкеДанныхГлавному(ЭлементДанных, ОтправкаЭлемента)
 
КоличествоОбъектовВыгружено = КоличествоОбъектовВыгружено + 1;
КонецПроцедуры

Процедура
ПриПолученииДанныхОтПодчиненного(ЭлементДанных, ПолучениеЭлемента, ОтправкаНазад)
 
КоличествоОбъектовЗагружено = КоличествоОбъектовЗагружено + 1;
КонецПроцедуры

Процедура
ПриПолученииДанныхОтГлавного(ЭлементДанных, ПолучениеЭлемента, ОтправкаНазад)
 
КоличествоОбъектовЗагружено = КоличествоОбъектовЗагружено + 1;
КонецПроцедуры

Процедура
ПередЗаписью(Отказ)
  Если
ОбменДаннымиСервер.НадоВыполнитьОбработчикПослеВыгрузкиДанных(ЭтотОбъект, Ссылка) Тогда
   
ПослеВыгрузкиДанных(Отказ);
  ИначеЕсли
ОбменДаннымиСервер.НадоВыполнитьОбработчикПослеЗагрузкиДанных(ЭтотОбъект, Ссылка) Тогда
   
ПослеЗагрузкиДанных(Отказ);
  КонецЕсли;
КонецПроцедуры

Процедура
ПослеВыгрузкиДанных(Отказ)
 
Сообщить("КоличествоОбъектовВыгружено: " + Строка(КоличествоОбъектовВыгружено));
КонецПроцедуры

Процедура
ПослеЗагрузкиДанных(Отказ)
 
Сообщить("КоличествоОбъектовЗагружено: " + Строка(КоличествоОбъектовЗагружено));
КонецПроцедуры

КоличествоОбъектовЗагружено = 0;
КоличествоОбъектовВыгружено = 0;

 

В модуль менеджера добавляем заглушки (http://www.conf1c.ru/2012/05/blog-post_02.html):


    Функция ПояснениеДляНастройкиПараметровУчета() Экспорт
        Возврат
"";
    КонецФункции

    Функция
ЗначенияПоУмолчаниюНаУзле() Экспорт
        Возврат Неопределено;
    КонецФункции

    Функция
ЗначенияПоУмолчаниюНаУзлеБазыКорреспондента() Экспорт
        Возврат Неопределено;
    КонецФункции

    Функция
ИмяФайлаНастроекДляПриемника() Экспорт
        Возврат
НСтр("ru = 'Настройки обмена УНФ-УНФ'");
    КонецФункции

    Функция
ИспользуемыеТранспортыСообщенийОбмена() Экспорт
       
Результат = Новый Массив;
       
Результат.Добавить(Перечисления.ВидыТранспортаСообщенийОбмена.FILE);
        Возврат
Результат;
    КонецФункции

    Функция
ИмяФормыСозданияНачальногоОбраза() Экспорт
        Возврат
"";
    КонецФункции

    Функция
ЗаголовокКомандыДляСозданияНовогоОбменаДанными() Экспорт
         Возврат
НСтр("ru = 'Создать обмен УНФ-УНФ'");
    КонецФункции

    Функция
ИспользоватьПомощникСозданияОбменаДанными() Экспорт
        Возврат Истина;
    КонецФункции

    Функция
НастройкаОтборовНаУзле() Экспорт
        Возврат Неопределено;
    КонецФункции

    Функция
НастройкаОтборовНаУзлеБазыКорреспондента() Экспорт
        Возврат Неопределено;
    КонецФункции

    Функция
ОписаниеЗначенийПоУмолчанию(ЗначенияПоУмолчаниюНаУзле) Экспорт
        Возврат
"";
    КонецФункции

    Функция
ОписаниеЗначенийПоУмолчаниюБазыКорреспондента(ЗначенияПоУмолчаниюНаУзле) Экспорт
          Возврат
"";
     КонецФункции

    Функция
ОписаниеОграниченийПередачиДанных(НастройкаОтборовНаУзле) Экспорт
     Возврат
"";
    КонецФункции

    Функция
ОписаниеОграниченийПередачиДанныхБазыКорреспондента(НастройкаОтборовНаУзле) Экспорт
        Возврат
"";
    КонецФункции

Создаем общий модуль (код взят из УТ 11):


////////////////////////////////////////////////////////////////////////////////
// Обмен Полный
// Процедура-обработчик события "ПередЗаписью" ссылочных типов данных (кроме документов) для механизма регистрации объектов на узлах
//
// Параметры:
//  ИмяПланаОбмена – Строка – имя плана обмена, для которого выполняется механизм регистрации
//  Источник       - источник события, кроме типа ДокументОбъект
//  Отказ          - Булево - флаг отказа от выполнения обработчика
//

Процедура ОбменДаннымиПолныйПередЗаписью(Источник, Отказ) Экспорт
   
ОбменДаннымиСобытия.МеханизмРегистрацииОбъектовПередЗаписью("Полный", Источник, Отказ);
КонецПроцедуры

// Процедура-обработчик события "ПередЗаписью" документов для механизма регистрации объектов на узлах
//
// Параметры:
//  ИмяПланаОбмена – Строка – имя плана обмена, для которого выполняется механизм регистрации
//  Источник       - ДокументОбъект - источник события
//  Отказ          - Булево - флаг отказа от выполнения обработчика
//

Процедура ОбменДаннымиПолныйПередЗаписьюДокумента(Источник, Отказ, РежимЗаписи, РежимПроведения) Экспорт
   
ОбменДаннымиСобытия.МеханизмРегистрацииОбъектовПередЗаписьюДокумента("Полный", Источник, Отказ, РежимЗаписи, РежимПроведения);
КонецПроцедуры

// Процедура-обработчик события "ПередЗаписью" константы для механизма регистрации объектов на узлах
//
// Параметры:
//  ИмяПланаОбмена – Строка – имя плана обмена, для которого выполняется механизм регистрации
//  Источник       - КонстантаМенеджерЗначения - источник события
//  Отказ          - Булево - флаг отказа от выполнения обработчика
//

Процедура ОбменДаннымиПолныйПередЗаписьюКонстанты(Источник, Отказ) Экспорт
   
ОбменДаннымиСобытия.МеханизмРегистрацииОбъектовПередЗаписьюКонстанты("Полный", Источник, Отказ);
КонецПроцедуры



// Процедура-обработчик события "ПередЗаписью" регистров для механизма регистрации объектов на узлах
//
// Параметры:
//  ИмяПланаОбмена – Строка – имя плана обмена, для которого выполняется механизм регистрации
//  Источник       - НаборЗаписейРегистра - источник события
//  Отказ          - Булево - флаг отказа от выполнения обработчика
//  Замещение      - Булево - признак замещения существующего набора записей
//

Процедура ОбменДаннымиПолныйПередЗаписьюРегистра(Источник, Отказ, Замещение) Экспорт
   
ОбменДаннымиСобытия.МеханизмРегистрацииОбъектовПередЗаписьюРегистра("Полный", Источник, Отказ, Замещение);
КонецПроцедуры


// Процедура-обработчик события "ПередУдалением" ссылочных типов данных для механизма регистрации объектов на узлах
//
// Параметры:
//  ИмяПланаОбмена – Строка – имя плана обмена, для которого выполняется механизм регистрации
//  Источник       - источник события
//  Отказ          - Булево - флаг отказа от выполнения обработчика
//

Процедура ОбменДаннымиПолныйПередУдалением(Источник, Отказ) Экспорт
   
ОбменДаннымиСобытия.МеханизмРегистрацииОбъектовПередУдалением("Полный", Источник, Отказ);
КонецПроцедуры

Создаем подписки на события (снимаем галки у типов объектов как в УТ) и привязываем к процедурам из модуля.

 

В ОбменДаннымиПредопределяемый Процедура ПолучитьПланыОбмена(ПланыОбменаПодсистемы) Экспорт добавляем строчку:

ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.Полный);

 

Для следующих общих команд добавляем параметр план обмена полный:

ВыполнитьОбменДанными

НастроитьПараметрыТранспортаСообщенийОбмена

ОткрытьПравилаРегистрацииОбъектов

ОткрытьСценарииОбменовДанными

ПерейтиВЖурналРегистрацииСобытийВыгрузкиДанных

ПерейтиВЖурналРегистрацииСобытийЗагрузкиДанных

ПолучитьНастройкиОбменаДаннымиДляВторойИнформационнойБазы

 

Создаем общую команду ОткрытьПомощникНастройкиОбмена


Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
   
ОбменДаннымиКлиент.ВыполнитьОбменДаннымиОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды.Источник);
КонецПроцедуры

Извесные косяки которые пока не планирую исправлять:

Помощник обмена в самом конце вываливается с ошибкой. Закрываем, кликаем на строку с настройкой обмена, в меню настройка-изменить, все действия - создать начальный образ.

После обновления конфы в переферийной базе пишет ошибку обмена - хотя на самом деле конфа обновилась. Решение - перезапускаем предприятие и повторяем обмен.

Подскажите как опубликовать только ту часть конфигурации, которую написал я, чтобы не нарушать права 1с? Если в процессе реализации возникают вопросы то сначала смотрите как это сделано в УТ, потом задавайте вопросы в комментариях.

 

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. Воронкин 16.10.12 19:52 Сейчас в теме
Думаю, скоро появится и штатно. В первых релизах УТ 11 - вообще ничего не было, потом функционал из 10.3 стали добавлять.
2. KliMich 16.10.12 22:12 Сейчас в теме
Наверное скоро будет... Но пока это актуально!
3. ptkrzy 69 16.10.12 22:32 Сейчас в теме
Это актуально для любой конфы на базе БСП, в том числе и для любой самописной.
4. Воронкин 17.10.12 15:11 Сейчас в теме
(3) За это и респект автору.
5. alexware 23.10.12 04:46 Сейчас в теме
Автору плюс. Как раз имею самописную конфигурацию на базе БСП и хотел бы внедрить РИБ. Выглядит вроде не очень страшно.
7. dimk@a 24.10.12 00:23 Сейчас в теме
Уж не знаю, как скоро появится в штатной, но у меня уже 3 месяца работает. Причем тупо создал план обмена, и галочки снимал чисто на глаз. Автору спасибо за публикацию - подправлю теперь свое творчество, и теперь я понял почему у меня всегда пишет выгружено 0 объектов. Ошибку с созданием образа подчиненной побеждал так - сохранял образ не в локальный каталог, а использовал сетевой путь, который начинается с \\
8. Tangram 153 30.01.13 23:40 Сейчас в теме
Для 1.4.4.11 в модуль менеджера плана обмена Полный нужно еще добавить:

Функция ПланОбменаИспользуетсяВМоделиСервиса() Экспорт
	Возврат ложь;
КонецФункции // ПланОбменаИспользуетсяВМоделиСервиса()

Функция ПодробнаяИнформацияПоОбмену() Экспорт

	Возврат "Обмен УНФ <-> УНФ";

КонецФункции // ПодробнаяИнформацияПоОбмену()
 
Функция КраткаяИнформацияПоОбмену() Экспорт
	Возврат "Обмен УНФ <-> УНФ";	
КонецФункции // КраткаяИнформацияПоОбмену()
Показать


Иначе УНФ вообще не запускается.
9. Tangram 153 01.02.13 00:44 Сейчас в теме
В продолжение темы:
Модуль менеджера плана обмена Полный:
Исправляем процедуру

    Функция НастройкаОтборовНаУзле() Экспорт
        Возврат Новый Структура; // мг
    КонецФункции


При запуске ПИБ вываливается на исключении в обработчике ПередЗаписью справочника ИдентификаторыОбъектовМетаданных:

	Если ПланыОбмена.ГлавныйУзел() <> Неопределено Тогда // Это не главный узел ИБ в РИБ-обмене.
		ВызватьИсключениеПоОшибке(
			НСтр("ru = 'Изменение идентификаторов объектов метаданных может быть выполнено
			           |только в главном узле распределенной информационной базы.'"));
	КонецЕсли;


Включение справочника в обмен пока не помогло.
Пока остановился на этом, разберусь, отпишу.
10. ptkrzy 69 01.02.13 11:56 Сейчас в теме
Просто закоментируй вызов исключения. В 1.4.4.10 много чего поменялось - нужно добавить несколько заглушек в модуль менеджера.
	Функция ПояснениеДляНастройкиПараметровУчета() Экспорт
		Возврат "";
	КонецФункции
	Функция ЗначенияПоУмолчаниюНаУзле() Экспорт

        Возврат Неопределено;
    КонецФункции

    Функция ЗначенияПоУмолчаниюНаУзлеБазыКорреспондента() Экспорт
        Возврат Неопределено;
    КонецФункции

    Функция ИмяФайлаНастроекДляПриемника() Экспорт
        Возврат НСтр("ru = 'Настройки обмена УНФ-УНФ'");
    КонецФункции

    Функция ИспользуемыеТранспортыСообщенийОбмена() Экспорт
        Результат = Новый Массив;
        Результат.Добавить(Перечисления.ВидыТранспортаСообщенийОбмена.FILE);
		Результат.Добавить(Перечисления.ВидыТранспортаСообщенийОбмена.FTP);
        Возврат Результат;
    КонецФункции

    Функция ИмяФормыСозданияНачальногоОбраза() Экспорт
		Возврат "ОбщаяФорма.СозданиеНачальногоОбразаСФайлами";
                //Решает проблему с созданием начального образа

    КонецФункции

    Функция ЗаголовокКомандыДляСозданияНовогоОбменаДанными() Экспорт
         Возврат НСтр("ru = 'Создать обмен УНФ-УНФ'");
    КонецФункции

    Функция ИспользоватьПомощникСозданияОбменаДанными() Экспорт
        Возврат Истина;
    КонецФункции

    Функция НастройкаОтборовНаУзле() Экспорт
        Возврат Новый Структура;
    КонецФункции

    Функция НастройкаОтборовНаУзлеБазыКорреспондента() Экспорт
        Возврат Неопределено;
    КонецФункции

    Функция ОписаниеЗначенийПоУмолчанию(ЗначенияПоУмолчаниюНаУзле) Экспорт
        Возврат "";
    КонецФункции

    Функция ОписаниеЗначенийПоУмолчаниюБазыКорреспондента(ЗначенияПоУмолчаниюНаУзле) Экспорт
          Возврат "";
     КонецФункции

    Функция ОписаниеОграниченийПередачиДанных(НастройкаОтборовНаУзле) Экспорт
     Возврат "";    
    КонецФункции

    Функция ОписаниеОграниченийПередачиДанныхБазыКорреспондента(НастройкаОтборовНаУзле) Экспорт    
        Возврат "";    
	КонецФункции
	
	Функция КраткаяИнформацияПоОбмену() Экспорт
		Возврат "КраткаяИнформацияПоОбмену";    
	КонецФункции
	Функция ПодробнаяИнформацияПоОбмену() Экспорт
		Возврат "";    
	КонецФункции
	Функция ПланОбменаИспользуетсяВМоделиСервиса() Экспорт
		Возврат Ложь;
	КонецФункции
	


Показать
11. aser86 13.03.13 13:26 Сейчас в теме
Добрый день! Не могли бы Вы выслать на почту ksaz@bk.ru .cf файл УНФ с настроенным планом обмена? а то у меня какие то ошибки выходят и не хочет создаваться распределенная база, буду очень очень благодарен !!!
12. LexSeIch 206 15.06.13 19:23 Сейчас в теме
Мир этому дому!
Автору плюс. Полезная информация по использованию БСП.
13. Tangram 153 17.06.13 10:03 Сейчас в теме
При обновлении на 1.4.6.19 в модуль менеджера плана обмена надо добавить функцию:

//Возвращает режим запуска, в случае интерактивного инициирования синхронизации
//Возвращаемые значения АвтоматическаяСинхронизация Или ИнтерактивнаяСинхронизация
//На основании этих значений запускается либо помощник интерактивного обмена, либо автообмен
Функция РежимЗапускаСинхронизацииДанных(УзелИнформационнойБазы) Экспорт

Возврат "АвтоматическаяСинхронизация";

КонецФункции
14. 13kawaii13 16.08.13 15:06 Сейчас в теме
При включении базы подчинённого узла выходит ошибка.



{Справочник.ИдентификаторыОбъектовМетаданных.МодульМенеджера(373)}: Ошибка при вызове метода контекста (Записать)
ТаблицаОбъект.Записать();
по причине:
Ошибка при выполнении обработчика - 'ПередЗаписью'
по причине:
{Справочник.ИдентификаторыОбъектовМетаданных.МодульОбъекта(96)}: Ошибка при работе со справочником "Идентификаторы объектов метаданных".

Добавление новых элементов может быть выполнено
только в главном узле распределенной информационной базы.
ТаблицаОбъект.Записать();


Вышлите мне пожалуйста .cf файл УНФ с настроенным планом обмена.
kawaii@live.ru
Не могу обойти возникающие ошибки. Релиз (1.4.6.19)
17. sudo90 09.02.14 11:57 Сейчас в теме
(14) 13kawaii13, Здравствуйте, тоже возникла ошибка такая же как у Вас, Вы справились с ней?
19. 13kawaii13 09.02.14 12:25 Сейчас в теме
(17) sudo90, Просто не стали обновляться на последний релиз.
15. 13kawaii13 20.08.13 10:51 Сейчас в теме
Вышлите мне пожалуйста .cf файл УНФ с настроенным планом обмена. (На любом релизе)
16. ptkrzy 69 23.08.13 16:10 Сейчас в теме
У меня есть сильно переписаная под нужды заказчика конфигурация. Это будет некорректно по отношению к заказчику и нарушать права самой 1с. Предложите метод, который позволит выгрузить лишь отличия между типовой кинфигурацией и УНФ+РИБ. Почитайте статью на ИТС http://its.1c.ru/db/bspdoc?db=bspdoc#content:34:1 .Либо обратитесь к франчайзи своего региона. Я думаю они смогут вам помочь.
20. sudo90 09.02.14 15:08 Сейчас в теме
Жаль, а у нас версия как раз 1.4.6.19((
21. ptkrzy 69 10.02.14 10:51 Сейчас в теме
Для 1.4.7.37 подробно описано по ссылке http://infostart.ru/public/249881/
22. Prometeus2011 97 22.07.16 09:47 Сейчас в теме
Если в модуле "ОбменДаннымиПовтИсп", процедура "ИспользуемыеТранспортыСообщенийОбмена" закомментировать строки:
Если Не ЭтоУзелАвтономногоРабочегоМеста(УзелИнформационнойБазы) Тогда
          ОбщегоНазначенияКлиентСервер.УдалитьЗначениеИзМассива(Результат, Перечисления.ВидыТранспортаСообщенийОбмена.WS);
КонецЕсли;

, то это позволяет производить синхронизацию в режиме сервиса, по http протоколу.
(Версия УНФ 1.6.4.19)
23. al_zzz 167 23.10.16 15:36 Сейчас в теме
Прошло 4 года с момента публикации. Видимо штатный РИБ в УНФ уже вряд ли появится...
24. Shaldryn 08.11.16 15:19 Сейчас в теме
кто настраивал в 1.6? вроде бы создает РИБ, но при запуске ее отображает не все разделы, только Работа, Зарплата, Производство. В чем может быть косяк?
Оставьте свое сообщение

См. также

РИБ 200 узлов. Середина пути Промо

Распределенная БД (УРИБ, УРБД) v8 Розница Россия Бесплатно (free)

Между настройкой и поддержкой РИБ на 2 узла и на 10 большой разницы нет, а вот когда число удаленных точек переваливает за сотню, приходится решать уже совсем другие вопросы

25.10.2016    38796    0    comol    215    

Восстановление узла РИБ по магазинам на примере 1С:Розница 2.3.4

Распределенная БД (УРИБ, УРБД) v8 Розница Россия Бесплатно (free)

После очередного обновления узла РИБ столкнулся с ошибкой, РИБ перестал работать. Начитался много статей про восстановление РИБа, ни одна толково не помогла. Поэтому не мытьем, так катанием сам разобрался, как же быстро восстановить РИБ, чтобы он заработал.

15.06.2020    1483    0    maxon    1    

Восстановление данных 1С8 при помощи механизма РИБ

Распределенная БД (УРИБ, УРБД) Тестирование и исправление v8 Бесплатно (free)

Предлагаю сообществу способ восстановления утраченных данных из бэкапа используя механизм РИБ. Зачастую наличие бэкапа базы не позволяет просто взять и откатить состояние базы на утро или вечер предыдущего дня. Бывает так, что утерю важных данных заметили спустя 2 дня, и свежий бекап нам не поможет. Предлагаю относительно простой способ переноса определенных данных из резервной копии базы в рабочую. Не надо писать обработку по выгрузке, загрузке данных или по переносу через COM-соединение. Единственное условие: в базе должны работать обмены РИБ.

13.06.2020    983    0    Vortigaunt    1    

Как мы РИБ на веб-сервисы переводили

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Россия Бесплатно (free)

Решение проблем обмена РИБ с 10+ баз с помощью веб-сервисов и базы обмена.

13.05.2020    3118    0    RSConsulting    22    

Отладка правил обмена 7.7, 8 Промо

Перенос данных из 1С7.7 в 1C8.X Обмен через XML Перенос данных из 1C8 в 1C8 v8 КД Бесплатно (free)

Отладка правил обмена всегда была для меня больной темой, пока наконец-то не разобрался. В интернете мало тем, посвященных этому, поэтому решил написать небольшую инструкцию по этому поводу. Очень надеюсь, что она будет кому-то полезна. С радостью выслушаю недочеты.

29.10.2013    50941    0    pyrkin_vanya    70    

Установка расширений конфигурации, модифицирующих структуры данных, в фоновом задании запрещена

Распределенная БД (УРИБ, УРБД) v8 Бесплатно (free)

Вариант решения проблемы синхронизации узла при передаче изменений метаданных расширения, используемого в распределенной информационной базе.

20.02.2020    2151    0    fristaller    2    

И снова "Конфигурация узла распределенной ИБ не соответствует ожидаемой"

Распределенная БД (УРИБ, УРБД) Обмен данными 1С v8 Бесплатно (free)

Конфигурация узла распределенной ИБ не соответствует ожидаемой. Приведен очередной способ устранения этой ошибки, возникший не в результате сбоев в работе оборудования или при обмене, а в результате обновления платформы 1С.

05.11.2019    5664    0    Kobra_RU    11    

Доработка конвертации данных КД2 (версии 2.1). Расширенная диагностическая информация при выгрузке по правилам из 1С 7.7 и при загрузке в 1С 7.7

Обмен данными 1С Перенос данных из 1С7.7 в 1C8.X Обмен через XML v7.7 v8 КД Бесплатно (free)

Есть очень неприятная особенность при настройке обмена по правилам КД2 в момент отладки на стороне 1С 7.7, как при выгрузке из 1С 7.7, так и при загрузке в 1С 7.7. Непонятно, в каком конкретно месте формирования или разбора данных XML файла в какой именно момент споткнулась программа (произошел сбой). Я нашел способ вывода дополнительной диагностики, теперь точно известно, на каком элементе данных XML споткнулся модуль выгрузки V77Exp.ert (модуль загрузки V77Imp.ert). Теперь отладка правил обмена на стороне 1С 7.7 стала простой, выполняется на порядок проще.

18.10.2019    5251    0    ksnik    0    

Кэширование COM-соединения. Три способа Промо

Практика программирования Перенос данных из 1С7.7 в 1C8.X Внешние источники данных WEB v8 Россия Бесплатно (free)

Статья о трех способах кэширования COM-соединения в 1С:Предприятии 8.x.

11.04.2013    40448    0    YPermitin    34    

Конвертация данных из 1С 8.3 в 7.7 (версия КД 2.1). Перенос данных из 8.3 в 7.7. Создание в современной 1С 8.3 XML в формате КД2. Инструкции и примеры переноса данных из любой современной 1С 8.3 в устаревшую конфигурацию 1С 7.7, через Конвертацию данных 2

Обмен данными 1С Перенос данных из 1С7.7 в 1C8.X v7.7 v8 КД Бесплатно (free)

При переходе на новую версию 1С в период параллельной эксплуатации может возникнуть необходимость обратной конвертации данных (по правилам КД версии 2.1) из 1С:Предприятие 8.3 в 1С:Предприятие 7.7 для переноса данных из 1С:Предприятие 8.3 в 7.7. Сделать это поможет следующая инструкция по КД2 о том, как создать новую конвертацию из 8.3 в 7.7, сохранить модуль и правила загрузки данных, сделать загрузку данных. КД2.

17.10.2019    7333    0    ksnik    0    

Подсистема обмена данными в рамках РИБ

Распределенная БД (УРИБ, УРБД) v8 Бесплатно (free)

Публикация оформлена после прочтения https://infostart.ru/public/1117071/ (автор https://infostart.ru/profile/586627/) на основе опыта реализации обмена между базами 1С (в том числе с разными конфигурациями) и разработки двухмесячной давности для обмена в рамках РИБ. Платформа начиная с 8.2.19.130

05.09.2019    4866    5    savostin.alex    6    

Cannot insert duplicate key. Кто виноват и что делать

Распределенная БД (УРИБ, УРБД) Тестирование и исправление v8 Бесплатно (free)

Ошибка "CANNOT INSERT DUPLICATE KEY" в базах 1С и связанная с ней "магия".

25.02.2019    19859    0    YPermitin    32    

Обмен по расписанию типовыми средствами. Промо

Распределенная БД (УРИБ, УРБД) Обмен через XML Перенос данных из 1C8 в 1C8 v8 1cv8.cf Россия Бесплатно (free)

Часто перед интеграторами стоит задача организовать автообмен (по расписанию или при наступлении какого-либо события) данными между различными конфигурациями. В этой статье я попробую изложить простую инструкцию, как это можно сделать средствами, заложенными в типовые конфигурации 1С (ЗУП, БП, УПП и т.д.). Для обмена используется подсистема "Обмен данными" из БСП

20.06.2012    101605    0    kser87    52    

Как отвязать информационную базу от РИБа

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Россия Бесплатно (free)

Краткая инструкция для новичков о том, как в 2 клика отвязать информационную базу от РИБа.

03.05.2018    15307    0    user861285    10    

Расширения конфигурации и РИБ, друзья или враги? Или как мы передаем расширения подчиненным РИБ узлам

Распределенная БД (УРИБ, УРБД) v8 Бесплатно (free)

Читая комментарии к курсу касательно новых возможностей расширений конфигурации, которые привнес релиз 8.3.11, на одном из известных сайтов с курсами, я обратил внимание, что коллегам приходится отказываться от расширений из-за решения перейти на РИБ. Мы сами относительно недавно начали переходить на РИБ, и мы также активно пользуемся расширениями и в этой статье я хотел бы рассказать, как мы решили эту проблему.

24.11.2017    18314    0    markers    11    

Magic Updater. Система администрирования распределенной сети 1С:РИБ

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Бесплатно (free)

Обновления 1С стали для Вас адом? Каждодневная "война" за получение данных из всех торговых точек? Обмены то проходят, то не проходят? Разрушилась база, а резервной копии нет и не было? Если у Вас тоже регулярно возникают данные вопросы - найдите пару минут прочитать статью ниже.

15.08.2017    17031    12    comol    15    

Особенности обмена данными с использованием "ручной" регистрации Промо

Распределенная БД (УРИБ, УРБД) Перенос данных из 1C8 в 1C8 v8 1cv8.cf Бесплатно (free)

Эта статья рассчитана на программистов, которые используют обмен данными с помощью метода "ВыбратьИзменения" и последующую их запись. Только для планов обменов, имеющих "ручную" регистрацию.

14.01.2013    32878    0    logarifm    6    

Опыт переноса данных для расчета среднего из ЗиК в УПП(КА)

Перенос данных из 1С7.7 в 1C8.X Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 1cv8.cf БУ Бесплатно (free)

Делюсь опытом использования стандартных инструментов и методикой переноса

25.06.2017    13574    0    SITR-utyos    0    

Восстановление обмена в РИБ. Запущенный случай

Распределенная БД (УРИБ, УРБД) v8 Россия Бесплатно (free)

Удачная попытка восстановить обмен в РИБ при большом количестве объектов обмена и ошибках при обмене.

03.04.2017    14732    0    peterxx    13    

Что делать, если параметр запуска /resetmasternode приводит к вылету с дампом

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Бесплатно (free)

Для тех, кто столкнулся с проблемой отключения узловой базы от главного узла через параметр запуска /ResetMasterNode.

01.04.2017    16697    0    therva    4    

Автоматическое обновление конфигурации в узлах РИБ Промо

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Бесплатно (free)

При поднятии РИБ одна из существенных проблем – как автоматически обновлять конфигурацию на периферийных узлах? Научить простых пользователей заходить в конфигуратор довольно проблематично. Предлагаю довольно простое, на мой взгляд решение с минимальными доработками в конфигурацию.

14.07.2012    52540    0    fixin    75    

Проблема с обновлением типовой конфигурации УТП 1.2 (Украина) в дочернем узле

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Украина Бесплатно (free)

При обновлении конфигурации в дочернем узле РБД , в случае, если обновление добавляет предопределенные элементы справочников, невозможно загрузить файл обмена стандартными средствами

15.02.2017    12665    0    bulpi    4    

Конфигурация узла распределенной ИБ не соответствует ожидаемой

Распределенная БД (УРИБ, УРБД) v8 Россия Бесплатно (free)

Есть куча материалов, где описано решение возникающей ошибки при обмене с РИБ, но ни одно не помогло. Пришлось включить мозг, и, о чудо, было найдено простое решение.

26.01.2017    23724    0    virtmon    32    

Планы обмена. Управляемый режим блокировок

Распределенная БД (УРИБ, УРБД) v8 Бесплатно (free)

Статья о том, как устроен объект конфигурации 1С:Предприятие 8 "План обмена", в том числе на уровне СУБД SQL Server. Анализируются особенности его использования при управляемом режиме блокировок.

28.11.2016    40075    0    zhichkin    17    

Highload обмен данными: постановка задачи

Производительность и оптимизация (HighLoad) Распределенная БД (УРИБ, УРБД) v8 Бесплатно (free)

Цели статьи: определить, что такое "highload обмен", описать типовой сценарий обмена, сформулировать основные требования к обменам такого типа и предложить методику оценки производительности (пропускной способности).

04.11.2016    14062    0    zhichkin    3    

Методика пошагового перехода из решения для платформы 7.7 "Торговля и склад" на решение для платформы 8 "Управление торговлей"

Перенос данных из 1С7.7 в 1C8.X Оптовая торговля Оптовая торговля v7.7 v8 УТ10 1С7:ТиС Оптовая торговля, дистрибуция, логистика Россия БУ УУ Бесплатно (free)

Данная статья предваряет публикацию подсистемы для одностороннего ONLINE обмена документами и справочниками между базами данных для процесса поэтапного перехода из "семерки" в "восьмерку" для случаев распределенной совместной работы большого количества пользователей, не допускающих резких скачкообразных внедрений с рисками остановки процессов продаж, поставок, доставок или складских сборок.

31.10.2016    14687    0    vugluscr1991    29    

Корректное отключение от главного узла РИБ и создание самостоятельной БД. Быстрое создание/восстановление узла РИБ без выгрузки начального образа для конфигураций на основе БСП

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Бесплатно (free)

В публикации описан один из способов создания тестовой БД для разработки с актуальными данными, быстрого восстановления работоспособности РИБ при "падении" одного из узлов, или "быстрого" создания/восстановления узла РИБ без выгрузки начального образа для конфигураций на основе БСП.

16.02.2016    95923    0    asg.aleks    12    

Автоматическое обновление конфигурации в узлах РИБ

Распределенная БД (УРИБ, УРБД) v8 Бесплатно (free)

Вариант автоматического обновления конфигурации (без участия пользователей) периферийной базы РИБ. Очень простой способ без необходимости внесения кода в конфигурацию 1С. В дополнение к публикации http://infostart.ru/public/143517/. Спасибо автору, навел на эту идею!

22.01.2016    23783    0    Kitri    4    

Отладка конвертации данных 2.1 в конфигурациях, построенных на БСП 2.1 (БП 3.0, УТ 11 etc.)

Практика программирования Распределенная БД (УРИБ, УРБД) Обмен через XML БСП (Библиотека стандартных подсистем) v8 1cv8.cf Бесплатно (free)

Отладка процесса выгрузки/загрузки данных при проведении синхронизации в новых конфигурациях 1С может вызвать (у меня вызвала) некоторые затруднения. О них и пойдёт речь.

29.10.2015    38765    0    NittenRenegade    23    

Как я восстанавливал разрушенную базу

Архивирование (backup) Распределенная БД (УРИБ, УРБД) Тестирование и исправление v8 1cv8.cf Бесплатно (free)

УТ10.3 на Платформе 8.2 на базе MSSQL была разрушена после попытки её восстановить после неудачного динамического обновления. Таблица Config целевой базы была заменена на содержимое таблицы Config от другой рабочей базы. Но на самом деле конфигурации у них существенно отличались, поэтому после таких действий целевая база рухнула окончательно. Что же делать?

21.08.2015    29251    0    METAL    25    

"Распил" базы "БП 3.0 ПРОФ" с дальнейшим переносом в "БП 3.0 Базовая" ОДНОЙ организации

Распределенная БД (УРИБ, УРБД) v8 Россия Бесплатно (free)

Условия: Есть "БП 3.0 ПРОФ", в которой ведется учет по трем (неважно, скольким) Организациям. Необходимо оставить учет только по одной (к примеру) организации, и при этом перенести все данные по ней в "БП 3.0. Базовая"

14.08.2015    16963    0    Viktor_Ermakov    10    

РИБ Бухгалтерия 3.0.39, файловый вариант базы

Распределенная БД (УРИБ, УРБД) v8 БП2.0 Россия Бесплатно (free)

Настройка обмена данных РИБ в файловом варианте базы, через планировщик задач.

18.05.2015    12257    0    maikl007    2    

Автоматическое обновление конфигурации периферийного узла РИБ при обмене

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Бесплатно (free)

При большом количестве периферийных узлов в РИБ достаточно проблематично производить обновление конфигурации. В данной статье опишу свой опыт решения данной проблемы.

24.03.2015    28903    0    kondrat1C    20    

Выделение одной организации из Бухгалтерии редакция 3 через РИБ

Распределенная БД (УРИБ, УРБД) v8 БП2.0 Россия Бесплатно (free)

Выделение одной организации из Бухгалтерии редакция 3 через РИБ (например, 3.0.36.16) может привести к большим проблемам с последующими обновлением.

16.02.2015    15064    0    shevelyov    4    

Перенос данных из семерки по частям

Перенос данных из 1С7.7 в 1C8.X v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

При переносе баз из семерки в восьмерку, если база данных достаточно большая, может возникнуть ошибка «msxml3.dll: Недостаточно памяти для завершения операции». В этом случае советуют переносить данные по частям. Но возможности выгрузки по частям в стандартной обработке сильно ограничены: можно выгрузить отдельно справочники, остатки на начало года, обороты, документы. Обычно такая выгрузка по частям не исправляет ситуацию, т.к. основной объем данных сосредоточен обычно в одном справочнике, значит нужно выгружать отдельно этот справочник, мало того, может понадобиться его выгружать в несколько этапов. Попытаюсь описать метод решения, который использую в таких случаях.

01.01.2015    27022    0    32ops    5    

Обмен с помощью WMI

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Бесплатно (free)

Полный контроль над процессом, осуществляемый из единого центра.

10.11.2014    10259    0    loekyn    7    

Обмены данными и РИБ с использованием облачных сервисов

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Бесплатно (free)

Проверенный на практике, простой и доступный способ настройки обменов данными без использования FTP и встроенного почтового клиента.

22.10.2014    19221    0    rarename    14    

Реализация обмена по организации в УТ

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Бесплатно (free)

В связи с открытием филиала в другом городе возникла необходимость организации учета в конфигурации "Управление торговлей для Казахстана, ред. 3" (адаптированный аналог "Управление торговлей, ред. 11"). Как оказалось встроенного обмена по организации не оказалось, есть только "Полный". Пришлось реализовывать самому. Конечно был вариант работы через терминальное подключение и тонкий клиент, но в связи во-первых неустойчивыми каналами связи и с заделкой на будущее (большие объемы данных) решил сделать РИБ. И вот об этом моя первая статья, может поможет кому нибудь.

05.06.2014    15362    0    Bajo    5    

РИБ для УНФ

Распределенная БД (УРИБ, УРБД) v8 УНФ Россия Бесплатно (free)

Штатного механизма типового полного обмена (РИБ) нет. Добавляем этот функционал. Данный способ подойдет для типового релиза УНФ начиная с версии 1.4.7.37 или для конфигураций на основе БСП.

10.01.2014    29586    0    ZhAmAn    28    

Получение в 1С82 списка баз 1С77 на сервере (управляемые формы)

Перенос данных из 1С7.7 в 1C8.X v8 Бесплатно (free)

Получение в 1С82 списка баз 1С77 на сервере (управляемые формы) для подключения к 1С77 через OLE.

23.12.2013    7887    0    sdf1979    3    

Интерактивный счетчик объектов обмена

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Бесплатно (free)

При обменах на периферийных базах счетчик обмена сделан не очень красиво – он зависает на 10% и вся загрузка не отображается на счетчике. Предлагаю методику, чтобы визуализировать прогресс загрузки/выгрузки.

16.08.2013    17095    0    fixin    3    

Параллельность выгрузок

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Бесплатно (free)

Рассказываю свой опыт, как добился параллельности выгрузки из центральной базы РИБ сразу в 70 узлов.

15.08.2013    24505    0    fixin    41    

Случай из практики: об одной нетривиальной ситуации при обмене УНФ-БП

Перенос данных из 1С7.7 в 1C8.X v8 1cv8.cf Бесплатно (free)

Работал себе обмен между УНФ и БП, а потом как-то засбоил - то проходит, то не проходит. О том, что это было...

11.07.2013    9704    0    uncle_o    10    

Удаление объекта в узле обмена по обмену данными

Перенос данных из 1С7.7 в 1C8.X v8 1cv8.cf Бесплатно (free)

Варианты удаления объектов на удаленном узле при обмене данными.

05.06.2013    32513    0    kosmo0    2